When you reset Lightroom's preferences, the name and location of the current catalog is reset. When you start Lightroom after resetting your preferences, locate the appropriate catalog. Otherwise some or all of your images will be missing.

Save your catalog information before you reset preferences

Write down the name and location of your current catalog before you reset your preferences. In Lightroom, choose Edit > Catalog Settings > General (Windows) or Lightroom > Catalog Settings > General (Mac OS). Your catalog name and location are listed in the Information section. You can also click the Show button to go to the catalog in Explorer (Windows) or Finder (Mac OS). Before you reset your preferences, write down the current catalog's location and name.

Reset your preferences

To reset your preferences, do the following:

  1. Quit Lightroom.
  2. Navigate to the preferences file: 
    • Windows 7, 8: C:\Users\[user name]\AppData\Roaming\Adobe\Lightroom\Preferences\Lightroom 5 Preferences.agprefs
    • Mac OS: /Users/[user name]/Library/Preferences/com.adobe.Lightroom5.plist
  3. Drag the preferences file to the Recycle Bin (Windows) or Trash (Mac OS).

Important (Mac OS): The user Library file is hidden by default on Mac OS X 10.7 and later. For temporary access to the user Library file, press Option and choose Go > Library in the Finder.

Important (Windows): The AppData folder is hidden by default. To view it, choose Start > Control Panel > Appearance and Personalization > Folder Options. In the Advanced area of the View tab, make sure that Show Hidden Files and Folders is selected. Then click OK.

For the location of preferences files in earlier versions of Lightroom, see:

Get your correct catalog back

When you start Lightroom after resetting preferences, Lightroom might ask you to upgrade your catalog. Follow these steps to get your correct catalog back.

  1. If you've been working in a catalog, do not choose Upgrade. Instead, click Choose a Different Catalog

    Note: Choosing Upgrade converts the catalog you used in your previous version of Lightroom to the current version of Lightroom. You probably already did this step when you installed the most recent version of Lightroom. Doing it again doesn't display your current photos, and many files could be missing.

    The Choose a Different Catalog button
  2. The next dialog box that appears lists the catalogs that Lightroom sees initially. If your catalog is not on this list, click Choose A Different Catalog.

    Make sure that you don't choose a catalog here that is not your actual catalog. If you do, you could see differences in the images in the catalog and the edits to some of the images, and missing photos.

    Note: The catalogs you see listed could have different names from what is shown below.

    The Choose a Different Catalog button
  3. In the Explorer (Windows) or Finder (Mac OS) window that appears, navigate to the location in which you saved your current catalog. Select that catalog and click Choose.

  4. The catalog you chose is added to the Lightroom Select Catalog window, at the top of the list. Select that catalog, and click Open.

    Select the catalog
  5. If you always want to use this catalog, select the Always load this catalog on startup check box. It's probably best to select Test integrity of this catalog also.

    Select the Always load this catalog on startup checkbox

Locate and verify your catalog

If you skipped the first section of this document (Save your catalog information before you reset preferences) and don't know the name of your catalog or where it is located, try the following:

  1. Look in the default location: 
    • Windows: C:\Users\[user name]\Pictures\Lightroom\
    • Mac OS: /Users/[user name]/Pictures/Lightroom/
  2. Search your hard drive for files ending in *.lrcat or lrcat to find all your catalogs. When you get the list, select one, right-click, and choose Properties (Windows), or select one and choose File > Get Info (Mac OS). You see the file location and information about when it was last modified to help determine which catalog you've been working with.
  3. You might need to open several catalogs to determine which is the correct, most recent one. If you have many catalogs, keep careful notes on what catalogs you opened, where they're located, and any other details necessary to compare them.
  4. You probably have many catalogs on your computer that were created when you backed up your catalog. Be careful that you don't open and start using one of these catalogs instead of your actual, most current catalog. By default, backed-up catalogs are located in C:\Users\[user name]\Pictures\Lightroom\Lightroom <version> Catalog\Backups\ (Windows) or /Users/[user name]/Pictures/Lightroom/Lightroom <version> Catalog/Backups/ (Mac OS). However, if you change the location when you run a backup, they could be in other locations instead.

Look for these things to help you determine which catalog to use from now on:

  • Are there unexpected missing files?
  • Are the most recently added files correct?
  • Are all your collections and keywords available?

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy