Atlasiet slāņus panelī Timeline un atlasiet Layer > Pre-compose vai nospiediet Ctrl+Shift+C (Windows) vai Command+Shift+C (macOS).
Ja vēlaties grupēt slāņus, kas jau ir kompozīcijā, varat tos priekškomponēt.Slāņu priekškomponēšana tos ievieto jaunā kompozīcijā, kas aizstāj slāņus sākotnējā kompozīcijā.Jaunā ligzdotā kompozīcija kļūst par avotu vienam slānim sākotnējā kompozīcijā.Jaunā kompozīcija parādās panelī Project un ir pieejama renderēšanai vai izmantošanai jebkurā citā kompozīcijā.Varat ligzdot kompozīcijas, pievienojot esošu kompozīciju citai kompozīcijai, tāpat kā pievienotu jebkuru citu materiāla vienību kompozīcijai.Viena slāņa priekškomponēšana ir noderīga, lai slānim pievienotu transformācijas rekvizītus un ietekmētu kārtību, kādā tiek renderēti kompozīcijas elementi.
Ligzdošana ir vienas kompozīcijas iekļaušana citā.Ligzdotā kompozīcija parādās kā slānis kompozīcijā, kurā tā ietverta.
Ligzdotu kompozīciju dažkārt sauc par priekškompozīciju, ko sarunvalodā dažreiz saīsina kā precomp vai pre-comp.Kad priekškompozīcija tiek izmantota kā avota materiāla vienība slānim, šo slāni sauc par priekškompozīcijas slāni.
Renderēšanas laikā var sacīt, ka attēla dati un cita informācija plūst no katras ligzdotās kompozīcijas kompozīcijā, kurā tā ietverta.Šī iemesla dēļ par ligzdotajām kompozīcijām dažkārt tiek sacīts, ka tās atrodas augšpus kompozīcijām, kurās tās ir ietvertas, savukārt kompozīcijas, kas tās ietver, tiek sauktas par tādām, kas atrodas lejpus ligzdotajām kompozīcijām, ko tās ietver.Kompozīciju kopumu, kas savienots, izmantojot ligzdošanu, sauc par kompozīciju tīklu.Kompozīciju tīklā var pārvietoties, izmantojot Composition Navigator un Mini-Flowchart.Uzziniet vairāk par ligzdotu kompozīciju atvēršanu un pārvietošanos tajās.
Priekškompozīcijas programmā After Effects ir līdzīgas Smart Objects programmā Adobe Photoshop.
Priekškomponēšana un ligzdošana palīdz pārvaldīt un organizēt sarežģītas kompozīcijas.Izmantojot priekškomponēšanu un ligzdošanu, var veikt šādas darbības:
- Lietojiet sarežģītas izmaiņas visai kompozīcijai: var izveidot kompozīciju, kas satur vairākus slāņus, ligzdot šo kompozīciju vispārējā kompozīcijā un animēt, kā arī lietot efektus ligzdotajai kompozīcijai, lai visi slāņi vienādā veidā mainītos vienā un tajā pašā laika periodā.
- Atkārtoti izmantojiet visu, ko izveidojat: Animāciju varat izveidot atsevišķā kompozīcijā un pēc tam vilkt šo kompozīciju citās kompozīcijās tik reižu, cik vēlaties.
- Atjauniniet vienā darbībā: Veicot izmaiņas ligzdotā kompozīcijā, šīs izmaiņas ietekmē katru kompozīciju, kurā tā tiek izmantota, tāpat kā izmaiņas avota materiāla vienumā ietekmē katru kompozīciju, kurā tas tiek izmantots.
- Mainiet slāņa noklusējuma renderēšanas secību: Varat norādīt, lai After Effects transformāciju (piemēram, pagriešanu) renderē pirms efektu renderēšanas, lai efekts tiktu lietots pagrieztajam materiālam.
- Pievienojiet slānim vēl vienu transformācijas rekvizītu kopu: Kompozīciju attēlojošajam slānim ir savi rekvizīti papildus to slāņu rekvizītiem, ko tas satur. Tas ļauj slānim vai slāņu kopai lietot papildu transformāciju kopu.
Tā kā prekompozīcija pati par sevi ir slānis, tās darbību varat kontrolēt, izmantojot slāņu slēdžus un kompozīcijas slēdžus panelī Timeline.Varat izvēlēties, vai izmaiņas, kas veiktas ietverošās kompozīcijas slēdžos, tiek pārnestas uz ligzdoto kompozīciju. Lai nepieļautu, ka slāņu slēdži ietekmē ligzdotās kompozīcijas, atlasiet Edit > Preferences > Composition (Windows) vai After Effects > Settings > Composition (macOS) un pēc tam notīriet izvēli Switches Affect Nested Comps.
Dialoglodziņa Composition Settings cilnē Advanced (Composition > Composition Settings) kompozīcijai atlasiet Preserve resolution when nested vai Preserve frame rate when nested or in render queue, lai tā saglabātu savu izšķirtspēju vai kadru nomaiņas ātrumu un nepārņemtu šos iestatījumus no ietverošās kompozīcijas.Piemēram, ja apzināti izmantojāt zemu kadru nomaiņas ātrumu kompozīcijā, lai izveidotu saraustītu, ar roku animētu rezultātu, ligzdojot šo kompozīciju, tai jāsaglabā kadru nomaiņas ātrums. Līdzīgi arī rotoskopēšanas rezultāti var izskatīties nepareizi, ja tie tiek pārveidoti uz citu kadru nomaiņas ātrumu vai izšķirtspēju. Izmantojiet šo iestatījumu efekta Posterize Time vietā, jo tas ir mazāk efektīvs.
Mainot pašreizējo laiku vienā panelī, pašreizējais laiks tiek atjaunināts arī citos paneļos, kas saistīti ar šo kompozīciju. Pēc noklusējuma pašreizējais laiks tiek atjaunināts arī visām kompozīcijām, kas saistītas ar pašreizējo kompozīciju ar ligzdošanu. Lai nepieļautu, ka ar ligzdošanu saistītās kompozīcijas atjaunina savu pašreizējo laiku, kad vienā kompozīcijā maināt pašreizējo laiku, notīriet iestatījuma Synchronize Time Of All Related Items izvēli (Edit > Preferences > Composition (Windows) vai After Effects > Settings > Composition (macOS)).
Iepriekšēja komponēšana ievieto slāņus jaunā kompozīcijā, ko bieži dēvē par precomposition vai precomp. Ar šo darbību sākotnējā kompozīcijā atlasītie slāņi tiek aizstāti ar vienu slāni, kas attēlo jauno priekškompozīciju.Viena slāņa iepriekšēja komponēšana ir noderīga, lai slānim pievienotu transformācijas rekvizītus un ietekmētu secību, kādā tiek renderēti kompozīcijas elementi.
Atstāt visus atribūtus
Atstāj iepriekšēji komponētā slāņa rekvizītus un atslēgkadrus sākotnējā kompozīcijā, lietojot tos jaunajam slānim, kas attēlo iepriekšējo kompozīciju. Jaunās kompozīcijas kadra izmērs ir tāds pats kā atlasītā slāņa izmērs. Šī opcija nav pieejama, ja atlasāt vairāk nekā vienu slāni, teksta slāni vai formas slāni.
Pārvietojiet visus atribūtus uz jauno kompozīciju
Pārvieto iepriekš kompozicionēto slāņu rekvizītus un atslēgkadrus par vienu līmeni tālāk no saknes kompozīcijas kompozīciju hierarhijā. Ja izmantojat šo opciju, slāņu īpašībās veiktās izmaiņas paliek pie atsevišķajiem slāņiem priekšskompozīcijā.Jaunās kompozīcijas kadra lielums ir tāds pats kā sākotnējās kompozīcijas kadra lielums.
Efekti, kuros kā ievade tiek izmantoti slāņi, piemēram, Set Matte un Displacement Map, ir vērsti uz ievades slāņa maskām un efektiem. Šos slāņus var izmantot bez iepriekšējas prekompozīcijas, lai uz tiem varētu atsaukties efekts.
Vadīkla ir līdzīga funkcijai izvēlnē View, kas atrodas skatītāja paneļa Layer apakšdaļā un ļauj renderēt slāni no dažādām pozīcijām renderēšanas secībā — no tā avota, no tā maskām vai no tā atsevišķajiem efektiem.
Efektiem ar slāņu rekvizītiem atveriet izvēlni Input Parameter, kas atrodas pa labi no slāņa atlases, un izvēlieties mērķa ievades slāni, piemēram:
- Source: mērķē tikai uz slāņa avotu. Maskas un efekti tiek ignorēti.
- Masks: mērķē uz slāni pēc tā masku lietošanas. Efekti tiek ignorēti.
- Effects & Masks: mērķē uz slāni pēc tā masku un efektu lietošanas.
Ligzdotās kompozīcijas dažkārt tiek dēvētas par esošām augšupplūsmā attiecībā pret kompozīcijām, kurās tās ir ietvertas, savukārt ietverošās kompozīcijas tiek sauktas par esošām lejupplūsmā attiecībā pret tajās ietvertajām ligzdotajām kompozīcijām. Saknes kompozīcija ir vistālāk lejupplūsmā — visdziļāk ligzdotā kompozīcija ir vistālāk augšupplūsmā. Kompozīcijas plūsmas ceļš ir kompozīciju ķēde, kas ir savstarpēji saistītas, vienai ietverot citu vai atrodoties citā ligzdoti. Kompozīciju tīkls ir viss kompozīciju kopums, kas ir savstarpēji saistītas ar ligzdošanu.
After Effects nodrošina vairākus veidus, kā atvērt ligzdotu kompozīciju (iepriekšēju kompozīciju):
- Veiciet dubultklikšķi uz kompozīcijas ieraksta panelī Project.
- Veiciet dubultklikšķi uz iepriekšējās kompozīcijas slāņa panelī Timeline. Alt-dubultklikšķis (Windows) vai Option-dubultklikšķis (macOS), lai atvērtu iepriekšējās kompozīcijas slāni kā slāni panelī Layer.
Veicot dubultklikšķi uz iepriekšējās kompozīcijas slāņa, kad ir aktīvs kāds krāsošanas rīks vai rīks Roto Brush, slānis tiek atvērts panelī Layer.
Lai atvērtu pēdējo aktīvo kompozīciju tajā pašā kompozīciju tīklā, kurā ietilpst pašlaik aktīvā kompozīcija, izmantojiet taustiņu Shift+Esc.
Izmantojiet Composition Navigator.
Izmantojiet Composition Mini-Flowchart.
Composition Navigator ir josla panela Composition augšdaļā, kas parāda attiecīgajā skatītājā aktīvo kompozīciju attiecībā pret citām kompozīcijām tajā pašā kompozīciju tīklā. Redzamās kompozīcijas ir pēdējās aktīvās kompozīcijas pašlaik aktīvās kompozīcijas plūsmas ceļā.
A. Bulta Composition Mini-Flowchart atvēršanai B. Paneļa izvēlnes poga C. Aktīvā (pašreizējā) kompozīcija
Bultas starp kompozīciju nosaukumiem norāda virzienu, kādā šajā plūsmas ceļā plūst pikseļu informācija. Pēc noklusējuma kompozīcijas Composition Navigator joslā tiek rādītas tā, ka lejupplūsmas kompozīcijas ir kreisajā pusē, bet augšupplūsmas kompozīcijas — labajā pusē. Šis noklusējums ir norādīts ar opciju Flow Right To Left paneļa Composition izvēlnē. Lai parādītu kompozīcijas citā secībā, izvēlieties Flow Left To Right. Šis iestatījums ir globāla preference — tas attiecas uz visām kompozīcijām un Composition Mini-Flowchart skatu.
Lejupplūsmas kompozīciju nosaukumi ir aptumšoti, norādot, ka to saturs netiek izmantots vai rādīts aktīvajā kompozīcijā.
Lai parādītu vai paslēptu Composition Navigator joslu, paneļa Composition izvēlnē atlasiet Show Composition Navigator.
Lai aktivizētu jebkuru Composition Navigator joslā redzamo kompozīciju, atlasiet kompozīcijas nosaukumu.
Ja plūsmas ceļš ir pārāk garš, lai to parādītu panelī Composition, Composition Navigator joslas kreisajā vai labajā malā parādās elipses
poga. Lai īslaicīgi parādītu visu plūsmas ceļu, atlasiet pogu ar elipsi.
Lai ritinātu garu plūsmas ceļu, novietojiet rādītāju virs kompozīcijas pogas Composition Navigator joslā un ritiniet peles ritenīti.
Composition Mini-Flowchart ir pārejoša vadīkla, ko var izmantot, lai ātri pārvietotos kompozīciju tīklā. Atverot Composition Mini-Flowchart, tiek parādītas kompozīcijas, kas atrodas tieši pirms un pēc atlasītās kompozīcijas.
Krāsas Composition Mini-Flowchart pamatojas uz etiķešu krāsām, kas piešķirtas kompozīcijām panelī Project.Ja kompozīcija vienā kompozīcijā tiek izmantota vairākas reizes, iekļautās kompozīcijas vairākie gadījumi tiek parādīti kā viens ieraksts ar skaitli iekavās, kas norāda gadījumu skaitu.
Lai atvērtu Composition Mini-Flowchart, veiciet kādu no šīm darbībām:
A. Indikators, kas norāda, ka kompozīcija neieplūst citās kompozīcijās B. Plūsmas virziens C. Aktīvā (pašreizējā) kompozīcija
- Izmantojiet taustiņu Tab, kad aktīvs ir panelis Composition, Layer vai Timeline.
Atlasiet bultu pa labi no kompozīcijas nosaukuma joslā Composition Navigator.
Atlasiet Composition Mini-Flowchart izvēlnē Composition, paneļa Composition izvēlnē vai paneļa Timeline izvēlnē.
Atlasiet pogu Composition Mini-Flowchart paneļa Timeline augšdaļā.
Tāpat kā Composition Navigator gadījumā, var izvēlēties, vai plūsmas virzienu rādīt no kreisās uz labo pusi vai no labās uz kreiso pusi. Bultas norāda plūsmas virzienu. Ja kompozīcijai blakus ir
nevis bulta, tad kompozīcijā neieplūst nekādas kompozīcijas vai tā pati neieplūst nevienā kompozīcijā.
Composition Mini-Flowchart augšupējās kompozīcijas ir sakārtotas no augšas uz leju alfabētiskā secībā vai pēc slāņu kārtības.Lai pārslēgtos starp šīm kārtošanas sistēmām, nospiediet taustiņu S, kad Composition Mini-Flowchart ir atvērts. Kārtojot pēc slāņu kārtības, kompozīcija, kas izmantota vairākas reizes, tiek kārtota atbilstoši tās augstākajam gadījumam sakārtošanas secībā. Pēc atlasītās kompozīcijas esošās kompozīcijas vienmēr tiek kārtotas pēc alfabēta.
Lai pārvietotos starp kompozīcijām un atlasītu tās Composition Mini-Flowchart, izmantojiet bulttaustiņus vai atlasiet bultu vai pogas
abās kompozīcijas malās. Lai aktivizētu atlasīto kompozīciju, izmantojiet atstarpes taustiņu vai taustiņu Enter (Windows) vai taustiņu Return (macOS). Lai aizvērtu Composition Mini-Flowchart bez jebkādas darbības veikšanas, izmantojiet taustiņu Esc, Shift vai atlasiet ārpus Composition Mini-Flowchart.
Sarežģītas ievietotas kompozīcijas renderēšana — gan priekšskatījumiem, gan galīgajai izejai — var prasīt ilgu laiku. Ja ir ievietota kompozīcija, ar kuru nav paredzēts strādāt turpmāk, var ietaupīt laiku katras renderēšanas operācijas laikā, priekšrenderējot ievietoto kompozīciju filmā un aizstājot kompozīciju ar renderēto filmu. Oriģinālo ievietoto kompozīciju tomēr var pārveidot, jo tā paliek panelī Projekts. Ja oriģinālajā ievietotajā kompozīcijā tiek veiktas nozīmīgas izmaiņas, renderējiet to vēlreiz.
Ievietotas kompozīcijas priekšrenderēšana ir īpaši noderīga, ja tā projektā tiek izmantota vairākkārt.
Pielietojiet galīgās izejas iestatījumus, kad priekšrenderējat ievietoto kompozīciju.
Atlasiet kompozīciju panelī Projekts vai Kompozīcija.
Atlasiet Kompozīcija > Priekšrenderēšana.
Komanda Priekšrenderēšana pievieno kompozīciju renderēšanas rindai un iestata pēcrenderēšanas darbību Importēt un aizstāt lietojumu, lai aizstātu kompozīciju ar renderēto filmu.
Panelī Renderēšanas rinda pielāgojiet iestatījumus pēc nepieciešamības un noklikšķiniet uz pogas Renderēt, lai renderētu kompozīciju.
Alternatīva kompozīcijas aizstāšanai ar filmu ir izmantot renderēto filmu kā aizstājēju ievietotajai kompozīcijai.
Kompozīcija veidojas no slāņiem, kas sakrauti cits uz cita panelī Laika skala. Kad kompozīcija tiek renderēta — gan priekšskatīšanai, gan galīgajai izejai — vispirms tiek renderēts zemākais slānis. Katrā rastra (nevektora) slānī elementi tiek piemēroti šādā secībā: maskas, efekti, pārveidojumi un slāņa stili.Nepārtraukti rastrētiem vektoru slāņiem noklusējuma renderēšanas secība ir maskas, pēc tam pārveidojumi un efekti.
Pārveidojumi ir izmaiņas tajās īpašībās, kas apkopotas kategorijā Pārveidot panelī Laika skala, tostarp Enkurpunkts, Pozīcija, Mērogs, Pagrieziens un Opacitāte. Tas, ko redzat panelī Slānis, ir renderēšanas rezultāts pirms pārveidojumu veikšanas.
Lai papildus kontrolētu, kad tiek veikti pārveidojumi, var pielietot efektu Pārveidot un pārkārtot to attiecībā pret citiem efektiem.
Efektu vai masku grupā vienumi tiek apstrādāti no augšas uz leju. Piemēram, ja tiek pielietots efekts Aplis un pēc tam efekts Palielināt, aplis tiek palielināts. Tomēr, ja efekts Palielināt tiek pārvietots virs (pirms) efekta Aplis panelī Efektu vadīklas vai Laika skala, aplis tiek zīmēts pēc palielināšanas un netiek palielināts.
Pēc tam, kad slānis ir renderēts, sākas nākamā slāņa renderēšana. Zemāk renderēto slāni var izmantot kā ievaddatus augstāk esošā slāņa renderēšanai — piemēram, lai noteiktu sapludināšanas režīma rezultātu.
Ja kompozīcijā ir ietvertas citas ligzdotas kompozīcijas, ligzdotā kompozīcija tiek renderēta pirms citiem slāņiem saturošajā kompozīcijā.
Daži efekti ignorē maskas slānī, kuram tie tiek lietoti. Lai šāds efekts darbotos uz maskota slāņa, veidojiet slāņa pirmskompozīciju ar lietoto masku un pēc tam lietojiet efektu pirmskomponētajam slānim.
Transformāciju sakļaušana
Ja ligzdotajai kompozīcijai ir atlasīts slēdzis Sakļaut transformācijas , tad ligzdotās kompozīcijas transformācijas netiek veiktas, kamēr nav renderētas saturošās kompozīcijas maskas un efekti.Šāda renderēšanas secība ļauj ligzdotās kompozīcijas un kompozīcijas, kurā tā ietverta, transformācijas kombinēt — vai sakļaut — un veikt kopā. Tas pats attiecas uz vektoru slāņiem, kas nav nepārtraukti rastrēti.
Tā vietā, lai izmantotu slēdzi Sakļaut transformācijas, vektoru slāņiem tajā pašā vietā ir slēdzis Nepārtraukti rastrēt. Vektoru slāņi ietver formu slāņus, teksta slāņus un slāņus, kuru avota materiāls ir vektora grafikas faili. Teksta slāņi un formu slāņi vienmēr tiek nepārtraukti rastrēti.
Transformāciju sakļaušana, piemēram, var saglabāt izšķirtspēju, ja slānis ligzdotajā kompozīcijā tiek samazināts par pusi un ligzdotā kompozīcija kompozīcijā, kurā tā ietverta, tiek palielināta divas reizes. Šajā gadījumā, tā vietā, lai veiktu abas transformācijas un zaudētu attēla datus, var veikt vienu transformāciju — kas faktiski neko nemaina, jo atsevišķās transformācijas viena otru izlīdzsvaro.
Ja transformācijas netiek sakļautas, ligzdotā kompozīcija, kas satur 3D slāņus, tiek renderēta kā 3D izkārtojuma 2D attēls, izmantojot kompozīcijas noklusējuma kameru. Šāda renderēšana neļauj ligzdotajai kompozīcijai krustoties ar 3D slāņiem, radīt ēnas uz 3D slāņiem un saņemt ēnas no 3D slāņiem kompozīcijā, kurā tā ietverta. Ligzdoto kompozīciju arī nevada kompozīcijas, kurā tā ietverta, kameras un apgaismojums.
Ja transformācijas tiek sakļautas, ligzdotās kompozīcijas slāņu 3D īpašības tiek atklātas kompozīcijai, kurā tā ietverta. Tādējādi ligzdotā kompozīcija var krustoties ar 3D slāņiem, radīt ēnas uz 3D slāņiem un saņemt ēnas no 3D slāņiem kompozīcijā, kurā tā ietverta. Kamera un apgaismojums var kontrolēt arī kompozīcijas ligzdoto kompozīciju.
Būtībā transformāciju sakļaušana ligzdotajai kompozīcijai liek After Effects neizlīdzināt un neapgriezt kompozīcijas slāņus. Tā kā pielāgošanas slānis darbojas ar visu zem tā esošo slāņu kompozītu tajā pašā kompozīcijā, pielāgošanas slānis ligzdotajā kompozīcijā ar sakļautām transformācijām piespiedīs izlīdzināšanu un apgriešanu, ko transformāciju sakļaušana parasti novērstu.
Ja ligzdotajai kompozīcijai ar sakļautām transformācijām ir lietota slēgta maska (ar maskas režīmu, kas nav Nav), slāņa stils vai efekts, ligzdotās kompozīcijas slāņi vispirms tiek renderēti atsevišķi, pēc tam tiek lietotas maskas un efekti, un tad rezultāts tiek komponēts galvenajā kompozīcijā. Šāda renderēšanas secība nozīmē, ka ligzdoto slāņu sapludināšanas režīmi netiek lietoti nevienam zemāk esošajam slānim galvenajā kompozīcijā un ka 3D slāņi virs un zem sakļautā slāņa nevar krustoties vai veidot ēnas viens otram.
Create stunning 3D animations in After Effects
Animate characters and illustrations, add motion to text, and more.