Работа с импортированными растровыми изображениями

При импорте растрового изображения в Flash Professional можно изменить это растровое изображение и использовать его в документе Flash Professional различными способами.

Если документ Flash Professional отображает импортированное растровое изображение размером более оригинала, то изображение может быть искажено. Чтобы убедиться в корректности показа изображений, просмотрите импортированные изображения.

Если выбрать растровое изображение в рабочей области, то инспектор свойств показывает имя символа растрового изображения и его размеры в пикселах и положение в рабочей области. Используя инспектора свойств, можно заменить экземпляр растрового изображения, то есть заменить экземпляр экземпляром другого растрового изображения в текущем документе.

В следующем видеоруководстве описаны принципы использования растровых изображений в Flash Professional:

Отображение инспектора свойств со свойствами растрового изображения

  1. Выберите экземпляр растрового изображения в рабочей области.

  2. Выберите меню «Окно» > «Свойства».

Замена экземпляра растрового изображения экземпляром другого растрового изображения.

  1. Выберите экземпляр растрового изображения в рабочей области.

  2. Выберите пункт «Окно» > «Свойства» и нажмите кнопку «Заменить».

  3. Выберите растровое изображение, чтобы заменить текущее изображение, назначенное экземпляру.

Настройка свойств растровых изображений

Чтобы сгладить края изображения, можно применить сглаживание к импортированному растровому изображению. Можно также выбрать режим сжатия, чтобы уменьшить размер растрового файла и отформатировать файл для отображения в сети.

  1. Выберите растровое изображение на панели «Библиотека» и нажмите кнопку «Свойства» в нижней части панели «Библиотека».
  2. Выберите режим «Разрешить сглаживание». Смягчение повышает качество растровых изображений при масштабировании.
  3. В поле «Сжатие» выберите один из следующих параметров.

    Фото (JPEG)

    Сжимает изображение в формате JPEG. Чтобы использовать уровень сжатия по умолчанию, заданный для импортированного изображения, выберите параметр «Применить качество документа по умолчанию». Чтобы задать новый уровень сжатия, отмените параметр «Применить качество документа по умолчанию» и введите значение между 1 и 100 в текстовом поле «Качество». (Высокое значение обеспечивает более полную целостность изображения, но при этом увеличивается размер файла.)

    Без потери качества (PNG/GIF)

    Используется алгоритм без потери качества: изображение сжимается, но при этом никакие данные не удаляются из изображения.

    Примечание. Используйте метод сжатия «Фото» с потерями при наличии сложных цветовых или тональных изменений, таких как фотографии или изображения с градиентными заливками. Используйте сжатие без потери качества для изображений с простыми фигурами и относительно небольшим числом цветов.

  4. Чтобы определить результаты сжатия файла, нажмите кнопку «Тест». Чтобы определить приемлемость уровня сжатия, сравните размер оригинального файла с размером сжатого файла.
  5. Нажмите кнопку «ОК».

Примечание.

Параметры «Качество JPEG», выбранные в диалоговом окне «Параметры публикации», не задают параметры качества для импортированных JPEG-файлов. Задайте настройку качества для каждого импортированного JPEG-файла в диалоговом окне «Свойства растрового изображения».

(Только во Flash Professional CC) Замена нескольких растровых изображений

Команда «Заменить растровое изображение» позволяет заменять символы и растровые изображения другими выбранными символами или растровыми изображениями.

  1. Во Flash Pro CC выберите в рабочей области несколько растровых изображений.
  2. На панели «Свойства» нажмите «ЗАМЕНИТЬ».
  3. В диалоговом окне «Замена символа» выберите растровое изображение, которым требуется заменить все выбранные символы или растровые изображения.
  4. Нажмите кнопку «ОК».

Импорт растровых изображений во время работы

Чтобы добавить растровые изображения во время работы, используйте команду BitmapData сценария ActionScript® 2.0 или ActionScript 3.0. Для этого укажите идентификатор привязки для растрового изображения. Дополнительные сведения см. в разделе «Назначение привязки ресурсам библиотеки» в руководстве Изучение ActionScript 2.0 в Adobe Flash или «Экспорт библиотечных символов для ActionScript» в руководстве разработчика ActionScript 3.0.

  1. Выберите растровое изображение на панели «Библиотека».
  2. Выполните одно из следующих действий.
    • Выберите пункт «Связывание» в меню, всплывающем при щелчке в правом верхнем углу панели.

    • Выберите имя растрового изображения на панели «Библиотека», щелкнув правой кнопкой мыши (Windows) или удерживая нажатой клавишу «Control» (Macintosh), и выберите пункт «Свойства» из контекстного меню.

      Если свойства связывания невидимы в диалоговом окне «Свойства», то нажмите кнопку «Дополнительно».

  3. Для привязки выберите режим «Экспортировать для ActionScript».
  4. Введите строку идентификатора в текстовое поле и нажмите кнопку «ОК».

Применение растрового изображения как заливки

Чтобы применить растровое изображение как заливку для графического объекта, используйте панель «Цвет». При применении растрового изображения как заливки объект заполняется растровым изображением как фрагментами мозаики. Инструмент «Преобразование градиента» позволяет масштабировать, поворачивать и наклонять изображение и его растровую заливку.

  1. Чтобы применить заливку к существующей иллюстрации, выделите графический объект или объекты в рабочей области.
  2. Выберите пункт «Окно» > «Цвет».
  3. Выберите пункт «Битовое изображение» во всплывающем меню в верхнем правом углу панели.
  4. Чтобы увеличить окно просмотра для отображения большего числа растровых изображений в текущем документе, щелкните стрелку в нижнем правом углу, чтобы развернуть панель «Цвет».
  5. Щелкните растровое изображение, чтобы выделить его.

    Битовое изображение становится текущим цветом заливки. Если на этапе 1 была выбрана иллюстрация, то растровое изображение применяется как заливка для иллюстрации.

Редактирование растровых изображений во внешнем редакторе

Если редактируется PNG-файл Fireworks, импортированный как сведенное изображение, то редактируйте исходный PNG-файл для растрового изображения, если он есть.

Примечание.

Нельзя редактировать растровые изображения из PNG-файлов Fireworks, импортированные как редактируемые объекты во внешний редактор изображения.

Если в системе установлено приложение Fireworks 3 или более поздней версии либо другая программа редактирования изображений, то можно запустить эту программу из Flash Professional, чтобы отредактировать импортированное растровое изображение.

Редактирование растрового изображения в Photoshop CS5 или более поздней версии

Примечание.

Если вы работаете во Flash Pro CS5.5, необходимо использовать Photoshop CS5.1 для доступа к этой функции.

  1. На панели «Библиотека» щелкните правой кнопкой мыши (Windows) или нажмите клавишу Control и щелкните (Macintosh) значок растрового изображения и выберите пункт «Изменить в Photoshop CS5».

  2. Внесите нужные изменения в файл в программе Photoshop.

  3. В Photoshop выберите «Файл» > «Сохранить». (Не изменяйте имя файла или его формат.)

  4. Вернитесь в Flash Professional.

    Файл автоматически обновляется в Flash Professional.

Редактирование растрового изображения с использованием Fireworks 3 или более поздней версии

  1. На панели «Библиотека» выберите значок растрового изображения, щелкнув правой кнопкой мыши (Windows) или удерживая нажатой клавишу «Control» (Macintosh), и выберите пункт «Изменить с помощью Fireworks 3».

  2. Укажите, нужно ли открыть исходный PNG-файл или файл растрового изображения.

  3. Внесите нужные изменения в файл в программе Fireworks.

  4. В Fireworks выберите пункт «Файл» > «Обновить».

  5. Вернитесь в Flash Professional.

    Файл автоматически обновляется в Flash Professional.

Редактирование растрового изображения с использованием другой программы редактирования изображений

  1. На панели «Библиотека» выберите значок растрового изображения, щелкнув правой кнопкой мыши (Windows) или удерживая нажатой клавише «Control» (Macintosh), и выберите пункт «Изменить с помощью».

  2. Выберите программу редактирования изображений, в которой будет открыт растровый файл и нажмите кнопку «ОК».

  3. Внесите нужные изменения в файл в программе редактирования изображений.

  4. Сохраните файл в программе редактирования изображений.

    Файл автоматически обновляется в Flash Professional.

  5. Вернитесь в Flash Professional, чтобы продолжить редактирование документа.

Разделение растрового изображения и создания растровой заливки

При разбиении растрового изображения в рабочей области изображение извлекается из библиотеки и преобразуется из экземпляра растрового изображения в фигуру. Когда растровое изображение разбивается на части, его можно изменить с использованием инструментов рисования и раскраски Flash Professional. С помощью инструмента «Волшебная палочка» можно выбрать области растрового изображения с идентичной или схожей цветовой гаммой.

Чтобы раскрасить разбитое на части растровое изображение, выберите растровое изображение с использованием инструмента «Пипетка» и примените растровое изображение как заливку с помощью инструмента «Ведро с краской» или другого инструмента рисования.

Разбиение растрового изображения на части

  1. Выберите растровое изображение в текущем монтажном кадре.

  2. Выберите «Модификация» > «Разделить».

Изменение заливки областей разбитого на части растрового изображения

  1. На панели инструментов выберите инструмент «Волшебная палочка». Если инструмент «Волшебная палочка» не виден, щелкните инструмент «Лассо» и выберите из всплывающего меню пункт «Волшебная палочка». Установите следующие параметры в инспекторе свойств:

    • Для параметра «Порог» введите значение между 1 и 200, чтобы указать, насколько близко должны совпадать цвета смежных пикселов, включаемых в выделенную область. При указании более высокого значения будут выбраны пикселы из более широкого диапазона. Если ввести значение 0, то будут выбраны только пикселы точно такого же цвета, как первый пиксел, выделенный щелчком мыши.

    • В поле «Смягчение» выберите параметр, чтобы задать степень смягчения краев выделенной области.

  2. Чтобы выделить область, щелкните растровое изображение. Для добавления к выделенной области нажмите еще раз.

  3. Чтобы выполнить заливку выделенных областей в растровом изображении, выберите заливку для использования в элементе управления «Цвет заливки».

  4. Чтобы применить новую заливку, выберите инструмент «Ведро с краской» и щелкните мышью любое место выделенной области.

Преобразуйте растровое изображение в векторную графику

Команда «Векторизация» преобразует растровое изображение в векторную графику с редактируемыми раздельными цветовыми областями. Изображением можно манипулировать как векторной графикой и уменьшить размер файла.

При преобразовании растрового изображения в векторную графику векторная графика более не связана с символом растрового изображения на панели «Библиотека».

Примечание.

Если в импортированном растровом изображении содержатся сложные фигуры и множество цветов, то размер преобразованного файла векторной графики может быть больше, чем у исходного растрового изображения. Чтобы найти баланс между размером файла и качеством изображения, экспериментируйте с различными настройками в диалоговом окне «Векторизация».

Можно также разбить на части растровое изображение, чтобы изменить изображение в Flash Professional с использованием инструментов рисования и раскраски.

  1. Выберите растровое изображение в текущем монтажном кадре.

  2. Выберите пункт «Модификация» > «Растровое изображение» > «Векторизация».

  3. Введите значение параметра «Пороговое значение цвета».

    Если разница в цветовых значениях RGB двух сравниваемых пикселов меньше цветового порога, то считается, что эти два пиксела одного цвета. При увеличении значения порога число цветов уменьшается.

  4. Для параметра «Наименьший участок» введите значение, чтобы задать число окружающих пикселов, учитываемых при назначении цвета пикселу.

  5. Для параметра «Точность контура» выберите вариант, чтобы задать плавность обрисовки контуров.

  6. Для параметра «Пороговое значение угла» выберите вариант, чтобы указать, будут ли сохранены или смягчены резкие края.

    Чтобы создать векторную графику, которая выглядит наиболее похоже на исходное растровое изображение, введите следующие значения.

    • Пороговое значение цвета: 10

    • Наименьшая область: 1 пиксел

    • Подгонка кривой: Пикселы

    • Пороговое значение угла: Много углов

Использование инструмента «Пипетка», чтобы применить растровую заливку

  1. Выберите инструмент «Пипетка» и щелкните разбитое на части растровое изображение в рабочей области. Инструмент «Пипетка» задает растровое изображение как текущую заливку и изменяет активный инструмент на инструмент «Ведро с краской».

  2. Выполните одно из следующих действий.

    • Чтобы применить растровое изображение как заливку, щелкните существующий графический объект с помощью инструмента «Заливка».

    • Выберите инструмент «Овал», «Прямоугольник» или «Перо» и нарисуйте новый объект. Объект заливается разбитым на части растровым изображением.

      Используйте инструмент «Свободное трансформирование», чтобы масштабировать, поворачивать и наклонять растровую заливку.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет