นำเข้าไฟล์ SVG

อัปเดตครั้งล่าสุดเมื่อ 11 ก.ย. 2026

เรียนรู้วิธีนำเข้าไฟล์ SVG เป็นเลเยอร์รูปร่างในระบบที่แก้ไขได้และพร้อมสร้างแอนิเมชันโดยไม่ต้อง conversion

ดับเบิลคลิกภายในแผง Project หรือใช้ File > Import > File เพื่อเรียกดูและนำเข้าไฟล์ SVG

หมายเหตุ

After Effects เวอร์ชันล่าสุดช่วยให้นำเข้าไฟล์เป็นฟุตเทจหรือคอมโปซิชัน

ลากและปล่อยไฟล์ SVG ที่นำเข้าแล้วไปยังแผง Timeline

เลือกเลเยอร์เพื่อใช้ส่วน Layer Contents ในแผง Properties เพื่อดูโครงสร้างของ SVG

แผง Properties เปิดอยู่และภายใต้ Layer Contents จะแสดงรายการเนื้อหา SVG
ใช้แผง Properties เพื่อดูเนื้อหาไฟล์ SVG และปรับแต่งคุณสมบัติของมัน

คุณยังสามารถเลือกลูกศรถัดจากเลเยอร์เพื่อแผ่ออก แล้วขยายส่วน Contentsคุณจะเห็นองค์ประกอบแต่ละตัวและคุณสมบัติของมัน เช่น Path, Fill, และ Transform

เลเยอร์ที่มีไฟล์ SVG ถูกเลือกและส่วน Contents ถูกขยายเพื่อแสดงคุณสมบัติ รวมถึง Path, Fill, และ Transform
ขยายส่วน Contents ของเลเยอร์ SVG เพื่อเข้าถึงและแก้ไขคุณสมบัติ รวมถึง Path, Fill, และ Transform

คุณสามารถใช้คุณสมบัติเหล่านี้สร้างแอนิเมชันเช่นเดียวกับเลเยอร์รูปร่างอื่นๆตัวอย่าง:

  • สร้างแอนิเมชัน Path เพื่อสร้างเอฟเฟกต์การแปลงรูป
  • เปลี่ยนสีพื้นตามเวลาเพื่อการเปลี่ยนผ่านแบบไดนามิก
  • ใช้คุณสมบัติ Transform เพื่อปรับขนาด หมุน หรือเคลื่อนย้ายองค์ประกอบแยกกัน

หากเลเยอร์มีการไล่ระดับสีและการลากเส้น คุณสามารถใช้คุณสมบัติ Scale และ Rotation เพื่อสร้างแอนิเมชันการไล่ระดับสี

เลเยอร์หนึ่งที่มีองค์ประกอบการไล่ระดับสีถูกเลือก และ Gradient Fill 1 ถูกเน้น
ใช้คุณสมบัติ Gradient Fill เพื่อปรับการไล่ระดับสีหรือสร้างแอนิเมชัน

นำเข้าไฟล์ SVG เป็นฟุตเทจหรือเป็นคอมโปซิชัน

การนำเข้า SVG ใน After Effects มีความยืดหยุ่นและควบคุมได้ดีกว่าในการนำเข้าไฟล์ SVG ในโปรเจคของคุณด้วยเวอร์ชันล่าสุด เมื่อนำเข้าไฟล์ SVG สามารถเลือกนำเข้าเป็นฟุตเทจหรือเป็นคอมโปซิชันได้

นำเข้าเป็นฟุตเทจ

นำเข้าเป็นองค์ประกอบ

นำเข้า SVG เป็นเลเยอร์เวกเตอร์เดียวที่แรสเตอร์ได้อย่างต่อเนื่อง

นำเข้า SVG เป็นองค์ประกอบที่สร้างจากเลเยอร์รูปร่างที่แก้ไขได้

คงการเชื่อมต่อกับไฟล์ SVG ภายนอกไว้

แต่ละองค์ประกอบจะถูกแปลงเป็นรูปร่างที่แก้ไขได้ของตัวเอง

เหมาะสำหรับกราฟิกแบบเวกเตอร์แบบเลเยอร์เดียวเมื่อไม่จำเป็นต้องแยกงานศิลปะออกเป็นส่วนๆ

เหมาะสำหรับการแก้ไขเส้นพาธ รูปร่าง และรายละเอียดระดับเลเยอร์ เมื่อต้องการทำภาพเคลื่อนไหวให้กับแต่ละองค์ประกอบ

ควบคุมได้ว่าจะใช้วิธีนำเข้าแบบใดเป็นค่าเริ่มต้นเมื่อนำเข้าไฟล์ SVG โดยตั้งค่าตัวเลือก Drag Multiple File Items As ในการกำหนดลักษณะ Import

  • macOS: After Effects > การตั้งค่า > Import > Drag Multiple File Items As
  • Windows: การแก้ไข > การกำหนดลักษณะ > Import > Drag Multiple File Items As
กล่องโต้ตอบการกำหนดลักษณะเปิดอยู่ ในแท็บ Import เมนูดรอปดาวน์ Drag Multiple File Items As เปิดอยู่ โดยมีตัวเลือกสำหรับเลือกวิธีนำเข้า
กำหนดค่ากำหนดลักษณะเริ่มต้นสำหรับการนำเข้าไฟล์ SVG โดยเลือกว่าจะนำเข้าเป็นฟุตเทจหรือเป็นองค์ประกอบ

ดับเบิลคลิกภายในแผง Project หรือใช้ File > Import > File เพื่อเรียกดูและนำเข้าไฟล์ SVG

ใช้เมนูดรอปดาวน์ Import As ในกล่องโต้ตอบ Import file เพื่อเลือกอย่างใดอย่างหนึ่งต่อไปนี้:

  • ฟุตเทจ
  • องค์ประกอบ - คงขนาดเลเยอร์ไว้

การเลือก Footage จะนำเข้าไฟล์เป็นเลเยอร์แบบแบนรวมชั้นเดียวโดยไม่สามารถเข้าถึงแต่ละองค์ประกอบได้ จึงเหมาะสำหรับการใช้งานแบบคงที่หรือเมื่อไม่ต้องทำภาพเคลื่อนไหวการเลือก Composition – Retain Layer Sizes จะสร้างองค์ประกอบใหม่ โดยนำเข้าแต่ละเลเยอร์ต้นฉบับแยกกัน และกำหนดขนาดตามเนื้อหาจริง ทำให้จุดยึดเป็นระเบียบมากขึ้นและการแปลงทำได้ง่ายขึ้นสำหรับการทำภาพเคลื่อนไหว

macOS

กล่องโต้ตอบ Import file เปิดอยู่ และมีตัวเลือกให้นำเข้าไฟล์เป็นฟุตเทจหรือเป็นองค์ประกอบ

Windows

กล่องโต้ตอบ Import file เปิดอยู่ และมีตัวเลือกให้นำเข้าไฟล์เป็นฟุตเทจหรือเป็นองค์ประกอบ

เลือกตัวเลือกต่อไปนี้ตามต้องการ:

  • Create Composition: สร้างองค์ประกอบใหม่โดยใช้การตั้งค่าเริ่มต้น และวาง SVG ที่นำเข้าโดยอัตโนมัติลงในไทม์ไลน์ ไม่ว่าจะนำเข้าเป็นฟุตเทจหรือเป็นองค์ประกอบที่มีเลเยอร์รูปร่าง ช่วยลดขั้นตอนการสร้างองค์ประกอบด้วยตัวเองและลากไฟล์ SVG เข้าไป
  • Scalable Vector Graphics Sequence: นำเข้าไฟล์ SVG ที่มีหมายเลขกำกับหลายไฟล์ และจัดการเป็นลำดับรูปภาพเวกเตอร์แบบทีละเฟรม

ใช้ส่วน เนื้อหาของเลเยอร์ ในแผง คุณสมบัติ หรือส่วน เนื้อหา ของเลเยอร์ในไทม์ไลน์เพื่อดูและทำงานกับองค์ประกอบแต่ละรายการและคุณสมบัติขององค์ประกอบนั้นได้ หากนำเข้าไฟล์ SVG เป็น composition หากนำเข้าเป็นฟุตเทจ ระบบจะทำงานเหมือนเลเยอร์ปกติและปรับได้ด้วยคุณสมบัติ แปลง มาตรฐาน

เช่นเดียวกับไฟล์ Illustrator หากนำเข้าไฟล์เวกเตอร์เป็นฟุตเทจ ก็สามารถเลือกเลเยอร์ในไทม์ไลน์ จากนั้นคลิกขวาแล้วเลือก สร้าง > สร้างรูปร่างและข้อความจากเลเยอร์เวกเตอร์ เพื่อแปลงเป็นเลเยอร์ที่แก้ไขได้ ทำให้สร้างภาพเคลื่อนไหวให้กับพาธ การลากเส้น และการเติมแต่ละรายการได้ ใน After Effects Beta เวอร์ชันล่าสุด ข้อความในไฟล์ต้นฉบับจะถูกแปลงเป็นเลเยอร์ข้อความที่แก้ไขได้ โดยยังคงแบบอักษร ขนาด การเติม ตำแหน่ง สไตล์ การลากเส้น และการตั้งค่าแบบอักษรผันแปรไว้ 

เมื่อนำเข้า SVG เป็นฟุตเทจ After Effects จะคงลิงก์แบบสดกับไฟล์ต้นฉบับไว้ ดังนั้นการเปลี่ยนแปลงใดๆ ที่ทำกับ SVG นั้นนอกแอปจะอัปเดตในโปรเจคโดยอัตโนมัติ

การแปลงข้อความ Illustrator เป็นเลเยอร์ข้อความที่แก้ไขได้

ใช้ฟีเจอร์ Beta ใหม่

ข้อความที่แก้ไขได้จากไฟล์ Illustrator พร้อมให้ทดสอบและส่งความคิดเห็นแล้ว ลองเลยใน After Effects (beta)

ใน After Effects Beta เวอร์ชันล่าสุด เมื่อนำเข้าเลเยอร์ Illustrator เป็นฟุตเทจ ข้อความใดๆ ในไฟล์ต้นฉบับจะถูกแปลงเป็นเลเยอร์ข้อความที่แก้ไขได้ของตัวเอง แทนที่จะถูกรวมเป็นเส้นขอบรูปร่างหมายความว่าแบบอักษร ขนาด การเติม ตำแหน่ง สไตล์ (เช่น ตัวหนาและตัวเอียง) การลากเส้น และการตั้งค่าแบบอักษรผันแปรจะถูกเก็บไว้ทั้งหมด จึงแก้ไขข้อความได้โดยตรงใน After Effects โดยไม่ต้องสร้างใหม่ตั้งแต่ต้นหรือกลับไปแก้ใน Illustrator

เลือก ไฟล์ > นำเข้า > ไฟล์ แล้วเลือกไฟล์ Illustrator ที่ต้องการนำเข้า

ในกล่องโต้ตอบ นำเข้าไฟล์ ตรวจสอบให้แน่ใจว่าได้ตั้งค่า นำเข้าเป็น เป็น ฟุตเทจ เมื่อเลือกไฟล์ที่จะนำเข้า

ในกล่องโต้ตอบการนำเข้า ให้ยืนยันว่าได้ตั้งค่า ชนิดการนำเข้า เป็น ฟุตเทจ และเลือก ตัวเลือกเลเยอร์ ตามสิ่งที่ต้องการนำเข้าจากไฟล์ Illustrator

ลากไฟล์ที่นำเข้าไปยังแผง ไทม์ไลน์

คลิกขวาที่เลเยอร์ Illustrator แล้วเลือก สร้าง > สร้างรูปร่างและข้อความจากเลเยอร์เวกเตอร์ หรือใช้ เลเยอร์ > สร้าง > สร้างรูปร่างและข้อความจากเลเยอร์เวกเตอร์

เมนูย่อย เลเยอร์ > สร้าง โดยไฮไลต์คำสั่ง สร้างรูปร่างและข้อความจากเลเยอร์เวกเตอร์ เพื่อแปลงข้อความเวกเตอร์เป็นเลเยอร์ข้อความที่แก้ไขได้
เลือก สร้างรูปร่างและข้อความจากเลเยอร์เวกเตอร์ เพื่อแปลงข้อความ Illustrator เป็นเลเยอร์ข้อความ After Effects ที่แก้ไขได้แทนรูปร่าง

ข้อความจะถูกแปลงเป็นเลเยอร์ข้อความที่แก้ไขได้ โดยใกล้เคียงกับแบบอักษร ขนาด การเติม และตำแหน่งของไฟล์ต้นฉบับ จากนั้นก็แก้ไขและปรับข้อความได้โดยตรงใน After Effects

เลเยอร์ข้อความ Brightness อยู่เหนือกราฟิกเปลวไฟ พร้อมแผง Character ที่แสดงแบบอักษร Adobe Clean Italic ขนาด 74px และเปิดใช้ Fill
หลังการแปลง ข้อความยังคงแก้ไขได้เต็มรูปแบบ — ยังคงเปลี่ยนแบบอักษร สไตล์ ขนาด และการเติมได้ในแผง Character

หมายเหตุ

ข้อความที่มีเฉพาะการลากเส้นจะยังคงถูกแปลงเป็นพาธ แทนที่จะเป็นเลเยอร์ข้อความที่แก้ไขได้ 

เนื้อหาเวกเตอร์ที่ไม่ใช่ข้อความจะยังคงถูกแปลงเป็นเลเยอร์รูปร่างเช่นเดิม และหากไฟล์ Illustrator มีทั้งสองแบบ ก็จะได้ทั้งเลเยอร์ข้อความและเลเยอร์รูปร่างผสมกัน

เข้าร่วมการสนทนาในชุมชน After Effects (Beta) ของเราเกี่ยวกับการสนับสนุนข้อความที่แก้ไขได้จากไฟล์ Illustrator

คัดลอกและวางเนื้อหา Illustrator และ SVG

ตอนนี้สามารถวางเนื้อหา SVG จากคลิปบอร์ดลงใน After Effects ได้โดยใช้ Edit > Pasteเนื้อหาจะถูกนำเข้าเป็นเลเยอร์รูปร่างในระบบที่แก้ไขได้และพร้อมสร้างแอนิเมชัน โดยไม่ต้องมีขั้นตอนการนำเข้าเพิ่มเติม

คัดลอกเนื้อหาจาก Illustrator

เปิดงานศิลปะใน Adobe Illustrator

ยืนยันว่าได้เลือกการกำหนดลักษณะ รวม SVG Code แล้ว

  • macOS: เลือก Illustrator > การตั้งค่า > การจัดการคลิปบอร์ด และเลือก รวม SVG Code
  • Windows: เลือก การแก้ไข > การกำหนดลักษณะ > การจัดการคลิปบอร์ด และเลือก รวม SVG Code
กล่องโต้ตอบการกำหนดลักษณะเปิดอยู่ใน Illustrator และตัวเลือกรวม SVG Code ถูกเลือก
เปิดใช้งานรวม SVG Code เพื่อให้งานศิลปะของคุณแก้ไขได้และมีคุณภาพสูงในแอป Adobe อื่นๆ

เลือกงานศิลปะที่ต้องการคัดลอก

เคล็ดลับ

แปลงข้อความ SVG ใดๆ เป็นเส้นโค้งก่อนคัดลอก เนื่องจากข้อความ SVG ไม่รองรับในการวาง

เลือก การแก้ไข > คัดลอก

สลับไปที่ After Effects และทำอย่างใดอย่างหนึ่งต่อไปนี้ขึ้นอยู่กับสถานะโปรเจคของคุณ:

  • หากไม่มีโปรเจคเปิดอยู่ เลือก การแก้ไข > วาง เพื่อสร้างโปรเจคใหม่พร้อมคอมโพสิชันที่มีเนื้อหา SVG เป็นเลเยอร์รูปร่าง
  • หากมีโปรเจคเปิดอยู่แต่ไม่ได้เลือกคอมโพสิชัน ให้เลือก การแก้ไข > วาง เพื่อสร้างคอมโพสิชันใหม่ในโปรเจคปัจจุบันที่มีเนื้อหาที่วาง
ตัวเลือกการแก้ไข > วางถูกเลือก และเนื้อหาจะถูกนำเข้าเป็นเลเยอร์รูปร่างในระบบที่แก้ไขได้และพร้อมสร้างแอนิเมชัน
การแก้ไข > วาง จะนำเนื้อหาเข้ามาเป็นเลเยอร์รูปร่างที่แก้ไขได้ พร้อมสำหรับการสร้างแอนิเมชัน

หากเลือกคอมโพสิชันใน After Effects แล้ว ให้เลือก แก้ไข > วาง เพื่อเพิ่มเนื้อหา SVG เป็นเลเยอร์รูปร่างใหม่ในคอมโพสิชันนั้น

วาง SVG จากแอปอื่นๆ

เนื้อหา SVG ที่คัดลอกจากแอปพลิเคชันใดๆ ที่เขียน SVG ลงในคลิปบอร์ดของระบบสามารถวางได้โดยใช้เวิร์กโฟลว์ การแก้ไข > วาง เดียวกันการสนับสนุนขึ้นอยู่กับว่าแอปพลิเคชันต้นทางวางข้อมูล SVG ที่ถูกต้องในคลิปบอร์ดหรือไม่