使用手冊 取消

存回和取出檔案

  1. Dreamweaver 使用手冊
  2. 簡介
    1. 多方互動網頁設計基本概念
    2. Dreamweaver 的新增功能
    3. 使用 Dreamweaver 開發網頁 - 總覽
    4. Dreamweaver / 常見問題
    5. 鍵盤快速鍵
    6. Dreamweaver 系統需求
    7. 功能摘要
  3. Dreamweaver 和 Creative Cloud
    1. 將 Dreamweaver 設定與 Creative Cloud 同步
    2. Dreamweaver 中的 Creative Cloud Libraries
    3. 在 Dreamweaver 中使用 Photoshop 檔案
    4. 使用 Adobe Animate 和 Dreamweaver
    5. 從資料庫擷取網頁最佳化的 SVG 檔案
  4. Dreamweaver 工作區和檢視
    1. Dreamweaver 工作區
    2. 最佳化視覺開發的 Dreamweaver 工作區
    3. 根據檔案名稱或內容搜尋檔案 | Mac OS
  5. 設定網站
    1. 關於 Dreamweaver 網站
    2. 設定網站的本機版本
    3. 連線到發佈伺服器
    4. 設定測試伺服器
    5. 匯入和匯出 Dreamweaver 網站設定
    6. 將現有網站從遠端伺服器帶入本機網站根目錄
    7. Dreamweaver 中的輔助功能
    8. 進階設定
    9. 設定網站偏好設定以傳送檔案
    10. 在 Dreamweaver 中指定 Proxy 伺服器設定
    11. 將 Dreamweaver 設定與 Creative Cloud 同步
    12. 在 Dreamweaver 中使用 Git
  6. 管理檔案
    1. 建立和開啟檔案
    2. 管理檔案和資料夾
    3. 下載和上傳伺服器檔案
    4. 存回和取出檔案
    5. 同步化檔案
    6. 比較檔案差異
    7. 遮罩 Dreamweaver 網站中的檔案和資料夾
    8. 啟用 Dreamweaver 網站的設計備註
    9. 防止 Gatekeeper 遭到潛在惡意利用
  7. 版面和設計
    1. 使用視覺輔助以配置版面
    2. 關於使用 CSS 配置頁面
    3. 使用 Bootstrap 設計回應式網站
    4. 在 Dreamweaver 中建立及使用媒體查詢
    5. 以表格呈現內容
    6. 顏色
    7. 使用流變格線版面的互動設計
    8. Dreamweaver 中的 Extract
  8. CSS
    1. 了解串接樣式表
    2. 使用 CSS 設計工具配置頁面
    3. 在 Dreamweaver 中使用 CSS 預處理器
    4. 如何在 Dreamweaver 中設定 CSS 樣式偏好設定
    5. 在 Dreamweaver 中移動 CSS 規則
    6. 在 Dreamweaver 中將行內 CSS 轉換為 CSS 規則
    7. 使用 div 標籤
    8. 套用漸層至背景
    9. 在 Dreamweaver 中建立與編輯 CSS3 轉變效果
    10. 格式化程式碼
  9. 頁面內容和資產
    1. 設定頁面屬性
    2. 設定 CSS 標題屬性和 CSS 連結屬性
    3. 處理文字
    4. 尋找和取代文字、標籤和屬性
    5. DOM 面板
    6. 在即時檢視中編輯
    7. 在 Dreamweaver 中進行文件編碼
    8. 在文件視窗中選取並檢視元素
    9. 在屬性檢視窗中設定文字屬性
    10. 檢查網頁拼字
    11. 在 Dreamweaver 中使用水平線
    12. 在 Dreamweaver 中新增和修改字體組合
    13. 使用資源
    14. 在 Dreamweaver 中插入和更新日期
    15. 在 Dreamweaver 中建立和管理最愛資源
    16. 在 Dreamweaver 中插入及編輯影像
    17. 新增媒體物件
    18. 在 Dreamweaver 中加入視訊
    19. 插入 HTML5 視訊
    20. 插入 SWF 檔
    21. 新增音效效果
    22. 在 Dreamweaver 中插入 HTML5 音效
    23. 使用圖庫項目
    24. 在 Dreamweaver 中使用阿拉伯文和希伯來文文字
  10. 連結和導覽
    1. 關於連結和導覽
    2. 連結
    3. 影像地圖
    4. 連結疑難排解
  11. jQuery Widget 和效果
    1. 在 Dreamweaver 中使用 jQuery UI 和 Mobile Widget
    2. 在 Dreamweaver 中使用 jQuery 效果
  12. 撰寫網站程式碼
    1. 關於在 Dreamweaver 中撰寫程式碼
    2. Dreamweaver 的程式碼撰寫環境
    3. 設定程式碼撰寫偏好設定
    4. 自訂程式碼色彩標示
    5. 撰寫和編輯程式碼
    6. 程式碼提示和程式碼完成
    7. 收合和展開程式碼
    8. 利用片段重複使用程式碼
    9. Lint 程式碼
    10. 最佳化程式碼
    11. 在設計檢視中編輯程式碼
    12. 使用頁面的檔頭內容
    13. 在 Dreamweaver 中插入伺服器端包含
    14. 在 Dreamweaver 中使用標籤資料庫
    15. 匯入自訂標籤到 Dreamweaver
    16. 使用 JavaScript 行為 (一般說明)
    17. 套用內建的 JavaScript 行為
    18. 關於 XML 與 XSLT
    19. 在 Dreamweaver 中執行伺服器端 XSL 轉換
    20. 在 Dreamweaver 中執行用戶端 XSL 轉換
    21. 在 Dreamweaver 中新增 XSLT 字元實體
    22. 格式化程式碼
  13. 跨產品工作流程
    1. 安裝與使用 Dreamweaver 的擴充功能
    2. Dreamweaver 中的應用程式內更新
    3. 在 Dreamweaver 中插入 Microsoft Office 文件 (僅適用於 Windows)
    4. 使用 Fireworks 和 Dreamweaver
    5. 使用 Contribute 編輯 Dreamweaver 網站的內容
    6. Dreamweaver-Business Catalyst 整合
    7. 建立個人化的電子郵件行銷活動
  14. 範本
    1. 關於 Dreamweaver 範本
    2. 辨識範本和以範本為架構的文件
    3. 建立 Dreamweaver 範本
    4. 建立範本的可編輯區域
    5. 在 Dreamweaver 中建立重複區域和表格
    6. 使用範本中的選擇性區域
    7. 在 Dreamweaver 中定義可編輯的標籤屬性
    8. 如何在 Dreamweaver 中建立巢狀範本
    9. 編輯、更新和刪除範本
    10. 在 Dreamweaver 中匯出及匯入 XML 內容
    11. 對現有的文件套用或移除範本
    12. 編輯 Dreamweaver 範本的內容
    13. Dreamweaver 中範本標籤的語法規則
    14. 設定範本區域的標示偏好設定
    15. 使用 Dreamweaver 範本的好處
  15. 行動裝置和多螢幕
    1. 建立媒體查詢
    2. 為行動裝置變更頁面方向
    3. 使用 Dreamweaver 為行動裝置建立網頁用程式
  16. 動態網站、網頁和網站表單
    1. 了解網頁用程式
    2. 設定您的電腦以進行應用程式開發
    3. 疑難排解資料庫連線
    4. 在 Dreamweaver 中移除連線 Script
    5. 設計動態網頁
    6. 動態內容來源總覽
    7. 定義動態內容的來源
    8. 將動態內容新增至頁面
    9. 在 Dreamweaver 中變更動態內容
    10. 顯示資料庫記錄
    11. 在 Dreamweaver 中提供即時資料及進行疑難排解
    12. 在 Dreamweaver 中新增自訂伺服器行為
    13. 使用 Dreamweaver 建立表單
    14. 使用表單向使用者收集資訊
    15. 在 Dreamweaver 中建立及啟用 ColdFusion 表單
    16. 建立網站表單
    17. 加強對 HTML5 表單元素的支援
    18. 使用 Dreamweaver 開發表單
  17. 以視覺化方式建立應用程式
    1. 在 Dreamweaver 中建立主要和細節頁面
    2. 建立搜尋及結果頁面
    3. 建立記錄插入頁面
    4. 在 Dreamweaver 中建立更新記錄頁面
    5. 在 Dreamweaver 中建立記錄刪除頁面
    6. 在 Dreamweaver 中使用 ASP 命令修改資料庫
    7. 建立註冊頁面
    8. 建立登入頁面
    9. 建立唯有授權用戶才能存取的頁面
    10. 使用 Dreamweaver 保護 ColdFusion 中的資料夾
    11. 在 Dreamweaver 中使用 ColdFusion 組件
  18. 測試、預覽和發佈網站
    1. 預覽頁面
    2. 在多部裝置上預覽 Dreamweaver 網頁
    3. 測試 Dreamweaver 網站

 

請使用 Dreamweaver 存回/取出系統、WebDAV 或 Subversion 在本機和遠端伺服器之間存回和取出檔案。

如果在共同作業環境中工作,您可以在本機和遠端伺服器之間取出和存回檔案。如果您是唯一在遠端伺服器上工作的人,則可以使用「上傳」和「下載」命令,而不需存回或取出檔案。

註解:

您可以對測試伺服器使用「下載」和「上傳」功能,但是您不能對測試伺服器使用「存回/取出」系統。

取出檔案就等於宣告「我目前正在使用這個檔案,請不要碰它!」 取出檔案後,「檔案」面板中就會顯示檔案取出者的名稱,並且在檔案圖示旁附加一個紅色核取記號 (如果是小組成員取出這個檔案) 或綠色核取記號 (如果是您取出這個檔案)。

存回檔案時,可以讓其他小組成員取出和編輯這個檔案。當您在編輯之後存回檔案時,本機版本會變成唯讀,而且在「檔案」面板中這個檔案的旁邊會出現鎖狀符號,防止您對檔案進行變更。

Dreamweaver 不會讓取出的檔案在遠端伺服器上成為唯讀。如果您使用 Dreamweaver 以外的應用程式傳送檔案,可能會覆寫取出的檔案。不過,在 Dreamweaver 以外的應用程式中,在檔案階層中已取出檔案的旁邊會看到 LCK 檔案,可以協助您防止這類意外狀況。

設定存回/取出系統

您必須建立本機網站與遠端伺服器的關聯,才能使用「存回/取出」系統。

  1. 選取「網站>管理網站」。
  2. 選取網站然後按一下「編輯」。
  3. 選取「網站設定」對話方塊中的「伺服器」類別,並執行下列其中一項作業:
    • 按一下「新增伺服器」按鈕以新增伺服器

    • 選取現有的伺服器並按一下「編輯現有的伺服器」按鈕

  4. 視需要指定「基本」選項,然後按一下「進階」按鈕。
  5. 如果您在小組環境中工作 (或獨自從幾部不同的電腦工作),請選取「啟用檔案取出」。如果您想要停用網站上的檔案存回和取出功能,請取消選取這個選項。

    如果要讓其他人知道您取出了某個檔案進行編輯,或提醒自己可能在別的電腦上存有較新版本的檔案,這個選項就很有用處。

    如果您沒有看見「存回/取出」選項,表示您尚未設定遠端伺服器。

  6. 如果您希望從「檔案」面板按兩下開啟檔案時即可自動取出檔案,請選取「開啟時取出檔案」選項。

    使用「檔案>開啟舊檔」開啟檔案時,即使選取了這個選項也不會取出檔案。

  7. 設定其餘選項:

    取出者名稱

    取出者名稱會與取出的檔案一起出現在「檔案」面板中,這樣可讓小組成員在需要已取出的檔案時,找到適當的人溝通。

    註解:

    如果您獨自從幾部不同的電腦工作,請對每部電腦使用不同的取出者名稱 (例如,AmyR-HomeMac 和 AmyR-OfficePC),以便在忘記存回檔案時,可以知道最新版本的檔案在哪裡。

    電子郵件地址

    當您取出檔案時,如果有輸入電子郵件地址,您的名稱便會以連結形式 (藍色並加底線) 顯示在「檔案」面板中的檔案名稱旁邊。如果小組成員按一下連結,預設電子郵件程式會開啟新郵件,上面有您的電子郵件地址,以及對應到檔案和網站名稱的主旨。

存回和取出遠端資料夾的檔案

設定「存回/取出」系統之後,您便可使用「檔案」面板或從「文件」視窗中,存回和取出遠端伺服器中的檔案。

使用檔案面板取出檔案

  1. 在「檔案」面板 (「視窗>檔案」) 中,選取要從遠端伺服器取出的檔案。
    註解:

    您可以在「本機」或「遠端」檢視中選取檔案,而非「測試伺服器」檢視。

    紅色核取記號表示其他小組成員已經取出這個檔案,而鎖狀符號表示檔案是唯讀的 (Windows) 或鎖定的 (Macintosh)。

  2. 請執行下列其中一項作業以取出檔案:
    • 按一下「檔案」面板工具列中的「取出」按鈕。

    • 按一下右鍵 (Windows) 或 Control + 按一下 (Macintosh),然後從快速選單選取「取出」。

  3. 在「相關檔案」對話方塊中按一下「是」,將相關檔案與選取的檔案一起下載;或按一下「否」,不要下載相關檔案。預設為不要下載相關檔案。您可以在「編輯 > 偏好設定 > 網站」中設定這個選項。
    註解:

    取出新檔案時最好一併下載相關檔案,但是當本機磁碟上已經有相關檔案的最新版本時,就沒有必要再下載了。

    綠色核取記號會出現在本機檔案的圖示旁邊,表示您已經取出這個檔案。

    註解:

    如果您取出目前作用中的檔案,這個檔案目前開啟的版本就會被新取出的版本所覆寫。

使用檔案面板存回檔案

  1. 在「檔案」面板 (「視窗>檔案」) 中,選取取出的檔案或新的檔案。
    註解:

    您可以在「本機」或「遠端」檢視中選取檔案,但並非「測試伺服器」檢視。

  2. 請執行下列其中一項作業以存回檔案:
    • 按一下「檔案」面板工具列中的「存回」按鈕。

    • 按一下右鍵 (Windows) 或 Control + 按一下 (Macintosh),然後從快速選單選取「存回」。

  3. 按一下「是」,將相關檔案與選取的檔案一起上傳;或按一下「否」,不要上傳相關檔案。預設為不要上傳相關檔案。您可以在「編輯 > 偏好設定 > 網站」中設定這個選項。
    註解:

    存回新檔案時,最好一併上傳相關檔案,但是當遠端伺服器上已經有相關檔案的最新版本時,就沒有必要再上傳了。

    鎖狀符號會出現在本機檔案的圖示旁邊,表示這個檔案目前是唯讀狀態。

    註解:

    如果您存回目前作用中的檔案,視您設定的偏好設定選項而定,這個檔案可能會在存回之前先自動儲存。

從文件視窗存回開啟的檔案

  1. 確認要存回的檔案已在「文件」視窗中開啟。
    註解:

    您一次只能存回一個開啟的檔案。

  2. 請執行下列其中一項作業:
    • 選取「網站>存回」。

    • 按一下「文件」視窗工具列中的「檔案管理」圖示,然後從選單選取「存回」。

      如果目前的檔案不屬於「檔案」面板中的作用中網站,Dreamweaver 會嘗試判斷目前的檔案屬於哪一個在本機定義的網站。如果目前檔案所屬的網站並非「檔案」面板中的作用中網站,Dreamweaver 就會開啟該網站,然後執行存回作業。

    註解:

    如果您存回目前作用中的檔案,視您設定的偏好設定選項而定,這個檔案可能會在存回之前先自動儲存。 

還原檔案取出動作

如果您取出檔案,然後決定不要對它進行編輯 (或決定放棄您所做的變更),則可以還原取出動作,檔案就會回到原始的狀態。

若要還原取出動作,請執行下列其中一項作業:

  • 在「文件」視窗中開啟檔案,然後選取「網站>還原取出」。

  • 在「檔案」面板中 (「視窗>檔案」),按一下右鍵 (Windows) 或 Control + 按一下 (Macintosh),然後選取「還原取出」。

    檔案的本機複本就會變成唯讀,而且您所做的任何變更都會消失。

使用 WebDAV 存回和取出檔案

Dreamweaver 可以連線到使用 WebDAV (Web 架構的分散式撰寫和版本控制) 的伺服器,WebDAV 是一組 HTTP 通訊協定擴充功能,能讓用戶共同編輯與管理遠端網頁伺服器上的檔案。如需詳細資訊,請參閱 www.webdav.org

  1. 如果您尚未設定,請定義 Dreamweaver 網站,以指定您用來存放專案檔案的本機資料夾。
  2. 選取「網站>管理網站」,然後在清單中按兩下您的網站。
  3. 選取「網站設定」對話方塊中的「伺服器」類別,並執行下列其中一項作業:
    • 按一下「新增伺服器」按鈕以新增伺服器

    • 選取現有的伺服器並按一下「編輯現有的伺服器」按鈕

  4. 在「基本」畫面,選取「連線方式」彈出式選單中的「WebDAV」,並視需要完成其餘的「基本」畫面選項。
  5. 按一下「進階」按鈕。
  6. 選取「啟動檔案取出」選項,然後輸入下列資訊:
    • 在「取出者名稱」方塊中,輸入可讓其他小組成員辨識您的名稱。

    • 在「電子郵件地址」方塊中,輸入您的電子郵件地址。

      名稱和電子郵件地址都是用來識別 WebDAV 伺服器上的擁有權,並且會出現在「檔案」面板中,作連絡之用。

  7. 按一下「儲存」。

    Dreamweaver 就會設定適合使用 WebDAV 存取的網站。當您在任何網站檔案上使用「存回」或「取出」命令時,會使用 WebDAV 來傳輸檔案。

    註解:

    WebDAV 可能不適合用來取出任何包含 PHP 標籤或 SSI 等動態內容的檔案,因為 HTTP GET 命令會將這些檔案顯示為已取出。

使用 Subversion (SVN) 取出及存回檔案

註解:

Dreamweaver CC 2017 和更新版本中已移除 Subversion (SVN) 支援。

Dreamweaver 可以連線至使用 Subversion (SVN) 的伺服器,SVN 是一套版本控制系統,能讓用戶共同編輯與管理遠端網頁伺服器上的檔案。Dreamweaver 並非完整的 SVN 用戶端,但是的確能讓用戶取得最新版的檔案、進行變更以及認同檔案。

註解:

Dreamweaver CS5 會使用 Subversion 1.6.6 用戶端程式庫,而 Dreamweaver CS5.5 則使用 1.6.9 用戶端程式庫。較新版本的 Subversion 用戶端程式庫不具備回溯相容性。請注意,如果您更新了協力廠商的用戶端應用程式 (例如 TortoiseSVN),並搭配使用較新版本的 Subversion,更新的 Subversion 應用程式會更新本機的 Subversion Meta 資料,而 Dreamweaver 將無法再與 Subversion 溝通。對 Subversion 伺服器的更新不會造成這個問題,因為這些更新程式具回溯相容性。如果您升級至搭配使用 Subversion 1.7 或更新版本的協力廠商用戶端應用程式,則必須向 Adobe 取得更新,才能再次搭配 Dreamweaver 使用 Subversion。如需有關此問題的詳細資訊,請參閱 www.adobe.com/go/dw_svn_en

Adobe 建議您在使用 SVN 版本控制檔案時,使用協力廠商檔案比較工具。比較檔案的差異時,您可以確切得知其他使用者針對檔案進行了哪些種類的變更。如需檔案比較工具的詳細資訊,請使用網頁搜尋引擎 (例如 Google 搜尋) 來搜尋「file comparison」或「diff」工具。Dreamweaver 可以搭配大部分的協力廠商工具使用。

如需有關使用 SVN 和 Dreamweaver 的總覽影片,請參閱 www.adobe.com/go/lrvid4049_dw

設定 SVN 連線

搭配 Dreamweaver 使用 Subversion (SVN) 做為版本控制系統之前,您必須設定 SVN 伺服器連線。您要在「網站定義」對話方塊的「版本控制」類別中設定 SVN 伺服器連線。

SVN 伺服器是一個檔案儲存庫,您與其他使用者可以從中取得和認同檔案。它與您平常搭配 Dreamweaver 使用的遠端伺服器不同。使用 SVN 時,遠端伺服器仍為網頁的「即時」伺服器,而 SVN 伺服器則仍會保留您要保有其版本控制權之檔案的儲存庫。典型的工作流程是用來在 SVN 伺服器之間來回取得和認可檔案,然後從 Dreamweaver 將這些檔案發佈到遠端伺服器。遠端伺服器的設定完全獨立於 SVN 的設定。

您必須有 SVN 伺服器和 SVN 儲存庫的存取權,才能開始進行這個設定。如需有關 SVN 的詳細資訊,請參閱 Subversion 網站,網址為:http://subversion.apache.org/

若要設定 SVN 連線,請遵照下列步驟:

  1. 選擇「網站>管理網站」,然後選取要設定版本控制的網站,再按一下「編輯」按鈕。

    註解:

    如果您尚未設定 Dreamweaver 網站的本機和遠端資料夾,則至少要先設定本機網站才能繼續 (這個階段不需要用到遠端網站,但您最終還是需要設定網站,才能將檔案發佈到網路上)。如需詳細資訊,請參閱「使用 Dreamweaver 網站」。

  2. 選取「網站設定」對話方塊中的「版本控制」類別。

  3. 從「存取」彈出式選單中選取「Subversion」。

  4. 按照下列方式設定選項:

    • 從「通訊協定」彈出式選單中選取通訊協定。可用的通訊協定為 HTTP、HTTPS、SVN 和 SVN+SSH。
    註解:

    使用 SVN+SSH 通訊協定時,需要特殊設定。如需詳細資訊,請參閱 www.adobe.com/go/learn_dw_svn_ssh_en

    • 在「伺服器位址」文字方塊中輸入 SVN 伺服器的位址 (一般格式為 servername.domain.com)。

    • 在「儲存庫路徑」文字方塊中輸入儲存庫在 SVN 伺服器上的路徑 (一般為 /svn/your_root_directory 等,伺服器管理員可以為 SVN 儲存庫的根資料夾命名)。

    • (選擇性) 若要使用預設伺服器連接埠以外的伺服器連接埠,請選取「非預設」,然後在文字方塊中輸入連接埠號碼。

    • 輸入 SVN 伺服器使用者名稱和密碼。

  5. 按一下「測試」以測試連線,或是按一下「確定」以關閉對話方塊。然後,按一下「完成」以結束「管理網站」對話方塊。

一旦伺服器連線建立完成,您就可以在「檔案」面板中檢視 SVN 儲存庫。若要檢視,您可以從「檢視」彈出式選單中選取「儲存庫檢視」,或是在展開的「檔案」面板中按一下「儲存庫檔案」按鈕

取得最新版本的檔案

當您從 SVN 儲存庫中取得最新版本的檔案時,Dreamweaver 會合併該檔案的內容及其對應之本機複本的內容 (換句話說,如果他人已在您上一次認可檔案之後更新檔案,這些更新都會合併到電腦檔案的本機版本中)。如果本機硬碟上還沒有這個檔案,Dreamweaver 會直接取得。

註解:

第一次從儲存庫取得檔案時,您應該使用空的本機目錄,或是不包含名稱與儲存庫檔案相同之檔案的本機目錄。如果本機磁碟包含名稱與遠端儲存庫檔案相符的檔案,Dreamweaver 不會在第一次就將儲存庫檔案裝載到本機磁碟。

  1. 請確認您已成功設定 SVN 連線。

  2. 請執行下列其中一項作業:

    • 您可以從「檢視」彈出式選單中選取「本機檢視」,藉此顯示 SVN 檔案的本機版本 (如果您是在展開的「檔案」面板中作業,系統會自動顯示「本機檢視」)。然後,以滑鼠右鍵按一下 (Windows) 或用 Control+按一下 (Macintosh) 所需的檔案或資料夾,然後選取「版本控制>取得最新版本」。

    • 您可以從「檔案」面板的「檢視」彈出式選單中選取「儲存庫檢視」,或是在展開的「檔案」面板中按一下「儲存庫檔案」按鈕,藉此顯示 SVN 儲存庫檔案。然後,以滑鼠右鍵按一下 (Windows) 或用 Control+按一下 (Macintosh) 所需的檔案或資料夾,然後選取「取得最新版本」。

註解:

您也可以在檔案上按下右鍵,然後從快速選單中選擇「取出」,或是選取檔案再按一下「取出」按鈕,取得最新版本。雖然 SVN 不支援取出工作流程,但這個動作其實並不會按照傳統的做法取出檔案。

認同檔案

  1. 請確認您已成功設定 SVN 連線。

  2. 請執行下列其中一項作業:

    • 您可以從「檢視」彈出式選單中選取「本機檢視」,藉此顯示 SVN 檔案的本機版本 (如果您是在展開的「檔案」面板中作業,系統會自動顯示「本機檢視」)。接著選取您要認同的檔案,然後按一下「存回」按鈕。

    • 您可以從「檔案」面板的「檢視」彈出式選單中選取「儲存庫檢視」,或是在展開的「檔案」面板中按一下「儲存庫檔案」按鈕,藉此顯示 SVN 儲存庫檔案。接著以滑鼠右鍵按一下 (Windows) 或用 Control+按一下 (Macintosh) 您要認同的檔案,然後選取「存回」。

  3. 檢視「認同」對話方塊中的動作,然後視需要進行變更,再按一下「確定」。

    您可以選取要變更動作的檔案,然後按一下「認同」對話方塊底部的按鈕來變更動作。有兩個可用的選項:認同和忽略。

註解:

「檔案」面板中的檔案如果有綠色標記,表示變更的檔案尚未認同到儲存庫。

更新儲存庫檔案或資料夾的狀態

您可以更新單一檔案或資料夾的 SVN 狀態,但更新時不會重新整理整個顯示畫面。

  1. 請確認您已成功設定 SVN 連線。

  2. 您可以從「檔案」面板的「檢視」彈出式選單中選取「儲存庫檢視」,或是在展開的「檔案」面板中按一下「儲存庫檔案」按鈕,藉此顯示 SVN 儲存庫檔案。

  3. 以滑鼠右鍵按一下 (Windows) 或用 Control+按一下 (Macintosh) 儲存庫中的任何資料夾或檔案,然後選取「更新狀態」。

更新本機檔案或資料夾的狀態

您可以更新單一檔案或資料夾的 SVN 狀態,但更新時不會重新整理整個顯示畫面。

  1. 請確認您已成功設定 SVN 連線。

  2. 您可以從「檢視」彈出式選單中選取「本機檢視」,藉此顯示 SVN 檔案的本機版本 (如果您是在展開的「檔案」面板中作業,系統會自動顯示「本機檢視」)。

  3. 以滑鼠右鍵按一下 (Windows) 或用 Control+按一下 (Macintosh)「檔案」面板中的任何資料夾或檔案,然後選取「更新狀態」。

檢視檔案的修訂

  1. 請確認您已成功設定 SVN 連線。

  2. 請執行下列其中一項作業:

    • 您可以從「檢視」彈出式選單中選取「本機檢視」,藉此顯示 SVN 檔案的本機版本 (如果您是在展開的「檔案」面板中作業,系統會自動顯示「本機檢視」)。以滑鼠右鍵按一下 (Windows) 或用 Control+按一下 (Macintosh) 您要查看修訂的檔案,然後選取「版本控制>顯示修訂」。

    • 您可以從「檔案」面板的「檢視」彈出式選單中選取「儲存庫檢視」,或是在展開的「檔案」面板中按一下「儲存庫檔案」按鈕,藉此顯示 SVN 儲存庫檔案。以滑鼠右鍵按一下 (Windows) 或用 Control+按一下 (Macintosh) 您要查看修訂的檔案,然後選取「顯示修訂」。

  3. 在「修訂記錄」對話方塊中,選取您需要的修訂,然後執行下列其中一項:

    • 按一下「與本機比較」,將選取的修訂與檔案的本機版本進行比較。
    註解:

    您必須安裝協力廠商檔案比較工具,才能比較檔案。如需檔案比較工具的詳細資訊,請使用網頁搜尋引擎 (例如 Google 搜尋) 來搜尋「file comparison」或「diff」工具。Dreamweaver 可以搭配大部分的協力廠商工具使用。

    • 按一下「比較」可比較兩個選取的修訂。用 Control+按一下可同時選取兩個修訂。

    • 按一下「檢視」可檢視選取的修訂。這個動作不會覆寫同一個檔案目前的本機複本。您可以將選取的修訂儲存到硬碟上,就像儲存任何其他檔案一樣。

    • 按一下「升級」可以讓選取的修訂成為儲存庫中最新的修訂。

鎖定及解除鎖定檔案

鎖定 SVN 儲存庫檔案可讓其他使用者知道您正在處理某個檔案,其他使用者仍然可以在本機上編輯檔案,但卻無法認同檔案,直到您解除檔案的鎖定為止。鎖定儲存庫中的檔案時,您會看到檔案上有個開鎖圖示。其他使用者會看到完全鎖定的圖示。

  1. 請確認您已成功設定 SVN 連線。

  2. 請執行下列其中一項作業:

    • 您可以從「檔案」面板的「檢視」彈出式選單中選取「儲存庫檢視」,或是在展開的「檔案」面板中按一下「儲存庫檔案」按鈕,藉此顯示 SVN 儲存庫檔案。然後,以滑鼠右鍵按一下 (Windows) 或用 Control+按一下 (Macintosh) 所需的檔案或資料夾,然後選取「鎖定」或「解除鎖定」。

    • 您可以從「檢視」彈出式選單中選取「本機檢視」,藉此顯示 SVN 檔案的本機版本 (如果您是在展開的「檔案」面板中作業,系統會自動顯示「本機檢視」)。然後,以滑鼠右鍵按一下 (Windows) 或用 Control+按一下 (Macintosh) 所需的檔案或資料夾,然後選取「鎖定」或「解除鎖定」。

新增檔案到儲存庫

「檔案」面板中的檔案如果有藍色加號,表示檔案不在 SVN 儲存庫中。

  1. 請確認您已成功設定 SVN 連線。

  2. 在「檔案」面板中,選取您要新增到儲存庫的檔案,然後按一下「存回」按鈕。

  3. 確認「認同」對話方塊中是否已選取這個檔案進行「認同」,然後按一下「確定」。

移動、複製、刪除或回復檔案

  • 若要移動檔案,請將檔案拖曳至本機網站的目標資料夾。

    當您移動檔案時,Dreamweaver 會使用「與記錄一同新增」符號來標示新位置的檔案,而使用「刪除」符號來標示舊位置的檔案。當您認同這些檔案時,舊位置的檔案就會消失。

  • 若要複製檔案,請選取檔案、複製它 (「編輯 > 複製」),然後在新的位置貼上 (「編輯 > 貼上」) 檔案。

    當您複製並貼上檔案時,Dreamweaver 會使用「與記錄一同新增」符號來標示新位置的檔案。

  • 若要刪除檔案,請選取檔案,然後按下 Delete 鍵。

    Dreamweaver 可讓您選擇要單獨刪除檔案的本機版本,還是同時刪除本機版本以及 SVN 伺服器上的版本。如果您選取要單獨刪除本機版本,SVN 伺服器上的檔案就不會受到影響。如果您選取要一併刪除 SVN 伺服器上的版本,本機版本就會以「刪除」符號標示,而且您必須認同檔案,才會進行刪除。

  • 若要將已複製或移動的檔案回復至原始位置,請以滑鼠右鍵按一下檔案,然後選取「版本控制 > 回復至前次儲存」。

解決檔案衝突

如果您的檔案與伺服器其他檔案衝突,您可以編輯這個檔案,然後將其標示為已解決。例如,如果您嘗試存回的檔案與其他使用者所做的變更衝突,SVN 將不會讓您認可檔案。您可以從儲存庫取得最新版本的檔案,然後手動針對工作複本進行變更,再將檔案標示為已解決,以便能夠認可檔案。

  1. 請確認您已成功設定 SVN 連線。

  2. 您可以從「檢視」彈出式選單中選取「本機檢視」,藉此顯示 SVN 檔案的本機版本 (如果您是在展開的「檔案」面板中作業,系統會自動顯示「本機檢視」)。

  3. 以滑鼠右鍵按一下 (Windows) 或用 Control+按一下 (Macintosh) 您要解決衝突的檔案,然後選取「版本控制>標示為已解決」。

離線

在其他檔案傳輸活動期間,離線可以讓您不用存取儲存庫。當您叫用需要連線的活動 (「取得最新版本」、「認同」等) 時,Dreamweaver 便會重新連線到 SVN 儲存庫。

  1. 請確認您已成功設定 SVN 連線。

  2. 您可以從「檢視」彈出式選單中選取「本機檢視」,藉此顯示 SVN 檔案的本機版本 (如果您是在展開的「檔案」面板中作業,系統會自動顯示「本機檢視」)。

  3. 以滑鼠右鍵按一下 (Windows) 或用 Control+按一下 (Macintosh)「檔案」面板中的任何檔案或資料夾,然後選取「版本控制>離線」。

清理本機 SVN 網站

這個命令可以讓您移除檔案鎖定,以便能夠繼續未完成的作業。如果收到「工作複本已鎖定」錯誤,就必須使用這個命令移除舊有的鎖定。

  1. 請確認您已成功設定 SVN 連線。

  2. 您可以從「檢視」彈出式選單中選取「本機檢視」,藉此顯示 SVN 檔案的本機版本 (如果您是在展開的「檔案」面板中作業,系統會自動顯示「本機檢視」)。

  3. 以滑鼠右鍵按一下 (Windows) 或用 Control+按一下 (Macintosh) 您要清理的檔案,然後選取「版本控制>清理」。

關於在 Subversion 控制的網站中移動檔案和資料夾

在 Subversion 控制的網站中移動檔案或資料夾的本機版本時,可能會對正在同步處理到 SVN 儲存庫的其他使用者造成問題。例如,如果您在本機上移動檔案,而且沒有在幾個小時內將其認同至儲存庫,其他使用者可能會嘗試從該檔案的原來位置取得檔案的最新版本。因此,當您在本機上移動檔案之後,應該一律立即將其認同回到 SVN 伺服器。

檔案和資料夾會保留在 SVN 伺服器上,直到您手動將其刪除為止。所以,如果您將檔案移到另一個本機資料夾並加以認同,舊版的檔案仍然會留在伺服器上的原來位置。為避免造成混淆,請刪除您所移動之檔案和資料夾的舊複本。

如果您在本機上移動檔案並將其認同回到 SVN 伺服器,檔案的版本記錄就會遺失。

 Adobe

更快、更輕鬆地獲得協助

新的使用者?