在 Dreamweaver 中將可編輯內容匯出及匯入為 XML。了解如何從一個網站匯出以範本為架構的內容到另一個網站。

您可以將以範本為架構的文件想成是包含了由名稱/值配對表示的資料。每個配對都是由可編輯區域的名稱和該區域的內容構成。

你可以將名稱/值配對匯出為 XML 檔,以便在 Dreamweaver 之外 (例如,在 XML 編輯器或文字編輯器,或資料庫應用程式) 處理資料。相反地,如果有適當結構化的 XML 文件,則可將其資料匯入以 Dreamweaver 範本為架構的文件中。

將文件的可編輯區域轉存為 XML

  1. 開啟含有可編輯區域之以範本為架構的文件。
  2. 選取「檔案 > 轉存 > 將範本資料轉存為 XML」。
  3. 選取其中一個「註釋」選項:
    • 如果範本含有重複區域或範本參數,請選取「使用標準的 Dreamweaver XML 標籤」。

    • 如果範本沒有包含重複區域或範本參數,請選取「使用可編輯區域名稱來當做 XML 標籤」。

  4. 按一下「確定」。
  5. 在出現的對話方塊中,選取資料夾位置,輸入 XML 檔的名稱,然後按一下「儲存」。

    便會產生一個含有來自文件參數和可編輯區域 (包括重複區域或選擇性區域內的可編輯區域) 中資料的 XML 檔案。這個 XML 檔案包括了原始範本的名稱,以及每個範本區域的名稱和內容。

    註解:

    不可編輯區域中的內容不會轉存為 XML 檔案。

匯入 XML 內容

  1. 請選取「檔案 > 匯入 > 將 XML 匯入範本」。
  2. 選取此 XML 檔案,然後按一下「開啟」。

    Dreamweaver 會根據 XML 檔中指定的範本建立新文件。並且用 XML 檔案的資料填入這個文件中每個可編輯區域的內容。產生的文件便會出現在新的「文件」視窗中。

    註解:

    如果 XML 檔不是完全按照 Dreamweaver 預期的方式設定,可能就無法匯入資料。這個問題的一個解決辦法是,從 Dreamweaver 匯出虛擬的 XML 檔,就會有完全正確結構的 XML 檔。然後再從您的原始 XML 檔案將資料複製到這個轉存的 XML 檔案中。如此一來,就產生了一個結構正確而且含有適當資料的 XML 檔案,可以進行匯入了。

匯出不含範本標記的網站

您可以將網站中以範本為架構的文件,以不包含範本標記的方式,匯出至另外一個網站。

  1. 選取「工具 > 範本 > 轉存為非範本文件」。

  2. 在「資料夾」方塊中,輸入您要將檔案轉存之目的資料夾的檔案路徑,或是按一下「瀏覽」,然後選取資料夾。

    註解:

    您必須選取在現有網站外的資料夾。

  3. 如果您想要將轉存之以範本為架構的文件儲存成 XML 版本,請選取「保存範本資料檔案」。
  4. 若要更新先前所轉存檔案的變更,請選取「僅轉存變更過的檔案」並且按一下「確定」。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策