Guide d'utilisation Annuler

Utilisation d’assistances visuelles pour la mise en forme

  1. Guide de l’utilisateur de Dreamweaver
  2. Introduction
    1. Principes de base du design web réactif
    2. Nouveautés de Dreamweaver
    3. Développement web avec Dreamweaver - Présentation
    4. Dreamweaver / Questions fréquentes
    5. Raccourcis clavier
    6. Configuration requise pour Dreamweaver
    7. Récapitulatif des nouvelles fonctionnalités
  3. Dreamweaver et Creative Cloud
    1. Synchronisation des paramètres de Dreamweaver avec Creative Cloud
    2. Bibliothèques Creative Cloud dans Dreamweaver
    3. Utilisation de fichiers Photoshop dans Dreamweaver
    4. Utilisation d’Adobe Animate avec Dreamweaver
    5. Extraction de fichiers SVG optimisés pour le web depuis des Bibliothèques
  4. Espaces de travail et affichages Dreamweaver
    1. Espace de travail de Dreamweaver
    2. Optimisation de l’espace de travail Dreamweaver pour la conception visuelle
    3. Recherche de fichiers sur la base de leur nom ou de leur contenu | Mac OS
  5. Configuration de sites
    1. À propos des sites Dreamweaver
    2. Création d’une version locale de votre site
    3. Connexion à un serveur de publication
    4. Configuration d’un serveur d’évaluation
    5. Importation et exportation des paramètres d’un site Dreamweaver
    6. Importation de sites web d’un serveur distant vers la racine de votre site local
    7. Fonctions d’accessibilité dans Dreamweaver
    8. Paramètres avancés
    9. Définition des préférences de site pour le transfert de fichiers
    10. Indication des paramètres du serveur proxy dans Dreamweaver
    11. Synchronisation des paramètres de Dreamweaver avec Creative Cloud
    12. Utilisation de Git dans Dreamweaver
  6. Gestion des fichiers
    1. Création et ouverture de fichiers
    2. Gestion des fichiers et des dossiers
    3. Acquisition et placement de fichiers depuis ou vers votre serveur
    4. Archivage et extraction de fichiers
    5. Synchronisation de fichiers
    6. Comparaison de fichiers pour analyse de leurs différences
    7. Masquage de fichiers et de dossiers dans votre site Dreamweaver
    8. Activation des notes de conception pour les sites Dreamweaver
    9. Prévention de l’exploitation potentielle de Gatekeeper
  7. Mise en page et design
    1. Utilisation d’assistances visuelles pour la mise en forme
    2. À propos de l’utilisation de CSS pour mise en forme de votre page
    3. Création de sites web en responsive design avec Bootstrap
    4. Création et utilisation des requêtes de multimédia dans Dreamweaver
    5. Présentation de contenus dans des tableaux
    6. Couleurs
    7. Design réactif à l’aide de mises en forme à grille fluide
    8. Extract dans Dreamweaver
  8. CSS
    1. Description des feuilles de style en cascade
    2. Mise en forme de pages avec CSS Designer
    3. Utilisation de préprocesseurs CSS dans Dreamweaver
    4. Comment définir les préférences de Style CSS dans Dreamweaver
    5. Déplacement des règles CSS dans Dreamweaver
    6. Conversion de code CSS intégré en règle CSS dans Dreamweaver
    7. Utilisation de balises div
    8. Application de dégradés à l’arrière-plan
    9. Permet de créer et modifier des effets de transition CSS3 dans Dreamweaver.
    10. Formatage du code
  9. Contenu de page et actifs
    1. Définition des propriétés de page
    2. Définition des propriétés d’en-tête CSS et des propriétés de lien CSS
    3. Utilisation du texte
    4. Recherche et remplacement de texte, de balises et d’attributs
    5. Panneau DOM
    6. Modification en mode En direct
    7. Le codage de documents dans Dreamweaver
    8. Sélection et affichage d’éléments dans la fenêtre de document
    9. Définition des propriétés de texte dans l’inspecteur Propriétés
    10. Vérification de l’orthographe d’une page web
    11. Utilisation de règles horizontales dans Dreamweaver
    12. Ajout et modification de combinaisons de polices dans Dreamweaver
    13. Utilisation d’actifs
    14. Insertion et mise à jour des dates dans Dreamweaver
    15. Création et gestion des actifs favoris dans Dreamweaver
    16. Insertion et modification d’images dans Dreamweaver
    17. Ajout d’objets multimédias
    18. Ajout de vidéos dans Dreamweaver
    19. Insertion de vidéo HTML5
    20. Insertion de fichiers SWF
    21. Ajout d’effets audio
    22. Insertion de fichiers audio HTML5 dans Dreamweaver
    23. Utilisation d’éléments de bibliothèque
    24. Utilisation de texte arabe et hébreu dans Dreamweaver
  10. Liens et navigation
    1. A propos des liens et de la navigation
    2. Etablissement de liens
    3. Cartes graphiques
    4. Résolution des problèmes de liens
  11. Effets et widgets jQuery
    1. Utilisation de widgets jQuery UI et Mobile dans Dreamweaver
    2. Utilisation d’effets jQuery dans Dreamweaver
  12. Codage de sites web
    1. À propos du codage dans Dreamweaver
    2. Environnement de codage dans Dreamweaver
    3. Définition des préférences de codage
    4. Personnalisation de la coloration du code
    5. Rédaction et modification de code
    6. Conseils et remplissage de code
    7. Réduction et développement de code
    8. Réutilisation de code à l’aide de fragments
    9. Analyse linting de code
    10. Optimisation du code
    11. Modification de code en mode Création.
    12. Utilisation de contenu d’en-tête pour les pages
    13. Insertion d’inclusions côté serveur dans Dreamweaver
    14. Utilisation des bibliothèques de balises dans Dreamweaver
    15. Importation de balises personnalisées dans Dreamweaver
    16. Utilisation de comportements JavaScript (instructions générales)
    17. Application de comportements JavaScript intégrés
    18. À propos de XML et de XSLT
    19. Exécution de transformations XSL côté serveur dans Dreamweaver
    20. Exécution de transformations XSL côté client dans Dreamweaver
    21. Ajout d’entités de caractère pour XSLT dans Dreamweaver
    22. Formatage du code
  13. Flux de travaux inter-produit
    1. Installation et utilisation des extensions pour Dreamweaver
    2. Mises à jour intégrées dans Dreamweaver
    3. Insertion de documents Microsoft Office dans Dreamweaver (Windows uniquement)
    4. Utilisation de Fireworks et Dreamweaver
    5. Édition de contenu sur des sites Dreamweaver à l’aide de Contribute
    6. Intégration entre Dreamweaver et Business Catalyst
    7. Création de campagnes de messagerie personnalisées
  14. Modèles
    1. À propos des modèles Dreamweaver
    2. Reconnaissance des modèles et des documents basés sur un modèle
    3. Création d’un modèle Dreamweaver
    4. Création de régions modifiables dans des modèles
    5. Création de régions et de tables modifiables dans Dreamweaver
    6. Utilisation de régions facultatives dans les modèles
    7. Définition d’attributs de balises modifiables dans Dreamweaver
    8. Comment créer des modèles imbriqués dans Dreamweaver
    9. Modification, mise à jour et suppression de modèles
    10. Exportation et importation de contenus xml dans Dreamweaver
    11. Application ou suppression d’un modèle depuis un document existant
    12. Modification de contenu dans les modèles de Dreamweaver
    13. Règles de syntaxe pour les balises de modèle dans Dreamweaver
    14. Définition des préférences de surbrillance pour des régions de modèle
    15. Avantages de l’utilisation de modèles dans Dreamweaver
  15. Terminaux mobiles et écrans multiples
    1. Création de requêtes multimédias
    2. Modification de l’orientation de la page pour les appareils mobiles
    3. Création d’applications web pour appareils mobiles à l’aide de Dreamweaver
  16. Sites dynamiques, pages et formulaires web
    1. En savoir plus sur les applications web
    2. Configuration de l’ordinateur pour le développement d’applications
    3. Résolution des problèmes de connexion aux bases de données
    4. Suppression des scripts de connexion dans Dreamweaver
    5. Conception de pages dynamiques
    6. Présentation des sources de contenu dynamique
    7. Définition de sources de contenu dynamique
    8. Ajout de contenus dynamiques aux pages
    9. Changement des contenus dynamiques dans Dreamweaver
    10. Affichage d’enregistrements d’une base de données
    11. Fourniture et dépannage de données en temps réel dans Dreamweaver
    12. Ajout de comportements de serveur personnalisés dans Dreamweaver
    13. Création de formulaires à l’aide de Dreamweaver
    14. Utilisation de formulaires pour la collecte des informations sur les utilisateurs
    15. Création et activations des formulaires ColdFusion dans Dreamweaver
    16. Création de formulaires web
    17. Prise en charge améliorée de HTML5 pour les éléments de formulaire
    18. Développement d’un formulaire à l’aide de Dreamweaver
  17. Création visuelle d’applications
    1. Création de pages principales et détaillées dans Dreamweaver
    2. Création de pages de recherche et de résultats
    3. Création d’une page d’insertion d’enregistrements
    4. Création de la mise à jour d’une page d’enregistrement dans Dreamweaver
    5. Création de pages de suppression d’enregistrement dans Dreamweaver
    6. Modification d’une base de données à l’aide des commandes ASP dans Dreamweaver
    7. Création d’une page d’enregistrement
    8. Création d’une page de connexion
    9. Création d’une page à accès restreint
    10. Sécurisation de dossiers dans ColdFusion à l’aide de Dreamweaver
    11. Utilisation de composants ColdFusion dans Dreamweaver
  18. Test, aperçu et publication de sites web
    1. Prévisualisation de pages
    2. Aperçu et inspection de pages web Dreamweaver sur plusieurs appareils
    3. Test de votre site Dreamweaver

 

Utilisez des assistances visuelles pour la mise en forme dans Dreamweaver, notamment la définition de règles, la définition de repères de mise en forme, l'utilisation des repères avec des modèles, l'utilisation d'une grille de mise en forme et l'utilisation d'un tracé d'image.

Définition de règles

Les règles vous aident à mesurer, organiser et planifier votre mise en forme. Vous pouvez afficher les règles graduées en pixels, pouces ou centimètres sur les bords gauche et supérieur de la page.

  • Pour activer ou désactiver les règles, sélectionnez Affichage > Options du mode Création > Règles > Afficher/Masquer.
  • Pour changer l'origine, faites glisser l'icône de l'origine de la règle , située dans le coin supérieur gauche de la fenêtre de document en mode Création, sur un point de la page.
  • Pour rétablir la position par défaut de l'origine, sélectionnez Affichage > Options du mode Création > Règles > Rétablir origine.
  • Pour changer d'unité de mesure, choisissez Affichage > Règles, puis sélectionnez Pixels, Pouces ou Centimètres.

Définition de repères de mise en forme

Les repères sont les lignes que vous faites glisser sur le document à partir des règles. Ils vous aident à placer et à aligner des objets de façon plus précise Vous pouvez également utiliser les repères pour mesurer la taille des éléments d'une page ou simuler les plis (zones visibles) des navigateurs Web.

Pour faciliter l'alignement des éléments, vous avez la possibilité de les aligner sur les repères et d'aligner des repères sur des éléments. (les éléments doivent être à positionnement absolu pour que l'alignement puisse fonctionner). Vous pouvez également verrouiller les repères pour qu'ils ne soient pas déplacés de façon accidentelle par un autre utilisateur.

Création d'un repère horizontal ou vertical

  1. Faites glisser le repère à partir de la règle correspondante.
  2. Positionnez le repère dans la fenêtre de document et relâchez le bouton de la souris (repositionnez le repère en le faisant glisser de nouveau).
    Remarque :

    Par défaut, les repères sont enregistrés en tant que mesures en pixels absolues depuis le côté supérieur ou gauche du document et sont affichés par rapport à l'origine de la règle. Pour enregistrer le repère sous la forme d'un pourcentage, appuyez sur la touche Maj lorsque vous créez ou déplacez le repère.

Affichage ou masquage d'un repère

  1. Choisissez Affichage > Repères > Afficher les repères.

Alignement d'éléments sur les repères

  • Pour aligner des éléments sur les repères, sélectionnez Affichage > Options du mode Création > Repères > Magnétiser les repères.
  • Pour aligner les repères sur des éléments, sélectionnez Affichage > Options du mode Création > Repères > Accrocher les repères aux éléments.
Remarque :

Lorsque vous redimensionnez des éléments, tels que des éléments à positionnement absolu, des tableaux et des images, ils sont alignés sur les repères.

Verrouillage ou déverrouillage de tous les repères

Sélectionnez Affichage > Options du mode Création > Repères > Verrouiller les repères.

Affichage et déplacement d'un repère vers une position spécifique

  1. Maintenez le pointeur de la souris sur le repère afin d'afficher sa position.
  2. Double-cliquez sur le repère.
  3. Entrez la nouvelle position dans la boîte de dialogue Déplacer le repère et cliquez sur OK.

Affichage de la distance entre les repères

Appuyez sur la touche Ctrl (Windows) ou Commande (Macintosh) et déplacez le pointeur de la souris n'importe où entre les deux repères.
Remarque :

L'unité de mesure est la même que celle utilisée pour les règles.

Simulation du pli (zone visible) d'un navigateur Web

Choisissez Affichage > Options du mode Création >Repères, puis sélectionnez une taille de navigateur prédéfinie dans le menu.

Suppression d'un repère

Faites glisser le repère hors du document.

Modification des paramètres des repères

  1. Sélectionnez Affichage > Options du mode Création >Repères > Modifier les repères, définissez les options suivantes et cliquez sur OK.

    Couleur des repères

    Indique la couleur des lignes du repère. Cliquez sur la palette de couleurs et choisissez une couleur dans le Sélecteur de couleur ou tapez un nombre hexadécimal dans la zone de texte.

    Couleur distance

    Indique la couleur des lignes qui apparaissent comme des indicateurs de distance lorsque vous déplacez le pointeur de la souris entre les repères. Cliquez sur la palette de couleurs et choisissez une couleur dans le Sélecteur de couleur ou tapez un nombre hexadécimal dans la zone de texte.

    Afficher les repères

    Affiche les repères en mode Création.

    Magnétiser les repères

    Aligne les éléments d'une page sur les repères à mesure que vous déplacez ces éléments dans la page.

    Verrouiller les repères

    Verrouille les repères en place.

    Accrocher les repères aux éléments

    Aligne les repères sur les éléments sur la page à mesure que vous faites glisser les repères.

    Effacer tout

    Efface tous les repères de la page.

Utilisation des repères avec des modèles

Lorsque des repères sont ajoutés à un modèle Dreamweaver, toutes les instances du modèle héritent de ces repères. Les repères des instances de modèle sont toutefois traités comme des régions modifiables par les utilisateurs. Les repères modifiés dans les instances de modèle sont restaurés à leur emplacement d'origine chaque fois que l'instance est mise à jour avec le modèle principal.

Vous pouvez aussi ajouter vos propres repères aux instances d'un modèle. Les guides ajoutés de cette manière ne sont pas écrasés lorsque l'instance du modèle est mise à jour avec le modèle principal.

Utilisation de la grille de mise en forme

La grille affiche un système de lignes horizontales et verticales dans la fenêtre de document. Cette fonction est utile pour placer des objets de façon précise. Vous pouvez aligner automatiquement des éléments de page à positionnement absolu sur la grille en les déplaçant, et changer la grille ou définir le comportement d'alignement en indiquant des paramètres spécifiques pour la grille. L'alignement fonctionne, que la grille soit visible ou non.

Affichage ou masquage de la grille

Sélectionnez Affichage > Options du mode Création > Grille > Afficher la grille.

Activation ou désactivation de l'alignement

Sélectionnez Affichage > Options du mode Création > Grille > Aligner sur la grille.

Modification des paramètres de la grille

  1. Sélectionnez Affichage > Options du mode Création > Grille > Paramètres de la grille.

  2. Définissez les options et cliquez sur OK pour appliquer les modifications.

    Couleur

    Spécifie la couleur des lignes de la grille. Cliquez sur la palette de couleurs et choisissez une couleur dans le Sélecteur de couleur ou tapez un nombre hexadécimal dans la zone de texte.

    Afficher la grille

    Affiche la grille en mode Création.

    Aligner sur la grille

    Permet d'aligner les éléments de la page sur les lignes de la grille.

    Espacement

    Détermine l'espacement entre les lignes de la grille. Tapez une valeur et sélectionnez Pixels, Pouces ou Centimètres dans le menu.

    Afficher

    Détermine si les lignes de la grille apparaissent sous forme de lignes ou de pointillés.

    Remarque :

    Si l'option Afficher la grille n'est pas sélectionnée, la grille n'apparaît pas et aucune modification n'est visible.

Utilisation d'un tracé d'image

Vous pouvez utiliser un tracé de l'image comme guide pour reproduire une mise en page ayant été créée dans une application graphique telle qu'Adobe Freehand ou Fireworks.

Un tracé d'image est une image JPG, GIF ou PNG qui apparaît à l'arrière-plan de la fenêtre de document. Vous pouvez masquer cette image, définir son opacité et la déplacer.

Le tracé de l'image est uniquement visible dans Dreamweaver ; il n'est pas visible lorsque vous affichez la page dans un navigateur. Lorsque le tracé de l'image est visible, les véritables image et couleur d'arrière-plan de la page ne sont pas visibles dans la fenêtre de document, mais le sont lorsque la page est affichée dans un navigateur.

Placement d'un tracé de l'image dans la fenêtre de document

  1. Effectuez l'une des opérations suivantes :
    • Sélectionnez Affichage > Options du mode Création > Tracé de l'image > Charger.

    • Sélectionnez Fichier > Propriétés de la page, puis dans la catégorie Tracé de l'image, cliquez sur le bouton Parcourir situé en regard de la zone de texte Tracé de l'image.

  2. Accédez à votre fichier d'image, puis cliquez sur OK.

  3. Dans la boîte de dialogue Propriétés de la page, définissez la transparence de l'image en faisant glisser le curseur Transparence de l'image, puis cliquez sur OK.

    Pour passer à un autre tracé ou modifier à tout moment la transparence du tracé en cours, choisissez Fichier > Propriétés de la page.

Affichage ou masquage du tracé de l'image

Sélectionnez Affichage > Options du mode Création > Tracé de l'image > Afficher.

Déplacement d'un tracé d'image

  1. Sélectionnez Affichage > Options du mode Création > Tracé de l'image > Ajuster la position.

    • Pour définir avec précision la position du tracé de l'image, indiquez les valeurs des coordonnées dans les zones de texte X et Y.

    • Pour déplacer l'image par incréments de 1 pixel, utilisez les touches fléchées.

    • Pour déplacer l'image par incrément de 5 pixels, appuyez simultanément sur la touche Maj et sur l'une des touches fléchées.

Rétablissement de la position du tracé de l'image

  1. Sélectionnez Affichage > Options du mode Création > Tracé de l'image > Rétablir la position.

    Le tracé de l'image se replace dans le coin supérieur gauche de la fenêtre de document (0,0).

Alignement du tracé de l'image sur un élément sélectionné

  1. Sélectionnez un élément dans la fenêtre de document.
  2. Sélectionnez Affichage > Options du mode Création > Tracé de l'image > Aligner l'image avec la sélection.

    Le coin supérieur gauche du tracé de l'image est aligné avec le coin supérieur gauche de l'élément sélectionné.

Logo Adobe

Accéder à votre compte

[Feedback V2 Badge]