Remarque :

Vous ne pouvez pas exporter de fichiers aux formats FLV et F4V dans la version d’After Effects CC de juin 2014 et dans les versions ultérieures. Utilisez After Effects CC (juin 2013) ou une version antérieure pour exporter des fichiers aux formats FLV et F4V.

After Effects vous permet de réaliser le rendu et l’exportation de films dans des fichiers exploitables dans Adobe Flash Player. Les fichiers SWF sont au format natif de Flash Player. En revanche, les fichiers FLV ou F4V doivent être contenus dans (ou liés à) des fichiers SWF pour que Flash Player réussisse à les lire. Vous pouvez également exporter des compositions vers Flash Professional sous la forme de fichiers XFL.

Cette vidéo de la série After Effects CS5: Learn By Video présente une vue d’ensemble de l’exportation vers divers formats pour Flash Professional et Flash Player et explique l’utilisation et les problèmes courants de chaque format.

XFL

Les fichiers XFL sont des représentations de compositions exploitables dans Flash CS4 Professional ou version ultérieure. Ils sont l’équivalent XML des fichiers FLA.

SWF

Les fichiers SWF sont de petits fichiers lus dans Flash Player. Ils sont souvent utilisés pour la production de graphiques vectoriels animés (dessins animés, par exemple), des données audio et d’autres types de données sur Internet. Les fichiers SWF permettent en outre à l’utilisateur d’interagir, en cliquant par exemple pour suivre un lien hypertexte, contrôler une animation ou fournir des renseignements à une application Internet riche (RIA). Ils sont créés à partir de fichiers FLA.

FLV et F4V

Les fichiers FLV et F4V ne contiennent pas de graphiques vectoriels, mais uniquement des vidéos à base de pixels (pixellisées). Ces fichiers ne sont pas interactifs. Les fichiers FLA peuvent contenir des fichiers FLV et F4V et renvoyer vers ces fichiers, lesquels sont ensuite intégrés ou liés à des fichiers SWF lus dans Flash Player.

Exportation d’une composition vers Flash Professional sous forme de fichier XFL

Vous pouvez exporter une composition After Effects au format XFL pour la modifier ultérieurement et l’utiliser dans Flash CS4 Professional ou version ultérieure. Vous pouvez, par exemple, utiliser ActionScript dans Flash Professional pour ajouter une animation interactive à chacun des calques d’une composition After Effects.

Lorsque vous exportez une composition en tant que fichier XFL, After Effects tente d’exporter des calques et des images clés distincts, en préservant le plus d’informations possible pour l’utilisation directe dans Flash Professional. Si After Effects ne parvient pas à exporter un élément d’une composition sous forme de données non rendues dans un fichier XFL, il existe deux solutions : soit l’élément est laissé de côté, soit il est rendu et transformé en élément PNG ou FLV, selon que vous avez choisi ou non d’ignorer les fonctions non prises en charge.

A propos des fichiers XFL

Ils sont l’équivalent XML des fichiers FLA. Un fichier XFL est un dossier d’archive compressé qui contient un dossier de bibliothèque et un document XML (DOMDocument.xml) décrivant le fichier FLA. Le dossier de bibliothèque contient les éléments visés par le fichier XML. Lorsque vous ouvrez un fichier XFL dans Flash Professional, le logiciel en extrait ces éléments et les utilise pour créer le document FLA. Vous pouvez ensuite enregistrer ce document dans Flash Professional sous la forme d’un nouveau fichier FLA tout en conservant le fichier XFL intact.

Remarque :

Si vous avez besoin d’examiner ou d’éditer manuellement le contenu d’un fichier XFL, vous pouvez ouvrir le fichier d’archive compressé comme tout autre fichier .zip. Bien qu’il soit inutile de donner l’extension .zip au nom de fichier, cette manipulation peut simplifier l’extraction des fichiers pour l’examen manuel.

Cette vidéo de la série After Effects CS5: Learn By Video illustre l’exportation au format XFL.

Exportation d’une composition au format XFL

  1. Pour exporter la composition sélectionnée sous la forme d’un fichier XFL, choisissez la commande Fichier > Exporter > Adobe Flash Professional (XFL).

  2. Dans la boîte de dialogue Paramètres Adobe Flash Professional (XFL), choisissez le comportement d’After Effects en présence de calques dont les fonctions ne sont pas prises en charge :

    Ignorer

    Les calques comportant des fonctions non prises en charge ne sont pas inclus à la sortie XFL.

    Pixelliser

    Les calques aux fonctions non prises en charge sont pixellisés, c’est-à-dire restitués au format bitmap (dans un fichier FLV ou une séquence d’images PNG). Les vecteurs ne sont pas conservés. Les calques conservent ainsi leur aspect lors de l’utilisation du fichier XFL dans Flash Professional. En cas de pixellisation dans une séquence PNG, les images adjacentes identiques ne sont pixellisées qu’une fois dans un fichier PNG unique référencé plusieurs fois.

  3. (Facultatif) Cliquez sur le bouton Options de format, puis modifiez les paramètres utilisés pour la création de séquences PNG ou de fichiers FLV.

    Si vous cliquez sur le bouton Options de format alors que vous avez sélectionné l’option FLV dans le menu Format, la boîte de dialogue des paramètres d’exportation apparaît. En principe, vous ne devriez pas avoir à y modifier trop de paramètres, si ce n’est le débit. Les modifications apportées dans cette boîte de dialogue sont permanentes et seront réutilisées pour les exportations ultérieures. Restez donc prudent dans vos choix.

    Si vous souhaitez annuler la modification d’options de format, cliquez sur le bouton Valeurs par défaut dans la boîte de dialogue Paramètres Adobe Flash Professional (XFL).

  4. Dans la boîte de dialogue Exporter sous Adobe Flash Professional (XFL), choisissez un emplacement pour les fichiers de sortie.

Une fenêtre indique la progression de l’exportation pendant le traitement de la composition.

Lorsque After Effects crée un fichier XFL, il enregistre également un compte-rendu ([nom_de_fichier XFL] report.htm) dans le même dossier que le fichier XFL. Le compte-rendu indique :

  • si les calques aux fonctions non prises en charge ont été pixellisés ou ignorés ;

  • si chacun des éléments sources a été pixellisé (rendu) ou lié ;

  • si chacun des calques a été pixellisé (rendu) ou converti en un objet Flash natif.

Utilisation dans Flash Professional d’un document FLA créé à partir d’un fichier XFL

Le panneau Bibliothèque dans Flash Professional s’apparente au panneau Projet dans After Effects. Lorsque Flash Professional crée un document FLA à partir d’un fichier XFL, il organise les symboles, les dossiers et les séquences vidéo qui le composent dans le panneau Bibliothèque. Tous les éléments du panneau Bibliothèque portent un nom unique, même s’ils sont issus d’éléments nommés à l’identique dans After Effects, ce qui permet de les manipuler avec ActionScript. Conformément à ce critère de nom unique, After Effects ajoute des caractères de soulignement et des chiffres à de nombreux noms lors de la création du fichier XFL.

Lorsque Flash Professional crée un document FLA à partir d’un fichier XFL contenant des fichiers FLV, ces derniers sont incorporés au montage dans Flash. Il est souvent plus judicieux de créer un document FLA en déplaçant les fichiers vidéo vers un emplacement externe référencé par le fichier SWF pour une diffusion en continu de la vidéo. Vous pouvez retirer les fichiers FLV comme il se doit dans Flash Professional en supprimant la vidéo et en la réimportant à l’aide du composant FLVPlayback.

Remarque :

dans After Effects, le montage de la composition commence à l’image 0. Dans Flash Professional, le montage commence à l’image 1. C’est pourquoi le montage de la composition After Effects et le montage Flash correspondant semblent être décalés d’une image.

Dans After Effects, les formats des pixels d’une composition peuvent être différents de 1,0 (pixels carrés). En revanche, Flash Professional ne prend en charge que le format des pixels 1,0. Lors de l’exportation d’une composition au format XFL, le document FLA est un document à pixels carrés avec un nombre différent de pixels de sorte que le document présente le même aspect dans Flash Professional que la composition dans After Effects. Les valeurs d’échelle du fichier XFL conservent l’aspect des calques.

Conservation des fonctions et des données lors de l’exportation d’une composition au format XFL

L’exportation d’une composition sous forme de fichier XFL dans After Effects s’effectue en plusieurs étapes. A chacune d’elles, le logiciel essaie d’exporter un maximum d’informations des calques et de leurs fichiers source.

Si la composition utilise des fichiers PNG, JPEG et FLV comme sources pour ses calques, ces fichiers source sont intégrés à la sortie XFL (liés) à moins que les calques ne sollicitent des fonctions imposant à After Effects de transcoder les fichiers source ou de pixelliser les calques afin de les exporter au format XFL.

Remarque :

le transcodage est la conversion d’un fichier source d’un format à un autre (GIF en PNG, par exemple). La pixellisation consiste à convertir un calque en image bitmap en intégrant toutes les informations de modèle (telles que les vecteurs et images clés) à chaque image aplatie à base de pixels.

Etape 1 : la liaison des fichiers source n’est pas modifiée, dans la mesure du possible.

Pour que le fichier source d’un calque soit lié au fichier XFL, ce calque doit répondre aux critères suivants :

  • Le calque comporte un élément de métrage source, lequel utilise une séquence PNG ou JPEG ou un fichier FLV comme source. (Il ne s’agit pas d’un calque de texte, d’un calque de caméra, d’un calque d’éclairage ni d’un calque de forme.)

  • La cadence d’images de l’élément de métrage source est identique à celle de la composition.

  • La source du calque n’est pas raccourcie.

  • Le calque ne déborde pas sur la première ou la dernière image de la zone de travail de la composition.

  • Les seules propriétés définies pour le calque sont les suivantes : Position, Point d’ancrage, Opacité, Echelle et Rotation. Dans la mesure où les effets ajoutent des propriétés aux calques, ce critère suppose également qu’aucun effet ne soit appliqué au calque.

  • Aucun flou de mouvement, remappage temporel ou aucune interpolation d’images n’est appliqué au calque.

  • Le calque n’a pas de cache par approche.

  • Aucun calque de réglage n’est situé au-dessus du calque.

  • Les calques du dessus n’utilisent que le mode de fusion Normal.

  • L’option Préserver la transparence n’est pas définie pour le calque, et celui-ci est le calque supérieur.

  • Le calque n’est pas un calque 3D.

Etape 2 : les fichiers source restants sont convertis en séquences PNG ou en fichiers FLV, dans la mesure du possible.

Si le fichier source d’un calque ne peut pas être lié au fichier XFL pour la seule raison qu’il n’utilise pas de séquence PNG, de séquence JPEG ou de fichier FLV comme source, la source du calque est transcodée ou pixellisée dans une séquence PNG ou un fichier FLV, qui est intégré au fichier XFL. Le cas échéant, les images clés Position, Opacité, Echelle et Rotation du calque sont conservées et converties en images clés dans la sortie XFL. Les calques utilisant la même source dans After Effects et remplissant toutes les conditions de lien répertoriées ci-dessous partagent également une source commune dans le document créé dans Flash Professional. Les précompositions peuvent être pixellisées comme éléments sources.

Le fichier XFL créé à partir d’une composition conserve les informations d’animation pour les calques dans la composition. Les images clés pour les propriétés Position, Opacité, Echelle et Rotation sont converties en images clés dans Flash Professional, à raison d’une image clé par image pour chacune des propriétés animées. Seules les images clés de position 2D (x et y) et rotation 2D (z) sont converties.

Il est possible d’animer la propriété Point d’ancrage dans After Effects, à la différence du point de transformation dans Flash Professional. Dans Flash Professional, le point de transformation se trouve en haut à gauche du symbole. Les animations d’images clés pour les propriétés de transformation (dont le Point d’ancrage) dans After Effects sont converties en animations axées sur le centre de transformation du fichier XFL exporté.

Etape 3 : les calques restants sont pixellisés en tant que calques individuels, dans la mesure du possible.

Si un calque ne remplit pas les conditions nécessaires pour que son fichier source soit lié, transcodé ou pixellisé en un élément source, le calque proprement dit doit être pixellisé en tant que calque. La pixellisation d’un calque entraîne la perte de toutes ses informations d’images clés, puisque toutes les informations sont contenues dans les éléments mêmes de l’image pixellisée.

Un calque doit répondre aux critères suivants pour être pixellisé en calque individuel :

  • Le calque repose sur un élément de métrage vidéo (y compris un solide) ou est un calque de forme ou un calque de texte. (Il ne s’agit pas d’un calque de caméra, d’un calque d’éclairage ni d’un calque de forme.)

  • Aucun calque de réglage n’est situé au-dessus du calque.

  • Les calques du dessus n’utilisent que le mode de fusion Normal.

  • Le calque n’a pas de cache par approche.

  • L’option Préserver la transparence n’est pas définie pour le calque, et celui-ci est le calque supérieur.

  • Le calque n’est pas un calque 3D.

Etape 4 : les calques restants sont rendus et pixellisés dans des réserves.

Si un calque ne remplit pas les conditions nécessaires à sa pixellisation en calque individuel, il est rendu et pixellisé avec les autres calques d’un groupe (appelé réserve). Les réserves de calques pixellisés ensemble sont généralement des calques 3D, des calques composés grâce aux modes de fusion, des caches par approche et des calques associés à un calque de réglage.

Limitations de l’exportation d’une composition au format XFL

A l’ouverture d’un fichier XFL, Flash Professional doit charger en mémoire tous les éléments correspondants. Un message After Effects vous avertit si le contenu de la composition en cours d’exportation occupera plus de 580 Mo de mémoire, de même que si l’ouverture d’un fichier XFL dans Flash Professional prendra beaucoup de temps en raison d’une séquence PNG comptant plus de 1050 images. L’exportation d’une composition au format XFL qui dépasse ces limites demeure possible, mais l’ouverture du fichier XFL avec Flash Professional n’est pas garantie.

Remarque :

Pour prévenir tout ralentissement de chargement lié aux séquences comportant un nombre élevé de fichiers PNG, vous pouvez envisager un prérendu au format FLV des calques associés à des séquences PNG.

After Effects sollicite la version incorporée d’Adobe Media Encoder pour créer des fichiers FLV. Adobe Media Encoder ne peut pas créer de fichiers FLV dont les dimensions en pixels sont supérieures à 1920 x 1080.

Lorsque vous exportez une composition vers le format XFL à partir d’un projet 32 bpc, le rendu des couleurs dont les valeurs sont inférieures à 0 et supérieures à 1 ne produit pas les résultats qui préservent l’apparence de la composition dans After Effects. Vous ne devez travailler dans un projet 8 bpc ou 16 bpc que lorsque vous créez une composition que vous prévoyez d’exporter vers Flash Professional au format XFL.

Les données audio ne sont pas exportées dans le fichier XFL.

Rendu et exportation d’une composition sous la forme d’un fichier SWF

Les fichiers SWF sont de petits fichiers lus dans Flash Player. Ils sont souvent utilisés pour la production de graphiques vectoriels animés (dessins animés, par exemple), des données audio et d’autres types de données sur Internet. Les fichiers SWF permettent en outre à l’utilisateur d’interagir, en cliquant par exemple pour suivre un lien hypertexte, contrôler une animation ou fournir des renseignements à une application Internet riche (RIA). Ils sont créés à partir de fichiers FLA.

Lors de la réalisation du rendu et de l’exportation d’un film dans un fichier SWF, After Effects essaie de préserver au mieux les images vectorielles. Toutefois, les images pixellisées et certains effets, modes de fusion et flous de mouvement, ainsi que le contenu des compositions imbriquées ne peuvent pas être représentés sous la forme de vecteurs dans le fichier SWF et sont donc pixellisés.

Vous avez le choix entre ignorer ces composants non gérés (le fichier SWF comprend alors uniquement les fonctionnalités After Effects qui peuvent être converties en éléments SWF natifs) ou bien pixelliser les images contenant des fonctionnalités non gérées et les ajouter au fichier SWF en tant qu’images en mode point compressées au format JPEG (ce qui réduit les performances du fichier SWF).

Les données audio sont codées au format MP3 et ajoutées au fichier SWF en tant que flux audio.

Lorsque After Effects crée un fichier SWF, il enregistre également un compte-rendu ([nom_de_fichier SWF]R.htm) dans le même dossier que le fichier SWF. Le compte-rendu contient un lien vers le fichier SWF qui permet de prévisualiser le fichier final à l’aide du module externe Flash Player. Ouvrez le compte-rendu dans un navigateur pour visualiser le fichier SWF et connaître les éléments de la composition qui ne sont pas pris en charge.

Le fichier SWF exporté utilise chaque élément de la composition d’After Effects une seule fois, puis le référence pour une utilisation ultérieure, à condition que son contenu ne change pas. Si un calque est utilisé dans plusieurs images, chaque occurrence se rapporte au même objet, même si les propriétés de transformation du calque (comme Position) sont animées. Cependant, si le contenu du calque est modifié (si le masque du calque est animé ou l’élément de métrage source du calque est une vidéo), un objet est créé pour chaque image dans laquelle le calque est visible. Si plusieurs calques de la composition partagent le même élément de métrage source, la source est ajoutée une fois, puis elle est référencée pour chaque calque supplémentaire partageant la source. Si cette source est un fichier Illustrator, une séquence vidéo de film SWF est créée et référencée. Les caractères sont ajoutés une fois sous forme vectorielle, puis référencés sur toutes les images qui suivent, sauf si vous choisissez l’option Remplissage sur tracé dans le menu Fond et tracé. Dans ce cas, les caractères sont ajoutés sous forme vectorielle sur chaque image.

Remarque :

si la gestion des couleurs est activée pour le projet, les couleurs sont converties de l’espace colorimétrique de travail du projet dans l’espace colorimétrique sRGB IEC61966-2.1 de sortie. Cet espace colorimétrique de sortie est adapté aux films diffusés dans un navigateur Web (voir Gestion des couleurs).

  1. Sélectionnez la composition à exporter, puis choisissez Fichier > Exporter > Adobe Flash Player (SWF).
  2. Saisissez le nom du fichier (en vous assurant qu’il comporte l’extension .swf) ainsi que son emplacement, puis cliquez sur le bouton Enregistrer.
  3. Définissez les options appropriées, puis cliquez sur le bouton OK.

Dans un extrait de son livre Flash + After Effects, disponible sur le site Web Focal Press, Chris Jackson donne des conseils sur le rendu et l’exportation de fichiers SWF.

Paramètres d’exportation SWF

Qualité JPEG

Indique la qualité des images pixellisées. Plus la qualité est élevée, plus le fichier est volumineux. (Si vous sélectionnez l’option Pixelliser pour Fonctionnalités non prises en charge, le paramètre de qualité JPEG est utilisé pour toutes les images en mode point compressées au format JPEG qui sont exportées en SWF, y compris pour les celles générées à partir d’images de composition ou de fichiers Adobe Illustrator.)

Fonctionnalités non prises en charge

Indique si les fonctionnalités non prises en charge par le format SWF doivent être pixellisées. Choisissez l’option Ignorer pour supprimer les effets non gérés ou l’option Pixelliser pour effectuer le rendu de toutes les images contenant des fonctionnalités non gérées (telles que les images en mode point compressées au format JPEG) et les inclure dans le fichier SWF. Si vous choisissez l’option Pixelliser, le module d’exportation SWF pixellise les fichiers source de tous les calques de la composition (sauf ceux utilisant des fichiers Illustrator ou des solides comme métrage source) et des compositions imbriquées dont l’option Condenser transform. est activée.

Débit audio

Débit de l’élément audio exporté. Choisissez l’option Auto pour obtenir le débit le plus bas compte tenu des paramètres d’échantillonnage et de la couche. Plus le débit est élevé, plus la taille du fichier est importante. Les données audio d’un fichier SWF sont au format MP3.

Boucle continue

Indique que le fichier SWF exporté est lu en boucle. Désélectionnez l’option Boucle continue si vous envisagez de paramétrer la lecture en boucle à l’aide de code HTML destiné à contrôler Flash Player.

Empêcher la modification

Crée un fichier SWF ne pouvant pas être modifié par des applications telles que Flash Professional.

Inclure les noms d’objets

Incorpore les noms des calques, des masques et des effets au fichier, pour qu’ils puissent être utilisés en entrée dans les programmes ActionScript. Cette option augmente la taille du fichier Les objets pixellisés n’ont pas de nom.

Chaque masque est exporté en tant qu’objet SWF distinct. Le nom de chaque objet correspond au nom du calque suivi de celui du masque. Si tous les masques sont en mode Différence, un seul objet SWF et exporté avec le nom du calque. Chaque caractère de texte est exporté en tant qu’objet SWF distinct.

Aplatir le dessin Illustrator

Scinde tous les objets qui se chevauchent en portions ne se chevauchant pas. Lorsque vous sélectionnez cette option, vous n’avez pas besoin de vectoriser le texte Illustrator avant l’exportation (cette option prend en charge les fichiers source d’Adobe Illustrator 9.0 et des versions ultérieures).

L’aplatissement des dessins Illustrator comporte des avantages et des inconvénients. En effet, le texte est exporté correctement au format SWF ; il est donc inutile de le vectoriser. Les objets qui se chevauchent sont supprimés, si bien que les calques composites s’affichent de la même façon dans After Effects et dans le fichier SWF. Les extrémités, les sommets et les groupes de transparence s’exportent correctement, et la partie du dessin en dehors des traits de coupe, qui n’est pas visible dans le fichier SWF, n’est pas incluse. La taille des fichiers SWF ne s’en trouve cependant pas forcément réduite. En outre, l’aplatissement risque d’introduire des objets non pris en charge, qui seront ensuite ignorés ou pixellisés, et des bordures blanches peuvent apparaître autour de certains objets. Cette procédure est parfois lente, demande beaucoup de mémoire et se révèle souvent inefficace pour les dessins Illustrator complexes.

Inclure les liens Web de repère de calque

Fait en sorte que les repères de calques se comportent comme des liens Web. L’option Inclure les liens Web des marqueurs de calque ajoute des liens Web et une action Get URL au fichier SWF d’après les informations relatives aux repères de calque. Cette option ajoute également un libellé à chaque image SWF disposant d’un repère de calque. Vous pouvez définir la façon dont le navigateur ouvre le lien Web, avec des commandes cible standard comme « _blank » (voir Liens Web, liens de chapitre, signaux de départ et repères).

_blank

Le lien Web est chargé dans une nouvelle fenêtre du navigateur.

_parent

Le lien Web est chargé dans l’image parent de celle dans laquelle le fichier actuel est lu.

_self

Le lien Web est chargé dans l’image en cours.

_top

Le lien Web est chargé dans l’image supérieure de la fenêtre en cours.

_level0

Provoque le chargement d’un autre fichier SWF au niveau 0. Généralement, le fichier en cours est lu au niveau 0 ; il est remplacé si un autre fichier est chargé à ce niveau. L’adresse URL doit appeler un autre fichier SWF.

_level1

Provoque le chargement d’un autre fichier SWF au niveau 1 si l’adresse URL appelle un autre fichier SWF.

Fonctionnalités prises en charge dans les exportations au format SWF

Calques

Les calques de texte d’After Effects sont exportés au format SWF en tant que graphiques vectoriels. Les types et options de calque suivants ne sont pas pris en charge : caches par approche, calques 3D, caméras et lumières 3D, calques d’effets, calques de forme, Préserver la transparence, Condenser transform. et Flou de mouvement. L’option Remplissage sur tracé et la propriété d’animation Flou ne sont pas prises en charge, et seul le mode de fusion Normal est pris en charge. Les compositions imbriquées ne sont pas prises en charge et sont pixellisées.

Masques

Seuls les modes Addition et Différence sont pris en charge. Si un calque comporte plusieurs masques, ils doivent tous être dans le même mode. Les options de masque Opacité partielle et Inversé ne sont gérées qu’en mode Addition. L’option Contour progressif du masque n’est pas prise en charge. Une opacité partielle et des masques se chevauchant en mode Addition peuvent donner un résultat différent dans le fichier SWF et dans After Effects (voir Modes de masque).

Effets

Les effets Texte curviligne, Niveau audio et Spectre audio sont gérés pour une sortie au format SWF.

Toutes les options Texte curviligne sont prises en charge, sauf : Composite sur original, Remplissage sur tracé et le mode Différence.

Les traits dessinés par l’application des effets Spectre audio et Niveau audio sont convertis en vecteurs. Les fonctions suivantes non prises en charge sont ignorées : Couleur externe (seule la fonction Couleur interne est utilisée), Lissage et Composite sur original. De plus, seuls les traits dont l’épaisseur est uniforme sont inclus dans le fichier SWF. Si, par exemple, vous sélectionnez l’option Utiliser chemin polaire dans Spectre audio, les traits s’épaississent à partir du centre dans After Effects, mais leur épaisseur reste la même dans le fichier SWF.

Les niveaux audio risquent d’augmenter la taille du fichier SWF. Par conséquent, il est recommandé de diminuer la valeur Echantillons affichés pour l’effet Niveau audio ou la valeur Bandes de fréquence pour l’effet Spectre audio, ou encore de diminuer la cadence d’images afin de réduire la taille du fichier SWF.

Résolution

Les fichiers SWF sont toujours créés avec une résolution intégrale (taille de la composition) ; les images en mode point au format de compression JPEG sont rendues avec une résolution intégrale.

Fichiers Adobe Illustrator

Seuls les tracés avec contour et avec fond des espaces colorimétriques CMJN ou RVB sont pris en charge.

Les calques possédant des fichiers source Illustrator sont convertis en des éléments SWF correspondants, si le calque ne contient pas de masques ou si l’option Condenser transform. est activée pour ce calque. Les calques Illustrator contenant des masques ou dont l’option Condenser transform. est activée sont pixellisés. Le fichier SWF conserve les traits de coupe Illustrator. Bien qu’elle ne soit pas visible, la partie de l’image en dehors de ces traits est également incluse dans le fichier SWF, ce qui rend le fichier plus volumineux.

Le rapport sur l’exportation en format SWF fournit des informations sur les fonctions non prises en charge dans les fichiers Adobe Illustrator pour la première image dans laquelle le fichier Illustrator est visible. Les fonctions non prises en charge sont ignorées ou pixellisées (selon l’option choisie) pour toutes les images dans lesquelles le métrage est visible.

Rendu et exportation d’une composition sous la forme d’un fichier FLV ou F4V

Les fichiers FLV et F4V ne contiennent pas de graphiques vectoriels, mais uniquement des vidéos à base de pixels (pixellisées). Ces fichiers ne sont pas interactifs.

Les formats FLV et F4V sont des formats de conteneur et chacun d’eux est associé à un ensemble de formats vidéo et audio. Les fichiers FLV contiennent généralement des données vidéo codées à l’aide du module de compression On2 VP6 et des données audio codées grâce au module de compression audio MP3. En revanche, les fichiers F4V contiennent le plus souvent des données vidéo codées à l’aide des codecs vidéo H.264 et audio AAC.

Remarque :

After Effects CS4 et versions antérieures offraient également une option de codage des données vidéo dans les fichiers FLV à l’aide du codec vidéo Sorenson Spark.

Pour visionner un film à partir d’un fichier conteneur FLV ou F4V, vous disposez de plusieurs solutions :

  • Importer le fichier dans l’application de création Flash Professional et publier la vidéo dans un fichier SWF

  • Lancer la lecture du film dans Adobe Media Player (AMP)

  • Prévisualiser le film à l’aide d’Adobe Bridge

Remarque :

Les repères d’After Effects sont inclus dans un fichier FLV ou F4V final sous forme de signaux de départ. Pour transférer les images clés ou les valeurs des propriétés globales vers l’application de création Flash Professional depuis After Effects, exécutez le script Convert Selected Properties To Markers.jsx avant le rendu et l’exportation d’un fichier FLV ou F4V.

Vous effectuez le rendu et l’exportation d’un film au format de conteneur FLV ou F4V à l’aide de la file d’attente de rendu, comme vous le feriez avec tout autre format (voir Rendu et exportation à l’aide du panneau File d’attente de rendu).

Pour inclure une couche alpha dans la sortie FLV, utilisez le module de compression On2 VP6 et sélectionnez l’option Encoder couche alpha dans l’onglet Vidéo de la boîte de dialogue des paramètres d’exportation. Lors du codage de la transparence dans les fichiers FLV, After Effects prémultiplie les couches avec du noir (voir Interprétation de la couche alpha : prémultipliée ou directe).

Lorsque vous effectuez le rendu et exportez une composition vers le format F4V ou FLV à partir d’un projet 32 bpc, le rendu des couleurs dont les valeurs sont inférieures à 0 et supérieures à 1 ne produit pas les résultats qui préservent l’apparence de la composition dans After Effects. Pour éviter des résultats inattendus, vous pouvez travailler dans un projet 8 bpc ou 16 bpc lorsque vous créez une composition dont vous prévoyez d’effectuer le rendu et l’exportation vers le format F4V ou FLV. Une autre solution consiste à travailler dans un projet 32 bpc, à effectuer le rendu de la composition et à l’exporter vers un autre format, puis à convertir le fichier de sortie au format F4V ou FLV.

Ressources en ligne sur les formats FLV et F4V

Cette vidéo de la série After Effects CS5: Learn By Video illustre l’exportation aux formats FLV et F4V.

Dans son article « Encoding options for H.264 video » (Options de codage pour la vidéo H.264), disponible sur le site Web Adobe Developer Connection, Jan Ozer fournit des détails techniques et des astuces pour encoder de la vidéo à l’aide du codec vidéo H.264.

Kush Amerasinghe passe en revue les formats H.264 et F4V dans un article intitulé « H.264 for the rest of us », disponible sur le site Web Adobe Developer Connection.

Dans certains chapitres de son ouvrage Video with Adobe Flash CS4 Professional Studio Techniques disponible sur le site Web Peachpit, Robert Reinhardt fournit des informations sur les vidéos pour Flash Player. Dans le chapitre « Compression primer », il explique en détail les avantages et inconvénients des codecs vidéo On2 VP6 et H.264.

Vous trouverez davantage d’informations sur les formats FLV et F4V (y compris la spécification F4V) sur le site Web Adobe Developer Connection.

Sur le site Web Adobe Developer Connection, Fabio Sonnati fournit des recommandations pour le paramétrage des vidéos H.264 (F4V) pour périphériques mobiles.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne