A propos des fichiers et des éléments de métrage importés

Vous importez des fichiers source dans un projet sous forme d’éléments de métrage, puis vous les utilisez comme sources pour des calques. Un même fichier peut être la source de plusieurs éléments de métrage, chacun possédant ses propres paramètres d’interprétation. Chaque élément de métrage peut être utilisé comme source d’un ou plusieurs calques. Vous travaillez avec plusieurs ensembles de calques dans une composition.

Vous travaillez essentiellement avec les métrages dans le panneau Projet. Vous pouvez utiliser le panneau Métrage afin d’évaluer le métrage et d’effectuer des tâches d’édition simples, telles que le raccourcissement d’une durée de métrage.

Vous pouvez importer de nombreux types de fichier, ensembles de fichiers ou composants de fichier comme sources de métrages, y compris des fichiers d’images animées, des fichiers d’images fixes, des séquences d’images fixes et des fichiers audio. After Effects vous permet également de créer vos propres métrages, tels que des solides et des précompositions. Vous pouvez importer des métrages dans un projet à tout moment.

Lorsque vous importez des fichiers, After Effects ne copie pas les données d’image proprement dites dans le projet mais crée un lien de référence à la source de l’élément de métrage, ce qui maintient une taille de fichiers de projet relativement petite.

Lorsque vous supprimez, renommez ou déplacez un fichier source importé, vous supprimez également la référence à ce fichier. Dans ce cas, le nom du fichier source s’affiche en italique dans le panneau Projet et la colonne Chemin d’accès indique qu’il est absent. Si le métrage est disponible, vous pouvez rétablir le lien. Pour ce faire, vous devez généralement cliquer deux fois sur le métrage et sélectionner de nouveau le fichier.

Remarque :

Vous pouvez trouver des éléments de métrage pour lesquels il manque des éléments source en saisissant absent dans le champ de recherche du panneau Projet. Voir Recherche et filtrage dans les panneaux Montage, Projet et Effets et paramètres prédéfinis.

Pour réduire le temps nécessaire au rendu et améliorer les performances, il est préférable de préparer le métrage avant de l’importer dans After Effects. Par exemple, il est plus rapide de mettre une image fixe à l’échelle ou de la recadrer dans Photoshop avant de l’importer dans After Effects, plutôt que d’effectuer ces opérations directement dans After Effects. Vous gagnerez du temps en effectuant une opération d’un bloc dans Photoshop plutôt que de laisser After Effects effectuer cette même action plusieurs fois par seconde (une fois pour chacune des trames dans laquelle l’image apparaît).

Pour gagner du temps et réduire la taille ou la complexité d’un projet, importez un élément source comme élément de métrage unique, puis réutilisez-le autant de fois que nécessaire dans une composition. Il est toutefois occasionnellement pratique de dupliquer un élément de métrage et des les interpréter chacun différemment. Par exemple, vous pouvez utiliser le même métrage à deux cadences différentes.

Si vous utilisez une autre application pour modifier un métrage utilisé dans un projet, vos changements apparaîtront dans After Effects à l’ouverture suivante du projet ou la prochaine fois que vous sélectionnerez le métrage, puis Fichier > Recharger le métrage.

Remarque :

Pour remplacer l’élément de métrage source pour un calque par un autre élément de métrage sans toucher aux modifications apportées aux propriétés du calque, sélectionnez le calque, puis faites glisser le nouveau métrage sur le calque dans le panneau Montage tout en appuyant sur la touche Alt (Windows) ou Option (Mac OS).

Remarque :

Pour remplacer toutes les occurrences des métrages sélectionnés par un autre métrage, sélectionnez-les dans le panneau Projet, puis faites glisser le nouveau métrage sur l’élément sélectionné dans le panneau Projet tout en maintenant la touche Alt (Windows) ou Option (Mac OS) enfoncée.

Lorsque After Effects importe des séquences vidéo et audio dans certains formats, l’application traite et met en cache les versions des séquences auxquelles elle peut accéder lors de la génération de prévisualisations. Cette mise en cache accélère considérablement les prévisualisations, car les éléments vidéo et audio n’ont pas besoin d’être retraités avant chaque prévisualisation. 

Pour plus d’informations sur l’importation des éléments, visionnez ce didacticiel vidéo d’Andrew Devis sur le site Web de Creative COW.

Encodage natif et décodage des fichiers QuickTime

After Effects peut, en mode natif, décoder et coder des fichiers QuickTime (.mov) avec les codecs GoPro CineForm sous Mac OS et Windows. Cela signifie que vous n’avez pas besoin d’installer d’autres codecs pour utiliser et créer ces fichiers.

Dans MOV, After Effects prend en charge, en mode natif, l’importation des formats non compressés suivants :

  • DV, IMX, MPEG2, XDCAM, h264, JPEG, Avid DNxHD, Avid DNxHR, Apple ProRes, AVCI et GoPro CineForm

La prise en charge de l’exportation en mode natif est disponible pour les formats non compressés suivants :

  • Avid DNxHD, Avid DNxHR, DV et GoPro CineForm

Remarque :

Dans la mesure où After Effects peut, en mode natif, importer et exporter de nombreux codecs (répertoriés ci-dessus), QuickTime n’est pas nécessaire sous Windows. Pour plus d’informations sur les problèmes de compatibilité, lisez le billet de blog intitulé QuickTime on Windows (QuickTime sous Windows)

Formats d’importation pris en charge

Certaines extensions de noms de fichier telles que MOV, AVI, MXF, FLV et F4V correspondent à des formats de conteneur et non à des formats audio, vidéo ou image spécifiques. Les conteneurs peuvent comprendre des données codées à l’aide de divers schémas de compression et d’encodage. After Effects est en mesure d’importer ce type de fichiers. Toutefois, l’importation des données qu’ils contiennent n’est possible que si les codecs correspondants (en l’occurrence les décodeurs) sont installés.

Pour élargir l’éventail de fichiers pouvant être importés à l’aide d’After Effects, vous pouvez installer des codecs supplémentaires. De nombreux codecs doivent être installés sur le système d’exploitation (Windows ou Mac OS) et fonctionnent en tant que composants des formats QuickTime ou Vidéo pour Windows. Contactez le fabricant de votre matériel informatique ou logiciel pour plus de détails sur les codecs compatibles avec les fichiers créés par vos périphériques ou applications.

L’importation et l’utilisation de certains fichiers nécessite l’installation de modules externes d’importation supplémentaires (voir Modules externes).

Adobe Premiere Pro peut capturer et importer de nombreux formats qu’After Effects ne peut pas importer au format natif. Vous pouvez importer des données d’Adobe Premiere Pro dans After Effects de plusieurs façons (voir Utilisation d’Adobe Premiere Pro et d’After Effects).

Formats audio

  • Document sonore Adobe (ASND ; fichiers multipistes importés sous la forme d’une seule piste fusionnée)

  • AAC (Advanced Audio Coding, M4A)

  • AIF, AIFF (Audio Interchange File Format)

  • MP3 (MP3, MPEG, MPG, MPA, MPE)

  • Vidéo pour Windows (AVI ; requiert QuickTime sur Mac OS)

  • WAV (Waveform Audio Vector)

Formats d’images fixes

  • Adobe Illustrator (AI, AI4, AI5, EPS, PS ; pixellisation en continu)
  • Adobe PDF (PDF ; première page seulement ; pixellisation en continu)
  • Adobe Photoshop (PSD)
  • Bitmap (BMP, RLE, DIB)
  • Camera Raw (TIF, CRW, NEF, RAF, ORF, MRW, DCR, MOS, RAW, PEF, SRF, DNG, X3F, CR2, ERF)
  • Cineon/DPX (CIN, DPX avec fichiers DPX 8, 10, 12 et 16 bpc, y compris ceux comportant une couche alpha et un code temporel)
  • Discreet RLA/RPF (RLA, RPF ; 16bpc; importe les données de caméra)
  • EPS
  • GIF
  • JPEG (JPG, JPE)
  • Données de caméra Maya (MA)
  • Maya IFF (IFF, TDI ; 16bpc)
  • OpenEXR (EXR, SXR, MXR ; 32 bpc)
  • PICT (PCT)
  • Portable Network Graphics (PNG ; 16 bpc)
  • Radiance (HDR, RGBE, XYZE ; 32 bpc)
  • SGI (SGI, BW, RGB ; 16 bpc)
  • Softimage (PIC)

Remarque :

After Effects comprend des modules externes d’effets de couche 3D de fnord software, qui permettent d’accéder à plusieurs calques et couches de fichiers OpenEXR (voir Utilisation des couches dans les fichiers OpenEXR).

Remarque :

After Effects peut également lire les fichiers ZPIC correspondant aux fichiers PIC importés. Voir Importation et utilisation de fichiers 3D à partir d’autres applications.

  • Targa (TGA, VDA, ICB, VST)

  • TIFF (TIF)

Remarque :

Vous pouvez importer des fichiers d’un format d’image fixe quelconque sous la forme d’une séquence. Voir Préparation et importation d’images fixes.

Formats de vidéo et d’animation

  • GIF animé (GIF)
  • Avid DNxHR
  • HEVC (H.265) MPEG-4
  • Prise en charge des fichiers ARRIRAW en provenance des caméras ARRI ALEXA ou ARRIFLEX D-21
    Pour plus d’informations sur les fichiers ARRIRAW, consultez les questions fréquentes sur ARRIRAW sur le site Web du groupe ARRI.
  • CinemaDNG

Remarque : CinemaDNG est un sous-ensemble de CameraRAW. Un sous-ensemble de paramètres Camera Raw est accessible via « Plus d’options » dans la boîte de dialogue Interpréter le métrage. S’agissant de la gestion des couleurs avec CinemaDNG, les mêmes espaces colorimétriques qu’avec la fonction Camera Raw existante d’After Effects sont disponibles, à savoir : RVB Adobe, sRGB IEC619662.1, ColorMatch RGB et ProPhoto RGB.

  • DV (dans un conteneur MOV ou AVI ou sous forme de flux DV sans conteneur)
  • Electric Image (IMG, EI)
  • FLV, F4V
  • QuickTime (MOV ; 16bpc, uniquement pour les codecs dépourvus de décodeurs natifs)
  • Vidéo pour Windows (AVI, WAV ; requiert QuickTime sous Mac OS)

  • Windows Media File (WMV, WMA, ASF ; Windows uniquement)

  • XDCAM HD et XDCAM EX

  • RED (R3D)
  • Media eXchange Format (MXF)

MXF est un format de conteneurs. After Effects peut uniquement importer certains types de données contenues dans des fichiers MXF. After Effects peut importer la variante Op-Atom des fichiers MXF utilisés par les caméscopes Panasonic pour enregistrer des médias Panasonic P2. Il peut aussi importer des vidéos à partir de ces fichiers MXF utilisant les codecs AVC-Intra 50, AVC-Intra 100, DV, DVCPRO, DVCPRO50 et DVCPRO HD. After Effects permet également d’importer des fichiers XDCAM HD au format MXF (format MXF OP1), lequel contient de la vidéo MPEG-2 conforme au format XDCAM HD.

  • Formats MPEG-1, MPEG-2 et MPEG-4 : MPEG, MPE, MPG, M2V, MPA, MP2, M2A, MPV, M2P, M2T, M2TS (AVCHD), MP4, M4V, M4A
  • SWF (pixellisation en continu)

Formats de projets

  • Projets Adobe Premiere Pro 1.0, 1.5, 2.0, CS3, CS4, CS5, CS6 et CC (PRPROJ ; 1.0, 1.5, et 2.0 Windows uniquement) ou version ultérieure

  • Projets binaires Adobe After Effects 6.0 ou version ultérieure dans After Effects CS5 (AEP, AET)

  • After Effects 7 peut ouvrir des projets After Effects 3.0 via After Effects 7.

  • Projets XML Adobe After Effects CS4 ou version ultérieure (AEPX)

Le module externe Automatic Duck Pro Import AE est désormais fourni avec l’application et se nomme Pro Import After Effects. Il vous permet d’importer des fichiers AAF et OMF d’un système Avid, des fichiers XML de Final Cut Pro 7 ou version antérieure, ainsi que des fichiers de projet de Motion 4 ou version antérieure. Pour plus d’informations sur l’utilisation de Pro Import After Effects, consultez le Guide de l’utilisateur du module, accessible en sélectionnant Fichier > Importer > Pro Import After Effects, puis en cliquant sur le bouton Aide.

Vous pouvez également importer des projets Final Cut Pro dans Adobe Premiere Pro, puis importer des composants de ce projet dans After Effects.


Remarque :

 

  • After Effects peut également lire les fichiers EIZ correspondant aux fichiers EI importés. Voir Importation et utilisation de fichiers 3D à partir d’autres applications.
  • certains formats de données MPEG sont enregistrés dans des conteneurs dont le format n’est pas reconnu par After Effects ; les extensions .vob et .mod sont notamment concernées. Dans certains cas, vous pouvez modifier l’extension des fichiers afin de les importer dans After Effects sous un format reconnu. En raison des diverses versions existantes de ces conteneurs, leur compatibilité n’est pas garantie.
  • Pour de plus amples informations sur les formats MPEG, rendez-vous sur le site Web MPEG et sur la page qui y est consacrée sur Wikipedia.
  • Avant d’utiliser QuickTime, lisez cette alerte émise par l’United States Computer Emergency Readiness Team en avril 2016, qui recommande aux utilisateurs de Windows de désinstaller Apple QuickTime de leurs ordinateurs.
  • les fichiers R3D sont interprétés comme contenant des couleurs 32 bits par couche dans un espace colorimétrique HDTV (Enr. 709) non linéaire. Les réglages de couleur RED R3D Source Settings (réglages source RED R3D) ne conservent pas les valeurs de surluminosité. Les réglages de couleur effectués dans After Effects préservent les couleurs de surluminosité lorsque vous utilisez des couleurs 32 bits par couche. Afin d’éviter l’écrêtage, gérez l’exposition dans After Effects plutôt qu’à l’étape d’interprétation du métrage dans la boîte de dialogue RED R3D Source Settings.
  • After Effects peut importer des éléments Sony XDCAM HD s’ils ont été enregistrés dans des fichiers MXF. After Effects ne peut pas importer d’éléments XDCAM HD au format IMX. After Effects peut importer des éléments Sony XDCAM EX enregistrés sous forme de fichiers d’origine avec l’extension de nom de fichier .mp4 dans un répertoire BPAV. Pour plus de détails sur le format XDCAM, reportez-vous à ce document PDF sur le site Web de Sony.
  • les fichiers SWF sont importés avec une couche alpha. L’audio n’est pas conservé. Le contenu interactif et les animations définies par des scripts ne sont pas conservés. Les animations définies par des images clés dans le film principal, de niveau supérieur, sont conservées.

Importation de métrages

Vous pouvez importer des fichiers multimédia dans votre projet à partir de la boîte de dialogue d’importation ou en les faisant glisser. Les métrages importés apparaissent dans le panneau Projet.

Si la boîte de dialogue Interpréter le métrage apparaît après l’importation d’un élément de métrage, ce dernier contient une couche alpha non identifiée. Dans ce cas, vous devez choisir une méthode d’interprétation de couche alpha ou cliquer sur Evaluer pour opter pour une sélection automatique de la méthode appropriée par After Effects (voir Interprétation de la couche alpha : prémultipliée ou directe).

Importation de métrages à l’aide de la boîte de dialogue d’importation

  1. Choisissez Fichier > Importer > Fichier ou Fichier > Importer > Fichiers multiples, ou cliquez deux fois sur une zone vide du panneau Projet.

    Si vous importez plusieurs fichiers, vous pouvez effectuer l’étape suivante plusieurs fois de suite en sélectionnant la commande d’importation une seule fois.

    Remarque :

    Pour afficher uniquement les fichiers de métrage pris en charge (en excluant les fichiers de projet), sélectionnez l’option Tous les fichiers de métrage dans le menu Type de fichiers (Windows) ou Activer (Mac OS).

  2. Utilisez l’une des méthodes suivantes :
    • Sélectionnez un fichier, puis cliquez sur le bouton Ouvrir.

    • Cliquez sur les différents fichiers à sélectionner tout en maintenant la touche Ctrl (Windows) ou Commande (Mac OS) enfoncée, puis cliquez sur le bouton Ouvrir.

    • Cliquez sur un premier fichier, puis sur un deuxième tout en maintenant la touche Maj enfoncée pour sélectionner une série de fichiers. Cliquez ensuite sur le bouton Ouvrir.

    • (Windows uniquement) Sélectionnez un dossier entier, puis cliquez sur le bouton Importer le dossier.

    Remarque :

    si l’option Séquence est sélectionnée, les fichiers du dossier sont importés sous la forme d’une séquence d’images fixes.

Importation de métrages par glissement

Remarque :

Si vous souhaitez que les fichiers d’images fixes à calques que vous faites glisser dans After Effects soient toujours importés sous la forme d’une composition, sélectionnez Édition > Préférences > Importation (Windows) ou After Effects > Préférences > Importation (Mac OS), puis cliquez sur l’option Composition ou Composition – Conserver les tailles de calque dans le menu « Importer plusieurs éléments par glissement en tant que » (voir Importation d’une séquence d’images fixes sous forme de composition).

  • Pour importer un seul fichier, faites-le glisser à partir de l’Explorateur Windows (Windows) ou du Finder (Mac OS) vers le panneau Projet.
  • Pour importer le contenu d’un dossier sous la forme d’une séquence d’images fixes affichée dans le panneau Projet en tant qu’élément de métrage distinct, faites glisser le dossier de l’Explorateur Windows (Windows) ou du Finder (Mac OS) dans le panneau Projet.
  • Pour importer le contenu d’un dossier sous la forme d’éléments de métrage individuels affichés dans le panneau Projet d’un dossier, appuyez sur la touche Alt et faites glisser un dossier de l’Explorateur Windows (Windows) ou appuyez sur la touche Option et faites glisser un dossier du Finder (Mac OS) dans le panneau Projet.
  • Pour importer un fichier de rendu de sortie depuis le panneau File d’attente de rendu, faites glisser le module de rendu correspondant vers le panneau Projet.

Remarque :

si vous faites glisser un module de rendu depuis le panneau File d’attente de rendu vers le panneau Projet avant que le rendu ne soit effectué, After Effects crée un pseudo-élément de métrage. Les références au pseudo-élément de métrage sont remplacées automatiquement lors du rendu du module de rendu ; le pseudo-élément, lui, n’est pas remplacé.

Interprétation de métrages

After Effects utilise un ensemble de règles internes pour interpréter chaque métrage importé en évaluant au mieux le format des pixels, la cadence, le profil des couleurs et le type de couche alpha du fichier source. Si l’évaluation d’After Effects est erronée ou si vous souhaitez utiliser le métrage différemment, vous pouvez modifier les règles de tous les métrages d’un type donné en modifiant le fichier des règles d’interprétation (interpretation rules.txt). Vous pouvez également modifier l’interprétation d’un métrage donné à partir de la boîte de dialogue Interpréter le métrage.

Les paramètres d’interprétation fournissent à After Effects les informations suivantes sur chacun des métrages :

Remarque :

dans tous ces cas, les informations sont utilisées pour prendre des décisions sur le mode d’interprétation des données dans l’élément de métrage importé, pour fournir à After Effects des informations sur le métrage d’entrée. Les paramètres d’interprétation de la boîte de dialogue Interpréter le métrage doivent concorder avec ceux utilisés pour créer le fichier de métrage source. N’utilisez pas les paramètres d’interprétation pour tenter de spécifier des paramètres pour votre rendu de sortie final.

En règle générale, il n’est pas nécessaire de modifier les paramètres d’interprétation. Cependant, si vous utilisez un métrage de type peu familier, l’application After Effects peut avoir besoin d’informations supplémentaires pour interpréter correctement cet élément.

Vous pouvez utiliser les commandes de la zone Gestion des couleurs de la boîte de dialogue Interpréter le métrage pour indiquer à After Effects comment interpréter les informations de couleur d’un métrage spécifique. En règle générale, cette opération n’est nécessaire que si le métrage ne contient pas de profil de couleurs incorporé.

Une prévisualisation dans le panneau Métrage permet d’observer les résultats des opérations d’interprétation de métrage.

Jeff Almasol propose, sur son site Web redefinery, un script pratique pour évaluer plus précisément la conversion 3:2, la conversion 24Pa ou l’interprétation de couche alpha.

Remarque :

avant d’accepter les modifications, sélectionnez Prévisualisation dans la boîte de dialogue Interpréter le métrage afin d’obtenir un aperçu des résultats des paramètres définis dans cette boîte de dialogue.

Interprétation d’un métrage à l’aide de la boîte de dialogue Interpréter le métrage

  1. Sélectionnez un élément de métrage dans le panneau Projet, puis Utilisez l’une des méthodes suivantes :
    • Cliquez sur le bouton Interprétation de métrage situé en bas du panneau Projet.

    • Faites glisser l’élément de métrage sur le bouton Interprétation de métrage.

    • Sélectionnez Fichier > Interpréter métrage > Principal.

    • Appuyez sur les touches Ctrl + Alt + G (Windows) ou Commande + Option + G (Mac OS).

Interprétation d’un proxy à l’aide de la boîte de dialogue Interprétation de métrage

  1. Sélectionnez le métrage d’origine dans le panneau Projet, puis Utilisez l’une des méthodes suivantes :
    • Appuyez sur Alt (Windows) ou sur Option (Mac OS) et sur le bouton Interpréter métrage situé en bas du panneau Projet.

    • Appuyez sur Alt (Windows) ou sur Option (Mac OS) et faites glisser l’élément de métrage sur le bouton Interprétation de métrage.

    • Choisissez Fichier > Interpréter métrage > Proxy.

Application de paramètres d’interprétation de métrage à plusieurs métrages

Vous pouvez appliquer les mêmes paramètres à différents métrages en copiant les paramètres d’interprétation d’un métrage et en les appliquant aux autres.

  1. Dans le panneau Projet, sélectionnez l’élément comportant les paramètres d’interprétation à appliquer.
  2. Sélectionnez Fichier > Interpréter métrage > Se rappeler de l’interprétation.
  3. Sélectionnez un ou plusieurs métrages dans le panneau Projet.
  4. Sélectionnez Fichier > Interpréter métrage > Appliquer l’interprétation.

Modification des règles d’interprétation pour tous les éléments d’un même type

Le fichier des règles d’interprétation contient les règles qui spécifient la manière dont After Effects interprète les métrages. Dans la plupart des cas, vous n’avez pas à modifier ce fichier. Lorsque vous importez un métrage, After Effects recherche une correspondance dans le fichier des règles d’interprétation, puis détermine les paramètres d’interprétation du métrage. Vous pouvez modifier ces paramètres après importation à l’aide de la boîte de dialogue Interpréter le métrage.

Dans la plupart des cas, le nom du fichier de règles d’interprétation est interpretation rules.txt ; toutefois, certaines mises à jour d’After Effects installent un nouveau fichier de règles d’interprétation dont le nom indique le numéro de version mis à jour. L’application mise à jour utilise ce nouveau fichier. Si vous avez apporté des modifications à un ancien fichier de règles d’interprétation, il vous sera peut-être nécessaire de les reporter dans le nouveau fichier.

Emplacements du fichier de règles d’interprétation dans After Effects CC :

  • (Windows) <lecteur>\Utilisateurs\<nom_utilisateur>\AppData\Roaming\Adobe\After Effects <15.1>
  • (Mac OS) <lecteur>/Utilisateurs/<nom_utilisateur>/Library/Preferences/Adobe/After Effects <15.1>

Emplacement du fichier de règles d’interprétation dans les versions précédentes d’After Effects CC :

  • (Windows) <lecteur>\Utilisateurs\<nom_utilisateur>\AppData\Roaming\Adobe\After Effects <14.x>
  • (Mac OS) <lecteur>/Utilisateurs/<nom_utilisateur>/Library/Preferences/Adobe/After Effects <14.x>
  1. Quittez After Effects.
  2. Par mesure de précaution, effectuez une copie de sauvegarde du fichier des règles d’interprétation. Par défaut, ce fichier réside dans le même dossier que l’application After Effects.
  3. Ouvrez le fichier de règles d’interprétation dans un éditeur de texte.
  4. Modifiez les paramètres conformément aux instructions du fichier.

    Remarque :

    vous devez saisir un code de type de fichier à quatre caractères pour chaque type de métrage ou chaque module de compression. Si vous ne connaissez pas le code d’un fichier ou d’un module de compression, appuyez sur la touche Alt (Windows) ou Option (Mac OS) tout en sélectionnant le fichier dans le panneau Projet. Le code du type de fichier et celui du module de compression (si le fichier est compressé) s’affichent sur la dernière ligne de la description du fichier en haut du panneau Projet.

  5. Enregistrez le fichier interpretation rules.txt.

Interprétation de la couche alpha : prémultipliée ou directe

Les fichiers images avec des couches alpha stockent les informations de transparence d’une ou deux façons : directe ou prémultipliée. Bien que les couches alpha soient identiques, les couches de couleur diffèrent.

Avec des couches directes (ou sans cache), les informations de transparence sont uniquement stockées dans la couche alpha et non dans l’une des couches de couleur visibles. Avec des couches directes, les résultats de la transparence n’apparaissent que lorsque l’image s’affiche dans une application compatible.

Avec des couches prémultipliées (ou avec cache), les informations de transparence sont stockées dans la couche alpha de même que dans les couches RVB visibles, qui sont multipliées avec une couleur d’arrière-plan. Il est parfois dit que les couches prémultipliées ont un cache couleur. Les couleurs des zones semi-transparentes, telles que les contours progressifs, s’orientent vers la couleur d’arrière-plan en fonction de leur degré de transparence.

Certains logiciels permettent d’indiquer la couleur d’arrière-plan avec laquelle les couches sont prémultipliées. Si ce n’est pas le cas, la couleur d’arrière-plan est généralement le noir ou le blanc.

Les couches directes conservent des informations de couleur plus précises que les couches prémultipliées. Les couches prémultipliées sont compatibles avec un plus grand éventail de programmes, tels qu’Apple QuickTime Player. Souvent, le choix de l’utilisation des images avec des couches directes ou prémultipliées a été fait avant que vous receviez les éléments à modifier et à composer. Adobe Premiere Pro et Adobe After Effects reconnaissent les couches directes et les couches prémultipliées, mais lorsqu’un fichier contient plusieurs couches alpha, seule la première est reconnue.

L’interprétation correcte de la couche alpha au moment de l’importation d’un fichier permet d’éviter des problèmes tels que l’apparition de couleurs indésirables sur le contour d’une image ou la dégradation de la qualité d’image sur les contours de la couche alpha. Par exemple, si des couches sont interprétées comme directes alors qu’elles sont prémultipliées, les zones semi-transparentes conservent une nuance de la couleur d’arrière-plan. Si un défaut colorimétrique, tel qu’un halo, apparaît le long des contours semi-transparents dans une composition, essayez de changer de méthode d’interprétation.

Couches prémultipliées
Un métrage comportant des couches prémultipliées (en haut) apparaît avec un halo noir s’il est interprété comme Direct - sans cache (angle inférieur gauche). Si le métrage est interprété comme Prémultiplié (avec cache couleur) et que l’arrière-plan est noir, le halo n’apparaît pas (angle inférieur droit).

Vous pouvez utiliser l’effet Suppression de halo coloré pour supprimer les franges des zones semi-transparentes d’un calque en annulant sa multiplication.

Définition de l’interprétation de couche alpha pour un élément de métrage

  1. Dans le panneau Projet, sélectionnez un métrage.
  2. Sélectionnez Fichier > Interpréter métrage > Principal.
  3. Pour inverser les zones opaques et transparentes de l’image, sélectionnez l’option Inverser alpha.
  4. Dans la zone Alpha, sélectionnez une méthode d’interprétation :

    Evaluer

    Tente d’identifier le type de couche utilisé dans l’image. Si After Effects ne parvient pas à l’identifier avec certitude, un signal sonore retentit.

    Ignorer

    Ignore les informations de transparence de la couche alpha.

    Direct - sans cache

    Interprète les couches comme étant directes.

    Prémultiplié - cache couleur

    Interprète les couches comme étant prémultipliées. Utilisez la pipette ou le sélecteur de couleurs pour spécifier la couleur de l’arrière-plan avec laquelle les couches ont été prémultipliées.

Définition des préférences de couche alpha par défaut

  1. Choisissez Edition > Préférences > Importer (Windows) ou After Effects > Préférences > Importer (Mac OS).
  2. Choisissez des options dans le menu Interpréter alpha non libellé comme. Ce menu contient les mêmes options que la boîte de dialogue Interpréter le métrage. L’option Demander à l’utilisateur vous permet de spécifier l’ouverture de la boîte de dialogue Interpréter le métrage à chaque importation d’un métrage comprenant une couche alpha non libellée.

Cadence

La cadence des images d’une composition détermine le nombre d’images affichées par seconde et le mode de division du temps en images utilisé par l’échelle de temps et l’affichage des unités temporelles. En d’autres termes, la cadence d’images de la composition indique combien de fois par seconde les images sont prélevées (par échantillonnage) des éléments de métrage sources, ainsi que les fractions temporelles auxquelles les images clés peuvent être définies.

Remarque :

la boîte de dialogue Paramètres de composition d’After Effects contient un menu destiné au code temporel compensé ou non compensé. Dans les versions précédentes, cette option était un paramètre global à l’échelle du projet.

Elle est généralement déterminée par le type de sortie que vous souhaitez obtenir. En général, une vidéo NTSC est cadencée à 29,97 images par seconde (ips), une vidéo PAL à 25 ips et un film cinématographique à 24 ips. Selon le système de diffusion utilisé, la vidéo DVD peut avoir la même cadence que la vidéo NTSC ou PAL, ou une cadence de 23,976. Les animations et les vidéos destinées aux CD-ROM ou au Web ont souvent une cadence de 10 à 15 ips.

Remarque :

Si vous définissez une cadence de composition double de la cadence du format de sortie, After Effects risque d’afficher séparément chaque zone de métrage source entrelacé dans le panneau Composition. Ce processus vous permet de définir des images clés sur les zones individuelles et de gagner en précision lorsque vous animez des masques.

Lorsque vous effectuez le rendu d’un film pour sortie finale, vous pouvez choisir d’utiliser la cadence de la composition ou une autre cadence. La capacité de définir la cadence pour chaque module de rendu est utile lorsque vous utilisez la même composition pour créer une sortie pour plusieurs supports.

Prise en charge des métrages de cadence élevée

Dans la version d’avril 2017 d’After Effects CC, vous pouvez définir une cadence maximale de 999 ips pour n’importe quel champ. La mise à jour vous permet d’utiliser des cadences plus élevées pour le rendu, contrairement aux versions antérieures où la cadence maximale que vous pouviez définir pour une composition était de 99 ips.

Les différents métrages animés d’une composition peuvent également avoir leur propre cadence. Le rapport entre la cadence du métrage animé et celle de la composition détermine la régularité de la lecture du calque. Si, par exemple, le métrage et la composition ont tous les deux une cadence de 30 i/s, les cadres de la composition défilent au même rythme que les cadres du métrage. Si la cadence du métrage est de 15 i/s et que celle de la composition est de 30 i/s, deux images successives de la composition défilent pour chaque image de métrage. Ces exemples s’appliquent aux cas les plus simples et supposent qu’aucune extension temporelle ou fusion d’images n’a été appliquée au calque.

L’idéal est d’utiliser un métrage source correspondant à la cadence de la sortie finale. Ainsi, After Effects effectue le rendu de chaque image, et aucune image du résultat final n’est omise, dupliquée ou interpolée. Toutefois, si la cadence d’images du métrage source est légèrement différente de la cadence de sortie que vous recherchez (par exemple, un métrage de 30 images/seconde et une sortie finale de 29,97 images/seconde), vous pouvez faire correspondre la cadence du métrage à celle de la composition en la conformant.

L’alignement de la cadence d’un métrage modifie uniquement la référence utilisée par After Effects, pas le fichier d’origine. Lorsque vous conformez la cadence, After Effects modifie la durée interne des images sans toucher au contenu. Par la suite, la vitesse de lecture du métrage est différente. Par exemple, si la cadence passe de 15 i/s à 30 i/s, la lecture du métrage est deux fois plus rapide. Dans la plupart des cas, vous ne conformez la cadence que lorsque la différence entre le métrage et la sortie est minime.

Remarque :

la conformité risque de modifier la synchronisation du métrage visuel contenant une piste audio, car la cadence est liée à la durée de la vidéo, mais pas à la durée de la séquence audio. Si vous souhaitez étendre temporellement les séquences audio et vidéo, utilisez la commande Extension temporelle (voir la section Extension temporelle d’un calque). Les images clés appliquées au métrage source restent à leurs emplacements d’origine (conservant leur synchronisation au sein de la composition, mais pas le contenu visuel du calque). Il peut être nécessaire d’ajuster les emplacements des images clés après l’alignement d’un métrage.

Vous pouvez modifier la cadence d’images d’un film ou d’une séquence d’images fixes. Par exemple, vous pouvez importer une séquence de dix images fixes et spécifier une cadence de 5 images par seconde (ips) pour ce métrage ; la séquence aura alors une durée de deux secondes dans la composition.

Remarque :

Lorsque vous importez une séquence d’images fixes, la cadence appliquée est celle qui a été définie dans les préférences Elément de séquence de la catégorie Importation. Par défaut, cette cadence est de 30 images par seconde (i/s). Vous pouvez modifier la cadence des images après l’importation en réinterprétant le métrage (voir Interprétation de métrages.)

Les cadences d’images réduites ont tendance à donner un aspect irréel aux projets. C’est pourquoi de nombreux utilisateurs préfèrent cadencer leurs travaux de création à 24 images par seconde plutôt qu’à 29,97 images par seconde (norme de cadence pour la vidéo NTSC).

Remarque :

si vous supprimez la conversion 3:2 d’un métrage vidéo entrelacé, After Effects définit automatiquement la cadence du métrage sur quatre cinquièmes de la cadence d’origine. Lors de la suppression d’une conversion 3:2 dans une vidéo NTSC, la cadence résultante est de 24 i/s.

La cadence de la composition doit correspondre à celle du format de sortie final. Dans la plupart des cas, vous pouvez choisir un paramètre de composition prédéfini. En revanche, vous devez définir la cadence de chaque métrage sur celle du métrage source d’origine.

Trish et Chris Meyer partagent conseils et astuces sur la conformité des métrages sur une cadence d’images spécifique dans un article disponible au format PDF sur le site Web Artbeats.

Modification de la cadence d’un métrage

  1. Sélectionnez le métrage dans le panneau Projet.
  2. Sélectionnez Fichier > Interpréter métrage > Principal.
  3. Sélectionnez l’option Se conformer à la cadence, indiquez la nouvelle cadence dans la zone Images par seconde, puis cliquez sur le bouton OK.

Remarque :

A défaut d’utiliser la commande Interpréter métrage pour changer la cadence d’images d’un élément de métrage, vous pouvez allonger un calque d’après l’élément de métrage. Par exemple, allongez la durée d’un calque de 100,1 % pour convertir la cadence d’images entre 30 i/s et 29,97 i/s. L’allongement de la durée d’un calque modifie la vitesse d’audio ainsi que la vidéo (voir la section Extension temporelle d’un calque).

Modification de la cadence d’une composition

  1. Choisissez Composition > Paramètres de composition.
  2. Utilisez l’une des méthodes suivantes :
    • Choisissez un paramètre de composition prédéfini dans le menu Paramètre prédéfini.

    • Définissez la valeur Cadence.

Remarque :

Jeff Almasol propose, sur son site Web redefinery, un script pour définir la cadence d’images ainsi que la durée de la composition actuelle et de toutes les compositions qui y sont imbriquées.

Format des pixels et format d’image

Le format des pixels (ou rapport L/H de pixel) représente le rapport longueur/hauteur d’un pixel dans l’image. Format d’image (IAR) définit le rapport entre la largeur et la hauteur d’une image.

Rapport L/H des images
Format d’image 4:3 (gauche) et format d’image 16:9 plus grand (droite)

Tandis que la plupart des moniteurs d’ordinateur utilisent des pixels carrés, la grande majorité des formats vidéo, y compris ITU-R 601 (D1) et DV, utilisent des pixels rectangulaires non carrés.

Certains formats vidéo produisent le même format d’image, mais font appel à un format de pixels différent. Par exemple, certains numériseurs NTSC produisent un format d’image 4:3, avec des pixels carrés (format des pixels de 1) et une image de 640 x 480 pixels. Le format D1 NTSC génère le même format d’image 4:3 mais utilise des pixels non carrés (format des pixels de 0,91) et une image de 720 x 486 pixels. Les pixels D1, qui ne sont jamais carrés, ont une orientation verticale dans les systèmes générant des vidéos NTSC et une orientation horizontale dans les systèmes générant des vidéos PAL.

Si vous affichez des pixels non carrés sans altération sur un moniteur à pixels carrés, les images et les animations sont déformées. Les cercles, notamment, prennent une forme elliptique. En revanche, les images s’affichent correctement sur les moniteurs vidéo. Lorsque vous importez un métrage source D1 NTSC ou DV dans After Effects, l’image apparaît légèrement plus large que sur un système D1 ou DV (les éléments PALD1 semblent légèrement plus étroits). L’effet inverse se produit lorsque vous importez un métrage anamorphique sur un grand écran D1/DV NTSC ou D1/DV PAL. Les formats vidéo grand écran permettent d’obtenir un rapport L/H de 16:9.

Remarque :

pour prévisualiser les pixels non carrés sur un écran d’ordinateur, cliquez sur le bouton Activer/désactiver la correction du format des pixels en bas du panneau Composition. La qualité de la correction du format des pixels pour les prévisualisations dépend de la préférence Qualité du zoom définie dans la catégorie Prévisualisations (voir Préférences de qualité du visualiseur).

Pixels carrés et non carrés
Pixels carrés et non carrés

A. Pixels carrés et rapport L/H des images 4:3 B. Pixels non carrés et rapport L/H des images 4:3 C. Pixels non carrés affichés sur un écran à pixels carrés 

Lorsqu’un métrage contient des pixels non carrés, After Effects affiche le format des pixels en regard de la vignette de l’image du métrage dans le panneau Projet. Vous pouvez modifier l’interprétation du format des pixels de chaque métrage dans la boîte de dialogue Interpréter le métrage. En veillant à ce que tous les métrages soient correctement interprétés, vous pouvez associer des métrages possédant des formats de pixels différents au sein d’une même composition.

After Effects accède directement en lecture et en écriture au format des pixels des séquences QuickTime. Par exemple, si vous importez une séquence dont la capture a été effectuée au format grand écran (DV 16:9), After Effects la configure correctement automatiquement. De la même manière, les fichiers AVI et PSD contiennent des informations qui indiquent explicitement le format de pixels des images.

Si un métrage ne contient pas d’informations indiquant de manière explicite le format de pixels de l’image, After Effects se base sur les dimensions en pixels du cadre du métrage pour évaluer ce format. Lorsque vous importez un métrage avec les dimensions D1 de 720 x 486 pixels ou des dimensions DV de 720 x 480 pixels, After Effects interprète automatiquement ce métrage comme D1/DV NTSC. Lorsque vous importez un métrage avec les dimensions D1 ou DV de 720 x 576 pixels, After Effects interprète automatiquement ce métrage comme D1/DV PAL. Cependant, vous pouvez vous assurer que tous les fichiers sont interprétés correctement en vérifiant le contenu du panneau Projet ou de la boîte de dialogue Interpréter le métrage.

Remarque :

veillez à rétablir la valeur Pixels carrés pour le format des pixels lorsque vous importez un fichier à pixels carrés de dimensions D1 ou DV (par exemple, une image de 720 x 480 pixels).

Le paramètre de format des pixels de la composition doit correspondre au format des pixels du format de sortie final. Dans la plupart des cas, vous pouvez choisir un paramètre de composition prédéfini. En revanche, vous devez définir le format des pixels de chaque élément de métrage sur celui du métrage source d’origine.

Trish et Chris Meyer réunissent des conseils et des astuces sur le format des pixels, dans deux documents PDF, sur le site Web Artbeats :

Chris Pirazzi livre, sur le site Web Lurker’s Guide to Video, de nombreux détails techniques sur les formats de pixels.

Mise à niveau des formats de pixels aux valeurs appropriées

After Effects CS3 et les versions antérieures utilisaient des formats de pixels pour des formats vidéo de définition standard qui ignoraient le concept d’ouverture propre. En ne tenant pas compte du fait qu’une ouverture propre diffère d’une ouverture de production dans une vidéo de définition standard, le format des pixels utilisé par After Effects CS3 et les versions antérieures était légèrement erroné. Les formats de pixels incorrects provoquent une légère déformation de certaines images.

Remarque :

L’ouverture propre correspond à la partie de l’image ne contenant ni artefacts, ni déformations visibles sur les bords d’une image. L’ouverture de production, quant à elle, correspond à l’image entière.

Dans un article sur le site Web d’Adobe, Todd Kopriva récapitule les informations à propos des formats de pixels corrigés.

Le tableau suivant fournit des informations sur les valeurs de format des pixels dans After Effects :

format

valeur dans After Effects CS4 et versions ultérieures

valeur précédente

D1/DV NTSC

0.91

0.9

D1/DV NTSC Grand écran

1.21

1.2

D1/DV PAL

1.09

1.07

D1/DV PAL Grand écran

1.46

1.42

Cette disparité est limitée à ces anciens formats de définition standard pour lesquels l’ouverture propre diffère de l’ouverture de production. Elle n’existe pas avec les formats plus récents.

Les nouveaux projets créés dans After Effects CS4 ou version ultérieure utilisent, par défaut, le format de pixels approprié.

Les projets et les compositions créés dans After Effects CS3 ou version antérieure sont mis à niveau de sorte qu’ils adoptent les formats de pixels adéquats dès leur ouverture dans After Effects CS4 ou version ultérieure.

Remarque :

si vous disposez d’un fichier de règles d’interprétation personnalisées, pensez à le mettre à jour avec les bonnes valeurs de format de pixels.

Si vous utilisez des métrages à pixels carrés conçus pour remplir l’image dans une composition ne contenant pas de pixels carrés, il se peut que le changement des formats de pixels provoque une différence de comportement. Par exemple, si vous avez créé précédemment des métrages à pixels carrés 768 x 576 à utiliser dans une composition PAL D1/DV, créez dès à présent ces métrages avec des pixels carrés de 788 x 576.

Les paramètres de composition prédéfinis pour les équivalents en pixels carrés des formats de définition standard ont été modifiés comme suit :

format

dimensions de pixel dans After Effects CS4 et versions ultérieures

dimensions de pixel précédentes

équivalent de NTSC D1 en pixels carrés

720x534

720x540

équivalent de NTSC D1 Grand écran en pixels carrés

872x486

864x486

équivalent de PAL D1/DV en pixels carrés

788x576

768 x 576

équivalent de PAL D1/DV Grand écran en pixels carrés

1050x576

1024x576

Modification de l’interprétation du format des pixels d’un métrage

  1. Sélectionnez un métrage dans le panneau Projet.
  2. Sélectionnez Fichier > Interpréter métrage > Principal.
  3. Choisissez un format dans le menu Format des pixels et cliquez sur le bouton OK.

Modification du format des pixels d’une composition

  1. Choisissez Composition > Paramètres de composition.
  2. Utilisez l’une des méthodes suivantes :
    • Choisissez un paramètre de composition prédéfini dans le menu Paramètre prédéfini.

    • Choisissez une valeur dans le menu Format des pixels.

Formats de pixels courants

Format des pixels

Utilisations

Pixels carrés

1.0

La résolution d’image du métrage est de 640 x 480 ou 648 x 486, le métrage est au format 1 920 x 1 080 HD (pas HDV ou DVCPRO HD), au format 1 280 x 720 HD ou HDV ou a été exporté d’une application qui ne prend pas en charge les pixels non carrés. Ce paramètre peut également convenir pour un métrage transféré depuis un film ou pour des projets personnalisés.

D1/DV NTSC

0.91

La résolution d’image du métrage est de 720 x 486 ou 720 x 480, et la sortie finale doit être au format d’image 4:3. Ce paramètre convient également aux éléments exportés depuis une application qui fonctionne avec des pixels non carrés, notamment une application d’animation 3D.

D1/DV NTSC Grand écran

1.21

La résolution d’image du métrage est de 720 x 486 ou 720 x 480, et la sortie finale doit être au format d’image 16:9.

D1/DV PAL

1.09

La résolution d’image du métrage est de 720 x 576, et la sortie finale doit être au format d’image 4:3.

D1/DV PAL Grand écran

1.46

La résolution d’image du métrage est de 720 x 576, et la sortie finale doit être au format d’image 16:9.

Anamorphique 2:1

2.0

Le métrage a été tourné avec un objectif anamorphoseur ou a été transféré par anamorphose à partir d’une image de film présentant un format 2:1.

HDV 1080/DVCPRO HD 720, Anamorphique HD 1080

1.33

La résolution d’image du métrage est de 1 440 x 1 080 ou 960 x 720, et la sortie finale doit être au format d’image 16:9.

DVCPRO HD 1080

1.5

La résolution d’image du métrage est de 1 280 x 1 080, et la sortie finale doit être au format d’image 16:9.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne