Gestione dei sottotitoli in Premiere Pro

Premiere Pro offre una serie completa di funzioni che consentono di modificare i sottotitoli, crearne di nuovi ed esportarli per tutti i formati supportati.

Potete importare e visualizzare i sottotitoli codificati, nonché modificare facilmente il testo, il colore, lo sfondo e la temporizzazione. Terminate le modifiche, potete esportare i file di sottotitoli codificati come un file “collaterale”, incorporarli in un filmato QuickTime o un file MXF o masterizzarli nel video.  

Oltre ai sottotitoli codificati, Premiere Pro supporta anche l’importazione di file di sottotitoli aperti da masterizzare come sottotitoli.

Importare e visualizzare i sottotitoli

Premiere Pro consente di importare file in cui sono incorporati dei sottotitoli codificati, o file “collaterali” di sottotitoli codificati.

Potete importare i file nel progetto in Premiere Pro proprio come importereste qualsiasi altro file mediante una delle seguenti opzioni:

  • Importare file di sottotitoli incorporati o file “collaterali” di sottotitoli scegliendo File > Importa
  • Importare dal Browser multimediale mediante il menu di scelta rapida del file

Visualizzare i sottotitoli nel monitor Sorgente o Programma

Quando importate clip di sottotitoli in un progetto, i sottotitoli vengono visualizzati come blocchi di sottotitoli nella scheda Sottotitoli.

Per visualizzare i sottotitoli nel monitor Sorgente o Programma, effettuate una delle seguenti operazioni:

  • Fate clic su “+” nella parte inferiore a destra di un monitor per aprire l’editor dei pulsanti, selezionate il pulsante Visualizzazione sottotitoli e fate clic su OK. In alternativa, potete aggiungere il pulsante Sottotitoli codificati alla barra dei pulsanti trascinandolo dall’editor pulsanti. Potete anche assegnare delle scelte rapide da tastiera a tali comandi.
  • Nel menu a comparsa del pannello Monitor sorgente o Monitor programma, fate clic sull’icona a forma di chiave inglese e selezionate Visualizzazione sottotitoli > Abilita.
Visualizzazione dei sottotitoli codificati nel monitor Sorgente o Programma
Visualizzazione dei sottotitoli codificati nel monitor Sorgente o Programma

Note importanti

  • Potete attivare o disattivare la visualizzazione dei sottotitoli.
  • Potete selezionare lo standard dei sottotitoli per una clip di sottotitoli caricata nel monitor Sorgente. Nel monitor Sorgente, fate clic sull’icona a forma di chiave inglese e selezionate Visualizzazione sottotitoli > Impostazioni. Ad esempio, potete selezionare gli standard per sottotitoli CEA-608 o CEA-708 e impostare il canale o servizio che desiderate visualizzare.
  • Una clip di sottotitoli codificati associata al video si comporta come una clip di canale audio collegata. La clip di testo è rappresentata negli indicatori sorgente della timeline e può essere attivata/disattivata o collegata a qualsiasi traccia video come qualsiasi altra clip video.
  • Quando una traccia viene espansa, i blocchi dei sottotitoli presenti in una clip di sottotitoli sono visibili assieme agli indicatori Fine sottotitolo che indicano l’inizio e la fine dei blocchi dei sottotitoli.

Creare o modificare i sottotitoli

Pannello Sottotitoli in Premiere Pro
Pannello Sottotitoli in Premiere Pro

A. Filtra contenuto sottotitolo B. Barra degli strumenti di formattazione C. Blocchi di testo modificabili D. Aggiungere ed eliminare blocchi di sottotitoli 

Creare i sottotitoli

Premiere Pro consente di creare i sottotitoli da zero. Potete aggiungere il testo, formattarlo e specificarne la posizione e il colore.

  1. Scegliete File > Nuovi sottotitoli.

    Viene aperta la finestra di dialogo Nuovi sottotitoli con le impostazioni video. Queste sono impostate da Premiere Pro in base alla sequenza aperta. Accettate le impostazioni video predefinite e fate clic su OK.

    Nota:

    Accertatevi che la frequenza fotogrammi del file dei sottotitoli che state creando corrisponda a quella della sequenza in questione.

  2. Nella finestra di dialogo Nuovi sottotitoli, scegliete il flusso e lo standard di sottotitoli appropriati. Premiere Pro aggiunge un nuovo file di sottotitoli nel pannello Progetto.

  3. Per aggiungere del testo al file dei sottotitoli, fate doppio clic sul file nel pannello Progetto. In alternativa potete aprire il pannello Sottotitoli da Finestra > Sottotitoli.

  4. Nel pannello Sottotitoli, digitate il testo dei sottotitoli. Usate gli strumenti di formattazione per specificare la posizione, modificare il colore del testo e il colore di sfondo dei sottotitoli. Potete anche applicare effetti di formattazione come sottolineato e corsivo.

  5. Per aggiungere altri blocchi di sottotitoli, fate clic su Aggiungi sottotitolo (+) in basso a destra nel pannello Sottotitoli. Per eliminare un blocco di sottotitoli, selezionatelo e fate clic su Elimina sottotitolo (-).

  6. Trascinate il file dei sottotitoli sulla sequenza sorgente nella timeline sopra la clip sorgente desiderata nella sequenza.

Modificare i sottotitoli

Immaginate di avere un programma che contiene già sottotitoli codificati. Potrebbe essere necessario creare una diversa versione del programma, con una durata più breve per esempio, per aggiungere più annunci pubblicitari.

Seguite questi passaggi per modificare un file di sottotitoli in Premiere Pro:

  1. Selezionate il file di sottotitoli per modificarlo nel pannello Timeline.

  2. Aprite il pannello Sottotitoli (Finestra > Sottotitoli) per visualizzare le didascalie.

  3. Nel pannello Sottotitoli potete modificare le parole delle clip di sottotitoli esistenti. Un’interfaccia utente intuitiva consente inoltre di modificare la temporizzazione e la formattazione, l’allineamento e il colore del testo.

  4. Le clip di testo sono anche visibili dalla timeline, da cui potete regolare i sottotitoli per sincronizzarli con l’oggetto multimediale dopo tagli, eliminazioni con scarto e ridisposizione dei segmenti.

Esportare i sottotitoli

Dopo aver modificato o creato i file di sottotitoli, potete esportare la sequenza contenente i sottotitoli da Premiere Pro o Adobe Media Encoder mediante la finestra di dialogo Impostazioni di esportazione. In alternativa, potete esportare su nastro la sequenza contenente i sottotitoli utilizzando hardware di terze parti che supporta la codifica di sottotitoli codificati.

Esportare i sottotitoli da Premiere Pro o Adobe Media Encoder

  1. Caricate una risorsa di sottotitoli codificati nel Monitor sorgente o selezionatela nel panello Progetto. Potete anche selezionare una sequenza nel pannello Progetto oppure avere il pannello Timeline attivo.

  2. Scegliete File > Esporta > Oggetto multimediale.

  3. Nella finestra di dialogo Impostazioni di esportazione, specificate le seguenti opzioni nella scheda Sottotitoli.

    Opzioni di esportazione

    Selezionate una delle seguenti opzioni di esportazione:

    • Crea file collaterale
    • Masterizza sottotitoli nel video
    • Incorpora nel file di output   

    Formato file

    Selezionate uno dei seguenti formati di file per esportare i dati dei sottotitoli codificati:

    • File sottotitoli codificati Scenarist (.scc)
    • File MacCaption VANC (.mcc)
    • SMPTE Timed Text (.xml)
    • Sottotitolo EBU N19 (.stl)

    Nota: l’opzione predefinita per le aree NTSC è SMPTE Timed Text; per le aree PAL è EBU N19.

    Potete anche esportare i file di dati per sottotitoli codificati in un file di sottotitoli aperti (formato file SRT):

    • Formato sottotitoli SubRip (.srt)

    Frequenza fotogrammi

    A seconda del formato scelto, un elenco di frequenze di fotogrammi supportate è visualizzato nel menu a comparsa Frequenza fotogrammi. Una frequenza di fotogrammi predefinita viene scelta in base alla frequenza di fotogrammi nota della sequenza che state esportando.

    Fate clic su Esporta per esportare il video con i dati dei sottotitoli. 

Gestire i sottotitoli incorporati

Premiere Pro supporta l’importazione e la decodifica dei sottotitoli incorporati nei file MOV e MXF.

Importazione di file multimediali con sottotitoli incorporati

Potete importare i file multimediali contenenti i sottotitoli incorporati come qualsiasi altro tipo di file, da File > Importa oppure dal browser multimediale. Premiere Pro importa automaticamente nel progetto i dati dei sottotitoli codificati incorporati.

Ad esempio, se importate una clip QuickTime che contiene sottotitoli incorporati, questi vengono automaticamente importati. Se una clip QuickTime dispone di un file di sottotitoli “collaterale”, potete importare quest’ultimo come qualsiasi altro file.

Per rilevare e importare automaticamente i dati dei sottotitoli incorporati in un file multimediale, selezionate Inserisci sottotitoli durante importazione nella sezione File multimediali della finestra di dialogo Preferenze.

Nota:

Per ottimizzare le prestazioni, Premiere Pro analizza il file alla ricerca di dati di sottotitoli solo la prima volta che lo aprite e non ripete tale scansione se il file viene aperto di nuovo successivamente.

Modifica dei sottotitoli incorporati

Per modificare un file di sottotitoli incorporati in Premiere Pro si segue la stessa procedura utilizzata per creare i file di sottotitoli separati. Quando modificate un file di sottotitoli incorporati, le modifiche vengono applicate solo nel progetto e il file sorgente non viene modificato.

Esportazione di file multimediali con sottotitoli incorporati

Durante l’esportazione, potete scegliere di mantenere i sottotitoli incorporati o dividerli in un file collaterale separato.

Per esportare i sottotitoli solo come file collaterale separato, selezionate il file dei sottotitoli nel pannello Progetto e scegliete File > Esporta > Sottotitoli.

Per esportare i file multimediali con sottotitoli incorporati, selezionate la sequenza di destinazione selezionata nella timeline e scegliete File > Esporta > File multimediali. Premiere Pro apre la finestra di dialogo Impostazioni di esportazione.

Nella finestra di dialogo Impostazioni di esportazione, per Formato selezionate QuickTime o MXF. Nella scheda Sottotitoli, per Opzioni di esportazione selezionate Incorpora nel file di output.

Gestire i sottotitoli masterizzati

Premiere Pro permette di masterizzare permanentemente i sottotitoli nel video. I sottotitoli masterizzati sono sempre visibili, anche se non si attiva la funzione di sottotitoli del televisore o dispositivo di streaming.

Premiere Pro supporta la masterizzazione dei sottotitoli sia codificati che aperti durante l’esportazione del video.

Se importate dei file SRT e XML che contengono dati di sottotitoli aperti, Premiere Pro li converte automaticamente in file di sottotitoli codificati CEA-708 CC1. Potete quindi modificare e masterizzare i sottotitoli nell’esportazione con Premiere Pro o Adobe Media Encoder.

Nella finestra di dialogo Impostazioni di esportazione, per Formato di esportazione selezionate Masterizza sottotitoli nel video.

Nota:

non è possibile modificare i sottotitoli masterizzati nel video.

Creare sottotitoli con applicazioni di terze parti

Se usate applicazioni di terze parti per creare sottotitoli, quello che segue è un tipico flusso di lavoro che potete seguire:

Fase 1: Esportare la sequenza in un’applicazione esterna per creare sottotitoli

Una volta completato il montaggio video e audio in Adobe Premiere Pro, potete esportare la sequenza come filmato di riferimento in un’applicazione per sottotitoli esterna.

Questo filmato può essere inviato a un’agenzia sottotitoli o a uno specialista, dove il filmato viene utilizzato come riferimento per creare da zero una traccia sottotitoli codificati. Un’applicazione di terze parti di sottotitoli codificati, come MacCaption di CPC, consente di creare da zero una traccia di sottotitoli codificati e di codificare quindi i dati dei sottotitoli codificati nel formato necessario.

Fase 2: Importare i file dei sottotitoli codificati in Premiere Pro

Quando ricevete un file di sottotitoli codificati da un’applicazione esterna potete importare il file nel progetto in Premiere Pro. Premiere Pro supporta l’importazione di file di sottotitoli codificati in formati nomefile .mcc, .scc, .xml, oppure .stl.

Quando importate un file collaterale di sottotitoli codificati nel progetto, viene creata una clip solo video contenente i blocchi di testo dei sottotitoli codificati. Potete apportate ulteriori regolazioni ai blocchi di testo per mantenerli in sincronizzazione con gli oggetti multimediali, come desiderato.

Un file collaterale di sottotitoli codificati contiene più flussi di sottotitoli, ad esempio CC1 o CC2. Quando tale clip contenente più flussi di sottotitoli viene aggiunta a una sequenza, la timeline mostra elementi di traccia separati per ogni flusso. Per passare da un flusso di sottotitoli a un altro, nella scheda Sottotitoli, selezionate un flusso dal menu a comparsa Flusso di sottotitoli.

Fase 3: Esportare il video modificato

Quando le didascalie sono sincronizzate con l’oggetto multimediale potete esportare il video modificato assieme al file dei sottotitoli codificati. Potete esportare i file collaterali di sottotitoli codificati e filmati QuickTime incorporati (sottotitoli QuickTime 608) da Premiere Pro e da Adobe Media Encoder.

 

Formati supportati

Sottotitoli codificati

File collaterali

  • SCC
  • MCC
  • XML
  • STL

File XML

  • W3C TTML (anche noto come DFXP)
  • SMPTE-TT
  • EBU-TT

Nota:

Per i file XML, i sottotitoli possono essere visualizzati sia nel pannello Sottotitoli, sia in un editor di testo.

Premiere Pro supporta l’incorporamento e la decodifica dai seguenti formati di file:  

  • MOV
  • DNxHD MXF Op1a
  • MXF Op1a

Sottotitoli aperti

Premiere Pro supporta l’importazione di file XML e SRT con sottotitoli aperti formattati, che vengono importati in Premiere Pro come file di sottotitoli aperti standard. Questi vengono identificati nel pannello Sottotitoli come Sottotitoli aperti.Nel pannello Sottotitoli potete modificare il font, lo stile di font, il colore del testo, il colore di sfondo e altri attributi dei sottotitoli aperti.

Potete esportare i sottotitoli aperti come file SRT e XML formattati per sottotitoli aperti, nonché convertire i file collaterali a flusso singolo e file incorporati a flusso singolo in sottotitoli aperti in Premiere Pro. Sono supportati anche i file per sottotitoli incorporati MOV e MXF. Potete modificare il valore Dimensione utilizzando il mouse o immettendo un numero.

  1. Con le opzioni Selezionate la famiglia di font e Selezionate lo spessore del font potete cambiare il tipo e le caratteristiche del font.
  2. Per modificare il colore del testo e del colore di sfondo della casella di testo delle didascalie aperte, utilizzate un contagocce del selettore colore oppure fate clic sul selettore colore alla sua sinistra. 
  3. Una volta inserito in una sequenza ed esportato, il testo dei sottotitoli aperti viene automaticamente masterizzato nel video, con un comportamento simile a quello dei titoli della sequenza. Per controllare la masterizzazione dei sottotitoli aperti, potete anche usare l’attivazione delle tracce.

Nota:

Premiere Pro non consente di convertire i file di sottotitoli aperti in formati per sottotitoli codificati.

Video: creare e personalizzare i sottotitoli (sottotitoli aperti)

Video: creare e personalizzare i sottotitoli (sottotitoli aperti)

Scoprite come aggiungere sottotitoli (sottotitoli aperti) al video con opzioni per impostarne il colore, le dimensioni e la posizione.

(Guarda il video, 7 min)

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online