使用 Dreamweaver 存回/取出系统、WebDAV 或 Subversion 在本地和远程服务器之间存回和取出文件。

如果您在协作环境中工作,则可以在本地和远程服务器中存回和取出文件。如果只有您一个人在远程服务器上工作,则可以使用“上传”和“获取”命令,而不用存回或取出文件。

注意:

您可以将“获取”和“上传”功能用于测试服务器,但不能将存回/取出系统用于测试服务器。

取出文件等同于声明“我正在处理这个文件,请不要动它!” 文件被取出后,“文件”面板中将显示取出这个文件的人的姓名,并在文件图标的旁边显示一个红色选中标记(如果取出文件的是小组成员)或一个绿色选中标记(如果取出文件的是您本人)。

存回文件使文件可供其他小组成员取出和编辑。当您在编辑文件后将其存回时,本地版本将变为只读,并且在“文件”面板中该文件的旁边将出现一个锁形符号,以防止您更改该文件。

Dreamweaver 不会使远程服务器上的取出文件成为只读。如果您使用 Dreamweaver 之外的应用程序传输文件,则可能会覆盖取出的文件。但是,在除 Dreamweaver 之外的应用程序中,LCK 文件将出现在文件层次结构中该取出文件的旁边,以防止出现这种意外。

设置存回/取出系统

必须先将本地站点与远程服务器相关联,然后才能使用存回/取出系统。

  1. 选择“站点”>“管理站点”。
  2. 选择一个站点,然后单击“编辑”。
  3. 在“站点设置”对话框中,选择“服务器”类别并执行下列操作之一:
    • 单击“添加新服务器”按钮,添加一个新服务器

    • 选择一个现有的服务器,然后单击“编辑现有服务器”按钮

  4. 根据需要指定“基本”选项,然后单击“高级”按钮。
  5. 如果您在小组环境中工作(或独自工作但使用几台不同的计算机),则选择“启用文件取出”。如果希望对网站禁用文件存回和取出,请取消选择此选项。

    该选项有助于让其他人知道您已取出文件进行编辑,或者提醒您自己可能将文件的最新版本留在了另一台计算机上。

    如果没有看到“存回/取出”选项,则说明您没有设置远程服务器。

  6. 如果要在“文件”面板中双击打开文件时自动取出这些文件,请选择“打开文件之前取出”选项。

    即使选择了该选项,使用“文件”>“打开”这种方法打开文件也不会取出文件。

  7. 设置其余选项:

    取出名称

    取出名称显示在“文件”面板中任何已取出文件的旁边;这使小组成员可以在其需要的文件被取出时和相关的人员联系。

    注意:

    如果您在几台不同的计算机上独自工作,请在每台计算机上使用不同的取出名称(如 AmyR-HomeMac 和 AmyR-OfficePC)。这样,当您忘记存回文件时,就可以知道文件最新版本的位置。

    电子邮件地址

    如果您取出文件时输入电子邮件地址,您的姓名会以链接(蓝色并且带下划线)形式出现在“文件”面板中的该文件旁边。如果某个小组成员单击该链接,则其默认电子邮件程序将打开一个新邮件,该邮件使用该用户的电子邮件地址以及与该文件和站点名称对应的主题。

将文件存回远程文件夹和从中取出文件

设置完存回/取出系统后,可以使用“文件”面板或从“文档”窗口存回和取出远程服务器中的文件。

使用“文件”面板取出文件

  1. 在“文件”面板(“窗口”>“文件”)中,选择要从远程服务器取出的文件。

    注意:

    可以在“本地”或“远程”视图中选择文件,但不能在“测试服务器”视图中选择。

    红色选中标记指示该文件已由其他小组成员取出,锁形符号指示该文件为只读 (Windows) 或锁定 (Macintosh) 状态。

  2. 执行下列操作之一来取出文件:
    • 单击“文件”面板工具栏中的“取出”按钮。

    • 右键单击 (Windows) 或按住 Control 单击 (Macintosh) 鼠标,然后从上下文菜单中选择“取出”。

  3. 在“相关文件”对话框中,单击“是”将相关文件随选定文件一起下载,或者单击“否”不下载相关文件。默认情况下,不会下载相关文件。可在“编辑”>“首选参数”>“站点”上设置此选项。

    注意:

    在取出新文件时下载相关文件通常是一种不错的做法,但是如果本地磁盘上已经有最新版本的相关文件,则无需再次下载它们。

    出现在本地文件图标旁边的一个绿色选中标记表示您已将文件取出。

    注意:

    如果您取出当前处于活动状态的文件,则新的取出版本会覆盖该文件的当前打开的版本。

使用“文件”面板存回文件

  1. 在“文件”面板(“窗口”>“文件”)中,选择取出文件或新文件。

    注意:

    可以在“本地”或“远程”视图中选择文件,但不能在“测试服务器”视图中选择。

  2. 执行下列操作之一来存回文件:
    • 单击“文件”面板工具栏中的“存回”按钮。

    • 右键单击 (Windows) 或按住 Control 单击 (Macintosh) 鼠标,然后从上下文菜单中选择“存回”。

  3. 单击“是”将相关文件随选定文件一起上传,或者单击“否”不上传相关文件。默认情况下,不会上传相关文件。可在“编辑”>“首选参数”>“站点”上设置此选项。

    注意:

    在存回新文件时上传相关文件通常是一种不错的做法,但是如果远程服务器上已经有最新版本的相关文件,则无需再次上传它们。

    一个锁形符号出现在本地文件图标的旁边,表示该文件现在为只读状态。

    注意:

    如果您存回当前处于活动状态的文件,则根据您设置的首选参数选项,该文件可能会在存回前自动保存。

从文档窗口存回打开的文件

  1. 确保要存回的文件在“文档”窗口中处于打开状态。

    注意:

    您每次只能存回一个打开的文件。

  2. 执行下列操作之一:
    • 选择“站点”>“存回”。

    • 单击“文档”窗口工具栏中的“文件管理”图标,然后从菜单中选择“存回”。

      如果当前文件不属于“文件”面板中的活动站点,Dreamweaver 将尝试确定当前文件属于哪个本地定义的站点。如果当前文件属于“文件”面板中活动站点之外的站点,则 Dreamweaver 将打开该站点,然后执行存回操作。

    注意:

    如果您存回当前处于活动状态的文件,则根据您设置的首选参数选项,该文件可能会在存回前自动保存。如果您存回当前处于活动状态的文件,则根据您设置的首选参数选项,该文件可能会在存回前自动保存。

撤消文件取出

如果您取出了一个文件,然后决定不对它进行编辑(或者决定放弃所做的更改),则可以撤消取出操作,文件会返回到原来的状态。

若要撤消文件取出,请执行下列操作之一:

  • 在“文档”窗口中打开文件,然后选择“站点”>“撤消取出”。

  • 在“文件”面板(“窗口”>“文件”)中,右键单击 (Windows) 或按住 Control 单击 (Macintosh) 鼠标,然后再选择“撤消取出”。

    该文件的本地副本成为只读文件,您对它进行的任何更改都将丢失。

使用 WebDAV 存回和取出文件

Dreamweaver 可以连接到使用 WebDAV(基于 Web 的分布式创作和版本控制)的服务器,WebDAV 是对 HTTP 协议的一组扩展,允许用户以协作方式编辑和管理远程 Web 服务器上的文件。有关详细信息,请参阅 www.webdav.org

  1. 如果尚未定义用于指定存储项目文件的本地文件夹的 Dreamweaver 站点,请定义一个。
  2. 选择“站点”>“管理站点”,然后在列表中双击您的站点。
  3. 在“站点设置”对话框中,选择“服务器”类别并执行下列操作之一:
    • 单击“添加新服务器”按钮,添加一个新服务器

    • 选择一个现有的服务器,然后单击“编辑现有服务器”按钮

  4. 在“基本”屏幕中,从“连接方法”弹出菜单中选择“WebDAV”,然后根据需要完成其余“基本”屏幕选项。
  5. 单击“高级”按钮。
  6. 选择“启用文件取出”选项并输入以下信息:
    • 在“取出名称”框中,输入将您与其他小组成员区分开的名称。

    • 在“电子邮件地址”框中,输入您的电子邮件地址。

      名称和电子邮件地址用于标识对 WebDAV 服务器的所有权,并出于联系目的出现在“文件”面板中。

  7. 单击“保存”。

    Dreamweaver 会配置站点以进行 WebDAV 访问。对任何站点文件使用存回或取出命令时,都将使用 WebDAV 传输文件。

    注意:

    WebDAV 可能无法正确取出带有动态内容(如 PHP 标签或 SSI)的任何文件,因为在取出这些文件时 HTTP GET 会呈现它们。

使用 Subversion (SVN) 获取和存回文件

注意:

在 Dreamweaver CC 2017 和更高版本中不再支持 Subversion (SVN)。

Dreamweaver 可以连接到使用 Subversion (SVN) 的服务器,Subversion 是一种版本控制系统,它使用户能够协作编辑和管理远程 Web 服务器上的文件。Dreamweaver 不是一个完整的 SVN 客户端,但却可使用户获取文件的最新版本、更改和提交文件。

注意:

Dreamweaver CS5 使用 Subversion 1.6.6 客户端库,Dreamweaver CS5.5 使用 1.6.9 客户端库。更高版本的 Subversion 客户端库不向后兼容。请注意,如果您更新第三方客户端应用程序(如 TortoiseSVN)以使用更高版本的 Subversion,则更新后的 Subversion 应用程序将更新本地 Subversion 元数据,Dreamweaver 将无法再与 Subversion 进行通信。Subversion 服务器的更新不会引起此问题,因为这类更新可向后兼容。如果升级到使用 Subversion 1.7 或更高版本的第三方客户端应用程序,则在再次可以将 Subversion 用于 Dreamweaver 之前,需要检查 Adobe 更新。有关此问题的详细信息,请参阅 www.adobe.com/go/dw_svn_en

Adobe 建议,使用 SVN 版本控制的文件时,最好同时使用第三方文件比较工具。比较文件差异时,您可以确切了解其他用户对文件做了哪些更改。有关文件比较工具的详细信息,请使用 Web 搜索引擎(如 Google 搜索)搜索“文件比较”或“diff”工具。Dreamweaver 可与大多数第三方工具配合使用。

有关使用 SVN 和 Dreamweaver 的视频概述,请参阅 www.adobe.com/go/lrvid4049_dw

建立 SVN 连接

使用 Subversion (SVN) 作为 Dreamweaver 的版本控制系统之前,必须建立与 SVN 服务器的连接。与 SVN 服务器的连接是在“站点定义”对话框的“版本控制”类别中建立的。

SVN 服务器是一个文件存储库,可供您与其他用户获取和提交文件。它与 Dreamweaver 中通常使用的远程服务器不同。使用 SVN 时,远程服务器仍是网页的“实时”服务器,SVN 服务器用于承载存储库,存储希望进行版本控制的文件。典型的工作流程是:在 SVN 服务器之间来回获取和提交文件,然后通过 Dreamweaver 发布到远程服务器。远程服务器的设置完全独立于 SVN 的设置。

开始此设置之前,必须获得对 SVN 服务器和 SVN 存储库的访问权限。有关 SVN 的详细信息,请访问 Subversion 网站,网址为 http://subversion.apache.org/

若要建立 SVN 连接,请执行以下步骤:

  1. 选择“站点”>“管理站点”,选择要为其设置版本控制的站点,然后单击“编辑”按钮。

    注意:

    如果还没有为 Dreamweaver 站点设置本地文件夹和远程文件夹,则至少需要先设置本地站点,然后再继续。(此阶段不要求设置远程站点,但最终将文件发布到 Web 之前,还是需要进行设置。)有关详细信息,请参阅使用 Dreamweaver 站点

  2. 在“站点设置”对话框中,选择“版本控制”类别。

  3. 从“访问”弹出菜单中,选择“Subversion”。

  4. 按以下步骤设置访问选项:

    • 从“协议”弹出菜单中选择协议。可选协议包括 HTTP、HTTPS、SVN 和 SVN+SSH。

    注意:

    使用 SVN+SSH 协议要求具备特殊配置。有关详细信息,请参阅 www.adobe.com/go/learn_dw_svn_ssh_en

    • 在“服务器地址”文本框中,输入 SVN 服务器的地址。通常形式为:服务器名称.域.com

    • 在“存储库路径”文本框中,输入 SVN 服务器上存储库的路径。通常类似于:/svn/your_root_directory,SVN 存储库根文件夹的命名由服务器管理员确定。

    • (可选)如果希望使用的服务器端口不同于默认服务器端口,请选择“非默认值”,并在文本框中输入端口号。

    • 输入 SVN 服务器的用户名和密码。

  5. 单击“测试”来测试连接,或单击“确定”关闭对话框。然后单击“完成”,关闭“管理站点”对话框。

与服务器建立连接后,可在“文件”面板中查看 SVN 存储库。若要查看 SVN 存储库,可以从“视图”弹出菜单中选择“存储库视图”,或在展开的“文件”面板中,单击“存储库文件”按钮 

获取最新版本的文件

从 SVN 存储库中获取最新版本的文件时,Dreamweaver 会将该文件的内容和其相应本地副本的内容进行合并。(即,如果您上次提交文件后,有其他用户更新了该文件,这些更新将合并到您计算机上的本地版本文件中。)如果本地硬盘上不存在此文件,Dreamweaver 会径直获取该文件。

注意:

首次从存储库中获取文件时,应使用本地空目录,或使用所含文件与存储库中文件不同名的本地目录。如果本地驱动器包含的文件与远程存储库中的文件同名,Dreamweaver 不会在第一次尝试时,便将存储库文件装入本地驱动器。

  1. 确保已成功建立 SVN 连接。

  2. 执行下列操作之一:

    • 按以下步骤在“文件”面板中显示 SVN 文件的本地版本:从“视图”弹出菜单中,选择“本地视图”。(如果正在使用展开的“文件”面板,将自动显示“本地视图”。)然后右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 所需文件或文件夹,并选择“版本控制”>“获取最新版本”。

    • 按此步骤显示 SVN 存储库文件:在“文件”面板的“视图”弹出菜单中,选择“存储库视图”;或在展开的“文件”面板中,单击“存储库文件”按钮。然后右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 所需文件或文件夹,并选择“获取最新版本”。

注意:

为获取最新版本,您还可以右键单击文件,然后从上下文菜单中选择“取出”,或者选择文件并单击“取出”按钮。但因为 SVN 不支持取出工作流程,所以此动作并不是传统意义上的实际取出文件。

提交文件

  1. 确保已成功建立 SVN 连接。

  2. 执行下列操作之一:

    • 按以下步骤在“文件”面板中显示 SVN 文件的本地版本:从“视图”弹出菜单中,选择“本地视图”。(如果正在使用展开的“文件”面板,将自动显示“本地视图”。)然后选择要提交的文件,并单击“存回”按钮。

    • 按此步骤显示 SVN 存储库文件:在“文件”面板的“视图”弹出菜单中,选择“存储库视图”;或在展开的“文件”面板中,单击“存储库文件”按钮。然后右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 要提交的文件,并选择“存回”。

  3. 在“提交”对话框中查看动作,根据需要修改,然后单击“确定”。

    选择要更改其动作的文件,然后单击“提交”对话框底部的按钮,这样可以更改动作。提供的选择有两个:提交和忽略。

注意:

在“文件”面板中,文件上的绿色选中标记表示此文件有更改,但尚未提交到存储库。

更新存储库中文件或文件夹的状态

您可以更新单个文件或文件夹的 SVN 状态。此更新操作不会刷新整个显示。

  1. 确保已成功建立 SVN 连接。

  2. 按此步骤显示 SVN 存储库文件:在“文件”面板的“视图”弹出菜单中,选择“存储库视图”;或在展开的“文件”面板中,单击“存储库文件”按钮。

  3. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 存储库中的任一文件夹或文件,然后选择“更新状态”。

更新本地文件或文件夹的状态

您可以更新单个文件或文件夹的 SVN 状态。此更新操作不会刷新整个显示。

  1. 确保已成功建立 SVN 连接。

  2. 按以下步骤在“文件”面板中显示 SVN 文件的本地版本:从“视图”弹出菜单中,选择“本地视图”。(如果正在使用展开的“文件”面板,将自动显示“本地视图”。)

  3. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)“文件”面板中的任一文件夹或文件,然后选择“更新状态”。

查看文件的修订版

  1. 确保已成功建立 SVN 连接。

  2. 执行下列操作之一:

    • 按以下步骤在“文件”面板中显示 SVN 文件的本地版本:从“视图”弹出菜单中,选择“本地视图”。(如果正在使用展开的“文件”面板,将自动显示“本地视图”。)然后右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 要查看其修订版的文件,并选择“版本控制”>“显示修订版”。

    • 按此步骤显示 SVN 存储库文件:在“文件”面板的“视图”弹出菜单中,选择“存储库视图”;或在展开的“文件”面板中,单击“存储库文件”按钮。然后右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 要查看其修订版的文件,并选择“显示修订版”。

  3. 在“修订历史记录”对话框中,选择所需一个或多个修订版,然后执行以下操作之一:

    • 单击“与本地文件比较”,比较文件的所选修订版和本地版本。

    注意:

    对比文件前,必须安装第三方文件对比工具。有关文件比较工具的详细信息,请使用 Web 搜索引擎(如 Google 搜索)搜索“文件比较”或“diff”工具。Dreamweaver 可与大多数第三方工具配合使用。

    • 单击“比较”,比较所选的两个修订版。按住 Control 键单击,同时选择两个修订版。

    • 单击“查看”,查看所选修订版。此动作不会覆盖该文件的当前本地副本。您可以像保存任何其他文件一样,将所选修订版保存到硬盘。

    • 单击“提升”,使所选修订版成为存储库中的最新版本。

锁定和解锁文件

通过锁定 SVN 存储库中的文件,可以让其他用户知道您正在处理该文件。其他用户仍可在本地编辑文件,但必须等到您解锁该文件后,才可提交该文件。在存储库中锁定文件时,该文件上将显示一个开锁图标。其他用户会看到完全锁定的图标。

  1. 确保已成功建立 SVN 连接。

  2. 执行下列操作之一:

    • 按此步骤显示 SVN 存储库文件:在“文件”面板的“视图”弹出菜单中,选择“存储库视图”;或在展开的“文件”面板中,单击“存储库文件”按钮。然后右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 所需文件,并选择“锁定”或“解锁”。

    • 按以下步骤在“文件”面板中显示 SVN 文件的本地版本:从“视图”弹出菜单中,选择“本地视图”。(如果正在使用展开的“文件”面板,将自动显示“本地视图”。)然后右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 所需文件,并选择“锁定”或“解锁”。

向存储库添加新文件

在“文件”面板中,文件上的蓝色加号表示 SVN 存储库中尚没有此文件。

  1. 确保已成功建立 SVN 连接。

  2. 在“文件”面板中,选择要添加到存储库的文件,然后单击“存回”按钮。

  3. 确保选择要提交的文件已位于“提交”对话框中,然后单击“确定”。

移动、复制、删除或还原文件

  • 要移动文件,请将文件拖到本地站点内的目标文件夹中。

    移动文件后,Dreamweaver 对新位置处的文件标以“与历史记录一起添加”标志,并对旧位置处的文件标以“删除”标志。提交这些文件后,旧位置处的文件即消失。

  • 要复制文件,请选择该文件,复制该文件(“编辑”>“复制”),然后将该文件粘贴(“编辑”>“粘贴”)到新位置。

    复制并粘贴文件后,Dreamweaver 对新位置处的文件标以“与历史记录一起添加”标志。

  • 要删除某个文件,请选择该文件,然后按“删除”。

    Dreamweaver 可让您选择要仅删除文件的本地版本,还是同时删除本地版本和 SVN 服务器上的版本。如果选择仅删除本地版本,则不影响 SVN 服务器上的文件。如果选择同时删除 SVN 服务器上的版本,则将本地版本标以“删除”标志,并且必须提交该文件才能进行删除。

  • 要将复制或移动的文件还原到其原始位置,请右键单击该文件,并选择“版本控制”>“还原”。

解析冲突的文件

如果您的文件与服务器上其他文件冲突,您可以编辑您的文件,然后将其标记为已解析。例如,如果您尝试存回的文件与其他用户的更改有冲突,SVN 将不允许您提交文件。此时,您可以从存储库中获取该文件的最新版本,手动更改工作副本,然后将您的文件标记为已解析,这样就可以提交了。

  1. 确保已成功建立 SVN 连接。

  2. 按以下步骤在“文件”面板中显示 SVN 文件的本地版本:从“视图”弹出菜单中,选择“本地视图”。(如果正在使用展开的“文件”面板,将自动显示“本地视图”。)

  3. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 要解析的文件,然后选择“版本控制”>“标记为已解析”。

脱机

您可能已发现,在其他文件传输活动期间,利用脱机来避免访问存储库非常有用。您一旦调用要求连接的活动(“获取最新版本”、“提交”等),Dreamweaver 就将重新连接到 SVN 存储库。

  1. 确保已成功建立 SVN 连接。

  2. 按以下步骤在“文件”面板中显示 SVN 文件的本地版本:从“视图”弹出菜单中,选择“本地视图”。(如果正在使用展开的“文件”面板,将自动显示“本地视图”。)

  3. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh)“文件”面板中的任一文件或文件夹,然后选择“版本控制”>“脱机”。

清理本地 SVN 站点

此命令允许您删除文件上的锁定,因而能够继续未完成的操作。在收到“工作副本已锁定”的错误信息时,应使用此命令来删除旧有锁定。

  1. 确保已成功建立 SVN 连接。

  2. 按以下步骤在“文件”面板中显示 SVN 文件的本地版本:从“视图”弹出菜单中,选择“本地视图”。(如果正在使用展开的“文件”面板,将自动显示“本地视图”。)

  3. 右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 要清理的文件,然后选择“版本控制”>“清理”。

关于移动 Subversion 控制的站点中的文件和文件夹

对于 Subversion 控制站点中的文件或文件夹,当您移动它们的本地版本时,可能会给正在向 SVN 存储库同步的其他用户带来问题。例如,如果您在本地移动了某个文件,且有数小时未将其提交到存储库,则另一个用户可能尝试从该文件的旧位置获取其最新版本。因此,在本地移动文件后,始终应立即将其提交回 SVN 服务器。

文件和文件夹会保留在 SVN 服务器上,除非您手动删除。所以,即使您将文件移动到其他本地文件夹并提交该文件,其旧版本仍保留服务器上的原先位置。为避免冲突,在移动文件和文件夹后,请删除它们的旧副本。

在本地移动文件并将其提交回 SVN 服务器时,该文件的版本历史记录将丢失。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略