在 Dreamweaver 中以 xml 形式导出和导入可编辑内容。了解将基于模板的内容从一个站点导出到另一个站点。

可以将基于模板的文档看作是其中含有由名称-值对表示的数据的模板。每一对由可编辑区域的名称及该区域的内容组成。

您可以将名称/值对导出到 XML 文件中,以便可在 Dreamweaver 之外(例如,在 XML 编辑器或文本编辑器中,或在数据库应用程序中)处理数据。反之,如果您的 XML 文档的结构处理适当,便可以将其中的数据导入基于 Dreamweaver 模板的文档。

将文档的可编辑区域导出为 XML

  1. 打开基于模板并包含可编辑区域的文档。
  2. 选择“文件”>“导出”>“作为 XML 的数据模板”。
  3. 选择“符号”选项之一:
    • 如果模板中包含重复区域或模板参数,请选择“使用标准 Dreamweaver XML 标签”。

    • 如果模板中不包含重复区域或模板参数,请选择“使用可编辑区域名称作为 XML 标签”。

  4. 单击“确定”。
  5. 在出现的对话框中,选择文件夹位置,输入 XML 文件的名称,然后单击“保存”。

    此时,将生成一个 XML 文件,文件的内容来自文档的参数和可编辑区域,包括重复区域或可选区域内部的可编辑区域。此 XML 文件中包括原始模板的名称以及每个模板区域的名称和内容。

    注意:

    不可编辑区域中的内容不会导出到此 XML 文件中。

导入 XML 内容

  1. 选择“文件”>“导入”>“XML 到模板”。
  2. 选择 XML 文件,然后单击“打开”。

    Dreamweaver 基于 XML 文件中指定的模板创建新文档。它还使用 XML 文件中的数据填充该文档中每个可编辑区域的内容。结果文档出现在新的“文档”窗口中。

    注意:

    如果您的 XML 文件未按 Dreamweaver 希望的方式进行准确设置,则您可能无法导入数据。解决此问题的一个方法是从 Dreamweaver 中导出虚拟 XML 文件,这样您将有一个具有完全正确结构的 XML 文件。然后从原始 XML 文件向导出的 XML 文件中副本数据。结果生成一个包含相应数据、结构正确并且可以导入的 XML 文件。

导出不带模板标记的站点

可以将基于模板的文档从一个站点导出到另一个站点(不包含模板标记)。

  1. 选择“工具”>“模板”>“不带标记导出”。

  2. 在“文件夹”框中,输入要将文件导出到的文件夹的文件路径,或者单击“浏览”并选择该文件夹。

    注意:

    必须选择当前站点以外的文件夹。

  3. 如果要保存已导出的基于模板的文档的 XML 版本,请选择“保留模板数据文件”。
  4. 要将更改更新到以前导出的文件,请选择“只解压缩已更改的文件”,然后单击“确定”。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略