关于设计备注

设计备注是您为文件创建的备注。设计备注与它们所描述的文件相关联,但存储在单独的文件中。您可以在展开的“文件”面板中看到哪些文件具有设计备注:“设计备注”图标会出现在“备注”列中。

您可以使用设计备注来记录与文档关联的其它文件信息,如图像源文件名称和文件状态说明。例如,如果将一个文档从一个站点复制到另一个站点,则可以为该文档添加设计备注,说明原始文档位于另一站点的文件夹中。

您也可以使用设计备注来记录因安全原因而不能放在文档中的敏感信息,例如,您可以记录某一价格或配置是如何选定的或哪些市场因素影响了某一设计决策等信息。

如果您在 Adobe® Fireworks® 或 Flash 中打开一个文件并将其导出为其它格式,则 Fireworks 和 Flash 会自动将原始源文件的名称保存在设计备注文件中。例如,如果您在 Fireworks 中打开 myhouse.png 并将其导出为 myhouse.gif,则 Fireworks 会创建一个名为 myhouse.gif.mno 的设计备注文件。此设计备注文件包含原始文件的名称,它采用的是绝对的 file: URL。因此,myhouse.gif 的设计备注可能包含此行:

fw_source="file:///Mydisk/sites/assets/orig/myhouse.png"

类似的 Flash 设计备注可能包含此行:

fl_source="file:///Mydisk/sites/assets/orig/myhouse.fla"

注意:

若要共享设计备注,用户应定义相同的站点根路径(例如 sites/assets/orig)。

当您将图形导入 Dreamweaver 中时,设计备注文件将随该图形一起自动复制到站点中。当您在 Dreamweaver 中选择图像并选择使用 Fireworks 编辑它时,Fireworks 将打开原始文件以供编辑。

对站点启用和禁用设计备注

设计备注是与文件相关联的备注,但存储于独立的文件中。可以使用设计备注来记录与文档关联的其它文件信息,如图像源文件名称和文件状态说明。

您可以在“站点定义”对话框的“设计备注”类别中对站点启用和禁用设计备注。启用“设计备注”时,如果需要,您还可以选择与他人共享“设计备注”。

  1. 选择“站点”>“管理站点”。
  2. 在“管理站点”对话框中,选择一个站点,然后单击“编辑”。
  3. 在“站点设置”对话框中,展开“高级设置”并选择“设计备注”类别。
  4. 选择“维护设计备注”以启用设计备注(取消选择即禁用)。
  5. 若要删除站点的所有本地设计备注文件,单击“清理”,然后单击“是”。(如果您要删除远程“设计备注”文件,则将需要手动删除它们)。

    注意:

    “清除设计备注”命令只能删除 MNO(设计备注)文件。该命令不会删除 _notes 文件夹或 _notes 文件夹中的 dwsync.xml 文件。Dreamweaver 使用 dwsync.xml 文件保存有关站点同步的信息。

  6. 选择“启用上传并共享设计备注”将与站点关联的设计备注与其余的文档一起上传,然后单击“确定”。
    • 如果选择该选项,则您可以和小组的其余成员共享设计备注。在您上传或获取某个文件时,Dreamweaver 将自动上传或获取关联的设计备注文件。

    • 如果未选择此选项,则 Dreamweaver 在本地维护设计备注,但不将这些备注与您的文件一起上传。如果您独自在站点上工作,取消选择此选项可改善性能。当您存回或上传文件时,设计备注并不会传输到远程站点,因此您仍可以在本地为站点添加和修改设计备注。

建立设计备注与文件的关联

您可以为站点中的每个文档或模板创建设计备注文件。您还可以为文档中的 Applet、ActiveX 控件、图像、Flash 内容、Shockwave 对象以及图像域创建设计备注。

注意:

如果在模板文件中添加设计备注,用该模板创建的文档不会继承这些设计备注。

  1. 执行下列操作之一:
    • 在“文档”窗口中打开文件并选择“文件”>“设计备注”。

    • 在“文件”面板中,右键单击 (Windows) 或按住 Ctrl 单击 (Macintosh) 该文件,然后选择“设计备注”。

    注意:

    如果该文件位于在远程站点中,则您必须首先取出或获取该文件,然后在本地文件夹中选择它。

  2. 在“基本信息”选项卡中,从“状态”菜单中选择文档的状态。
  3. 单击日期图标(在“备注”框的上方)在您的备注中插入当前本地日期。
  4. 在“备注”框中键入注释。
  5. 选择“文件打开时显示”在每次打开文件时显示设计备注文件。
  6. 在“所有信息”选项卡中,单击加号 (+) 按钮可以添加新的键-值对;选择一个键-值对,然后单击减号 (–) 按钮可以将其删除。

    例如,您可以将一个键命名为 Author(在“名称”框中),并将值定义为 Heidi(在“值”框中)。

  7. 单击“确定”保存备注。

    Dreamweaver 将您的备注保存到名为 _notes 的文件夹中,与当前文件处在相同的位置。文件名是文档的文件名加上 .mno 扩展名。例如,如果文件名是 index.html,则关联的设计备注文件名为 index.html.mno。

使用设计备注

将设计备注关联到文件之后,您可以打开设计备注,更改其状态或将其删除。

打开与文件关联的设计备注

  1. 执行下列操作之一来打开设计备注:
    • 在“文档”窗口中打开文件,然后选择“文件”>“设计备注”。

    • 在“文件”面板中,右键单击 (Windows) 或按住 Ctrl 单击 (Macintosh) 该文件,然后选择“设计备注”。

    • 在“文件”面板的“备注”列中,双击黄色的“设计备注”图标。

    注意:

    若要显示黄色的“设计备注”图标,请选择“站点”>“管理站点”>“[站点名称]”>“编辑”>“高级设置”>“文件视图列”。在列表面板中选择“备注”,然后选择“显示”选项。当单击“文件”工具栏上的“展开”按钮以显示本地站点和远程站点时,本地站点中会包含一个“备注”列,为任何带有设计备注的文件显示一个黄色备注图标。

指定自定义设计备注状态

  1. 打开文件或对象的设计备注(请参阅前面的步骤)。
  2. 单击“所有信息”选项卡。
  3. 单击加号 (+) 按钮。
  4. 在“名称”字段中,输入 status 一词。
  5. 在“值”字段中,输入状态。

    如果已存在状态值,则该值将被新状态值取代。

  6. 单击“基本信息”选项卡并记下在“状态”弹出菜单中显示的新状态值。

    注意:

    状态菜单中一次只能有一个自定义值。如果再次执行此步骤,则 Dreamweaver 将用您输入的新状态值替代第一次输入的状态值。

从站点中删除未关联的设计备注

  1. 选择“站点”>“管理站点”。
  2. 选择站点,然后单击“编辑”。
  3. 在“站点定义”对话框中,从左侧的“类别”列表中选择“设计备注”。
  4. 单击“清理”按钮。

    Dreamweaver 提示您确认它应删除任何不再与站点中的文件关联的设计备注。

    如果使用 Dreamweaver 删除具有关联设计备注文件的文件,则 Dreamweaver 同时也将删除设计备注文件。因此,通常只有当您在 Dreamweaver 外删除或重命名文件后,才会出现孤立的设计备注文件。

    注意:

    如果在单击“清理”前取消对“维护设计备注”选项的选择,则 Dreamweaver 将删除站点的所有设计备注文件。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略