Vytváření textových rámečků

Text v aplikaci InDesign se nachází uvnitř kontejnerů nazývaných textové rámečky. (Textový rámeček je podobný textovému rámečku v aplikaci QuarkXPress a textovému bloku v aplikaci Adobe PageMaker.)

Existují dva typy textových rámečků: mřížky rámečků a normální textové rámečky. Mřížky rámečků jsou druhem textových rámečků specifickým pro asijské jazyky, ve kterých se Em rámečky znaků a mezery znaků zobrazují jako mřížky. Prázdné textové rámečky, ve kterých se nezobrazuje žádná mřížka, jsou normální textové rámečky.

Podobně jako grafické rámečky můžete i textové rámečky přemísťovat, měnit jejich velikost a upravovat je. Nástroj, kterým vyberete textový rámeček, určuje druh změn, které můžete provádět:

  • Pomocí textového nástroje můžete zadávat nebo upravovat text v rámečku.

  • Pomocí nástroje pro výběr můžete provádět všeobecné úkony, jako je nastavení polohy nebo velikosti rámečku.

  • Pomocí nástroje pro přímý výběr můžete změnit tvar rámečku.

  • Pomocí nástroje pro vodorovnou nebo svislou mřížku vytvořte mřížku rámečku. Viz článek Vytváření mřížek rámečků.

  • Textový nástroj slouží k vytvoření rámečku s prostým textem pro vodorovný text a nástroj svislý text k vytvoření rámečku s prostým textem pro svislý text. Pomocí stejných nástrojů můžete upravit existující text v rámečku.

Textové rámečky mohou být také propojeny s dalšími textovými rámečky, aby text z jednoho rámečku mohl přetékat do dalšího rámečku. Rámečky propojené tímto způsobem jsou zřetězené. Text, který protéká jedním nebo více zřetězenými rámečky, se nazývá článek. Když umístíte (importujete) soubor z textového procesoru, vloží se do dokumentu jako jeden článek, bez ohledu na počet rámečků, které vyplňuje.

Textové rámečky mohou mít více sloupců. Textové rámečky mohou být založeny na sloupcích stránky, ale jsou na nich nezávislé. Jinými slovy textový rámeček se dvěma sloupci může být umístěn na stránce se čtyřmi sloupci. Textové rámečky mohou být také umístěné na vzorových stránkách a přesto obsahovat text na stránkách dokumentu.

Poznámka:

Pokud používáte opakovaně stejný typ textového rámečku, můžete vytvořit objektový styl obsahující formátování textového rámečku, například barvy tahu a výplně, volby textového rámečku a efekty obtékání a průhlednosti textu.

Když umístíte nebo vložíte text, nemusíte vytvářet textový rámeček; InDesign automaticky přidá rámečky podle nastavení sloupců stránky.

Při vložení textu dojde k automatickému vytvoření rámečku s prostým textem. Nebo můžete ručně vytvořit prázdný textový rámeček pro prostý text a text zadat.

  1. Proveďte libovolný z následujících úkonů:
    • Vyberte textový nástroj a pak tažením určete šířku a výšku nového textového rámečku. Podržte při tažení stisknutou klávesu Shift, chcete-li vytvořit čtvercový rámeček. Po uvolnění tlačítka myši se v rámečku objeví textový kurzor, určující místo vkládání textu.

    Vytvoření nového textového rámečku tažením
    Vytvoření nového textového rámečku tažením

    • Pomocí nástroje pro výběr klikněte na vstupní nebo výstupní bod jiného textového rámečku a pak kliknutím nebo tažením vytvořte další rámeček.

    • Pomocí příkazu Umístit umístěte textový soubor.

    • S textovým nástrojem klikněte do prázdného textového rámečku. Pokud je v předvolbách Text vybraná volba Textový nástroj převede rámečky na textové rámečky, prázdný rámeček se převede na textový rámeček.

Nastavení polohy a velikosti textových rámečků

Chcete-li textové rámečky přemístit nebo změnit jejich velikost, použijte nástroj pro výběr.

Poznámka:

Chcete-li textový rámeček přemístit nebo změnit jeho velikost bez přepínání z textového nástroje na nástroj pro výběr, stiskněte klávesu Ctrl (Windows) nebo Command (Mac OS) a pak rámeček přetáhněte.

Přemístění textového rámečku

  • Přetáhněte rámeček pomocí nástroje pro výběr.
  • Při používání textového nástroje stiskněte klávesu Ctrl (Windows) nebo Command (Mac OS) a přetáhněte rámeček. Když uvolníte klávesu, textový nástroj je stále vybraný.

Změna velikosti textového rámečku

  1. Proveďte libovolný z následujících úkonů:
    • Chcete-li pro změnu velikosti použít textový nástroj , podržte stisknutou klávesu Ctrl (Windows) nebo Command (Mac OS) a táhněte za libovolné táhlo rámečku. Pokud před začátkem tažení jednu sekundu podržíte stisknuté tlačítko myši, text se bude při změnách velikosti rámečku zalamovat.

      Poznámka: Pokud na textový rámeček místo tažení jen kliknete, ztratíte textový výběr nebo polohu textového kurzoru.

    • Chcete-li pro změnu velikosti použít nástroj pro výběr , táhněte za libovolné táhlo rámečku na okraji jeho rámečku. Podržte stisknutou klávesu Ctrl (Windows) nebo Command (Mac OS), chcete-li změnit také velikost textu uvnitř rámečku. (Viz Typ měřítka.)

    • Chcete-li rychle přizpůsobit rámeček jeho obsahu, vyberte textový rámeček nástrojem pro výběr a dvojitě klikněte na libovolné táhlo. Pokud například dvojitě kliknete na střední dolní táhlo, spodní okraj rámečku se přitáhne ke spodnímu okraji textu. Pokud dvojitě kliknete na střední pravé táhlo, výška se zachová, zatímco šířka se zmenší tak, aby se vyplnil rámeček.

      Tip: Můžete také dvojitě kliknout na táhlo rámečku s přesahujícím textem a tím zvětšit výšku nebo šířku tak, aby se celý text vešel do rámečku. Pokud textový rámeček obsahuje více přesahujícího textu, než se rozumně vejde na stránku, pak se jeho velikost nezmění.

    Dvojitým kliknutím na táhlo se změní velikost textového rámečku
    Dvojitým kliknutím na táhlo se změní velikost textového rámečku

    • Chcete-li přizpůsobit textový rámeček obsahu, vyberte rámeček nástrojem pro výběr a zvolte Objekt > Přizpůsobení > Přizpůsobit rámeček obsahu. Dolní okraj textového rámečku se přizpůsobí podle obsahu textu. Pokud textový rámeček obsahuje více přesahujícího textu, než se rozumně vejde na stránku, pak se jeho velikost nezmění.

    • Pomocí nástroje pro změnu velikosti tažením změňte velikost rámečku. (Viz Typ měřítka.)

Používání textových rámečků na vzorových stránkách

Když vytváříte nový dokument, můžete vybrat volbu Základní textový rámeček a umístit tak prázdný textový rámeček na výchozí vzorovou stránku dokumentu. Tento rámeček má atributy sloupců a okrajů, zadané v dialogovém okně Nový Dokument.

Při používání textových rámečků na vzorových stránkách postupujte podle těchto pravidel:

  • Pokud chcete, aby každá stránka dokumentu obsahovala textový rámeček velikosti stránky, do kterého můžete nechat natékat nebo psát text, vytvořte základní textové rámečky. Pokud dokument vyžaduje větší obměny, například bude obsahovat stránky s různými počty rámečků nebo různě dlouhé rámečky, volbu Základní textový rámeček nevybírejte a vytvořte textové rámečky na vzorových stránkách textovým nástrojem.

  • Bez ohledu na to, zda vyberete nebo nevyberete volbu Základní textový rámeček, můžete do vzorové stránky přidávat textové rámečky fungující jako vyhrazená místa. Tyto zástupné prázdné rámečky můžete zřetězit dohromady a tím připravit natékání textu.

  • K natékání textu do vzorových textových rámečků použijte stejný postup jako pro rámečky vytvořené na stránkách dokumentu.

  • Pokud potřebujete napsat text do základního textového rámečku na stránce dokumentu, klikněte na textový rámeček na stránce dokumentu se stisknutými klávesami Ctrl+Shift (Windows) nebo Command+Shift (Mac OS). Pak klikněte do rámečku textovým nástrojem a začněte psát.

  • Můžete použít funkci Inteligentní přeformátování textu k automatickém přidání nebo odebrání stránek při psaní a úpravě textu. Ve výchozím nastavení, pokud píšete text na konci zřetězeného textového rámečku založeného na vzorové stránce, přidá se nová stránka, která umožní pokračovat v psaní textu v novém textovém rámečku. Nastavení Inteligentního přeformátování textu můžete změnit.

  • Pokud změníte okraje stránky, textové rámečky se přizpůsobí novým okrajům pouze v případě, že je zapnutá volba Povolit úpravy rozvržení.

  • Výběr volby Základní textový rámeček nemá vliv na přidávání stránek při automatickém natékání textu.

Změna vlastností textového rámečku

Použijte příkaz Volby textového rámečku, chcete-li změnit nastavení jako je počet sloupců v rámečku, svislé zarovnání textu uvnitř rámečku nebo odstup vsazení, což je vzdálenost okrajů mezi textem a rámečkem.

Před (vlevo) a po (vpravo) nastavení vsazení a vytvoření dvou sloupců v textovém rámečku
Před (vlevo) a po (vpravo) nastavení vsazení a vytvoření dvou sloupců v textovém rámečku

Poznámka:

Pokud potřebujete použít stejné vlastnosti textového rámečku pro více textových rámečků, vytvořte objektový styl, který můžete aplikovat na textové rámečky.

  1. Pomocí nástroje pro výběr vyberte rámeček, nebo klikněte textovým nástrojem dovnitř textového rámečku nebo vyberte text.
  2. Zvolte Objekt > Volby textového rámečku nebo stiskněte klávesu Alt (Windows) nebo Option (Mac OS) a pak dvojitě klikněte na textový rámeček nástrojem pro výběr.
  3. Změňte volby textového rámečku a pak klikněte na OK.

Tyto volby textového rámečku jsou dostupné, když definujete objektový styl pro textové rámečky. Viz Objektové styly.

Přidání sloupců do textového rámečku

Pomocí dialogového okna Volby textového rámečku můžete vytvořit sloupce uvnitř textového rámečku.

Poznámka:

V textovém rámečku nemůžete vytvořit sloupce s nestejnou šířkou. Chcete-li vytvořit sloupce s nestejnou šířkou nebo výškou, přidejte zřetězené textové rámečky vedle sebe buď do stránky dokumentu, nebo do vzorové stránky.

  1. Pomocí nástroje pro výběr vyberte rámeček nebo pomocí textového nástroje klikněte dovnitř textového rámečku nebo vyberte text.
  2. Zvolte Objekt > Volby textového rámečku.
  3. Určete počet sloupců, šířku každého sloupce a mezery mezi jednotlivými sloupci textového rámečku.
  4. (Volitelně) Vyberte Pevná šířka sloupců, chcete-li zachovat šířku sloupce při změně velikosti rámečku. Pokud je tato volba vybraná, může změna velikosti rámečku změnit počet sloupců, ale ne jejich šířku.
    Pevná šířka sloupců
    Pevná šířka sloupců

    A. Původní textový rámeček se 2 sloupci B. Po zvětšení s vypnutou volbou Pevná šířka sloupců (stále 2 sloupce) C. Po zvětšení s vybranou volbou Pevná šířka sloupců (4 sloupce) 
  5. (Volitelné) Chcete-li vytvořit text dole ve víceloupcovém textovém rámečku, zvolte Vyvážené sloupce.
    Před vyvážením sloupců a po vyvážení sloupců
    Před vyvážením sloupců a po vyvážení sloupců

Změna odstupu vsazení (okrajů) textového rámečku

  1. Pomocí nástroje pro výběr vyberte rámeček nebo pomocí textového nástroje klikněte dovnitř textového rámečku nebo vyberte text.
  2. Zvolte Objekt > Volby textového rámečku.
  3. V sekci Odstup vsazení v záložce Všeobecné zadejte velikost vsazení pro Nahoře, Vlevo, Dole a Vpravo. (Chcete-li použít stejný odstup na všech stranách, klikněte na ikonu Změnit všechna nastavení na stejné hodnoty .)

Pokud vybraný rámeček nemá obdélníkový tvar, budou volby Nahoře, Vlevo, Dole a Vpravo ztlumené a místo nich bude dostupná volba Vsazení.

Volby odsazení prvního účaří

Chcete-li změnit volby prvního účaří vybraného textového rámečku, zvolte Objekt > Volby textového rámečku a klikněte na záložku Volby účaří. Následující volby jsou v nabídce Posun pod První účaří:

Horní dotažnice

Výška znaku „d“ v písmu spadá pod horní vsazení textového rámečku.

Výška verzálek

Horní okraj velkých písmen se dotýká horního vsazení textového rámečku.

Proklad

Použije hodnotu prokladu textu jako vzdálenost mezi účařím prvního řádku textu a horním vsazením rámečku.

Výška x

Výška znaku „x“ v písmu spadá pod horní vsazení rámečku.

Pevné

Určete vzdálenost mezi účařím prvního řádku textu a horním vsazením rámečku.

Minimální

Vyberte minimální hodnotu pro odsazení účaří. Pokud je například vybraná volba Proklad a určíte minimální hodnotu 1p, použije InDesign hodnotu podkladu pouze pokud je větší než 1 pica.

Poznámka:

Pokud chcete přitahovat horní okraj textového rámečku na mřížku, zvolte buď Proklad nebo Pevné, abyste mohli nastavit umístění prvního účaří textu v textovém rámečku.

Nastavení mřížky účaří pro textový rámeček

Někdy můžete chtít mřížku účaří použít pro rámeček a ne pro celý dokument. Použijte dialogové okno Volby textového rámečku, chcete-li aplikovat mřížku účaří na textový rámeček. Když nastavujete mřížku účaří pro textový rámeček, pamatujte si následující:

  • Mřížka účaří dokumentu se nezobrazuje za nebo před textovými rámečky, které používají vlastní mřížku účaří.
  • Pokud je v předvolbách Mřížky vybraná volba Mřížky vzadu, pak mřížky účaří založené na rámečku mají přednost před mřížkami účaří založenými na dokumentu. Pokud není vybraná volba Mřížky vzadu, pak mřížky účaří založené na dokumentu mají přednost před mřížkami účaří založenými na rámečku.
  1. Zvolte Zobrazení > Mřížka a vodítka > Zobrazovat mřížku účaří, chcete-li zobrazit všechny mřížky účaří včetně těch v textovém rámečku.
  2. Vyberte textový rámeček nebo umístěte textový kurzor do textového rámečku a zvolte Objekt > Volby textového rámečku.

    Chcete-li mřížku účaří použít pro všechny zřetězené rámečky (i pokud jeden nebo více z nich neobsahuje text), umístěte do textu textový kurzor, zvolte Úpravy > Vybrat vše a pak aplikujte nastavení mřížky účaří v dialogovém okně Volby textového rámečku.

  3. klikněte na záložku Volby účaří.
  4. Pro Mřížka účaří vyberte Použít vlastní mřížku účaří a proveďte libovolný z následujících úkonů:

    Začátek

    Zadejte hodnotu odsazení mřížky od hořejšku stránky, horního okraje stránky, hořejšku rámečku nebo horního vsazení rámečku podle toho, kterou položku vyberete z nabídky Vzhledem k.

    Relativně k

    Zadejte, zda chcete, aby mřížka účaří začínala vzhledem k horní části stránky, k hornímu okraji stránky, k horní části textového rámečku nebo k horní části výřezu textového rámečku.

    Dílky po

    Zadejte hodnotu pro mezery mezi čárami mřížky. Ve většině případů zadáte hodnotu, která se rovná prokladu hlavního textu, aby se řádky textu zarovnávaly přesně na mřížku.

    Barva

    Vyberte barvu čar mřížky nebo zvolte (Barva vrstvy), chcete-li použít stejnou barvu jako má vrstva, na které je textový rámeček.

Poznámka:

Pokud nevidíte mřížku účaří v textovém rámečku, zvolte Zobrazení > Mřížka a vodítka > Zobrazovat mřížku účaří, abyste zkontrolovali, že mřížky účaří nejsou skryté. Pokud se mřížka účaří stále nezobrazuje, zkontrolujte práh zobrazení mřížek účaří v části Mřížky v dialogovém okně Předvolby. Aby se mřížka zobrazila, budete možná muset rámeček přiblížit nebo zmenšit prahovou hodnotu.

Určení počtu slov a znaků

  1. Umístěte textový kurzor do textového rámečku, chcete-li zobrazit počty pro celý řetězec rámečků (článek), nebo vyberte text, chcete-li zobrazit počty pouze pro vybraný text.
  2. Příkazem Okna > Informace zobrazte panel Informace.

Panel Informace zobrazuje počet znaků, slov, řádků a odstavců v textovém rámečku. Zobrazí se také pozice textového kurzoru v textovém rámečku.

Práce s dalšími jazyky

Můžete přiřadit jazyky různému textu. Přiřazení příslušného jazyka textu je zejména užitečné pro kontrolu pravopisu a dělení slov. (Viz Přiřazení jazyka k textu.)

Jestliže potřebujete pracovat s asijským textem, jsou k dispozici speciální verze aplikace InDesign pro japonštinu, zjednodušenou čínštinu, tradiční čínštinu a korejštinu. Tyto verze umožňují vytvářet mřížky rozvržení a mřížky rámečků pro sestavování vícebajtových znaků a zahrnují řadu funkcí pro formátování vícebajtového textu včetně doplňkových písem.

Podobně je k dispozici speciální verze aplikace InDesign pro formátování středovýchodních jazyků, jako je hebrejština, arabština, fársí a urdu, které se formátují zprava doleva. Tato verze se nazývá InDesign ME.

Další informace o zakoupení InDesign ME nebo verze InDesignu pro asijské jazyky najdete na webové stránce společnosti Adobe.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online