사용 안내서 취소

외부 에셋을 사용하여 작업

  1. Adobe XD 사용 안내서
  2. 소개
    1. Adobe XD의 새로운 기능
    2. 일반 질문
    3. Adobe XD를 사용하여 디자인, 프로토타이핑 및 공유
    4. 시스템 요구 사항
      1. 하드웨어 및 소프트웨어 요구 사항
      2. Adobe XD, Big Sur 및 Apple silicon | macOS 11
    5. 작업 영역 기본 사항
    6. Adobe XD에서 앱 언어 변경
    7. Access UI 디자인 키트
    8. Adobe XD의 접근성
    9. 키보드 단축키
    10. 팁 및 요령
    11. XD 스타터 플랜 변경 사항
  3. 디자인
    1. 아트보드, 안내선 및 레이어
      1. 아트보드 시작하기
      2. 안내선 및 그리드 사용
      3. 스크롤 가능 아트보드 제작
      4. 레이어를 사용하여 작업
      5. 스크롤 그룹 만들기
    2. 모양, 오브젝트 및 패스
      1. 오브젝트 선택, 크기 조정 및 회전
      2. 오브젝트 이동, 정렬, 배치 및 배열
      3. 오브젝트 그룹화, 잠금, 복제, 복사 및 뒤집기
      4. 오브젝트에 대한 선, 채우기 및 그림자 설정
      5. 반복 요소 만들기
      6. 3D 변형으로 원근감 있는 디자인 만들기
      7. 부울 작업을 통해 오브젝트 편집
    3. 텍스트 및 글꼴
      1. 드로잉 및 텍스트 툴을 사용하여 작업
      2. Adobe XD의 글꼴
    4. 구성 요소 및 상태
      1. 구성 요소를 사용하여 작업
      2. 중첩된 구성 요소를 사용하여 작업
      3. 구성 요소에 여러 상태 추가
    5. 마스킹 및 효과
      1. 모양이 적용된 마스크 만들기
      2. 흐림 효과를 사용하여 작업
      3. 그레이디언트 만들기 및 수정
      4. 혼합 효과 적용
    6. 레이아웃
      1. 반응형 크기 조정 및 제한
      2. 구성 요소 및 그룹에 대해 고정된 패딩 설정
      3. 스택을 사용하여 다이내믹한 디자인 제작
    7. 비디오 및 Lottie 애니메이션
      1. 비디오를 사용하여 작업
      2. Lottie 애니메이션을 사용하여 작업
  4. 프로토타입
    1. 인터랙티브 프로토타입 제작
    2. 프로토타입 애니메이트
    3. 자동 애니메이트에 대해 지원되는 오브젝트 속성
    4. 키보드 및 게임패드가 포함된 프로토타입 만들기
    5. 음성 명령 및 음성 재생을 사용하여 프로토타입 제작
    6. 시간 경과 전환 만들기
    7. 오버레이 추가
    8. 음성 프로토타입 디자인
    9. 앵커 링크 만들기
    10. 디자인 및 프로토타입 미리보기
    11. 비디오를 사용하여 프로토타입 제작
  5. 공유, 내보내기 및 검토
    1. 선택한 아트보드 공유
    2. 디자인 및 프로토타입 공유
    3. 링크 액세스 권한 설정
    4. 프로토타입을 사용하여 작업
    5. 프로토타입 검토
    6. 디자인 사양 작업
    7. 디자인 사양 공유
    8. 디자인 사양 검사
    9. 디자인 사양 탐색
    10. 디자인 사양 검토 및 댓글 달기
    11. 디자인 에셋 내보내기
    12. 디자인 사양에서 에셋 내보내기 및 다운로드
  6. 디자인 시스템
    1. Creative Cloud Library 포함 디자인 시스템
    2. Adobe XD에서 문서 에셋을 사용하여 작업
    3. Adobe XD에서 Creative Cloud Libraries를 사용하여 작업
    4. 연결된 에셋에서 Creative Cloud Libraries로 마이그레이션
    5. 디자인 토큰을 사용하여 작업 
    6. Creative Cloud Libraries의 에셋 사용
  7. 클라우드 문서
    1. Adobe XD의 클라우드 문서
    2. 디자인 공동 작업 및 편집
    3. 나와 공유된 문서 공동 편집
  8. 통합 기능 및 플러그인
    1. 외부 에셋을 사용하여 작업
    2. Photoshop의 디자인 에셋을 사용한 작업
    3. Photoshop에서 에셋 복사 및 붙여넣기
    4. Photoshop 디자인 가져오기 또는 열기
    5. Adobe XD에서 Illustrator 에셋을 사용하여 작업
    6. Illustrator 디자인 열기 또는 가져오기
    7. Illustrator에서 XD로 벡터 복사
    8. Adobe XD용 플러그인
    9. 플러그인 생성 및 관리
    10. XD에 대한 Jira 통합
    11. XD용 Slack 플러그인
    12. XD용 Zoom 플러그인
    13. XD에서 Behance로 디자인 게시
  9. iOS 및 Android용 XD
    1. 모바일 디바이스에서 미리보기
    2. Adobe XD 모바일 FAQ
  10. 문제 해결
    1. 알려진 문제 및 해결된 문제
      1. 알려진 문제
      2. 해결된 문제
    2. 설치 및 업데이트
      1. Windows에서 XD가 호환되지 않음
      2. 오류 코드 191
      3. 오류 코드 183
      4. XD 플러그인 설치 문제
      5.  Windows 10에서 XD를 제거했다가 다시 설치하라는 메시지가 표시됨
      6. 환경 설정 마이그레이션 문제
    3. 실행 및 충돌
      1.  Windows 10에서 실행 시 XD 충돌 문제
      2.  Creative Cloud에서 로그아웃하면 XD가 종료됨
      3. Windows에서의 구독 상태 관련 문제
      4. Windows에서 XD 실행 시 차단된 앱 경고 표시
      5. Windows에서 크래시 덤프 생성
      6. 충돌 로그 수집 및 공유
    4. 클라우드 문서
      1. XD 클라우드 문서 관련 문제
    5. 프로토타이핑, 게시 및 검토
      1. macOS Catalina에서 프로토타입 인터랙션을 기록할 수 없음
      2. 게시 작업 과정 관련 문제
      3. 게시된 링크가 브라우저에 표시되지 않음
      4. 프로토타입이 브라우저에서 올바르게 렌더링되지 않음
      5. 공유 링크에 댓글 패널이 갑자기 표시됨
      6. 라이브러리를 게시할 수 없음
    6. 다른 앱 가져오기, 내보내기 및 작업
      1. XD에서 가져오기 및 내보내기
      2. XD의 Photoshop 파일
      3. XD의 Illustrator 파일
      4. XD에서 After Effects로 내보내기
      5. XD의 Sketch 파일
      6. 내보내기에 서드파티 앱이 표시되지 않음

Photoshop, Illustrator, Sketch 및 웹 브라우저에서 에셋을 Adobe XD로 가져오고 After Effects로 에셋을 내보내는 방법을 알아봅니다.

Photoshop 및 Illustrator 등의 Adobe 앱과 Sketch 및 웹 브라우저 등의 서드 파티 앱에서 XD로 에셋을 가져올 수 있습니다. 이들 에셋은 XD에서 향상시키거나, 인터랙티브 프로토타입 개발에 사용할 수 있습니다. XD에서 After Effects로 에셋을 내보내 더욱 향상시킬 수도 있습니다.

앱에 따라 다양한 방법으로 외부 에셋을 사용하여 작업할 수 있습니다.

 Photoshop 및 Illustrator 파일을 XD 파일로 변환하려면 열기를 사용하십시오. 해당 파일의 내용을 기존 XD 파일에 추가하려면 가져오기를 사용하십시오.

Photoshop을 사용하여 작업

다음 방법 중 하나를 사용하여 Photoshop 에셋을 XD로 가져올 수 있습니다.

  • 파일 > 열기를 선택해 XD에서 직접 .psd 파일을 엽니다. 그런 다음 다른 모든 XD 파일과 마찬가지로 XD에서 파일을 편집하고, 인터랙션을 와이어로 연결하고, 프로토타입 또는 디자인 사양으로 공유할 수 있습니다.
  • 파일 > 가져오기를 선택해 .psd 파일을 XD로 가져옵니다.
  • Photoshop에서 비트맵 및 벡터 콘텐츠를 복사하여 XD에 붙여넣습니다. 
  • Photoshop 에셋을 라이브러리 패널에서 XD 캔버스로 드래그합니다. 자세한 내용은 Adobe XD에서의 Creative Cloud Libraries를 참조하십시오.
  • .psd 파일을 OS 클립보드로 복사하고 모양 붙여넣기 옵션을 사용하여 이미지를 이미지 채우기로 직접 붙여넣습니다. 

자세한 내용은 Photoshop에서 디자인 에셋으로 작업을 참조하십시오.

Photoshop에서 SVG 복사 및 붙여넣기

Photoshop에서 SVG를 복사하여 붙여넣으려면 Photoshop에서 모양 또는 벡터 레이어를 마우스 오른쪽 버튼으로 클릭하고 SVG 복사를 클릭한 다음 XD에서 붙여넣습니다.

Illustrator에서 에셋 가져오기

XD에서 Illustrator 파일을 열거나 가져올 수 있습니다.

또한 Illustrator 파일을 열거나 가져올 때 동일한 충실도와 편집 가능성을 유지한 상태로 Adobe Illustrator에서 벡터와 비트맵을 복사하여 XD에 붙여넣을 수 있습니다. Illustrator 파일은 별도의 문서로 열리는 것이 아니라 열려 있는 문서 내에 놓이게 됩니다. 스마트 오브젝트는 비트맵이 아닌 확장된 레이어로 가져오게 되며, 조정 레이어는 그대로 유지됩니다. 단, Illustrator 아트보드를 복사하여 XD에 붙여넣을 수는 없습니다.

또한 벡터 파일을 OS 클립보드로 복사하고 모양 붙여넣기 옵션을 사용하여 이미지를 이미지 채우기로 직접 붙여넣을 수 있습니다. 

Creative Cloud Libraries에 보관되어 있는 Adobe Illustrator 에셋을 라이브러리 패널에서 XD 캔버스로 드래그하여 XD로 가져올 수도 있습니다. 자세한 내용은 Adobe XD에서의 Creative Cloud Libraries를 참조하십시오.

XD에서 Illustrator로 SVG 복사 및 붙여넣기

이제 XD 벡터 콘텐츠를 클립보드에 복사한 다음 완전히 편집 가능한 레이어로 Adobe Illustrator에 붙여넣을 수 있습니다.

XD의 콘텐츠를 복사하여 Illustrator에 붙여넣으려면:

1. XD에서 모양 또는 벡터 레이어를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 복사를 선택합니다.

2. Adobe Illustrator에서 편집 > 붙여넣기를 선택하여 벡터 콘텐츠를 붙여넣습니다.

XD에서 Illustrator 파일 열기

XD로 Illustrator 에셋 가져오기
XD로 Illustrator 에셋 가져오기

XD에서 바로 Illustrator (.ai) 파일을 열고 XD 파일로 변환할 수 있습니다. 파일을 연 다음 XD에서 이를 편집하고, 인터랙션을 와이어로 연결하고, 프로토타입 또는 디자인 사양으로 공유할 수 있습니다.

XD에서 Illustrator 파일을 열려면 다음 중 하나를 수행하십시오.

  • XD에서 파일> 열기를 선택합니다. 필요한 폴더로 이동한 다음 .ai 파일을 선택하고 XD에서 엽니다. Cmd+O(Mac) 또는 Ctrl+O(Windows) 키보드 단축키를 사용할 수도 있습니다.
  • XD에서 파일을 열려면(Mac만 해당) XD 아이콘 위로 드래그하여 Ai 파일을 드래그합니다.
  • Illustrator 파일을 마우스 오른쪽 버튼으로 클릭한 다음 서브메뉴에서 다음으로 열기 > XD를 선택합니다.

 XD에서 Illustrator 파일을 열 때 일부 요소에 대한 정확도는 완벽하게 유지되도록 지원되지 않을 수 있습니다. 지원되는 요소와 지원되지 않는 요소에 대한 목록은 XD에서 Illustrator 파일을 열 때 지원되는 요소를 참조하십시오.

Illustrator 파일 가져오기

Illustrator 파일을 XD로 가져오려면 파일 > 가져오기를 선택합니다. 가져온 Illustrator 파일에 아트보드가 있으면 이들 아트보드는 XD 아트보드 아래에 배치됩니다. XD 아트보드 아래쪽에 공간이 부족한 경우 가져온 아트보드는 사용 가능한 공간에 배치됩니다. 가져온 파일에 아트보드가 없으면 에셋은 캔버스의 중앙에 배치됩니다. 가져온 파일에 아트보드가 없으면 에셋은 캔버스의 중앙에 배치됩니다. 

Sketch에서 에셋 가져오기

Sketch 에셋을 XD로 가져오는 다양한 방법
Sketch 에셋을 XD로 가져오는 다양한 방법

  • XD에서 .sketch 파일을 바로 열 수 있습니다. 그런 다음 다른 모든 XD 파일과 마찬가지로 XD에서 파일을 편집하고, 인터랙션을 와이어로 연결하고, 프로토타입 또는 디자인 사양으로 공유할 수 있습니다. 자세한 내용은 XD에서 Sketch 파일 열기를 참조하십시오.
  • Sketch에서 에셋을 복사하여 XD에 붙여넣을 수도 있습니다. 자세한 내용은 Sketch에서 선택한 에셋 가져오기를 참조하십시오.
  • XD에서의 편집 기능을 그대로 유지한 채 Sketch에서 XD로 직접 복사하여 붙여넣을 수도 있습니다.
  • 또한 Sketch 파일을 OS 클립보드로 복사하고 모양 붙여넣기 옵션을 사용하여 이미지를 이미지 채우기로 직접 붙여넣을 수 있습니다. 
  • Sketch 콘텐츠를 XD 디자인 시스템으로 변환할 수 있습니다. 자세한 내용은 Sketch 라이브러리 변환을 참조하십시오.

XD에서 Sketch 파일 열기

XD에서 바로 Sketch 파일(.sketch)을 열고 XD 파일로 변환할 수 있습니다. 파일을 연 다음 XD에서 이를 편집하고, 인터랙션을 와이어로 연결하고, 프로토타입 또는 디자인 사양으로 공유할 수 있습니다.

 Sketch 43 이상 버전을 사용하여 제작한 Sketch 파일만 열 수 있습니다.을 사용하여 제작한 Sketch 파일만 열 수 있습니다. 이전 파일을 보유하고 있는 경우에는 최신 버전의 Sketch를 사용하여 해당 파일을 저장한 다음 XD에서 파일을 여십시오.

XD에서 Sketch 파일을 열려면 다음 중 하나를 수행하십시오.

  • 파일 > 열기를 클릭합니다. 필요한 폴더로 이동하고 .sketch 파일을 선택한 다음 XD에서 엽니다.
  • Sketch 파일을 XD 아이콘 위로 드래그하여 XD에서 파일을 엽니다(Mac만 해당).
  • Sketch 파일을 마우스 오른쪽 버튼으로 클릭한 다음 컨텍스트 메뉴에서 다음으로 열기 > XD를 선택합니다.

Cmd+O(Mac) 또는 Ctrl+O(Windows) 키보드 단축키를 사용할 수도 있습니다.

 XD에서 Sketch 파일을 열 때 일부 요소에 대한 정확도는 완벽하게 유지되도록 지원되지 않을 수 있습니다. 지원되는 요소와 지원되지 않는 요소에 대한 목록은 XD에서 Sketch 파일을 열 때 지원되는 요소를 참조하십시오.

Sketch에서 선택한 에셋 가져오기

  1. Sketch에서 하나 이상의 레이어 또는 그룹을 선택하고 내보낼 수 있도록 설정을 클릭합니다. 

  2. 포맷으로 SVG를 선택하고 Sketch에서 XD로 레이어를 드래그합니다.

    콘텐츠가 편집 가능한 벡터 콘텐츠로 XD에 삽입됩니다.

Sketch 라이브러리를 XD 디자인 시스템으로 변환

이제 Sketch 콘텐츠를 XD로 이동하고 디자인 시스템 작업을 계속할 수 있습니다. Sketch 기호 및 요소는 XD 구성 요소로 변환될뿐만 아니라 링크된 에셋으로도 사용할 수 있습니다.

  1. XD에서 디자인 시스템을 엽니다.
  2. 에셋 패널에서 에셋 연결을 클릭합니다. 에셋 패널에 기존 에셋이 있는 경우 플러스 아이콘(+)을 클릭합니다.
  3. 에셋 링크 창에서 Sketch 라이브러리 변환을 선택한 다음 파일 선택기에서 Sketch 파일을 선택합니다. XD는 소스 Sketch 문서를 변환하여 자동으로 클라우드 문서로 저장하고 색상, 문자 스타일 및 구성 요소를 XD 문서에 연결합니다. 
  4. 작업해야 하는 여러 Sketch 라이브러리가 있는 경우 에셋 패널에서 플러스 아이콘을 클릭하고 다른 Sketch 라이브러리를 다시 가져옵니다. 

Sketch 라이브러리 및 구성 요소

다음 지침을 사용하여 XD의 구성 요소로 작업하십시오.

  1. 변환된 구성 요소를 아트보드로 드래그합니다. 
  2. 소스 구성 요소를 편집하려면 구성 요소 인스턴스를 클릭하고 마우스 오른쪽 버튼을 클릭한 후 소스 문서에서 마스터 편집을 선택합니다. 
  3. 에셋을 편집하려면 에셋 패널에서 에셋을 선택합니다.
  4. 변경 사항이 적용되면 작업 문서로 전환합니다.
  5. 업데이트를 클릭하여 변경 내용을 수락합니다 

자세한 내용은 XD에서 구성 요소를 사용하여 작업을 참조하십시오.

자세한 내용 보기

이 영상 일러스트레이션을 시청하여 Sketch 라이브러리를 XD 디자인 시스템으로 변환하는 방법에 대해 자세히 알아보십시오.

시청 시간: 30초

1

웹 브라우저에서 에셋 가져오기

모든 최신 웹 브라우저에서 이미지를 직접 드래그하여 내 아트보드 위에 놓을 수 있습니다. 이미지를 드래그하여 아트보드에 있는 오브젝트에 놓을 수도 있습니다. 이렇게 하면 이미지 크기가 해당 오브젝트에 맞게 자동으로 조정됩니다.

또한 이미지를 OS 클립보드로 복사하고 모양 붙여넣기 옵션을 사용하여 이미지를 이미지 채우기로 직접 붙여넣을 수 있습니다. 

기타 파일 가져오기

PNG, JPG, TIFF, GIF, SVG, 지원되는 비디오Lottie 파일 같은 에셋을 가져오려면 다음 작업 중 하나를 수행하십시오.

  • 파일 > 가져오기를 클릭하고 파일을 찾아 선택합니다.
  • 파인더 또는 Windows 파일 탐색기에서 파일을 XD로 드래그합니다. 이미지 파일을 복사하고 붙여넣을 수도 있습니다.

After Effects로 내보내기

에셋을 After Effects로 내보내기
에셋을 After Effects로 내보내기

 XD에서 After Effects 2018 이상 버전으로만 내보낼 수 있습니다. 이전 버전이 설치되어 있는 경우 After Effects로 내보내기 옵션은 비활성화됩니다. 이 옵션을 사용하려면 Creative Cloud 데스크탑 앱에 로그인하고 After Effects를 최신 버전으로 업데이트하십시오.

After Effects를 사용하여 XD 디자인을 맞춤형 애니메이션 또는 마이크로인터랙션으로 바꾸려면 다음을 수행하십시오.

  • XD에서 After Effects에 애니메이션을 적용할 레이어 또는 아트보드를 선택합니다. 
  • 파일> 내보내기 > After Effects를 선택합니다. After Effects가 컴퓨터에 설치되어 있지 않으면 이 옵션은 회색으로 표시됩니다. ⌥⌘F(Mac) 또는 Ctrl+Alt+F (Windows) 키보드 단축키를 사용할 수도 있습니다. After Effects는 시작하거나(닫힌 경우) 전경으로 이동합니다(배경에서 실행중인 경우).
  • 선택한 레이어 또는 아트보드는 기본 모양, 단락 간격을 포함한 텍스트, 에셋, 안쪽 및 바깥쪽 획, 중첩된 컴포지션으로 After Effects 프로젝트에 추가됩니다. 동일한 After Effects 프로젝트에 여러 에셋 전송을 수행하고 여러 단계 또는 여러 XD 파일에서 애니메이션을 만들 수 있습니다.

 XD 콘텐츠를 After Effects로 내보낼 때 일부 요소에 대한 정확도는 완벽하게 유지되도록 지원되지 않을 수 있습니다. 지원되는 요소와 지원되지 않는 요소에 대한 목록은 XD 파일을 After Effects로 내보낼 때 지원되는 기능을 참조하십시오.

가져오기 및 내보내기 제한 사항

가져오기 및 내보내기 제한 사항에 대해 알아보려면 Adobe XD에서 파일을 가져오거나 내보낼 수 없는 이유는 무엇입니까?
를 참조하십시오.

Adobe 로고

내 계정 로그인