Although increasing performance is always a goal for the Lightroom team, new and improved features continue to require system resources. 

Performance issues that have surfaced online have been greeted with many different suggestions. The Lightroom team wants to provide customers with solutions that work. The team would also like to make sure that you're aware of any risks involved in any supported solutions. 

This TechNote is a list of less-traditional suggestions to performance issues that customers have described on social media sites. It will be updated as solutions are found or become outdated. For more traditional solutions and suggestions, see this TechNote.

Restart Lightroom

Refreshing memory in your computer by restarting Lightroom is the first thing to try, and relieves many slow-downs.

Update to the most recent version of Lightroom

To update Lightroom, choose Help > Check For Updates in Lightroom.

In Lightroom 5.6 reduce the number of Develop presets

In Lightroom 5.6, if you have numerous Develop presets loaded, performance might decrease. The exact number of presets will depend on your computer. Lightroom was tested with 1000, so try reducing the number to around 1000 to start with, then see if that increases performance. If that works, try increasing the presets until you find the number that works with your computer.


RAM: The minimum system requirement is 2 GB. But 16 GB can improve performance considerably, especially if you use other applications at the same time, like Photoshop.

SSD drives: If you have a solid-state drive, Lightroom is faster if you put your catalog (the .lrcat file) and image previews (the .lrdata file) on the SSD drive.

Update your video driver

Updated display drivers can fix many issues, such as crashing, incorrectly rendered objects, and performance problems.

To update the display driver on Windows 7 or Vista, see this TechNote.

On Mac OS, most video driver updates are installed with OS updates. However, Nvidia does provide some drivers. For Nvidia video cards, go to the Nvidia website.

Catalog location

The default location for your catalog is the My Pictures > Lightroom folder (Windows) or the Pictures > Lightroom folder (Mac OS). Your image preview file ([catalog name Previews.lrdata]) is in the same location as your catalog. You can move your catalog and previews file to any location. However, if you do, make sure you can remember the name and location of the catalog and the previews file.

After you move your catalog, point Lightroom to its new location. When you reopen Lightroom, you're asked to locate your catalog. Select Choose a Different Catalog:

Lightroom Catalog location

Next, the Select Catalog dialog box appears. Select your catalog. If your moved catalog is not listed, select Choose a Different Catalog. Then, navigate to the new location in the Finder window that opens.

Lightroom choose a different dialog

If the dialog box below opens, select Choose a Different Catalog until the Finder window opens. Navigate to the new location of your current catalog.

Lightroom choose a different dialog

If you use Photoshop with Lightroom, check Photoshop's RAM setting

See the Max Out on RAM and Memory Usage sections in this TechNote to determine the best RAM settings for your computer. To change your memory settings in Photoshop, choose Apple > Preferences > Performance (Mac OS) or Edit > Preferences > Performance (Windows).

High-resolution displays

Drawing to the screen can be slow when Lightroom is using the entire screen of a high-resolution display. A high-resolution display has a native resolution near 2560 x 1600, and is found on 30-inch monitors and Retina MacBooks. To increase performance on such displays, reduce the size of the Lightroom window, or use the 1:2 or 1:3 views in the Navigator panel.

Develop module

Spot Removal tool, local corrections, and History panel

The Spot Removal Tool and Local Corrections Brush are not designed for hundreds to thousands of corrections. If your image contains many (hundreds) of localized adjustments, consider using a pixel-based editing application such as Photoshop for that level of correction.

If you have many corrections, check your History panel. The History panel has no limits, and it isn't deleted unless specified. If you've been creating many local or spot corrections, your history could be long, which can slow Lightroom's performance as a whole.

Clear the History panel by clicking the X on the right of the History panel header.

Order of Develop operations

The best order of Develop operations to increase performance is as follows:

  1. Spot healing.
  2. Geometry corrections, such as Lens Correction profiles and Manual corrections, including keystone corrections using the Vertical slider.
  3. Global non-detail corrections, such as Exposure and White Balance. These corrections can also be done first if desired.
  4. Local corrections, such as Gradient Filter and Adjustment Brush strokes.
  5. Detail corrections, such as Noise Reduction and Sharpening.

Note: Performing spot healing first improves the accuracy of the spot healing, and ensures the boundaries of the healed areas match the spot location.

Avoid corrections that you don't need

This suggestion applies especially to local corrections. Each slider you've changed when applying local corrections or the gradient filter is applied to that entire correction. And, each option uses resources and can affect performance.

When applying local corrections and gradients, make sure that you need all the corrections you've selected.

If you do not need a brush stroke or gradient to perform a certain type of correction, set its slider to zero.

Also avoid using unnecessary global corrections, especially options that use resources, such as Noise Reduction, Sharpening, and Lens Corrections.

Some sliders default to a value that turns them on by default. For the more resource-intensive options, zero does disable the slider.

Zoom options

If the Fit and Fill zoom options are slow, try using the 1:2, 1:3, or 1:4 options in the Navigator panel.

Which Process Version to use

Process Version 2012 does take more resources than Process Version 2010, so in some cases it could be slower. However, it's necessary to balance the performance gain with the editing and image quality available with Process Version 2012.

Increase the Camera Raw cache

Increasing the Camera Raw cache in Lightroom's preferences can help performance in the Develop module if you repeatedly work on the same set of images.

To reset the Camera Raw cache:

  1. In Lightroom, select Edit > Preferences > File Handling (Windows) or Lightroom > Preferences > File Handling (Mac OS).
  2. Increase the Camera Raw cache. If you're not sure how much to increase it, start with 2-3 GB initially, depending on the amount of space on your hard disk, and how you use Lightroom.
  3. You can also change the location of the cache if you want.

Delete the Lightroom previews cache

Although it's rare, sometimes one or more of the following issues can occur, and if they do, you may need to delete your preview cache file:

  • Your hard disk gets unexpectedly full.
  • You get an error about your cache in Lightroom.
  • You get artifacts—such as lines, dots, or unexpected colored areas—in your images.

The file that contains your thumbnail and preview data is called [Catalogname] Previews.lrdata, and is in the same folder as your catalog.

Your thumbnails, small previews, and 1:1 (full size) previews are kept in this Previews.lrdata file. Lightroom's preferences have the option of when to delete the largest previews, the 1:1 previews. When you delete the 1:1 previews, the size of the Previews.lrdata file is reduced. If you don't delete 1:1 previews, the previews file can get very large. 

The default setting for when the large 1:1 previews are deleted is one week. The size of the preview file is reduced when these large previews are deleted, but the entire file isn't deleted unless you manually delete it. The file doesn't become huge unless you rarely or never delete the 1:1 previews, but whether it affects your hard disk depends on your available hard disk space. You can change how often the 1:1 previews are deleted by choosing Edit > Catalog Settings > File Handling (Windows) or Lightroom > Catalog Settings > File Handling (Mac OS). 

Note: Do not confuse the Previews.lrdata file discussed in this technote with the [Catalogname] Smart Previews.lrdata file, which contains all your Smart Previews. In cases where there is very limited hard disk space, you may need to delete this file, but if your hard disk space is low enough that you get low hard disk errors, you should empty your trash, archive some files, and/or reoganize your data so there's more open hard disk space. 

If you delete the Previews.lrdata file, previews are recreated for each folder or collection you open in Lightroom, so the first time you work in a folder, you'll experience some delay while previews are recreated.

If the option to Automatically Discard 1:1 Previews is set to Never or After 30 Days, your preview file can get very large. It can take up many GB of space. If your hard disk suddenly gets full, check the size of this file. You can then delete the file. 

You may get an error in Lightroom that indicates a problem with the cache; this is another time you'd want to delete your previews.lrdata file.

If your images display with artifacts, such as colored lines, colored dots, or areas of unexpected colors, then your preview file may be corrupted, and the only way to fix this is to delete the previews.lrdata file. 

Note that if you included previews of images in your catalog from images that you've archived, you'll lose these prevews as well. 

If deleting the Previews.lrdata file does not solve your issue, try purging your Camera Raw cache file. 

  1. In Lightroom, choose Edit > Preferences > File Handling (Windows) or Lightroom > Preferences > File Handling (Mac OS).
  2. Click Purge Cache under the Camera Raw Cache Settings. 

You can also change the location of this cache by clicking Choose. Note that this cache is used only by the Develop module. 

Reduce the number of presets

Adding presets to Lightroom (whether created by you or a third-party) can reduce performance because the Develop module generates thumbnails in the Navigator panel for each preset. This is most strongly seen once you have 2,000 or more presets. Reduce the number of presets loaded into Lightroom to only those you use most often to avoid this type of slow down.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy