What's covered
Optimize your operating system, hardware, and Photoshop setup to maximize performance.
On this page


    Use the following information to improve Photoshop's performance

    In general, you should take a holistic approach to optimizing Photoshop's performance for your needs. Read all of the suggestions here. Consider which ones to implement within the context of your computer setup, the types of files you use, and your particular workflow. Each circumstance is unique and requires a different combination of techniques to get the most efficient performance from Photoshop.

    There are four primary ways to affect performance in Photoshop:

    • Specify Photoshop performance preferences
    • Use good work habits in Photoshop
    • Optimize your hardware setup
    • Optimize your operating system for Photoshop

    The easiest way to improve performance, without spending money, is to set your Photoshop preferences and fine-tune its features to take advantage of the way you work and the type of files you typically work with.

    The most dramatic way to increase performance is investing in faster and more-powerful hardware.

    Set Photoshop Performance preferences

    You can improve performance by adjusting memory allocation. The Memory Usage area of the Performance preferences dialog box tells you how much RAM is available to Photoshop. It also shows the ideal range for your system. By default, Photoshop uses 70% of available RAM.

    You can assign more or less RAM to Photoshop by changing the value in the Let Photoshop Use box. Or, you can drag the Memory Usage slider. Restart Photoshop to enable your changes.

    If you experience out-of-RAM or out-of-memory errors in Photoshop, increase your RAM allocation. With no other applications running, you can increase the RAM allocation to 100% to improve Photoshop performance.

    To find the ideal RAM allocation for your system, change it in 5% increments and monitor performance in the Efficiency indicator. See Keep an eye on the Efficiency indicator.

    Photoshop performance preferences

    scratch disk is any drive or drive partition with free memory. By default, Photoshop uses the hard drive on which the operating system is installed as the primary scratch disk.

    To improve performance, set the scratch disk to a defragmented hard disk that has plenty of unused space and fast read/write speeds. If you have more than one hard drive, you can specify additional scratch disks. Photoshop supports up to 64 exabytes of scratch disk space on up to four volumes. (An exabyte equals 1 billion GB.)

    If your startup disk is a hard disk, as opposed to a solid-state disk (SSD), try using a different hard disk for your primary scratch disk. An SSD, on the other hand, performs well as both the primary startup and scratch disk. In fact, using an SSD is probably better than using a separate hard disk as your primary scratch disk.

    The following guidelines can help you assign and manage your scratch disks:

    • For best performance, scratch disks should be on a different drive than any large files you are editing.
    • Scratch disks should be on a different drive than the one your operating system uses for virtual memory.
    • RAID disks/disk arrays are good choices for dedicated scratch disk volumes.
    • Drives with scratch disks should be defragmented regularly.
    To manage your scratch disks:
    1. Choose Edit > Preferences > Scratch Disks (Windows) or Photoshop > Preferences > Scratch Disks (Mac OS).
    2. To change the scratch disk order, click the arrow buttons.
    3. To enable or disable a scratch disk, select or deselect the Active checkbox.
    4. Click OK. To apply the changes, restart Photoshop.

    If Photoshop cannot launch because the scratch disk is full, hold down the Cmd + Opt keys (Mac) or Ctrl + Alt keys (Windows) on launch to set a new scratch disk.

    Photoshop uses image caching to speed the redrawing of high-resolution images. You can specify up to eight levels of cached image data. Increasing cache levels will improve Photoshop’s responsiveness while you work, although it will take longer to load images.

    Three cache presets are available in the Performance preferences panel. These options set your cache level and tile size (the amount of data on which Photoshop operates at a time) based on the kind of document you’re editing and the amount of RAM you have. Bigger tiles speed up complex operations, such as sharpening filters. Smaller changes, such as brush strokes, are more responsive with smaller tiles.

    • Tall and Thin: Better for editing images with smaller pixel dimensions that have many layers (dozens to hundreds).
    • Big and Flat: Better for editing images with larger pixel dimensions (many tens to hundreds of megabytes) and fewer layers.
    • Default: For images in between.

    For more control, you can manually set cache levels (the default value is 4):

    • If you use relatively small files—roughly 1 megapixel or 1280 by 1024 pixels—and many layers (50 or more), set Cache Levels to 1 or 2. Setting Cache Levels to 1 disables image caching; only the current screen image is cached.
    • If you use files with larger pixel dimensions—say, 50 megapixels or larger—set Cache Levels higher than 4. Higher cache levels speed up redrawing.

    You may not get high-quality results with some Photoshop features if you set Cache Levels to 1.

    You can save scratch disk space and improve performance by limiting or reducing the number of history states Photoshop saves in the History panel. The amount of space you save varies depending on how many pixels an operation changes. For example, a history state based on a small paint stroke or a non-destructive operation, such as creating or modifying an adjustment layer, consumes little space. Applying a filter to an entire image, on the other hand, consumes much more space.

    Photoshop can save up to 1,000 history states; the default number is 20. To reduce that number, go to the Performance preference dialog box, choose History & Cache > History States. In the History States pop-up menu, drag to a lower value.

    The best way to optimize GPU acceleration, which speeds up screen redraws, is to keep your video adapter driver up to date. For more information about GPU acceleration and instructions on updating video adapter drivers, see Photoshop GPU and video card FAQ.

    Turning on OpenCL, a technology that lets applications use the GPU, is likely to improve performance if you use these Photoshop features:

    • Video Panorama
    • Blur Gallery (Iris, Field, and Tilt-shift Blur)

    To turn on OpenCL, in the Performance Preferences panel, click Advanced Settings and select Use OpenCL.

    Fine-tune Photoshop features

    Follow these tips to customize and speed up Photoshop performance to match your working style.

    The Save In Background preference is on by default. When it is on, Photoshop lets you continue working while Save and Save As commands are performed, instead of requiring you to wait until they complete. The Automatically Save Recovery Information preference is enabled only if Save in Background is on. When enabled, recovery information is saved for each open file at the specified interval. (Recovery information is saved as a redundant backup; your original file is not modified.)

    In most cases, background save operations do not significantly affect the performance or responsiveness of normal Photoshop operations. However, if you are editing a file that is much larger than available RAM, the save operation can affect responsiveness or performance until the save is complete.

    If Photoshop seems to intermittently slow down, you can check whether background save is affecting performance. Choose Save Progress in the status pop-up menu on the lower left of your image window.

    If you notice performance issues while the Save Progress bar is moving, go to Preferences > File Handling, and decrease the frequency of the Automatically Save Recovery Information preference. Or, turn off the preference.

    Fine-tune Photoshop

    Setting a lower value for the recovery interval gives you more protection against crashes. In most cases, saving the recovery information does not affect the performance or responsiveness of Photoshop. However, a slowdown in performance is most likely if the files you’re modifying are larger than the available RAM.

    Recovery information is saved in the same locations as the Photoshop scratch files. If you regularly keep many large files open while working, the amount of space can be significant. If you get out-of-disk-space errors while performing commands other than Save commands, add scratch disk space. Or, disable the Automatically Save Recovery Information preference.

    Very large files are often the cause of performance problems. Photoshop supports a maximum file size of 300,000 x 300,000 pixels, except for PDF files, which are limited to 30,000 x 30,000 pixels and 200 x 200 inches.

    File size capability for Photoshop:

    • PSD files: 2 GB
    • TIFF files: 4 GB
    • PSB files: 4 exabytes (4096 petabytes or 4 million terabytes)
    • PDF files: 10 GB (pages are limited to a maximum size of 200 inches)

    Watch the Efficiency indicator to monitor performance while you work in Photoshop. Click the pop-up menu at the bottom of the image window and choose Efficiency.

    If the value in the indicator is below 100%, Photoshop has used all available RAM and is using the scratch disk, which slows performance. If the efficiency is less than 90%, allocate more RAM to Photoshop in Performance preferences. Or, add additional RAM to your system.

    Efficiency indicator

    If you receive an “out of RAM” error message or if Photoshop is running slowly, it could be caused by having too many open images. If you have several windows open, try closing some of them.

    To reduce the amount of scratch disk space Photoshop uses, minimize the number of patterns and brush tips you keep loaded. Save presets you don’t require right now to a preset file. Or delete them if they were loaded from a preset file.


    See Work with the Preset Manager to find out more about managing preset patterns and brush tips.

    Each time you change a document, Photoshop updates all the thumbnails visible in the Layers and Channels panels. This update can affect responsiveness when you’re rapidly painting, moving, or nudging layers. The more thumbnails visible, the greater this effect.

    To minimize or disable these thumbnail previews, click the Panel menu and choose Panel Options. Select a smaller thumbnail size or select None, and then click OK.

    Layers panel

    If you don’t need to work with your PSD and PSB files in older versions of Photoshop or in applications that don’t support layers, you can turn off a file compatibility feature in order to speed up document saving:

    1. In Preferences > File Handling, for 16-bit and 32-bit PSD and PSB documents, select Disable Compression of PSD and PSB Files.

    2. From the Maximize PSD and PSB File Compatibility menu, choose Ask or Never.

      Maximize PSD and PSB file compatibility

      See Maximize compatibility when saving files for more information.

    Photoshop can perform many operations on 16-bit and 32-bit images. However, these images require more memory, scratch space, and time to process than 8-bit images.

    To convert your image to 8 bits per channel, choose Image > Mode > 8 Bits/Channel. See Bit Depth in Photoshop Help for more information.


    Converting to 8 bits per channel deletes data from your image. Save a copy of the original 16-bit or 32-bit image before you convert to 8 bits per channel.

    To speed font processing in Photoshop, turn off the WYSIWYG font preview list by choosing Type > Font Preview Size > None.

    The greater the image resolution, the more memory and disk space Photoshop requires to display, process, and print an image. Depending on your final output, higher image resolution does not necessarily provide higher final image quality, but it can slow performance, use additional scratch disk space, and slow printing. The optimal resolution for your images depends on how the images will be displayed or printed. 

    For images presented onscreen, think in terms of total pixel dimensions. For example, many web images are no more than 725 pixels wide. To reduce the image dimensions of an image, choose Image > Image Size. In the Image Size dialog box, make sure that the Resample option is selected. Enter a new value for the Dimensions Width or Height (entering a value for one changes both).

    Reduce image resolution

    For printed images, increasing resolution beyond about 360 DPI brings marginal if any benefits in most cases. If you produce many prints, experiment to find a resolution that gives you pleasing results. To reduce the resolution of an image, choose Image > Image Size. In the Image Size dialog box, select Resample. Change the Width and Height values to reflect the physical size of your printed document. Then, decrease the Resolution value, and click OK.

    If you are going to increase the image resolution for printing rather than decrease it, perform this resolution increase as one of your last steps before printing the image. That way, you don’t have to process all this extra information in earlier steps.

    You can improve system performance by freeing up unused memory and scratch disk space from Photoshop to make it available to other programs. To do so, choose one of these options:

    • Edit > Purge > All
    • Edit > Purge > Undo
    • Hold down Option (Mac OS) or Alt (Windows) and choose About Photoshop CC

    If other programs are actively trying to allocate or use the memory, freeing up memory in Photoshop will improve performance. Freeing up scratch disk space will be beneficial if you're out of space on a disk volume. If you free up significant memory or disk space, Photoshop will be slower the next time you open large files, while Photoshop allocates space.

    If you want Photoshop to always use less memory, choose Edit > Preferences >Performance (Windows) or Photoshop > Preferences > Performance (Mac OS) and move the Memory Usage slider to the left. See Adjust memory use.


    Activity monitors, task managers, and disk utilities may take several seconds to register the change. In fact, for some utilities, you may need to explicitly request the update.

    The contents of the clipboard are often large if you’ve been copying and pasting data within large documents. And, those contents are of little use when you’re done pasting. To free up RAM being used by image data in the clipboard, choose Edit > Purge > Clipboard.


    The Purge command cannot be undone.

    The Filter Gallery allows you to test one or more filters on an image before applying the effects, which can save considerable time and memory. See Filter Gallery overview for more information.

    Dragging layers or files is more efficient than copying and pasting them. Dragging bypasses the Clipboard and transfers data directly. Copying and pasting can potentially involve more data transfer and is much less efficient.

    Layers are fundamental to working in Photoshop, but they increase file size and redraw time. Photoshop recomposes each layer after each change in the image. After you complete changes to layers, flatten (merge) them to reduce file size. Select the layers in the Layers panel, right-click (Windows) or Control-click (Mac OS) and choose Merge Layers. To flatten all layers in a file, choose Layer > Flatten Image. Also make sure to remove any empty layers from the file.


    Photoshop does not let you separate layers after merging them. You can either choose Edit > Undo or use the History panel to return to an unmerged state.

    If you don’t frequently change some of your layers, consider converting layers or layer sets into Smart Objects, which saves disk space and improves performance. Select the layers or layer sets in the Layers panel, right-click (Windows) or Control-click (Mac OS) and choose Convert To Smart Object. See Work with Smart Objects.

    Photoshop can save layers in TIFF files. However, layered TIFF files are larger than flat TIFF files and require more resources for processing and printing. If you work with a layered TIFF file, save the original layered file as an Adobe Photoshop (.psd) file. Then, when you are ready to save the file in TIFF format, choose File > Save As. In the Save As dialog box, choose Format > TIFF, select Save As A Copy, deselect Layers, and click Save.

    For added speed when exporting TIFF files, do not choose ZIP compression. (ZIP compression produces the smallest TIFF files, however.)

    The Export Clipboard option causes Photoshop to make the contents of the clipboard available to other programs. If you copy large amounts of data in Photoshop, but won’t paste it into other applications, save time by turning off this option:

    1. Choose Photoshop > Preferences > General (Mac OS) or Edit > Preferences > General (Windows).

    2. Deselect Export Clipboard.

    3. Click OK.

    Optimize your hardware setup for Photoshop

    If you’re interested in modifying your current hardware setup (or perhaps if you’re buying a new system), use the following information to optimize it for Photoshop.

    The speed of the computer’s central processing unit, or CPU, limits the processing speed of Photoshop. Photoshop requires a multicore Intel processor (Mac OS) or a 2 GHz or faster processor (Windows).

    Photoshop generally runs faster with more processor cores, although some features take greater advantage of the additional cores than others. However, you’ll get diminishing returns with multiple processor cores: The more cores you use, the less you get from each additional core. Therefore, Photoshop doesn’t run four times as fast on a computer with 16 processor cores as on a computer with four cores. For most users, the increase in performance that more than six cores provides doesn’t justify the increased cost.


    If you are running Photoshop in a virtual environment, Photoshop's GPU use can cause performance issues. Virtual machines cannot access the GPU.

    Photoshop uses random access memory (RAM) to process images. If Photoshop has insufficient memory, it uses hard-disk space, also known as a scratch disk, to process information. Accessing information in memory is faster than accessing information on a hard disk. Therefore, Photoshop is fastest when it can process all or most image information in RAM.

    For the latest version of Photoshop, at least 8 GB of RAM is recommended.

    For instructions on how you can specify how much RAM to allocate to Photoshop, see Memory usage.

    Photoshop reads and writes image information to disk when your system doesn’t have enough RAM to contain all of it. The Efficiency indicator can help you determine whether getting a faster hard disk or solid-state disk would improve your performance. If the efficiency number is usually above 95%, spending money on a faster scratch disk has little benefit.

    To improve Photoshop performance, use a disk with a fast data transfer rate. For example, use an internal hard disk or an external disk connected via a fast interface such as Thunderbolt, FireWire 800, eSATA, or USB3. Network servers (hard disk accessed over a network) have slower data transfer rates.

    The latest version of Photoshop requires at least 2.5 GB (Windows) or 3.2 GB (Mac OS). Installation requires additional space, and Adobe recommends more hard-disk space for virtual memory and scratch disk space.

    Fast RAID 0 arrays make excellent scratch disks, especially if you use the array exclusively for your scratch disk. Also make sure that you defragment the array regularly, and don’t use it as your startup volume.

    To gain the greatest benefit from an SSD, use it as the scratch disk. Using it as a scratch disk gives you significant performance improvements if you have images that don’t fit entirely in RAM. For example, swapping tiles between RAM and an SSD is much faster than swapping between RAM and a hard disk.

    If your SSD doesn’t have much free space (the scratch file grows bigger than can fit on the SSD), add a secondary or tertiary hard disk. (Add it after the SSD.) Make sure that these disks are selected as scratch disks in the Performance preferences.

    Also, SSDs vary widely in performance, much more so than hard disks. Using an earlier, slower drive results in little improvement over a hard disk.


    Adding RAM to improve performance is more cost effective than purchasing an SSD.

    If the Efficiency indicator is already high, an SSD doesn’t improve performance. The lower the Efficiency indicator, the greater the improvement an SSD offers.

    For more information on performance and 64-bit Photoshop, see 64-bit OS benefits, limitations.

    Optimize your operating system for Photoshop

    Use the following information to set up and use your operating system efficiently with Photoshop.

    Other open applications and startup items decrease the amount of memory available to Photoshop. To free up additional memory, quit unnecessary applications, startup items, and extensions. Then, make more memory available to Photoshop.

    From time to time, run Disk Cleanup to remove temporary files and any other files that are not being used.

    1. Click the Start button, type Disk Cleanup in the Search text box, and choose Disk Cleanup from the Programs list.

    2. Select a drive to clean up.

    3. Select Temporary Files and any other files that you want to delete.

    4. Click OK.

    Photoshop takes longer to read or write a fragmented file than one saved to a contiguous location.

    For instructions on defragmenting hard disks on Windows, see these Microsoft Help topics:

    • (Windows 7 and Vista) ”Improve performance by defragmenting your hard disk”
    • (Windows 8) “Optimize your hard drive”

    Fragmentation is rarely a problem on Mac OS, unless you normally run with the drive nearly full.

    Solid-state disks do not require defragmenting, because their performance doesn’t degrade significantly with normal levels of fragmentation.


    RAID arrays don’t become fragmented. Fragmentation is more likely to be an issue if you use a single disk for everything. It can also be an issue if permanent files and the Photoshop scratch disk share a volume, especially if the volume doesn’t have much free space. In this case, defragmenting the disk can make a significant difference.

    Updates to the Windows or Mac OS X operating system improve its performance and compatibility with applications.

    For Windows, turn on Windows Update.

    For Mac OS X, use Software Update.

    Specifying a fixed virtual memory setting helps prevent Photoshop scratch disk files from competing for the space with virtual memory (especially if you set the virtual memory setting on a different drive from the primary scratch disk). Be sure to use a drive with enough free, contiguous space for the best performance. Also, keep the paging file on a separate, empty, defragmented hard disk.

    As always, the advice to use separate disks for virtual memory and scratch disks does not apply to solid-state disks. With an SSD, putting all of the most heavily-used files on an SSD is beneficial, and carries little or no penalty.

    To change virtual memory, quit all applications and then do the following:

    1. Choose Start > Control Panel, and double-click System.

    2. In the Tasks list, choose Advanced System Settings, and click the Advanced tab.

    3. In the Performance section, click Settings.

    4. Click the Advanced tab, and then click Change.

    5. Deselect Automatically Manage Paging File Size For All Drives.

    6. Click each hard disk letter to show the available space on that drive. Select a hard drive that has three times the amount of your computer’s installed RAM and doesn’t contain a scratch disk.

    7. Select Custom Size, and enter the amount of your physical RAM plus 300 MB in the Initial Size box. Enter three times the amount of your computer’s installed RAM into the Maximum Size box.

    8. Click Set, and then click OK. Continue to click OK to exit all dialog boxes.

    9. Restart the computer: If you have applications open, select Restart Later, close your applications, and then restart Windows. Otherwise, click Restart Now.

    To change Virtual Memory in Windows 8, quit all applications and then do the following:

    1. Click Start > Control Panels. If you don’t see the Start button, choose the folders icon and search your computer for control panel.

    2. Choose System and Security > System.

    3. Follow the steps above, beginning with step 3.

    Back to top