For Premiere Pro system requirements, see the Adobe website.

For tips on optimizing a computer system and Premiere Pro for performance, see this white paper.

Set up a DV or HDV system

DV/HDV capture setup
DV/HDV setup

A. Computer and computer monitor B. 6-pin FireWire port and connector C. 4-pin FireWire port and connector D. DV/HDV camcorder E. RCA jacks and plugs for L (white) audio, R (red) audio, composite video (yellow); jack and plug for S-Video (y/c) F. HDMI port and connector G. Television monitor 

With this setup, you can capture audio and video from a DV or HDV source. You can monitor the signal on a TV monitor while editing. Finally, you can export any sequence back to videotape.

  1. Connect the DV or HDV camcorder or VTR to the computer using a FireWire cable.
  2. Connect the camcorder or VTR to the television monitor with an S-Video or RCA video cable and RCA audio cables, or an HDMI cable.
  3. Set the camcorder or VTR to VTR or Play mode.
  4. (For HDV camcorders or VTRs only) Make sure the device is in DV playback mode for DV projects, or HDV playback mode for HDV projects. See the user manual for your device for details.

Set up an SD-SDI, HD-SDI, or component system

SDI/component setup with breakout box
SDI/component setup with breakout box

A. Computer and computer monitor B. (Optional) A/V breakout box C. XLR jacks and plugs for L & R audio D. RS232/422 port and connector E. BNC jacks and plugs for Y/Pb/Pr component video, BNC jack, and plug for SDI video F. HD/SD VTR G. BNC jacks and plugs for Y/Pb/Pr component video, BNC jack, and plug for SDI video H. RCA jacks and plugs for L (white) & R (red) audio I. Speakers J. Television monitor 

With this setup you can capture audio and video from an SD-SDI, HD-SDI, or component video device (camcorder or VTR). You can monitor the signal on a TV monitor while editing. Finally, you can export any sequence back to the camcorder or VTR.

This setup requires either an SDI or component PCI card installed in the computer. Alternatively, it requires an external SDI or component device connected to the computer via FireWire. Either an internal card or an external device would provide ports, usually with BNC connectors, capable of receiving SDI or component video signals.

Some SDI and component PCI cards come with breakout boxes which provide ports for the SDI or component signals. Some breakout boxes also provide ports for genlock. Others provide the necessary outputs directly on the card.

  1. Connect the SD-SDI, HD-SDI, or component device to the computer or breakout box using SDI or component video cables. A single cable with BNC connectors carries SDI video, but three separate cables with BNC connectors carry component video signals. Run video cables from the video outputs of the computer or breakout box to the video inputs of the device. Also run video cables from the video outputs of the device to the video inputs of the computer or breakout box.
  2. Connect the SD-SDI, HD-SDI, or component device to the computer or breakout box using XLR audio cables. Run audio cables from the audio outputs of the computer or breakout box to the audio inputs of the device. Also run audio cables from the audio outputs of the device to the audio inputs of the computer or breakout box.
  3. Do one of the following:
    • Connect the serial device control port (RS-422 or RS-232) on the camcorder or VTR with the serial port (Windows) or USB port (Mac OS) on the computer. Use the Pipeline Digital ProVTR cable for RS-232/422-controlled devices.

    • If your system has a breakout box with a serial device control port (RS-422 or RS-232), connect the serial device control port on the device with this port on the breakout box. Do not connect the serial control port on the device with the serial or USB port on the computer. Some breakout boxes require a standard serial 9-pin D-Sub cable instead of the Pipeline Digital ProVTR cable. Consult the documentation from the manufacturer of the breakout box.

    Note:

    Native serial device control is available in Windows only.

  4. Connect the deck or camcorder to the television monitor with component video cables and to amplified speakers with RCA audio cables.
  5. Put the camcorder or deck into VTR or Play mode.
  6. In Premiere Pro, select File >New > Sequence.
  7. In the Available Presets area of the New Sequence dialog box, select the SDI or component preset that matches the format of your source footage. Premiere Pro does not provide these presets. Manufacturers of SDI cards, component capture cards, and other devices provide these presets. The presets must be installed with those cards and devices.
  8. Type a name in the Sequence Name box. Then click OK.

Set up a file-based system

File-based system
File-based system

A. Card reader, drive, or camcorder for P2, XDCAM HD, XDCAM EX, or AVCHD media B. Computer and computer monitor C. Audio cables running to speakers or amplifier D. Speakers  E. TV monitor F. BNC connectors for component or SDI video cables to TV monitor (alternative to “G”) G. HDMI connector for audio-video cable to TV monitor (alternative to “F”) 

With this setup, you can import or transfer audio and video files from card readers, drives, or tapeless camcorders recorded in any of the following digital video file formats:

  • Panasonic P2

  • XDCAM HD

  • XDCAM EX

  • AVCHD

  • AVC-I

You can also preview video on a high-definition TV monitor, if your computer has one of the following:
  • a high-definition capture card,

  • a display card with component, SDI or HDMI outputs.

  1. Connect the card reader, disk drive, or camcorder to the computer, typically with a USB 2.0 cable. Check the manual for your device for details.
  2. Connect the output of the computer sound card to computer speakers or audio amplifier.
  3. Connect the video outputs from the capture card, breakout box, or display card to the TV monitor using component, SDI, or HDMI cables.

Set up an S-Video or composite system

S-Video/composite setup
S-Video/composite setup

A. Computer and computer monitor B. Ports and connectors for FireWire, USB 2.0 C. A/D converter D. Jacks and plugs for RCA composite video, S-Video (y/c) E. RS 232/422 port and connector F. RCA jacks and plugs for L (white) and R (red) audio G. Analog camcorder, analog VTR H. RCA jacks and plugs for L (white) audio, R (red) audio, and composite video (yellow); jack and plug for S-Video (y/c) I. Television monitor 

With this setup, you can capture audio and video from an analog camcorder or VTR. You can monitor the video signal on a TV monitor while editing. Finally, you can export any sequence back to the camcorder or VTR.

To convert the analog source signal to a digital file the computer can read, this setup requires an analog/digital (A/D) converter, or digitizer. You can use any of the following to digitize the video signal:

  • an internal digitizer, installed in the computer,

  • an external digitizer, connected to the computer,

  • a digital camcorder or VTR capable of digitizing an incoming analog signal.

  1. Connect the analog camcorder or VTR to the digitizer using S-Video or RCA video cables. Run video cables from the video outputs of the computer or its interface to the video inputs of the device. Also run video cables from the video outputs of the device to the video inputs of the computer or its interface.
  2. Connect the analog camcorder or VTR to the digitizer using XLR or RCA audio cables. Run audio cables from the audio outputs of the digitizer to the audio inputs of the device. Also run audio cables from the audio outputs of the device to the audio inputs of the digitizer.
  3. (Optional. For an analog camcorder or VTR with an RS-422 or RS-232 port. Windows only) Connect the serial device control port on the camcorder or VTR with the serial port on the computer or digitizer using the Pipeline Digital ProVTR cable.

    Note:

    Native serial device control is available in Windows only.

  4. Connect the analog camcorder or VTR, or the digitizer, to the television monitor with an S-Video or RCA video cable, and RCA or XLR audio cables.
  5. Put the analog camcorder or deck into VTR or Play mode.
  6. In Premiere Pro, select File >New > Sequence.
  7. In the Available Presets area of the New Sequence dialog box, select the preset that matches the format of your A/D converter. Do not match the source footage. For example, if you use a DV camcorder or A/DV converter to convert the analog signal, choose a DV preset.
  8. Type a name in the Sequence Name box. Then click OK.

Specify the default audio device

  1. Choose Edit > Preferences > Audio Hardware (Windows) or Premiere Pro > Preferences > Audio Hardware (Mac OS), and set the following options:
    • Select an output device from the Default Device menu.

    • Select a buffer size from the Buffersize menu (Mac OS).

  2. Click OK.

Audio Hardware Settings (Windows only)

When you click ASIO Settings in the Audio Hardware panel of the Preferences dialog box, Premiere Pro opens the Audio Hardware Settings dialog box, which contains an Input tab, and an Output tab.

Enable Devices

Determines which connected audio device is routed into and out of Premiere Pro. If the device is an ASIO device, select the ASIO drivers for the device. If the sound card does not have manufacturer-supplied ASIO drivers, choose Premiere Pro WDM Sound for this setting. To enable a device, be sure to install an up-to-date driver for the device (Windows.) If you want to input more than two stereo channels or monitor 5.1 surround audio, the device driver must comply with the ASIO (Audio Stream Input Output) specification. If it does not, only stereo inputs and outputs are available, regardless of the number of hardware inputs and outputs that are connected.

Buffersize

Specifies the size of the buffer, in kilobytes, that Premiere Pro uses for recording audio.

Device 32-bit Recording/Playback

On the Input tab, check Device 32-bit Recording to record audio in 32-bit samples. On the Output tab, check Device 32-bit Playback to enable 32-bit playback.

Note:

If you have trouble hearing audio, see the TechNote: “No sound during playback of video or audio clips.”

Set up a USB microphone (Mac OS)

  1. In the Audio Midi Setup application in Utilities, go to Audio > Open Aggregate Device Editor.
  2. Check each of the following:
    • Your USB microphone.

    • An additional input device, for example, Line In.

    • An output device

  3. Select this new aggregate device within Premiere Pro's Audio Hardware Preference panel.

Specify ASIO device settings (Windows only)

  1. Choose Edit >Preferences > Audio Hardware.
  2. Click ASIO settings. Specify the ASIO settings for the selected device.

    Note:

    The device and driver you use determine the settings in this dialog box, not Adobe Premiere Pro. See the documentation for the ASIO device and driver you use.

  3. In the Audio Hardware Settings dialog box, select the Input tab.
  4. Check the boxes next to the names of any devices you want to enable.
  5. Check Device 32-bit Recording if you want to record 32-bit audio.
  6. Drag the Samples slider to set the size of the buffer.
  7. Click OK.

Specify whether to render audio when rendering video

You can specify whether Premiere Pro renders audio previews by default.

Select Sequence > Render Effects In to Out, or Sequence > Render In to Out. These commands are used you have set In and Out points to mark the area to render audio previews, rather than the work area bar.

Rendering audio previews could improve playback performance, but could take additional time when you select either of these commands.

  1. Select Edit > Preferences > General (Windows), or Premiere Pro > Preferences > General (Mac OS).
  2. Select or deselect Render Audio When Rendering Video.
  3. Click OK.

Specify the duration for preroll and postroll pauses

You can set the length of preroll and postroll for clip and sequence previews in the General pane of the Preferences dialog box.

Note:

The Preroll and Postroll fields are different from the Preroll setting in the Device Control pane of the Preferences dialog box. The Preroll setting in the Device Control pane affects the control of external devices such as VTRs and camcorders.

  1. Select Edit > Preferences > General (Windows) or Premiere Pro > Preferences > General (Mac OS).
  2. In the Preroll and Postroll fields, type in the number of seconds for each.
  3. Click OK.

Specify scratch disks to improve system performance

When you edit a project, Premiere Pro uses disk space to store files required by your project. Premiere Pro stores captured video and audio, conformed audio, and preview files. Premiere Pro uses conformed audio files and preview files to optimize performance, allowing real-time editing, 32-bit floating-point quality, and efficient output.

All scratch disk preferences are saved with each project. You can select different scratch disk locations for different projects. If you reopen an earlier project after editing another project with different scratch disk locations, Premiere Pro will seek out the files belonging to the earlier project at the scratch disk locations you chose for that project.

If you delete preview files or conformed audio files for a project, Premiere Pro automatically recreates them when you reopen the project.

By default, scratch disk files are stored where you save the project. The scratch disk space required increases as sequences become longer or more complex. For best performance, dedicate a hard disk or disk strictly for your media assets. Choose a disk for the assets other than the disk where you keep your project file, operating system files, or the files for applications. That way your media disks can access and play media files as fast as possible, without having to access other files. Use the Project > Project Settings > Scratch Disks command to specify which disks Premiere Pro uses for media files. Choose scratch disks when you set up a new project.

In terms of performance, it’s best to dedicate a different disk to each asset type, but you can also specify folders on the same disk. You can specify unique scratch disk locations for each of the following types of files:

Captured Video

Video files that you create using File > Capture

Note:

If you transfer video files to a scratch disk folder before creating the project for them, specify the folder containing the video files for Captured Video.

Captured Audio

Audio files that you create using File > Capture, or by recording through the Audio Mixer as when recording a voice-over.

Video Previews

Files created when you use the Sequence > Render In to Out, export to a movie file, or export to a device. If the previewed area includes effects, the effects are rendered at full quality in the preview file.

Audio Previews

Audio preview files are created by all of the following commands:

  • Sequence > Render In to Out

  • Use export to a movie file

  • Export to a DV device

If the previewed area includes effects, they are rendered at full quality in the preview file.

Specify scratch disks

You set up scratch disks in the Scratch Disk pane of the Preferences dialog box. Before changing scratch disk settings, you can verify the amount of free disk space on the selected volume. by The amount appears in the box to the right of the path. If the path is too long to read, position the pointer over the path name. The full path appears in a tool tip.

  1. Choose Project > Project Settings > Scratch Disks.
  2. Identify a location for each type of file named in the dialog box. Premiere Pro creates a subfolder named for each file type (for instance, Captured Video) and stores the folder’s associated files in it. The menu lists three default locations:

    My Documents (Windows) or Documents (Mac OS)

    Stores scratch files in the My Documents folder (Windows) or Documents folder (Mac OS).

    Same As Project

    Stores scratch files in the same folder where the project file is stored.

    Custom

    Allows you to specify a location of your choosing. Choose Custom, then click Browse and browse to any available folder.

Optimizing scratch disk performance

For optimum performance, follow these guidelines:

  • If your computer has only one hard disk, consider leaving all scratch disk options at their default settings.
  • Set up scratch disks on one or more separate hard disks. In Premiere Pro, you can set up a separate scratch disk for each type of media. For example, you can set up one disk for captured video and another for captured audio.
  • On Windows, specify only partitions formatted for the NTFS file format as scratch disks. On Mac OS, use partitions formatted for Mac OS Extended. FAT32 partitions are not recommended for video. They do not support large file sizes.

Note:

Third-party tools are available that allow NTFS drives to work with Mac OS. See Tuxera NTFS for Mac, and Paragon NTFS for Mac.

  • On Mac OS, disable journaling for best performance.

  • Specify your fastest hard disks for capturing footage and storing scratch files. You can use a slower disk for audio preview files and the project file.

  • Specify only disks attached to your computer. A hard disk located on a network is usually too slow. Avoid using removable media because Premiere Pro always requires access to scratch disk files. Scratch disk files are preserved for each project, even when you close the project. They are reused when you reopen the project associated with them. If scratch disk files are stored on removable media and the media are removed from the drive, the scratch disk is not available to Premiere Pro.

  • You can divide a single disk into partitions and set up partitions as scratch disks. However, partioning doesn’t improve performance because the single drive mechanism becomes a bottleneck. For best results, set up scratch disk volumes that are physically separate drives.

  • You can capture audio and video to separate drives, if supported by the format codec. (The native DV and HDV capture in Premiere Pro does not support capturing audio separate from video.) Set the locations for new files by choosing Edit > Preferences > Scratch Disks (Windows) or Premiere Pro > Preferences > Scratch Disks (Mac OS). If you don’t change the defaults, all files captured or created by Premiere Pro are stored in the same folder in which it stores the project files.

 

Online resources for improving system performance

See this forum thread for advice from experienced users on setting up disks for a video editing system.

For a collection of videos and articles about making Premiere Pro work faster can be found on this blog post.

See this video to learn about hard disk setup for optimum performance in Adobe Premiere Pro and After Effects.

To learn how to format a disk as NTFS on Windows, see this web page on the Microsoft site.

To learn how to format a disk as HFS+ on Mac OS, see this page from the kenstone.net website. The information on this page is valid for Mac OS X 10.4-10.7

Move or clean the Media Cache Database

When Premiere Pro imports video and audio in some formats, it processes and caches versions of these items that it can readily access when generating previews. Imported audio files are each conformed to a new .cfa file, and MPEG files are indexed to a new .mpgindex file. The media cache greatly improves performance for previews, because the video and audio items do not need to be reprocessed for each preview.

Note:

When you first import a file, you may experience a delay while the media is being processed and cached.

A database retains links to each of the cached media files. This media cache database is shared with Adobe Media Encoder, After Effects, Premiere Pro, and Audition, so each of these applications can each read from and write to the same set of cached media files. If you change the location of the database from within any of these applications, the location is updated for the other applications, too. Each application can use its own cache folder, but the same database keeps track of them.

  • Choose Edit > Preferences > Media (Windows) or Premiere Pro > Preferences > Media (Mac OS), and do one of the following:
    • To move the media cache or the media cache database, click the respective Browse, button.

    • To remove conformed and indexed files from the cache and to remove their entries from the database, click Clean. This command only removes files associated with footage items for which the source file is no longer available.

    Note:

    Before clicking the Clean button, make sure that any storage devices that contain your currently used source media are connected to your computer. If footage is determined to be missing because the storage device on which it is located is not connected, the associated files in the media cache is removed. This removal results in the need to reconform or reindex the footage when you attempt to use the footage later.

Note:

Cleaning the database and cache with the Clean button does not remove files that are associated with footage items for which the source files are still available. To manually remove conformed files and index files, navigate to the media cache folder and delete the files.

Optimize rendering for available memory

By default, Premiere Pro renders video using the maximum number of available processors, up to 16. However, some sequences, such as those containing high-resolution source video or still images, require large amounts of memory for the simultaneous rendering of multiple frames. These sequences can force Premiere Pro to cancel rendering and to give a Low Memory Warning alert. In these cases, you can maximize the available memory by changing the rendering optimization preference from Performance to Memory. Change this preference back to Performance when rendering no longer requires memory optimization.

  1. Select Edit > Preferences, and select Memory in the Preferences dialog box.
  2. In the drop-down list next to Optimize Rendering For, select Memory.
  3. Click OK, close Premiere Pro, and reopen the project for the new preference to take effect.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy