Você anima os caminhos de máscara e caminhos de forma quase da mesma maneira que anima outras propriedades: defina os quadros-chave da propriedade Caminho de máscara ou Caminho, defina caminhos em cada quadro-chave, e o After Effects interpolará entre esses valores especificados.

Introdução e recursos do rotoscópio

Rotoscópio (ou apenas roto em uso eventual) é o desenho ou pintura em quadros de um filme, usando elementos visuais no filme como referência. Um tipo comum de rotoscópio é traçar um caminho ao redor de um objeto em um filme e usar esse caminho como uma máscara para separar o objeto do fundo. Isso permite que você trabalhe com o objeto e o plano de fundo em separado e, consequentemente, você pode fazer coisas como aplicar efeitos diferentes ao objeto em vez de ao seu fundo ou substituir o fundo.

Observação:

O After Effects inclui as ferramentas Pincel tipo rotoscópio e Refinar bordas, que podem ser usadas para executar muitas das mesmas tarefas que o rotoscópio convencional, mas em muito menos tempo. Para obter informações sobre como usar a ferramenta Pincel tipo rotoscópio, consulte Pincel tipo rotoscópio, refinar borda e refinar fosco.

Observação:

Se um objeto de fundo ou primeiro plano for uma cor uniforme e distinta, você pode usar a máscara de cor em vez do rotoscópio para remover o fundo ou objeto. Se a gravação foi filmada com a máscara de cor em mente, a máscara de cor é bem mais fácil que o rotoscópio. (Consulte Introdução à codificação e fluxo de trabalho.)

O rotoscópio no After Effects é em grande parte uma questão de desenhar máscaras, animar o caminho de máscara e depois usar essas máscaras para definir um fosco. Muitas ferramentas e técnicas adicionais facilitam essa tarefa, como o controle de movimento no objeto antes de começar a desenhar máscaras e depois usar os dados do controle de movimento para fazer com que a máscara ou fosco sigam automaticamente o objeto.

Dicas de rotoscópio

  • Imediatamente depois de começar a desenhar uma máscara, pressione Alt+Shift+M (Windows) ou Option+Shift+M (Mac OS) para ativar os quadros-chave para essa máscara e definir um quadro-chave. Assim, você não editará uma máscara quadro a quadro por vários minutos (ou mais) e depois se aperceber que perdeu todo seu trabalho em quadros anteriores porque você esqueceu de clicar no cronômetro para tornar o caminho de máscara animado.
  • Desenhe as máscaras em uma camada sólida branca com a opção Vídeo (olho) desativada, acima da camada (bloqueada) de gravação. Assim, você não corre nenhum risco de mover acidentalmente a camada de gravação ao manipular a máscara e também será muito mais fácil aplicar os dados de rastreamento à máscara. (Você aplica os dados de rastreamento à camada sólida invisível que contém a máscara.) Isso também significa que você não perderá seus quadro de visualização em cache sempre que manipular a máscara. (Consulte Alternar entre a visibilidade ou a influência de um grupo de camadas ou propriedades e Bloquear ou desbloquear uma camada.)
  • Ative a preferência Preservar contagem de vértice de constante. (Consulte Designar o primeiro vértice de um caminho de Bézier.)
  • Quando possível, transforme (gire, redimensione, mova) a máscara inteira ou um subconjunto dos vértices da máscara em vez de mover os vértices individualmente. Assim, ganha em eficiência e evita a trepidação proveniente de movimento inconsistente nos quadros. (Consulte Mover vértices no modo de transformação livre.)
  • O controle de movimento manual é menos demorado que o rotoscópio manual. Quanto mais esforço for gasto para obter bons dados de rastreamento para várias partes da cena e objeto, menos tempo você gastará desenhando e refinando máscaras. (Consulte Controle e estabilização de movimento.)
  • Use o recurso difusão da máscara de largura variável para obter mais controle de difusão objetos.

Recursos online sobre o rotoscópio

Este vídeo da série After Effects CS5: Aprenda por vídeo mostra como combinar rastreamento de movimento e rotoscopia para isolar e corrigir a cor do rosto de um ator de maneira seletiva.

Scott Squires fornece um conjunto de filmes no seu site Effects Corner que mostram como usar o rotoscópio, na pintura e na máscara:

Mathias Möhl oferece o roteiro do KeyTweak em seu site, com o qual você pode modificar muitos quadros-chave em uma propriedade ao mesmo tempo. Com o KeyTweak, você pode modificar alguns quadros-chave manualmente, e o script modifica os quadros-chave restantes nesse meio, conforme necessário. O KeyTweak é especialmente útil para quadros-chave Caminho da máscara em um fluxo de trabalho de rotoscópio.

Rich Young fornece vários recursos de rotoscópio no seu site After Effects Portal.

Visualizar caminhos e formas de máscara

  • Para ver os caminhos de máscara para as camadas selecionadas no painel Linha de tempo, pressione M.
  • Para exibir as máscaras ou forma selecionadas no painel Linha de tempo, pressione SS (pressione a tecla S duas vezes).
  • Para ver caminhos de máscara e de forma no painel Composição, clique no botão Alternar visibilidade do caminho de máscara e de forma na parte inferior do painel Composição.
  • Para ver os caminhos de máscara no painel Camada, escolha Máscaras no menu Exibir do painel Camada.
  • Para ocultar um caminho de máscara enquanto mostra outros, bloqueie a máscara selecionando a opção Bloquear no painel Linha de tempo e escolha Camada > Máscara > Ocultar máscaras bloqueadas.
  • Para isolar máscaras selecionadas e ocultar outras, escolha Camada > Máscara > Bloquear outras máscaras e depois escolha Camada > Máscara > Ocultar máscaras bloqueadas.

Selecionar caminhos de forma, formas e grupos de formas

Você pode selecionar camadas de forma e seus componentes em qualquer um dos quatro níveis de seleção, chamados de modos de seleção:

Modo de seleção de camadas

A camada de forma inteira é selecionada. As transformações são aplicadas às propriedades de transformação da camada, no grupo de propriedades Transformar que está no mesmo nível do grupo de propriedades Conteúdo.

Modo de seleção de grupos

Um grupo de formas inteiro é selecionado. As transformações são aplicadas às propriedades de transformação do grupo, no grupo de propriedades Transformar no grupo de formas no painel Linha de tempo.

Modo de transformação livre

Vários vértices em um ou mais caminhos de Bézier são selecionados. Uma caixa delimitadora de transformação livre é exibida ao redor dos vértices no painel Composição. Ao operar em essa caixa, é possível mover vários vértices com uma única transformação. As transformações são aplicadas aos vértices propriamente ditos, contidos na propriedade Caminho no painel Linha de tempo.

Modo de edição de caminho

Somente os vértices são selecionados. Nesse modo, é possível executar as operações de edição de caminho, como adicionar vértices a um caminho e mover vértices individuais.

Observação:

Quando a ferramenta Caneta estiver ativa, o modo de edição de caminho está ativo. Para permanecer no modo de edição de caminho, selecione a ferramenta Caneta; pressione V ou Ctrl (Windows) ou Command (Mac OS) para ativar temporariamente a ferramenta Seleção conforme necessário.

Modos de seleção para formas em camadas de forma
Modos de seleção para formas em camadas de forma

A. Seleção de camada B. Seleção de grupo C. Transformação livre D. Edição de caminho 

Para obter informações sobre como selecionar máscaras, consulte Selecionar máscaras, segmentos e vértices.

Observação:

Pressione Ctrl+A (Windows) ou Command+A (Mac OS) com um vértice de forma selecionado para selecionar todos os vértices nesse caminho. Clique novamente para selecionar todas as formas. Clique novamente para selecionar todas as camadas.

Selecionar uma camada de forma

  • Clique no nome da camada ou na barra de duração da camada no painel Linha de tempo.
  • Usando a ferramenta Seleção, clique dentro dos limites da camada no painel Composição.
  • Para desmarcar todas as formas em uma camada, mas manter a camada da forma selecionada, clique dentro dos limites da camada, mas fora dos caminhos de forma.

Selecionar um grupo de formas no modo de seleção de grupo

  • Usando a ferramenta Seleção, clique duas vezes em um membro do grupo no painel Composição. Cada vez que clicar duas vezes, você desce um outro nível na hierarquia de grupo.
  • Para ativar a ferramenta Seleção direta , pressione e segure Ctrl (Windows) ou Command (Mac OS) com a ferramenta Seleção selecionada. Clique em uma forma no painel Composição com a ferramenta Seleção Direta para selecionar diretamente o grupo dessa forma, independentemente da profundidade de aninhamento da forma na hierarquia de grupo.
  • Para selecionar um grupo contido no mesmo grupo que já está selecionado, clique no grupo para selecionar.
  • Para adicionar um grupo a uma seleção, clique com a tecla Shift pressionada nele. É possível combinar a tecla Shift com o duplo clique e com a ferramenta Seleção direta para adicionar grupos mais profundamente aninhados à seleção.

Selecionar caminhos e vértices no modo de edição de caminho

Observação:

Para especificar o tamanho das alças de direção de Bézier e dos vértices para máscaras e formas, escolha Editar > Preferências > Geral (Windows) ou After Effects > Preferências > Geral (Mac OS) e edite o valor Tamanho de ponto do caminho.

  • Para selecionar um vértice, clique no vértice com a ferramenta Seleção. Para adicionar vértices à seleção, clique com a tecla Shift pressionada neles.
  • Para selecionar um segmento de caminho, clique no segmento com a ferramenta Seleção. Para adicionar segmentos à seleção, clique com a tecla Shift pressionada neles.
  • Para selecionar um caminho inteiro, clique com a tecla Alt (Windows) ou Option (Mac OS) em um segmento ou um vértice do caminho com a ferramenta Seleção ou selecione qualquer parte do caminho e pressione Ctrl+A (Windows) ou Command+A (Mac OS).
  • Para selecionar vértices com o movimento de arrastar, selecione um caminho ou uma parte de um caminho para acessar o modo de edição do mesmo e depois arraste com a ferramenta de seleção de letreiro para desenhar uma caixa de seleção de letreiro ao redor dos vértices a serem selecionados. Para adicionar vértices à seleção, mantenha a tecla Shift pressionada enquanto desenha caixas de seleção de letreiro adicionais.

Selecionar todos os pontos em um caminho e acessar o modo de transformação livre

  • Clique duas vezes em um segmento de caminho enquanto estiver no modo de edição de caminho ou no modo de seleção de grupo de uma única forma.
  • Selecione a propriedade Caminho no painel Linha de tempo e pressione Ctrl+T (Windows) ou Command+T (Mac OS).

Selecionar máscaras, segmentos e vértices

Diferentemente das camadas, as máscaras podem ter mais de um nível de seleção. Você pode selecionar uma máscara como um caminho inteiro, adequado quando você deseja mover ou redimensionar uma máscara. Contudo, se desejar alterar o caminho de uma máscara, selecione um ou mais pontos nele. Os pontos selecionados aparecem sólidos e os pontos não selecionados aparecem vazios.

Observação:

Para especificar o tamanho das alças de direção de Bézier e dos vértices para máscaras e formas, escolha Editar > Preferências > Geral (Windows) ou After Effects > Preferências > Geral (Mac OS) e edite o valor Tamanho de ponto do caminho.

Selecionar ou desmarcar máscaras no painel Camada ou Composição

  • Para selecionar um vértice em uma máscara, clique no vértice com a ferramenta Seleção . Para adicionar vértices à seleção, clique com a tecla Shift pressionada neles.
  • Para selecionar um segmento de máscara, clique no segmento com a ferramenta Seleção. Para adicionar segmentos à seleção, clique com a tecla Shift pressionada neles.
  • Para selecionar uma máscara inteira, clique com a tecla Alt (Windows) ou clique com a tecla Option (Mac OS) em um segmento, vértice ou alça de uma máscara com a ferramenta Seleção, ou selecione qualquer parte da máscara e escolha Editar > Selecionar tudo ou pressione Ctrl+A (Windows) ou Command+A (Mac OS). Para adicionar máscaras à seleção, clique em Alt+Shift (Windows) ou clique em Option+Shift (Mac OS) nelas.
  • Para selecionar máscaras arrastando, selecione uma máscara ou parte de uma máscara para acessar o modo de edição de máscara e depois arraste com a ferramenta Seleção para desenhar uma caixa de seleção de letreiro completamente ao redor dos vértices ou máscaras que deseja selecionar. Para adicionar máscaras ou vértices à seleção, mantenha a tecla Shift pressionada enquanto desenha caixas de seleção de letreiro adicionais.
  • Para selecionar todas as máscaras em uma camada, selecione uma máscara na camada e escolha Editar > Selecionar tudo ou pressione Ctrl+A (Windows) ou Command+A (Mac OS).
  • Para desmarcar todas as máscaras, pressione Ctrl+Shift+A (Windows) ou Command+Shift+A (Mac OS).
  • Para selecionar uma máscara adjacente em uma camada, pressione Alt+acento grave (`) (Windows) ou Option+acento grave (`) (Mac OS) para selecionar a máscara seguinte, ou Shift+Alt+acento grave (`) (Windows) ou Shift+Option+acento grave (`) (Mac OS) para selecionar a máscara anterior.
  • Para desmarcar uma máscara, clique em qualquer local sem ser na máscara.
  • Para remover um vértice ou segmento de uma seleção, clique em Shift no vértice ou segmento.

Observação:

Para usar a ferramenta Seleção quando a ferramenta Caneta estiver selecionada, mantenha Ctrl (Windows) ou Command (Mac OS) pressionado.

Selecionar máscaras no painel Linha de tempo

  1. Clique na seta da direita ao lado do nome de uma camada para expandi-la.
  2. Clique na seta da direita ao lado do título Máscaras para expandi-la, revelando todas as máscaras nessa camada.
  3. Siga um destes procedimentos:
    • Para selecionar uma máscara, clique em seu nome.
    • Para selecionar um intervalo contíguo de máscaras, clique em Shift nos nomes da primeira e última máscaras no intervalo.
    • Para selecionar as máscaras não contíguas, clique em Ctrl (Windows) ou Command (Mac OS) nos nomes de quaisquer máscaras que deseja incluir.

Observação:

Você pode selecionar somente máscaras inteiras no painel Linha de tempo. Para selecionar vértices individuais em uma máscara, use o painel Composição ou Camada.

Bloquear ou desbloquear máscaras

Bloquear uma máscara evita que você a selecione nos painéis Linha de tempo, Composição e Camada ou que a defina como destino no painel Camada. Utilize esse recurso para evitar alterações indesejadas na máscara.

  1. No painel Linha de tempo, expanda o grupo de propriedades Máscaras.
  2. Na coluna Recursos de A/V, clique na caixa abaixo do ícone de Bloquear ao lado da máscara que deseja bloquear ou desbloquear. Uma máscara está bloqueada e não pode ser selecionada quando a opção Bloquear está selecionada – ou seja, quando o ícone Bloquear aparece na caixa.

Observação:

Para desbloquear simultaneamente várias máscaras, selecione uma ou mais camadas e escolha Camada > Máscara > Desbloquear todas as máscaras.

Observação:

Para isolar máscaras selecionadas e ocultar outras, escolha Camada > Máscara > Bloquear outras máscaras e depois escolha Camada > Máscara > Ocultar máscaras bloqueadas.

Mover vértices no modo de transformação livre

Você pode redimensionar e girar um caminho de máscara ou de forma inteiro (ou vértices selecionados em um ou mais caminhos) usando o comando Pontos de transformação livre. Ao usar esse comando, uma caixa delimitadora de transformação livre envolve os vértices selecionados e um ponto de ancoragem aparece no centro da caixa delimitadora para marcar o ponto de ancoragem para a transformação atual. Você pode redimensionar e girar os vértices selecionados arrastando a caixa delimitadora ou suas alças. Para alterar o ponto de referência dos vértices são girados ou dimensionados mova o ponto de ancoragem da caixa delimitadora. As alças da caixa delimitadora de transformação livre e o ponto de ancoragem existem independentemente das alças e do ponto de ancoragem da camada.

Observação:

Quando você anima a rotação usando Pontos de transformação livre, os vértices da máscara são interpolados em uma linha reta de quadro-chave para quadro-chave. Por esse motivo, os resultados podem ser diferentes do esperado.

  1. Exiba a camada que contém os caminhos que você deseja transformar no painel Composição ou Camada.
  2. Usando a ferramenta Seleção, siga um desses procedimentos:
    • Para transformar qualquer número de vértices, selecione os vértices que deseja transformar e escolha Camada > Caminho da forma e máscara > Pontos de transformação livre.
    • Para transformar um caminho de máscara ou de forma inteiro, selecione-o no painel Linha de tempo e escolha Camada > Caminho da forma e máscara > Pontos de transformação livre.
  3. Para mover o ponto de ancoragem da caixa delimitadora, posicione a ferramenta Seleção no ponto de ancoragem da caixa delimitadora até a ferramenta Seleção mudar para um ícone do ponto de ancoragem de movimento . Arraste para posicionar o ponto de ancoragem.
  4. Siga qualquer combinação desses procedimentos:
    • Para mover o caminho ou os vértices selecionados, posicione o ponteiro dentro da caixa delimitadora e arraste.
    • Para dimensionar o caminho ou vértices selecionados, posicione o ponteiro sobre uma alça da caixa delimitadora e, quando o ponteiro mudar para uma seta reta de duas pontas , arraste para um novo tamanho. Pressione Shift enquanto arrasta para restringir o redimensionamento. Mantenha pressionada a tecla Ctrl (Windows) ou Command (Mac OS) enquanto arrasta para redimensionar ao redor do ponto de ancoragem da caixa delimitadora.
    • Para girar o caminho ou os vértices selecionados, posicione o ponteiro fora da caixa delimitadora de transformação livre e, quando o ponteiro mudar para uma seta curva de duas pontas , arraste para girar.
  5. Para sair do modo de transformação livre, pressione Esc, Enter (Windows) ou Return (Mac OS).

Converte um caminho entre Bézier manual e RotoBézier

É possível converter qualquer caminho de máscara de Bézier manual ou caminho de forma de Bézier manual em um caminho de RotoBézier. Se o caminho de Bézier manual possuir alças de direção que foram definidas, essa conversão muda a forma do caminho, pois o After Effects calcula a curvatura de segmentos de RotoBézier automaticamente.

A conversão de um caminho de RotoBézier em um caminho de Bézier manual não altera a forma do caminho.

  1. Selecione uma máscara no painel Camada, Composição ou Linha de tempo, ou selecione um caminho de forma no painel Composição ou Linha de tempo.
  2. Escolha Camada > Caminho da forma e máscara > RotoBézier.

Modificar um caminho de máscara ou de forma de Bézier

Você pode alterar um caminho de máscara de Bézier usando a ferramenta Seleção e as ferramentas de caneta no painel Camada ou Composição. Você pode alterar um caminho da forma de Bézier usando a ferramenta Seleção e as ferramentas de caneta no painel Composição.

As ferramentas de caneta – Adicionar vértice, Excluir vértice e Converter vértice – estão agrupadas com a ferramenta Caneta no painel Ferramentas. Para exibir essas ferramentas no painel Ferramentas, clique e mantenha pressionada a ferramenta Caneta no painel Ferramentas.

Observação:

Na maioria dos casos, a ferramenta de caneta apropriada é ativada quando você coloca o ponteiro da ferramenta Caneta em um contexto específico. Por exemplo, a ferramenta Excluir vértice fica ativada quando você coloca o ponteiro da ferramenta Caneta sobre um vértice existente e a ferramenta Adicionar vértice se torna ativa quando você coloca o ponteiro da ferramenta Caneta sobre um segmento de caminho. Para ativar manualmente e percorrer essas ferramentas, pressione G.

Para modificar um caminho, verifique se você clica somente em vértices ou segmentos existentes; caso contrário, você pode criar um novo marcador em vez disso.

Mover, adicionar ou excluir um vértice

  1. Siga um destes procedimentos:
    • Para mover um vértice, arraste-o com a ferramenta Seleção .

    Observação:

    Para mudar temporariamente da ferramenta Caneta para a ferramenta Seleção, pressione V, Ctrl (Windows) ou Command (Mac OS).

    • Para adicionar um vértice a uma máscara, use a ferramenta Adicionar vértice para clicar no segmento entre dois vértices existentes.
    • Para excluir um vértice de uma máscara, use a ferramenta Excluir vértices para clicar no vértice.

Ajustar um segmento de caminho

  1. Siga um destes procedimentos com a ferramenta Seleção:
    • Arraste um vértice.
    • Arraste as alças de direção que se estendem de um vértice suave adjacente.
    • Arraste um segmento curvado.

    Observação:

    Arrastar um segmento curvado em uma máscara de RotoBézier também move os vértices.

Alternar um vértice entre um ponto suave e um ponto de vértice

  1. Clique no vértice com a ferramenta Converter vértice .

    Observação:

    Para ativar a ferramenta Converter vértice quando a ferramenta Caneta estiver selecionada, mantenha a tecla Alt (Windows) ou Option (Mac OS) pressionada.

Definir a tensão de uma máscara de RotoBézier

  1. Se desejar ajustar a tensão de mais de um vértice simultaneamente, selecione-os.
  2. Ao usar a ferramenta Converter vértice , arraste um vértice.

    Observação:

    Para ativar a ferramenta Converter vértice quando a ferramenta Caneta estiver selecionada, mantenha a tecla Alt (Windows) ou Option (Mac OS) pressionada.

    O ponteiro Ajustar tensão aparece quando você arrasta um vértice da máscara RotoBezier.

    Clicar em um vértice em vez de arrastar define o vértice para um ponto de vértice (tensão de 100%); clicar novamente define o vértice para um ponto suave (tensão de 33%). Arrastar para cima ou para a direita reduz a tensão da seleção, aumentando a curva de segmentos de caminho adjacentes; arrastar para baixo ou para a esquerda aumenta a tensão da seleção, diminuindo a curva de segmentos de caminho adjacentes.

    Observação:

    Para exibir a o valor de tensão de um vértice, examine o painel Informações enquanto ajusta a tensão.

Alterar um caminho de máscara numericamente

  1. Selecione a máscara.
  2. No painel Linha de tempo, expanda as propriedades Máscara.
  3. Ao lado da propriedade Caminho da máscara, clique na palavra sublinhada, especifique as alterações na caixa de diálogo Forma de máscara.

Designar o primeiro vértice para um caminho de Bézier

Para animar um caminho, o After Effects designa o vértice na extremidade superior do quadro-chave inicial como o primeiro vértice e números de cada vértice sucessivos em ordem crescente do primeiro vértice. O After Effects atribui os mesmos números aos vértices correspondentes em todos os quadros-chave sucessivos. O After Effects interpola o movimento de cada vértice da posição inicial em um quadro-chave à posição do vértice numerado correspondentemente no quadro-chave seguinte. A qualquer momento durante uma animação, você pode designar outro vértice como o primeiro vértice; isto faz com que o After Effects renumere os vértices do caminho. Renumerar vértices faz com que a animação do caminho mude, porque o After Effects mapeia os novos números de vértice para os números antigos de vértice correspondentes ainda salvos em quadros-chave sucessivos.

Ao copiar um caminho fechado para um caminho de movimento, o vértice designado como o primeiro vértice do caminho fechado é usado como o início do caminho de movimento. Todos os caminhos de movimento são caminhos abertos.

Algumas operações de caminho de forma, como Aparar caminhos, também usam o primeiro vértice como entrada para determinar como modificar o caminho.

Observação:

Por padrão, quando você adiciona um vértice a um caminho, o novo vértice aparece no caminho em toda a duração do caminho, mas remodela o caminho somente no momento em que foi adicionado. Quando você exclui um vértice de um caminho em um ponto específico no tempo, o vértice é excluído do caminho em toda a duração do caminho. Impeça o After Effects de adicionar e excluir vértices em toda a duração do caminho escolhendo Editar > Preferências > Geral (Windows) ou After Effects > Preferências > Geral (Mac OS) e desmarcando a opção Preservar contagem de vértice constante ao editar máscaras.

Observação: Preservar contagem de vértices constantes ao editar máscaras foi renomeado como “Preservar contagem de suavização e de vértice constante ao editar máscaras” na After Effects CC e CS6.

  1. Crie um caminho animado.
  2. No painel Linha de tempo, mova o indicador do tempo atual até o ponto onde deseja designar o primeiro vértice novo.
  3. Selecione o vértice para designar como o primeiro vértice.
  4. Escolha Camada > Caminho da forma e máscara > Definir primeiro vértice.

    Observação:

    O vértice designado como o primeiro vértice é exibido ligeiramente maior que outros vértices no painel Composição.

Animar um caminho de máscara com a Interpolação de máscara inteligente

A Interpolação de máscara inteligente fornece um alto nível de controle ao criar quadros-chaves do caminho de máscara e animações suaves e realistas. Depois de selecionar os quadros-chave do caminho de máscara para interpolar, a Interpolação de máscara inteligente cria quadros-chave intermediários com base em configurações que você fornece. O painel Informações exibe o progresso da interpolação e o número de quadros-chave criados.

  1. Escolha Janela > Interpolação de máscara.
  2. Selecione pelo menos dois quadros-chave do caminho de máscara adjacentes.
  3. Defina as opções no painel Interpolação de máscara e clique em Aplicar.

    Observação:

    Para interromper o processo de interpolação, pressione Esc. O painel Informações indica que o processo foi interrompido e relata o número de quadros-chave criados.

    Taxa de quadros-chave

    Especifica o número de quadros-chave que a Interpolação de máscara inteligente cria por segundo entre os quadros-chave selecionados. Por exemplo, um valor de 10 cria um novo quadro-chave a cada 1/10 de um segundo. Escolha Automático para definir a taxa de quadros-chave igual à taxa de quadros da composição, que aparece entre parênteses. Crie mais quadros-chave para uma animação mais suave; crie menos quadros-chave para reduzir o tempo de renderização.

    Observação:

    Independentemente da taxa de quadros-chave selecionada, a Interpolação de máscara inteligente sempre adiciona quadros-chave no quadro imediatamente após o primeiro quadro-chave do caminho de máscara e no quadro imediatamente antes do segundo quadro-chave do caminho de máscara. Por exemplo, se você interpolar entre quadros-chave em 0 segundos e 1 segundo em uma composição de 30 qps com uma taxa de quadros-chave de 10 quadros-chave por segundo, são adicionados quadros-chave do caminho de máscara nos números de quadro 1, 3, 6, 9, 12, 15, 18, 21, 24, 27 e 29.

    Campos de quadro-chave

    Dobra a taxa de quadros-chave. Quando essa opção está selecionada e a Taxa de quadros-chave está definida como a taxa de quadros da composição, um quadro-chave é adicionado em cada campo de vídeo. Selecione essa opção para máscara animada de vídeo entrelaçado. Se essa opção não estiver selecionada, a máscara pode deslizar do objeto que você está tentando mascarar. Para obter mais informações sobre campos em vídeo entrelaçado, consulte, Vídeo entrelaçado e campos separadores.

    Usar caminhos de vértice linear

    Especifica que os vértices no primeiro quadro-chave movem ao longo de um caminho reto para os vértices correspondentes no segundo quadro-chave. Deixe essa opção desmarcada se você deseja que alguns vértices interpolem ao longo de caminhos curvos; por exemplo, quando a interpolação desejada envolve partes em rotação. Se essa opção não estiver selecionada, a Interpolação de máscara inteligente cria um caminho natural para a máscara.

    Resistência de dobra

    Especifica o quão suscetível o caminho de máscara interpolado está para dobrar em vez de esticar. Um valor de 0 especifica que, à medida que o caminho de máscara é animado, ele dobra mais do que estica; um valor de 100 especifica que o caminho de máscara estica mais do que dobra.

    Qualidade

    Especifica o quão restritamente a Interpolação de máscara inteligente faz a correspondência dos vértices de quadro-chave para outro. Um valor de 0 especifica que um determinado vértice no primeiro quadro-chave corresponde apenas ao vértice com a mesma numeração no segundo quadro-chave. Por exemplo, o décimo vértice no primeiro quadro-chave deve corresponder ao décimo vértice no segundo quadro-chave. Um valor de 100 significa que um vértice no primeiro quadro-chave pode potencialmente corresponder a qualquer vértice no segundo quadro-chave. Valores mais altos costumam gerar melhores interpolações; porém, quanto maior o valor, maior o tempo de processamento.

    Adicionar vértices de caminho de máscara

    Especifica se a Interpolação de máscara inteligente adiciona vértices para facilitar interpolações de qualidade. Em geral, a Interpolação de máscara inteligente funciona melhor quando os caminhos de máscara têm conjuntos densos de vértices. Além disso, um vértice no primeiro caminho de máscara não pode corresponder ao meio de um segmento de linha reta ou curva no segundo caminho de máscara, por isso às vezes é necessário adicionar vértices antes de fazer a correspondência para obter o resultado desejado. A Interpolação de máscara inteligente não modifica os quadros-chave originais. Somente os novos quadros-chave do caminho de máscara calculados pela Interpolação de máscara inteligente têm vértices adicionais.

    O valor definido especifica a precisão com que os caminhos de máscara de entrada são subdivididos. Os Pixels entre vértices especifica a distância, em pixels, entre vértices no caminho de máscara de perímetro maior depois da subdivisão. A opção Vértices totais especifica o número de vértices nos caminhos de máscara interpolados. A Porcentagem de contorno especifica que um vértice é adicionado em cada porcentagem indicada do comprimento do contorno do caminho de máscara. Por exemplo, o valor 5 significa que um vértice é adicionado em cada segmento sucessivo do contorno que representa 5% do perímetro total. Para usar apenas os vértices que estavam no caminho no primeiro quadro, não selecione essa opção.

    Observação:

    A Interpolação de máscara inteligente pode adicionar vértices em locais de vértice existentes se Adicionar vértices de caminho de máscara não estiver selecionado. Se dois vértices em um caminho de máscara corresponderem a um único vértice em um outro, o único vértice único é duplicado no mesmo local de forma que o segmento entre os dois vértices encolha para esse local.

    Método de correspondência

    Especifica o algoritmo que a Interpolação de máscara inteligente usa para corresponder vértices em um caminho de máscara com os vértices no outro. A opção Automático aplica o algoritmo correspondente para curvas se qualquer um dos dois quadros-chave selecionados tiverem um segmento curvado; caso contrário, aplica o algoritmo de polilinha. A opção Curva aplica o algoritmo para caminhos de máscara que têm segmentos curvados. A opção Polilinha aplica o algoritmo para caminhos de máscara que têm apenas segmentos retos.

    Observação:

    Os quadros-chave de caminho de máscara adicionados pela Interpolação de máscara inteligente são polilinhas quando o Método de correspondência de Polilinha estiver selecionado, independentemente de os caminhos de máscara de entrada terem segmentos curvados.

    Use correspondências de vértice 1:1

    Especifica se a Interpolação de máscara inteligente cria um vértice em um caminho de máscara que corresponda ao vértice com a mesma numeração em um outro caminho de máscara. Em cada um dos caminhos de máscara de entrada, a Interpolação de máscara inteligente corresponde aos primeiros vértices, aos segundos vértices, aos terceiros vértices, etc. Se os dois caminhos tiverem números distintos de vértices, essa ação pode produzir resultados indesejáveis.

    Primeira correspondência de vértices

    Especifica se a Interpolação de máscara inteligente corresponde aos primeiros vértices nos dois quadros-chave do caminho de máscara. Se não for selecionada, a Interpolação de máscara inteligente pesquisa as melhores correspondências de primeiro vértice entre os dois caminhos de máscara de entrada.

    Observação:

    Para garantir bons resultados, verifique se os primeiros vértices dos caminhos de máscara de entrada correspondem e depois selecione Primeira correspondência de vértices.

Mover uma máscara ou deslocar uma camada por trás de uma máscara

É possível ajustar a área visível através de uma máscara, movendo a máscara no painel Camada ou Composição ou deslocando (movendo) a camada por trás da máscara no painel Composição. Quando você move uma máscara, os valores da posição da camada de máscara permaneçam constantes, e a máscara se move em relação a outros objetos no painel Composição.

Quando você usa a ferramenta Deslocar atrás (ponto de ancoragem) para deslocar uma camada para trás de uma máscara, a posição da máscara permanece constante no painel Composição mas muda no painel Camada. Os valores Posição da camada mascarada muda em relação à composição. Quando você desloca para além das bordas do quadro da camada, os valores Caminho da máscara na camada também mudam. O uso da ferramenta Deslocar atrás (ponto de ancoragem) poupa etapas. Sem ela, você teria que mudar as propriedades Posição e Caminho da máscara camada mascarada manualmente. Você pode animar uma camada deslocando atrás de outra camada configurando quadros-chave para as propriedades Posição e Caminho da máscara da camada mascarada.

Mover uma máscara ou deslocar uma camada por trás de uma máscara
Quando você usa a ferramenta Deslocar atrás (ponto de ancoragem) no painel Composição, o After Effects automaticamente faz dois ajustes. No painel Camada, a máscara é movida em relação à sua camada (superior) e, no painel Composição, a camada é movida em relação à composição (inferior).

Mover uma máscara

  1. Selecione a máscara ou máscaras que você deseja mover.
  2. No painel Composição, arraste a máscara ou máscaras até um novo local. Para restringir o movimento da máscara ou máscaras para horizontal ou vertical, pressione Shift depois de começar a arrastar.

Deslocar uma camada atrás de sua máscara

  1. Selecione a ferramenta Deslocar atrás (ponto de ancoragem) no painel Ferramentas.

  2. Clique dentro da área de máscara no painel Composição e arraste a camada para uma nova posição.

Reconhecimento facial e controle de máscara

Você pode usar o controle de máscara para transformá-la, de forma que siga o movimento de um objeto (ou objetos) em um filme. Para obter mais informações, consulte Controle de máscara.

Você também pode usar o controlador de máscaras para detectar e acompanhar com precisão os rostos humanos. Para obter mais informações, consulte Reconhecimento facial.

Acesso da expressão a pontos de caminho em máscaras, formas de Bézier e traçados de pincel

É possível usar as expressões para ler e gravar as coordenadas x e y de pontos de caminho ou vértices para:

  • Máscaras de camada
  • Formas de bézier   
  • Traçados de pincel nos efeitos Pintura, Pincel tipo rotoscópio e Refinar borda.

Os métodos de expressão são semelhantes a acessar os vértices de caminho por meio de script. O método de expressão é chamado points() em vez de vertices() para a familiaridade.

Acessar métodos de expressão

Você pode acessar os métodos da expressão usando as seguintes etapas:

  1. Para criar uma camada sólida, selecione Camada > Sólida.

  2. Ao criar um sólido, crie uma máscara. Clique na ferramenta Forma, por exemplo, um polígono, e crie uma máscara por cima da camada sólida.

  3. No painel Linha de tempo, torcer para abrir as propriedades da Máscara e clicar com a tecla alt pressionada Caminho da máscara.

  4. O campo de expressão é exibido. No painel Linha de tempo, clique no Menu idioma de expressão e selecione Propriedade do caminho.

    Menu de idiomas da expressão
    Menu de idiomas da expressão
  5. Selecione um método de expressão na lista de métodos de expressão do ponto de caminho.

    Para saber mais sobre os métodos de expressão, consulte Acesso de expressão a pontos de caminhos em formas, máscaras e traçados de pincel (referência de expressão).

Abaixo estão listados os métodos de expressão de exemplo dos seguintes objetos de caminho:

  • Caminhos de máscara de camada: layer("Dark Gray Solid 1").mask("Mask 1").path ou .maskPath
  • Caminhos de forma de Bézier: layer("Shape Layer 1").content("Shape 1").content("Path 1").path
  • Caminhos de traçado do efeito de pintura:layer("Dark Gray Solid 1").effect("Paint").stroke("Brush 1").path
  • Caminhos de traçado do Pincel tipo rotoscópio e efeito Refinar borda: layer("Dark Gray Solid 1").effect("Pincel tipo rotoscópio e efeito Refinar borda").stroke("Primeiro plano 1").path

Dicas para trabalhar com esses métodos de expressão:

  • Os valores de ponto e tangente são retornados como uma matriz de matrizes de pares de número [x,y] para as coordenadas dos vértices. Os valores de coordenadas são arredondados para quatro casas decimais.
  • As matrizes de ponto e tangente começam com o primeiro vértice no caminho. Você pode alterar o primeiro vértice dos caminhos da máscara de camada e de forma de Bézier usando o comando Camada > Máscara e Caminho de forma > Definir primeiro vértice.
  • As coordenadas para máscara de camada de pontos do caminho são relativas à origem da camada em seu canto superior esquerdo.
  • As coordenadas para pontos do caminho de forma Bézier são relativos ao ponto de ancoragem do grupo de formas do caminho (por exemplo, "Transformar: Forma 1 > Ponto de ancoragem").
  • As coordenadas para pontos de caminho de traçado de pincel são relativas ao início do traçado; o primeiro ponto é [0,0].
  • O método toComp() ou outros métodos de transformação do espaço da camada podem ser úteis ao converter coordenadas de diferentes camadas em um espaço comum ou apenas retornar as coordenadas relativas ao espaço de composição.
  • Porque os caminhos de forma de Bézier são relativos ao ponto de ancoragem do grupo de forma local e não da camada, seus valores podem ter sido deslocados de onde deveriam estar. Para solucionar isso, defina todas as propriedade de Transformação grupo de forma para zero. Lembre-se de que converter uma forma paramétrica para uma forma de Bézier pode afetar a posição do grupo de formas.
  • O método createPath() pode ser passado para pontos, tangentes e métodos isClosed do mesmo ou de outros caminhos. Você pode passar esses métodos inalterados para duplicar um caminho ou transformar os valores de ponto e tangente antes de passá-los para modificar ou animar o caminho.

Painel Criar nulos a partir dos caminhos

Criar nulos a partir dos caminhos scriptUI, permite criar animações intuitivas orientadas por expressões, sem criar expressões manualmente. É possível vincular os caminhos diretamente a formas, formas para sólidos etc. O painel Criar nulos a partir dos caminhos usa o acesso de expressão para pontos de caminho a fim de vincular automaticamente onulopara que você não precise criar a expressão por conta própria.

O painel cria nulos para cada ponto de caminho em um caminho de máscara ou de forma de Bézier. Você pode usar os seguintes botões no painel para orientar o desempenho dos nulos:

  • Pontos seguem nulos: o botão cria nulos que controlam a posição dos pontos de caminho. Os pontos de caminho são anexados aos nulos e você pode animá-los para orientar os pontos do caminho.
  • Nulos seguem pontos: o botão cria nulos controlados pela posição dos pontos de caminho. Os nulos são anexados aos pontos de caminho e você pode animar os pontos do caminho para mover os nulos.
  • Caminho de mapeamento: o botão para criar um único nulo que segue o caminho. A posição do nulo é vinculada às coordenadas do caminho. A rotação do nulo é orientada automaticamente para seguir o caminho. O Caminho de mapeamento controla o movimento do nulo no caminho e onde houver repetições. Por padrão, os quadros-chave são configurados para rastrear o caminho em 1 segundo eloopestá ativado.

Trabalhar com o painel

  1. Para abrir o painel, selecione Janelas > Criar nulos a partir de caminhos.jsx.

  2. Para adicionar uma máscara de forma, selecione Camada > Nova > Camada de forma. Adicione uma máscara de forma à camada.

    Observação:

    O painel funciona com formas de Bézier, portanto, todas as formas paramétricas como retângulo, elipse e estrela devem ser convertidas em uma forma de Bézier. Para converter uma forma paramétrica em forma de Bézier, gire para abrir a camada de forma e clique com o botão direito do mouse nocaminhoda forma, por exemplo, Retângulo 1, e selecione Converter em caminho de Bézier.

    Repita a etapa 2 para adicionar mais formas.

  3. Cada forma e máscara de Bézier tem um caminho. No painel Linha de tempo, gire para abrir as camadas e ver os caminhos. Se você deseja que nulo siga os pontos do caminho, selecione um caminho no painel Linha de tempo clique em Nulos seguem pontos no painel Criar nulos a partir do painel.

    O script gera um nulo para cada ponto no caminho. Você pode excluir todos os nulos que não forem necessários.

    Observação:

    Quando você converte uma forma paramétrica em uma forma de Bézier, o After Effects ajusta a propriedade da Posição da forma. Isso gera um deslocamento quando a posição dos nulos é calculada. Para evitar o problema, defina o valor da propriedade Transformar uma forma como, Transformar: Elipse 1 como zero antes de criar nulos.

  4. Se você deseja que os pontos de caminho sigam nulos, selecione um caminho no painel Linha de tempo. Clique em Pontos seguem nulos no painel Criar nulos a partir de caminhos .

  5. Depois de criar nulos para todos os pontos de caminho, você pode anexá-losentre sipara criar animações. Os nulos criadas com o botão Pontos seguem nulos e nulos criados com Nulos seguem pontos têm cores diferentes. Para anexar nulos, selecione um nulo e, mantendo a tecla Shift pressionada, use o ícone de seleção para selecionar uma camada principal e fazer com que as coordenadas nulas passem para ela.

    Depois de anexar todos os nulos juntos, visualize a animação para ver como funcionam.

Esta obra está licenciada sob uma licença não adaptada da Creative Commons Attribution-Noncommercial-Share Alike 3.0  As publicações do Twitter™ e do Facebook não são cobertas pelos termos do Creative Commons.

Avisos legais   |   Política de privacidade online