想提升 Photoshop Lightroom 的效能嗎?試試以下的建議。

採取全方位措施以達到最佳效果。請閱讀此處的所有建議。考量哪一項可在您電腦設定內容中實行。同時考量您使用的檔案類型,和您的特定工作流程。每種情況都是獨一無二的,需要不同的技術組合,才能達到最有效的 Lightroom 效能。

最佳化您的硬體和作業系統

更新至 Lightroom 的最新版本

在 Lightroom 中選擇「說明 > 檢查更新」。

高於最低系統需求

執行 Lightroom 的最低系統需求只是讓 Lightroom 運作的最低需求。特別是更多的 RAM 和更快的處理器可發揮顯著的效能優勢。需求會依下列條件而有所不同:

  • 您使用的檔案類型
  • 檔案的大小
  • 編目中的影像總數量
  • 汙點修復或局部 (筆刷的) 調整套用至影像的範圍

有助於提高效能的選項包含:

  • 64 位元、多核心處理器 (為獲得最佳效能,需至少為 6 核心;如果您使用多個高解析度螢幕而需要更強效能,就必須特別額外提升效能)
  • 12 GB RAM (建議);如果您要同時使用 Photoshop,RAM 應至少為 4 GB
  • 高速硬碟,尤其是供編目和預視用途使用

尋找您的 Lightroom 版本所適用的系統需求

若要查看您特定系統組態的詳細資訊,請在 Lightroom 中選擇「說明 > 系統資訊」。

請在 RAM 至少 12 GB 的電腦上執行 Lightroom

建議在 RAM 至少 12 GB 的電腦上執行 Lightroom,以享有最佳效能。搭載建議的 RAM 規格能產生龐大效益,尤其在讀入及轉存相片、於「放大」檢視中瀏覽相片,以及建立 HDR 影像和全景影像時,效能更顯著。

使用高速硬碟

若要執行最簡單的工作流程,使用快速的 (7200 rpm) 內部串行 ATA 硬碟即足夠。若要執行較耗資源的工作流程,則建議使用 RAID 陣列。

如果您在多台電腦上執行相同的編目時,將編目、影像檔案和預視儲存於外接式磁碟機是非常方便的作法。但這樣的作法可能會對 Lightroom 效能產生不良影響。如果您一定要將檔案儲存於外接裝置,請確定你具備快速的連線能力。舉例來說,使用 Thunderbolt 連線、USB 3.0 (非 USB 1.0 或 2.0) 或 eSATA 連線。 為了獲得最佳效能,請將外部磁碟機連接至相容的連接埠,且此連接埠在所有可用連接埠中具有最高頻寬限制。以下列出各種連接埠的頻寬限制:

Thunderbolt = 10 GB/秒
eSATA = 600MB/秒
PCIe = 500MB/秒
USB3 = 400MB/秒
USB2 = 35MB/秒

註解:

無法在網路磁碟機上儲存編目檔案,但您可以儲存相片。網路磁碟機 (透過網路存取的硬碟) 的資料傳輸率較慢。因此在 Lightroom 中切換模組或切換檔案時,可能需要較多時間。

請確定您具備足夠大的磁碟機且有足夠的可用空間

在硬碟可用空間嚴重不足的情況下執行,可能導致效能不彰。請確定儲存您 Lightroom 編目、預視和影像檔案的硬碟,還擁有至少 20% 的可用空間。

請參閱 Lightroom 系統需求,找出您的 Lightroom 版本所需要的最少硬碟可用空間。

更新圖形驅動程式

使用相容的圖形處理器 (另稱為圖形卡、視訊卡或 GPU)。請務必保持圖形驅動程式軟體為最新版本。

如果您電腦的圖形處理器與 Lightroom 不相容,請在「Lightroom (macOS)/編輯 (Win) > 偏好設定 > 效能」中,取消勾選「使用圖形處理器」核取方塊。

如需詳細資訊,請參閱 Lightroom 圖形處理器 (GPU) 疑難排解和常見問答集

以 64 位元模式來執行 Lightroom (Lightroom 4 和 3)

以 64 位元模式來執行 Lightroom,可以存取 2 GB 以上的 RAM,這也是 32 位元作業系統的最高效能。提供 Lightroom 存取 4 GB 以上的 RAM 可顯著提升效能。

如果 Lightroom 安裝於可執行 64 位元作業系統的電腦上並以 64 位元模式運作,就會自動以 64 位元模式作業。您可以採用下列方式來確認是否以 64 位元模式執行:

確認 Lightroom 是以 64 位元於 Windows 上執行

  1. 啟動 Lightroom 並查看應用程式的標題列。

  2. 查看標題中是否出現「x64」。

確認 Lightroom 是以 64 位元於 Mac OS 執行

  1. 在「Finder」中,導覽至「應用程式」資料夾並按一下「Adobe Lightroom 3」。

  2. 按 Command + I 鍵。

  3. 在「一般」選項中,請確定「以 32 位元模式開啟」已取消選取

若您一起使用 Photoshop 與 Lightroom,請檢查 Photoshop 的 RAM 設定

請參閱此 TechNote 中的發揮 RAM 與記憶體使用量最大效能章節,來判斷您電腦的最佳 RAM 設定。若要變更 Photoshop 中的記憶體設定,請選擇「Apple > 偏好設定 > 效能」(Mac OS)「編輯 > 偏好設定 > 效能」(Windows)

高解析度顯示器

Lightroom 使用整個高解析度顯示器的全部畫面時,在畫面上繪圖會顯得較為緩慢。高解析度顯示器的原生解析度接近 2560 x 1600,可見於 30 吋螢幕和 Retina MacBooks。若要提高此類顯示器的效能,請減少 Lightroom 視窗的尺寸,或使用「導覽器」面板中的 1:2 或 1:3 檢視。

在 Lightroom 中使用最佳化設定

在 Lightroom Classic 編輯內容時,暫停執行「與 Lightroom CC 同步」

同步影像會耗用 CPU 及系統資源,以建立預視畫面及從 Creative Cloud 上傳/下載影像。在桌上型電腦上讀入及編輯影像時,暫時停止執行與 Lightroom CC 同步功能。作業完成後,再繼續執行與 Lightroom CC 同步功能,並讓同步程序的應用程式整夜保持開啟,以繼續完成同步作業。

有意演算 1:1 預視

Lightroom 使用預視在「格點」檢視、「放大」檢視,以及「編輯相片」、「幻燈片播放」、「列印」和「Web」模組中顯示相片縮圖。

您讀入相片時,可選擇逐步提高品質的三種預視類型:

最小: 這種預視是小型、低解析度且為相機產生,內嵌於相片中的 JPEG 預視。它們是建立速度最快的預視類型。「圖庫」模組中的「底片顯示格窗」和「格點」檢視會暫時使用最小預視,直到 Lightroom 要針對那些縮圖演算標準大小預視為止。

嵌入與附屬檔案: 這些預視較大,也是由相機產生,需花費比最小預視稍長的時間建立。

標準: Lightroom 建立標準預視。使用 Camera Raw 引擎進行處理。所以,特別是當您在「編輯相片」模組中套用調整後,有時候會在最小或嵌入預視中顯示出不同的影像。您可以根據使用的顯示器,指定需要的「標準」預視大小。「標準」預視使用於「底片顯示格窗」和「格點」檢視縮圖,也使用於「幻燈片播放」、「列印」和「Web」模組中的預視和內容區域。

1:1:  這些預視乃是由 Camera Raw 引擎進行處理,以實際像素的 100% 視圖顯示,像是「標準」預視。Lightroom 產生 1:1 預視時,也會同時產生最小和標準預視,所以依程式需要共有三種可用的預視。因為處理的資料龐大,1:1 預視需要較長的時間來建立。您在「圖庫」模組中不論是放大至 1:1 或更大時,Lightroom 都會使用 1:1 預視。

若要顯示並處理相片,Lightroom 會根據不同工作而採用標準或 1:1 預視。如果在讀入時,您僅告訴 Lightroom 產生「最小」或「內嵌」預視,Lightroom 會在您於應用程式中工作時自動建立「標準」和 1:1 預視。此程序會影響效能。若要提高您的生產力並降低此程序的干擾,需針對演算 1:1 預視的時機和方式進行管理。在讀入時演算,或手動設定其他時間來執行演算。

若要在讀入時演算 1:1 預視,請在讀入視窗中使用「檔案處理」面板。選擇「演算預視 > 1:1」。雖然讀入時產生 1:1 預視會延緩讀入程序,但這麼做可讓您在「圖庫」模組中開始工作時,Lightroom 能有更理想的回應能力。

如果想要加快讀入程序,您也可以在讀入時演算最小或標準預視。然後,您隨時可以在「圖庫」模組中的「格點」檢視中選取多張相片,接著選擇「圖庫 > 預視 > 演算 1:1 預視」。讓 Lightroom 在您開始使用影像工作之前先進行處理。

盡可能縮小標準大小預視

因為演算標準預視要花費時間,請不要在 Lightroom 的必要作業之外加重其負擔。縮小標準預視也有助於降低預視檔案快取的大小,如此不僅可以提升效能,還可以節省硬碟空間。

若要縮小標準預視,請在「編目設定」對話方塊中指定適當的大小和品質:

  1. 選擇「編輯 > 編目設定」(Windows) 或 「Lightroom > 編目設定」(Mac OS),然後選取「檔案處理」。

  2. 如為「標準預視大小」,請選擇與您螢幕解析度長邊最接近的數值,並且不要低於該數值。例如,如果您的螢幕解析度為 1920 x 1200 像素,請選擇「標準預視大小 > 2048 像素」。

  3. 如為「預視品質」,請選擇「低」或「中」,等同於 JPEG 檔案品質規模的低或中等範圍。

註解:

您使用的顯示器越大 (且解析度越高),在您進行調整時,Lightroom 就要耗費更多效能去計算預視並更新像素。如果您使用大螢幕時發生效能不彰的情況,請使用「顯示控制台」(Windows) 或「顯示器系統偏好設定」(Mac OS),嘗試降低顯示器的解析度。 

盡可能延長 1:1 預視保留時間

因為 1:1 預視會迅速地耗盡磁碟空間,Lightroom 提供您清除預視的選項: 每天、每週或每個月。每次清除預視後,Lightroom 都必須在下一次您需要時重新建立,即使您只是放大至「放大」檢視。

若是磁碟空間充裕,盡可能延長 1:1 預視保留時間有助於最佳的效能表現。在「編目設定」對話方塊中的「檔案處理」區域,選擇「自動清除 1:1 預視 > 30 天後」或「永不」。

但是請注意,檔案會包含預視,如果您將刪除預視的選項設定為「永不」或「30 天」,[編目設定] Previews.lrdata 檔案可能會增大。此檔案與編目檔案相同。如果此選項設定為「永不」,然後發生硬碟空間不足的問題,請檢查此檔案的大小。如果檔案過大,請刪除檔案。

將編目和預視快取保留在相同的資料夾

依預設,Lightroom 會將預視快取檔案 [編目名稱] Previews.lrdata 和編目檔案 [編目名稱].lrcat 保留在相同的資料夾中。如果您移動編目檔案或與快取分開儲存,則 Lightroom 必須重新產生預視。所以請將兩者儲存在相同位置。

如需編目、預視和其他 Lightroom 檔案的預設位置,請參閱偏好檔案和其他檔案位置

將自動寫入 XMP 維持關閉

依預設,您在 Lightroom 中作出的檔案變更 (例如加入關鍵字或校正紅眼) 都會和相片一起存放在 Lightroom 編目中。  然而,使用其他應用程式時 (例如 Adobe Bridge 和 Camera Raw),這些編輯內容會儲存為 XMP (可延伸中繼資料平台) 資料以供識別。這項資料會和映像檔一起存放。

在 Lightroom 中,您可以自動或手動將編輯內容儲存至 XMP。如果您經常切換使用 Lightroom、Adobe Bridge 和 Camera Raw,自動儲存變更至 XMP 是最方便的做法。如此一來,您就可以不必費心。這些應用程式會持續保持同步,一律反映出目前的 Lightroom 編輯內容,而您不會在 Bridge 或 Lightroom 中看到中繼資料不相符圖示或小圖示。

變更內容會自動儲存,但會大幅降低 Lightroom 效能。如果您不會使用多個應用程式,則建議您關閉自動寫入偏好設定。變更內容仍然會儲存在編目中,當您在 Lightroom 列印或轉存相片時,這些變更會在輸出內容中顯示。

如要關閉自動寫入 XMP,請執行以下步驟:

  1. 選擇「編輯 > 編目設定」(Windows) 或「Lightroom > 編目設定」(Mac OS)。

  2. 按一下「中繼資料」標籤,取消選取「自動將更改寫入至XMP 中」。

即使已關閉自動寫入 XMP,您也可以隨時將中繼資料變更手動儲存至個別檔案。如需更多資訊,請參閱中繼資料基本知識與動作

最佳化編目

Lightroom 會持續地將變更寫入編目檔案 (.lrcat)。效能遲緩時,可藉由選取「檔案 > 最佳化編目」將 Lightroom 編目最佳化。將編目最佳化會指示 Lightroom 檢查編目的資料架構,且確定其為簡潔有序。

要更進一步最佳化效能、改善編目穩定度和備份編目,請在結束 Lightroom 時,選擇「在備份之前測試完整性」和「在備份之後最佳化編目」選項。這些程序會花費一些時間,但可以有助於維持編目順暢地作業。 

增加 Camera Raw 快取大小

您每次在「編輯相片」模組檢視或編輯 RAW 影像時,Lightroom 都會產生最新的高品質預視。模組會以原始影像檔案做為基礎,然後依照已套用的任何處理或調整更新預視。如果原始影像位於 Camera Raw 快取,則程序會稍微加快。Lightroom 會檢查原始影像資料的快取,如果影像資料已有快取就會略過初步處理。

依預設,Lightroom 將 Camera Raw 快取設定為 1 GB。如果您增加快取大小,便可以儲存更多影像資料,並轉而加速產生那些影像的預視。 一些 Lightroom 使用者發現將 Camera Raw 快取增加至 20 GB 或以上,將可大幅提昇「編輯相片」模組的效能。 若要增加 Camera Raw 快取大小,請依照下列執行:

  1. 選擇「Lightroom > 偏好設定」(Mac OS) 或「編輯 > 偏好設定」(Windows)。

  2. 按一下「檔案處理」標籤。

  3. 在「Camera Raw 快取設定」區域,調整至最大大小 10 GB 或以上進行測試。

若要進一步加速快取,請將快取保留在高速硬碟中。若要指定 Camera Raw 快取的位置,請依照以下方式執行:

  1. 選擇「Lightroom > 偏好設定」(Mac OS) 或「編輯 > 偏好設定」(Windows)。

  2. 按一下「檔案處理」標籤。

  3. 在「Camera Raw 快取設定」區域,按一下「選擇」並導覽至您想要儲存快取的位置。

「污點移除」工具、局部校正及「步驟記錄」面板

「污點移除」工具及「局部校正」筆刷並非專門設計為提供數百到數千次校正。若您的影像包含許多 (數百次) 局部調整,請考慮使用以像素為基礎的編輯方法 (如 Photoshop) 進行此層級的校正。

若您校正許多次,請查看您的「步驟記錄」面板。 「步驟記錄」面板並無限制,且除非另有規定,否則不會遭到刪除。若您已建立許多局部或污點校正,您的步驟記錄可能會相當冗長,因而拖慢整體 Lightroom 的效能。

請按一下「步驟記錄」面板標題右方的 X,清除「步驟記錄」面板。

Develop 作業順序

提高效能的最佳 Develop 作業順序如下所述:

  1. 污點修復。
  2. 如「鏡頭校正」設定檔及「手動」校正等幾何校正,包括使用「垂直」滑桿的梯形校正。
  3. 非細節的整體校正,如「曝光度」及「白平衡」。必要時,也可先行完成這些校正。
  4. 局部校正,如「漸層濾鏡」及「調整筆刷」筆畫。
  5. 細節校正,如「雜訊消除」及「銳化」。

備註: 先執行污點修復可提高污點修復的準確性,並確保修復的區域邊界符合污點位置。

避免進行非必要的校正

此建議尤其適用於局部校正。您在套用局部校正或漸層濾鏡時變更的每個滑桿,皆會套用至整體校正。而且,每個選項都會耗用資源,影響效能。

套用局部校正及漸層時,請確認您需要已選取的所有校正。

若您無須使用筆刷筆畫或漸層來執行某類型的校正,請將其滑桿設為零。

另請避免運用不必要的整體校正,尤其是耗費資源的選項,如「雜訊消除」、「銳化」及「鏡頭校正」。

某些滑桿的預設值是開啟。若是資源更密集的選項,設為零會停用滑桿。

縮放顯示選項

若「符合」與「填滿」縮放顯示選項變慢,請嘗試使用「導覽器」面板中的「1:2」、「1:3」 或「1:4」選項。

要使用哪個處理版本

處理版本 2012 耗費的資源確實高於處理版本 2010,因此在某些情況下可能會變慢。然而,需在效能增益與處理版本 2012 提供的編輯與影像品質之間求取平衡。

刪除 Lightroom 預置快取。

儘管下列問題鮮少發生,但下列其中一個或多個問題有時會發生,且若真的發生,您可能需要刪除預視快取檔案:

  • 您的硬碟突然滿了。
  • 您在 Lightroom 中出現快取錯誤。
  • 您的影像中出現不自然感—如線條、圓點或非預期的彩色區域。

包含您的縮圖與預視資料的檔案稱為 [編目名稱] Previews.lrdata,與編目一樣位於相同資料夾中。

您的縮圖、小預視及 1:1 (完整尺寸) 預視均保留在此 Previews.lrdata 檔案中。Lightroom 的偏好設定具有何時要刪除最大預視 (1:1 預視) 的選項。刪除 1:1 預視時,Previews.lrdata 檔案大小將會隨之減少。若您未刪除 1:1 預視,預視檔案可以變很大。 

1:1 預視刪除時間的預設設定為 1 週。刪除這些大預視時,雖然預視檔案大小會減少,但除非手動刪除整個檔案,否則不會刪除整個檔案。除非您鮮少或從未刪除 1:1 預視,否則檔案不會變得很巨大,但是否會影響硬碟,則取決於您的可用硬碟空間。您可選擇「編輯 > 編目設定 > 檔案處理」(Windows) 或 「Lightroom > 編目設定 > 檔案處理」(Mac OS),變更刪除 1:1 預視的頻率。

備註: 請勿將在此 TechNote 討論的 Previews.lrdata 檔案與 [編目名稱] Smart Previews.lrdata 檔案 (內含您所有智慧型預視) 搞混。若硬碟空間非常有限,您可能需要刪除此檔案,但若您的硬碟空間不足,而出現硬碟錯誤,您應清空資源回收筒、封存某些檔案,及/或整理您的資料,以便有更多可用的硬碟空間。

若您刪除 Previews.lrdata 檔案,您在 Lightroom 中開啟的每個資料夾或集合都會重新建立預視,因此首次在資料夾中工作時,您會在重新建立預視時感到些許延遲。

若「自動捨棄 1:1 預視」選項設為「從不」或「30 天後」,您的預視檔案會變得非常大。這會佔用好幾 GB 的空間。若您的硬碟突然滿了,請檢查此檔案的大小。您之後可以刪除檔案。 

您可能會在 Lightroom 中遇到指出快取問題的錯誤;此時是您會想要刪除 previews.lrdata 檔案的時候。

若您的影像有不自然感 (如彩色線條、圓點或非預期的彩色區域),您的預視檔案可能損毀,而唯一修正的方法即是刪除 previews.lrdata 檔案。 

請注意,若您從已封存的影像將影像預視納入編目中,您也會失去這些預視。 

若刪除 Previews.lrdata 檔案無法解決您的問題,請嘗試清除您的 Camera Raw 快取檔案。 

  1. 在 Lightroom 中,選擇「編輯 > 偏好設定 > 檔案處理」(Windows) 或「Lightroom > 偏好設定 > 檔案處理」(Mac OS)。
  2. 按一下「Camera Raw 快取設定」下的「清除快取」

您也可以按一下「選擇」,變更此快取的位置。請注意,此快取僅供 Develop 模組之用。

減少預置數

增加 Lightroom 的預置數 (無論是您或協力廠商建立) 會因 Develop 模組在「導覽器」面板中產生各預置的縮圖,而降低效能。您擁有 2,000 或以上的預置數後,最能感受到此現象。請將載入 Lightroom 預置數減少至您最常用的幾個預置數,以免出現此類型的拖慢現象。

定期執行系統維護

保持 Lightroom 處於最新狀態

更新可修正錯誤並改善效能。請確定您執行的是您的 Lghtroom 版本的最新更新。選擇「說明 > 檢查更新」

關閉不必要的應用程式和啟動項目

其他開啟的應用程式和啟動項目會降低 Lightroom 可用的記憶體數量。結束無謂的應用程式、啟動項目和延伸功能,然後空出更多可供 Lightroom 使用的記憶體。

在 Lightroom 中工作時,也要暫時停用會執行即時掃描或自動備份的防毒或安全性軟體。如需停用防毒或安全性軟體功能的說明,請參閱您的防毒或安全性軟體的文件。

執行磁碟清理 (Windows)

在應用程式中工作時,Windows 會在硬碟中為您的資料檔案儲存一份暫存複本。許多應用程式會建立 .tmp 檔案,然後在您結束應用程式後便予以刪除。然而,當機或系統錯誤會妨礙應用程式刪除這些檔案,以致於占用磁碟空間並產生問題。時不時執行磁碟清理,可移除暫存檔案與其他不再使用的檔案。

  1. Windows: 選擇「開始」,在「搜尋」文字方塊中鍵入「磁碟清理」,然後在「程式」清單中選擇「磁碟清理」。

  2. 選擇要清理的磁碟機 (若適用)。

  3. 選取暫存檔案與其他您要刪除的檔案。

  4. 按一下「確定」。

重組硬碟

您在硬碟中新增、刪除以及移動檔案時,其可用空間就不再是單一的連續區塊。如果系統沒有足夠的連續空間,就會將檔案片段儲存於硬碟的不同位置。Lightroom 對於讀取/寫入分散檔案所花費的時間,會比讀取/寫入儲存於連續位置的檔案還要多。

重組硬碟時,請務必選取修正磁碟機錯誤並復原磁區損毀的選項。如需在 Windows 上重組硬碟的指示,請參閱以下 Microsoft 說明主題:

一般而言,Mac OS 硬碟不需進行磁碟重組。Mac OS X 會自動針對小型檔案進行磁碟重組。在 Mac OS 上若要完成更穩定的磁碟重組或針對硬碟進行疑難排解的問題,請使用「Apple 磁碟工具程式」。亦可使用 Micromat Tech Tool Pro 之類的協力廠商工具程式。請參閱 Apple 支援網站上的 Mac OS X 的磁碟最佳化相關資訊

安裝現有的作業系統更新

更新 Windows 或 macOS 作業系統,可以改善其效能以及與應用程式間的相容性。

透過 Microsoft 網站取得 Windows Service Pack 和其他更新。若需要安裝 Service Pack 和其他更新程式的協助,請聯絡 Microsoft 技術支援團隊。

若要取得 Mac OS X 更新,請於 Apple 功能表上選擇「軟體更新」。如需協助安裝更新,請聯絡 Apple 技術支援。

註解:

安裝系統更新之前,請檢查 Adobe 軟體的系統需求以確保相容性。(此外,請檢查您用於 Adobe 軟體的任何協力廠商軟體或硬體)。若未列出更新,請聯絡 Adobe 或協力廠商軟體或硬體的製造商。

此産品由 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 授權  Creative Commons 條款未涵蓋 Twitter™ 與 Facebook 文章。

法律說明   |   線上隱私權政策