Marionetten sind die Objekte/Figuren, die Sie aus Ihren Photoshop- oder Illustrator-Grafikenerstellenund die Sie steuern können, um Bewegungen zu erstellen. Sie können jederzeit zu Photoshop oder Illustrator wechseln, um Änderungen an Grafiken durchzuführen, oder das Verhalten mithilfe von Tagging in Character Animator steuern.

Eine Marionette verfügt über Ebenen, die teilweise gruppiert sind. Ebenen mit Öffnungspfeilen werden als Gruppen bezeichnet. Wählen Sie Ebenen aus, um ihre Eigenschaften zu ändern, Marionetten aus Teilen im Projektfenster zusammenzusetzen (z. B. Teile aus mehreren Marionetten oder Grafikdateien), Ebenen neu anzuordnen und neu zu positionieren sowie Ebenen auszublenden oder anzuzeigen.

Sie können Marionetten aus entsprechend strukturierten Grafikdateien erstellen oder mit einer leeren Marionette beginnen und sie aus Teilen anderer Marionetten oder importierten Grafikdateien zusammenstellen. Außerdem haben Sie die Möglichkeit, eine Marionette zu duplizieren, um eine neue Version für eine weitere Arbeit zu erstellen.

Anschließend können Sie Ebenen und Handles auswählen und ihnen Tags zuweisen, um deren Verhalten zu steuern. Weitere Informationen finden Sie unter Vorbereiten von Grafiken.

Characterizer, der auf Adobe Sensei basiert, generiert in Sekundenschnelle eine stylisierte Character Animator-Marionette. Für die Erstellung der Marionetten werden ein per Webcam erfasstes Bild des Benutzers sowie sämtliche Referenzgrafiken verwendet. Weitere Informationen finden Sie unter Erstellen einer Marionette mit Characterizer.

Erstellen einer Marionette in Character Animator aus Grafiken

So erstellen Sie eine Marionette aus einer PSD- oder AI-Datei:
  1. Wählen Sie „Datei“ > „Importieren“ (Befehl/Strg+I) aus.

  2. Wählen Sie eine oder mehrere .ai- oder .psd-Dateien aus und klicken Sie anschließend auf „Öffnen“.

    Für jede ausgewählte Grafikdatei wird im Projektfenster eine Marionette erstellt, die entsprechend dem Dateinamen der Grafikdatei benannt wird.

Marionette aus Vorlage erstellen

Um eine Marionette anhand einer PSD- oder AI-Vorlagendatei zu erstellen, verwenden Sie den Chloe-Marionettenlink im Arbeitsbereich „Start“. Eine Kopie der PSD- oder AI-Vorlagendatei wird im Projektordner abgelegt, ins Projekt importiert sowie zu einer neuen Szene hinzufügt und die PSD- oder AI-Datei wird in Photoshop oder Illustrator geöffnet, damit Änderungen vorgenommen werden können. Nach dem Speichern der Änderungen an der Datei und dem erneuten Wechsel zu Character Animator wird die Marionette entsprechend aktualisiert.

Leere Marionette erstellen

Um eine leere Marionette zu erstellen, wählen Sie „Marionette“ > „Neue leere Marionette“ aus und benennen Sie das Marionettenelement.

Hinweis:

Auf eine leere Marionette werden keine Standardverhalten angewendet.

Marionette duplizieren

Um eine Marionette zu duplizieren, wählen Sie sie aus und wählen Sie anschließend Bearbeiten > Duplizieren (Befehl/Strg+D) aus.

Beim Duplizieren eines Marionettenelements im Projektfenster wird eine separate Kopie aller Gruppen und Ebenen in der Marionette erstellt. Dadurch können Sie verhindern, dass Änderungen in einer Marionette sich auf die duplizierte Marionette auswirken.

Teilen einer Marionette

Teilen Sie eine Marionette mit anderen Character Animator-Benutzern, indem Sie sie als .puppet-Datei exportieren. Bei der Marionettendatei handelt es sich um eine importfertige eigenständige Datei, die sämtliche für die Marionette benötigten Grafiken enthält.

  1. Wählen Sie die Marionette im Projektfenster aus bzw. öffnen Sie sie.

  2. Wählen Sie „Datei“ > „Exportieren“ > „Marionette“ und geben Sie einen Namen für die .puppet-Datei ein.

  3. Senden Sie die .puppet-Datei über einen freigegebenen Link oder auf andere Weise an den anderen Benutzer.

  4. Um eine geteilte Marionette zu öffnen, importieren Sie die .puppet-Datei über „Datei“ > „Importieren“ oder indem Sie sie in das Projektfenster ziehen.

    Hinweis:

    • Sie können die Marionette erneut mit einer freigegebenen Grafikinstanz verknüpfen.
    • Parameteränderungen an einer Marionette in der Zeitleiste sowie aufgenommene Einstellungen einer Marionettenspur sind nicht in einer .puppet-Datei enthalten.
    • Verhalten der importierten Marionette werden auf die Versionen der Verhalten aktualisiert, die im aktuellen Projekt verfügbar sind.

Zyklus-Marionetten

Erstellen Sie aus einer Reihe von Bildern (im PNG-Format) eine Zyklus-Marionette, die Sie mit dem Verhalten „Zyklusebenen“ verwenden möchten. Bei diesem Verhalten werden die einzelnen Ebenen der Marionette in ihrer Reihenfolge angezeigt. Dies ist hilfreich, um ein Muster zu wiederholen.

Erstellen einer Zyklus-Marionette

  1. Öffnen Sie eine Marionette im Marionettenfenster und klicken Sie auf Zyklus hinzufügen oder wählen Sie Datei > Zyklus importieren

  2. Wenn Sie die Zyklus-Marionette mit der Option Zyklus hinzufügen erstellen, wählen Sie eine PNG- oder JPEG-Datei aus Ihrer Sequenz.

    Hinweis:

    Bei Sequenzen handelt es sich um PNG-Dateien mit demselben Basisnamen und einem numerischen Suffix wie Klappern001.png, Klappern002.png usw.

    Im Projektfenster wird eine Marionette mit angewendeten Zyklusebenen erstellt, die nach der PNG- oder JPEG-Sequenz benannt ist. Diese Marionette wird dann im Marionettenfenster über der aktuell ausgewählten Ebene hinzugefügt.

  3. Wenn Sie die Zyklus-Marionette mit der Option PNG-Zyklus importieren erstellen, ziehen Sie die erstellte Zyklus-Marionette aus dem Projektfenster auf die Marionette im Marionettenfenster.

    Hinweis:

    • Bei Zyklus-Marionetten, die mit dem Menübefehl Zyklus importieren erstellt werden und bei denen der Parameter Start des Zyklusebenen-Verhaltens auf Sofort eingestellt ist, wird beim Hinzufügen der Marionette zu einer Szene automatisch der Zyklus angezeigt. 
    • Bei Zyklus-Marionetten, die mit der Schaltfläche Zyklus hinzufügen erstellt werden, ist der Parameter Start auf Wenn ausgelöst eingestellt. Dies ist hilfreich, wenn der Zyklus per Tastendruck ausgelöst wird.
    • Alle Ebenen mit Ausnahme der ersten Ebene in der Zyklus-Marionette sind standardmäßig deaktiviert und für alle Ebenen ist die Einstellung Andere in der Gruppe ausblenden ausgewählt. Dadurch wird beim Klick auf den Augapfel einer Ebene automatisch die zuvor angezeigte Ebene ausgeblendet.

Platzieren von Marionetten in einer Szene

Marionetten können Sie anzeigen und steuern, indem Sie sie in einer Szene platzieren. Sie können mehrere Marionetten in einer Szene platzieren.

Führen Sie einen der folgenden Schritte aus, um eine Marionette zu platzieren:

  • Wählen Sie die Marionette im Projektfenster aus, klicken Sie dann auf Der neuen Szene hinzufügen oder wählen Sie Objekt > Der neuen Szene hinzufügen.
  • Ziehen Sie die Marionette aus dem Projektfenster in die Szene, um sie im Szenen- oder im Zeitleistenfenster zu öffnen.
  • Wenn das Szenen- und das Zeitleistenfenster leer sind (also keine Szene geöffnet ist), wird die hineingezogene Marionette einer neuen Szene hinzugefügt.
  • Ziehen Sie die Marionette in eine bestehende Szene, die im Projektfenster aufgeführt wird.

Die Marionette wird in der Szene geöffnet und ein Spurelement für die Marionette wird geöffnet und im Zeitleistenfenster ausgewählt. Mit diesem Spurelement können die spezifischen Parameter für diese Marionetteninstanz angepasst werden.

Hinweis: Die importierten Marionetten werden standardmäßig in der Mitte der Szene positioniert. Verwenden Sie das Verhalten „Transformieren“, um eine Marionette in der Szene neu zu positionieren.

Bearbeiten der ursprünglichen Grafik einer Marionette

Die mit einer Marionette verbundene Grafik kann aktualisiert werden, ohne eine Marionette neu zu erstellen und angewendete Verhalten und Verhaltensparameter von Grund auf zu ändern.

Um die Grafik einer Marionette zu bearbeiten, befolgen Sie diese Schritte:

  1. Wählen Sie die Marionette im Projektfenster oder die Marionettenebene im Marionettenfenster aus und wählen Sie dann Bearbeiten > Datei extern bearbeiten (Befehl/Strg+E) aus. Wenn Ihre Marionettendatei in Photoshop oder Illustrator geöffnet ist, können Sie die Dateien direkt dort bearbeiten und die Änderungen werden automatisch synchronisiert. Die mit der Grafik der Marionette verknüpfte Standardanwendung wird gestartet (z. B. Photoshop für .psd-Dateien, Illustrator für .ai-Dateien). Öffnen Sie die Grafik.

  2. Passen Sie die Grafik wie gewünscht an und speichern Sie Ihre Änderungen. Es ist wichtig, die an den Grafikdateien vorgenommenen Änderungen zu speichern, damit diese Änderungen in Character Animator angezeigt werden.

  3. Wechseln Sie zurück zu Character Animator. Die bearbeitete Datei sollte automatisch erkannt und aktualisiert werden.

  4. Wenn Character Animator die aktualisierte Grafik nicht erkennt, schließen Sie die Fehlermeldung und warten Sie einige Sekunden.

Video: Aufbau einer Marionette von Grund auf

Video: Aufbau einer Marionette von Grund auf
Dave Werner

Hinweis: Im Tuturial-Video Building A Puppet From Scratch (Erstellen einer neuen Marionette) erfahren Sie, wie Sie eine Marionette in Photoshop neu erstellen und diese in Adobe Character Animator zum Leben erwecken.

Wenn eine Marionette im Projekt ausgewählt oder im Bedienfeld „Marionette“ geöffnet ist, wird im Bereich „Marionette“ des Bedienfelds „Eigenschaften“ der Pfad für die Quellgrafik und in der QuickInfo der vollständige Pfad angezeigt. Wenn die Grafikdatei nicht gefunden werden kann, wird der Dateiname gelb angezeigt und erhält das QuickInfo-Präfix Fehlt.

Um die Quellgrafik erneut zu verknüpfen oder zu ersetzen, klicken Sie auf den Dateinamen im Bedienfeld „Eigenschaften“ und wählen Sie dann die zu verwendende Grafikdatei aus.

Ersetzen der Quellmarionette einer Marionettenspur

Sie können eine Marionette in einer Zeitleiste auch dann noch aktualisieren oder ersetzen, wenn Sie bereits Einstellungen für sie aufgenommen haben. Dies ermöglicht es Ihnen, beim Hinzufügen von neuen Inhalten zu einer Marionette bestehende Aufzeichnungen beizubehalten, wenn dabei die allgemeine Marionettenstruktur bestehen bleibt.

Um die Quellmarionette einer Marionettenspur zu ersetzen, führen Sie einen der folgenden Schritte aus:

  • Wählen Sie die Marionettenspur in der Zeitleiste aus. Halten Sie dann die Wahltaste (Mac) bzw. die Alt-Taste (Windows) gedrückt und ziehen Sie dabei die Marionette auf die ausgewählte Marionettenspur im Zeitleistenfenster.
  • Wählen Sie im Projektfenster die Marionette aus, durch die Sie die andere ersetzen möchten. Klicken Sie dann mit der rechten Maustaste auf der linken Seite des Spurkopfbereichs auf die Marionettenspur und wählen Sie Mit ausgewählter Marionette im Projektfenster ersetzen aus.

Alle von Teilen der ursprünglichen Quellmarionette aufgenommenen Einstellungen, die nicht mehr in der zum Ersetzen verwendeten Marionette vorhanden sind, werden entfernt.

Dieses Werk unterliegt den Bedingungen der Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Twitter™- und Facebook-Beiträge fallen nicht unter die Bedingungen der Creative Commons-Lizenz.

Rechtliche Hinweise   |   Online-Datenschutzrichtlinie