Extrayez et archivez des fichiers depuis un serveur local ou distant à l'aide du système d’archivage et d’extraction de Dreamweaver, de WebDAV ou de Subversion.

Si vous travaillez en équipe, vous avez la possibilité d'archiver et d'extraire des fichiers sur les serveurs local et distant. Si vous êtes la seule personne à travailler sur le serveur distant, vous pouvez utiliser les commandes Acquérir et Placer pour transférer des fichiers sans avoir à les archiver ou à les extraire.

Remarque :

Vous pouvez utiliser la fonctionnalité d'acquisition et de placement de fichiers sur un serveur d'évaluation, mais le système d'archivage et d'extraction n'est pas disponible sur ce type de serveur.

L'extraction d'un fichier équivaut à signaler aux autres utilisateurs que vous travaillez sur ce fichier et qu'ils ne doivent pas le modifier. Lors de l'extraction d'un fichier, le nom de la personne ayant effectué l'opération est affiché dans le panneau Fichiers, avec une coche de couleur rouge (si le fichier a été extrait par un autre membre de l'équipe) ou verte (si vous êtes la personne à avoir extrait le fichier) en regard de son icône.

L'archivage d'un fichier équivaut à le mettre à la disposition des autres membres de l'équipe, qui peuvent l'extraire et le modifier. Lorsque vous archivez un fichier après l'avoir modifié, la version locale de ce fichier devient accessible en lecture seule et un cadenas apparaît en regard du fichier dans le panneau Fichiers pour vous empêcher de le modifier.

Dreamweaver ne rend pas les fichiers extraits accessibles en lecture seule sur le serveur distant. Si vous transférez des fichiers à l'aide d'une application autre que Dreamweaver, vous risquez d'écraser les fichiers extraits. Toutefois, dans les applications autres que Dreamweaver, le fichier LCK est visible près du fichier extrait dans la hiérarchie de fichiers afin d'éviter ce type d'incident.

Configuration du système d'archivage et d'extraction de fichiers

Pour utiliser le système d'archivage et d'extraction, vous devez associer votre site local à un serveur distant.

  1. Choisissez Site > Gérer les sites.
  2. Sélectionnez un site et cliquez sur Modifier.
  3. Dans la boîte de dialogue Configuration du site, sélectionnez la catégorie Serveurs et effectuez l'une des actions suivantes :
    • Cliquez sur le bouton Ajouter nouveau serveur pour ajouter un nouveau serveur.

    • Sélectionnez un serveur existant puis cliquez sur le bouton Modifier serveur existant.

  4. Définissez les options de base requises, puis cliquez sur le bouton Avancé.
  5. Activez l'option Activer l'extraction de fichier si vous travaillez au sein d'une équipe (ou si vous travaillez seul, mais depuis plusieurs machines). Désélectionnez cette option si vous souhaitez désactiver l'archivage et l'extraction de fichiers dans votre site Web.

    Cette option est utile pour informer les autres utilisateurs que vous avez extrait un fichier en vue de le modifier ou pour vous rappeler qu'une version plus récente d'un fichier est peut-être ouverte sur une autre machine.

    Si vous ne voyez pas les options Archiver/Extraire, cela signifie que vous n'avez pas configuré le serveur distant.

  6. Activez l'option Extraire les fichiers à l'ouverture si vous voulez que les fichiers soient automatiquement extraits lorsque vous double-cliquez dessus pour les ouvrir dans le panneau Fichiers.

    Si vous choisissez Fichier > Ouvrir pour ouvrir un fichier, cela n'extrait pas le fichier, même si cette option est activée.

  7. Définissez les options restantes :

    Nom d'extraction

    Ce nom apparaît dans le panneau Fichiers à côté des fichiers extraits afin que les membres d'une équipe puissent s'adresser à la personne appropriée s'ils ont besoin d'un fichier extrait.

    Remarque :

    Si vous travaillez seul sur plusieurs machines, utilisez un nom d'extraction différent pour chaque machine (par exemple, PierreR-MacDomicile et PierreR-PCBureau) de manière à savoir où se trouve la version la plus récente du fichier si vous oubliez de l'archiver.

    Adresse électronique

    Si vous saisissez une adresse électronique, lors de l'extraction d'un fichier, votre nom apparaît dans le panneau Fichiers en regard du fichier, sous la forme d'un lien (bleu souligné). Si un membre de l'équipe clique sur le lien, son programme de messagerie électronique par défaut ouvre un nouveau courriel à destination de votre adresse électronique et comportant un objet qui correspond aux noms du site et du fichier.

Archivage et extraction de fichiers dans un dossier distant

Une fois le système d'archivage et d'extraction défini, vous pouvez archiver et extraire des fichiers sur un serveur distant via le panneau Fichiers ou la fenêtre de document.

Extraction des fichiers à l'aide du panneau Fichiers

  1. Dans le panneau Fichiers (Fenêtre > Fichiers), sélectionnez les fichiers à extraire du serveur distant.

    Remarque :

    Vous pouvez sélectionner des fichiers dans l'affichage du site local ou distant mais pas dans l'affichage Serveur d'évaluation.

    Une coche de couleur rouge indique qu'un autre membre de l'équipe dispose du fichier extrait. Un symbole représentant un cadenas indique que le fichier est en lecture seule (Windows) ou verrouillé (Macintosh).

  2. Procédez de l'une des manières suivantes pour extraire les fichiers :
    • Cliquez sur le bouton Extraire dans la barre d'outils du panneau Fichiers.

    • Cliquez avec le bouton droit de la souris (Windows) ou en maintenant la touche Ctrl enfoncée (Macintosh), puis choisissez Extraire dans le menu contextuel.

  3. Dans la boîte de dialogue Fichiers dépendants, cliquez sur Oui si vous souhaitez télécharger les fichiers dépendants associés aux fichiers sélectionnés ou sur Non si vous ne voulez pas les télécharger. L'option par défaut est de ne pas télécharger les fichiers indépendants. Vous pouvez définir cette option en sélectionnant Edition > Préférences > Site.

    Remarque :

    D'une manière générale, il est conseillé de télécharger les fichiers dépendants lorsque le fichier extrait est un nouveau fichier, mais c'est inutile si les versions les plus récentes des fichiers dépendants sont déjà présentes sur le disque local.

    Une coche de couleur verte apparaît en regard de l'icône du fichier local pour signaler que vous l'avez extrait.

    Remarque :

    Si vous extrayez le fichier actif, la version ouverte du fichier est écrasée par la nouvelle version extraite.

Archivage des fichiers à l'aide du panneau Fichiers

  1. Dans le panneau Fichiers (Fenêtre > Fichiers), sélectionnez les fichiers extraits ou sélectionnez de nouveaux fichiers.

    Remarque :

    Vous pouvez sélectionner des fichiers dans l'affichage du site local ou distant mais pas dans l'affichage Serveur d'évaluation.

  2. Procédez de l'une des manières suivantes pour archiver les fichiers :
    • Cliquez sur le bouton Archiver dans la barre d'outils du panneau Fichiers.

    • Cliquez avec le bouton droit de la souris (Windows) ou en maintenant la touche Ctrl enfoncée (Macintosh), puis choisissez Archiver dans le menu contextuel.

  3. Cliquez sur Oui si vous souhaitez envoyer les fichiers dépendants associés aux fichiers sélectionnés ou sur Non si vous ne voulez pas les envoyer. L’option par défaut est de ne pas transférer les fichiers indépendants. Vous pouvez définir cette option en sélectionnant Édition > Préférences > Site.

    Remarque :

    Il est en général conseillé de transférer les fichiers dépendants lorsque vous archivez un nouveau fichier, mais si les versions les plus récentes des fichiers dépendants figurent déjà sur le serveur distant, il n'est pas utile de les transférer à nouveau.

    Un cadenas apparaît en regard de l'icône du fichier local pour indiquer que ce dernier n'est désormais accessible qu'en lecture seule.

    Remarque :

    Si vous archivez le fichier actif, il se peut que ce fichier soit automatiquement enregistré avant d'être archivé, selon les options définies dans les préférences.

Archivage d'un fichier ouvert à partir de la fenêtre de document

  1. Assurez-vous que le fichier à archiver ou à extraire est ouvert dans la fenêtre de document.

    Remarque :

    Vous ne pouvez archiver qu'un seul fichier ouvert à la fois.

  2. Effectuez l'une des opérations suivantes :
    • Choisissez Site > Archiver.

    • Cliquez sur l'icône Gestion des fichiers dans la barre d'outils de la fenêtre du document, puis sélectionnez Archiver dans le menu.

      Si le fichier actuel n’est pas associé au site actif dans le panneau Fichiers, Dreamweaver tente de déterminer à quel site défini localement le fichier actuel appartient. Si le fichier actuel appartient à un autre site que celui qui est actif dans le panneau Fichiers, Dreamweaver ouvre ce site, puis effectue l'opération d'archivage.

    Remarque :

    Si vous archivez le fichier actif, il se peut que ce fichier soit automatiquement enregistré avant d'être archivé, selon les options définies dans les préférences.  

Annulation de l'extraction d'un fichier

Si vous extrayez un fichier, puis que vous décidez de ne pas le modifier (ou si vous décidez d'éliminer les modifications que vous avez apportées), vous pouvez annuler l'opération d'extraction. Le fichier reprend alors son état d'origine.

Pour annuler l'extraction d'un fichier, procédez de l'une des façons suivantes :

  • Ouvrez le fichier dans la fenêtre Document, puis choisissez Site > Annuler extraction.

  • Dans le panneau Fichiers (Fenêtre > Fichiers), cliquez avec le bouton droit (Windows) ou en maintenant la touche Ctrl enfoncée (Macintosh), puis sélectionnez Annuler extraction.

    La copie locale du fichier passe alors en lecture seule, et toutes les modifications que vous y avez apportées sont perdues.

Utilisation de WebDAV pour archiver et extraire des fichiers

Dreamweaver peut se connecter à un serveur utilisant WebDAV (Web-based Distributed Authoring and Versioning), un ensemble d'extensions du protocole HTTP permettant aux utilisateurs au sein d'un groupe de modifier et de gérer des fichiers sur des serveurs Web distants. Pour plus de détails, consultez www.webdav.org.

  1. Si vous ne l'avez pas encore fait, définissez un site Dreamweaver indiquant le dossier local que vous utilisez pour stocker vos fichiers de projet.
  2. Sélectionnez Site > Gérer les sites puis double-cliquez sur votre site dans la liste.
  3. Dans la boîte de dialogue Configuration du site, sélectionnez la catégorie Serveurs et effectuez l'une des actions suivantes :
    • Cliquez sur le bouton Ajouter nouveau serveur pour ajouter un nouveau serveur.

    • Sélectionnez un serveur existant puis cliquez sur le bouton Modifier serveur existant.

  4. Dans l'écran Base, sélectionnez WebDAV dans le menu Se connecter au moyen de, puis complétez si nécessaire les autres options de l'écran Base.
  5. Cliquez sur le bouton Avancé.
  6. Sélectionnez l'option Activer l'extraction de fichier et entrez les informations suivantes :
    • Dans la zone de texte Nom d'extraction, entrez un nom vous identifiant par rapport aux autres membres de l'équipe.

    • Indiquez votre adresse électronique dans la zone appropriée.

      Le nom et l'adresse électronique sont utilisés pour l'identification sur le serveur WebDAV et s'affiche dans le panneau Fichiers pour les contacts.

  7. Cliquez sur Enregistrer.

    Dreamweaver configure le site pour l'accès WebDAV. Lorsque vous utilisez la commande d'archivage ou d'extraction sur un fichier du site, le fichier est transféré au moyen de WebDAV.

    Remarque :

    Il se peut que WebDAV ne parvienne pas à extraire correctement des fichiers incluant un contenu dynamique, parce que la méthode HTTP GET les rend au moment de leur extraction.

Utilisation de Subversion (svn) pour acquérir et archiver des fichiers

Remarque :

La prise en charge de Subversion (SVN) a été supprimée de Dreamweaver CC 2017 et des versions ultérieures.

Dreamweaver peut se connecter à un serveur utilisant Subversion (SVN), un système de contrôle de version qui permet aux utilisateurs de collaborer à la modification et la gestion de fichiers sur des serveurs Web distants. Dreamweaver n'est pas un client SVN intégral, mais il permet aux utilisateurs d'obtenir les versions les plus récentes de fichiers, d'apporter des modifications et d'envoyer les fichiers.

Remarque :

Dreamweaver CS5 utilise la bibliothèque du client Subversion 1.6.6 et Dreamweaver CS5.5 utilise la bibliothèque du client 1.6.9. Les versions plus récentes de la bibliothèque cliente Subversion ne sont pas rétrocompatibles. Notez que si vous mettez à jour une application cliente tierce (par exemple TortoiseSVN) en vue d'une utilisation avec une version ultérieure de Subversion, l'application Subversion mise à jour mettra à jour les métadonnées Subversion locales, et Dreamweaver ne pourra plus communiquer avec Subversion. Ce problème n'est pas influencé par les mises à jour du serveur Subversion, car celles-ci sont rétrocompatibles. Si vous procédez à une mise à jour vers une application cliente tierce qui fonctionne avec Subversion en version 1.7 ou ultérieure, vous devrez rechercher des mises à jour auprès d'Adobe avant de pouvoir réutiliser Subversion avec Dreamweaver. Pour plus d’informations sur ce problème, consultez le site www.adobe.com/go/dw_svn_en.

Adobe recommande d'utiliser un outil de comparaison de fichiers, développé par une tierce partie, lorsque vous utilisez des fichiers à contrôle de version SVN. Lorsque vous comparez des fichiers afin de détecter leurs différences, vous pouvez voir précisément quels types de modifications d'autres utilisateurs ont apportées. Pour plus d'informations sur les outils de comparaison de fichiers, utilisez un moteur de recherche Web tel que Google pour trouver des outils de « comparaison de fichiers » ou « diff ». Dreamweaver fonctionne avec la plupart des outils tiers.

Vous trouverez un didacticiel vidéo sur l'utilisation de SVN et Dreamweaver à l'adresse www.adobe.com/go/lrvid4049_dw.

Etablissement d'une connexion SVN

Avant d'utiliser Subversion (SVN) comme système de contrôle des versions avec Dreamweaver, vous devez établir une connexion à un serveur SVN. Pour définir une connexion à un serveur SVN, utilisez la catégorie Contrôle de version de la boîte de dialogue Définition du site.

Le serveur SVN est un référentiel de fichiers depuis lequel vous (et d'autres utilisateurs) pouvez obtenir et valider des fichiers. Il est différent du serveur distant qu'on utilise généralement dans Dreamweaver. En cas d'utilisation de SVN, le serveur distant reste le serveur « en direct » pour vos pages Web. Le serveur SVN sert pour sa part au stockage du référentiel des fichiers au sujet desquels vous voulez conserver un contrôle de version. Le processus habituel consiste à obtenir des fichiers depuis le serveur SVN et à les y valider, puis à les publier sur votre serveur distant à partir de Dreamweaver. La configuration du serveur distant est tout à fait distincte de celle de SVN.

Avant de pouvoir entamer cette configuration, vous devez disposer d'un accès à un serveur SVN et à un référentiel SVN. Pour plus d'informations sur SVN, consultez le site Web de Subversion à l'adresse suivante : http://subversion.apache.org/.

Pour configurer la connexion SVN, procédez comme suit :

  1. Choisissez Site > Gérer les sites, sélectionnez le site pour lequel vous voulez configurer le contrôle des versions, puis cliquez sur le bouton Modifier.

    Remarque :

    Si vous n'avez pas encore défini de dossiers locaux et distants pour un site Dreamweaver, vous devrez au moins configurer un site local avant de pouvoir continuer. Le site distant n'est pas nécessaire pour l'instant, mais vous devrez en définir un pour pouvoir publier vos fichiers sur le Web. Pour plus d'informations, reportez-vous à la section Utilisation de sites Dreamweaver.

  2. Dans la boîte de dialogue Configuration du site, sélectionnez la catégorie Contrôle de version.

  3. Sélectionnez Subversion dans la liste déroulante Accès.

  4. Définissez les options d'accès comme suit :

    • Sélectionnez un protocole dans la liste déroulante Protocole. Les protocoles disponibles sont HTTP, HTTPS, SVN et SVN+SSH.

    Remarque :

    L'emploi du protocole SVN+SSH exige une configuration spéciale. Pour plus d’informations, consultez la page www.adobe.com/go/learn_dw_svn_ssh_en.

    • Entrez l'adresse du serveur SVN dans la zone de texte Adresse du serveur (généralement sous la forme nomserveur.domaine.com).

    • Entrez le chemin d'accès à votre référentiel sur le serveur SVN dans la zone Référentiel (généralement sous la forme /svn/votre_répertoire_racine. C'est à l'administrateur du serveur de nommer le dossier racine pour le référentiel SVN).

    • (Facultatif) Si vous voulez utiliser un port de serveur différent du port par défaut, activez l'option Instance spécifique puis entrez un numéro de port dans la zone de texte.

    • Entrez votre nom d'utilisateur et votre mot de passe sur SVN.

  5. Cliquez sur Tester pour tester votre connexion, ou sur OK pour fermer la boîte de dialogue. Cliquez ensuite sur Terminé pour fermer la boîte de dialogue Gérer les sites.

Lorsque la connexion au serveur est établie, votre référentiel SVN peut être visualisé dans le panneau Fichiers. Pour le visualiser, vous pouvez choisir le mode Affichage du référentiel dans la liste déroulante Affichage, ou cliquez sur le bouton Fichiers du référentiel dans le panneau Fichiers développé.

Obtention des versions les plus récentes des fichiers

Lorsque vous obtenez la version la plus récente d'un fichier depuis le référentiel SVN, Dreamweaver fusionne le contenu de ce fichier à celui de la copie locale correspondante. En d'autres termes, si un autre utilisateur a mis à jour le fichier depuis la dernière fois où vous l'avez validé, ses mises à jour sont fusionnées avec la version locale du fichier sur votre ordinateur. Si le fichier n'existe pas sur le disque dur local, Dreamweaver se contente de l'obtenir.

Remarque :

Lorsque vous obtenez pour la première fois des fichiers depuis le référentiel, travaillez avec un répertoire local vide ou un répertoire local qui ne contient pas de fichiers portant les mêmes noms que dans le référentiel. Dreamweaver ne monte pas les fichiers du référentiel sur le lecteur local à la première tentative si le lecteur local contient des fichiers dont le nom est identique à celui de fichiers dans le référentiel distant.

  1. Assurez-vous d'avoir bien défini une connexion SVN.

  2. Effectuez l'une des opérations suivantes :

    • Affichez la version locale de vos fichiers SVN dans le panneau Fichiers en choisissant Affichage local dans la liste déroulante Affichage. Si vous travaillez dans le panneau Fichiers développé, l'affichage local est automatiquement disponible. Cliquez ensuite avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Macintosh) sur le fichier ou le dossier qui vous intéresse, puis cliquez sur Contrôle de version > Obtenir les versions les plus récentes.

    • Affichez les fichiers du référentiel SVN en choisissant Affichage du référentiel dans la liste déroulante Affichage du panneau Fichiers ou en cliquant sur le bouton Fichiers du référentiel dans le panneau Fichiers développé. Cliquez ensuite avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Macintosh) sur le fichier ou le dossier qui vous intéresse, puis cliquez sur Obtenir les versions les plus récentes.

Remarque :

Vous pouvez également cliquer sur un fichier à l'aide du bouton droit de la souris puis choisir Extraire dans le menu contextuel, ou sélectionner ce fichier et cliquer sur le bouton Extraire afin d'obtenir sa version la plus récente. Toutefois, comme SVN ne prend pas en charge les processus d'extraction, cette méthode ne permet pas d'extraire le fichier de la façon habituelle.

Validation de fichiers

  1. Assurez-vous d'avoir bien défini une connexion SVN.

  2. Effectuez l'une des opérations suivantes :

    • Affichez la version locale de vos fichiers SVN dans le panneau Fichiers en choisissant Affichage local dans la liste déroulante Affichage. Si vous travaillez dans le panneau Fichiers développé, l'affichage local est automatiquement disponible. Sélectionnez ensuite le fichier à valider puis cliquez sur Archiver.

    • Affichez les fichiers du référentiel SVN en choisissant Affichage du référentiel dans la liste déroulante Affichage du panneau Fichiers ou en cliquant sur le bouton Fichiers du référentiel dans le panneau Fichiers développé. Cliquez ensuite avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Macintosh) sur le fichier que vous voulez valider, puis cliquez sur Valider.

  3. Prenez connaissance des actions dans la boîte de dialogue Archivage, apportez les éventuelles modifications requises, puis cliquez sur OK.

    Vous pouvez modifier des actions en les sélectionnant puis en cliquant sur le bouton dans le bas de la boîte de dialogue Archivage. Deux options sont disponibles : Valider et Ignorer.

Remarque :

La présence d'une coche de couleur verte sur un fichier dans le panneau Fichiers indique qu'il a été modifié et pas encore validé dans le référentiel.

Mise à jour de l'état de fichiers ou de dossiers dans le référentiel

Vous pouvez mettre à jour l'état SVN d'un fichier ou d'un dossier. La mise à jour n'actualise pas l'affichage tout entier.

  1. Assurez-vous d'avoir bien défini une connexion SVN.

  2. Affichez les fichiers du référentiel SVN en choisissant Affichage du référentiel dans la liste déroulante Affichage du panneau Fichiers ou en cliquant sur le bouton Fichiers du référentiel dans le panneau Fichiers développé.

  3. Cliquez ensuite avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Macintosh) sur n'importe quel fichier ou dossier du référentiel, puis cliquez sur Mettre à jour l'état.

Mise à jour de l'état de fichiers ou de dossiers locaux

Vous pouvez mettre à jour l'état SVN d'un fichier ou d'un dossier. La mise à jour n'actualise pas l'affichage tout entier.

  1. Assurez-vous d'avoir bien défini une connexion SVN.

  2. Affichez la version locale de vos fichiers SVN dans le panneau Fichiers en choisissant Affichage local dans la liste déroulante Affichage. Si vous travaillez dans le panneau Fichiers développé, l'affichage local est automatiquement disponible.

  3. Cliquez ensuite avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Macintosh) sur n'importe quel fichier ou dossier du panneau Fichiers, puis cliquez sur Mettre à jour l'état.

Affichage des versions d'un fichier

  1. Assurez-vous d'avoir bien défini une connexion SVN.

  2. Effectuez l'une des opérations suivantes :

    • Affichez la version locale de vos fichiers SVN dans le panneau Fichiers en choisissant Affichage local dans la liste déroulante Affichage. Si vous travaillez dans le panneau Fichiers développé, l'affichage local est automatiquement disponible. Cliquez ensuite avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Macintosh) sur le fichier dont vous voulez afficher les versions, puis choisissez Contrôle de version > Afficher les versions.

    • Affichez les fichiers du référentiel SVN en choisissant Affichage du référentiel dans la liste déroulante Affichage du panneau Fichiers ou en cliquant sur le bouton Fichiers du référentiel dans le panneau Fichiers développé. Cliquez ensuite avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Macintosh) sur le fichier dont vous voulez afficher les versions, puis choisissez Afficher les versions.

  3. Dans la boîte de dialogue Historique des versions, choisissez la ou les versions qui vous intéressent, puis effectuez l'une des actions suivantes :

    • Cliquez sur Comparer au site local pour comparer la version sélectionnée à la version locale du fichier.

    Remarque :

    Vous devez installer un outil de comparaison de fichiers, provenant d'un éditeur tiers, avant de pouvoir comparer les fichiers. Pour plus d'informations sur les outils de comparaison de fichiers, utilisez un moteur de recherche Web tel que Google pour trouver des outils de « comparaison de fichiers » ou « diff ». Dreamweaver fonctionne avec la plupart des outils tiers.

    • Cliquez sur Comparer pour comparer deux versions sélectionnées. Cliquez tout en maintenant la touche CTRL enfoncée pour sélectionner deux versions simultanément.

    • Cliquez sur Afficher pour afficher la version sélectionnée. Cette action n'entraîne pas le remplacement de la copie locale actuelle du fichier concerné. Vous pouvez enregistrer la version sélectionnée sur votre disque dur comme vous le feriez avec n'importe quel autre fichier.

    • Cliquez sur Marquer comme actuel pour faire de la version sélectionnée la version la plus récente du référentiel.

Verrouillage et déverrouillage de fichiers

Le verrouillage d'un fichier dans le référentiel SVN permet d'indiquer aux autres utilisateurs que vous êtes en train de travailler dessus. Les autres utilisateurs peuvent toujours modifier le fichier localement, mais ils ne pourront valider le fichier que quand vous l'aurez déverrouillé. Lorsque vous verrouillez un fichier dans le référentiel, vous verrez que ce fichier s'accompagne d'une icône représentant un cadenas ouvert. Pour les autres utilisateurs, l'icône représente un cadenas fermé.

  1. Assurez-vous d'avoir bien défini une connexion SVN.

  2. Effectuez l'une des opérations suivantes :

    • Affichez les fichiers du référentiel SVN en choisissant Affichage du référentiel dans la liste déroulante Affichage du panneau Fichiers ou en cliquant sur le bouton Fichiers du référentiel dans le panneau Fichiers développé. Cliquez ensuite avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Macintosh) sur le fichier qui vous intéresse, puis choisissez Verrouiller ou Déverrouiller.

    • Affichez la version locale de vos fichiers SVN dans le panneau Fichiers en choisissant Affichage local dans la liste déroulante Affichage. Si vous travaillez dans le panneau Fichiers développé, l'affichage local est automatiquement disponible. Cliquez ensuite avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Macintosh) sur le fichier qui vous intéresse, puis choisissez Verrouiller ou Déverrouiller.

Ajout d'un nouveau fichier au référentiel

La présence d'un symbole « plus » bleu sur un fichier dans le panneau Fichiers indique que ce fichier n'existe pas encore dans le référentiel SVN.

  1. Assurez-vous d'avoir bien défini une connexion SVN.

  2. Dans le panneau Fichiers, sélectionnez le fichier à ajouter au référentiel, puis cliquez sur le bouton Archiver.

  3. Assurez-vous que le fichier est sélectionné pour une validation dans la boîte de dialogue Validation, puis cliquez sur OK.

Déplacement, copie, suppression ou rétablissement de fichiers

  • Pour déplacer un fichier, faites-le glisser vers le dossier de destination de votre site local.

    Lorsque vous déplacez un fichier, Dreamweaver le marque, à son nouvel emplacement, au moyen d'un signe Ajouter avec historique, et le marque à l'aide d'un signe Supprimer à son ancien emplacement. Lorsque vous envoyez ces fichiers, celui qui se trouve à l'ancien emplacement disparaît.

  • Pour copier un fichier, sélectionnez-le, copiez-le (Edition > Copier) puis collez-le (Edition > Coller) à son nouvel emplacement.

    Lorsque vous copiez et collez un fichier, Dreamweaver le marque, à son nouvel emplacement, au moyen d'un signe Ajouter avec historique.

  • Pour supprimer un fichier, sélectionner-le puis appuyez sur supprimer.

    Dreamweaver vous permet de supprimer uniquement la version locale du fichier, ou à la fois la version locale et celle sur le serveur SVN. Si vous décidez de ne supprimer que la version locale, le fichier sur le serveur SVN n'est pas touché. Si vous décidez de supprimer également la version sur le serveur SVN, la version locale est marquée à l'aide d'un signe Supprimer, et vous devez envoyer le fichier pour que la suppression soit effectuée.

  • Pour rétablir un fichier copié ou déplacé à son emplacement d'origine, cliquez sur le fichier à l'aide du bouton droit puis choisissez Contrôle de version > Rétablir.

Résolution des conflits entre fichiers

Si votre fichier est en conflit avec un autre fichier sur le serveur, vous pouvez le modifier puis le marquer comme étant résolu. Par exemple, si vous tentez d'archiver un fichier qui est en conflit avec les modifications apportées par un autre utilisateur, SVN ne vous permettra pas de valider ce fichier. Vous pouvez obtenir la version la plus récente du fichier depuis le référentiel, apporter manuellement des modifications à votre copie de travail, puis marquer votre fichier comme étant résolu de façon à pouvoir le valider.

  1. Assurez-vous d'avoir bien défini une connexion SVN.

  2. Affichez la version locale de vos fichiers SVN dans le panneau Fichiers en choisissant Affichage local dans la liste déroulante Affichage. Si vous travaillez dans le panneau Fichiers développé, l'affichage local est automatiquement disponible.

  3. Cliquez avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Macintosh) sur le fichier dont vous voulez résoudre le conflit, puis choisissez Contrôle de version > Marquer comme résolu.

Travail hors ligne

Il peut s'avérer utile de travailler hors ligne, de manière à éviter tout accès au référentiel pendant d'autres activités de transfert de fichiers. Dreamweaver se connecte au référentiel SVN dès que vous lancez une activité qui exige une connexion (Obtenir les versions les plus récentes, Valider, etc.).

  1. Assurez-vous d'avoir bien défini une connexion SVN.

  2. Affichez la version locale de vos fichiers SVN dans le panneau Fichiers en choisissant Affichage local dans la liste déroulante Affichage. Si vous travaillez dans le panneau Fichiers développé, l'affichage local est automatiquement disponible.

  3. Cliquez avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Macintosh) sur n'importe quel fichier ou dossier du panneau Fichiers, puis choisissez Contrôle de version > Travailler hors ligne.

Nettoyage d'un site SVN local

Cette commande permet de supprimer les verrous des fichiers, de manière à reprendre des activités non terminées. Utilisez cette commande pour supprimer d'anciens verrous si vous recevez des messages d'erreur vous informant que la copie de travail est verrouillée.

  1. Assurez-vous d'avoir bien défini une connexion SVN.

  2. Affichez la version locale de vos fichiers SVN dans le panneau Fichiers en choisissant Affichage local dans la liste déroulante Affichage. Si vous travaillez dans le panneau Fichiers développé, l'affichage local est automatiquement disponible.

  3. Cliquez avec le bouton droit de la souris (Windows) ou en maintenant la touche Contrôle enfoncée (Macintosh) sur le fichier à nettoyer, puis choisissez Contrôle de version > Nettoyer.

À propos du déplacement de fichiers et de dossiers dans des sites contrôlés par Subversion

Lorsque vous déplacez les versions locales de fichiers ou de dossiers dans un site contrôlé par Subversion, vous risquez de créer des problèmes à d'autres utilisateurs qui pourraient se synchroniser avec le référentiel SVN. Par exemple, si vous déplacez un fichier localement et ne le validez pas dans le référentiel pendant quelques heures, il se peut qu'un autre utilisateur tente d'en obtenir la version la plus récente depuis son ancien emplacement. Veillez donc à toujours valider les fichiers sur le serveur SVN juste après les avoir déplacés localement.

Les fichiers et les dossiers demeurent sur le serveur jusqu'à ce que vous les supprimiez manuellement. Ainsi, même si vous déplacez un fichier dans un dossier local différent et que vous le validez, son ancienne version reste à l'emplacement précédent sur le serveur. Pour éviter toute confusion, supprimez les anciennes copies des fichiers et dossiers que vous avez déplacés.

Lorsque vous déplacez un fichier localement et que vous le validez de nouveau sur le serveur SVN, l'historique des versions du fichier est perdu.

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne