Image Trace

  1. Illustrator User Guide
  2. Get to know Illustrator
    1. Introduction to Illustrator
      1. What's new in Illustrator
      2. Common questions
      3. Illustrator system requirements
      4. Illustrator for Apple silicon
    2. Workspace
      1. Workspace basics
      2. Create documents
      3. Tools Default keyboard shortcuts | Illustrator
      4. Tool galleries
      5. Customize keyboard shortcuts
      6. Artboards
      7. Customize the workspace
      8. Properties panel
      9. Set preferences
      10. Touch Workspace
      11. Microsoft Surface Dial support in Illustrator
      12. Recovery, undo, and automation
      13. Rotate view
      14. Rulers, grids, and guides
      15. Accessibility in Illustrator
      16. Safe Mode
      17. View artwork
      18. Use the Touch Bar with Illustrator
      19. Files and templates
      20. Synchronize settings using Adobe Creative Cloud
    3. Tools in Illustrator
      1. Selection
        1. Overview
        2. Selection
        3. Direct Selection
        4. Group Selection
        5. Lasso
        6. Magic Wand
      2. Navigation
        1. Overview
        2. Zoom
        3. Rotate View
      3. Paint
        1. Overview
        2. Gradient
        3. Shape Builder
      4. Type
        1. Overview
        2. Type
        3. Type on path
  3. Illustrator on the iPad
    1. Introduction to Illustrator on the iPad
      1. Illustrator on the iPad overview
      2. Illustrator on the iPad FAQs
      3. System requirements | Illustrator on the iPad
      4. What you can or cannot do on Illustrator on the iPad
    2. Workspace
      1. Illustrator on the iPad workspace
      2. Touch shortcuts and gestures
      3. Keyboard shortcuts for Illustrator on the iPad
      4. Manage your app settings
    3. Documents
      1. Work with documents in Illustrator on the iPad
      2. Import Photoshop and Fresco documents
    4. Select and arrange objects
      1. Create repeat objects
      2. Blend objects
    5. Drawing
      1. Draw and edit paths
      2. Draw and edit shapes
    6. Type
      1. Work with type and fonts
      2. Create text designs along a path
      3. Add your own fonts
    7. Work with images
      1. Vectorize raster images
    8. Color
      1. Apply colors and gradients
  4. Cloud documents
    1. Basics
      1. Work with Illustrator cloud documents
      2. Share and collaborate on Illustrator cloud documents
      3. Upgrade cloud storage for Adobe Illustrator
      4. Illustrator cloud documents | Common questions
    2. Troubleshooting
      1. Troubleshoot create or save issues for Illustrator cloud documents
      2. Troubleshoot Illustrator cloud documents issues
  5. Add and edit content
    1. Drawing
      1. Drawing basics
      2. Edit paths
      3. Draw pixel-perfect art
      4. Draw with the Pen, Curvature, or Pencil tool
      5. Draw simple lines and shapes
      6. Image Trace
      7. Simplify a path
      8. Define perspective grids
      9. Symbolism tools and symbol sets
      10. Adjust path segments
      11. Design a flower in 5 easy steps
      12. Perspective drawing
      13. Symbols
      14. Draw pixel-aligned paths for web workflows
    2. 3D effects and Adobe Substance materials
      1. About 3D effects in Illustrator
      2. Create 3D graphics
      3. Create 3D objects
      4. Create 3D Text
    3. Color
      1. About color
      2. Select colors
      3. Use and create swatches
      4. Adjust colors
      5. Use the Adobe Color Themes panel
      6. Color groups (harmonies)
      7. Color Themes panel
      8. Recolor your artwork
    4. Painting
      1. About painting
      2. Paint with fills and strokes
      3. Live Paint groups
      4. Gradients
      5. Brushes
      6. Transparency and blending modes
      7. Apply stroke on an object
      8. Create and edit patterns
      9. Meshes
      10. Patterns
    5. Select and arrange objects
      1. Select objects
      2. Layers
      3. Group and expand objects
      4. Move, align, and distribute objects
      5. Stack objects    
      6. Lock, hide, and delete objects
      7. Duplicate objects
      8. Rotate and reflect objects
    6. Reshape objects
      1. Crop images
      2. Transform objects
      3. Combine objects
      4. Cut, divide, and trim objects
      5. Puppet Warp
      6. Scale, shear, and distort objects
      7. Blend objects
      8. Reshape using envelopes
      9. Reshape objects with effects
      10. Build new shapes with Shaper and Shape Builder tools
      11. Work with Live Corners
      12. Enhanced reshape workflows with touch support
      13. Edit clipping masks
      14. Live shapes
      15. Create shapes using the Shape Builder tool
      16. Global editing
    7. Type
      1. Create text
      2. Fonts and typography
      3. Format type
      4. Import and export text
      5. Format paragraphs
      6. Special characters
      7. Create type on a path
      8. Character and paragraph styles
      9. Tabs
      10. Text and type
      11. Find missing fonts (Typekit workflow)
      12. Update text from Illustrator 10
      13. Arabic and Hebrew type
      14. Fonts | FAQ and troubleshooting tips
      15. Create 3D text effect
      16. Creative typography designs
      17. Scale and rotate type
      18. Line and character spacing
      19. Hyphenation and line breaks
      20. Text enhancements
      21. Spelling and language dictionaries
      22. Format Asian characters
      23. Composers for Asian scripts
      24. Create text designs with blend objects
      25. Create a text poster using Image Trace
    8. Create special effects
      1. Work with effects
      2. Graphic styles
      3. Create a drop shadow
      4. Appearance attributes
      5. Create sketches and mosaics
      6. Drop shadows, glows, and feathering
      7. Summary of effects
    9. Web graphics
      1. Best practices for creating web graphics
      2. Graphs
      3. SVG
      4. Create animations
      5. Slices and image maps
  6. Import, export, and save
    1. Import
      1. Import artwork files
      2. Import bitmap images
      3. Import artwork from Photoshop
      4. Place multiple files | Illustrator CC
      5. Unembed images
      6. Import Adobe PDF files
      7. Import EPS, DCS, and AutoCAD files
      8. Links information
    2. Creative Cloud Libraries in Illustrator 
      1. Creative Cloud Libraries in Illustrator
    3. Save
      1. Save artwork
    4. Export
      1. Use Illustrator artwork in Photoshop
      2. Export artwork
      3. Collect assets and export in batches
      4. Package files
      5. Create Adobe PDF files
      6. Extract CSS | Illustrator CC
      7. Adobe PDF options
      8. File information and metadata
  7. Printing
    1. Prepare for printing
      1. Set up documents for printing
      2. Change the page size and orientation
      3. Specify crop marks for trimming or aligning
      4. Get started with large canvas
    2. Printing
      1. Overprint
      2. Print with color management
      3. PostScript printing
      4. Print presets
      5. Printer's marks and bleeds
      6. Print and save transparent artwork
      7. Trapping
      8. Print color separations
      9. Print gradients, meshes, and color blends
      10. White Overprint
  8. Automate tasks
    1. Data merge using the Variables panel
    2. Automation with scripts
    3. Automation with actions
  9. Troubleshooting 
    1. Crash on launch issues
    2. Recover files after crash
    3. File issues
    4. GPU device driver issues
    5. Wacom device issues
    6. DLL file issues
    7. Memory issues
    8. Preferences file issues
    9. Font issues
    10. Printer issues
    11. Share crash report with Adobe

Image Trace lets you convert raster images (JPEG, PNG, PSD etc.) to vector artwork. Using this feature, you can easily base a new drawing on an existing piece of artwork by tracing it. For example, you can convert the image of a pencil sketch you've drawn on paper into vector artwork using Image Trace. You can choose from a set of tracing presets to get the desired result quickly.

Before and after tracing a raster image using tracing presets

A. Original image B. Tracing results using different presets 

Trace an image

  1. Open or place a raster image in your Illustrator document.

  2. With the placed image selected, do one of the following:

    • Choose Object > Image Trace > Make to trace with default parameters. Illustrator converts the image to black and white tracing result by default.
    • Click the Image Trace button in the Control panel or the Properties panel, or select a preset from the Tracing Presets button ().
    • Choose Window > Image Trace or switch to the Tracing workspace to open the Image Trace panel, and do one of the following:
    Бележка:
    • In the Image Trace panel, enable Preview to see the results of your modifications. 
    • The resolution of your placed image determines the speed of the tracing.
  3. (Optional) Adjust the results of the tracing in the Image Trace panel (Window > Image Trace).

  4. To convert the tracing object to paths and to manually editing the vector artwork, choose Object > Image Trace > Expand.

For a video on tracing, see this how-to video on Image Trace.

Specify tracing options

When the image is selected, you can see that the options in the Image Trace panel become available. At the top of the panel are the basic options; you can expose additional options by turning the triangle next to the Advanced label.

Basic controls

Specify the basic options in the Image Trace panel to get the desired tracing result.

Preset

Specifies a tracing preset. The icons located across the top of the panel are shortcuts named according to popular workflows. Choosing one of these presets sets all the variables needed to produce that related tracing result.

Examples of tracing presets available in Image Trace panel

Icon

Name of the preset

Definition

Auto-Color

Creates a posterized image from photo or artwork

High Color

Creates photorealistic artwork of high fidelity

Low Color

Creates simplified photorealistic artwork

Grayscale

Traces the artwork to shades of gray

Black And White

Simplifies the image to black-and-white artwork

Outline

Simplifies the image to black outlines

Additional presets are accessible in the top drop-down menu.

Examples of tracing presets available in the Preset drop-down menu.

A. 3 Colors B. 6 Colors C. High Fidelity Photo 

Click the menu icon () to save the current settings as a new preset, or to delete or rename existing presets. For details, see Save a tracing preset.

View

Specifies the view of the traced object. A tracing object is made up of two components: the original source image and the tracing result (which is the vector artwork). You can choose to view the tracing result, source image, outlines, and other options. You can click the eye icon to overlay the selected view over the source image.

Choose a view of the traced object
Choose a view of the traced object

A. Tracing Result B. Tracing Result With Outlines C. Outlines D. Outlines With Source Image E. Source Image 

Mode

Specifies a color mode for the tracing result. The available options define basic color versus grayscale modes for your traced artwork.

The following color settings appear based on the settings in the Mode option:

Specifies the number of colors to use in a color tracing result. If you have selected Document Library as the palette, you can choose a swatch. (This option is available only when Mode is set to Color.)

Adjust the number of colors in the tracing result when Mode is set to Color.

Specifies the number of grays to use in a grayscale tracing result. (This option is available only when Mode is set to Grayscale.)

Adjust the number of grays in the tracing result when Mode is set to Grayscale.

Specifies a value for generating a black and white tracing result from the original image. All pixels lighter than the Threshold value are converted to white; all pixels darker than the Threshold value are converted to black. (This option is available only when Mode is set to Black And White.)

Adjust the threshold value to convert the pixels to black or white in the tracing result when Mode is set to Black And White.

Palette

Specifies a palette for generating a color or grayscale tracing from the original image. (This option is available only when Mode is set to Color or Grayscale.)

You can choose one of the following options:

Automatically switches between the limited palette and full tone for the tracing, depending on the input image. When you select Automatic for your palette, you can adjust the Colors slider to alter vector simplicity and accuracy in the tracing. The value 0 means simplified at the expense of accuracy and the value 100 means accurate or photorealistic at the expense of simplicity.

Example: Tracing result when you choose Automatic

Uses a small set of colors for the tracing palette. You can use the Color slider to further reduce the colors selected.

Example: Tracing result when you choose Limited

Uses the entire set of colors for the tracing palette. This option is the best for tracing photos and creates photorealistic artwork. With this option selected, the Color slider determines the variability of the pixels that make up each of the fill regions. When the Color slider is to the right, the variability is smaller, resulting in more paths defined by smaller areas of color. On the other hand, when the slider is to the left, the fill areas are fewer and larger.

Example: Tracing result when you choose Full Tone

Uses an existing color group for the tracing palette. This option allows you to define the exact colors you want in your traced artwork. You can choose any color library you’ve loaded via the Swatches panel for your tracing palette.

Example: Tracing result when you choose Document Library

Add color libraries to the Swatches panel from the Swatch Libraries menu

  1. To open the Swatches panel, choose Window > Swatches.
  2. Click the Swatch Libraries Menu icon () on the lower-left of the Swatches panel. Alternatively, choose Open Swatch Library from the panel menu.
  3. Choose a library from the list.
  4. To add the desired color group to the Swatches panel, click the Save Color Group To Swatches Panel button (). For details, see Use swatch libraries.
Add color libraries to the Swatches panel from the Swatch Libraries menu.

Choose any color library you’ve loaded via the Swatches panel for your tracing palette.

Add color libraries to the Swatches panel using the Adobe Color Themes panel

  1. To open the Adobe Color Themes panel, choose Window > Color Themes.
  2. Explore the many public color themes available in the Explore tab or create your own color themes. Then, add the selected color theme to the Swatches panel. For details, see Use the Adobe Color Themes panel.
Add color libraries to the Swatches panel from the Adobe Color Themes panel.

Choose any color library you’ve loaded via the Adobe Color Themes panel for your tracing palette.

Advanced controls

Fine-tune your tracing result using advanced options in the Image Trace options.

Paths

Controls the distance between the traced shape and the original pixel shape. Lower values create a looser path fitting; higher values create a tighter path fitting.

Corners

Specifies the emphasis on corners and the likeliness that a sharp bend will turn into a corner point. A higher value results in more corners.

Noise

Specifies an area in pixels that is ignored while tracing. A higher value results in less noise.

Tip: For a high-resolution image, move the Noise slider to a higher value (for example in the 20–50 range) to have some effect. For a low-resolution image, set it lower (1–10).

Method

Specifies a method for tracing. You can choose one of the following options:

Icon

Name of the preset

Definition

Abutting

Creates cutout paths. The edge of one path is exactly the same as the edge of its neighboring path.

Overlapping

Creates stacked paths. Each path slightly overlaps its neighbor.

Fills

Creates filled regions in the tracing result.

Strokes

Creates stroked paths in the tracing result.

Stroke

Specifies the maximum width of features in the original image that can be stroked. Features larger than the maximum width become outlined areas in the tracing result.

Snap Curves To Lines

Specifies if slightly curved lines are replaced with straight lines and if lines near to 0 or 90 degrees are snapped to absolute 0 or 90 degrees.

Tip: You can choose this option for geometric artwork or if shapes in your source image are slightly rotated.

Ignore White

Specifies if white fills areas are replaced with no fills.

For a video on tracing, see this how-to video on Image Trace.

Save a tracing preset

  1. Open the Image Trace panel by choosing Window > Image Trace.

  2. Set tracing options for the preset using the Image Trace panel.

    Бележка:

    You can’t edit or delete the default presets (default presets appear in brackets []). However, you can make an editable copy of a default preset by selecting the preset and choosing Save As New Preset from the panel menu.

  3. Click the menu icon () and choose Save As New Preset.

  4. Enter a name for the  preset , and click OK.

  5. (Optional) To rename your saved preset, click the menu icon () and choose Rename. Enter a name for the  preset , and click OK.

  6. (Optional) To delete your saved preset, click the menu icon () and choose Delete.

Edit the tracing result

When you are satisfied with the results of a tracing, you can convert the tracing object to paths. This final step allows you to work with the tracing result as you do other vector artwork. Once you convert the tracing object, you can no longer adjust the tracing options.

  1. Select the tracing result.

  2. To convert the tracing result to paths, do one of the following:

    • Click Expand in the Control panel or the Properties panel.
    • Choose Object > Image Trace > Expand

    The resulting paths are grouped together.

  3. To ungroup the grouped paths, click Ungroup in the Properties panel. Alternatively, choose Object > Ungroup.

  4. (Optional) To simplify paths by removing excess anchor points, choose Object > Path > Simplify. For details, see Simplify a path

    You can also reshape or edit paths. For details, see Adjust path segments.

  5. To color your tracing result, convert it to Live Paint Groups by selecting the desired paths and choosing Object > Live Paint > Make. For details, see Live Paint groups.

     

Release a tracing object

To discard a tracing but keep the original placed image, release the tracing object.

  1. Select the tracing object.

  2. Choose Object > Image Trace > Release.

Лого на Adobe

Влезте във вашия акаунт