如何在 Animate 中使用帧和关键帧

上次更新日期: 2026年6月9日
注意:

Animate 对所有客户进入维护模式。 这适用于个体、小型企业和企业客户。 维护模式意味着我们将继续支持该应用程序并提供持续的安全和错误修复,但我们没有添加新功能的计划。 新用户和现有用户均可继续使用Animate。 我们没有计划停止 Animate。 无论处于何种开发状态,我们承诺确保 Animate 用户拥有对其内容的访问权限。  

概述

Adobe Animate 文档将时长划分为类似于胶片的帧。 帧是动画的核心,指定每一段的时间和运动。 影片中帧的总数和播放速度共同决定了影片的总长度。 以下提供了帧中一些概念的简短描述,供您参考。

帧

在时间轴中,可使用这些帧来组织和控制文档的内容。 您在时间轴中放置帧的顺序将决定帧内对象在最终内容中的显示顺序。

关键帧

关键帧是指新元件实例显示在时间轴上的帧。 关键帧也可以指,包含用于控制文档某些方面的 Actionscript 代码的帧。 您还可以将空白关键帧添加到时间轴中作为计划稍后添加的元件的占位符,或者直接将该帧保留为空。

使用关键帧,您可以设置位置,添加锚点、动作、评论等。 

范围

使用基于范围的帧选择,您只需单击一次即可选择两个关键帧之间的一组帧。

静态帧范围

在静态帧范围内,相同的内容可用于整个范围持续时间。 在您需要显示固定时间量的图形时,即可使用这种类型的范围。 

补间帧范围

在补间帧范围内,请在每个帧范围内进行内容更改。 您可以使用此类型的动画范围。 

在时间轴中添加或插入帧

  • 若要插入新帧,请选择插入 > 时间轴 > 帧 (F5)。

  • 若要创建关键帧,请选择插入 > 时间轴 > 关键帧 (F6),或者右键单击 (Windows) 或按住 Ctrl 单击 (Macintosh) 要在其中放置关键帧的帧,然后从上下文菜单中选择插入关键帧。

  • 若要创建空白关键帧,请选择“插入”>“时间轴”>“空白关键帧”,或者右键单击 (Windows) 或按住 Ctrl 再单击 (Macintosh) 要在其中放置关键帧的帧,然后从上下文菜单中选择“插入空白关键帧”。

帧上的效果

滤镜和色彩效果过去仅适用于影片剪辑和图形元件。 利用高级图层,滤镜和色彩效果现在可应用于一个选定帧,从而应用至该帧内得所有内容,包括形状、绘制对象、图形元件等。 此外,也可使用传统、形状和跨帧 IK 补间对图层效果进行补间。

有关更多信息,请参阅应用图层效果。 

在时间轴中选择和标记帧

您可以使用 Animate 提供的两种方法选择帧。 您还可以标记帧以组织其内容。 

Animate 提供两种用于在时间轴中选择帧的不同方法。 在基于帧的选择(默认情况)中,可以在时间轴中选择单个帧。 在基于整体范围的选择中,在单击一个关键帧到下一个关键帧之间的任何帧时,整个帧序列都将被选中。 

在时间轴中选择帧

选择单个或多个帧

  • 若要选择一个帧,请单击该帧。 
  • 若要选择多个连续的帧,请在帧上拖动鼠标,或按住 Shift 并单击其他帧。

  • 若要选择多个不连续的帧,请在按住 Ctrl (Windows) 或 Command (Macintosh) 的同时单击其他帧。

  • 若要选择时间轴中的所有帧,请选择编辑 > 时间轴 > 选择所有帧。

基于范围的帧选择

作为基于范围的选择的前提条件,您可以通过单击右上角的汉堡图标,然后选择基于范围的选择菜单项,来在 Animate 时间轴中指定基于范围的选择。 

  • 要选择整个帧范围(补间动画或反向运动),请单击帧。 
  • 若要选择多个范围,请在按住 Shift 键的同时单击每个范围。

为时间轴中的帧添加标签

您可以为时间轴中的帧添加标签作为帮助组织其内容的一种方式。 还可以为一个帧添加标签以便在 ActionScript 中按其标签引用该帧。 这样,如果重新排列时间轴并将该标签移至其他帧编号,ActionScript 仍可引用该帧标签而无需更新。

帧标签只能应用于关键帧。 最佳做法是在时间轴中创建一个单独的图层来包含帧标签。 使用标签的单独图层可以更好地组织内容和关键帧。 

若要添加帧标签,请按以下步骤操作:

选择要在时间轴中为其添加标签的帧。

选中该帧之后,在“属性”检查器的“标签”部分输入标签名称。 按 Enter 或 Return。

作为一种最佳做法,应在帧中创建所有标签的单独图层。 

启用基于整体范围的帧选择

使用基于范围的帧选择,您只需单击一次即可选择两个关键帧之间的一组帧。

单击时间轴部分右上角的汉堡图标。 

将显示一个弹出菜单。 

从弹出菜单中选择“基于范围的选择”。 

分发到关键帧

使用“分发到关键帧”选项可以将舞台上的多个对象(元件和位图)分发到每个单独的关键帧。

选择舞台上任一图层的多个对象。

右键单击舞台上的任何位置,然后选择“分布到关键帧”。

复制、粘贴、删除或移动帧或帧序列

关键帧和其之后的常规帧范围称为关键帧序列。 时间轴可以包含任意数量的关键帧序列。

要复制或粘贴帧或帧序列,请执行以下操作之一:

复制或粘贴帧或帧序列

  • 选择帧或序列并选择“编辑”>“时间轴”>“复制帧”。 选择要替换的帧或序列,然后选择“编辑”>“时间轴”>“粘贴帧”。

  • 按住 Alt (Windows) 或按住 Option (Macintosh) 将一个关键帧拖动到要复制到的位置。

删除帧或帧序列

删除帧、帧序列或关键帧

选择帧或序列并选择“编辑”>“时间轴”>“删除帧”,或者右键单击 (Windows) 或按住 Ctrl 再单击 (Macintosh) 帧或序列,从上下文菜单中选择“删除帧”。

周围的帧保持不变。

删除关键帧

选择关键帧并选择“编辑”>“时间轴”>“清除关键帧”,或者右键单击 (Windows) 或按住 Ctrl 再单击 (Macintosh) 关键帧并从上下文菜单中选择“清除关键帧”。

移动关键帧或帧序列

选择一个关键帧或帧序列,然后将该关键帧或帧序列拖到所需的位置。

更改静态帧序列的长度

在按住 Ctrl (Windows) 或 Command (Macintosh) 的同时向左或向右拖动范围的开始或结束帧。

若要更改逐帧动画序列的长度,请参阅创建逐帧动画。

在时间轴中预览帧内容

从时间轴面板右上角的时间轴面板选项菜单中选择“预览”。

在时间轴的每个关键帧中,您可以查看关键帧中各项的缩略图预览。