处理导入的位图

将位图导入 Animate 后,可以修改该位图,并可用各种方式在 Animate 文档中使用它。

如果 Animate 文档中显示的导入位图比原始位图大,说明图像可能发生扭曲。若要确保正确显示图像,请预览导入的位图。

在舞台上选择位图后,“属性”检查器会显示该位图的元件名称、像素尺寸以及在舞台上的位置。 使用属性检查器,可以交换位图实例 -- 即,用当前文档中的其他位图的实例替换该实例。

 

显示具有位图属性的属性检查器

  1. 在舞台上选择一个位图实例。

  2. 选择“窗口”>“属性”。

用一个位图的实例替换另一个位图的实例

  1. 在舞台上选择一个位图实例。

  2. 选择“窗口”>“属性”,然后单击“交换”。

  3. 选择一个位图以替换当前分配给该实例的位图。

设置位图属性

可以对导入的位图应用消除锯齿功能,以平滑图像的边缘。也可以选择压缩选项以减小位图文件的大小,以及格式化文件以便在 Web 上显示。

  1. 在“库”面板中选择一个位图,然后单击“库”面板底部的“属性”按钮。
  2. 选择“允许平滑”。平滑可用于在缩放位图图像时提高图像的品质。
  3. 为“压缩”选择以下其中一个选项:

    照片 (JPEG)

    以 JPEG 格式压缩图像。 若要使用为导入图像指定的默认压缩品质,请选择“使用文档默认品质”。 若要指定新的品质压缩设置,请取消选择“使用文档默认品质”,并在“品质”文本字段中输入一个介于 1 和 100 之间的值。 (设置的值越高,保留的图像就越完整,但产生的文件也会越大。)

    无损 (PNG/GIF)

    将使用无损压缩格式压缩图像,这样不会丢失图像中的任何数据。

    注意:对于具有复杂颜色或色调变化的图像(例如具有渐变填充的照片或图像),请使用照片压缩。对于具有简单形状和相对较少颜色的图像,请使用无损压缩。

  4. 若要确定文件压缩的结果,请单击“测试”。 若要确定选择的压缩设置是否可以接受,请将原始文件大小与压缩后的文件大小进行比较。
  5. 单击“确定”。

注意:

在“发布设置”对话框中选择“JPEG 品质”设置不会为导入的 JPEG 文件指定品质设置。 请在“位图属性”对话框中为每个导入的 JPEG 文件指定品质设置。

(仅限 Animate)交换多个位图

使用“交换位图”选项,您可以使用选定的元件或位图来替换元件或位图。

  1. 在 Animate 中,选择舞台上的多个位图。

  2. 在“属性”面板中,单击“交换”。
  3. 在“交换位图”对话框中,选择您要用来替换所有选定元件/位图的位图。
  4. 单击“确定”。

在运行时导入位图

若要在运行时向文档添加位图,请使用 ActionScript® 2.0 或 ActionScript 3.0 BitmapData 命令。为此,请为该位图指定链接标识符。有关详细信息,请参阅学习使用 ActionScript 2.0 中的“为库中的资源分配链接”或 ActionScript 3.0 开发人员指南中的为 ActionScript 导出库元件

  1. 在“库”面板中选择该位图。
  2. 请执行下列操作之一:
    • 从面板右上角的“面板”菜单中选择“链接”。

    • 右键单击 (Windows) 或按住 Ctrl 单击 (Macintosh)“库”面板中的位图名称,然后从上下文菜单中选择“属性”。

      如果在“属性”对话框上看不到“链接”属性,请单击“高级”。

  3. 为“链接”选择“为 ActionScript 导出”。
  4. 在文本字段中输入一个标识字符串,然后单击“确定”。

将位图应用为填充

若要将位图作为填充应用到图形对象,请使用“颜色”面板。 将位图应用为填充时,会平铺该位图,以填充对象。 “渐变变形”工具使您可以缩放、旋转或倾斜图像及其位图填充。

  1. 若要将填充应用到现有的插图,请在舞台上选择一个或多个图形对象。
  2. 选择“窗口”>“颜色”。
  3. 从面板右上角的弹出菜单中选择“位图”。
  4. 若要使用较大的预览窗口显示当前文档中的更多位图,请单击右下角的箭头展开“颜色”面板。
  5. 单击一个位图,选择它。

    该位图成为当前的填充颜色。 如果在步骤 1 中已经选择了插图,则该位图会作为填充应用到该插图。

在外部编辑器中编辑位图

如果您要编辑导入为拼合图像的 Fireworks PNG 文件,请编辑位图的 PNG 源文件(如果有)。

注意:

不能在外部图像编辑器中编辑导入为可编辑对象的 Fireworks PNG 文件中的位图。

如果系统上安装了 Fireworks 3(或更高版本)或其他图像编辑应用程序,则可以从 Animate 启动该应用程序来编辑导入的位图。

使用 Photoshop CS5 或更高版本编辑位图

注意:

如果您使用的是 CS5.5,则需要使用 Photoshop CS5.1 访问此功能。

  1. 在“库”面板中,右键单击 (Windows) 或按住 Control 键单击 (Macintosh) 位图的图标,然后选择“使用 Photoshop CS5 编辑”。

  2. 在 Photoshop 中对文件执行所需的修改。

  3. 在 Photoshop 中,选择“文件”>“保存”。(不要更改文件名或格式。)

  4. 返回 Animate。

    该文件在 Animate 中会自动更新。

使用 Fireworks 3 或更高版本编辑位图

  1. 在“库”面板中,右键单击 (Windows) 或按住 Control 单击 (Macintosh) 位图的图标,然后选择“使用 Fireworks 3 进行编辑”。

  2. 指定打开 PNG 源文件还是位图文件。

  3. 在 Fireworks 中对文件执行所需的修改。

  4. 在 Fireworks 中,选择“文件”>“更新”。

  5. 返回 Animate。

    该文件在 Animate 中会自动更新。

使用其他图像编辑应用程序编辑位图

  1. 在“库”面板中,右键单击 (Windows) 或按住 Ctrl 单击 (Macintosh) 位图的图标,然后选择“编辑方式”。

  2. 选择用于打开该位图文件的图像编辑应用程序,然后单击“确定”。

  3. 在图像编辑应用程序中对该文件执行所需的修改。

  4. 在图像编辑应用程序中保存该文件。

    该文件在 Animate 中会自动更新。

  5. 返回 Animate 继续编辑该文档。

分离位图和创建位图填充

分离舞台上的位图时会将舞台上的图像与其库项目分离,并将其从位图实例转换为形状。分离位图时,可以使用 Animate 绘画和涂色工具修改位图。使用魔术棒工具时,可以选择包含相同或类似颜色的位图区域。

若要使用分离的位图进行涂色,请用滴管工具选择该位图,然后用颜料桶工具或其他绘画工具将该位图应用为填充。

分离位图

  1. 选择当前场景中的位图。

  2. 选择“修改”>“分离”。

更改分离位图的填充区域

  1. 在“工具”面板中,选择“魔术棒”工具。如果魔术棒工具不可见,可单击套索工具,然后从弹出菜单中选择魔术棒工具。在属性检查器中设置以下选项:

    • 对于“阈值”,输入一个介于 1 和 200 之间的值,用于定义将相邻像素包含在所选区域内必须达到的颜色接近程度。 数值越高,包含的颜色范围越广。 如果输入 0,则只选择与您单击的第一个像素的颜色完全相同的像素。

    • 对于“平滑”,选择一个选项来定义选区边缘的平滑程度。

  2. 若要选择一个区域,请单击该位图。 若要添加到选区,请继续单击。

  3. 要填充位图中的所选区域,请从“填充颜色”控件中选择要使用的填充。

  4. 若要应用新的填充,请选择颜料桶工具,然后单击所选区域的任意位置。

将位图转换为矢量图形

“转换位图为矢量图”命令会将位图转换为具有可编辑离散颜色区域的矢量图形。将图像作为矢量图形处理,便可以减小文件大小。

将位图转换为矢量图形时,矢量图形不再链接到“库”面板中的位图元件。

注意:

如果导入的位图包含复杂的形状和许多颜色,则转换后的矢量图形的文件比原始的位图文件大。 若要找到文件大小和图像品质之间的平衡点,请尝试“转换位图为矢量图”对话框中的各种设置。

还可以分离位图以使用 Animate 绘画和涂色工具修改图像。

  1. 选择当前场景中的位图。

  2. 选择“修改”>“位图”>“转换位图为矢量图”。

  3. 输入一个“颜色阈值”值。

    当两个像素进行比较后,如果它们在 RGB 颜色值上的差异低于该颜色阈值,则认为这两个像素颜色相同。 如果增大了该阈值,则意味着降低了颜色的数量。

  4. 对于“最小区域”,输入一个值来设置为某个像素指定颜色时需要考虑的周围像素的数量。

  5. 对于“曲线拟合”,选择一个选项来确定绘制轮廓所用的平滑程度。

  6. 对于“转角阈值”,选择一个选项来确定保留锐边还是进行平滑处理。

    若要创建最接近原始位图的矢量图形,请输入以下值:

    • 颜色阈值:10

    • 最小区域:1 像素

    • 曲线拟合:像素

    • 转角阈值:较多转角

使用滴管工具应用位图填充

  1. 选择“滴管”工具,然后单击舞台上的分离位图。 “滴管”工具会将该位图设置为当前的填充,然后将活动工具更改为“颜料桶”工具。

  2. 请执行下列操作之一:

    • 若要将位图应用为填充,请使用颜料桶工具单击现有图形对象。

    • 选择椭圆、矩形或钢笔工具,然后画出一个新对象。 该对象会用分离的位图作为填充。

      要缩放、旋转或倾斜位图填充,请使用自由变换工具。

本产品经 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License 许可  Twitter™ 与 Facebook 中的内容不在 Creative Commons 的条款约束之下。

法律声明   |   在线隐私策略