用户指南 取消(C)

向 Animate 中置入图稿

  1. Adobe Animate 用户指南
  2. Animate 简介
    1. Animate 新增功能
    2. 图示术语表
    3. Animate 系统要求
    4. Animate 键盘快捷键
    5. 在 Animate 中使用多种文件类型
  3. 动画
    1. Animate 动画基础知识
    2. 如何在 Animate 中使用帧和关键帧
    3. 在 Animate 中使用逐帧动画
    4. 如何在 Animate 中使用传统补间动画
    5. 画笔工具
    6. 运动辅助线
    7. 补间动画和 ActionScript 3.0
    8. 关于补间动画
    9. 补间动画
    10. 创建补间动画
    11. 使用属性关键帧
    12. 用补间对位置进行动画处理
    13. 如何使用动画编辑器编辑补间动画
    14. 编辑补间动画的运动路径
    15. 处理补间动画
    16. 添加自定义缓动
    17. 创建和应用动画预设
    18. 设置动画的补间范围
    19. 处理另存为 XML 文件的补间动画
    20. 补间动画与传统补间
    21. 形状补间
    22. 在 Animate 中使用骨骼工具动画
    23. 在 Animate 中处理角色 Rig
    24. 如何在 Adobe Animate 中使用遮罩层
    25. 如何在 Animate 中使用场景
  4. 交互性
    1. 如何使用 Animate 创建按钮
    2. 将 Animate 项目转换为其它文档类型格式
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 在 Animate 中通过代码片段添加交互性
    5. 创建自定义 HTML5 组件
    6. 使用 HTML5 Canvas 中的组件
    7. 创建自定义组件:示例
    8. 自定义组件的代码片段
    9. 最佳做法 - 使用 Animate 制作广告
    10. 虚拟现实创作和发布
  5. 工作区和工作流
    1. 创建和管理画笔
    2. 在 HTML5 Canvas 文档中使用 Google 字体
    3. 使用 Creative Cloud Libraries 和 Adobe Animate
    4. 使用 Animate 的舞台和工具面板
    5. Animate 工作流程和工作区
    6. 在 HTML5 Canvas 文档中使用 Web 字体
    7. 时间轴和 ActionScript
    8. 使用多个时间轴
    9. 设置首选参数
    10. 使用 Animate 创作面板
    11. 使用 Animate 创建时间轴图层
    12. 导出移动应用程序和游戏引擎的动画
    13. 移动和复制对象
    14. 模板
    15. 在 Animate 中查找和替换
    16. 撤消、重做和历史记录面板
    17. 键盘快捷键
    18. 如何在 Animate 中使用时间轴
    19. 创建 HTML 扩展
    20. 图像和动画 GIF 的优化选项
    21. 图像和 GIF 的导出设置
    22. Animate 中的资源面板
  6. 多媒体与视频
    1. 在 Animate 中变形和合并图形对象
    2. 在 Animate 中创建并使用元件实例
    3. 图像描摹
    4. 如何在 Adobe Animate 中使用声音
    5. 导出 SVG 文件
    6. 创建用于 Animate 中的视频文件
    7. 如何在 Animate 中添加视频
    8. 使用视频提示点
    9. 使用 Animate 绘制和创建对象
    10. 改变线条和形状
    11. Animate CC 中的笔触、填充和渐变
    12. 使用 Adobe Premiere Pro 和 After Effects
    13. Animate CC 中的颜色面板
    14. 使用 Animate 打开 Flash CS6 文件
    15. 在 Animate 中使用传统文本
    16. 向 Animate 中置入图稿
    17. 在 Animate 中导入的位图
    18. 3D 图形
    19. 在 Animate 中使用元件
    20. 使用 Adobe Animate 绘制线条和形状
    21. 在 Animate 中使用库
    22. 导出声音
    23. 在 Animate CC 中选择对象
    24. 在 Animate 中使用 Illustrator AI 文件
    25. 使用喷涂刷工具应用图案
    26. 应用混合模式
    27. 排列对象
    28. 使用“命令”菜单自动处理任务
    29. 多语言文本
    30. 在 Animate 中使用摄像头
    31. 将 Animate 与 Adobe Scout 一起使用
    32. 使用 Fireworks 文件
    33. 图形滤镜
    34. 声音和 ActionScript
    35. 绘制首选参数
    36. 用钢笔工具绘图
  7. 平台
    1. 将 Animate 项目转换为其它文档类型格式
    2. 自定义平台支持
    3. 在 Animate 中创建和发布 HTML5 Canvas 文档
    4. 创建和发布 WebGL 文档
    5. 如何打包 AIR for iOS 应用程序
    6. 发布 AIR for Android 应用程序
    7. 发布用于桌面的 Adobe AIR
    8. ActionScript 发布设置
    9. 最佳做法 - 管理应用程序中的 ActionScript
    10. 如何在 Animate 中使用 ActionScript
    11. 最佳做法 - 辅助功能指南
    12. Animate 工作区中的辅助功能
    13. 编写和管理脚本
    14. 启用自定义平台支持
    15. 自定义平台支持概述
    16. 创建辅助内容
    17. 使用自定义平台支持插件
    18. 调试 ActionScript 3.0
    19. 启用自定义平台支持
  8. 导出和发布
    1. 如何从 Animate CC 导出文件
    2. OAM 发布
    3. 导出 SVG 文件
    4. 使用 Animate 导出图形和视频
    5. 发布 AS3 文档
    6. 导出移动应用程序和游戏引擎的动画
    7. 导出声音
    8. 导出 QuickTime 视频文件
    9. 使用 ActionScript 控制外部视频播放
    10. 最佳做法 - 移动设备内容创建技巧
    11. 最佳做法 - 视频惯例
    12. 最佳做法 - SWF 应用程序创作指南
    13. 最佳做法 - 构造 FLA 文件
    14. 在 Animate 中优化 FLA 文件的最佳做法
    15. ActionScript 发布设置
    16. 指定 Animate 的发布设置
    17. 导出放映文件
    18. 导出图像和动画 GIF
    19. HTML 发布模板
    20. 使用 Adobe Premiere Pro 和 After Effects
    21. 快速分享和发布动画

关于将插图导入 Animate 中

Adobe Animate 可以使用在其他应用程序中创建的插图。可以导入各种文件格式的矢量图形和位图。如果您的系统安装了 QuickTime® 4 或更高版本,则可以导入更多的矢量或位图文件格式。可以将 Adobe® FreeHand® 文件(MX 版本和更低版本)和 Adobe® Fireworks® PNG 文件直接导入 Animate 中,并且保留这些格式的属性。

导入 Animate 中的图形文件的大小不能小于 2 x 2 像素。

若要在运行时期间将 JPEG 文件加载到 Animate SWF 文件中,请使用 loadMovie 动作或方法。 有关详细信息,请参阅《ActionScript 2.0 语言参考》中的 loadMovie(MovieClip.loadMovie 方法)或《ActionScript 3.0 开发人员指南》中的“使用影片剪辑”

Animate 可以导入矢量图形、位图和图像序列,如下所示:

  • 将 Adobe® Illustrator® 和 Adobe® Photoshop® 文件导入 Animate 中时,可以指定可让您保留大部分插图可视数据的导入选项,以及通过 Animate 创作环境保持特定可视属性的可编辑性的功能。

  • 将矢量图像从 FreeHand 导入 Animate 中时,可以选择用于保留 FreeHand 图层、页面和文本块的选项。

  • 从 Fireworks 导入 PNG 图像时,可以将文件作为能够在 Animate 中修改的可编辑对象进行导入,或作为可以在 Fireworks 中编辑和更新的拼合文件进行导入。

  • 选择用于保留图像、文本和辅助线的选项。

    如果通过剪切和粘贴从 Fireworks 导入 PNG 文件,该文件将转换为位图。

  • 将 SWF 和 WMF(Windows® 元文件格式)文件直接导入 Animate 文档(而不是库)中时,这些文件中的矢量图像是作为当前图层中的一个组导入的。

  • 直接导入 Animate 文档中的位图(扫描的照片、BMP 文件)是作为当前图层中的单个对象导入的。Animate 保留所导入位图的透明度设置。 因为导入位图可能会增大 SWF 文件的文件大小,所以应考虑压缩导入的位图。

    通过拖放操作将位图从应用程序或桌面导入 Animate 时,将不能保留位图透明度。若要保留透明度,请使用“文件”>“导入到舞台”或“导入到库”命令进行导入。

  • 直接导入 Animate 文档中的任何图像序列(例如,PICT 或 BMP 序列)是作为当前图层的连续关键帧导入的。

支持的导入文件格式

有关 Animate 支持的可供导入、导出或编辑的各种文件格式的完整列表,请参阅支持的文件格式技术说明。

图形格式

您可以将以下矢量或位图文件格式导入 Animate 8 或更高版本:

文件类型

扩展名

Windows

Macintosh

Adobe Illustrator(版本 10 或更低版本)

.ai

Adobe Photoshop

.psd

位图

.bmp

 

GIF 和 GIF 动画

.gif

JPEG

.jpg

PNG

.png

Flash Player 6/7

.swf

可缩放矢量图形

.svg

声音格式

Animate 可以导入以下音频格式:

文件类型

扩展名

Windows

Macintosh

Adobe Soundbooth

.asnd

波形

.wav

 

音频交换文件格式

.aiff

 

MP3

.mp3

Sound Designer II

.sd2

 

Sun AU

.au

System 7 声音

.snd

 

视频格式

Animate 可以导入以下视频格式:

文件类型

扩展名

Windows

Macintosh

Adobe Animate 视频

.flv、.f4v

Windows 视频

.avi

MPEG

.mpg、.m1v、.m2p、.m2t、.m2ts、.mts、.tod、.mpe、.mpeg

MPEG-4

.mp4、.m4v、.avc

数字视频

.dv、.dvi

适用于移动设备的 3GPP/3GPP2

.3gp、.3gpp、.3gp2、.3gpp2、.3p2

在 Animate 中导入插图

Animate 可将各种文件格式的插图直接导入到舞台或库中。

将文件导入 Animate 中

  1. 请执行下列操作之一:
    • 要将文件直接导入当前 Animate 文档中,请选择“文件”>“导入”>“导入到舞台”。

    • 要将文件导入到当前 Animate 文档的库中,请选择“文件”>“导入”>“导入到库”。(若要使用文档中的库项目,直接将它拖到舞台上即可。))

  2. 从“文件类型”(Windows) 或“显示”(Macintosh) 弹出菜单中选择文件格式。
  3. 定位到所需的文件,然后选择它。 如果导入的文件具有多个图层,则 Animate 可能会创建新图层(取决于导入文件的类型)。任何新图层都显示在时间轴上。

  4. 单击“打开”。
  5. 如果所导入的文件名以数字结尾,并且在同一文件夹中还有其他按顺序编号的文件,请执行下列操作之一:

    注意:(仅限 Windows 8)在选中“矢量轮廓”选项的情况下,如果导入的 PSD 文件包含文本,则您无法编辑矢量对象的锚点。对于使用 Windows 8 中不支持的字体来创建的 PSD 文件也是如此。

    • 若要导入所有的连续文件,请单击“是”。

    • 若要只导入指定的文件,请单击“否”。

      下面是可以用作序列的文件名的示例:

      Frame001.gif、Frame002.gif、Frame003.gif

      Bird 1、Bird 2、Bird 3

      Walk-001.ai、Walk-002.ai、Walk-003.ai

将其他应用程序中的位图直接粘贴到当前 Animate 文档中

  1. 复制其他应用程序中的图像。
  2. 在 Animate 中,选择“编辑”>“粘贴到中心位置”。

导入 FXG 文件

FXG 格式允许 Animate 与其他 Adobe 应用程序(例如 Adobe Illustrator、Fireworks 和 Photoshop)交换图形,并可保留所有复杂图形信息。Animate 允许您导入 FXG 文件(仅限 2.0 版本),还可以 FXG 格式保存舞台上选定的对象或保存整个舞台。

  • 要导入 FXG 文件,请选择“文件”>“导入”>“导入到舞台”或“导入到库”,并选择要打开的 FXG 文件。

关于 AutoCAD DXF 文件

Animate 支持 AutoCAD 10 中的 AutoCAD® DXF 格式。

DXF 文件不支持标准系统字体。 Animate 会尝试正确地映射字体,但是结果无法预知,特别是对于文本对齐。

因为 DXF 格式不支持实心填充,所以填充区域只作为轮廓导出。 因此,DXF 格式最适合线条画,例如平面图和地图。

您可以将二维 DXF 文件导入 Animate 中。Animate 不支持三维 DXF 文件。

尽管 Animate 不支持在 DXF 文件中进行缩放,但是所有导入的 DXF 文件都会产生一个 12 x 12 英寸的文件,您可以使用“修改”>“变形”>“缩放”命令对其进行缩放。另外,Animate 只支持 ASCII DXF 文件。如果 DXF 文件是二进制的,需将其转换为 ASCII,然后再导入 Animate。

使用 ActionScript 加载插图

借助 ActionScript,您可以在运行时从库中加载外部图像文件或资源。

Adobe 徽标

登录到您的帐户