The following sections discuss some of the common errors that may occur when you are developing, packaging, or deploying mobile applications.

Installing non-market applications

While installing your mobile application on an Android device, if you are getting the following security error, you need to enable the installation of non-market applications on your device.

139035001

Click the Setting button, and go to the appropriate screen where you can enable installing non-market applications (from unknown sources):

139035002

Note: The settings menu and the UI labels may differ depending on the version of Android.

PhoneGap application limit

In order to create new private applications using PhoneGap, you need to upgrade your subscription to a paid plan (up to 25 private applications). To upgrade your account, go to https://build.phonegap.com/plans and click on the green $9.99 paid plan button at bottom right to proceed through the registration process.

Note that the free plan allows only 1 private application. So, if you are creating more than one application, you will get the following error in ColdFusion builder:

139035003

When this error occurs, you can either delete the existing private application or migrate to a paid PhoneGap plan.

Error while building iOS bundle

When you do not specify the right credentials for iOS packaging, PhoneGap build service will fail to produce the required IPA file:

139035004

Ensure that you have specified the path to the iOS developer certificate and the provisioning profile from the ColdFusion Builder. See Global configuration requirements.

Cannot install the IPA file

If you cannot install the IPA file on the device using Apple iTunes, check if the device is provisioned through the iOS provisioning portal. 

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy