Úpravy objektů pomocí grafických rámečků

Mezi objekty aplikace Adobe InDesign patří všechny položky, které můžete přidat nebo vytvořit v okně dokumentu. To zahrnuje otevřené cesty, zavřené cesty, složené tvary a cesty, text, rastrové obrazy, 3D objekty a jakékoliv umístěné soubory, například obrazy.

Pokud je uvnitř rámečku grafika (jako v případě jakékoliv importované grafiky), můžete ji upravit změnou jejího vztahu k rámečku, jako v následujících příkladech:

  • Ořízněte grafiku tím, že zmenšíte její rámeček.

  • Vytvořte různé efekty maskování a uspořádání vložením objektu do rámečku.

  • Přidejte ke grafice ohraničující rámeček nebo obrys změnou tloušťky tahu a barvy jejího rámečku.

  • Umístěte grafiku na střed v obdélníku pozadí tím, že zvětšíte její rámeček a nastavíte barvu výplně rámečku.

Vložení objektu do rámečku

Pomocí příkazu Vložit dovnitř můžete vkládat grafiky do kontejnerových rámečků. Můžete dokonce vkládat grafiky do vnořených rámečků.

Obraz pozadí vložený do rámečku
Obraz pozadí vložený do rámečku

  1. Proveďte jeden z následujících úkonů:
    • Chcete-li vložit do rámečku jeden objekt, vyberte tento objekt.

    • Chcete-li vložit do rámečku dva nebo více objektů, nejdříve z nich vytvořte skupinu, protože rámeček může obsahovat pouze jeden objekt.

    • Chcete-li vložit textový rámeček do jiného rámečku a zachovat jeho současný vzhled, vyberte celý textový rámeček nástrojem pro výběr nebo pro přímý výběr , ne textovým nástrojem.

  2. Zvolte Úpravy > Kopírovat (nebo Úpravy > Vyjmout, pokud nechcete zachovat originál).

  3. Vyberte cestu nebo rámeček, a pak zvolte Úpravy > Vložit dovnitř.

Odstranění obsahu rámečku

  1. Proveďte jeden z následujících úkonů:
    • Při odstraňování grafického nebo textového rámečku vyberte objekt pomocí nástroje pro přímý výběr . Nebo použijte nástroj pro výběr a klikněte na nástroj pro zachycení obsahu obrazu.

    • Když odstraňujete znaky textu, vyberte je textovým nástrojem .

  2. Proveďte jeden z následujících úkonů:
    • Chcete-li obsah trvale odstranit, stiskněte klávesu Delete nebo Backspace.

    • Chcete-li vložit obsah jinam v návrhu, zvolte Úpravy > Vyjmout, odznačte rámeček a pak zvolte Úpravy > Vložit.

Poznámka:

Importovaný obraz nemůže být bez rámečku. Pokud vyjmete importovaný obraz z jeho rámečku a vložíte ho jinam do dokumentu, automaticky se pro něj vytvoří nový rámeček.

Přizpůsobení objektů rámečkům

Pokud mají rámeček a jeho obsah různé velikosti, můžete je vzájemně přesně přizpůsobit pomocí příkazů pro přizpůsobení.

Volby zarovnání rámečku se aplikují na rámečky, které obsahují buď grafiku nebo jiný textový rámeček (textové rámečky vnořené v jiném rámečku), ale neovlivní odstavce uvnitř textového rámečku – zarovnání a umístění vlastního textu se nastavuje pomocí příkazu Volby textového rámečku a panelů Odstavec, Odstavcové styly a Článek.

Přizpůsobení objektu jeho rámečku

  1. Vyberte rámeček objektu.

  2. Zvolte Objekt > Přizpůsobit a vyberte jednu z následujících voleb:

    Vyplnit rámeček proporcionálně

    Změní velikost obsahu tak, aby vyplnil celý rámeček, a přitom zachová proporce obsahu. Rozměry rámečku se nezmění. Pokud mají obsah a rámeček rozdílné proporce, část obsahu se ohraničovacím rámečkem ořízne.

    Přizpůsobit obsah proporcionálně

    Změní velikost obsahu tak, aby se vešel do rámečku, a přitom zachová proporce obsahu. Rozměry rámečku se nezmění. Pokud mají obsah a rámeček různý poměr stran, vznikne prázdné místo.

    Přizpůsobit podle obsahu

    Automaticky přizpůsobí obraz dovnitř rámečku podle obsahu obrazu a velikosti rámečku. Rozměry rámečku se nezmění. Pro nastavení jako výchozí možnosti přizpůsobení rámečku přejděte do nabídky Předvolby > Obecné a vyberte Nastavit přizpůsobení podle obsahu jako výchozí nastavení přizpůsobení rámečku.

    Poznámka:

    • Funkce Přizpůsobit podle obsahu odebere transformace, jako jsou změna měřítka, otočení, převrácení nebo úkos, které jsou v obrázku použité. Transformace použité v rámečku však odebrány nebudou.
    • Přizpůsobení podle obsahu není dostupné pro 32bitovou verzi systému Windows.

    Přizpůsobit rámeček obsahu

    Změní velikost rámečku tak, aby se přizpůsobil svému obsahu. Proporce rámečku se změní podle potřeby, aby odpovídaly proporcím obsahu. To je užitečné pro obnovení grafického rámečku, který jste nedopatřením změnili.

    Přizpůsobit obsah rámečku

    Změní velikost obsahu tak, aby se obsah přesně vešel do rámečku, a přitom povolí změnu proporcí obsahu. Rámeček se nezmění, ale pokud mají obsah a rámeček různý poměr stran, může se obsah natáhnout.

    Poznámka:

    Chcete-li rámeček rychle přizpůsobit obsahu, dvojitě klikněte na některé rohové táhlo na rámečku. Rámeček změní velikost směrem od bodu, na který jste dvojitě klikli. Pokud kliknete na boční táhlo, rámeček změní velikost pouze v tomto rozměru.

    Zarovnání objektu uvnitř grafického rámečku
    Zarovnání objektu uvnitř grafického rámečku

    A. Originál B. Rámeček přizpůsobený obsahu C. Obsah přizpůsobený rámečku 

    Vystředit obsah

    Umístí obsah do středu rámečku. Proporce rámečku i jeho obsahu se zachovají. Velikost obsahu a rámečku se nezmění.

    Poznámka:

    Příkazy pro přizpůsobení nastaví vnější okraje obsahu na střed tahu rámečku. Pokud má rámeček velkou tloušťku tahu, vnější okraje obsahu se překryjí. Můžete nastavit zarovnání tahu rámečku na střed, na vnitřní nebo na vnější okraj rámečku. (Viz Nastavení tahů.)

    Chcete-li odstranit nežádoucí nastavení přizpůsobení aplikované pomocí automatického přizpůsobení, zvolte Objekt > Přizpůsobení > Vymazat volby přizpůsobení rámečku.

Použití automatického přizpůsobení

Když změníte velikost rámečku obrazu, ale není vybrané automatického přizpůsobení, změní se velikost rámečku, ale velikost obrazu zůstane stejná. Jestliže vyberete Automatické přizpůsobení, změní se velikost obrazu podle rámečku. Rozhodnete-li se oříznout nebo transformovat obraz, použijte pro transformaci samotného obrazu nástroj pro přímý výběr. Anebo zrušte výběr volby Automatické přizpůsobení, transformujte obraz a vyberte znovu Automatické přizpůsobení.

Volbu Automatické přizpůsobení můžete vybrat v ovládacím panelu a v dialogovém okně Volby přizpůsobení rámečku.

Nastavení voleb přizpůsobení rámečku

Volbu přizpůsobení můžete spojit s rámečkem vyhrazeného místa tak, že kdykoliv se do tohoto rámečku vloží nový obsah, použije se příkaz přizpůsobení.

  1. Vyberte rámeček.

  2. Zvolte Objekt > Přizpůsobit > Volby přizpůsobení rámečku.

  3. Určete následující volby, a pak klikněte na OK:

    Automaticky přizpůsobit

    Vyberte tuto volbu, pokud chcete, aby se velikost obrazu změnila automaticky, když změníte velikost rámečku.

    Referenční bod

    Určuje referenční bod pro akce oříznutí a přizpůsobení. Pokud například vyberete jako referenční bod pravý horní roh a pak zvolíte příkaz Přizpůsobit obsah proporcionálně, obraz se může oříznout na levé nebo dolní straně (od referenčního bodu).

    Velikost oříznutí

    Určuje umístění ohraničovacího rámečku obrazu vzhledem k rámečku. K oříznutí obrazu použijte kladné hodnoty. Můžete například vyloučit rámeček, který obklopuje vložený obraz. Pomocí záporných hodnot přidejte prostor mezi ohraničovací rámeček obrazu a rámeček. Můžete například požadovat, aby mezi obrazem a rámečkem byl bílý prostor.

    Pokud zadáte hodnoty oříznutí, které způsobí, že obraz nebude viditelný, budou se tyto hodnoty ignorovat, ale volby přizpůsobení se přesto použijí.

    Přizpůsobení prázdnému rámečku

    Určete, zda chcete, aby se obsah přizpůsobil rámečku (což může způsobit zkreslení obrazu), aby se přizpůsobil obsah proporcionálně (může vzniknout prázdné místo) nebo aby se rámeček vyplnil proporcionálně (může dojít k oříznutí jedné nebo více stran).

Akce přizpůsobení se použije pouze v případě, když se obsah umístí do rámečku. Jestliže změníte velikost rámečku, volba přizpůsobení se automaticky znovu aplikuje, pouze pokud je vybráno automatické přizpůsobení.

Přemístění grafického rámečku nebo jeho obsahu

Když používáte nástroj pro výběr a vybíráte rámeček s grafikami, můžete vybrat buď rámeček nebo obraz v rámečku. Když kliknete mimo nástroj pro zachycení obsahu a přetáhnete výběr, obsah rámečku se přesune s rámečkem. Když přetáhnete nástroj pro zachycení obsahu, obraz se přesune v rámečku.

Následující metody představují způsoby, jak posunout rámeček nebo jeho obsah nezávisle na sobě. Tyto metody jsou užitečné pro nastavení způsobu oříznutí nebo maskování grafiky v jejím rámečku.

Poznámka:

Pokud nástroj pro výběr nefunguje podle očekávání, zkuste nejdříve vše odznačit. To uděláte stisknutím kláves Ctrl+Shift+A (Windows) nebo Command+Shift+A (Mac OS).

  1. Proveďte libovolný z následujících úkonů:
    • Chcete-li přesunout rámeček i jeho obsah, klikněte nástrojem pro výběr na obraz mimo nástroj pro zachycení obsahu.

    • Chcete-li posunout importovaný obsah bez posunutí rámečku (to znamená změnit polohu obsahu za rámečkem), přetáhněte nástroj pro zachycení obsahu. Pro přetažení obrazu můžete použít také nástroj pro přímý výběr .

    Přemístění obsahu, ale ne jeho rámečku
    Přemístění obsahu, ale ne jeho rámečku

    Poznámka:

    Pokud podržíte stisknuté tlačítko myši na grafice před tím, než s ní pohnete, zobrazí se mimo rámeček dynamický náhled grafiky (stínový obraz), ale náhled obrazu, který se pohybuje uvnitř rámečku, není stínový. Tím se usnadní kontrola umístění celého obrazu v rámečku.

    • Chcete-li přesunout rámeček bez přesunutí obsahu, klikněte na rámeček pomocí nástroje pro výběr, přepněte se do nástroje pro přímý výběr a přetáhněte středový bod.
    Přemístění rámečku, ale ne jeho obsahu
    Přemístění rámečku, ale ne jeho obsahu

    • Chcete-li přesunout více rámečků, vyberte objekty pomocí nástroje pro výběr a pak je přetáhněte. Pokud pro výběr více objektů použijete nástroj pro přímý výběr, ovlivní se pouze položka, kterou přetáhnete.

Vytvoření ohraničení nebo pozadí

Grafický rámeček se ideálně hodí pro použití jako ohraničení nebo pozadí pro jeho obsah, protože můžete změnit jeho tah a výplň nezávisle na jeho obsahu.

Přidání ohraničení ke grafickému rámečku
Přidání ohraničení ke grafickému rámečku

A. Fotografie v grafickém rámečku B. Rámeček s aplikovaným tahem C. Zvětšený rámeček s aplikovaným tahem i výplní 
  1. Nástrojem pro výběr klikněte na importovanou grafiku mimo nástroj pro zachycení obsahu, abyste vybrali její rámeček.
  2. Chcete-li zvětšit rámeček bez změny velikosti grafiky, táhněte kterékoliv táhlo ohraničovacího rámečku směrem ven. Chcete-li zachovat proporce rámečku, podržte při tažení stisknutou klávesu Shift.
  3. Pomocí panelu Vzorník a panelu nástrojů aplikujte barvu tahu a výplně.
  4. Pomocí panelu Tah nastavte tloušťku, styl nebo zarovnání tahu rámečku.

Poznámka:

Pomocí panelu Transformace nebo ovládacího panelu můžete rychle zvětšit rámeček na všechny strany stejně. Vyberte rámeček nástrojem pro přímý výběr , nastavte ikonu umístění referenčního bodu v panelu na středový bod a zadejte nové hodnoty pro šířku a výšku.

Oříznutí nebo maskování objektů

Oříznutí a maskování jsou termíny, které popisují skrytí části objektu. Obecně je rozdíl v tom, že oříznutí použije obdélník pro oříznutí okrajů obrazu a maskování použije libovolný tvar pro změnu pozadí objektu na průhledné. Typickým příkladem masky je ořezová cesta vytvořená pro určitý obraz.

K oříznutí nebo zamaskování objektů použijte grafické rámečky. Protože importovaná grafika se automaticky vloží do rámečku, můžete ji okamžitě oříznout nebo maskovat bez toho, že byste pro ni museli vytvářet rámeček. Pokud jste nevytvořili rámeček pro importovanou grafiku ručně, vytvoří se automaticky rámeček stejné velikosti, jako je grafika, proto není zřejmé, že tam tento rámeček je.

Poznámka:

Aby byl tisk efektivní, posílají se při výstupu dokumentu pouze data pro viditelné části oříznutých nebo maskovaných obrazů. Přesto ušetříte místo na disku a paměť RAM, když oříznete nebo maskujete obrazy na požadované tvary a velikost před jejich importem do dokumentu.

  • Chcete-li oříznout importovaný obraz nebo jinou grafiku, která je již v obdélníkovém rámečku, klikněte na objekt nástrojem pro výběr  přetáhněte libovolné táhlo ohraničovacího rámečku, který se objeví. Podržte při tažení Shift, chcete-li zachovat původní proporce rámečku.


    Oříznutí obrazu pomocí grafického rámečku

  • Chcete-li oříznout nebo maskovat libovolný objekt, pomocí nástroje pro výběr nebo pro přímý výběr tooltovyberte jeden objekt, který chcete maskovat. Zvolte Úpravy > Kopírovat, vyberte prázdnou cestu nebo rámeček menší, než je objekt, a zvolte Úpravy > Vložit dovnitř.
  • Chcete-li obsah rámečku oříznout přesně, vyberte rámeček nástrojem pro přímý výběr a změňte velikost rámečku pomocí panelu Transformace nebo ovládacího panelu.
  • Chcete-li určit nastavení oříznutí pro prázdný rámeček vyhrazeného místa, zvolte Objekt > Přizpůsobit > Volby přizpůsobení rámečku, a pak určete hodnotu oříznutí.

Poznámka:

Pro importovanou grafiku můžete také vytvořit masku změnou tvaru existujícího rámečku grafiky pomocí kreslicích nástrojů.

Volby exportu objektu

Úvod k možnostem exportu objektů

Volby exportu objektu lze používat k zadání parametrů exportu potřebných k exportu do různých formátů, například EPUB, HTML a přístupných PDF.

 

Volby exportu objektu lze vztahovat jak na textové a grafické rámečky, tak na skupiny. Volby exportu objektu používejte k:

  • Definování alternativního textu pro umístěné obrazy a grafiku.

  • Použití nastavení tagů a skutečného textu u tagovaných dokumentů PDF.

  • Vytváření různých nastavení převodu jednotlivých objektů tak, aby se správně vykreslovaly na obrazovkách různých velikostí a s různými hustotami obrazových bodů. Tyto volby použijte pro řízení kvality rasterizace aplikované na textové efekty, například vržený stín a úkos, při exportu rozvržení do formátu HTML nebo EPUB.

Poznámka:

Pokud objekt obsahuje hypertextové odkazy, bude podporován při exportu.

Použití voleb exportu objektu

  1. V rozvržení vyberte rámeček nebo skupinu.
  2. Vyberte možnost Objekt > Volby exportu objektu.

    nebo

    Klikněte pravým tlačítkem na objekt a vyberte Volby exportu objektu.

  3. Použijte nastavení.

Poznámka:

Dialogové okno Volby nastavení exportu můžete nechat otevřené a vybírat další objekty v rozvržení, na které chcete použít příslušná nastavení.

Volby alternativního textu

Alternativní text (Alt. text) je stručný textový popis obrazu nebo grafiky. Tento text se používá v případech, když nedojde k vykreslení obrazu nebo když chcete pomoci programům pro čtení z obrazovky.

Zdroj alternativního textu

Vyberte zdroj pro přiřazení alternativního textu pro vybrané rámečky nebo skupiny.

Poznámka:

Pokud importujete obsah z aplikace Microsoft Word, InDesign importuje také alternativní text patřící k obrázkům.

Vlastní

Zadejte text ručně.

Ze struktury

Z XMP (Titul |Popis| Titulek)

Použijte data uložená v běžných polích XMP. Pokud jsou data aktualizovaná pomocí jiné aplikace, například Adobe Bridge, dojde při aktualizaci odkazu k automatické aktualizaci textu.

Z jiných XMP

Pokud je textový řetězec uložen v nějakém jiném poli XMP, zadejte kompletní název jmenného prostoru a vlastnosti ve formátu <jmenný prostor>:<vlastnost>. Například uživatelské rozhraní Adobe Bridge podporuje IPTC Core obsahující pole nadepsané „Kód předmětu IPTC“. Pokud by bylo toto pole použito k uložení textového řetězce, potom by hodnota vlastnosti byla „Iptc4xmpCore:SubjectCode[1]“.

Volby tagovaných dokumentů PDF

Použít tag

Vyberte zdroj pro přiřazení tagu PDF pro vybrané rámečky nebo skupiny.

Ze struktury

Bude použit text uvedený ve struktuře.

Artefakt

Používá se pro grafické elementy, které nemají žádný důležitý význam při čtení nahlas programem pro čtení z obrazovky.

Odvozen od objektu

Automaticky určuje obsah rámečku a použije tagy „Story“ (článek) nebo „Figure“ (obrázek).

Zdroj skutečného textu

Dokumenty PDF podporují kromě alternativního textu také skutečný text. Skutečný text lze použít u grafických elementů, které vypadají jako text. Například naskenovaný obraz TIFF. Skutečný text se používá k vyjádření slov, která byla převedena na kresbu. Skutečný text lze používat pouze v tagovaných dokumentech PDF.

Vlastní

Zadejte text ručně.

Ze struktury

Z XMP (Titul |Popis| Titulek)

Použijte data uložená v běžných polích XMP. Pokud jsou data aktualizovaná pomocí jiné aplikace, například Adobe Bridge, dojde při aktualizaci odkazu k automatické aktualizaci textu.

Z jiných XMP

Pokud je textový řetězec uložen v nějakém jiném poli XMP, zadejte kompletní název jmenného prostoru a vlastnosti ve formátu <jmenný prostor>:<vlastnost>. Například uživatelské rozhraní aplikace Bridge podporuje IPTC Core obsahující pole nadepsané „Kód předmětu IPTC“. Pokud by bylo toto pole použito k uložení textového řetězce, potom by hodnota vlastnosti byla „Iptc4xmpCore:SubjectCode[1]“.

Volby EPUB a HTML

Volby EPUB a HTML použijte k zadání nastavení převodu obrazu u jednotlivých objektů. Pokud nejsou tato nastavení zadaná, použijí se nastavení převodu z exportu obrazu do EPUB. Viz Volby obrazů ve formátu EPUB.

Volby exportu objektu
Volby exportu objektu

epub: typ

Kliknutím na ikonu šipky zvolte pořadí, ve kterém může čtenář číst dokument.

Zachovat vzhled z rozvržení

Po zaškrtnutí tohoto pole můžete zadat vlastní nastavení převodu obrazu pro vybrané rámečky.

Výchozí

Výchozí nastavení namapovaná do nastavení dialogu Export.

Použít existující obraz pro grafické objekty

Použije existující obraz pro grafické objekty

Rastrovat kontejner

Převést objekt na obraz. Například textový rámeček je převeden na obraz.

Rastrovat obsah

Vzhled je zachován pomocí CSS.

Vlastní rastrování

Po zaškrtnutí tohoto pole můžete zadat vlastní nastavení převodu obrazu pro vybrané rámečky.

Formátovat

Umožňuje zvolit, zda se optimalizované obrazy z dokumentu převedou do GIF, JPEG nebo PNG.

Rozlišení (ppi)

Určete rozlišení obrazů v obrazových bodech na palec (ppi) . Operační systémy jsou standardizovány buď na 72 ppi nebo 96 ppi, rozsah mobilních zařízení se liší od 132 ppi (iPad) přes 172 ppi (Sony Reader) až po 300 ppi (iPhone 4). Hodnotu ppi můžete zadat pro každý vybraný objekt. Možné hodnoty jsou 72, 96, 150 (dnešní průměr ze všech zařízení eBook) a 300.

Paleta

Umožňuje nastavit, jak InDesign zpracuje barvy při optimalizaci souborů GIF. Formát GIF používá omezenou paletu barev, která nemůže překročit 256 barev.

Zvolte Adaptivní, aby se vytvořila paleta používající reprezentativní vzorek barev v grafice bez jakéhokoliv rozkladu barev (míchání malých barevných bodů, aby se simulovaly další barvy). Chcete-li vytvořit paletu bezpečných webových barev, které jsou podmnožinou systémových barev Windows a Mac OS, zvolte Webová. Zvolte Systémová (Win) nebo Systémová (Mac), abyste vytvořili paletu pomocí vestavěné systémové palety barev. Tato volba může mít neočekávané výsledky.

Zvolte Prokládaně, chcete-li pomalu načítaný obraz zobrazovat postupným vyplňováním chybějících řádků. Pokud tato volba není vybrána, je obraz rozmazaný a zobrazí se ostře až ve chvíli, kdy dosáhne plného rozlišení.

Kvalita

Pro každý vytvořený obraz JPEG určuje kompromis mezi kompresí (snížení velikosti souboru) a kvalitou obrazu. Nízká vytváří nejmenší soubory a nejméně kvalitní obrazy.

Metoda

Určuje, jak rychle se grafika JPEG bude zobrazovat, když se soubor obsahující grafiku otevře na Webu. Zvolte Progresivní, aby se obrazy JPEG při stahování zobrazovaly postupně a s postupným načítáním detailů. (Soubory vytvořené s touto volbou jsou o něco větší a při zobrazování vyžadují více paměti RAM.) Zvolte Účaří, pokud se má každý soubor JPEG zobrazit až po svém stažení (do té doby se na jeho místě objeví rámeček).

Vlastní Rozvržení

V rozbalovacím seznamu vyberte předvolbu rozvržení.

  • Zarovnání a mezery: Určuje zarovnání obrazu vlevo, na střed, vpravo a odsazení nahoře a dole.
  • Plovoucí doleva: Volba pro doleva plovoucí zarovnání.
  • Plovoucí doprava: Volba pro doprava plovoucí zarovnání.

Vložit novou stránku

Tuto volbu vyberte, chcete-li vkládat společně s obrazy nové stránky. Nové stránky lze vkládat před obrazem, po obraze nebo před a po obraze.

Velikost

Z následujících voleb vyberte vlastní šířku a výšku CSS:

  • Žádná: Na objekt nebude aplikována žádná šířka ani výška CSS.
  • Výchozí: Použije se výchozí šířka a výška CSS.
  • Pevná: Použije se pevná šířka a výška CSS.
  • Relativně k toku textu: Vztahuje se pouze na šířku CSS. Šířka CSS se přizpůsobí toku textu.
  • Relativně k velikosti textu: Vztahuje se pouze na šířku CSS. Šířka CSS se přizpůsobí toku textu.
  • Vlastní šířka: Pomocí této volby můžete zadat vlastní hodnotu šířky.
  • Vlastní výška: Pomocí této volby můžete zadat vlastní hodnotu výšky.

Poznámka:

Rozbalovací seznam Velikost se vztahuje pouze na rozvržení Zalamovatelný EPUB a HTML. Nevztahuje se na pevné rozvržení EPUB.

Tato práce podléhá licenci Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.  Na příspěvky ze služeb Twitter™ a Facebook se nevztahují podmínky licence Creative Commons.

Právní upozornění   |   Zásady ochrany osobních údajů online