Aprenda a utilizar los comandos Deshacer/Rehacer y el panel Historia para controlar el estado de sus imágenes en Adobe Photoshop.

Los comandos Deshacer/Rehacer y el panel Historia le permiten controlar fácilmente los estados de las imágenes.

Uso de los comandos Deshacer o Rehacer

Actualización de Photoshop CC 20.0 (versión de octubre de 2018)

A partir de la versión de octubre de 2018 de Photoshop CC (20.0), puede deshacer varios pasos en su documento de Photoshop utilizando Control + Z (Win) o Comando + Z (Mac). Este nuevo modo multideshacer está activado de forma predeterminada.

Para realizar la operación deshacer o rehacer, realice las siguientes acciones:

  • Deshacer: retrocede un paso en la cadena de deshacer. Seleccione Edición > Deshacer o utilice el método abreviado de teclado Control + Z (Win) o Comando + Z (Mac).
  • Rehacer: avanza un paso. Seleccione Edición > Rehacer o utilice el método abreviado de teclado Mayús + Control + Z (Win) o Mayús + Comando + Z (Mac).

El menú Edición también muestra el nombre del paso que se deshará o rehará junto a los comandos de deshacer y rehacer. Por ejemplo, Edición > Deshacer Editar texto.

¿Cómo vuelvo a los métodos abreviados heredados de deshacer?

(Photoshop)

Para volver al modo deshacer heredado en Photoshop, realice las siguientes acciones:

  1. En la barra de menús, seleccione Edición > Métodos abreviados de teclado.
  2. En el cuadro de diálogo Métodos abreviados de teclado y menús, seleccione Utilizar métodos abreviados heredados y haga clic en OK.
  3. Reinicie Photoshop.

(Adobe Camera Raw)

Para volver al modo deshacer heredado en Adobe Camera Raw, realice las siguientes acciones:

  1. En barra de menús de Photoshop, seleccione Edición > Preferencias > Administración de archivos.
  2. En la sección Compatibilidad de archivo, haga clic en Preferencias de Camera Raw.
  3. En el cuadro de diálogo Preferencias de Camera Raw, seleccione Utilizar métodos abreviados heredados y haga clic en OK.
  4. Reinicie Photoshop.

Vuelta a la última versión guardada

  1. Seleccione Archivo > Volver.

    Nota:

    Volver se añade como un estado de historia en el panel Historia y esta operación puede deshacerse.

Restauración de parte de una imagen a la versión guardada anteriormente

  1. Realice una de las siguientes acciones:
    • Utilice la herramienta Pincel de historia para pintar con el estado o la instantánea seleccionados en el panel Historia.

    • Utilice la herramienta Borrador  con la opción Borrar a historia seleccionada.

    • Seleccione el área que desea restaurar y elija Edición > Rellenar. En Usar, elija Historia y haga clic en OK.

    Nota:

    Para restaurar la imagen con una instantánea del estado inicial del documento, seleccione Opciones de historia en el menú del panel y asegúrese de que la opción Crear automáticamente primera instantánea esté seleccionada.

Cancelación de una operación

  1. Mantenga pulsada la tecla Esc hasta que se detenga la operación que esté llevándose a cabo. En Mac OS, también puede pulsar Comando+punto.

Recepción de una notificación al completarse una operación

Una barra de progreso indica que se está llevando a cabo una operación. Puede interrumpir la operación o pedir al programa que le avise cuando esta operación haya terminado.

  1. Realice una de las siguientes acciones: seleccione Edición > Preferencias > Generales (Windows) o Photoshop > Preferencias > Generales (Mac OS).

  2. Seleccione Notificar al terminar.
  3. Haga clic en OK.

Utilización del panel Historial

Puede utilizar el panel Historia para ir a cualquier estado reciente de la imagen creado durante la sesión de trabajo actual. Cada vez que aplica un cambio a una imagen, el nuevo estado de esa imagen se añade al panel.

Por ejemplo, si selecciona, pinta y gira parte de una imagen, cada uno de estos estados aparece de forma independiente en la lista del panel. Al seleccionar uno de los estados, la imagen adopta el aspecto que tenía cuando se aplicó el cambio por primera vez. Ahora ya puede trabajar desde ese estado.

También puede utilizar el panel Historia para eliminar estados de imagen y, en Photoshop, para crear un documento a partir de un estado o instantánea.

Para mostrar el panel Historia, seleccione Ventana > Historia o haga clic en la ficha del panel Historia.

Panel Historia de Photoshop
Panel Historia de Photoshop

A. Define el origen del pincel de historia. B. Miniatura de una instantánea C. Estado de historia D. Regulador de estado de historia 

Al utilizar el panel Historia, tenga en cuenta lo siguiente:

  • Los cambios que afectan a todo el programa, como cambios en los paneles, ajustes de color, acciones y preferencias, no se reflejan en el panel Historia porque no son cambios que afecten a una imagen determinada.

  • Por defecto, el panel Historia muestra los últimos 20 estados. Puede cambiar el número de estados recordados definiendo una preferencia en Preferencias > Rendimiento. Los estados más antiguos se eliminan automáticamente para liberar memoria en Photoshop. Para conservar un estado determinado durante toda la sesión de trabajo, realice una instantánea de dicho estado (consulte Realización de una instantánea de una imagen).

  • Después de cerrar y volver abrir el documento, todos los estados e instantáneas de la última sesión de trabajo desaparecen del panel.

  • Por defecto, aparece una instantánea del estado inicial del documento en la parte superior del panel.

  • Los estados se van añadiendo a la parte inferior de la lista. Es decir, el último estado se encuentra en la parte superior de la lista y el más reciente, en la parte inferior.

  • Cada estado aparece enumerado con el nombre de la herramienta o comando utilizado para modificar la imagen.

  • Por defecto, al seleccionar un estado, los estados situados por debajo aparecen atenuados. De esta forma se ven claramente los cambios que se descartarán si continúa trabajando desde el estado seleccionado.

  • Por defecto, al seleccionar un estado y, a continuación, cambiar la imagen, se eliminan todos los estados posteriores.

  • Si selecciona un estado y, a continuación, modifica la imagen, eliminando los estados posteriores, puede utilizar el comando Deshacer para deshacer el último cambio y restaurar los estados eliminados.

  • Por defecto, al eliminar un estado se elimina ese estado y todos los siguientes. Si elige la opción Permitir historia no lineal, al eliminar un estado solo se elimina ese estado.

Vuelta a un estado anterior de la imagen

  1. Realice una de las siguientes acciones:
    • Haga clic en el nombre del estado.

    • Seleccione Paso adelante o Paso atrás en el menú del panel Historia o en el menú Edición para ir al estado anterior o siguiente.

Eliminación de uno o varios estados de imagen

  1. Realice una de las siguientes acciones:
    • Haga clic en el nombre del estado y seleccione Eliminar en el menú del panel Historia para eliminar ese cambio y los que lo siguieron.

    • Arrastre el estado al icono Eliminar  para borrar ese cambio y los que lo siguieron.

    • Seleccione Borrar historia del menú del panel para eliminar la lista de estados del panel Historia sin cambiar la imagen. Esta opción no reduce la cantidad de memoria usada por Photoshop.

    • Mantenga pulsada la tecla Alt (Windows) u Opción (Mac OS) y escoja Borrar historia del menú del panel para purgar la lista de los estados sin modificar la imagen. Si aparece un mensaje indicando que Photoshop no tiene suficiente memoria, purgar estados resulta útil ya que el comando elimina los estados del búfer de Deshacer y libera memoria. El comando Borrar historia no puede deshacerse.

    • Seleccione Edición > Purgar > Historias para purgar la lista de estados en todos los documentos abiertos. Esta acción no puede deshacerse.

Creación de un documento con un estado de imagen o reemplazarlo por un estado de imagen

  1. Realice una de las siguientes acciones:
    • Arrastre un estado o una instantánea al botón Crear un documento nuevo desde el estado actual  del panel Historia. La lista de historia del documento recién creado solo contiene la entrada Duplicar estado.

    • Seleccione un estado o una instantánea y haga clic en el botón Crear un documento nuevo desde el estado actual . La lista de historia del documento recién creado solo contiene la entrada Duplicar estado.

    • Seleccione un estado o una instantánea y elija Nuevo documento en el menú del panel Historia. La lista de historia del documento recién creado solo contiene la entrada Duplicar estado.

    • Arrastre un estado hasta un documento existente.

    Nota:

    Para guardar una o varias instantáneas o estados de imagen para utilizarlos en una sesión de edición posterior, cree un nuevo archivo para cada uno de los estados que guarde y guarde cada uno en un archivo diferente. Cuando vuelva a abrir el archivo original, también piense en abrir los otros archivos guardados. Puede arrastrar la instantánea inicial de cada archivo hasta la imagen original y volver a acceder a las instantáneas desde del panel Historia de la imagen original.

Definición de las opciones de historia

Puede especificar el número máximo de elementos que desea incluir en el panel Historia y definir otras opciones para personalizar el panel.

  1. Elija Opciones de historia en el menú del panel Historia.
  2. Seleccione una de estas opciones:

    Crear automáticamente primera instantánea

    Crea automáticamente una instantánea del estado inicial de la imagen al abrir el documento.

    Crear automáticamente nueva instantánea al guardar

    Genera una instantánea cada vez que se guarda.

    Permitir historia no lineal

    Realiza cambios en un estado seleccionado sin eliminar los estados siguientes. Normalmente, cuando selecciona un estado y modifica la imagen, se eliminan todos los estados que le siguen. De esta manera, el panel Historia puede mostrar una lista de los pasos de edición en el orden en el que se realizaron. Al grabar estados de forma no lineal, puede seleccionar un estado, hacer un cambio en la imagen y eliminar solo ese estado. El cambio se añade al final de la lista.

    Mostrar por defecto el cuadro de diálogo Nueva instantánea

    Hace que Photoshop le solicite los nombres de instantáneas aunque utilice los botones del panel.

    Hacer permanentes los cambios de visibilidad de capa

    Esta es la opción seleccionada por defecto. La activación y desactivación de la visibilidad se registra como paso de historia. Deseleccione esta opción para excluir los cambios de visibilidad de las capas en los pasos de historia.

Configuración de las opciones del registro de historia de edición

Puede que necesite realizar un seguimiento de las operaciones realizadas en un archivo Photoshop, por su propio interés, por el de sus clientes o por motivos legales. El registro de historia de edición facilita el mantenimiento de un historial textual de los cambios realizados en una imagen. Puede ver los metadatos del registro de historia de edición mediante Adobe Bridge o el cuadro de diálogo Información de archivo.

Puede optar por exportar el texto en un archivo de registro externo o bien almacenar la información en los metadatos de los archivos editados. El almacenamiento de numerosas operaciones de edición como metadatos de archivo aumenta el tamaño de archivo; estos archivos pueden tardar más de lo normal en abrirse y guardarse.

Nota:

Si necesita demostrar que el archivo de registro no se ha manipulado, conserve el registro de edición en los metadatos del archivo y utilice Adobe Acrobat para firmar digitalmente el archivo de registro.

Por defecto, los datos del registro de historia sobre cada sesión se guardan como metadatos incrustados en el archivo de imagen. Puede especificar dónde guardar los datos del registro de historia y el nivel de detalle del registro.

  1. Elija Edición > Preferencias > Generales (Windows) o Photoshop > Preferencias > Generales (Mac OS).
  2. Haga clic en la preferencia Registro de historia para activarla o desactivarla.
  3. En la opción Guardar elementos de registro en, seleccione uno de los siguientes:

    Metadatos

    Guarda el registro de historia como metadatos incrustados en cada archivo.

    Archivo de texto

    Exporta el registro de historia a un archivo de texto. Deberá dar un nombre al archivo de texto y seleccionar una ubicación donde almacenarlo.

    Ambos

    Almacena metadatos en el archivo y crea un archivo de texto.

    Nota:

    Si desea guardar el archivo de texto en otra ubicación o guardar otro archivo de texto, haga clic en el botón Elegir, especifique dónde desea guardar el archivo de texto, asígnele un nombre si es necesario y haga clic en Guardar.

  4. En el menú Editar elementos de registro, seleccione una de las opciones siguientes:

    Solo sesiones

    Conserva un registro de todas las veces que entra o sale de Photoshop y de las veces que abre y cierra archivos (incluye el nombre de archivo de cada imagen). No incluye información sobre las ediciones realizadas en el archivo.

    Conciso

    Incluye el texto que aparece en el panel Historia además de la información de Sesiones.

    Detallado

    Incluye el texto que aparece en el panel Acciones además de la información de Conciso. Si necesita una historia completa de todos los cambios realizados en los archivos, seleccione Detallado.

Realización de una instantánea de una imagen

El comando Instantánea le permite realizar una copia temporal (o instantánea) de cualquier estado de la imagen. La nueva instantánea se añade a la lista de instantáneas situada en la parte superior del panel Historia. Seleccionar una instantánea le permite trabajar a partir de esa versión de la imagen.

Las instantáneas son parecidas a los estados del panel Historia, pero ofrecen ventajas adicionales:

  • Puede asignar un nombre a las instantáneas para que sea más sencillo identificarlas.

  • Las instantáneas se pueden almacenar durante toda la sesión de trabajo.

  • Los efectos se pueden comparar con facilidad. Por ejemplo, puede realizar una instantánea antes y después de aplicar un filtro. A continuación, seleccione la primera instantánea y pruebe el mismo filtro con diferentes ajustes. Puede alternar las instantáneas para buscar los ajustes que más le gusten.

  • Con las instantáneas puede recuperar su trabajo con facilidad. Antes de probar con una técnica compleja o aplicar una acción, realice una instantánea. Si no está satisfecho con los resultados, puede seleccionar la instantánea para deshacer todos los pasos.

Nota:

Las instantáneas no se guardan con la imagen; al cerrar la imagen se eliminan las instantáneas. Asimismo, a menos que se seleccione la opción Permitir historia no lineal, si selecciona una instantánea y modifica la imagen, se eliminan todos los estados de la lista actual del panel Historia.

Creación de una instantánea

  1. Seleccione un estado y realice una de las siguientes acciones:
    • Para crear una instantánea de manera automática, haga clic en el botón Crear instantánea nueva  del panel Historia o, si se ha seleccionado Crear automáticamente nueva instantánea al guardar en las opciones de historia, elija Nueva instantánea en el menú del panel Historia.

    • Para definir las opciones al crear una instantánea, seleccione Nueva instantánea en el menú del panel Historia o pulse Alt (Windows) u Opción (Mac OS) y haga clic en el botón Crear instantánea nueva.

  2. Introduzca el nombre de la instantánea en el cuadro de texto Nombre.

  3. Seleccione el contenido de la instantánea en el menú Desde:

    Documento entero

    Realiza una instantánea de todas las capas de la imagen en ese estado.

    Capas combinadas

    Realiza una instantánea que combina todas las capas de la imagen en ese estado.

    Capa actual

    Realiza una instantánea solo de la capa seleccionada actualmente en ese estado.

Trabajo con instantáneas

  1. Realice una de las siguientes acciones:
    • Para seleccionar una instantánea, haga clic en el nombre de la instantánea o arrastre el regulador situado a la izquierda de la instantánea hacia arriba o hacia abajo hasta otra instantánea.

    • Para cambiar el nombre de una instantánea, haga doble clic en la instantánea e introduzca un nombre.

    • Para eliminar una instantánea, selecciónela y elija Eliminar en el menú del panel, haga clic en el icono Eliminar  o arrastre la instantánea al icono Eliminar.

Pintura con un estado o una instantánea de una imagen

La herramienta Pincel de historia  permite pintar una copia de un estado o una instantánea de la imagen en la ventana de la imagen actual. Esta herramienta realiza una copia o muestra de la imagen y, a continuación, pinta con ella.

Por ejemplo, puede realizar una instantánea de un cambio realizado con una herramienta de pintura o filtro (con la opción Documento entero seleccionada al crear la instantánea). Tras deshacer el cambio en la imagen, puede utilizar la herramienta Pincel de historia para aplicar el cambio de forma selectiva en áreas de la imagen. A menos que seleccione una instantánea combinada, la herramienta Pincel de historia pinta de una capa del estado seleccionado en la misma capa de otro estado.

La herramienta Pincel de historia copia de un estado o instantánea a otro, pero solo en la misma ubicación. En Photoshop, también puede pintar con la herramienta Pincel histórico para crear efectos especiales.

  1. Seleccione la herramienta Pincel de historia .
  2. Realice una de las acciones siguientes:
    • Especifique la opacidad y el modo de fusión.

    • Elija un pincel y defina las opciones del mismo.

  3. En el panel Historia, haga clic en la columna izquierda del estado o instantánea que se utilizará como origen de la herramienta Pincel de historia.
  4. Arrastre para pintar con la herramienta Pincel de historia.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea