בעיה

כשאתה מחובר לחשבון משתמש מסוים במחשב Macintosh או במחשב שבו פועל Windows 7 ואילך, יישום Adobe מתנהג בצורה לא צפויה.לדוגמה, היישום לא פועל, מבצע פקודות באופן שגוי, מחזיר שגיאות או נסגר באופן בלתי צפוי. הבעיות אינן מתרחשות כשאתה מתחבר לחשבון משתמש אחר.

לפני שתתחיל

Mac OS

צור עותק גיבוי של דיסק האתחול לפני שתתחיל לבצע את המשימות המתוארות במסמך זה.

כשאתה מבצע כמה מהצעדים המתוארים במסמך זה, ה-Finder מציג חלון Authenticate (אימות). כשמופיע חלון Authenticate (אימות), הזן את שם המשתמש והסיסמה של חשבון מנהל מערכת, ולאחר מכן לחץ על OK (אישור).

יש הרבה גורמים אפשריים שעשויים להוביל להתנהגות בלתי צפויה בחשבון מסוים. מסמך זה מטפל רק בגורמים הנפוצים ביותר. לקבלת עזרה נוספת בפתרון בעיות בחשבונות של משתמשים פנה לתמיכה של Apple.

Windows

גבה את כונן המערכת שלך לפני שתתחיל לבצע את המשימות המתוארות במסמך זה.

מדי פעם משימות אלו פותחות תיבת דו-שיח מסוג User Account Control (בקרת חשבון משתמש), בה תתבקש לתת אישור כדי להמשיך. קרא את הפרטים בתיבת הדו-שיח כדי להחליט אם תרצה להמשיך. אם תבחר לבטל את תיבת הדו-שיח, לא תוכל להמשיך במשימה.

חלק מהמשימות המתוארות במסמך מזכירות עבודה עם תיקיות נסתרות. כברירת מחדל, Windows Explorer לא מציג תיקיות מוסתרות. כדי שהתיקיות המוסתרות יהיו גלויות, ראה הצגת קבצים, תיקיות וסיומות שמות קבצים | Windows XP‏, Windows Vista‏, Windows 7.

יש הרבה גורמים אפשריים שעשויים להוביל להתנהגות בלתי צפויה בחשבון מסוים. מסמך זה מטפל רק בגורמים הנפוצים ביותר. לקבלת סיוע נוסף בפתרון בעיות עם חשבונות משתמשים, פנה ליצרן המחשב או עבור לאתר העזרה והתמיכה של Microsoft בכתובת http://support.microsoft.com.

פתרונות

התחבר לחשבון המשתמש שבו היישום של Adobe מתנהג באופן לא צפוי. לאחר מכן בצע את המשימות הבאות לפי הסדר:

Mac OS

1. תן הרשאות קריאה-כתיבה בתיקיות מתאימות.

ודא שלחשבון המשתמש יש הרשאות קריאה-כתיבה בתיקיות הבאות:

  • ‎/Applications/Adobe
  • ‎/Applications/.AdobePatchFiles (מוסתרת, השתמש בפקודה Go > Go to Folder (עבור > עבור לתיקייה)
  • ‎/Applications/Utilities/Adobe
  • /Library/Application Support/Adobe
  • ‎/Library/Preferences/com.adobe
  • ‎/Users/[user]/Library/Application Support/Adobe
  • ‎/Users/[user]/Library/Caches/Adobe
  • ‎/Users/[user]/Library/Caches/com.adobe
  • ‎/Users/[user]/Library/Preferences/Adobe
  • ‎/Users/[user]/Library/Preferences/com.adobe

לאחר מתן ההרשאות, כדי שהשינויים יחולו, התנתק מחשבון המשתמש והתחבר מחדש או הפעל מחדש את המחשב.

2. צור מחדש את קובצי ההעדפות הספציפיים לחשבון אשר מתייחסים ליישום של Adobe.

יישומי Adobe מאחסנים את ההגדרות המותאמות אישית של משתמש מסוים בקובצי העדפות. לכל חשבון משתמש יש סדרת קובצי העדפות משלו.

כאשר יישום מסוים של Adobe מתנהג באופן בלתי צפוי רק בחשבון משתמש ספציפי, ייתכן שאחד מקובצי ההעדפות של היישום פגום. באפשרותך לשנות את שם התיקייה הנוכחית, וכך היישום של Adobe ייאלץ ליצור קובצי העדפות לא פגומים. יישומי Adobe מסוימים מאחסנים מספר קובצי העדפות בתוך תיקייה; אם מדובר ביישומים אלה - באפשרותך לשנות את שם התיקייה.

חלק מיישומי Adobe שומרים העדפות גם בתיקיות וגם בקבצים עצמאיים. לדוגמה, \Adobe Photoshop CS4 משתמש הן בקובץ העדפות בשם com.adobe.Photoshop.plist והן בתיקיית העדפות בשם Adobe Photoshop CS4 Settings. כדי לאלץ את Photoshop CS4 ליצור קובצי העדפות לא פגומים, שנה את שמותיהם של שני הפריטים הללו. לדוגמה, שנה את שמותיהם ל-Old com.adobe.Photoshop.plist ול-Old Adobe Photoshop CS4 Settings, בהתאמה.

באופן כללי, יישומי Adobe מאחסנים תיקיות וקובצי העדפות באחד או יותר מהמיקומים הבאים:

  • ‎/Users/[user name]/Library/Preferences
  • ‎/Users/[user name]/Library/Preferences/Adobe
  • ‎/Users/[user name]/Library/Application Support/Adobe

חשוב: כברירת מחדל, Apple הגדירה את התיקייה של ספריית המשתמש כמוסתרת בעת השקת Mac OS X 10.7. אם דרושה לך גישה לקבצים בתיקיית הספרייה המוסתרת כדי לפתור בעיות הקשורות ל-Adobe, ראה כיצד לגשת לקבצים בספריית המשתמש המוסתרת.

חלק מיישומי Adobe מאחסנים קובצי העדפות נוספים במיקומים אחרים. לדוגמה, Adobe Premiere Pro CS4 מאחסן קובצי העדפות נוספים בתיקיות בשמות Layouts‏, Settings ו-Styles. קבצים אלה ממוקמים בתוך ‎/Users/[user name]/Documents/Adobe/Premiere Pro/4.0.

כדי לדעת מהם השמות והמיקומים המדויקים של קובצי ותיקיות ההעדפות של יישום Adobe שעבורו אתה פותר את הבעיות, עבור אל www.adobe.com/support. חפש במאגר המידע של התמיכה את מונח החיפוש preferences ואת שם וגרסת היישום. לאחר מכן עיין במסמך System Errors or Freezes או במסמכים אחרים שיופיעו ברשימת תוצאות החיפוש.

כדי ליצור מחדש את קובצי ההעדפות ליישום Adobe, בצע את הפעולות הבאות:

  1. צא מהיישום Adobe.
  2. שנה את שם קובצי ותיקיות ההעדפות של היישום של Adobe.
  3. פתח את היישום של Adobe. היישום יוצר קובצי העדפות.

אחרי שיצרת מחדש את קובצי ותיקיות ההעדפות, נסה לשחזר את הבעיה.

אם הבעיה ממשיכה להתרחש, הסיבה אינה קובץ העדפות פגום. כדי לשחזר את ההגדרות המותאמות אישית של חשבון המשתמש, מחק את קובצי ותיקיות ההעדפות החדשים. לאחר מכן שחזר את השמות המקוריים של כל הפריטים שאת שמותיהם שינית.

אם הבעיה לא מתרחשת יותר, הסיבה הייתה קובץ העדפות פגום. עם זאת, ההגדרות המותאמות אישית שהיו קשורות לקובצי ההעדפות הקודמים הולכות לאיבוד.

3. פתרון בעיות עם גופנים הספציפיים לחשבון.

ב-Mac OS ניתן להתקין גופנים בכל חשבונות המשתמשים או רק בחשבון משתמש ספציפי. קובצי גופנים ספציפיים לחשבון ממוקמים תחת ‎/Users/[user name]/Library/Fonts.

כאשר יישום מסוים של Adobe מתנהג באופן בלתי צפוי רק בחשבון ספציפי, הגורם עשוי להיות קובץ גופנים פגום שמותקן רק בחשבון זה.

השתמש ביישום Font Book, אשר כלול במערכת Mac OS X, כדי להשבית זמנית את כל הגופנים הספציפיים לחשבון. אחרי שתשבית את הגופנים הספציפיים לחשבון, חפש ומחק את קובצי מטמון הגופנים של Adobe. בצעו את הפעולות הבאות:

  1. צא מכל היישומים הפתוחים.
  2. אם, לצורך הפעלה והשבתה של גופנים, אתה בדרך-כלל משתמש בתוכנית שירות לניהול גופנים של צד שלישי - השבת זמנית את תוכנית השירות הזו. לקבלת הוראות עיין בתיעוד שלה.
  3. פתח את Font Book. (כברירת מחדל, Font Book ממוקם בתיקייה Applications.)
  4. בעמודה Collection (אוסף) בחר User (משתמש). לאחר מכן בצע אחת מהפעולות הבאות:

    • אם עמודת הגופנים ריקה - בחשבון משתמש זה לא מותקנים גופנים ספציפיים לחשבון. דלג על שאר חלקי משימה זו והתקדם אל משימה 3.
    • אם לפחות גופן אחד מופיע בעמודת הגופנים, בחר Edit (עריכה) > Disable "User"‎ (השבת "משתמש").
  5. ב-Finder, בחר File (קובץ) > Find (חיפוש). אפשרויות החיפוש מופיעות בחלק העליון של החלון הקדמי ביותר ב-Finder.

  6. חפש קובצי מטמון גופנים של Adobe על-ידי הגדרת אפשרויות החיפוש באופן הבא:

    • Mac OS X v.10.4.x: בשורה העליונה של אפשרויות החיפוש, בחר Home (בית). בשורה השנייה בחר Name (שם) ו-Begins With (מתחיל ב-) בשני התפריטים הקופצים. לאחר מכן הקלד AdobeFnt בתיבת הטקסט שמימין ל-Begins With (מתחיל ב-).
    • Mac OS X v.10.5.x: בשורה העליונה של אפשרויות החיפוש, בחר את שם חשבון המשתמש (שמופיע בין מרכאות). בשורה השנייה בחר Name (שם) ו-Begins With (מתחיל ב-) בשני התפריטים הקופצים. לאחר מכן הקלד AdobeFnt בתיבת הטקסט שמימין ל-Begins With (מתחיל ב-).
  7. בתוצאות החיפוש מחק את כל הקבצים ששמותיהם מתחילים ב-AdobeFnt ומסתיימים ב-.lst.

  8. פתח את היישום של Adobe ונסה לשחזר את הבעיה.

אם הבעיה עדיין מתרחשת, הגורם אינו גופן ספציפי לחשבון. הפעל מחדש את הגופנים הספציפיים לחשבון על-ידי פתיחת Font Book, בחירת משתמש בעמודה Collection (אוסף) ובחירת Edit (עריכה) > Enable (הפעל). לאחר מכן התקדם אל משימה 3.

אם הבעיה לא מתרחשת יותר, הגורם הוא גופן ספציפי לחשבון. כדי לזהות את קובץ הגופן המדויק שגורם לבעיה בצע את הפעולות הבאות:

  1. פתח את Font Book.

  2. בעמודה Collection (אוסף) בחר User (משתמש).

  3. בעמודה Font (גופן) בחר אחד מהגופנים המושבתים.

  4. בחר Edit (עריכה) > Enable [Font Name]‎ (הפעל את [שם גופן]).

  5. פתח את היישום של Adobe ונסה לשחזר את הבעיה. לאחר מכן בצע אחת מהפעולות הבאות:

    • אם הבעיה ממשיכה להתרחש, צא מיישום Adobe ואז חזור על שלבים 3 עד 5.
    • אם הבעיה לא מתרחשת יותר, הגורם הוא הגופן האחרון שהפכת לזמין מחדש. השאר את הגופן במצב מושבת; לחלופין, מחק גופן זה ופנה למפרסם הגופן לקבלת קובץ גופן חלופי.

4. מחק קובצי מטמון של Adobe שספציפיים לחשבון.

יישומים מסוימים של Adobe יוצרים קובצי נתונים זמניים, אשר מכונים קובצי מטמון. קובצי מטמון רבים מדי או פגומים בחשבון משתמש עשויים לגרום ליישום Adobe להתנהג באופן לא צפוי.

בצעו את הפעולות הבאות:

  1. צא מכל יישומי Adobe.

  2. ב-Finder, נווט אל ‎/Users/[user name]/Library/Caches.

  3. בתיקייה Caches (מטמון), מחק את התיקייה Adobe.

  4. מחק את כל שאר התיקיות בתוך התיקייה Caches שנקראות בשם היישום של Adobe שלגביו אתה פותר את הבעיה.

  5. מחק את כל שאר התיקיות בתוך התיקייה Caches שנקראות בשם הרכיבים של היישום של Adobe שלגביו אתה פותר את הבעיה. לדוגמה, אם אתה פותר בעיות עבור Photoshop CS4, מחק גם את התיקייה Adobe Camera Raw בתוך התיקייה Caches.

  6. פתח את היישום של Adobe ונסה לשחזר את הבעיה.

אם הבעיה ממשיכה, התקדם למשימה הבאה.

5. פתרון בעיות עם פריטי התחברות הספציפיים לחשבון.

פריטי התחברות הם יישומים או מסמכים שנפתחים אוטומטית כשאתה מתחבר לחשבון של משתמש. (הם אף נפתחים אוטומטית כשאתה מפעיל את המחשב, אם אפשרות ההתחברות האוטומטית מופעלת אצלך.) חלק מפריטי ההתחברות מוסתרים לאחר פתיחתם. כאשר יישום Adobe פועל באופן בלתי צפוי בחשבון מסוים, ייתכן שאחד מפריטי ההתחברות של החשבון אינו פועל כהלכה, פגום, או לא מתאים ליישום של Adobe.

כדי לקבוע אם אחד מפריטי ההתחברות של חשבון המשתמש גורם לבעיה ביישום Adobe, בצע את הפעולות הבאות:

  1. בחר Apple Menu ‏> Log Out [User Name]‎.

  2. בתיבת הדו-שיח של האישור לחץ על Log Out (התנתק). כעבור מספר דקות יופיע חלון ההתחברות.

  3. בחלון ההתחברות בחר את שם חשבון המשתמש שבו אתה פותר בעיות.

  4. הקלד את הסיסמה של חשבון המשתמש בתיבת הטקסט Password (סיסמה); אךאל תקיש על Return ואל תלחץ על Log In (התחבר) עדיין.

  5. השאר את מקש Shift לחוץ ולחץ על Log In (התחבר). שחרר את מקש Shift כשתופיע תחנת העגינה. פריטי ההתחברות יושבתו עד שתתנתק מהמערכת (או תפעיל מחדש את המחשב).

  6. פתח את היישום של Adobe ונסה לשחזר את הבעיה.

אם הבעיה ממשיכה להתרחש, הסיבה אינה פריט התחברות. התנתק כדי להפוך את פריטי ההתחברות לזמינים מחדש (דרך Apple Menu (תפריט Apple) ‏> Log Out [User Name] (התנתקות [שם משתמש])). לאחר מכן התחבר מחדש לאותו חשבון מבלי להחזיק את מקש ה-Shift לחוץ. לאחר מכן התקדם אל משימה 5.

אם הבעיה לא מתרחשת יותר, הגורם הוא פריט התחברות. כדי לזהות את פריט ההתחברות הספציפי שגורם לבעיה בצע את הפעולות הבאות:

אם הבעיה עדיין מתרחשת, הגורם אינו גופן ספציפי לחשבון. הפעל מחדש את הגופנים הספציפיים לחשבון על-ידי פתיחת Font Book, בחירת משתמש בעמודה Collection (אוסף) ובחירת Edit (עריכה) > Enable (הפעל). לאחר מכן התקדם אל משימה 3.

אם הבעיה לא מתרחשת יותר, הגורם הוא גופן ספציפי לחשבון. כדי לזהות את קובץ הגופן המדויק שגורם לבעיה בצע את הפעולות הבאות:

  1. בחר Apple Menu (תפריט Apple) ‏> Log Out [User Name]‎ (התנתקות [שם משתמש])).

  2. היכנס בחזרהאלבאותו חשבון. אל תחזיק את המקש Shift לחוץ.

  3. בחר Apple Menu (תפריט Apple) ‏> System Preferences (העדפות מערכת).

  4. בחלון System Preferences (העדפות מערכת) לחץ על Accounts (חשבונות).

  5. אם סמל המנעול בתחתית החלון נראה נעול, לחץ על הסמל ובצע אימות.

  6. בחר את שם חשבון המשתמש שבו אתה פותר בעיות.

  7. לחץ על הכרטיסייה Login Items (פריטי התחברות).

  8. ערוך רשימה של פריטי ההתחברות הנוכחיים.

  9. בחר פריט התחברות והקש Delete.

  10. פתח את היישום של Adobe ונסה לשחזר את הבעיה. לאחר מכן בצע אחת מהפעולות הבאות:

    • אם הבעיה ממשיכה להתרחש, צא מיישום Adobe ואז חזור על שלבים 9 ו-10.
    • אם הבעיה לא מתרחשת יותר, הגורם הוא פריט ההתחברות האחרון שמחקת. פנה למפרסם של פריט ההתחברות כדי לקבל מידע על זמינות הגרסה המעודכנת. שחזר את פריטי ההתחברות האחרים על-ידי גרירת סמליהם לאזור פריטי ההתחברות בהעדפות המערכת. לחלופין, התקן מחדש את היישום הקשור לפרטי ההתחברות.

6. אפס את הגדרות הגישה בתיקייה Library של חשבון המשתמש.

השלם את המשימה רק אם החשבון שבו אתה פותר בעיות הוא חשבון מנהל מערכת ולחשבון יש סיסמה.

לכל קובץ ותיקייה באמצעי אחסון של Mac OS X יש הגדרות הרשאה ובעלות בסגנון Unix. הגדרות אלו קובעות לאילו חשבונות משתמשים תהיה גישה לקובץ או לתיקייה ולאיזה חשבונות לא תהיה גישה.

יישום Adobe יכול להתנהג באופן בלתי צפוי בחשבון מסוים אם הגדרות הגישה שלו לתיקייה Library שלו (או לתיקיית-משנה) פגומות או מוגבלות בשוגג. תוכל להשתמש בפקודות ה-Unix ‏chmod ו-chown כדי לתקן הגדרות אלו. בצעו את הפעולות הבאות:

  1. ב-Finder, בחר Go ‏> Home. החלון הקדמי ביותר של frontmost עובר לתיקיית Home של חשבון המשתמש. רשום לעצמך את השם בכותרת של חלון Finder זה. שם זה הוא "שם המשתמשהקצר" עבור חשבון המשתמש. (שם משתמשקצר זה דרוש להשלמת שלב 3.)

  2. פתח את היישום Terminal, שכברירת מחדל ממוקם תחת ‎/Applications/Utilities.

  3. כשאחת מהפקודות הבאות משמשת כתבנית, הקלד פקודה ממשית בחלון ה-Terminal ואז הקש Return. אחרי שתקיש Return בסוף הפקודה, תראה הנחיה להזנת סיסמה. הקלד את הסיסמה לחשבון המשתמש והקש Return פעם נוספת. כשתקליד כל אחד מתווי הסיסמה לא תקבל משוב כלשהו, כגון כוכביות. זוהי התנהגות רגילה.)

    חשוב: כל אחת מהפקודות הבאות היא תבנית, לא הפקודה שאותה אתה מקליד בפועל. בפקודה שתקליד בפועל, החלף את שם המשתמש בשם המשתמש המקוצר שזיהית בשלב 1. הקלד את שם המשתמש המקוצר באותיות קטנות. (במערכת Mac OS X v10.4.x, הקלד את שם המשתמש המקוצר פעמיים, עם נקודתיים להפרדה. במערכת Mac OS X v.10.5.x, הקלד את שם המשתמש המקוצר ולאחריו נקודתיים ואת המילה staff.)

    פקודת תבנית עבור Mac OS X v.10.4.x:


    sudo chown-R username:username~/Library

    פקודת תבנית עבור Mac OS X v.10.5.x:

    sudo chown-R username:staff~/Library

  4. הקלד את הפקודה שלהלן בדיוק כפי שהיא מופיעה, ולאחר מכן הקש Return.

    sudo chmod -R 700 ~/Library

  5. סגור את Terminal.

  6. פתח את היישום של Adobe ונסה לשחזר את הבעיה.

אם הבעיה ממשיכה, התקדם למשימה הבאה.

7. תקן את דיסק האתחול.

פגם בדיסק שמשפיע רק על חשבון משתמש מסוים עלול לגרום להתנהגות בלתי צפויה של יישום Adobe באותו חשבון.

בצע את הפעולות שלהלן אם דיסק ההתקנה של Mac OS X שהגיע עם המחשב נמצא ברשותך. אם דיסק זה אינו ברשותך, תוכל לתקן את דיסק האתחול בעזרת הפקודה fsck ב-Terminal. לחלופין תוכל להשתמש בתוכנית שירות של צד שלישי המיועדת לתיקון דיסקים. לקבלת הוראות על השימוש בפקודה fsck עיין במאמר TS1417 באתר התמיכה של Apple. לקבלת הוראות על השימוש בתוכנית שירות של צד שלישי לצורך תיקון דיסק, עיין בתיעוד של תוכנית השירות.

  1. הכנס את דיסק ההתקנה של Mac OS X לכונן האופטי של המחשב.
  2. בחר Apple Menu (תפריט Apple) ‏> Restart (הפעלה מחדש).
  3. כשתשמע את צליל האתחול, התחל להחזיק את המקש C במקלדת לחוץ.
  4. כשתראה את חלון האתחול עם סרגל ההתקדמות, שחרר את המקש C.
  5. אם תוכנית ההתקנה של Mac OS X מנחה אותך לבחור שפה, בחר את השפה המועדפת עליך.
  6. כשתפריט תוכנית ההתקנה יהפוך לזמין (בחלקו השמאלי העליון של המסך), בחר Installer (תוכנית התקנה) > Disk Utility (תוכנית שירות לדיסקים).
  7. תחת Disk Utility בחר את דיסק האתחול בצד שמאל.
  8. לחץ על First Aid (עזרה ראשונה)תחתבצד שימין.

  9. לחץ על Repair Disk (תיקון דיסק).

  10. אם בסיום תהליך התיקון מתקבל חיווי שתוקנו שגיאות בדיסק, חזור על שלב 9. אחרי שתהליך התיקון יסתיים מבלי שמתקבל דיווח על שגיאות שנמצאו, פתח את היישום של Adobe ונסה לשחזר את הבעיה.

אם הבעיה ממשיכה, התקדם למשימה הבאה.

8. השתמש בחשבון משתמש חדש.

אם היישום עדיין מתנהג באופן לא צפוי בחשבון מסוים, Adobe ממליצה שתעתיק (או תעביר) את כל הקבצים האישיים לחשבון משתמש חדש. לאחר מכן השתמש בחשבון החדש בתור חשבונך הרגיל.

לקבלת עזרה בהעתקת קבצים אישיים לחשבון משתמש חדש, פנה לתמיכה של Apple.

Windows

1. תן הרשאות קריאה-כתיבה בתיקיות מתאימות.

ודא שלחשבון המשתמש יש הרשאות קריאה-כתיבה בתיקיות הבאות:

  • C:\Program Files\Adobe
  • C:\Program Files\Common Files\Adobe
  • C:\Program Files (x86)\Adobe
  • C:\Program Files (x86)\Common Files\Adobe
  • C:\ProgramData\Adobe
  • C:\Users\\AppData\Roaming\Adobe
  • C:\Users\\AppData\Roaming\com.adobe.
  • C:\Users\\AppData\Local\Adobe
  • C:\Users\\AppData\LocalLow\Adobe
  • C:\Users\\AppData\Local\VirtualStore\Program Files\Common Files\Adobe

2. צור מחדש את קובצי ההעדפות הספציפיים לחשבון אשר מתייחסים ליישום של Adobe.

יישומי Adobe מאחסנים את ההגדרות המותאמות אישית של משתמש מסוים בקובצי העדפות. לכל חשבון משתמש יש סדרת קובצי העדפות משלו.

כאשר יישום מסוים של Adobe מתנהג באופן בלתי צפוי רק בחשבון משתמש ספציפי, ייתכן שהגורם הוא פגם באחד מקובצי ההעדפות של היישום. באפשרותך לשנות את שם התיקייה שבה שמורים קובצי ההעדפות, וכך היישום של Adobe ייאלץ ליצור קובצי העדפות לא פגומים.

לדוגמה, Adobe Premiere Pro CS4 שומר קובצי העדפות בתיקייה ששמה 4.0, אשר ממוקמת בכתובת C:\Users\[user name]\AppData\Roaming\Adobe\Premiere Pro. כדי לאלץ את Adobe Premiere Pro CS4 ליצור מחדש את קובצי ההעדפות, שנה את שם התיקייה 4.0 (למשל, שנה אותו ל-Old 4.0).

באופן כללי, יישומי Adobe מאחסנים תיקיות וקובצי העדפות באחד מהמיקומים הבאים או בשניהם:

  • C:\Users\[user name]\AppData\Roaming\Adobe
  • C:\Users\[user name]\AppData\Local\Adobe

חלק מיישומי Adobe מאחסנים קובצי העדפות נוספים במיקומים אחרים. לדוגמה, Adobe Premiere Pro CS4 מאחסן קובצי העדפות נוספים בתיקיות בשמות Styles ו-Layouts, אשר ממוקמות בכתובת C:\Users\[user name]\Documents\Adobe\Premiere Pro\4.0.

כדי לדעת מהם השמות והמיקומים המדויקים של תיקיות ההעדפות של יישום Adobe שעבורו אתה פותר את הבעיות, עבור אל www.adobe.com/support.חפש במאגר המידע של התמיכה את מונח החיפוש preferences ואת שם וגרסת היישום. לאחר מכן, עייןבמסמך"System Errors or Freezes" או במסמכים אחרים שיופיעו ברשימת תוצאות החיפוש.

כדי ליצור מחדש את קובצי ההעדפות ליישום Adobe, בצע את הפעולות הבאות:

  1. סגור את היישום של Adobe.

  2. שנה את שם תיקיות ההעדפות של היישום של Adobe.

  3. הפעל את היישום של Adobe. היישום יוצר קובצי העדפות לא פגומים.

אחרי שיצרת מחדש את קובצי ההעדפות, נסה לשחזר את הבעיה.

אם הבעיה ממשיכה להתרחש, הסיבה אינה קובץ העדפות פגום. כדי לשחזר את ההגדרות המותאמות אישית של יישום Adobe בחשבון המשתמש, מחק את תיקיות ההעדפות החדשות. לאחר מכן שחזר את השמות המקוריים של התיקיות שאת שמותיהם שינית.

אם הבעיה לא מתרחשת יותר, הסיבה הייתה קובץ העדפות פגום. (לחשבון המשתמש אין את ההגדרות המותאמות אישית שהיו קשורות לקובצי ההעדפות הקודמים.)

3. מחק קבצים זמניים שספציפיים לחשבון.

חלק מיישומי Adobe מאחסנים נתונים בקבצים זמניים. אם הקבצים הזמניים הספציפיים לחשבון רבים מדי, מיושנים או פגומים - יישום Adobe עשוי להתנהג באופן בלתי צפוי.

כדי למחוק קבצים זמניים השתמש בתוכנית העזר לניקוי. ראה מחיקת קבצים זמניים באמצעות תוכנית העזר לניקוי (Windows 7 ו-Windows Vista).

כברירת מחדל, תוכנית העזר לניקוי אינה מוחקת קבצים בתיקייה הזמנית הספציפית לחשבון שבוצעה אליה גישה בשבעת הימים האחרונים. תוכל לבצע הסרה מקיפה יותר של קבצים זמניים על-ידי מחיקת תכולת התיקייה הזמנית באופן ידני.

הגבלת אחריות: אם תמחק את תכולת התיקייה הזמנית באופן ידני, תיתכן השפעה שלילית על יישומים של מפרסמים שאינם Adobe. אם תבחר לבצע משימה נוספת זו - עליך להיות זהיר. Adobe אינה תומכת בבעיות שעולות בעקבות מחיקה ידנית של קבצים בתיקייה הזמנית.

כדי למחוק ידנית את תכולת התיקייה הזמנית של החשבון, בצע את הפעולות הבאות:

  1. סגור את כל היישומים.

  2. בחר התחל > כל התוכניות > עזרים. לחץ לחיצה ימנית על שורת הפקודה ובחר באפשרות הפעל כמנהל מערכת.

  3. בחלון Command Prompt, הקלד את הפקודה הבאה בדיוק כפי שהיא מופיעה להלן, ולאחר מכן הקש Enter‏:

    del %temp%\*.* /s /q

    הערה: del היא הפקודה למחיקת קבצים. %temp%\*.* הוא שילוב של "משתנה הסביבה" עבור מיקום התיקייה הזמנית של החשבון, בשילוב עם תווים כלליים שמציינים את כל הקבצים.‎/s מרחיב את הפקודה כך שתכלול את כל הקבצים בתיקיות משנה כלשהן./q מונע מ-Windows לבקש אישור למחיקת כל קובץ וקובץ. 

  4. רשימה של הקבצים שנמחקו מופיעה בחלון Command Prompt. (הרשימה עשויה לכלול קבצים שלא ניתן למחוק. סביר להניח שתראה גם את ההודעה Access is denied (הגישה נדחתה) או The process cannot access the file because it is being used by another process (לתהליך אין אפשרות לגשת לקובץ מפני שהוא נמצא בשימושו של תהליך אחר). זוהי התנהגות רגילה.)

  5. סגור את החלון Command Prompt.

אחרי שמחקת את הקבצים הזמניים, פתח את היישום של Adobe ונסה לשחזר את הבעיה.

אם הבעיה ממשיכה, התקדם למשימה הבאה.

4. פתרון בעיות עם פריטי אתחול הספציפיים לחשבון.

פריטי אתחול הם יישומים או מסמכים שנפתחים אוטומטית כשאתה מתחבר לחשבון של משתמש. כאשר יישום Adobe פועל באופן בלתי צפוי בחשבון אחד, ייתכן שאחד מפריטי האתחול של החשבון אינו פועל כהלכה, פגום, או לא מתאים ליישום.

כדי לקבוע אם אחד מפריטי האתחול של חשבון המשתמש גורם לבעיה ביישום Adobe, בצע את הפעולות הבאות:

  1. ב-Windows Explorer, נווט אל C:\Users\[user name]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup.

  2. בצע אחד מהצעדים הבאים:

    • אם התיקייה Startup ריקה, או אם אין תיקיית Startup, לחשבון זה אין פריטי אתחול ספציפיים לחשבון. דלג על שאר השלבים והתקדם אל משימה 4.
    • אם יש לפחות פריט אחד בתיקייה Startup, צור תיקייה בשולחן העבודה. תן לתיקייה החדשה את השם Holding Folder.
  3. העבר את כל הפריטים מהתיקייה Startup לתיקייה Holding Folder שיצרת.

  4. בחר Start (התחל) > Log Off (התנתק).

  5. התחבר לאותו חשבון.

  6. פתח את היישום של Adobe ונסה לשחזר את הבעיה.

אם הבעיה עדיין מתרחשת, הגורם אינו פריט אתחול ספציפי לחשבון. באפשרותך להחזיר את כל הפריטים שנמצאים בתיקייה Holding Folder אל C:\Users\[user name]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup. התקדם אל משימה 4.

אם הבעיה לא מתרחשת יותר, הגורם הוא פריט אתחול ספציפי לחשבון. כדי לזהות את פריט האתחול הספציפי שגורם לבעיה בצע את הפעולות הבאות:

  1. סגור את היישום של Adobe.

  2. החזר פריט אחד מ-Holding Folder אל C:\Users\[user name]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup.

  3. בחר Start (התחל) > Log Off (התנתק).

  4. התחבר לאותו חשבון.

  5. פתח את היישום של Adobe ונסה לשחזר את הבעיה. לאחר מכן בצע אחת מהפעולות הבאות:

    • אם הבעיה ממשיכה להופיע - חזור על שלבים 1 עד 5.
    • אם הבעיה לא מתרחשת יותר, הגורם הוא פריט האתחול האחרון שהפכת לזמין מחדש. הסר אותו מהתיקייה Startup ופנה למפרסם של פריט האתחול כדי לקבל מידע על זמינות הגרסה המעודכנת. החזר את כל הפריטים הנותרים מ-Holding Folder אל C:\Users\[user name]\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup.

5. אפס את הגדרות הגישה בתיקיות הנתונים של היישום שספציפיות לחשבון.

השלם את המשימה רק אם החשבון שבו אתה פותר בעיות הוא חשבון מנהל מערכת ואינונמצאבתחום רשת.

שגיאות ספציפיות לחשבון עשויות להתרחש כאשר לחשבון אין גישת קריאה/כתיבה מלאה לתיקיות שבהן נמצאים קובצי ההעדפות של יישום Adobe וקובצי הנתונים הספציפיים לחשבון.באפשרותך להשתמש בפקודהicaclsכדי לאפס את הגדרות הגישה. בצעו את הפעולות הבאות:

  1. סגור את כל היישומים.

  2. בחר התחל > כל התוכניות > עזרים. לחץ לחיצה ימנית על שורת הפקודה ובחר באפשרות הפעל כמנהל מערכת. נפתח חלון עם שורת פקודה.

  3. בחלון שורת הפקודה, הקלד כל אחת מהפקודות הבאות בדיוק כפי שהיא מופיעה כאן. הקש Enter לאחר כל פקודה. 

    חשוב: הקלד רווח לפני ואחרי כל אחד מהמעבירים -- ‎/T‏, ‎/C ו-‎/grant ‏-- בכל פקודה.

    icacls "%userprofile%\AppData\Local" /T /C /grant "%username%":F

    icacls "%userprofile%\AppData\Roaming" /T /C /grant "%username%":F

    icacls "%userprofile%\AppData\Local" /T /C /grant system:F

    icacls "%userprofile%\AppData\Roaming" /T /C /grant system:F

  4. סגור את חלון שורת הפקודה.

  5. פתח את היישום של Adobe ונסה לשחזר את הבעיה.

אם הבעיה ממשיכה, התקדם למשימה הבאה.

6. צור מחדש את מפתח Adobe הספציפי לחשבון ברישום של Windows.

הגבלת אחריות: משימה זו מחייבת אותך לשנות את הרישום של Windows. הרישום מכיל מידע הקשור למערכת אשר חיוני למחשב וליישומים. לפני שתשנה את הרישום צור עותק גיבוי שלו. Adobe לא תומכת בבעיות שמתעוררות כתוצאה משינוי בלתי הולם של הרישום. לקבלת מידע נוסף על הרישום של Windows או על עורך הרישום, בקר באתר העזרה והתמיכה של Microsoft בכתובת http://support.microsoft.com.

  1. סגור את כל היישומים.

  2. לחץ על 'התחל'. הקלד regedit בתיבת החיפוש ולאחר מכן הקש על Enter. עורך הרישום נפתח.

  3. בחלונית השמאלית בעורך הרישום, אתר ובחר את מפתח הרישום הבא:

    HKEY_CURRENT_USER\Software\Adobe.

  4. בחר קובץ > ייצוא.

  5. בתיבת הדו-שיח Export Registry File (ייצוא קובץ רישום), בחר Selected Branch (ענף נבחר) תחת Export Range (טווח ייצוא). ציין שם ומיקום למפתח רישום הגיבוי ולחץ על Save (שמור).

  6. לחץ באמצעות לחצן העכבר הימני על מפתח Adobe ובחר באפשרות Delete (מחק).

  7. בתיבת הדו-שיח Confirm Key Delete (אישור מחיקת מפתח) לחץ על OK (אישור).

  8. סגור את עורך הרישום.

  9. פתח את היישום של Adobe ונסה לשחזר את הבעיה.

אם הבעיה ממשיכה להתרחש, הסיבה אינה ערך רישום פגום. תוכל לשחזר את עותק הגיבוי של מפתח Adobe על-ידי ביצוע הפעולות הבאות:

  1. סגור את כל היישומים.

  2. לחץ על 'התחל'. הקלד regedit בתיבת החיפוש ולאחר מכן הקש על Enter. עורך הרישום נפתח.

  3. בעורך הרישום, בחר קובץ > ייבוא.

  4. בתיבת הדו-שיח Import Registry File (ייבוא קובץ רישום), נווט למיקום של מפתח הרישוי ששמרת בשלבים הקודמים. בחר את הקובץ ולחץ על פתח.

7. תקן את הכונן הקשיח של המערכת.

פגם בדיסק שמשפיע רק על חשבון משתמש מסוים עלול לגרום לתפקוד לקוי של יישום Adobe באותו חשבון.

כדי לתקן את הכונן הקשיח של המערכת ראה תיקון וביצוע איחוי של כוננים קשיחים (Windows 7 ו-Windows Vista).

אחרי שתיקנת את הכונן, פתח את היישום של Adobe ונסה לשחזר את הבעיה. אם הבעיה ממשיכה, התקדם למשימה הבאה.

8. השתמש בחשבון משתמש חדש.

אם היישום עדיין מתנהג באופן לא צפוי בחשבון מסוים, העתק (או העבר) את כל הקבצים האישיים לחשבון שבו ההתנהגות אינה מתרחשת. השתמש בחשבון החדש בתור חשבונך הרגיל.

לקבלת עזרה בהעתקת קבצים אישיים לחשבון משתמש חדש, פנה ליצרן המחשב. לחלופין עבור לאתר העזרה והתמיכה של Microsoft בכתובת http://support.microsoft.com.

עבודה זו בוצעה ברישיון של Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  הודעות המתפרסמות ב- Twitter™‎ ו- Facebook אינן מכוסות בתנאי Creative Commons.

הצהרות משפטיות   |   מדיניות פרטיות מקוונת