Il processo di codifica

Per codificare un elemento video o audio, aggiungetelo alla coda di codifica in Adobe Media Encoder, quindi selezionate i predefiniti di codifica o create le impostazioni di codifica personalizzate. La codifica può quindi essere avviata immediatamente dopo l’aggiunta di un elemento oppure in un secondo tempo.

Aggiungere un elemento alla coda di codifica - Trascinate i file video o audio nella coda di Adobe Media Encoder.

Codificare l’elemento mediante i predefiniti - Con l’elemento nella coda, selezionate i formati e i predefiniti dai menu a comparsa Formato e Predefiniti. Oppure scegliete un predefinito dal browser dei predefiniti e trascinatelo sull'elemento interessato nella coda. Per ulteriori informazioni, consultate Codificare mediante i predefiniti.

Codificare l’elemento con impostazioni personalizzate - Selezionate l’elemento e scegliete Modifica > Impostazioni di esportazione, quindi scegliete le impostazioni desiderate. Per ulteriori informazioni, consultate Codificare con impostazioni personalizzate.

Per avviare automaticamente la codifica degli elementi nella coda (o per disattivare questa funzione), selezionate (o deselezionate) l’opzione Avvia coda automaticamente se inattivo per, nella finestra di dialogo Preferenze. Per ulteriori informazioni, consultate Preferenze.

Schermata di Adobe Media Encoder
Finestra principale di Adobe Media Encoder

Importare elementi nella coda di codifica

  • Per aggiungere file video o audio, effettuate una delle seguenti operazioni:
    • Trascinate uno o più file nella coda dal desktop o dal Browser multimediale.
    • Fate clic sul pulsante Aggiungi sorgente e scegliete uno o più file.
    • Fate doppio clic su un'area vuota nel pannello Coda e scegliete uno o più file.
  • Per aggiungere una sequenza Adobe Premiere Pro, effettuate una delle seguenti operazioni:
    • Individuate il progetto di Adobe Premiere Pro nel Browser multimediale e fate clic sulle sequenze per poi trascinarle nella coda.
    • Scegliete File > Aggiungi sequenza Premiere Pro, quindi selezionate un progetto Premiere Pro e selezionate una o più sequenze dal progetto.
    • Fate clic su una sequenza e trascinatela dal pannello Progetto di Adobe Premiere Pro alla coda.
    • Fate clic su un progetto Premiere Pro e trascinatelo dal desktop alla coda.
  • Per aggiungere una composizione Adobe After Effects, effettuate una delle seguenti operazioni:
    • Individuate il progetto di Adobe After Effects nel Browser multimediale e trascinate le sequenze nella Coda.
    • Scegliete File > Aggiungi composizione After Effects, quindi selezionate un progetto After Effects e infine una composizione dal progetto.
    • Fate clic su una composizione e trascinatela dal pannello Progetto di After Effects alla coda.
    • Fate clic su un progetto After Effects e trascinatelo dal desktop alla coda..

Interruzione codifica

  • Per interrompere la codifica dell’elemento corrente, scegliete File > Interrompi file corrente. Adobe Media Encoder prosegue con la codifica degli altri elementi della coda.
  • Per interrompere la codifica di tutti gli elementi nella coda, scegliete File > Interrompi coda.

Interpretare gli elementi nella coda di codifica

Quando Adobe Media Encoder importa una risorsa video, tenta di determinare le proporzioni pixel, la frequenza fotogrammi e l’ordine dei campi relativi a tale risorsa, nonché come interpretare le informazioni del canale alfa (trasparenza). Se Adobe Media Encoder interpreta in modo errato tali caratteristiche, potete assegnare esplicitamente l’interpretazione corretta.

  1. Selezionate uno o più elementi nella coda di codifica.

  2. Scegliete File > Interpreta metraggio. Potete inoltre fare clic con il pulsante destro del mouse sul file e scegliere Interpreta metraggio.

    interpret selection
    Selezione di Interpreta metraggio

  3. Scegliete le impostazioni di interpretazione appropriate.

    iterpret window
    Finestra di dialogo Interpreta metraggio

Individuare elementi mancanti nella coda di codifica

Potete identificare le sorgenti o gli output nella coda che contengono elementi mancanti prima di codificare. Questo consente di identificare e correggere i problemi prima di codificare. Uno stato di avviso viene visualizzato accanto alla sorgente o all’output contenente degli elementi mancanti. Posizionate il puntatore sull’icona per visualizzare un riepilogo dell’errore associato a questo problema. 

Adobe Media Encoder visualizza un’icona di avviso nei casi seguenti:

  • Un progetto Premiere Pro contiene file multimediali non in linea. In questo caso, Adobe Media Encoder utilizza i file proxy al posto del set mancante. Se non vi sono proxy, viene utilizzato un elemento grafico con il messaggio “File multimediali non in linea”.
  • Alcuni font risultano mancanti dal progetto Premiere Pro.
  • Alcuni effetti risultano mancanti dal progetto Premiere Pro.
  • Alcuni file risultano mancanti in Effetti di sovrapposizione. 
Identificare gli elementi mancanti
Identificare gli elementi mancanti

Cartelle esaminate in Adobe Media Encoder  

Potete configurare Adobe Media Encoder in modo che cerchi i file in determinate cartelle, definite cartelle esaminate. Quando Adobe Media Encoder rileva un file video o audio in una cartella esaminata, lo codifica in base alle impostazioni assegnate alla cartella ed esporta il file codificato nella relativa cartella Output, all’interno della cartella esaminata.

in Adobe Media Encoder potete utilizzare il pannello Cartelle esaminate per aggiungere e gestire le cartelle. Per aggiungere una cartella esaminata, effettuate una delle seguenti operazioni:

  1. Scegliete File > Aggiungi cartella esaminata e selezionate una cartella.
  2. Fate doppio clic in un’area vuota del pannello Cartelle esaminate e selezionate una cartella.
  3. Create una cartella da Risorse del computer (Windows) o dal Finder (Mac OS), quindi trascinatela nel pannello Cartelle esaminate.

Potete vedere il nome delle cartelle create nella colonna a sinistra nel pannello Cartelle esaminate.

All’avvio della coda, gli elementi aggiunti alla coda di codifica dalla cartella esaminata verranno codificati con altri elementi nella coda.

Nota:

se è selezionata la preferenza Avvia coda automaticamente se inattivo per, la codifica inizia quando è trascorso il lasso di tempo specificato dopo che la cartella di controllo ha aggiunto un nuovo elemento alla coda di codifica.

Nota:

Per la codifica automatica degli elementi che vengono aggiunti alla cartella esaminata, mantenete selezionata la casella di controllo Codifica automatica cartelle esaminate.

Aggiunta di predefiniti

Potete scegliere un formato e un predefinito dai menu nella cartella esaminata accanto al nome della cartella. Oppure trascinate un predefinito dal browser dei predefiniti alla cartella esaminata.

Creare l’output in più formati da un singolo elemento sorgente mediante le cartelle esaminate

È possibile generare output diversi con una singola operazione mediante le cartelle esaminate. Ad esempio, ogni volta che transcodificate una risorsa video potete generare un filmato AVI e un’immagine miniatura JPEG. Per creare tali file in una singola operazione, effettuate i passaggi di seguito:

  1. Create una cartella da Risorse del computer (Windows) o dal Finder (Macintosh) e denominatela, ad esempio, “CartellaEsaminata”.

  2. Create una cartella esaminata facendo clic sul pulsante Aggiungi cartella, quindi individuate la cartella precedentemente creata e denominata “CartellaEsaminata”.

    1. Fate clic su Formato e selezionate MPEG4 dal menu a comparsa.

    2. Fate clic su Predefinito e selezionate l’impostazione desiderata dal menu a comparsa Predefinito.

      preset and format
      Menu a comparsa Formato e Predefinito

    3. Fate clic su Cartella di output. Selezionate un percorso in cui salvare l’output che verrà generato.

      Output Folder
      Cartella di output

  3. Create una cartella esaminata che faccia anch’essa riferimento alla cartella “CartellaEsaminata”, come per il passaggio 2.

    1. Selezionate AVI dal menu Formato.

    2. Selezionate un predefinito dal menu Predefiniti e fate clic su OK.

    3. Fate clic su Cartella di output. Selezionate un percorso in cui salvare l’output che verrà generato.

  4. Create una cartella esaminata che faccia anch’essa riferimento alla cartella “CartellaEsaminata”, come per i passaggi 2 e 3.

    1. Selezionate JPEG dal menu Formato.

    2. Selezionate un predefinito dal menu Predefiniti e fate clic su OK.

    3. Fate clic su Cartella di output. Selezionate un percorso in cui salvare l’output che verrà generato.

  5. Fate clic sul file sorgente e trascinatelo in “CartellaEsaminata”, quindi fate clic sul pulsante Inizia coda. Il processo di codifica viene avviato automaticamente se è selezionata l’opzione Codifica automatica cartelle esaminate.

Al termine, ciascun file si troverà nel rispettivo percorso di output.

Nota:

Il predefinito deve essere personalizzato e l’opzione Esporta come sequenza deve essere deselezionata. Verrà esportato solo il primo fotogramma del video, solitamente nero.

Nota:

Le sequenze di immagini fisse non sono supportate come riprese sorgente mediante le cartelle esaminate. Se un set di immagini fisse viene inserito in una cartella esaminata, ogni singola immagine viene aggiunta come elemento a parte nella coda e l’intera sequenza non viene quindi trattata come un singolo elemento di ripresa.

Salvare la coda di codifica

La coda di codifica e tutte le impostazioni di codifica vengono salvate automaticamente all’uscita da Adobe Media Encoder.

La coda di codifica viene salvata automaticamente anche quando la codifica viene avviata dall’utente.

Per salvare manualmente la coda di codifica, scegliete File > Salva coda.

Nota:

Disattivate la casella di controllo Preferenze > All’uscita rimuovi file completati dalla coda se desiderate mantenere in coda gli oggetti di cui è stata completata la codifica dopo la chiusura e il riavvio di Adobe Media Encoder.

Rimuovere elementi dalla coda di codifica

  1. Selezionate gli elementi da rimuovere dalla coda di codifica.

  2. Fate clic sul pulsante Rimuovi, scegliete Modifica > Cancella oppure premete il tasto Canc.

    Delete file new
    Eliminare degli elementi dalla coda di codifica

Duplicare gli elementi nella coda di codifica

  1. Selezionate gli elementi da duplicare nella coda di codifica.

  2. Effettuate una delle seguenti operazioni:

    • Fate clic sul pulsante Duplica o scegliete Modifica > Duplica.
    • Premete i tasti Ctrl+D (Windows) o Comando+D (Mac OS).
    • Fate clic con il pulsante destro del mouse sul file e scegliete Duplica.
    Duplicate item
    Duplicare un elemento

Ignorare gli elementi nella coda di codifica

Ignora elementi

  1. Selezionate gli elementi da ignorare nella coda di codifica.

  2. Scegliete Modifica > Ignora selezione oppure fate clic con il pulsante destro del mouse su un file e scegliete Ignora selezione.

    Skip selection
    Ignora selezione

Ripristinare un file ignorato per la codifica

  1. Selezionate gli elementi nella coda di codifica per i quali desiderate ripristinare lo stato Pronto.

  2. Scegliete Modifica > Ripristina stato oppure fate clic con il pulsante destro del mouse su un file e scegliete Modifica > Ripristina stato.

    Reset status
    Ripristinare lo stato di un file ignorato

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online