Adobe Media Encoder utilizza i predefiniti esistenti o le impostazioni personalizzate per codificare e transcodificare i file multimediali in diversi formati video e audio.

Il processo di codifica

Per codificare un elemento video o audio, occorre aggiungerlo alla coda di codifica in Adobe Media Encoder, quindi selezionare i predefiniti o le impostazioni personalizzate di codifica. La codifica può quindi essere avviata immediatamente dall’applicazione dopo l’aggiunta di un elemento, oppure in un secondo tempo. Con Adobe Media Encoder potete effettuare le seguenti operazioni:

  • Aggiungere un elemento alla coda di codifica: trascinate i file video o audio al pannello Coda di Adobe Media Encoder. Per ulteriori informazioni, consulta Importare elementi nella coda di codifica.
  • Codificare l’elemento mediante i predefiniti: con l’elemento nella coda, seleziona i formati e i predefiniti dall’elenco a discesa Formato e Predefiniti. Oppure scegli un predefinito dal browser dei predefiniti e trascinalo sull’elemento interessato nella coda. Per ulteriori informazioni, consulta Codificare mediante i predefiniti.
  • Codificare l’elemento mediante le impostazioni personalizzate: seleziona gli elementi desiderati nel pannello Coda e scegli Modifica > Impostazioni di esportazione oppure fai clic sul Formato e Predefinito elencato, nel pannello Coda, quindi scegli le impostazioni desiderate. Per ulteriori informazioni, consulta Codificare con impostazioni personalizzate.

Per avviare la codifica automatica degli elementi nella coda dopo la durata specificata, seleziona l’opzione Avvia coda automaticamente se inattivo per. Imposta la durata desiderata per lo stato di inattività nella finestra di dialogo Preferenze. 

Preferenze
Preferenze

Una volta attivato, il conto alla rovescia viene visualizzato nel pannello Codifica. Per ulteriori informazioni, consulta Preferenze.

Conto alla rovescia per la codifica
Conto alla rovescia per la codifica

Importare elementi nella coda di codifica

Per aggiungere file video o audio alla coda di codifica, effettua una delle seguenti operazioni:

  • Trascina uno o più file nel pannello Coda dal desktop o dal Browser multimediale.
  • Fai clic sul pulsante Aggiungi sorgente  nel pannello Coda e scegli uno o più file.
  • Fai doppio clic su un’area vuota nel pannello Coda e scegli uno o più file.

Importare da Premiere Pro

Per aggiungere una sequenza Adobe Premiere Pro, effettua una delle seguenti operazioni:

  • Individua il progetto di Adobe Premiere Pro nel Browser multimediale e fai clic sulle sequenze per poi trascinarle nel panello Coda.
  • Scegli File > Aggiungi sequenza Premiere Pro, quindi seleziona un progetto Premiere Pro e seleziona una o più sequenze dal progetto.
  • Fai clic su una sequenza e trascinala dal pannello Progetto di Adobe Premiere Pro al pannello Coda.
  • Fai clic su un progetto Premiere Pro e trascinalo dal desktop al pannello Coda.

Importare da After Effects

Per aggiungere una composizione Adobe After Effects, effettua una delle seguenti operazioni:

  • Individua il progetto di Adobe After Effects nel Browser multimediale e trascina le sequenze nel pannello Coda.
  • Scegli File > Aggiungi composizione After Effects, quindi seleziona un progetto After Effects e infine una composizione dal progetto.
  • Fai clic su una composizione e trascinala dal pannello Progetto di After Effects al pannello Coda.
  • Fai clic su un progetto After Effects e trascinalo dal desktop al pannello Coda.

Interrompere la codifica

Per interrompere codifica, effettua una delle seguenti operazioni

  • Per interrompere la codifica dell’elemento corrente, scegli File > Interrompi elemento corrente. Adobe Media Encoder prosegue con la codifica degli altri elementi della coda.
  • Per interrompere la codifica di tutti gli elementi nella coda, scegli File > Interrompi coda.

Unione delle clip

Quando aggiungi più file multimediali alla coda, puoi combinarli in un singolo file. Per unire più file multimediali, effettua le seguenti operazioni:

  1. Seleziona File > Aggiungi sorgente o fai clic sul pulsante Aggiungi sorgente nel pannello Coda. Si apre Esplora file.

  2. Seleziona le risorse da unire.

  3. Seleziona la casella di controllo Unisci clip.

    Unisci clip
    Unisci clip
  4. Fai clic su Apri per aggiungere la clip unita alla coda.

In alternativa, seleziona le clip da unire. Trascinale nel pannello Coda e rilasciale sopra l’opzione Rilascia qui per unire le clip.

Rilascia qui per unire le clip
Rilascia qui per unire le clip

Le clip unite vengono caricate nella coda. Per visualizzare le singole clip, fai clic su Visualizza sorgenti. Per impostazione predefinita, le clip vengono ordinate in ordine alfabetico. Puoi riorganizzarle in base alle tue esigenze.

Il nome delle clip unite viene impostato automaticamente sulla prima clip della serie. Per modificare il nome di una clip, fai clic sul nome. Per ulteriori informazioni, consulta Unione di più clip con Adobe Media Encoder.

Nota:

Le clip unite rispettano i punti di attacco e stacco impostati nel browser multimediale. Tuttavia, non è possibile modificare la durata delle sorgenti dopo che queste sono state aggiunte a una clip unita.

Individuare elementi mancanti nella coda di codifica

Prima di avviare la codifica, puoi individuare gli elementi nella coda che contengono elementi mancanti. Questo processo consente di trovare e correggere i problemi prima di codificare. Uno stato di avviso viene visualizzato accanto alla sorgente o all’output contenente elementi mancanti. Per visualizzare un riepilogo dell’errore associato a questo problema, passa il cursore sull’icona.

Adobe Media Encoder visualizza un’icona di avviso  nei casi seguenti:

  • Un progetto Premiere Pro contiene file multimediali non in linea. In questo caso, Adobe Media Encoder utilizza i file proxy al posto del set di file multimediali mancante. Se non vi sono proxy, viene utilizzato un elemento grafico con il messaggio “File multimediali non in linea”.
  • Alcuni font risultano mancanti dal progetto Premiere Pro.
  • Alcuni effetti risultano mancanti dal progetto Premiere Pro.
  • Alcuni file risultano mancanti in Effetti di sovrapposizione.
Riepilogo errore
Riepilogo errore

Interpretare gli elementi nella coda di codifica

Quando Adobe Media Encoder importa una risorsa video, tenta di determinare la frequenza fotogrammi, le proporzioni pixel, l’ordine dei campi e il canale alfa per la risorsa video. Se Adobe Media Encoder interpreta in modo errato tali caratteristiche, puoi assegnare manualmente l’interpretazione corretta.

  1. Seleziona uno o più elementi video nella coda di codifica.

  2. Effettua una delle seguenti operazioni:

    • Sceglie File > Interpreta metraggio
    • Fai clic con il pulsante destro del mouse sul file e scegli Interpreta metraggio.
  3. Scegli le impostazioni di interpretazione appropriate.

Interpreta metraggio
Interpreta metraggio

Nota:

L’opzione Interpreta metraggio non è disponibile se selezioni una risorsa che non è un video o una risorsa di immagine.

Codificare mediante i predefiniti o impostazioni personalizzate

Codificare mediante i predefiniti

predefinito
A. Formato B. Predefinito C. Destinazione 
  1. Aggiungi elementi al pannello Coda. Per informazioni, consulta Importare elementi nella coda di codifica.

  2. Scegli un formato compatibile con il dispositivo di output facendo clic sul testo del Formato (A) per aprire la finestra a comparsa Formato contenente i formati di file supportati.

  3. Scegli un predefinito compatibile con il dispositivo di output facendo clic sul testo del Predefinito (B) per aprire la finestra a comparsa Predefinito contenente i predefiniti standard di settore. Per ulteriori informazioni, consulta Creare predefiniti personalizzati per Media Encoder.

    Oppure trascina un predefinito dal Browser predefiniti e rilascialo nella coda.

    Applicare un predefinito
    Applicare un predefinito
  4. Scegli un percorso per l’output esportato: fai clic sul testo File di output (C), quindi individua la directory o cartella in cui esportare il file, nella finestra di dialogo Salva con nome. Fai clic su Salva.

  5. Premi il pulsante Inizia coda.

I file vengono codificati nel formato scelto, in base al predefinito scelto e salvati nel percorso indicato. Dopo che file è stato codificato, fai clic sul percorso del file di output per aprire la cartella contenente il file codificato.

file di output
A. File di output dopo la codifica B. File di output prima della codifica 

Nota:

Per interrompere la codifica durante il processo di codifica, fai di nuovo clic sul pulsante Inizia coda.

Codificare con impostazioni personalizzate

Per codificare con impostazioni personalizzate, effettua le seguenti operazioni:

  1. Aggiungi elementi al pannello Coda. Per informazioni, consulta Importare elementi nella coda di codifica.

  2. Apri la finestra di dialogo Impostazioni di esportazione in uno dei seguenti modi:

    • Seleziona la riga dell’elemento per il testo che mostra Formato, predefinito e percorso file di output nel pannello Coda e seleziona Modifica > Impostazioni di esportazione
    • Fai clic con il pulsante destro del mouse sulla riga del testo che mostra Formato, predefinito e percorso del file di output e seleziona Impostazioni di esportazione
    • Fai clic sul nome Formato o Predefinito per aprire la finestra di dialogo Impostazioni di esportazione.
  3. Imposta le opzioni di esportazione e fai clic su OK. Per ulteriori informazioni, consulta Impostazioni di esportazione per Media Encoder - Riferimento.

  4. Con la finestra di dialogo Impostazioni di esportazione chiusa, fai clic sul pulsante Inizia coda per iniziare a codificare i file.

Nota:

Per ottimizzare le prestazioni durante la codifica, chiudi il pannello Codifica. È possibile utilizzare le barre di stato nel pannello Coda per visualizzare lo stato del processo di codifica.

Nella finestra di dialogo Impostazioni di esportazione puoi effettuare le seguenti operazioni:

  • Scegli un formato video, audio o di immagine fissa nel menu Formato. Per ulteriori informazioni, consulta Formati di file supportati per l’esportazione.

  • Scegli un predefinito di codifica nel menu Predefinito.

  • Seleziona Esporta video, Esporta audio, o entrambi.

  • Specifica le opzioni di precodifica, comprese le opzioni di taglio e ritaglio. Per ulteriori informazioni, consulta Finestra di dialogo Impostazioni di esportazione.

  • Imposta le opzioni per l’esportazione dei metadati XMP. Per ulteriori informazioni consulta Esportazione e metadati XMP sottili.

  • Seleziona Usa massima qualità di rendering o Rendering a profondità di bit massima.

  • Seleziona Usa fusione fotogrammi.

  • Fai clic sul testo sottolineato accanto a Nome output, nella sezione in alto a destra della finestra di dialogo Opzioni di esportazione, e specifica un nome file e un percorso per il file codificato. Se non specifichi un nome file, verrà usato il nome file della clip video sorgente.

Nota:

Se il formato è impostato su Filmato P2, non viene applicato il nome file assegnato dall’utente. Viene invece assegnato da Adobe Media Encoder un nome composto di sei caratteri alfanumerici. Il nome specificato per Nome output viene salvato nei metadati della clip e visualizzato come nome della clip in Adobe Premiere Pro.

Puoi specificare la cartella di destinazione in cui salvare il file codificato, in relazione alla cartella contenente la clip video sorgente. Quando specifichi una cartella di destinazione, verifica che la cartella di destinazione specificata esista. Se specifichi una cartella che ancora non esiste, un messaggio di errore ti informa che il file non può essere codificato perché non è possibile trovare la cartella.

Salvare la coda di codifica

La coda di codifica e le impostazioni di codifica vengono salvate automaticamente all’uscita da Adobe Media Encoder. La coda di codifica viene salvata automaticamente anche quando il processo di codifica viene avviato dall’utente.

Per salvare manualmente la coda di codifica, scegli File > Salva coda.

Nota:

Disattiva la casella di controllo Preferenze > All’uscita rimuovi file completati dalla coda se desideri mantenere in coda gli oggetti di cui è stata completata la codifica dopo la chiusura e il riavvio di Adobe Media Encoder.

Modificare il percorso del file di output per più sorgenti

Segui i passaggi descritti di seguito per modificare il percorso File di output per più output (contemporaneamente):

  1. Seleziona più sorgenti nella coda mediante Maiusc-clic.

  2. Fai clic sul testo del file di output di una sorgente nella selezione corrente.

  3. Scegli un percorso nella finestra di dialogo Seleziona una cartella di output e fai clic su Scegli.

Gli output selezionati sono presenti nella nuova directory ma mantengono i loro nomi univoci di file di output.

Cartella esaminata

Puoi configurare Adobe Media Encoder in modo che cerchi i file in determinate cartelle, definite “cartelle esaminate”. Adobe Media Encoder codifica automaticamente i file inseriti nella cartella esaminata. Quando Adobe Media Encoder rileva un file video o audio in una cartella esaminata, effettua la codifica del file mediante le impostazioni di codifica assegnate alla cartella. Quindi esporta il file codificato in una cartella di output creata all’interno della cartella esaminata.

Utilizzando le cartelle esaminate, Adobe Media Encoder automatizza il processo di accodamento e rendering dei file multimediali. Puoi creare più versioni di una sorgente aggiungendo diverse istanze di output utilizzando diversi formati o predefiniti.

Pannello Cartelle esaminate
Pannello Cartelle esaminate

In Adobe Media Encoder puoi utilizzare il pannello Cartelle esaminate per aggiungere e gestire le cartelle. Per aggiungere una cartella esaminata, effettua una delle seguenti operazioni:

  • Scegli File > Aggiungi cartella esaminata e seleziona una cartella.
  • Fai doppio clic in un’area vuota del pannello Cartelle esaminate e seleziona una cartella.
  • Crea una cartella da Risorse del computer (Windows) o dal Finder (Mac OS), quindi trascinala nel pannello Cartelle esaminate.

All’avvio della coda, gli elementi aggiunti alla coda di codifica dalla cartella esaminata vengono codificati con altri elementi nella coda.

Nota:

Se è selezionata la preferenza “inizia coda automaticamente se inattivo per”, la codifica inizia quando è trascorso il lasso di tempo specificato dopo che la cartella di controllo ha aggiunto un elemento alla coda di codifica.

Per la codifica automatica degli elementi che vengono aggiunti alla cartella esaminata, mantieni selezionata la casella di controllo Codifica automatica cartelle esaminate.

Creare output in più formati mediante cartelle esaminate

Puoi generare output diversi con una singola operazione mediante le cartelle esaminate. Ad esempio, ogni volta che transcodifichi una risorsa video puoi generare un filmato AVI e un’immagine miniatura JPEG.

Per creare questi file con un’unica operazione utente, effettua le seguenti operazioni:

  1. Crea una cartella da Esplora file (Windows) o dal Finder (macOS) denominata “CartellaEsaminata”.

  2. Crea una cartella esaminata facendo clic sul pulsante Aggiungi cartella , quindi individua la cartella precedentemente creata e denominata “CartellaEsaminata”.

    • Fai clic su Formato e seleziona MPEG4 dal menu a comparsa.
    • Fai clic su Predefinito e seleziona l’impostazione desiderata dal menu a comparsa Predefinito.
    Impostazioni di esportazione
    Impostazioni di esportazione
    • Fai clic su Cartella di output. Seleziona un percorso in cui salvare l’output che verrà generato.
  3. Crea una cartella esaminata che faccia anch’essa riferimento alla cartella “CartellaEsaminata”, come nel passaggio 2.

    • Fai clic su Formato e seleziona AVI dal menu a comparsa.
    • Fai clic su Predefinito e seleziona l’impostazione desiderata dal menu a comparsa Predefinito.
    • Fai clic su Cartella di output. Seleziona un percorso in cui salvare l’output che verrà generato.
  4. Crea una cartella esaminata che faccia anch’essa riferimento alla cartella “CartellaEsaminata”, come nei passaggi 2 e 3.

    • Fai clic su Formato e seleziona JPEG dal menu a comparsa.
    • Fai clic su Predefinito e seleziona l’impostazione desiderata dal menu a comparsa Predefinito.
    • Fai clic su Cartella di output. Seleziona un percorso in cui salvare l’output che verrà generato.
  5. Fai clic sul file sorgente e trascinalo in “CartellaEsaminata”, quindi fai clic sul pulsante Inizia coda. Il processo di codifica viene avviato automaticamente se è selezionata l’opzione Codifica automatica cartella esaminata.

Al termine, ciascun file si troverà nel rispettivo percorso di output.

Rimuovere, duplicare e ignorare gli elementi nella coda di codifica

Rimuovere, duplicare e ignorare gli elementi nella coda di codifica
Rimuovere, duplicare e ignorare gli elementi nella coda di codifica

Rimuovere elementi dalla coda di codifica

Per rimuovere elementi dalla coda di codifica, effettua le seguenti operazioni:

  1. Seleziona gli elementi da rimuovere dalla coda di codifica.

  2. Effettua una delle seguenti operazioni:

    • Fai clic con il pulsante destro del mouse sul file e scegli il pulsante Rimuovi.
    • Scegli Modifica > Cancellaoppure premi il tasto Canc.
    • Seleziona per confermare la rimozione. Seleziona Non visualizzare più questo messaggio per evitare che la finestra di conferma appaia ogni volta che un elemento viene rimosso dalla coda.

Duplicare gli elementi nella coda di codifica

Per duplicare gli elementi nella coda di codifica, effettua le seguenti operazioni:

  1. Seleziona l’elemento o gli elementi da duplicare dalla coda di codifica.

  2. Effettua una delle seguenti operazioni:

    • Fai clic con il pulsante destro del mouse sul file e scegli Duplica.
    • Fai clic sul pulsante Duplica o scegli Modifica > Duplica
    • Premi i tasti CTRL+D (Windows) o Comando+D (macOS)

Ignorare gli elementi nella coda di codifica

Per ignorare gli elementi nella coda di codifica, effettua le seguenti operazioni:

  1. Seleziona gli elementi da ignorare nella coda di codifica.

  2. Effettua una delle seguenti operazioni:

    • Scegli Modifica > Ignora selezione.
    • Fai clic con il pulsante destro del mouse sul file e scegli Ignora selezione.

Ripristinare lo stato degli elementi nella coda di codifica

Per ripristinare lo stato di un file nella coda di codifica, effettua le seguenti operazioni:

  1. Seleziona gli elementi nella coda di codifica per i quali desideri ripristinare lo stato Pronto.

  2. Effettua una delle seguenti operazioni:

    • Scegli Modifica > Ripristina stato.
    • Fai clic con il pulsante destro del mouse sul file e scegli Modifica > Reimposta stato.

Monitorare l’avanzamento della codifica

Durante la codifica di un elemento, la colonna Stato della coda di codifica fornisce lo stato di ciascun elemento. Adobe Media Encoder è in grado di codificare simultaneamente output diversi da una singola sorgente. Tuttavia, i file sorgente vengono elaborati in sequenza a seconda del loro ordine nella coda.

Mentre è in corso un processo di codifica, puoi continuare a lavorare nell’applicazione. Puoi aggiungere, rimuovere o riordinare gli elementi in coda o nella cartella esaminata. Tuttavia, gli output per i quali è in corso la codifica non possono essere modificati.

  • Pronto
    L’elemento si trova nella coda di codifica, ma non è ancora stato codificato. Puoi rimuovere dalla coda un file che non è ancora stato codificato e che non è in fase di codifica.
  • Fine
    L’elemento è stato codificato con successo.
  • Arrestato 
    L’utente ha annullato il processo di codifica mentre l’elemento era in fase di codifica.
  • Non riuscito 
    Adobe Media Encoder ha riscontrato un errore nel tentativo di codificare l’elemento specificato.
  • Ignora
    L’utente può ignorare uno o più file selezionati. Con i file selezionati, scegli Modifica > Ignora selezione.

Segnali acustici per il completamento dei processi (corretto o con errori)

Adobe Media Encoder emette dei segnali acustici al completamento dei processi presenti nella coda. Se si verifica una condizione di errore, viene emesso un segnale acustico diverso. Se non desideri sentirli, è possibile disattivarli nelle preferenze.

Preferenze
Preferenze

Visualizzare il registro

Per visualizzare una descrizione comandi con il messaggio di errore, passa il mouse sull’icona di stato. Per aprire il registro per qualsiasi elemento per il quale la codifica è stata completata, interrotta o non riuscita, fai clic sul suo stato.

Visualizzare il registro
Visualizzare il registro

Codifica parallela

Adobe Media Encoder codifica tutte le sorgenti in sequenza, ma codifica tutti gli output di una sorgente in modalità parallela. La codifica parallela viene utilizzata per esportare più formati contemporaneamente per la stessa sorgente, ma non può essere utilizzata per esportare sorgenti diverse contemporaneamente.

Codifica parallela
Codifica parallela

Nota:

La codifica parallela è attivata per impostazione predefinita. Per disattivare la codifica parallela, seleziona Modifica > Preferenze e deseleziona Abilita codifica parallela.

Per la codifica simultanea di più output, nel pannello Codifica viene visualizzata una miniatura di anteprima, la barra di avanzamento e la stima del tempo richiesto per il completamento di ciascun output di codifica.

In alcuni casi, le impostazioni di esportazione richiedono un output per la codifica in serie anziché in parallelo. In questi casi, la coda ritorna alla modalità di codifica parallela al termine della codifica in serie temporanea.

Questo prodotto è concesso in licenza in base alla licenza di Attribuzione-Non commerciale-Condividi allo stesso modo 3.0 Unported di Creative Commons.  I post su Twitter™ e Facebook non sono coperti dai termini di Creative Commons.

Note legali   |   Informativa sulla privacy online