이미지 및 그래픽 내보내기

PNG 시퀀스

라이브러리 또는 스테이지에 있는 개별 동영상 클립, 버튼, 그래픽 기호로부터 일련의 이미지 파일을 내보낼 수 있습니다. Animate CC(이전의 Flash Professional CC)는 내보내는 동안 심볼의 각 프레임에 대해 별도의 이미지 파일을 만듭니다. 스테이지에서 내보내는 경우 크기 조절과 같이 심볼 인스턴스에 적용한 모든 변형은 이미지 출력에 보존됩니다.

PNG 시퀀스를 내보내려면

  1. 라이브러리 또는 스테이지에서 단일 동영상 클립, 버튼 또는 그래픽 기호를 선택합니다.

  2. 마우스 오른쪽 버튼으로 클릭하고 PNG 시퀀스 내보내기를 선택합니다.

    select-png-sequence
  3. [다른 이름으로 저장] 대화 상자에서 출력 위치를 선택하고 확인을 클릭합니다.

     

  4. PNG 시퀀스 내보내기 대화 상자에서 원하는 옵션을 설정합니다. 

    export-pngsequence

    - 이미지 출력의 폭입니다. 이 값을 변경하여 출력 크기를 조정할 수 있습니다. 기본값은 기호 내용의 폭입니다.

    높이 - 이미지 출력의 높이입니다. 이 값을 변경하여 출력 크기를 조정할 수 있습니다. 기본값은 기호 내용의 높이입니다.

    해상도 - 이미지 출력의 해상도입니다. 기본값은 72dpi입니다.

    색상 - 이미지 출력의 비트 심도입니다. 8, 24 또는 32비트를 선택할 수 있습니다. 기본값은 투명성을 지원하는 32비트입니다. 투명성을 지원하지 않는 24비트나 8비트를 선택하면 [배경] 설정이 스테이지로 변경됩니다. 아래를 참조하십시오.

    배경 - 이미지 출력의 배경색으로 사용할 색상입니다. 이 설정은 색상 옵션이 8비트 또는 24비트로 설정되어 있을 때 사용할 수 있습니다. [색상]이 32비트로 설정되어 있으면 이미지 배경이 항상 투명입니다. [색상] 옵션이 8비트 또는 24비트로 설정되어 있으면 [배경] 옵션이 기본값인 스테이지 색상으로 설정됩니다. 8비트 또는 24비트 이미지의 경우 설정을 불투명으로 변경한 후 색상 선택기에서 배경색을 선택할 수 있습니다. 또는 배경색으로 알파 값을 선택하여 투명하게 만들 수 있습니다.

    매끄럽게 - 이미지 출력 가장자리에 매끄러움을 적용할 것인지 여부를 전환합니다. 투명 배경을 사용하지 않고 있는데 이미지가 스테이지의 현재 색상과 다른 배경색 위에 배치된 경우 이 옵션을 끄십시오.

  5. 내보내기를 클릭하여 PNG 시퀀스를 내보냅니다.

애니메이션 GIF 내보내기

다음 단계를 수행하여 Animate에서 애니메이션 GIF 파일 내보낼 수 있습니다. 

  1. 파일 > 내보내기 > 애니메이션 GIF 내보내기로 이동합니다.

    대화 상자가 나타납니다. 

    export-animated-gif
  2. 대화 상자에서 원하는 옵션을 선택하고 완료를 클릭하여 애니메이션 GIF 파일로 애니메이션을 내보냅니다.

    animated-gif-dialog

    파일 > 내보내기 > 이미지 내보내기를 선택하여 정적 GIF 이미지 파일을 내보낼 수도 있습니다.

CC 라이브러리로 이미지 및 그래픽 내보내기

CC 라이브러리로 이미지 또는 그래픽을 내보내려면 창 > CC 라이브러리를 선택합니다.

CC 라이브러리 창이 나타납니다. 

add-to-cc-library

CC 라이브러리 창의 왼쪽 아래 모서리에 있는 + 아이콘을 클릭하고 이미지 또는 그래픽 파일을 선택하고 추가를 클릭합니다.

FXG 그래픽 교환 형식(Animate CC에서 더 이상 사용 안 됨)

FXG 파일

FXG 형식은 Animate/Flash 플랫폼을 위한 그래픽 교환 파일 형식입니다. FXG는 Flex 프레임워크에서 사용되는 XML 기반 프로그래밍 언어인 MXML의 하위 세트입니다. FXG 형식은 높은 정확도를 유지하는 그래픽 내용 교환을 가능하게 하여 디자이너와 개발자가 보다 효율적으로 공동 작업을 수행하는 데 도움이 됩니다. 디자이너는 Adobe 디자인 도구를 사용하여 그래픽을 만들고 FXG 형식으로 내보낼 수 있습니다. 그런 다음 Adobe Flash Builder 및 Adobe Flash Catalyst와 같은 도구에서 FXG 파일을 사용하여 풍부한 인터넷 환경과 애플리케이션을 개발할 수 있습니다.

FXG 파일을 만들 때 벡터 그래픽은 파일 내에 직접 저장됩니다. 해당되는 태그가 없는 Illustrator(내보내기) 요소는 비트맵 그래픽으로 내보내지고 FXG 파일에서 참조됩니다. 비트맵, 일부 필터, 일부 혼합 모드, 그래디언트, 마스크 및 3D가 여기에 포함됩니다. 이러한 효과 중 일부는 FXG로 내보낼 수 있지만 FXG 파일을 여는 애플리케이션으로 가져올 수는 없습니다.

FXG 내보내기를 사용하여 벡터 및 비트맵 이미지를 포함한 파일을 내보내면 FXG 파일과 함께 별도의 폴더가 만들어집니다. 이 폴더의 이름은 <파일 이름.에셋>이며 FXG 파일에 연결된 비트맵 이미지가 포함됩니다.

FXG 파일 형식에 대한 자세한 내용은 FXG 2.0 사양을 참조하십시오.

FXG 내보내기 제한

Animate에서는 스테이지에서 FXG로 내보내기 위한 객체를 한 개 또는 여러 개 선택할 수 있습니다. FXG 형식으로 내보낼 때는 객체 및 레이어 이름이 보존됩니다.

FXG 파일로 저장할 때의 제한 사항은 다음과 같습니다.

  • Scale-9 격자: 내보낼 수 있지만 Adobe Illustrator에서만 읽을 수 있습니다.

  • 사운드 및 비디오: 내보내지지 않습니다.

  • 구성 요소: 내보내지지 않습니다.

  • 여러 프레임을 포함하는 트윈 및 애니메이션: 내보내지지 않지만, 선택한 프레임은 정적 객체로 내보내집니다.

  • 포함된 글꼴: 내보내지지 않습니다.

  • 버튼 심볼: Animate에서는 버튼 업 상태만 내보냅니다.

  • 3D 속성: 내보내지지 않습니다.

  • IK(역기구학) 속성: 내보내지지 않습니다.

  • 텍스트 특성: 일부 특성은 내보낼 수 없습니다.

Animate 내용을 FXG 형식으로 내보내기

Animate에서는 다음 두 가지 방법으로 내용을 FXG 형식으로 내보낼 수 있습니다.

  • 스테이지의 객체를 FXG로 내보내려면 객체를 선택한 다음 내보내기 > 선택 항목 내보내기를 선택합니다. 그런 다음 파일 유형 메뉴에서 FXG 형식을 선택합니다.

  • 전체 스테이지를 FXG로 저장하려면 내보내기 > 이미지 내보내기를 선택한 다음 파일 유형 메뉴에서 Adobe FXG를 선택합니다.

JPEG 시퀀스 및 JPEG 이미지

이 옵션은 JPEG 제작 설정 옵션과 일치합니다. 그러나 스크린에 일치는 내보낸 이미지를 스크린에 표시할 때 Animate 내용의 크기와 일치시킵니다. 동영상에 맞춤을 사용하면 JPEG 이미지의 크기가 Animate 내용과 동일하게 되고 원본 이미지의 종횡비가 유지됩니다.

PNG 시퀀스 및 PNG 이미지

PNG 내보내기 설정 옵션은 다음 항목만 제외하고, 사용자가 적용할 수 있는 PNG 제작 설정 옵션과 유사합니다.

크기

내보내는 비트맵 이미지의 크기를 높이 필드에 입력한 픽셀 수로 설정합니다.

해상도

해상도를 dpi 단위로 입력합니다. 스크린 해상도를 사용하고 원본 이미지의 종횡비를 유지하려면 스크린에 일치를 선택합니다.

색상

PNG 제작 설정 탭의 비트 심도 옵션과 동일합니다. 이미지를 만드는 데 사용할 픽셀당 비트 수를 설정합니다. 256색 이미지의 경우 8비트를 선택하고, 많은 색상이 있는 이미지의 경우 24bpc를 선택하며, 많은 색상과 투명도(32bpc)가 있는 이미지의 경우에는 24bpc - 알파 채널 포함을 선택합니다. 비트 심도가 높을수록 파일 크기가 커집니다.

포함

최소 이미지 영역을 내보내거나 전체 문서 크기를 지정하려면 선택합니다.

참고:

내보낸 GIF의 치수는 4000픽셀 미만의 값으로 제한됩니다. 이러한 치수 제한은 버전 CS6 이상에 적용 가능합니다.

참고:

[256색상] 옵션이 선택된 경우 [단색 디더링] 옵션은 작동하지 않습니다. 즉, GIF에 대해 선택된 색상 체계가 256색상인 경우 GIF 이미지가 디더링되지 않습니다.

(Animate CC에서 더 이상 사용 안 됨) 비트맵(BMP) 이미지

다른 애플리케이션에서 사용할 수 있는 비트맵 이미지를 만듭니다. 비트맵 내보내기 대화 상자에는 다음 옵션이 포함되어 있습니다.

크기

내보내는 비트맵 이미지의 크기를 픽셀 단위로 설정합니다. 사용자가 지정하는 크기가 항상 원본 이미지와 동일한 종횡비를 갖습니다.

해상도

내보내는 비트맵 이미지의 해상도를 인치 당 도트 수(dpi) 단위로 설정하고 사용자의 드로잉 크기를 기준으로 폭 및 높이를 자동으로 계산합니다. 해상도가 모니터와 일치하도록 설정하려면 스크린에 일치를 선택합니다.

색상 심도

이미지의 비트 심도를 지정합니다. 일부 Windows 애플리케이션에서는 비트맵 이미지용 최신 32bpc(채널당 비트) 심도를 지원하지 않으므로 32bpc 형식을 사용하는 데 문제가 있으면 24bpc 형식을 사용하십시오.

매끄럽게

내보내는 비트맵에 앤티앨리어싱을 적용합니다. 앤티앨리어싱을 사용하면 고품질의 비트맵 이미지가 생성되지만 색이 칠해진 배경에서는 이미지 주변에 회색 픽셀 후광이 생깁니다. 후광이 나타나면 선택 취소합니다.

Animate 문서(SWF)

Dreamweaver와 같은 다른 애플리케이션에 Animate 내용을 배치하려면 전체 문서를 SWF 파일로 내보냅니다. Animate가 FLA 파일에 대한 현재 제작 설정 값을 사용하여 SWF 파일을 내보냅니다.

Adobe Media Encoder를 사용한 HD 비디오 내보내기

Animate CC에서는 트윈, 심볼, 그래픽을 다양한 형식의 고화질(HD) 비디오에 내보낼 수 있습니다. Animate에서 내보낸 HD 비디오는 통신이 가능한 비디오 회의, 스트리밍, 공유 애플리케이션에서 사용할 수 있습니다.

기본적으로 Animate 에서는 QuickTime 동영상(.MOV) 파일로만 내보낼 수 있습니다. MOV 파일로 내보낼 때 QuickTime 라이브러리가 사용되므로 Animate의 내보내기 기능을 사용하려면 최신 버전의 QuickTime Player를 설치해야 합니다.

Animate가 이제 Adobe Media Encoder와 통합되었기 때문에 HD 비디오 내보내기 작업 과정이 변경되었습니다. 이제, MOV 파일을 다른 여러 형식으로 변환할 수 있습니다. Adobe Media Encoder는 Animate 내용 관련 내보내기 형식만 제공하도록 최적화되었습니다. Adobe Media Encoder를 사용하여 비디오를 인코딩하고 내보내는 방법에 대한 자세한 내용은 비디오와 오디오 인코딩 및 내보내기를 참조하십시오.

참고:

Adobe Media Encoder는 Creative Cloud 데스크톱 애플리케이션에서 Animate CC를 설치하는 경우 자동으로 설치됩니다.

이전 및 최신 비디오 내보내기 작업 과정 간의 차이점

새로운 작업 과정은 CS6 이하 버전의 비디오 내보내기 작업 과정과 다릅니다.

주요 차이점은 다음과 같습니다.

  • Adobe Media Encoder와의 통합: Animate CC는 Adobe Media Encoder 7.0와 통합되었지만, 이전 버전은 AME에 종속되지 않습니다.
  • 내보내기 형식: Animate CC에서는 QuickTime 동영상만 내보낼 수 있습니다.
  • HD 비디오: Animate CC에서는 HD 비디오를 내보낼 수 있습니다.

또한 CS6 작업 과정에는 다음과 같은 문제가 있었습니다.

  • QuickTime을 사용하는 MOV 내보내기 작업 과정은 오류가 발생할 가능성이 있었으며 메모리를 많이 소모했습니다.
  • AVI 내보내기는 동영상 클립을 지원하지 않았습니다.

Animate CC에서는 프레임 손실 문제와 더불어 앞서 언급된 문제가 수정되었습니다. Adobe Media Encoder 작업 과정을 사용하면 Animate CC에서 MOV 파일을 원활하게 내보낼 수 있습니다. 새로운 AME 기반 작업 과정을 사용하여 Animate 내용을 MOV 파일로 내보낸 후 AME를 사용하여 MOV 파일을 원하는 출력으로 변환할 수 있습니다.

프레임 #2에서 시작되는 내보내기

타임라인 구성 방식에 따라, 내보낸 비디오는 다음 시나리오 중 하나의 결과일 수 있습니다.

  1. 루트 타임라인에 둘 이상의 프레임이 있는 경우 내보내기가 프레임 #2에서 시작됩니다.
  2. 루트 타임라인에 프레임이 하나뿐인 경우에는 내보내기에 프레임 #1이 포함됩니다.
  3. 루트 타임라인에 둘 이상의 프레임이 있고 프레임 #1에 ActionScript 또는 사운드가 추가된 경우에는 호출되지 않습니다.

HD 비디오 내보내기

내보내기를 시작하기 전에 다음을 수행합니다.

  • QuickTime을 설치합니다.
  • 프레임 속도를 60fps보다 작거나 같은 값으로 설정합니다. 자세한 내용은 애니메이션 기본 사항을 참조하십시오.
  1. FLA를 만들거나 기존 FLA를 엽니다.

  2. 파일 > 내보내기 > 비디오 내보내기로 이동합니다.

    export-video
    비디오 내보내기 대화 상자

  3. 비디오 내보내기 대화 상자에서 렌더링 폭렌더링 높이스테이지 크기에 설정되는 예상 폭과 높이 값입니다.

  4. 비디오 내보내기 대화 상자에서 원하는 옵션을 설정합니다.

    • 렌더링 크기 HW: HD 비디오를 내보낼지, 아니면 보통 비디오를 내보낼지에 따라 내보내려는 해상도에 맞춰 렌더링 크기를 구성합니다. 각각 스테이지높이와 같은 값을 설정합니다. 렌더링 폭렌더링 높이 값을 변경하려면 원하는 대로 스테이지 크기를 수정하면 됩니다. Animate에서는 스테이지 크기에 따라 종횡비가 유지됩니다.
    • 스테이지 색상 무시(알파 채널 생성): 스테이지 색상을 사용하여 알파 채널을 생성합니다. 알파 채널이 투명한 트랙으로 인코딩됩니다. 따라서 내보낸 QuickTime 동영상을 다른 내용 위에 오버레이하여 배경 색상 또는 장면을 변경할 수 있습니다.
    • Adobe Media Encoder에서 비디오 변환: AME를 사용하여, 내보낸 MOV 파일을 다른 형식으로 변환하려면 이 옵션을 선택합니다. 이 옵션을 선택하면 Animate의 비디오 내보내기 작업이 완료된 후 AME가 시작됩니다.
    • 내보낸 비디오 경로: 비디오를 내보내려는 경로를 입력하거나 찾아 선택합니다.
    • 내보내기 중단: Animate에서 내보내기를 중단하는 경우 이 옵션을 지정합니다.
      • 마지막 프레임 도달 시간: 마지막 프레임에서 중단하려는 경우 이 옵션을 선택합니다.
    마지막 프레임에 도달하면 내보내기 중단
    마지막 프레임에 도달하면 내보내기 중단
    • 내보내기 중단: Animate에서 내보내기를 중단하는 경우 이 옵션을 지정합니다.
      • 다음 시간 경과 후: 일정 시간 후 내보내기를 종료하려면 이 옵션을 선택하고 기간을 지정합니다. 이 옵션을 사용하면 비디오를 섹션마다 별도로 내보낼 수 있습니다.
    1분 15초 후 내보내기 중단
    1분 15초 후 내보내기 중단
    3초 후 내보내기 중단
    3초 후 내보내기 중단

  5. 내보내기를 클릭합니다. Adobe Media Encoder에서 비디오 변환 옵션을 선택한 경우 AME가 시작되고, 내보낸 MOV 파일을 새 대기열에서 사용할 수 있게 됩니다. AME를 사용하여 비디오를 인코딩하고 변환하는 방법에 대한 자세한 내용은 비디오와 오디오 인코딩 및 내보내기를 참조하십시오.


이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책