Auslösen und Steuern von Marionetten

Auslöser werden erstellt, um die Funktion von Gruppen und Ebenen zu steuern. Dabei werden Gruppen und Ebenen ein- oder ausgeblendet, wenn eine Taste gedrückt wird. Sie können eine Vielzahl von Auslösern erstellen, einschließlich Handpositionen, wiederholten Feuerbällen und Blinzelzyklen, um Ihre Marionetten zu steuern. 

Ein Tutorial zur Steuerung eines Charakters mit Auslösern finden Sie hier.

Verhalten „Auslöser“ und Auslöserfenster

Das Auslöserverhalten wird standardmäßig auf neue Marionetten angewendet. Es ermöglicht Ihnen, Grafiken auszulösen und Auslöser mit benutzerdefinierten Namen einzurichten, die auf Ebenen in verschiedenen Gruppen verweisen können. Diese benannten Auslöser werden im Bedienfeld „Auslöser“ aufgeführt, in dem Sie eine Taste einem Auslöser zuweisen, die Liste der durch einen bestimmten Auslöser gesteuerten Ebenen anzeigen und Auslösergrafiken sogar eine MIDI-Note zuweisen können, indem Sie ein verbundenes MIDI-Gerät verwenden. 

Auslöserfenster
Auslöserfenster

Es gibt zwei Arten von Auslösern: 
• Einzelne Auslöser – bei diesen Auslösern sind die Ebenen standardmäßig ausgeblendet. Sie werden erst dann eingeblendet, wenn eine Taste gedrückt, eine MIDI-Note abgespielt oder ein MIDI-Controller ausgeführt wird (wenn beispielsweise die H-Taste gedrückt wird, um einen Hut auf einer Figur einzublenden). 
• Tauschsätze: Diese zeigen nur einen Auslöser gleichzeitig an, wie z. B. für unterschiedliche Gesten. Der Satz von Auslösern ist einer Gruppe von Ebenen in einer Marionette zugewiesen. Jeder Auslöser im Satz ist einer eigenen Auslösertaste oder MIDI-Note zugewiesen und einer der Auslöser kann als Standard festgelegt sein.

Durch Klicken auf den Namen einer Ebene, die einem Auslöser zugewiesen ist, wird die Ebene im Marionettenfenster angezeigt. Wenn Sie eine Ebene oder Gruppe in einer Marionette anzeigen möchten, ohne die anderen Ebenen oder Gruppen zu beeinflussen, verwenden Sie einen einzelnen Auslöser. Wenn Sie möchten, dass diese Ebene oder Gruppe weitere Ebenen oder Gruppen ausblendet (z. B. Drücken der Taste „B“, um die Ebene „Blinzeln“ in einer Gruppe anzuzeigen, die auch Pupillen- und Augapfelebenen enthält), verwenden Sie einen Tauschsatz.

Hinweis: Das veraltete Verhalten „Tastaturauslöser“ funktioniert weiterhin, wenn Sie jedoch das neue Bedienfeld „Auslöser“ verwenden möchten und keine älteren „Tastaturauslöser“-Aufzeichnungen besitzen, die Sie beibehalten müssen, ersetzen Sie es durch „Auslöser“.

Erstellen und Bearbeiten von Auslösern

Das Bedienfeld „Auslöser“ ist im Arbeitsbereich „Anpassen“ standardmäßig geöffnet. Sie können es auch über den Menübefehl Fenster > Auslöser öffnen oder schließen.

Erstellen eines einzelnen Auslösers, der eine Marionettenebene zeigt

Führen Sie einen der folgenden Schritte durch:
• Klicken Sie in die Auslöserspalte (  ) für eine Marionettenebene, der noch kein Auslöser zugewiesen wurde (kein Symbol in der Spalte), und wählen Sie dann  Auslöser erstellen aus.

• Klicken Sie im Marionettenfenster mit der rechten Maustaste auf die Ebene und  wählen Sie dann  Auslöser erstellen aus.

• Ziehen Sie die Ebene aus dem Bedienfeld „Marionette“ und legen Sie sie im Bedienfeld „Auslöser“ ab.

Legen Sie die Ebene auf einem Tauschsatz ab, um ihn zu diesem hinzuzufügen. Legen Sie sie an einer anderen Position ab, um einen individuellen Auslöser zu erstellen.

• Klicken Sie auf die Schaltfläche Hinzufügen (+) im Bedienfeld „Auslöser“ und  wählen Sie dann  Auslöser erstellen für einen leeren Auslöser aus. Legen Sie dann Marionettenebenen darauf ab oder fügen Sie sie hinzu.

Auslöser mit Problemen (Schlüsselkonflikten, keine Ebenen usw.) werden orange angezeigt. Fahren Sie mit dem Mauszeiger über den Auslöser, um Details anzuzeigen. In der QuickInfo wird darauf ebenfalls hingewiesen.

Erstellen eines Auslöser-Tauschsatzes

Führen Sie einen der folgenden Schritte durch:
• Klicken Sie in die Auslöserspalte (  ) für eine Marionettengruppe, deren Ebenen noch kein Auslöser-Tauschsatz zugewiesen wurde (keine Symbole in der Spalte), und wählen Sie Tauschsatz erstellen aus.

• Klicken Sie in einer Gruppe von Ebenen mit der rechten Maustaste in das Fenster „Marionette“ und wählen Sie Tauschsatz erstellen.

• Klicken Sie im Bedienfeld „Auslöser“ auf Hinzufügen (+), wählen Sie Tauschsatz erstellen und ziehen Sie einzelne Auslöser oder Marionettenebenen (die Sie als einzelne Auslöser verwenden möchten) dorthin.

Ein neuer Auslösersatz wird im Bedienfeld „Auslöser“ erstellt. Diese Auslöser werden jeweils nach den ausgewählten Ebenen benannt. Wenn Marionettenebenen in der Gruppe sichtbar sind, wird die oberste Ebene zum Standardauslöser im Tauschsatz. Sie können den Tauschsatz umbenennen und sich gegen einen Standardauslöser entscheiden.

Auslösern Kennzeichnungen zuweisen

Weisen Sie Auslösern Kennzeichnungsfarben zu, um zusammengehörige Auslöser oder Tauschsätze im Bedienfeld „Auslöser“ leicht identifizieren zu können. Sie können auch das Bedienfeld „Auslöser“ filtern, um Auslöser und Tauschsätze mit gleichen Farben anzuzeigen.

Auslöser mit zugewiesenen Kennzeichnungen

Wählen Sie einen oder mehrere Auslöser oder Tauschsets > klicken Sie mit der rechten Maustaste auf eines der Elemente > wählen Sie aus der Liste der Kennzeichnungsfarben. Stellen Sie „Keine“ ein, wenn Sie keine Kennzeichnung zuweisen möchten. Standardmäßig ist keine Kennzeichnung zugewiesen.

Klicken Sie mit der rechten Maustaste auf den Auslöser und Tauschsatz mit der entsprechenden Kennzeichnungsfarbe und wählen Sie dann „Kennzeichnungsgruppe auswählen“ aus.

Klicken Sie in das Suchfeld für Filter im Bedienfeld „Auslöser“ > geben Sie Kennzeichnung:Farbe ein (z. B. Kennzeichnung:gr, um Elemente mit einer grünen oder einer grauen Kennzeichnung anzuzeigen).

Festlegen der Standardauslöser

Um einen bestimmten Auslöser in einem Tauschsatz als Standard festzulegen, führen Sie einen der folgenden Schritte aus:
・Wählen Sie den Auslöser aus und wählen Sie dann die Option Standard unten im Fenster aus.
・Klicken Sie auf das Auslösersymbol neben dem Namen des Auslösers.
・Doppelklicken Sie auf den Namen des Auslösers.
Der Standardauslöser wird durch ein helleres ausgefülltes Symbol und einen helleren Namen markiert. Wenn Sie keine Ebenen standardmäßig auslösen möchten, wiederholen Sie den obigen Schritt, um die Option Standard zu deaktivieren.

Zuweisen einer Ebene oder Gruppe zu einem vorhandenen Auslöser

Um einem vorhandenen Auslöser eine Ebene oder Gruppe zuzuweisen, führen Sie einen der folgenden Schritte aus:
• Klicken Sie im Marionettenfenster mit der rechten Maustaste auf die Ebene oder Gruppe,  wählen Sie  Zu  Auslöser hinzufügen  und anschließend den entsprechenden Auslöser aus dem Kontextmenü aus.
• Ziehen Sie die Ebene oder Gruppe auf den Auslöser im Bedienfeld „Auslöser“.

Konfigurieren der Einstellungen zur Aktivierung des Auslösers

Um den Aufruf des Auslösers zu ändern, wählen Sie den Auslöser im Bedienfeld „Auslöser“ aus und führen Sie einen der folgenden Schritte durch:

  • Geben Sie eine Taste in der Tastaturspalte ein.
  • Klicken Sie auf das Feld MIDI-Note und drücken Sie dann entweder die Taste an Ihrem MIDI-Gerät oder geben Sie die MIDI-Noten-Nummer ein.
  • Um den Auslöser zu verriegeln, sodass Sie die Tastatur- oder MIDI-Taste nicht gedrückt halten müssen, um den Auslöser für längere Zeit zu aktivieren, aktivieren Sie das Kontrollkästchen Riegel im unteren Bereich des Bedienfelds.
  • Durch Hinzufügen einer Ebene oder einer erneuten Wiedergabe eines bestehenden Auslösers wird jetzt der Zielauslöser im Bedienfeld „Auslöser“ ausgewählt.

Im Layoutmodus des Steuerungsfensters können Sie Auslösern Tasten und MIDI-Noten auch direkter zuweisen. Weitere Informationen finden Sie unter Layoutmodus.

Umbenennen, Neuanordnen oder Kombinieren von Auslöser- oder Tauschsätzen

Um einen Auslöser- oder Tauschsatz umzubenennen, wählen Sie ihn im Bedienfeld „Auslöser“ aus, drücken Sie die Eingabetaste bzw. den Zeilenschalter (auf der Haupttastatur, nicht auf der Zehnertastatur) und geben Sie den neuen Namen ein. Um die Änderung zu übernehmen, drücken Sie die Eingabetaste oder klicken Sie außerhalb des Textfelds. Drücken Sie die Escape-Taste, um Ihre Änderungen zu verwerfen.

Um Auslöser neu anzuordnen und sie innerhalb von Tauschsätzen bzw. hinein- oder hinauszuschieben, wählen Sie einen oder mehrere Auslöser aus und ziehen Sie sie ins Fenster. Durch Ziehen eines Tauschsatzes in einen anderen Satz werden die Auslöser zu einem einzigen Tauschsatz kombiniert. Auslöser in einem Tauschsatz neu anzuordnen, ist auch hilfreich, wenn Sie die Priorität der Auslöser basierend auf der angezeigten Reihenfolge festlegen möchten.

Um ausgelöste Ebenen zu kombinieren, ziehen Sie einen Auslöser auf einen anderen Auslöser. Die Ebenen des abgelegten Auslösers werden dem Ziel-Auslöser zugewiesen. Der abgelegte Auslöser wird gelöscht.

Um die Auslöser aus einem Tauschsatz mit denen eines anderen Tauschsatzes zu kombinieren, ziehen Sie den Tauschsatz auf oder in einen anderen Tauschsatz. Die Auslöser des abgelegten Tauschsatzes werden dem Ziel-Tauschsatz hinzugefügt. Der Standardauslöser des Ziel-Tauschsatzes bleibt weiterhin der Standardauslöser.

 

Hinweis:

Wenn Sie eine Marionettengruppe teilbar machen, wechseln alle Auslöser, die den Ebenen der Gruppe zugeordnet sind, zur geteilten Marionette. Alle Steuerelemente für solche Auslöser (im Steuerungsfenster angezeigt) sind nach wie vor der übergeordneten  Marionette  und nicht der geteilten Marionette zugewiesen. Sie können Steuerelemente für die Auslöser der geteilten Marionette generieren.

Anzeigen von Auslösern

Um die Auslöser anzuzeigen, die einer Ebene in einer Marionette zugewiesen sind, führen Sie einen der folgenden Schritte aus:

• Bewegen Sie den Mauszeiger über das Auslösersymbol in der Zeile der Ebene im Bedienfeld „Marionette“. Die Liste der Auslöser (sowie alle Auslösertasten), die die Ebene anzeigen,  wird  in einer QuickInfo angezeigt.
• Klicken Sie auf das Auslösersymbol in der Zeile der Ebene, um den Auslöser im Bedienfeld „Auslöser“ anzuzeigen.
• Wenn eine Ebene mehreren Auslösern zugeordnet ist, klicken Sie auf das Auslösersymbol mit  Pfeil  in der Zeile dieser Ebene und wählen Sie dann den jeweiligen Auslöser aus, der im Bedienfeld „Auslöser“ angezeigt werden soll.

Tipp: Durch Klicken auf den Augapfel für eine Ebene (im Bedienfeld „Marionette“), die einem Auslöser in einem Tauschsatz zugewiesen ist, werden die Augäpfel für andere ausgelöste Ebenen in diesem Tauschsatz automatisch deaktiviert. Klicken Sie bei gedrückter Wahl-/Alt-Taste, um das automatische Umschalten zwischen Augäpfeln zu übersteuern.

Konfigurieren des Verhaltens von Auslösern, wenn mehrere Auslöser aktiviert werden

Um das Verhalten von Auslösern in einem Tauschsatz anzupassen, wenn gleichzeitig mehrere Auslöser aktiviert werden, wählen Sie den Tauschsatz aus und legen Sie die Priorität entweder auf Aktuellste fest, um den zuletzt verwendeten Auslöser zu bevorzugen, oder auf Angezeigte Reihenfolge, um den Auslöser zu bevorzugen, der im Bedienfeld „Auslöser“ ganz oben angezeigt wird. Die Ebenen des bevorzugten Auslösers werden angezeigt.

Entfernen von Ebenen

Um einem Auslöser zugewiesene Ebenen zu entfernen, wählen Sie den Auslöser im Bedienfeld „Auslöser“ aus und klicken Sie im unteren Bereich des Bedienfelds neben den zu entfernenden Ebenen auf „x“.

Hinweis: Wenn alle Ebenen, die einem Auslöser zugewiesen sind, entfernt werden, wird der Auslöser nicht automatisch gelöscht.

Löschen eines Auslöser- oder Tauschsatzes

Um einen Auslöser- oder Tauschsatz zu löschen, wählen Sie ihn aus und wählen Sie anschließend Bearbeiten > Löschen (Taste „Entf“ oder Rücktaste).

Hinweis:

Verhalten wie „Kopfdrehung“, „Lippensynchronisation“, „Bewegungsauslöser“ und „Gesicht“ (für das Blinzeln) lösen separat vom Verhalten „Auslöser“ zusätzliche Ebenen aus. Wenn Sie diese vier Verhalten gemeinsam mit Ebenen, die durch das Verhalten „Auslöser“ ausgelöst wurden, in einer Marionettengruppe verwenden möchten, aktivieren Sie die Option „Andere in der Gruppe ausblenden“ für die Ebenen, die nicht von diesen vier Verhalten ausgelöst werden. Bei Verwendung dieser Option bestimmt die Ebenenreihenfolge die Priorität. Ändern Sie die andernfalls die Struktur der Grafikdatei.

Kopieren von Auslösern zum Austausch zwischen Marionetten

Hinweis:

Bei Marionetten, bei denen die Namen der Tauschsätze und Auslöser übereinstimmen, können Sie die Auslöser von der einen Marionette kopieren und in die andere einfügen. Kopieren Sie diese Tauschsätze und Auslöser von der ursprünglichen Marionette, bevor die Einstellungen dieser Auslöser aufgenommen werden. Andernfalls funktionieren die eingefügten Auslöser nicht.

Um die Kompatibilität von Auslösern zwischen Marionetten einzurichten, führen Sie die folgenden Schritte aus:

  1. Wählen Sie die Marionette aus, von der Sie die Auslöser kopieren möchten. Wählen Sie im Bedienfeld Auslöser die Tauschsätze und Auslöser aus, die Sie kopieren möchten.

  2. Um die Auslöser zu kopieren, wählen Sie Bearbeiten > Kopieren. Um Tauschsätze oder Auslöser zwischen Marionetten zu verschieben, wählen Sie Bearbeiten > Ausschneiden.

  3. Wählen Sie die Marionette aus, in die Sie die Tauschsätze oder Auslöser  lassen .

  4. Richten Sie den Fokus auf das Bedienfeld „Auslöser“ und wählen Sie Bearbeiten > Einfügen.

Die eingefügten Tauschsätze und Auslöser werden am unteren Ende der Liste der Auslöser angezeigt. Verschieben Sie sie bei Bedarf an eine andere Position in der Liste. Jetzt können Sie eine beliebige Aufnahme von Auslösern durch Kopieren zwischen diesen beiden Marionetten austauschen.

Sie können Tastaturauslöser, die mit einer Version vor der vom Oktober 2017 erstellt wurden, in Auslöser konvertieren, um die flexiblere Auslöserfunktion nutzen sowie das Steuerungsfenster verwenden zu können. Beachten Sie, dass vorhandene Projekte und .puppet-Dateien, die das Verhalten „Tastaturauslöser“ nutzen, auch weiterhin funktionieren.

Bei Marionetten, die auf Auslösern basieren, verwenden Sie das Bedienfeld „Auslöser“ oder „Steuerung“, um sämtliche zugewiesenen Auslösertasten für eine Marionette anzuzeigen.

Steuerungsfenster: benutzerdefiniertes Layout für Marionettenauslöser und Verhaltensparameter 

Das Steuerungsfenster ist eine visuelle Benutzeroberfläche bzw. ein Dashboard zum Zugriff auf Auslöser oder unterstützte Verhaltensparameter für eine Marionette. Wählen Sie die Auslöser und Verhaltensparameter (numerische Werte und Winkel), auf die Sie einen einfachen Zugriff wünschen, und steuern Sie sie von einem einzigen Ort aus. Diese benutzerdefinierten Steuerelemente sind dann mit der Marionette verknüpft. Diese Steuerelemente können für andere als Teil einer exportierten Marionette freigegeben werden.

Das Steuerungsfenster ist standardmäßig in den Arbeitsbereichen Aufnehmen und Streamen geöffnet, Sie können es jedoch mit dem Menübefehl Fenster > Steuerelemente ebenfalls öffnen. Das Bedienfeld enthält die Steuerelemente, die mit der im Projektfenster oder im Zeitleistenfenster ausgewählten Marionette oder der im Marionettenfenster geöffneten Marionette verknüpft sind.

Das Steuerungsbedienfeld verfügt über zwei Modi:

  • Layoutmodus: Hier können Sie den Inhalt und das Aussehen der Steuerelemente anpassen.
Layoutmodus
Layoutmodus

  • Durchführungsmodus: In diesem Modus können Sie verschiedene Steuerelemente verwenden, indem Sie auf die Links oben im Fenster klicken.
Durchführungsmodus
Durchführungsmodus

Layoutmodus

Auslöser für eine Marionette können als klickbare Schaltflächen visualisiert werden, auf denen die Grafik für die einzelnen Auslöser zu sehen ist. Außerdem ist ihnen eine Taste oder MIDI-Hinweis zugeordnet. Sie können die Verhaltensparameter für eine Marionette und alle zugeordneten MIDI-Noten als justierbare Regler oder Winkelsteuerelemente darstellen. Das Layout wird zusammen mit der Marionette gespeichert und beim Export in eine .puppet-Datei eingeschlossen, sodass Sie Auslöserlayouts für andere freigeben können.

Im Folgenden werden die verfügbaren Steuerelemente im Layoutmodus beschrieben.

Steuerungen zum Bedienfeld hinzufügen: Wählen Sie die Marionette und eine der folgenden Optionen aus: 

  • Wenn das Bedienfeld leer ist, klicken Sie im Bedienfeld auf den Link Steuerelemente für „Marionettennamen“ erstellen, um Schaltflächen-Steuerelemente basierend auf den Auslösern der Marionette zu erstellen.
  • Wenn Auslöser kürzlich im Fenster Auslöser hinzugefügt wurden oder wenn Sie zuvor einige Auslöser-Steuerelemente gelöscht haben, klicken Sie auf die Schaltfläche Steuerelemente aktualisieren . Dadurch werden Schaltflächen für die zusätzlichen Auslöser oder für die zuvor gelöschten Auslöser-Steuerelemente hinzugefügt.
  • Wenn eine Marionettenspur im Bedienfeld „Schnitt“ ausgewählt ist, ziehen Sie den Namen eines beliebigen numerischen Verhaltensparameters aus dem Bedienfeld „Eigenschaften“ in das Bedienfeld „Steuerungselemente“. Sie können auch über den Namen dieser Parameter rechtsklicken und „Zu Steuerungsfenster hinzufügen“ auswählen.

Gehen Sie wie folgt vor, um Steuerelemente für bestimmte Auslöser zu erstellen:

  • Wählen Sie die Auslöser oder Tauschsätze im Bedienfeld „Auslöser“ aus und ziehen Sie sie in das Bedienfeld „Steuerungselemente“.
  • Klicken Sie mit der rechten Maustaste auf einen Auslöser oder Tauschsatz und wählen Sie dann im Kontextmenü „Zu Steuerungsfenster hinzufügen“ aus.

Mehrere Steuerelemente aktivieren oder deaktivieren: Führen Sie einen der folgenden Schritte aus: 

  • Klicken Sie bei gedrückter Umschalttaste oder Befehls-/Strg-Taste auf die Steuerelemente. 
  • Ziehen Sie einen Rahmen um die Steuerelemente. Halten Sie die Umschalt- oder die Befehls-/Strg-Taste gedrückt, um die Auswahl der mit dem Rahmen markierten Steuerelemente umzuschalten. 
  • Drücken Sie die Befehls-/Strg-Taste + A, um alle Steuerelemente auszuwählen.
  • Drücken Sie die Umschalttaste + Befehls-/Strg-Taste + A, um die Auswahl aller Steuerelemente aufzuheben.

Ordnen Sie Steuerelemente neu: Führen Sie einen der folgenden Schritte aus

  • Ziehen Sie die ausgewählten Steuerelemente im Bedienfeld. Die gezogenen Steuerelemente können am Rasterlayout ausgerichtet werden. 
  • Klicken Sie bei gedrückter Wahl-/Alt-Taste auf die Schaltfläche „Layout aktualisieren“, um einen Reflow der aktuellen Steuerelemente basierend auf der aktuellen Bedienfeldgröße durchzuführen.

So weisen Sie eine andere Taste oder ein anderes MIDI-Steuerelement zu: Wählen Sie das Steuerelement aus und tippen Sie auf die Taste bzw. das MIDI-Steuerelement (Schaltfläche, Schieberegler oder Knopf), die bzw. das Sie verwenden möchten. Dieselbe Wirkung erzielen Sie, wenn Sie die Taste oder MIDI-Note im Bedienfeld „Auslöser“ ändern. Steuerelemente, die einem MIDI-Steuerelement zugeordnet sind, werden im Layoutmodus in einer grünen Überlagerung angezeigt.

Um Parameter schnell zu aktivieren oder zu deaktivieren, ohne die entsprechenden Steuerungen im Bedienfeld Eigenschaften suchen zu müssen, verwenden Sie die Schaltfläche Für Aufnahme vorbereiten und ändern Sie die Verhaltensparameter mithilfe des Schiebereglers und des Knopfes.

Hinweis: Dieses Steuerelement ist nur verfügbar, wenn eine Marionettenspur ausgewählt ist.

Zuweisung einer Taste oder einer MIDI-Note bzw. eines MIDI-Controllers für ein Steuerelement aufheben: Führen Sie einen der folgenden Schritte durch:

  • Klicken Sie mit der rechten Maustaste und wählen Sie „Auslösertaste entfernen“, „MIDI-Note entfernen“ oder „MIDI-Controller entfernen“ (nur verfügbar für Steuerelemente von Verhaltensparametern). 
  • Löschen Sie die Inhalte des Felds „MIDI-Note“ im Bedienfeld Auslöser

Grafik auf einer Schaltfläche für einen Auslöser ändern, der mit mehreren Marionettenebenen verknüpft ist: Klicken Sie mit der rechten Maustaste auf das Schaltflächensteuerelement und dann auf einen Ebenennamen.

Hintergrundfarbe des Steuerelements ändern (zur Erhöhung des Kontrasts bei dunklen Grafiken): Klicken Sie mit der rechten Maustaste auf das Steuerelement und wählen Sie dann entweder „Hell“ oder „Dunkel“. 

Wertebereich für einen Regler oder ein Winkelparameter-Steuerelement ändern: Klicken oder scrubben Sie die blauen Werte für das Minimum (linke Seite) und das Maximum (rechte Seite) auf dem Steuerelement. Wenn Sie beispielsweise den Parameter Transformieren > Skalieren hinzugefügt haben, jedoch keine negative Skalierung benötigen, legen Sie den Wert für das Minimum auf 0 fest. 

Steuerelemente entfernen: Wählen Sie sie aus und wählen Sie dann „Bearbeiten“ > „Löschen“ (Taste „Entf“ oder Rücktaste) oder klicken Sie auf die Schaltfläche „Ausgewählte Steuerelemente löschen“ unten im Bedienfeld. 

 

Benutzerdefinierte Grafiken für Schaltflächensteuerelemente

Sie können benutzerdefinierte Grafiken für Schaltflächensteuerelemente verwenden, indem Sie sie an einer beliebigen Stelle in der Grafikdatei für eine Marionette erstellen. Um eine andere Grafik für Schaltflächen auszuwählen, deren Auslösern mehrere Ebenen zugewiesen sind, klicken Sie mit der rechten Maustaste auf eine Schaltfläche und wählen Sie den Ebenennamen an erster Stelle des Kontextmenüs aus.

Wenn sich dies auf das Aussehen der Marionette in der Szene auswirkt, deaktivieren Sie das ihr zugehörige Augapfel-Symbol.

  • Um eine benutzerdefinierte Grafik einer Schaltfläche zuzuweisen, ziehen Sie die Ebene vom Bedienfeld Marionette auf das Schaltflächensteuerelement.

Wechseln vom Layout- in den Durchführungsmodus

Um zurück zum Durchführungsmodus zu gelangen, doppelklicken Sie im Layoutmodus an beliebiger Stelle neben den Steuerelementen. Die
Tabulatortaste ist der Standard-Tastaturbefehl für den schnellen Wechsel zwischen Layout- und Durchführungsmodus. Sie können im Editor für Tastaturbefehle in der Kategorie „Fenster“ einen anderen Tastaturbefehl für Layoutmodus für Steuerungsfenster umschalten auswählen.

Durchführungsmodus

Klicken Sie auf Durchführen, um in den Durchführungsmodus zu wechseln, wenn Sie die Steuerungen verwenden möchten. Sie können auf die Schaltfläche klicken oder die zugewiesene Taste drücken oder die zugewiesene MIDI-Steuerung berühren, um Aktionen auszuführen. 

Verschieben von Inhalten

Sie können den Inhalt des Steuerungsfensters verschieben, um Steuerelemente anzuzeigen, die sich außerhalb des anzeigbaren Bereichs befinden.
Um den Inhalt des Steuerungsfensters zu verschieben, führen Sie einen der folgenden Schritte aus:

  • Verwenden Sie die vertikalen oder horizontalen Bildlaufleisten.
  • Halten Sie die Wahl-/Alt-Taste oder die mittlere Maustaste gedrückt und ziehen Sie dabei im Bedienfeld.
  • Um horizontal zu blättern, drehen Sie das Mausrad vertikal oder halten Sie die Umschalttaste gedrückt und drehen dabei das Mausrad.

Umbenennen von Steuerelementen für Verhaltensparameter

Im Steuerungsfenster werden die Steuerelemente der Verhaltensparameter nach den zugehörigen Parametern benannt. Diese können umbenannt werden. Führen Sie die folgenden Schritte aus:

  1. Wechseln Sie im Bedienfeld Steuerung zum Modus Layout.

  2. Sie können das Verhaltensparametersteuerelement auswählen und dann die Return-Taste (MacOS) oder die Eingabe-Taste (Windows) drücken, oder Sie können mit der rechten Maustaste auf ein Verhaltensparametersteuerelement klicken und anschließend Umbenennen auswählen.

  3. Geben Sie den gewünschten Namen ein und drücken Sie die Return-/Eingabe-Taste oder klicken Sie außerhalb des Bearbeitungfelds.

Auslösen von Audio

Gestalten Sie Ihre Marionetten lebendiger – mit auslösebarem Audio. Wenn ein Auslöser aktiviert wird, können Sie Audio wiedergeben oder aufzeichnen, indem Sie dem Auslöser Audio hinzufügen. So können Sie beispielsweise eine Marionette etwas rufen lassen, wenn der entsprechende Gesichtsausdruck ausgelöst wird.

Führen Sie die folgenden Schritte aus, um auslösebares Audio aus einer Audiodatei zu erstellen:

  1. Importieren Sie die Audiodatei in das Projekt. Beispielaudiodateien finden Sie hier.
  2. Ziehen Sie die Audiodatei auf eine Marionette im Bedienfeld „Projekt“.

Dadurch wird eine Audiowiedergabe erstellt, die einem neuen Auslöser zugewiesen ist. Sie können diesem Auslöser einen Schlüssel zuweisen und ihn entweder als Auslöser oder als Wiedergabe verwenden. Eine Audiowiedergabe (im Bereich „Wiedergaben“ des Bedienfelds „Eigenschaften“) hat ein Wellenformsymbol neben der Wiedergabetaste und audiospezifische Einstellungen am unteren Rand des Bedienfelds.

Führen Sie die folgenden Schritte aus, um Szenenaudio in eine neue Wiedergabe und einen neuen Auslöser einzufügen:

  1. Wählen Sie die Audiospuren und die in die Wiedergabe aufzunehmenden Marionetten-Takes aus.
  2. Klicken Sie mit der rechten Maustaste auf ein ausgewähltes Take oder eine ausgewählte Audiospur und wählen Sie dann den Befehl „Wiedergabe und Auslöser erstellen“ oder „Wiedergabe und Auslöser in Tauschsatz erstellen“.

Audioauslöser wiedergeben

Auslöser mit Audio können wie jeder andere Auslöser wiedergegeben und aufgenommen werden, indem ihnen ein Schlüssel zugewiesen wird. Nach der Aufnahme werden sie nicht als separate Audiospuren, sondern als Auslöserleisten im Bedienfeld „Zeitleiste“ angezeigt. Wenn diese Auslöserleisten wiedergegeben werden, werden auch die zugehörigen Audiodateien aus den Wiedergaben des Auslösers wiedergegeben.

Hinweis:

Mit aufgezeichneten Auslösern verknüpftes Audio, wird beim Scrubbing in der Zeitleiste (z. B. Audio-Scrubbing) nicht wiedergegeben und nicht beim Erstellen von Einstellungen aus Szenenaudio verwendet (z. B. der Befehl „Lippensynchrone Einstellung aus Szenenaudio berechnen“). Wenn Sie eine Auslöserleiste mit einer Audiowiedergabe aufteilen, beginnt das Audio bei jeder Auslöserleiste am Anfang – das Audio wird nicht geteilt.

Tipp: Wenn Sie eine Marionette mit einer Audiowiedergabe importieren, dessen Quellaudio nicht im Projekt enthalten ist, können Sie es dem Projekt hinzufügen. Wählen Sie hierfür im Kontextmenü der „Audiowiedergabe“ die Option „Audio gemeinsam nutzbar machen“

Fader: Gruppe durch Auslöser ein- und ausblenden

Sie können Tastaturauslöser verwenden, um die Deckkraft der Marionette zu steuern. Mit diesem Verhalten können Sie einen bestimmten Teil einer Marionette ein- oder ausblenden, indem Sie die Deckkraft dieses Teils (einer Gruppe) mithilfe eines Auslösers (beispielsweise eines Tastaturauslösers) erhöhen oder verringern.

Einrichten

Fügen Sie das Verhalten zu einer bestimmten Gruppe einer Marionette hinzu, die Sie ein- oder ausblenden möchten. Das Verhalten wird nicht standardmäßig auf Marionetten angewendet. Um optimale Ergebnisse zu erzielen, sollten Sie Fader und Transformieren nicht für dieselbe Gruppe festlegen. Sie können außerdem eine Auslösertaste für die Gruppe hinzufügen. Verriegeln Sie die Taste, wenn Sie zwischen Ein- und Ausblenden umschalten möchten, indem Sie die Taste drücken, statt sie gedrückt zu halten. 

Hinweis:

Wenn für eine Gruppe die Füllmethode auf Normal festgelegt ist und die Marionette Deckkraft gruppieren verwendet, werden die Ebenen getrennt ausgeblendet, bis die letzte Deckkraftstufe erreicht ist. Problemumgehung: Legen Sie die Deckkraft der Gruppe auf 99,9 % fest.

Steuern

Verwenden Sie den Parameter Dauer, um zu steuern, wie schnell die Deckkraft (in Sekunden) erhöht oder reduziert wird.

Bearbeiten von Auslösereinstellungen

Einstellungen, die durch Aktivieren von Auslösern aufgezeichnet werden, werden im Zeitleistenfenster als Auslöserleisten angezeigt. Sie können sie einfach wie  Mundbild- Leisten ausgerichtet.

Sie können im Zeitleistenfenster die Höhe der Bereiche verringern, in denen die  Einstellungsleisten  für Auslöser und  Mundbild er  angezeigt werden, um eine kompaktere Benutzeroberfläche zu erhalten.

Bearbeitbare Auslösereinstellungen
Bearbeitbare Auslösereinstellungen

Nachstehend sind die verschiedenen Parameter aufgeführt.

  • Auslöserleiste auswählen: Klicken Sie in die Mitte oder auf die Kante der Leiste. Um mehrere Leisten auszuwählen, klicken Sie bei gedrückter Umschalttaste bzw. Befehls-/Strg-Taste oder ziehen Sie einen Rahmen um die Leisten. 
  • Timing einer Auslöserleiste ändern: Ziehen Sie die linke Kante horizontal, um die Startzeit zu ändern, oder ziehen Sie die rechte Kante, um die Endzeit zu ändern. Die linke Kante wird am  Abspielkopf  oder der Start- bzw. Endzeit für  Einstellungs- Leisten ausgerichtet. 
  • Zu einem anderen Auslöser in einem Tauschsatz wechseln: Klicken Sie mit der rechten Maustaste auf die Auslöserleiste und wählen Sie einen der anderen Auslöser im Satz. 

Tipp: Wenn der  Abspielkopf  über einer Auslöserleiste platziert ist, deaktivieren Sie entweder die Marionette oder das entsprechende Verhalten „Auslöser“, um Änderungen an einem Auslöser anzuzeigen. Sie können den  Abspielkopf  auch zeitlich verschieben, um die Änderungen zu sehen.

  • Eine Auslösereinstellung einfügen: Klicken Sie mit der rechten Maustaste über eine Lücke vor, nach oder zwischen Auslöserleisten und wählen Sie einen der verfügbaren Auslöser aus. Eine neue Auslöserleiste beginnt an dem Zeitpunkt, auf den Sie geklickt haben. 
  • Auslöserleiste in zwei Teile teilen: Wählen Sie die Auslöserleiste aus und anschließend entweder Bearbeiten > Teilen (Befehls-/Strg-Taste + Umschalttaste + D), wodurch die Teilung am Abspielkopf erfolgt, oder die Schrägstrichtaste (/), wodurch die Leiste in zwei Hälften geteilt wird.
  • Auslöserleisten löschen: Wählen Sie die Auslöserleisten aus und anschließend entweder Bearbeiten > Löschen (Taste „Entf“ oder Rücktaste) oder klicken Sie mit der rechten Maustaste über eine Auslöserleiste und wählen Sie Löschen.
     

Um die Einstellungsleisten für Auslöser oder Mundbild er auszublenden, wählen Sie den Menübefehl Auslöser- und Mundbild-Einstellungsleiste anzeigen.

Wiedergaben: Wiederverwendbare und auslösbare Aufzeichnungen

Mithilfe von Wiedergaben können Sie die aufgezeichneten Takes für eine Marionette auslösen, entweder live oder für die erneute Aufzeichnung. Diese wiederverwendbaren Einstellungen können beispielsweise erstellt werden, um verschiedene Bewegungen während eines Livestreams oder eine bestimmte Blickrichtung oder Armgeste während der Aufnahme zu wiederholen. Einige Anwendungen einer Zyklusmarionette können stattdessen über die Wiedergabe einer aufgenommenen Bewegung erfolgen. 

Eine Wiedergabe repräsentiert speziell ausgewählte  Takes  und ist mit einem Auslöser verknüpft, dem Sie eine Taste oder einen MIDI-Hinweis für die Aktivierung zuweisen können. Wiederholungen werden auch dann eingefügt, wenn Sie eine Marionette exportieren. Dadurch können Sie die aufgezeichnete Bewegung freigeben, sodass sie von anderen Benutzern ausgelöst werden können.  

Wiederholungen in Character Animator

Erstellen und Bearbeiten von Wiedergaben

Gehen Sie wie folgt vor, um eine Wiedergabe und einen Auslöser zu erstellen:

  1. Wählen Sie eine oder mehrere Einstellungsleisten im Bedienfeld „Schnitt“ aus.

  2. Klicken Sie mit der rechten Maustaste auf einen ausgewählten Take. Wählen Sie dann einen Befehl aus, mit dessen Hilfe eine Wiedergabe erstellt und anschließend einem Auslöser zugeordnet wird (ein neuer Auslöser, ein neuer Auslöser in einem vorhandenen Tauschsatz oder ein vorhandener Auslöser).

Die erstellten Wiedergaben für eine Marionette werden im Bereich Wiedergaben im Bedienfeld „Eigenschaften“ angezeigt und geben die Dauer der Wiedergabe an. Erstellte Wiedergaben und die zugehörigen Auslöser werden standardmäßig nach dem Verhalten für diese Takes benannt. Wenn eine Wiedergabe mehrere Takes für ein Verhalten enthält, wird die Anzahl der Takes hinter dem Namen des Verhaltens in Klammern angezeigt. Verwenden Sie den Suchfilter im Eigenschaftenfenster, um nach Wiedergaben zu suchen.

Erstellte Wiedergaben
Erstellte Wiedergaben

Der Auslöser für die Wiedergabe wird im Bedienfeld „Auslöser“ angezeigt, beispielsweise Auslöser, die die Ebenen einer Marionette angeben. Wenn ein Auslöser ausgewählt ist, werden im Bereich „Ebenen und Wiedergaben“ im unteren Teil des  Fensters  die zugehörigen Marionettenebenen und Wiedergaben aufgelistet. Wenn Sie auf den Namen einer Wiedergabe klicken, wird sie im Bedienfeld „Eigenschaften“ angezeigt. 

Eine Wiedergabe enthält Kopien der Takes, mit deren Hilfe sie erstellt wurde. Daher können Sie die Original-Takes bei Bedarf löschen. 

Wiedergaben, bei denen Probleme vorliegen, werden orange angezeigt. Um weitere Informationen in einer QuickInfo anzuzeigen, bewegen Sie den Mauszeiger über das orangefarbene Symbol oder den Namen.Wiedergaben, die keinem Trigger zugewiesen sind, werden ebenfalls orange angezeigt. Wenn Sie den Mauszeiger darüber bewegen, werden Sie in der QuickInfo darüber informiert, dass die Wiedergabe über keinen Auslöser verfügt.

Sie können auch Halte-Wiederholungen und überblendete Halte-Wiederholungen erstellen und diverse andere Vorgänge für Verhaltensparameter durchführen. Weitere Informationen finden Sie unter Menü „Verhaltensparameter“.

Auswählen von Wiedergaben oder Aufheben der Auswahl von Wiedergaben

  • Eine einzelne Wiedergabe wählen Sie durch einfaches Klicken aus.
  • Wenn Sie einen Wiedergabebereich auswählen möchten, klicken Sie auf die erste Wiedergabe in dem Bereich und klicken Sie dann bei gedrückter Umschalttaste auf die letzte Wiedergabe in dem Bereich.
  • Wenn Sie einzelne Wiedergaben auswählen oder die Auswahl einzelner Wiedergaben aufheben möchten, klicken Sie bei gedrückter Befehlstaste (Mac OS) oder Strg-Taste (Windows) auf die Wiedergabe.
  • Wenn Sie alle Wiedergaben auswählen möchten, drücken Sie die Befehlstaste + A (Mac OS) oder Strg-Taste + A (Windows).
  • Wenn Sie die Auswahl aller Wiedergaben aufheben möchten, drücken Sie die Befehlstaste + Umschalttaste + A (Mac OS) bzw. die Strg-Taste + Umschalttaste + A (Windows).

Umbenennen, Neuanordnen, Löschen und Hinzufügen von Wiedergaben zu einem Auslöser

  • Wenn Sie eine Wiedergabe umbenennen möchten, wählen Sie sie im Bedienfeld Eigenschaften aus, drücken Sie die Return-Taste (macOS) bzw. die Eingabetaste (Windows) oder wählen Sie im Kontextmenü die Option „Umbenennen“ aus. Ändern Sie dann den Namen und drücken Sie die Return-Taste/Eingabetaste oder klicken Sie außerhalb des Textfeldes.
  • Wenn Sie Wiedergaben in der Wiedergabeliste neu anordnen möchten, wählen Sie sie aus und ziehen Sie dann eine ausgewählte Wiedergabe in vertikaler Richtung.
  • Wenn Sie Wiedergaben löschen möchten, wählen Sie sie im Bedienfeld „Eigenschaften“ aus und drücken Sie dann die Taste „Entf“. Die in den ausgewählten Wiedergaben enthaltenen ursprünglichen Takes werden nicht gelöscht.
  • Wenn Sie einem Auslöser Wiedergaben hinzufügen möchten, wählen Sie sie im Bedienfeld „Eigenschaften“ aus, ziehen Sie dann eine ausgewählte Wiedergabe und legen Sie sie im Bedienfeld „Auslöser“ ab. Sie können Wiedergaben wie folgt ablegen: auf einem vorhandenen Auslöser, außerhalb eines vorhandenen Auslösers, um einen neuen Auslöser für jede ausgewählte Wiedergabe zu erstellen, oder in einem Tauschsatz, um sie als Auslöser im Tauschsatz hinzuzufügen.

Wiedergabe und Aufzeichnen von Wiedergaben

Wiedergaben werden normalerweise mit zugehörigen Auslösern erstellt (diese können über eine Taste, eine MIDI-Note oder ein Schaltflächensteuerelement aktiviert werden), aber Sie können Wiedergaben auch direkt verwenden.

Führen Sie eine der folgenden Aktionen aus, um eine Wiedergabe abzuspielen:

• Drücken Sie die Taste oder klicken Sie auf die MIDI-Note oder das Schaltflächensteuerelement (im Steuerungsfenster), die bzw. das dem Auslöser der Wiedergabe zugeordnet ist.

• Klicken Sie im Bedienfeld „Eigenschaften“ neben dem Namen der Wiedergabe auf die Schaltfläche „Abspielen“.

Die aufgezeichneten Takes in der Wiedergabe werden abgespielt, aber der  Abspielkopf bewegt sich nicht. Ein kleiner Zähler neben dem Namen der Wiedergabe im Bedienfeld „Eigenschaften“ gibt den Fortschritt an.

Tipp: Wenn Sie das Abspielen einer Wiedergabe abbrechen möchten, bewegen Sie den Abspielkopf zu einem anderen Zeitpunkt.

Wenn Sie eine Wiedergabe aufzeichnen möchten, aktivieren Sie die Wiedergabe vor oder nach Beginn der Aufzeichnung. Stoppen Sie die Aufzeichnung, wenn Sie fertig sind.

Hinweis:

Bei Verwendung der Befehle „Take mit 1 Frame aufzeichnen“ und „Take mit 2 Frames aufzeichnen“ werden Wiedergaben ignoriert.  
Sie können jedoch ausgewählte Wiedergaben im Bedienfeld „Eigenschaften“ kopieren und in die Zeitleiste einfügen.

Verwenden von Wiedergabeauslösern in Tauschsätzen

Wiedergaben können beliebigen Auslösern zugeordnet werden, einschließlich Auslösern in einem Tauschsatz. Wenn sie dem Standardauslöser in einem Tauschsatz zugeordnet sind, werden diese Wiedergaben sofort abgespielt.

Anhalten und Fortsetzen von Wiedergaben

Standardmäßig spielen Wiedergaben die gesamte Dauer der aufgezeichneten Takes ab, Sie können die Länge der Wiedergabe jedoch über die Auslösungsdauer steuern.

Hinweis:

Das gilt nicht für Einstellungen, die mit Befehl +1, 2 oder 3 erstellt wurden und nicht über bearbeitete Mundbild- /Auslöserwerte verfügen. Diese konstanten Einstellungen verwenden standardmäßig „Anhalten“/„Fortsetzen“.

Wenn Sie die Art und Weise des Abspielens einer Wiedergabe steuern möchten, wählen Sie sie aus und legen Sie dann die Option Ende des Auslösers auf eine der folgenden Einstellungen fest:

Wiedergabe enden lassen: Die gesamte Dauer der aufgezeichneten Takes für die  Wiedergabe  wird abgespielt. Dabei ist es unerheblich, wie lange Sie die Wiedergabe auslösen.

Wiedergabe anhalten/fortsetzen: Die Takes in der Aufnahme werden abgespielt, bis Sie die Auslösung beenden. Wenn Sie die Auslösung über die Dauer der Wiedergabe hinweg fortsetzen, werden die Takes mit der letzten Ausblendungszeit automatisch erweitert. Wenn Sie die Wiedergabe während eines ausgeblendeten Takes anhalten, wird das Take ausgeblendet, sobald der Auslöser anhält.

Konvertieren älterer oder veralteter Tastaturauslöser in Auslöser

Hinweis:

Die alte Tastaturspalte im Marionettenfenster existiert nicht mehr. Bearbeiten Sie die Taste eines veralteten Auslösers im Bereich Tastaturauslöser (veraltet) des Eigenschaftenfensters. Sie können außerdem die Einstellungen für „Riegel“ und „Andere in der Gruppe ausblenden“ anpassen. Die Einstellung „Andere in der Gruppe ausblenden“ kann auch bei Auslösertasten funktionieren, die vom Verhalten „Auslöser“ verwendet werden.

Um eine Marionette von Tastaturauslösern zu Auslösern zu konvertieren, führen Sie die folgenden Schritte aus:

WICHTIG: Mit dem folgenden Vorgang werden vorhandene Tastaturauslöser-Aufnahmen entfernt.

  1. Wählen Sie die Marionette im Projektfenster aus.

  2. Wählen Sie Marionette > Veraltete Auslösertasten konvertieren aus.

    Das Verhalten „Auslöser“ ersetzt das Verhalten „Tastaturauslöser“. Die vorhandenen Auslösertasten werden im Bedienfeld „Auslöser“ in entsprechende Auslöser konvertiert.

  3. (Optional) Konsolidieren Sie alle nicht verwendeten Auslöser im Bedienfeld „Auslöser“, indem Sie einen Auslöser auf einen anderen Auslöser ziehen.

    Wenn Sie eine importierte .puppet-Datei konvertiert haben, exportieren Sie die Marionette in eine neue .puppet-Datei, um diese Änderungen zu speichern.

Adobe-Logo

Bei Ihrem Konto anmelden