Problème

L’icône PDFMaker (Convertir au format Adobe PDF) et le menu Acrobat manquent dans une application Microsoft Office 2003, XP, ou 2000 (Access, Excel ou Word par exemple).

Solution

Adoptez l'une ou plusieurs des solutions suivantes :

Solution 1 : supprimez Adobe PDF de la liste Eléments désactivés dans l’application Microsoft Office.

  1. Ouvrez le programme Microsoft Office (Word, Excel, Publisher ou Excel).
  2. Cliquez sur Aide > A propos de [nom du programme].
  3. Cliquez sur Eléments désactivés.
  4. Dans la liste, sélectionnez Adobe PDF et cliquez sur Activer.
  5. Quittez le programme Microsoft Office, puis relancez-le.

Remarque : les applications Microsoft Office désactivent les compléments en tant que sécurité intégrée si l’application est fermée prématurément (par exemple, le système n’a pas été arrêté correctement ou l’application s’est bloquée).

Solution 2 : assurez-vous que les composants PDFMaker sont installés.

  1. Sélectionnez Démarrer > Exécuter, saisissez appwiz.cpl dans la zone de texte Ouvrir, puis cliquez sur OK pour ouvrir la boîte de dialogue Ajouter ou supprimer des programmes.
  2. Recherchez et sélectionnez Adobe Acrobat 7 ou Adobe Acrobat 8 et cliquez sur Modifier/Supprimer.
  3. Lorsque l’Assistant s’affiche, cliquez sur Suivant.
  4. Sélectionnez Modifier et cliquez de nouveau sur Suivant.
  5. Développez l’arborescence Créer un fichier Adobe PDF, puis cliquez sur la flèche vers le bas sur l’objet Acrobat PDFMaker.
  6. Sélectionnez « Ce composant sera installé sur le disque dur local », cliquez sur Suivant, puis sur Mettre à jour.

Solution 3 : activez le fichier de complément COM dans l’application Office.

  1. Lancez l’application Office.
  2. Sélectionnez Aide > A propos de [application].
  3. Cliquez sur Eléments désactivés.
  4. Recherchez PDFMakerOfficeAddin dans la liste :
    • Si l’élément est répertorié, sélectionnez-le et cliquez sur le bouton Activer. Fermez toutes les boîtes de dialogue, puis relancez l’application Office.
    • Si l’élément n’est pas répertorié, assurez-vous que PDFMOfficeAddin.dll est disponible dans le dossier Acrobat 7.0/PDFMaker/Office (Acrobat 7, Acrobat 3D) ou Acrobat 8.0/PDFMaker/Office (Acrobat 8). Si le fichier est absent, réinstallez Acrobat.

Solution 4 : renommez le fichier Normal.dot.

Pour empêcher la mise en forme, l’insertion automatique et les macros stockées dans le modèle global (Normal.dot) d’affecter le comportement de Microsoft Word et d’autres applications, renommez votre modèle global (Normal.dot). De cette manière, vous pouvez rapidement déterminer si le modèle global est à l’origine du problème.

Important : lorsque vous renommez le modèle Normal.dot, vous réinitialisez plusieurs options avec les paramètres par défaut, y compris des styles personnalisés, des barres d’outils personnalisées, des macros et des entrées d’insertion automatique. Par conséquent, Microsoft recommande vivement de ne pas supprimer votre fichier Normal.dot.

Certaines configurations risquent de créer plusieurs fichiers Normal.dot. Par exemple, ce problème peut se produire si un ordinateur exécute plusieurs versions de Word ou si plusieurs installations de station de travail existent sur le même ordinateur.

Pour renommer le fichier Normal.dot :

Remarque : les étapes suivantes sont spécifiques à Microsoft Word, mais peuvent également être utilisées avec de légères modifications pour d’autres applications Microsoft Office. N’utilisez pas le commutateur /a pour redémarrer Word ou une autre application après avoir terminé ces étapes.

Sous Windows 2000 :

  1. Quittez toutes les instances de Word, y compris Outlook si Word est votre éditeur de courrier électronique.
  2. Choisissez Démarrer > Rechercher > Fichiers et dossiers.
  3. Dans la zone Rechercher les fichiers ou les dossiers nommés, tapez Normal.dot.
  4. Dans la zone Rechercher dans, sélectionnez votre disque dur local.
  5. Cliquez sur Rechercher pour rechercher le fichier.
  6. Pour chaque occurrence du fichier Normal.dot qui s’affiche dans la boîte de dialogue des résultats de recherche, procédez comme suit :
    • Cliquez avec le bouton droit sur le fichier, puis sélectionnez Renommer.
    • Donnez un nouveau nom au fichier (OldNormal.dot ou Normal-1.dot, par exemple), puis appuyez sur la touche Entrée.
  7. Dans le menu Fichier, cliquez sur Fermer pour quitter la recherche, puis relancez Word.

Sous Windows XP :

  1. Quittez toutes les instances de Word, y compris Outlook si Word est votre éditeur de courrier électronique.
  2. Sélectionnez Démarrer > Rechercher.
  3. Sous Que voulez-vous rechercher, sélectionnez Tous les fichiers et tous les dossiers.
  4. Dans la zone Une partie ou l’ensemble du nom de fichier, tapez Normal.dot.
  5. Dans la zone Rechercher dans, sélectionnez votre disque dur local (ou un autre emplacement de modèle utilisateur si vous exécutez Word à partir d’un serveur de réseau).
  6. Cliquez sur Rechercher.
  7. Pour chaque occurrence du fichier Normal.dot qui s’affiche dans la boîte de dialogue des résultats de recherche, procédez comme suit :
    • Cliquez avec le bouton droit sur le fichier, puis sélectionnez Renommer.
    • Donnez un nouveau nom au fichier (OldNormal.dot ou Normal-1.dot, par exemple), puis appuyez sur la touche Entrée.
  8. Dans le menu Fichier, cliquez sur Fermer, puis relancez Word.

Si le problème est résolu lorsque vous renommez le modèle global, il provient d’un modèle Normal.dot endommagé.

Solution 5 : modifiez le niveau de sécurité des macros dans l’application Office.

Pour le chargement du fichier de complément COM dans Windows, l’onglet Editeurs approuvés doit répertorier Adobe Inc. Si ce n’est pas le cas, modifiez les paramètres de sécurité.

Dans les applications Office 2000, XP ou 2003 :

  1. Dans le menu Outils, choisissez Macro > Sécurité.
  2. Cliquez sur l’onglet Editeurs approuvés :
    1. Si Adobe Inc. est répertorié, aucune modification n’est nécessaire.

    2. Si Adobe Inc. n’est pas répertorié, passez à l’étape 3.

  3. Choisissez l’un des paramètres suivants :
    • Dans l’onglet Sécurité, définissez le niveau de sécurité sur Très élevé ; dans l’onglet Editeurs approuvés, sélectionnez Faire confiance à tous les modèles et compléments installés.
    • Dans l’onglet Sécurité, définissez le niveau de sécurité sur Elevé ; dans l’onglet Editeurs approuvés, désactivez l’option Faire confiance à tous les modèles et compléments installés.
  4. Fermez toutes les boîtes de dialogue, puis relancez l’application.

Solution 6 : ajoutez le fichier de complément COM dans le Registre Windows.

  1. Dans l’Explorateur Windows, localisez le fichier de complément COM (PDFMOfficeAddin.dll) et notez le chemin d’accès exact, pouvant comprendre des espaces.
  2. Sélectionnez Démarrer > Exécuter.
  3. Tapez regsvr32 suivi d’un espace, puis saisissez le chemin d’accès noté à l’étape 1, entre guillemets. Par exemple :

    regsvr32 "C:\Program Files\Adobe\Acrobat 8.0\PDFMaker\Office"
  4. Cliquez sur OK, puis lancez l’application Office.

Solution 7 : exécutez la commande Détecter et réparer lorsque aucune autre application n’est en cours d’exécution.

  1. Quittez toutes les applications et redémarrez Windows.
  2. Démarrez Acrobat.
  3. Choisissez Aide > Détecter et réparer et suivez les instructions à l’écran.
  4. Une fois la réparation terminée, redémarrez votre ordinateur.

Solution 8 : supprimez et réinstallez Acrobat en mode simplifié.

Les pilotes de périphériques et logiciels chargés automatiquement avec Windows (les économiseurs d’écran et les utilitaires de protection antivirus, par exemple) peuvent créer un conflit avec le programme d’installation d’Acrobat et causer ensuite des problèmes au sein de l’application Acrobat. Pour éviter les conflits, réinstallez Acrobat alors que Windows se trouve en mode simplifié. En mode simplifié, les pilotes de périphérique non standard et les logiciels de démarrage sont désactivés.

Pour supprimer Acrobat :

  1. Déplacez vos éventuels fichiers personnels hors du dossier d’application Acrobat et de ses sous-dossiers.
  2. Sélectionnez Démarrer > Paramètres > Panneau de configuration, puis double-cliquez sur Ajout/Suppression de programmes.
  3. Sélectionnez Adobe [produit Acrobat] et cliquez sur Supprimer. Pour supprimer l'application, suivez les instructions qui s'affichent.
  4. Redémarrez l'ordinateur.

Pour réinstaller Acrobat en mode simplifié :

  1. Fermez les applications ouvertes.
  2. Dans l'Explorateur Windows, déplacez toutes les icônes et tous les raccourcis des dossiers suivants vers un autre répertoire :
    • Documents and Settings/All Users/Menu Démarrer/Programmes/Démarrage
    • Documents and Settings/ [nom de l’utilisateur] /Menu Démarrer/Programmes/Démarrage
  3. Redémarrez Windows.
  4. Cliquez avec le bouton droit de la souris sur la barre des tâches et sélectionnez Gestionnaire des tâches.
  5. Cliquez sur l’onglet Applications.
  6. Sélectionnez toutes les applications en cours d’exécution et cliquez sur Fin de tâche.
  7. Double-cliquez sur le fichier Setup.exe du support d’installation et suivez les instructions à l’écran pour effectuer l’installation.
  8. Pour réactiver les éléments de démarrage lorsque vous avez terminé l’installation, replacez les icônes et les raccourcis déplacés à l’étape 2 dans leurs dossiers Démarrage respectifs.

Solution 9 : supprimez les macros de Word.

  1. Sélectionnez Outils > Modèles et compléments.
  2. Sélectionnez chaque élément, puis cliquez sur Supprimer.
  3. Fermez et relancez Word.



    Remarque :
    si l’icône Convertir au format PDF reste absente, sélectionnez Outils >Modèles et compléments et assurez-vous que les éléments supprimés n’apparaissent pas. Si les éléments supprimés s’affichent, supprimez la macro de Word ou supprimez l’application ayant installé la macro dans Word.

Solution 10 : supprimez d’autres fichiers de complément COM dans Word.

  1. Démarrez Word.
  2. Sélectionnez Outils > Personnaliser.
  3. Cliquez sur l’onglet Commandes et sélectionnez Outils dans la liste Catégories.
  4. Sélectionnez l’élément Compléments COM et faites-le glisser vers la barre d’outils de Word.
  5. Cliquez sur le menu Compléments COM dans la barre d’outils de Word.
  6. Sélectionnez et supprimez tous les compléments à l’exception de l’assistant de page Web et de l’outil de polices Microsoft Word.
  7. Fermez et relancez Word.

Solution 11 : réparez Access (Access uniquement).

Si vous avez installé Access 2000 après avoir installé Office XP ou Office 2003, vous devez effectuer une réparation d’Office pour faire apparaître le menu PDFMaker.

  1. Cliquez sur Démarrer > Paramètres > Panneau de configuration > Ajout/Suppression de programmes(Windows 2000) ou sur Démarrer > Panneau de configuration > Ajout/Suppression de programmes (Windows XP).
  2. Sélectionnez Microsoft Office, puis cliquez sur Modifier.
  3. Dans la boîte de dialogue Configuration, sélectionnez Réinstaller (Office 2003) ou Réparer (Office XP), puis cliquez sur Suivant.
  4. Choisissez Détecter et réparer les erreurs contenues dans l’installation de Office, puis cliquez sur Installer.

Solution 12 : personnalisez les options de la barre d’outils (Access uniquement).

  1. Sélectionnez Afficher > Barres d’outils > Personnaliser.
  2. Dans l’onglet Barres d’outils, sélectionnez les options Utilitaire 1 et Barre de menus.
  3. Cliquez sur Propriétés.
  4. Cochez la case Autoriser le masquage.

Solution 13 : supprimez les fichiers PDFMaker de versions antérieures du système.

  1. Sélectionnez Démarrer > Rechercher.
  2. Sélectionnez Tous les fichiers et tous les dossiers.
  3. Dans la zone de texte « Une partie ou l’ensemble du nom de fichier : », tapez PDFMaker.* .
  4. Cliquez sur Rechercher.

    Remarque : cette recherche peut prendre plusieurs minutes selon la vitesse de votre système.
  5. Supprimez tous les résultats correspondant à des fichiers système (PDFMaker.DOT ou PDFMaker.XLA, par exemple). Il n’est pas nécessaire d’effacer les documents que vous avez créés et nommés PDFMaker (PDFMaker.doc ou PDFMaker.pdf, par exemple).

Solution 14 : supprimez Microsoft Works.

Adobe a vérifié que Microsoft Works est en conflit avec Microsoft Word et empêchera l’apparition du menu Convertir au format Adobe PDF dans Word. Microsoft Works est préinstallé sur de nombreux ordinateurs.

Pour supprimer Microsoft Works :

  1. Sélectionnez Démarrer > Exécuter, tapez appwiz.cpl dans la zone de texte Ouvrir, puis cliquez sur OK pour ouvrir la boîte de dialogue Ajouter ou supprimer des programmes.
  2. Recherchez et sélectionnez Microsoft Works, puis cliquez sur Modifier/Supprimer.
  3. Lorsque l’Assistant s’affiche, cliquez sur Suivant.
  4. Sélectionnez Supprimer, cliquez sur Suivant, puis suivez les instructions restantes à l’écran.

Informations supplémentaires

Acrobat 7.0-8.0 installe un fichier de complément COM dans le dossier Acrobat 7.0/PDFMaker/Office ou Acrobat 8.0/PDFMaker/Office. Ce fichier fournit les icônes et les commandes de menu PDFMaker pour Word, Excel, PowerPoint, Access, Publisher et Project. Le fichier de complément COM doit être inscrit dans le Registre Windows avant qu’il ne s’affiche dans les applications.

Les icônes PDFMaker n’apparaissent pas dans la barre d’outils si une application Office se bloque et désactive le fichier de complément COM.

D’autres macros et fichiers de complément COM peuvent entrer en conflit avec le fichier de complément COM pour PDFMaker et empêcher l’affichage des icônes Convertir au format PDF dans la barre d’outils.

Dans Access, si l’affichage de la barre d’outils Utilitaire 1 n’est pas activé, les icônes PDFMaker n’apparaissent pas.

329044 : apparition du message « Fichiers PDFMaker manquants » lorsque vous cliquez avec le bouton droit de la souris sur un fichier pour le convertir au format PDF

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne