Mises à jour de sécurité disponibles pour Adobe Flash Player

Date de publication : 14 avril 2015

Dernière mise à jour : 11 août 2015

Identifiant de vulnérabilité : APSB15-06

Priorité : Voir le tableau ci-dessous

Références CVE : CVE-2015-0346, CVE-2015-0347, CVE-2015-0348, CVE-2015-0349, CVE-2015-0350, CVE-2015-0351, CVE-2015-0352, CVE-2015-0353, CVE-2015-0354, CVE-2015-0355, CVE-2015-0356, CVE-2015-0357, CVE-2015-0358, CVE-2015-0359, CVE-2015-0360, CVE-2015-3038, CVE-2015-3039, CVE-2015-3040, CVE-2015-3041, CVE-2015-3042, CVE-2015-3043, CVE-2015-3044

Plate-forme : toutes plates-formes

Synthèse

Adobe a publié des mises à niveau de sécurité pour Adobe Flash Player pour Windows, Macintosh et Linux.   Ces mises à jour corrigent des vulnérabilités susceptibles de permettre à un pirate de prendre le contrôle du système concerné.  

Adobe est conscient qu’une tentative d’exploitation de CVE-2015-3043 existe et recommande aux utilisateurs de mettre à jour leurs produits avec les dernières versions :

  • Les utilisateurs des environnements d’exécution pour bureau d’Adobe Flash Player pour Windows et Macintosh sont invités à passer à la version 17.0.0.169. 
  • Les utilisateurs de la version de support approfondi Adobe Flash Player sont invités à passer à la version 13.0.0.281. 
  • Les utilisateurs d’Adobe Flash Player pour Linux sont invités à passer à la version 11.2.202.457. 
  • Adobe Flash Player, installé avec Google Chrome ou avec Internet Explorer sous Windows 8.x, sera automatiquement mis à jour vers la version 17.0.0.169, dès sa sortie. 
  • Les utilisateurs de l’environnement d’exécution pour bureau d’Adobe AIR doivent installer la version 17.0.0.172.
  • Les utilisateurs du kit SDK Adobe AIR, et du kit SDK et compilateur Adobe AIR sont invités à installer la version 17.0.0.172.

Versions logicielles concernées

  • Adobe Flash Player versions 17.0.0.134 et antérieures
  • Adobe Flash Player version 13.0.0.277 et versions 13.x antérieures
  • Adobe Flash Player version 11.2.202.451 et versions 11.x antérieures
  • AIR Desktop Runtime versions 17.0.0.144 et antérieures
  • Kit SDK et compilateur AIR versions 17.0.0.144 et antérieures 

Pour vérifier le numéro de version d’Adobe Flash Player installé sur le système, accédez à la page A propos de Flash Player ou cliquez avec le bouton droit de la souris sur du contenu exécuté dans Flash Player, puis sélectionnez "A propos d’Adobe (ou de Macromedia) Flash Player" dans le menu. Effectuez cette vérification pour tous les navigateurs utilisés sur votre système.

Pour vérifier le numéro de la version d’Adobe AIR installée sur votre système, suivez les instructions de la note technique concernant Adobe AIR.

Solution

Adobe recommande aux utilisateurs d’effectuer la mise à niveau de leurs installations en procédant comme suit : 

  • Adobe recommande aux utilisateurs des environnements d’exécution pour bureau d’Adobe Flash Player pour Windows et Macintosh d’effectuer une mise à jour vers la version 17.0.0.169, en consultant le Centre de téléchargement Adobe Flash Player ou en utilisant le processus de mise à jour s’ils y sont invités. 

  • Adobe recommande aux utilisateurs de la version de support approfondi d’Adobe Flash Player d’effectuer une mise à jour vers la version 13.0.0.281, en consultant la page http://helpx.adobe.com/fr/flash-player/kb/archived-flash-player-versions.html

  • Adobe recommande aux utilisateurs d’Adobe Flash Player pour Linux d’installer la version 11.2.202.457 en la téléchargeant depuis le _frCentre de téléchargement Adobe Flash Player

  • La version d’Adobe Flash Player installée avec Google Chrome sera automatiquement mise à jour vers la dernière version de Google Chrome, qui inclut Adobe Flash Player 17.0.0.169. 

  • La version d’Adobe Flash Player installée avec Internet Explorer pour Windows 8.x sera automatiquement mise à jour vers la dernière version (comprenant Adobe Flash Player 17.0.0.169), dès sa sortie.

  • Adobe recommande aux utilisateurs des environnements d’exécution pour bureau d’Adobe AIR d’effectuer une mise à jour vers la version 17.0.0.172, en consultant le Centre de téléchargement Adobe AIR.  

  • Adobe recommande aux utilisateurs du kit SDK Adobe AIR d’effectuer une mise à jour vers la version 17.0.0.172, en consultant le Centre de téléchargement Adobe AIR.  

  • Adobe recommande aux utilisateurs du kit SDK et du compilateur Adobe AIR d’effectuer une mise à jour vers la version 17.0.0.172, en consultant le Centre de téléchargement Adobe AIR.

Degrés de priorité et de gravité

Adobe attribue à ces mises à jour les priorités suivantes et recommande aux utilisateurs concernés de mettre à jour leurs installations avec les dernières versions des logiciels :

Produit Versions concernées Plate-forme Priorité
Environnement d’exécution pour bureau d’Adobe Flash Player Versions 17.0.0.134 et antérieures
Windows et Macintosh
1
Version de support approfondi Adobe Flash Player Versions 13.0.0.277 et antérieures Windows et Macintosh
1
Adobe Flash Player pour Google Chrome  Versions 17.0.0.134 et antérieures Windows, Macintosh et Linux
1
Adobe Flash Player pour Internet Explorer 10 et  11 Versions 17.0.0.134 et antérieures Windows 8.0 et 8.1 1
Adobe Flash Player Versions 11.2.202.451 et antérieures Linux 3
Environnement d’exécution pour bureau d’Adobe AIR Versions 17.0.0.144 et antérieures Windows et Macintosh 3
Kit SDK AIR Versions 17.0.0.144 et antérieures Windows, Macintosh, Android et iOS 3
Kit SDK et compilateur AIR Versions 17.0.0.144 et antérieures Windows, Macintosh, Android et iOS  3

Ces mises à jour corrigent des vulnérabilités critiques du logiciel.

Détails

Adobe a publié des mises à niveau de sécurité pour Adobe Flash Player pour Windows, Macintosh et Linux.   Ces mises à jour corrigent des vulnérabilités susceptibles de permettre à un pirate de prendre le contrôle du système concerné. 

Adobe est conscient qu’une tentative d’exploitation de CVE-2015-3043 existe et recommande aux utilisateurs de mettre à jour leurs produits avec les dernières versions :

  • Les utilisateurs des environnements d’exécution pour bureau d’Adobe Flash Player pour Windows et Macintosh sont invités à passer à la version 17.0.0.169.

  • Les utilisateurs de la version de support approfondi Adobe Flash Player sont invités à passer à la version 13.0.0.281.

  • Les utilisateurs d’Adobe Flash Player pour Linux sont invités à passer à la version 11.2.202.457.

  • Adobe Flash Player, installé avec Google Chrome ou avec Internet Explorer sous Windows 8.x, sera automatiquement mis à jour vers la version 17.0.0.169, dès sa sortie.

  • Les utilisateurs de l’environnement d’exécution pour bureau d’Adobe AIR doivent installer la version 17.0.0.172.

  • Les utilisateurs du kit SDK Adobe AIR, et du kit SDK et compilateur Adobe AIR sont invités à installer la version 17.0.0.172.

Ces mises à jour corrigent des vulnérabilités de type « corruption de mémoire » susceptibles d’entraîner une exécution de code (CVE-2015-0347, CVE-2015-0350, CVE-2015-0352, CVE-2015-0353, CVE-2015-0354, CVE-2015-0355, CVE-2015-0360, CVE-2015-3038, CVE-2015-3041, CVE-2015-3042, CVE-2015-3043). 

Ces mises à jour corrigent une vulnérabilité de confusion de type susceptible d’entraîner l’exécution de code (CVE-2015-0356). 

Ces mises à jour corrigent une vulnérabilité de type « débordement de mémoire tampon » susceptible d’entraîner l’exécution de code (CVE-2015-0348). 

Ces mises à jour corrigent des vulnérabilités de type « utilisation de zone désallouée » susceptibles d’entraîner l’exécution de code (CVE-2015-0349, CVE-2015-0351, CVE-2015-0358, CVE-2015-3039). 

Ces mises à jour corrigent des vulnérabilités de type « double-free » susceptibles d’entraîner l’exécution de code (CVE-2015-0346, CVE-2015-0359). 

Ces mises à jour corrigent des vulnérabilités de type « fuite de mémoire » susceptibles de contourner la randomisation du format d’espace d’adresse (ASLR) (CVE-2015-0357, CVE-2015-3040).  

Ces mises à jour corrigent une vulnérabilité de type « contournement de sécurité » susceptible d’entraîner la divulgation d’informations (CVE-2015-3044). 

Logiciels concernés   Mise à niveau recommandée Disponibilité
Environnements d’exécution pour bureau d’Adobe Flash Player
  17.0.0.169

Centre de téléchargement Flash Player

Distribution de Flash Player

Version de support approfondi d’Adobe Flash Player   13.0.0.281 Extension d'assistance
Flash Player pour Linux   11.2.202.457 Centre de téléchargement Flash Player
Flash Player pour Google Chrome   17.0.0.169 Versions Google Chrome
Flash Player pour Internet Explorer 10 et 11   17.0.0.169
Avis de sécurité Microsoft
Environnement d’exécution pour bureau d’Adobe AIR   17.0.0.172 Centre de téléchargement AIR
Kit SDK AIR   17.0.0.172 Téléchargement du kit SDK AIR
Kit SDK et compilateur AIR   17.0.0.172 Téléchargement du kit SDK AIR

Remerciements

Adobe tient à remercier les personnes et sociétés suivantes pour avoir signalé ces problèmes et joint leurs efforts aux nôtres pour protéger nos clients :

  • Anonyme (CVE-2015-3043)
  • bilou pour sa contribution au Chromium Vulnerability Rewards Program (CVE-2015-0357, CVE-2015-0358, CVE-2015-0359)
  • Chris Evans du projet Google Project Zero (CVE-2015-0348, CVE-2015-0352, CVE-2015-0353, CVE-2015-0354, CVE-2015-0355, CVE-2015-0360)

  • instruder de l’équipe Alibaba Security Research Team (CVE-2015-3038)

  • Jihui Lu de KeenTeam (@K33nTeam) pour sa contribution au Chromium Vulnerability Rewards Program (CVE-2015-0351, CVE-2015-3040, CVE-2015-3041)

  • Jouko Pynnönen de Klikki Oy (CVE-2015-0346, CVE-2015-3044)

  • Michele Spagnuolo de l’équipe de sécurité de Google et Mark Brand du projet Google Project Zero (CVE-2015-3042)

  • Natalie Silvanovich pour sa contribution au projet Google Project Zero (CVE-2015-0356)

  • Natalie Silvanovich pour sa contribution au projet Google Project Zeroet bilou pour sa contribution au projet Zero Day Initiative d’HP (CVE-2015-3039)

Révisions

12 mai 2015 : ajout de versions d’Adobe AIR corrigeant les vulnérabilités CVE référencées dans ce bulletin.  

3 juillet 2015 : remerciements supplémentaires à bilou qui travaille sur le projet Zero Day Initiative d’HP et qui avait signalé séparément la vulnérabilité CVE-2015-3039.