Actualizări de securitate disponibile pentru Adobe Flash Player

Data publicării: 13 octombrie 2015

Ultima actualizare: 7 ianuarie 2016

Identificator vulnerabilitate: APSB15-25

Prioritate: Consultați tabelul de mai jos

Număr CVE: CVE-2015-5569, CVE-2015-7625, CVE-2015-7626, CVE-2015-7627, CVE-2015-7628, CVE-2015-7629, CVE-2015-7630, CVE-2015-7631, CVE-2015-7632, CVE-2015-7633, CVE-2015-7635, CVE-2015-7636, CVE-2015-7637, CVE-2015-7638, CVE-2015-7639, CVE-2015-7640, CVE-2015-7641, CVE-2015-7642, CVE-2015-7643, CVE-2015-7644

Platformă: toate platformele

Sumar

Adobe a lansat actualizări de securitate pentru Adobe Flash Player.  Aceste actualizări corectează vulnerabilități critice, care pot permite unui atacator să preia controlul asupra sistemului afectat.

Versiuni afectate

Produs Versiuni afectate Platformă
Componentă runtime desktop Adobe Flash Player 19.0.0.185 și versiunile anterioare
Windows și Macintosh
Versiune cu asistență extinsă Adobe Flash Player 18.0.0.241 și versiunile anterioare Windows și Macintosh
Adobe Flash Player pentru Google Chrome 19.0.0.185 și versiunile anterioare Windows, Macintosh, Linux și ChromeOS
Adobe Flash Player pentru Microsoft Edge și Internet Explorer 11 19.0.0.185 și versiunile anterioare Windows 10
Adobe Flash Player pentru Internet Explorer 10 și 11 19.0.0.185 și versiunile anterioare Windows 8.0 și 8.1
Adobe Flash Player pentru Linux 11.2.202.521 și versiunile anterioare Linux
Componentă runtime desktop AIR 19.0.0.190 și versiunile anterioare Windows și Macintosh
SDK-ul AIR 19.0.0.190 și versiunile anterioare Windows, Macintosh, Android și iOS
SDK-ul și compilatorul AIR 19.0.0.190 și versiunile anterioare Windows, Macintosh, Android și iOS
  • Pentru a verifica versiunea de Adobe Flash Player instalată pe sistem, accesați pagina Despre Flash Player sau faceți clic dreapta pe conținutul care rulează în Flash Player și selectați „Despre Adobe (sau Macromedia) Flash Player” din meniu. Dacă utilizați mai multe browsere, faceți această verificare pe fiecare browser instalat pe sistem.  
  • Pentru a verifica numărul versiunii de Adobe AIR instalate pe sistemul dvs., urmați instrucțiunile din Nota tehnică Adobe AIR

Soluție

Adobe acordă acestor actualizări următoarele evaluări ale priorității și recomandă utilizatorilor să își actualizeze produsele instalate la cea mai nouă versiune:

Produs Versiuni actualizate Platformă Disponibilitate
Componentă runtime desktop Adobe Flash Player
19.0.0.207 Windows și Macintosh
1 Centrul de descărcare Flash Player  Distribuție Flash Player
Versiune cu asistență extinsă Adobe Flash Player 18.0.0.252 Windows și Macintosh
1 Asistență extinsă
Adobe Flash Player pentru Google Chrome 19.0.0.207 Windows, Macintosh, Linux și ChromeOS    1 Versiuni Google Chrome
Adobe Flash Player pentru Microsoft Edge și Internet Explorer 11 19.0.0.207 Windows 10 1 Recomandare de securitate Microsoft
Adobe Flash Player pentru Internet Explorer 10 și 11 19.0.0.207 Windows 8.0 și 8.1
1 Recomandare de securitate Microsoft
Adobe Flash Player pentru Linux 11.2.202.535 Linux 3 Centru de descărcare Flash Player
Componentă runtime desktop AIR 19.0.0.213 Windows și Macintosh 3 Centrul de descărcare AIR
SDK-ul AIR 19.0.0.213 Windows, Macintosh, Android și iOS 3 Descărcați SDK-ul AIR
SDK-ul și compilatorul AIR 19.0.0.213 Windows, Macintosh, Android și iOS 3 Descărcați SDK-ul AIR
  • Adobe le recomandă utilizatorilor componentei runtime desktop Adobe Flash Player pentru Windows și Macintosh să actualizeze Adobe Flash Player la versiunea 19.0.0.207, prin Centrul de descărcare Adobe Flash Player sau prin mecanismul de actualizare din cadrul produsului, când primesc o solicitare în acest sens [1].
  • Adobe le recomandă utilizatorilor versiunii cu asistență extinsă Adobe Flash Player să actualizeze la versiunea 18.0.0.252, vizitând http://helpx.adobe.com/flash-player/kb/archived-flash-player-versions.html.
  • Adobe le recomandă utilizatorilor Adobe Flash Player pentru Linux să actualizeze Adobe Flash Player la versiunea 11.2.202.535, vizitând Centrul de descărcare Adobe Flash Player
  • Adobe Flash Player instalat cu Google Chrome va fi actualizat automat la cea mai recentă versiune Google Chrome, care va include Adobe Flash Player 19.0.0.207 pe Windows, Macintosh, Linux și Chrome OS.
  • Adobe Flash Player instalat cu Microsoft Edge pentru Windows 10 va fi actualizat automat la cea mai recentă versiune, care va include Adobe Flash Player 19.0.0.207.
  • Adobe Flash Player instalat cu Internet Explorer 10 și 11 pentru Windows 8.0 și 8.1 va fi actualizat automat la cea mai recentă versiune, care va include Adobe Flash Player 19.0.0.207.
  • Adobe le recomandă utilizatorilor componentei runtime desktop AIR, ai AIR SDK și ai SDK-ului și compilatorului AIR să actualizeze la versiunea 19.0.0.213, vizitând Centrul de descărcare AIR sau Centrul pentru dezvoltatori AIR
  • Vizitați Pagina de asistență Flash Player pentru asistență la instalarea Flash Player.
 
[1] Utilizatorii Flash Player 11.2.x sau ai versiunilor ulterioare pentru Windows și utilizatorii Flash Player 11.3.x sau ai versiunilor ulterioare pentru Macintosh care au selectat opțiunea „Permite Adobe să instaleze actualizări” vor primi actualizarea automat. Utilizatorii care nu au opțiunea „Permite Adobe să instaleze actualizări” activată pot instala actualizarea prin intermediul mecanismului de actualizare din cadrul produsului, când li se solicită acest lucru.

Detalii privind vulnerabilitatea

  • Aceste actualizări remediază o vulnerabilitate care ar putea fi exploatată pentru a ocoli politica originii comune și ar putea duce la divulgare de informații (CVE-2015-7628).
  • Aceste actualizări includ o caracteristică de apărare în profunzime în API-ul Flash broker (CVE-2015-5569).
  • Aceste actualizări remediază vulnerabilități de utilizare după dealocare, care pot duce la executare de cod (CVE-2015-7629, CVE-2015-7631, CVE-2015-7635, CVE-2015-7636, CVE-2015-7637, CVE-2015-7638, CVE-2015-7639, CVE-2015-7640, CVE-2015-7641, CVE-2015-7642, CVE-2015-7643, CVE-2015-7644).
  • Aceste actualizări remediază o vulnerabilitate de depășire a memoriei tampon care poate duce la executare de cod (CVE-2015-7632).
  • Aceste actualizări remediază vulnerabilități de corupere a memoriei care pot duce la executare de cod (CVE-2015-7625, CVE-2015-7626, CVE-2015-7627, CVE-2015-7630, CVE-2015-7633).

Mențiuni

Adobe dorește să mulțumească următoarelor persoane și organizații pentru raportarea problemelor relevante și pentru colaborarea cu Adobe în scopul protejării clienților noștri: 

  • Dave "dwizzzle" Weston (CVE-2015-5569)
  • bee13oy, lucrând pentru programul Chromium Vulnerability Rewards (CVE-2015-7633)
  • instruder de la centrul de investigații privind amenințările de securitate Alibaba, lucrând pentru inițiativa HP Zero Day (CVE-2015-7629)
  • Anonymous, care lucrează pentru inițiativa HP Zero Day (CVE-2015-7632)
  • Nicolas Joly și Natalie Silvanovich de la Google Project Zero (CVE-2015-7644)
  • bilou, care colaborează cu Zero Day Initiative de la HP (CVE-2015-7631)
  • bilou, lucrând pentru inițiativa HP Zero Day și Yuki Chen de la Qihoo 360 Vulcan Team (CVE-2015-7643)
  • instruder de la Centrul de informații privind amenințările de securitate Alibaba (CVE-2015-7630)
  • Jincheng Liu și Lijun Cheng de la Echipa de cercetare a securității Alibaba (CVE-2015-7625, CVE-2015-7626)
  • Kai Kang de la Tencent's Xuanwu LAB (CVE-2015-7627)
  • Yuki Chen din echipa Qihoo 360 Vulcan (CVE-2015-7635, CVE-2015-7636, CVE-2015-7637, CVE-2015-7638, CVE-2015-7639, CVE-2015-7640, CVE-2015-7641, CVE-2015-7642, CVE-2015-7643)
  • Dl Tokuji Akamine (CVE-2015-7628)

Revizuiri

14 octombrie 2015: S-au adăugat elemente CVE creditate pentru Yuki Chen din echipa Qihoo 360 Vulcan

5 noiembrie 2015: S-a eliminat CVE-2015-7634 din buletin. Acest CVE a fost clasificat inițial drept problemă de corupere a memoriei, dar recent a fost reclasificat ca bug de anulare a referinței pentru un indicator nul neexploatabil.

7 ianuarie 2016: S-a adăugat credit pentru Dl Tokuji Akamine, pentru divulgarea CVE-2015-7628