Il existe quatre façons principales d’influer sur les performances de Photoshop :

  • Optimiser votre configuration matérielle
  • Spécifier vos préférences de performances
  • Utiliser de bonnes habitudes de travail dans Photoshop
  • Prendre certaines mesures pour accélérer le système d’exploitation

Pour obtenir de meilleurs résultats toutefois, suivez une approche holistique, afin d’optimiser les performances de Photoshop. Lisez les présentes suggestions dans leur totalité, afin de connaître celles que vous devez mettre en œuvre dans le contexte de la configuration de votre ordinateur, des types de fichiers que vous utilisez et de vos flux de production. Chaque circonstance est unique et nécessite une combinaison particulière de techniques, en vue d’obtenir les meilleures performances de Photoshop.

Optimiser votre configuration matérielle

Utilisez un processeur suffisamment rapide

La vitesse du processeur limite la vitesse de traitement de Photoshop. Photoshop CS4 nécessite un processeur PowerPC G5 ou multicœur Intel (Mac OS), ou alors un processeur 1,8 GHz ou supérieur (Windows). Photoshop CS5, CS6 et CC nécessitent un processeur multicœur Intel (Mac OS), ou alors un processeur 2 GHz ou supérieur (Windows).

Photoshop est généralement plus rapide avec les processeurs à plusieurs cœurs, même si certaines fonctionnalités tirent davantage profit que d’autres des cœurs supplémentaires. Notez que les bénéfices par cœur diminuent avec le nombre de cœurs : plus le nombre de cœurs utilisés est élevé, moins vous tirez parti de chaque cœur supplémentaire. Par conséquent, Photoshop n’est pas quatre fois plus rapide sur un ordinateur disposant de 16 cœurs que sur un ordinateur qui en compte quatre. Pour la plupart des utilisateurs, l’augmentation des performances fournies par plus de 6 coeurs ne saurait justifier l’augmentation des coûts.

Photoshop CS6, CC et CC 2014 utilisent également davantage le processeur graphique (GPU) que les versions antérieures afin d’améliorer les performances d’un plus grand nombre de fonctionnalités. Cette augmentation de l’utilisation du GPU peut entraîner des problèmes de performances lors de l’exécution de Photoshop CS6 et versions ultérieures dans un environnement virtuel. Les ordinateurs virtuels ne peuvent pas accéder au GPU.

Libérez un maximum de RAM

Photoshop utilise de la mémoire vive (RAM) pour le traitement des images. Si Photoshop ne dispose pas de suffisamment de mémoire, il fait appel à l’espace disponible sur le disque dur (disque de travail) pour traiter les informations. L’accès aux informations en mémoire est plus rapide que l’accès aux informations sur un disque dur. Par conséquent, Photoshop est plus rapide lorsqu’il peut traiter la totalité ou la majeure partie des informations contenues dans la RAM. Attribuez suffisamment de mémoire à Photoshop pour contenir votre fichier d’image le plus volumineux.

A combien de RAM Photoshop peut-il accéder ?

Version de Photoshop Version du système d’exploitation Quantité de RAM maximale que Photoshop peut utiliser
CS4, CS5 et versions ultérieures, 32 bits Windows 32 bits 1,7 Go
CS4, CS5 et versions ultérieures, 32 bits Windows 64 bits 3,2 Go
CS4, CS5 et versions ultérieures, 64 bits* Windows 64 bits Autant de RAM que votre ordinateur peut en contenir
CS4, 32 bits Mac OS 3 Go
CS5, 32 bits Mac OS 2,1 Go
CS5 et versions ultérieures, 64 bits Mac OS Autant de RAM que votre ordinateur peut en contenir

* Photoshop 64 bits n’est pas officiellement pris en charge par Windows XP 64 bits, mais il doit tout de même pouvoir s’exécuter.

Pour plus d'informations sur les performances et Photoshop 64 bits, voir Limitations et avantages du SE en 64 bits | Photoshop CS4, CS5, CS6, CC, CS6, CC.

Pour obtenir des instructions sur l’allocation de mémoire vive (RAM) à Photoshop, reportez-vous à la sectionUtilisation de la mémoire.

Utilisez un disque dur rapide et de grande capacité pour travailler sur les images de grande taille

Photoshop lit et écrit les informations des images sur le disque lorsque la RAM est insuffisante pour toutes les contenir. Vérifiez l’indicateur d’efficacité (voir ci-dessous) pour déterminer si l’acquisition d’un disque dur plus rapide ou d’un disque SSD permettrait d’améliorer vos performances. Si l’indicateur d’efficacité est supérieur à 95 %, le gain de performances d’un disque de travail plus rapide ne compensera probablement pas son coût.

Pour améliorer les performances de Photoshop, utilisez un disque avec un taux de transfert de données rapide. Par exemple, utilisez un disque dur interne ou un disque dur externe connecté via une interface rapide, telle que Thunderbolt, FireWire 800, eSATA ou USB3. Le transfert de données est généralement plus lent sur les serveurs réseau (disques durs accessibles via un réseau).

Photoshop CS4 à CS6 nécessitent au minimum 1 Go d’espace disque disponible (Windows) ou 2 Go d’espace disque disponible (Mac OS). Photoshop CC nécessite au minimum 2,5 Go (Windows) ou 3,2 Go (Mac OS). L’installation requiert de l’espace supplémentaire et Adobe recommande également de l’espace de disque dur supplémentaire pour la mémoire virtuelle et l’espace du disque de travail.

Les architectures RAID 0 rapides constituent d’excellents disques de travail, en particulier lorsqu’elles sont utilisées comme disque de travail exclusivement. Il faut dans ce cas s’assurer que le volume est défragmenté régulièrement et n’est pas utilisé comme volume de démarrage. 

Disques SSD

L’installation de Photoshop sur un disque SSD permet à Photoshop un lancement rapide, en moins d’une seconde. Ce démarrage rapide constitue toutefois le seul gain de temps, car il s’agit de l’unique moment où le disque SSD lit une grande quantité de données.

Pour optimiser l’utilisation du disque SSD, utilisez-le en tant que disque de travail. Une utilisation en tant que disque de travail permet une nette amélioration des performances pour les images dont la taille est supérieure à celle de la RAM. Par exemple, la permutation de mosaïques entre la mémoire RAM et le SSD est beaucoup plus rapide qu’une permutation entre la mémoire RAM et le disque dur.

Si votre SSD ne dispose pas de beaucoup d’espace libre (dans le cas où le fichier de travail dépasse la taille que peut contenir le SSD), vous pouvez ajouter un disque dur secondaire ou tertiaire. (Ajoutez-le après le SSD.) Assurez-vous que ces disques sont sélectionnés en tant que disques de travail dans le volet Performances de la fenêtre des Préférences.

En outre, les SSD présentent des performances très variables, bien plus que les disques durs. L’utilisation d’un lecteur ancien plus lent implique un gain de performances limité par rapport à un disque dur.

Remarque : l’ajout de RAM pour améliorer les performances est plus rentable que l’achat d’un SSD. Si les considérations financières ne sont pas importantes, si votre ordinateur utilise le maximum de sa mémoire RAM ou si vous exécutez Photoshop CS5 en 64 bits, mais que vous voulez malgré tout améliorer les performances de votre ordinateur, nous vous conseillons d’utiliser un disque SSD comme disque de travail.

Comme indiqué plus haut, un SSD n’améliore pas les performances si l’indicateur d’efficacité est déjà élevé. Plus l’indicateur d’efficacité est faible, plus le gain offert par un SSD sera important.

Définition des préférences de performances

Les préférences de performances peuvent considérablement affecter les performances de Photoshop. Pour définir les préférences de performances, sélectionnez Photoshop > Préférences > Performances (Mac OS) ou Edition > Préférences > Performance (Windows). Spécifiez ensuite les options de chacune des zones suivantes :

Utilisation de la mémoire

Plus la quantité de RAM disponible pour Photoshop est importante, plus Photoshop traite rapidement les informations concernant les images. La zone d’utilisation de la mémoire de la boîte de dialogue Préférences de performances indique la quantité de mémoire RAM disponible pour Photoshop. Elle indique également la fourchette idéale pour votre système.

Remarque : la quantité de RAM disponible ne correspond pas à votre quantité totale de RAM. Photoshop décompte la RAM nécessaire au système d’exploitation. 

Par défaut, Photoshop utilise 70 % de la mémoire RAM disponible. Vous pouvez affecter davantage ou moins de RAM à Photoshop en modifiant la valeur de la case Laisser Photoshop utiliser. Vous pouvez également utiliser le curseur d’utilisation de la mémoire. Relancez Photoshop pour activer les changements.

L’allocation par défaut de 70 % convient à la plupart des utilisateurs exécutant une version 32 bits de Photoshop. Pour trouver l’allocation idéale à votre système, modifiez la valeur par incréments de 5% et contrôlez les performances avec l’indicateur d’état d’efficacité. Reportez-vous à la section Contrôler l’indicateur d’efficacité.

Si vous exécutez la version 64 bits de Photoshop et rencontrez un problème de RAM saturée ou des erreurs de mémoire insuffisante, augmentez votre allocation de RAM. Lorsqu’aucune autre application n’est en cours d’exécution, vous pouvez définir l’allocation de RAM à 100 % pour améliorer les performances de Photoshop.

Si vous exécutez la version 32 bits de Photoshop, il est possible que vous rencontriez des erreurs de mémoire RAM saturée lorsque vous définissez l’allocation à 100 %. Si vous rencontrez des erreurs de mémoire RAM saturée, réduisez l’allocation de RAM à 85-90 % et réessayez. Si les problèmes persistent, réduisez l’allocation de RAM par incréments de 5 % et testez de nouveau jusqu’à ce que l’erreur disparaisse, ou bien utilisez la version 64 bits de Photoshop si vous pouvez.

Disques de travail

Définissez le disque de travail sur un disque dur défragmenté disposant d’une grande quantité d’espace non utilisé et d’une vitesse de lecture/écriture élevée (reportez-vous à la section Défragmenter le disque dur). Si vous avez plusieurs disques durs, spécifiez des disques de travail supplémentaires. Photoshop prend en charge jusqu’à 64 exaoctets d’espace sur le disque de travail, sur quatre volumes maximum. (Un exaoctet équivaut à 1 milliard de gigaoctets.)

Si votre disque de démarrage est un disque dur (par opposition à un disque SSD), l’utilisation d’un disque dur différent comme disque de travail principal peut améliorer les performances. Si votre disque de démarrage est un disque SSD, il n’y a aucun intérêt à sélectionner un disque différent comme disque de travail principal. L’utilisation de votre disque SSD comme disque de démarrage du système et volume de travail principal est efficace et probablement meilleure que l’utilisation d’un disque de travail différent. Voir Affectation des disques de travail dans l’aide de Photoshop pour plus d’informations.

Préférences de l’historique et de la mémoire cache

Niveaux de cache

Photoshop utilise la mise en mémoire cache d’images pour accélérer le retraçage des images haute résolution. Grâce à la mémoire cache, Photoshop utilise des versions basse résolution des images pour les mettre à jour rapidement à l’écran. L’option des niveaux de cache vous permet d’indiquer à Photoshop d’enregistrer entre un et huit niveaux de données d’images mises en cache. Plus vous disposez de niveaux de cache, plus Photoshop met du temps à ouvrir le fichier, mais plus il est réactif lorsque vous travaillez. Moins vous disposez de niveaux de cache, plus l’image se charge rapidement, mais plus Photoshop est lent. 

Le niveau de mise en cache par défaut est 4. Vous pouvez toutefois le modifier selon les types de fichiers que vous utilisez et la quantité de mémoire RAM dont vous disposez.

Si vous utilisez des fichiers relativement petits (environ 1 mégapixel ou 1 280 x 1 024 pixels) et de nombreux calques (plus de 50), définissez le cache sur 1 ou 2. La définition des niveaux de cache à 1 désactive la mise en mémoire cache de l’image ; seule l’image à l’écran est placée dans le cache.

Remarque : Certaines fonctionnalités de Photoshop ne permettent pas d’obtenir une qualité optimale si les niveaux de cache sont définis sur 1.

Si vous utilisez des fichiers avec des dimensions en pixels supérieures (50 mégapixels ou plus), définissez les niveaux de cache sur une valeur supérieure à 50. La définition d’un niveau de cache élevé améliore les performances en accélérant le délai de retraçage.

La taille de la mosaïque du cache correspond à la quantité de données traitées lors d’une seule opération. Photoshop traite chacune des mosaïques de données, puis effectue le retraçage. Photoshop est plus performant sur les mosaïques de grande taille, bien que ces dernières prennent plus de temps à se retracer. Les mosaïques volumineuses permettent d’effectuer des opérations complexes, telles que le réglage de la netteté des filtres, plus rapidement. Toutefois, les modifications mineures, telles que l’application de contours, sont plus efficaces lorsque Photoshop utilise des mosaïques plus petites.

Dans Photoshop CS4, vous pouvez modifier la taille de la mosaïque du cache à l’aide du module externe Grands carreaux (reportez-vous à la section Module externe Grands carreaux (Photoshop CS4).

Dans Photoshop CS5 et CS6, vous pouvez choisir une taille de carreaux dans le menu contextuel Taille de la mosaïque du cache dans les préférences de performances. Si vous disposez d’un processeur Intel Core, choisissez 128 K ou 1 024 K. Si votre processeur est Intel Pentium 4 ou AMD, Photoshop est plus performant avec la configuration 132 K ou 1 032 K.

Dans Photoshop CS5 et CS6, la section Historique et cache des préférences de performances possède également trois caches prédéfinis : Haut et fin, Par défaut et Grand et plat. Ces options définissent le niveau de cache et la taille de mosaïque en fonction du type de document que vous éditez et de la quantité de RAM que vous avez.

  • Haut et fin : meilleur pour retoucher les images de petites dimensions disposant de nombreux calques (plusieurs dizaines/centaines).
  • Grand et plat : meilleur pour modifier des images de plus grandes dimensions (plusieurs dizaines/centaines de mégaoctets) mais moins de calques.
  • Valeur par défaut : pour les images intermédiaires.

Etats d’historique

Chaque état d’historique, ou instantané, d’une opération ayant une incidence sur l’image dans son intégralité augmente la quantité d’espace du disque de travail dont le fichier a besoin. Photoshop crée une copie de l’objet d’origine. Ainsi, si vous appliquez un flou gaussien sur une image de 500 Ko et créez un instantané de cette modification dans le panneau Historique, Photoshop nécessite 1 Mo d’espace sur le disque de travail pour l’image. Si vous appliquez un réglage de niveaux, un filtre de bruit et une accentuation à une image de 5 Mo, puis enregistrez un instantané d’historique de chaque état, l’image nécessite 15 Mo d’espace sur le disque de travail.

Chaque état ou instantané d’historique supplémentaire défini dans le cadre Historique augmente l’espace du disque de travail utilisé par Photoshop.  Plus le nombre de pixels modifiés par une opération est élevé, plus l’espace utilisé par l’état d’historique correspondant sera important. Un état d’historique correspondant à un simple trait ou à une opération non destructive, telle que la création ou la modification d’un calque de réglage, occupe peu d’espace sur le disque de travail. Un état d’historique correspondant à l’application d’un filtre à toute une image utilise beaucoup plus d’espace sur le disque de travail.

Vous pouvez enregistrer l’espace du disque de travail et améliorer les performances en limitant ou réduisant le nombre d’états que Photoshop peut enregistrer dans le panneau Historique. Photoshop peut enregistrer jusqu’à 1 000 états d’historique. Par défaut, il en enregistre 20. Afin de réduire ce nombre, cliquez dans le menu contextuel Etat de l’historique de la zone Historique et cache, puis définissez une valeur inférieure en faisant glisser la souris.

Module externe Grands carreaux (Photoshop CS4)

Le module externe Grands carreaux, qui se trouve dans le dossier des modules externes en option du DVD de l’application, est désactivé par défaut. Afin de l’activer, copiez-le dans le dossier Extensions de votre dossier de modules externes Photoshop CS4 et supprimez le tilde (~) du nom de fichier. N’activez ce module externe que si vous avez plus de 1 Go de RAM installé.

Lorsque vous activez le module externe, il augmente la taille de la mosaïque d’images dans Photoshop. Photoshop réactualise plus de données à la fois, car les mosaïques sont plus grandes et sont réactualisées intégralement une par une. Photoshop prend moins de temps pour réactualiser un petit nombre de mosaïques plus grandes, qu’un grand nombre de mosaïques plus petites. Les mosaïques volumineuses semblent parfois se réactualiser plus lentement et prendre plus de temps à s’afficher si vous réalisez de petits ajustements répétés. Toutefois, le temps total de calcul et d’affichage de l’image finale est moindre. Les mises à jour de l’écran pendant la peinture peuvent également être moins fluides lorsque Grands carreaux est installé.

Si vous passez beaucoup de temps à peindre ou que vous peaufinez rapidement les options des filtres ou panneaux et que la réponse de Photoshop est réactive, alors n’activez pas Grands carreaux. Cependant, si la progression des barres est trop lente, activez l’option Grands carreaux pour améliorer les performances.

Paramètres du GPU

Photoshop CS4 et versions ultérieures optimisent l’utilisation du GPU sur la carte graphique de l’ordinateur, afin d’accélérer les opérations d’affichage à l’écran. Pour que Photoshop puisse accéder au GPU, la carte graphique doit disposer d’un GPU prenant en charge OpenGL. Il nécessite également au minimum 128 Mo de RAM et un pilote qui prend en charge OpenGL 2.0 et Shader Model 3.0.

Photoshop CS6 requiert 256 Mo de VRAM. Photoshop 13.1 ne peut pas afficher les fonctions 3D si vous avez moins de 512 Mo sur votre carte vidéo. Photoshop CC requiert 512 Mo de VRAM. 

Le meilleur moyen d’optimiser l’accélération du GPU est de conserver le pilote d’adaptateur vidéo à jour. Pour plus d’informations sur l’accélération du GPU et des instructions sur la mise à jour des pilotes de carte vidéo, voir Photoshop CC GPU FAQFAQ GPU Photoshop CS6 ou Prise en charge du GPU et d’OpenGL | Photoshop CS4, CS5. Pour obtenir des instructions sur la définition des paramètres GPU dans la boîte de dialogue des préférences de performances, voir FAQ GPU Photoshop CS6Photoshop CS6 GPU FAQ ou Fonctions et préférences de l’unité de traitement graphique et d’OpenGL | Photoshop et Bridge | CS4, CS5.

OpenCL

OpenCL est une technologie permettant d'utiliser pour des applications le processeur qui se trouve sur la carte vidéo, le GPU. Plusieurs fonctions utilisent OpenCL dans Photoshop CC, elles doivent donc être plus rapide. Assurez -vous qu'OpenCL est activé pour exécuter ces fonctions à leur vitesse la plus rapide.

Pour activer OpenCL, choisissez Edition > Préférences > Performances (Windows) ou Photoshop > Préférences > Performances (Mac OS). Cliquez sur Paramètres avancés, puis sélectionnez Utiliser OpenCL.

Les fonctionnalités qui sont activées dans OpenCL sont les suivants :

  • Panorama vidéo
  • Galerie d'effets de flou (Flou de diaphragme, Flou de profondeur de champ et Bascule-Décentrement)

Enregistrer en arrière-plan et Enregistrer automatiquement les données de récupération

L’enregistrement en arrière-plan est activé par défaut. Lorsque cette option est activée, vous pouvez continuer à travailler pendant les tâches d’enregistrement (Enregistrer et Enregistrer sous) au lieu de devoir attendre que celles-ci soient achevées. Si vous souhaitez contrôler la progression d’un enregistrement en arrière-plan, vous pouvez sélectionner Enregistrer la progression dans le menu contextuel d’état. L’enregistrement des opérations effectuées en arrière-plan (c’est-à-dire avec la préférence activée) prend plus de temps . Cependant, vous pouvez continuer à travailler pendant l’enregistrement.

De façon générale, l’enregistrement en arrière-plan n’affectera pas les performances ou la réactivité des opérations normales de Photoshop. Cependant, dans le cas d’un fichier plus volumineux que la mémoire vive disponible, l’opération d’enregistrement peut avoir une incidence sur les performances ou la réactivité de Photoshop.

L’option Enregistrer automatiquement les données de récupération tous/toutes les n’est disponible que si l’option Enregistrer en arrière-plan est activée. Si cette option est activée, les données de récupération de tout fichier ouvert sont enregistrées selon l’intervalle de temps spécifié. Ces informations de récupération sont enregistrées en arrière-plan à un emplacement caché, de sorte que le fichier d’origine n’est jamais modifié. Le fichier d’origine n’est modifié qu’en réponse à votre commande explicite Enregistrer ou Enregistrer sous. Si Photoshop ou le système se bloque, les informations récupérées seront ouvertes au prochain lancement de Photoshop.

La définition d’un intervalle d’enregistrement moindre offre une meilleure protection contre les blocages. De façon générale, l’enregistrement des données de récupération n’affecte pas les performances ou la réactivité de Photoshop. En fonction des opérations en cours, ainsi que du format et du nombre de fichiers ouverts, il peut toutefois y avoir des répercussions sur les performances.  Cela se produit généralement lorsque les fichiers en cours de modification sont plus volumineux que la quantité de mémoire RAM disponible.

Problèmes possibles :

Si Photoshop semble ralentir par intermittence, sélectionnez Enregistrer la progression dans le menu contextuel d’état en bas à gauche de la fenêtre de l’image. Si vous constatez une diminution des performances au moment où la barre de progression évolue, augmentez la valeur de la préférence Enregistrer automatiquement les données de récupération tous/toutes les. Ou désactivez la préférence.

Les informations de récupération sont enregistrées aux mêmes emplacements que les fichiers de travail Photoshop. Elles augmentent la quantité d’espace utilisée par Photoshop sur les disques de travail spécifiés dans la préférence Disques de travail dans le panneau Performances des Préférences. Si vous travaillez régulièrement avec de nombreux fichiers volumineux ouverts, la quantité d’espace peut être importante. Si vous obtenez des erreurs d’espace disque insuffisant pendant l’exécution d’autres commandes que les commandes d’enregistrement, ajoutez de l’espace de disque de travail. Vous pouvez également désactiver la préférence Enregistrer automatiquement les données de récupération tous/toutes les.

Conseils pour améliorer les performances de Photoshop

Travailler en respectant les limites de taille des fichiers

Plus le fichier de travail est volumineux, plus il est susceptible de générer des problèmes de performances. 

Photoshop prend en charge une taille de fichier maximum de 300 000 x 300 000 pixels, sauf pour les fichiers PDF, qui sont limités à 30 000 x 30 000 pixels et à 200 x 200 pouces.

Types de fichiers pris en charge par Photoshop :

  • Fichiers PSD : 2 Go
  • Fichiers TIFF : 4 Go (Photoshop CS6 prend en charge les fichiers TIFF de plus 4 Go)

Remarque : la plupart des applications ne parviennent pas à gérer des fichiers TIFF de plus de 2 Go.

  • Fichiers PSB : 4 exaoctets (4 096 pétaoctets ou 4 millions de téraoctets)
  • Fichiers PDF : 10 Go (la taille des pages est limitée à 200 pouces)

Reportez-vous également à la section Taille du fichierdans l’aide de Photoshop CS5.

Photoshop CS6 prend en charge les valeurs de profondeur paires et impaires.

Contrôler l’indicateur d’efficacité

Observez l’indicateur d’efficacité pendant que vous travaillez dans Photoshop. Il vous indique lorsque Photoshop a utilisé toute la quantité de RAM disponible et qu’il commence à utiliser le disque de travail, ce qui ralentit les performances. Cliquez sur le menu déroulant situé en bas de la fenêtre de l’image et choisissez Efficacité. (Vous pouvez également afficher l’état Efficacité d’état dans le panneau d’informations. Reportez-vous à la section Utilisation du panneau Informations dans l’aide de Photoshop CS5.) Si la valeur d’efficacité est inférieure à 100 %, Photoshop utilise le disque de travail. Par conséquent, il est plus lent. Si l’efficacité est inférieure à 90-95 %, allouez davantage de mémoire RAM à Photoshop dans Préférences de performances (voir Utilisation de la mémoire) ou ajoutez de la mémoire RAM à votre système.

Indicateur d’état d’efficacité

Fermer les fenêtres de document inutiles

Les fenêtres de document utilisent plus de RAM dans Photoshop CS4 et versions ultérieures que dans les versions précédentes. Un trop grand nombre d’images ouvertes dans Photoshop peut engendrer un message d’erreur indiquant une mémoire RAM saturée ou ralentir l’exécution de Photoshop. Si tel est le cas, fermez certaines fenêtres de document.

Réduire le nombre de motifs et de formes prédéfinis chargés

Pour réduire la quantité d’espace de travail utilisé par Photoshop, minimisez le nombre de motifs et de formes chargés. Enregistrez les paramètres prédéfinis dont vous n'avez actuellement pas besoin dans un fichier de paramètres prédéfinis. Ou supprimez-les s’ils ont été chargés à partir d’un fichier de préconfiguration.

Pour afficher les motifs ou formes prédéfinis chargés, sélectionnez Edition > Gestionnaire des paramètres prédéfinis, puis Type > Motifs ou Type > Formes. Pour enregistrer un motif ou une forme prédéfini que vous n’utilisez pas, sélectionnez-les dans le Gestionnaire des paramètres prédéfinis. Cliquez ensuite sur Enregistrer le groupe et indiquez un nom pour chaque fichier. Cliquez sur Supprimer pour les supprimer des paramètres prédéfinis chargés. En cas de besoin, vous pouvez les charger à nouveau à partir du Gestionnaire des paramètres prédéfinis ou des différents menus contextuels relatifs aux motifs et formes.

Réduire ou désactiver les vignettes d’aperçu du panneau

A chaque modification du document, Photoshop met à jour toutes les vignettes visibles dans les panneaux Calques et Couches. Cette mise à jour peut affecter la réactivité de Photoshop lors des opérations rapides de peinture, de déplacement ou de décalage des calques. Plus le nombre de vignettes est élevé, plus ce problème risque d’être important.

Pour réduire ou désactiver les vignettes d’aperçu dans ces panneaux, cliquez sur Couches, Calques ou Tracés, puis choisissez Options de panneau. Dans la zone Taille de vignettes, sélectionnez une plus petite taille de vignette ou choisissez Aucun, puis cliquez sur OK.

Définition de l’option Maximiser la compatibilité des fichiers PSD et PSB sur Demander

La fonctionnalité Maximiser la compatibilité des fichiers PSD et PSB associe une copie aplatie de l’image lorsque vous l’enregistrez. Ces données supplémentaires garantissent que les fichiers PSD et PSB puissent être ouverts dans les versions précédentes de Photoshop, dans Photoshop Lightroom, ainsi que dans des applications tierces qui prennent en charge des fichiers PSD.Elles permettent également l’affichage des aperçus QuickLook dans le Finder et l’ouverture des boîtes de dialogue sous Mac OS. Pour les fichiers volumineux contenant peu de calques, l’augmentation de la taille peut rapidement devenir importante. L’enregistrement des informations de compatibilité prend également plus de temps pour les documents volumineux.

Pour accélérer l’enregistrement de documents (au détriment de l’espace disque) :

  1. Pour les documents PSD et PSB 16 et 32 bits, dans le panneau Gestion des fichiers de la boîte de dialogue Préférences, sélectionnez l’option Désactiver la compression de fichiers PSD et PSB.

  2. Pour les fichiers TIFF, ne sélectionnez la compression ZIP ni pour le document ni pour ses calques dans la boîte de dialogue des options TIFF.

Reportez-vous à la section Maximiser la compatibilité lors de l’enregistrement de fichiers dans l’aide de Photoshop CS5 pour plus d’informations.

Travailler en mode d’image 8 bits

Photoshop peut effectuer de nombreuses opérations sur les images 16 et 32 bits. Toutefois, le traitement de ces images requiert davantage de mémoire, d’espace de travail et de temps que pour les images 8 bits. Pour convertir l’image en 8 bits par couche, sélectionnez Image > Mode > 8 bits/couche. Reportez-vous à la section Codage dans l’aide de Photoshop  pour plus d’informations.

Remarque : la conversion en 8 bpc supprime des données de l’image. Enregistrez une copie de l’objet d’origine en image 16 ou 32 bits avant de le convertir en 8 bpc.

Camera Raw peut ouvrir les images à 8 ou 16 bits par couche. Pour modifier ce paramètre, ouvrez la boîte de dialogue Camera Raw en ouvrant un fichier RAW. Cliquez sur le texte bleu souligné en-dessous de l’aperçu de l’image, puis sélectionnez 8 bits/couche ou 16 bits/couche dans le menu contextuel Profondeur.

Désactiver l’option d’aperçu des polices WYSIWYG

La désactivation de la liste d’aperçu des polices WYSIWYG accélère le traitement des polices dans Photoshop. Dans Photoshop CS4 et CS5, sélectionnez Photoshop > Préférences > Texte (Mac OS) ou Edition > Préférences > Texte (Windows). Désélectionnez Taille d’aperçu de la police et cliquez sur OK. Dans Photoshop CS6 et CC, sélectionnez Texte > Taille d’aperçu de la police > Aucune.

Pour plus d’aide concernant les polices, voir Dépannage des polices | Photoshop CS5.

Réduire la résolution des images

Plus la résolution est élevée, plus Photoshop a besoin de mémoire et d’espace disque pour l’affichage, le traitement et l’impression des images. Une plus haute résolution d’image n’offre pas nécessairement une meilleure qualité mais peut entraîner un ralentissement des performances de Photoshop, une utilisation plus importante de l’espace disque de travail ainsi qu’un ralentissement de l’impression. La résolution optimale de vos images dépend de la manière dont les images doivent être affichées ou imprimées. Il est souvent utile d’effectuer la plus grande partie du traitement de votre image à sa résolution initiale et de n’en réduire la taille et la résolution qu’au moment de son optimisation pour un support de sortie particulier (après l’enregistrement d’une copie de l’original à pleine résolution).

Pour les images destinées à un affichage sur écran ou à un message électronique, pensez en termes de dimensions en nombre total de pixels. La plupart des images Web ne sont pas plus larges que 700 pixels. Les systèmes d’affichage ne cessent de s’agrandir, mais les plus grandes résolutions communément utilisées aujourd’hui sont de 2 560 x 1 600 pixels, soit environ 4 mégapixels.

Pour réduire les dimensions d’une image dans Photoshop, sélectionnez Image > Taille de l’image. Dans la boîte de dialogue Taille de l’image, vérifiez que les options Conserver les proportions et Rééchantillonnage sont sélectionnées. Saisissez une nouvelle valeur pour la largeur ou la hauteur des pixels. (La saisie d’une valeur pour l'une modifie les deux car l’option Conserver les proportions rétablit leur relation.)

Pour les images destinées à l’impression, les avantages apportés par une résolution supérieure à 360 ppp sont la plupart du temps négligeables, voire inexistants. Pour une image destinée à de nombreuses impressions, il est important de prendre le temps de trouver la résolution la plus adaptée.

Pour réduire la résolution d’une image dans Photoshop, choisissez Image > Taille de l’image. Dans la boîte de dialogue Taille de l’image, sélectionnez Rééchantillonnage. Modifiez les valeurs de la taille du document pour refléter la taille physique à laquelle vous prévoyez d’imprimer le document. Réduisez ensuite la valeur Résolution et cliquez sur OK. Si, au lieu d’être supérieure, la valeur de la résolution est inférieure à la valeur que vous aviez à l’esprit, (en d’autres termes, si vous voulez augmenter la résolution du document au lieu de la diminuer), reportez-vous à une autre documentation sur l’optimisation de l’impression des images de basse résolution.

Si vous souhaitez augmenter la résolution de l’image à l’impression plutôt que de la diminuer, effectuez cette opération lors des dernières étapes avant d’imprimer l’image. De cette manière, vous n’avez pas à traiter toutes ces informations supplémentaires dans les étapes précédentes.

Pour plus d'informations, voir Recadrage, redimensionnement et rééchantillonnage avancés | Photoshop, ainsi que Préparation de l’impression à partir de Photoshop et Nouveautés et instructions à propos de l’impression dans Photoshop.

Purger la fonction Annuler, le Presse-papiers et les états de l’historique

Annuler, le Presse-papiers et les états de l’historique contiennent tous des données d’images. Pour libérer de la RAM, sélectionnez Edition > Purger puis Annuler, Presse-papiers, Historiques, ou Tout. 

Remarque : la commande Purger ne peut pas être annulée.

Le Presse-papiers contient souvent des données volumineuses si vous les avez copiées et collées dans des documents importants. Et elles sont généralement peu utiles lorsque vous avez terminé de les coller. La fonction Annuler et les états de l’historique, au contraire, contiennent souvent des données utiles pour corriger des erreurs précédentes. Les opérations de purge d’historique et d’annulation libèrent davantage de RAM immédiatement. Toutefois, les états inutilisés de l’historique sont automatiquement transférées de la RAM au disque de travail pendant que vous travaillez. L’utilité de la purge de l’historique et de la fonction Annuler reste donc limitée.

La galerie de filtres vous permet de tester un ou plusieurs filtres sur une image avant d’appliquer les effets, ce qui peut faire gagner un temps considérable. Reportez-vous à la section Présentation de la Galerie de filtres dans l’aide de Photoshop pour plus d’informations.

Opération Glisser entre des fichiers

Il est plus efficace d’effectuer un glisser-déposer de calques ou de fichiers qu’un copier-coller. En effet, le déplacement ne fait pas appel au Presse-papiers et transfère les données directement. Le copier-coller peut potentiellement impliquer un transfert de données plus important, ce qui réduit son efficacité.

Savoir utiliser les calques

Les calques sont fondamentaux dans l’utilisation de Photoshop, mais ils augmentent la taille du fichier et le temps de retraçage. Photoshop permet de recomposer chaque calque après chaque changement dans l’image. Une fois que vous avez terminé d’apporter des modifications aux calques, aplatissez-les (fusionnez-les) pour réduire la taille d’un fichier. Sélectionnez les calques dans le panneau Calques, cliquez avec le bouton droit de la souris (Windows) ou, tout en maintenant la touche Ctrl enfoncée (Mac OS), choisissez l’option Fusionner les calques. (Veillez à supprimer les calques vides du fichier, car ils augmentent sa taille. Sélectionnez les calques vides dans le panneau Calques, cliquez avec le bouton droit [Windows] ou, tout en maintenant la touche Ctrl enfoncée [Mac OS], choisissez l’option Supprimer le calque.) Pour aplatir tous les calques d’un fichier, sélectionnez Calque > Aplatir l’image.

Remarque : Photoshop ne vous permet pas de séparer les calques une fois qu’ils sont fusionnés. Vous pouvez choisir Edition > Annuler ou utiliser le panneau Historique pour revenir à un état non fusionné.

Si vous n’apportez pas de changements fréquents à certains de vos calques, vous pouvez transformer les calques ou les groupes de calques en objets dynamiques, ce qui libère de l’espace disque et améliore les performances. Sélectionnez les calques ou les groupes de calques dans le panneau Calques, cliquez avec le bouton droit de la souris (Windows) ou, tout en maintenant la touche Ctrl enfoncée (Mac OS), choisissez l’option Convertir en objet dynamique.

Enregistrer les fichiers TIFF sans calques

Photoshop permet d’enregistrer des calques dans des fichiers TIFF. Toutefois, les fichiers TIFF à calques sont plus volumineux que les fichiers TIFF aplatis ; ils consomment davantage de ressources pour le traitement et l’impression. Si vous utilisez un fichier TIFF à calques, enregistrez le fichier à calques d’origine en tant que fichier Adobe Photoshop (.psd). Ensuite, lorsque vous êtes prêt à enregistrer le fichier au format TIFF, choisissez Fichier > Enregistrer sous. Dans la boîte de dialogue Enregistrer sous, choisissez Format > TIFF, sélectionnez l’option Enregistrer comme une copie, désélectionnez Calques, puis cliquez sur Enregistrer.

Si vous souhaitez accélérer l’exportation des fichiers TIFF, ne choisissez pas la compression ZIP. La compression ZIP est cependant celle qui génère les plus petits fichiers TIFF.

Ne pas exporter le Presse-papiers

Si vous sélectionnez le paramètre Exporter le Presse-papiers, Photoshop rend le contenu du presse-papiers disponible à d’autres programmes. Si vous copiez d'importantes quantités de données dans Photoshop, mais ne les copiez pas dans d'autres applications, gagnez du temps en désactivant l'option Exporter le Presse-Papiers.

  1. Choisissez la commande Photoshop > Préférences > Général (Mac OS) ou Edition > Préférences > Général (Windows).
  2. Désélectionnez Exporter le Presse-papiers.
  3. Cliquez sur OK.

Optimiser le système d’exploitation pour Photoshop

Fermez les applications et éléments de démarrage inutiles

D’autres applications ouvertes et éléments de démarrage réduisent la quantité de mémoire disponible pour Photoshop. Quittez les applications inutiles, les éléments de démarrage et les extensions, puis libérez de la mémoire pour Photoshop. Reportez-vous aux sections suivantes dans les documents de dépannage du système d’exploitation Adobe :

 Reportez-vous ensuite à la section Utilisation de la mémoire pour obtenir des instructions sur la façon d’allouer davantage de RAM à Photoshop.

Désactivation de App Nap (Mac)

Exécutez l’application de nettoyage de disque (Windows)

Lorsque vous utilisez une application, une copie de votre fichier de données est stockée temporairement sur le disque dur. De nombreuses applications créent des fichiers .tmp et les suppriment lorsque vous fermez les applications. Des blocages ou des erreurs système peuvent empêcher une application de supprimer ces fichiers, entraînant ainsi une occupation de l’espace disque et la génération de problèmes. De temps à autre, exécutez l’application de nettoyage de disque pour supprimer les fichiers temporaires et les autres fichiers qui ne sont pas en cours d’utilisation.

  1. Effectuez l’une des opérations suivantes :

    • Sous Windows XP : sélectionnez Démarrer > Programmes > Accessoires > Outils système > Nettoyage de disque.
    • Sous Windows Vista/Windows 7/8 : sélectionnez Démarrer, saisissez Nettoyage de disque dans la zone de texte Rechercher, puis choisissez Nettoyage de disque dans la liste des programmes.
  2. Sélectionnez un disque à nettoyer, le cas échéant.
  3. Sélectionnez les fichiers temporaires et tout autre fichier que vous souhaitez supprimer.
  4. Cliquez sur OK.

Défragmentez le disque dur

A mesure que vous ajoutez, supprimez et déplacez des fichiers sur un disque dur, l’espace disponible n’est plus constitué d’un seul bloc contigu. Si le système ne dispose pas d’espace contigu suffisant, il enregistre des fragments d’un fichier dans différents emplacement du disque dur. Photoshop prend plus de temps pour lire ou écrire sur un fichier fragmenté qu’un fichier enregistré dans un emplacement contigu.

Pour obtenir des instructions concernant la défragmentation des disques durs sous Windows, reportez-vous aux rubriques d’aide Microsoft suivantes :

  • (Windows XP) Tâches de maintenance permettant d’améliorer les performances Suivez les instructions de l’étape 4, Défragmentation du disque dur.
  • (Windows 7 et Windows Vista) « Améliorer les performances en défragmentant le disque dur »
  • (Windows 8) « Optimiser le disque dur »

Sur Mac OS, utilisez un utilitaire de disque, tel que le Défragmenteur de disque, Symantec Norton Utilities ou Micromat Drive 10. La fragmentation est très rarement un problème sous Mac OS, sauf si vous avez l’habitude de travailler avec un lecteur presque plein. Pour plus d’informations, reportez-vous à la section Défragmentation du disque dur et vérification des erreurs.

Remarque : les baies RAID ne se fragmentent pas. La fragmentation risque plutôt de poser problème si vous utilisez un seul disque pour toutes vos applications. Cela peut également être le cas si un même volume est partagé entre des fichiers permanents et le disque de travail de Photoshop, en particulier s’il ne dispose pas de beaucoup d’espace libre. Dans ce cas, la défragmentation du disque peut faire la différence.

Il est inutile de défragmenter les disques à semi-conducteurs, car leurs performances sont préservées significativement avec des niveaux normaux de fragmentation.

Installez les mises à jour du système d’exploitation

Les mises à jour du système d’exploitation Windows ou Mac OS X peuvent améliorer leurs performances et leur compatibilité avec les applications. 

Obtenez les Service Packs windows et d’autres mises à jour à partir du site web de microsoft. Pour obtenir de l’aide concernant l’installation des Service Packs et des autres mises à jour, contactez le support technique de Microsoft.

Pour obtenir les mises à jour de Mac OS X, choisissez Mise à jour de logiciels dans le menu Pomme. Pour obtenir de l’aide sur l’installation des mises à jour, contactez le support technique d’Apple.

Important : avant d’installer une mise à jour système, vérifiez la configuration requise pour le logiciel Adobe afin d’assurer la compatibilité. (Vérifiez également tout logiciel ou matériel tiers que vous utilisez avec le logiciel Adobe). Si la mise à jour n’apparaît pas dans la liste, contactez Adobe ou le fabricant de votre logiciel ou matériel tiers.

Spécifiez une mémoire virtuelle fixe (Windows)

La mémoire virtuelle permet au système d’utiliser l’espace du disque dur pour stocker les informations qui sont normalement stockées dans la mémoire vive. Il faut plus de temps pour accéder aux informations figurant sur un disque dur qu’à celles figurant dans la mémoire. Par conséquent, l’utilisation d’une partie du disque dur en tant que mémoire virtuelle peut réduire les performances. En outre, Photoshop ne peut pas utiliser l’espace de disque dur que le système utilise pour la mémoire virtuelle pour ses fichiers de disque de travail. (Le disque de travail n’est utilisé que pour stocker les informations des images au fur et à mesure que vous travaillez.)

La définition d’un paramètre de mémoire virtuelle fixe permet d’empêcher les fichiers du disque de travail de Photoshop de se faire concurrence sur l’espace de mémoire virtuelle, plus particulièrement si vous définissez le paramètre de mémoire virtuelle sur un disque différent du disque de travail principal. Pour les deux types de mémoire virtuelle, veillez à utiliser un disque disposant de suffisamment d’espace contigu pour obtenir de meilleures performances. Par ailleurs, gardez le fichier d’échange sur un disque dur à part, vide et défragmenté.

Comme toujours, l’utilisation conseillée de disques distincts pour la mémoire virtuelle et pour les disques de travail ne s’applique pas aux disques SSD. En cas d’utilisation d’un disque SSD, il est préférable de placer tous les fichiers les plus fréquemment utilisés sur le SSD, puisque leur stockage sur un même disque SSD ne présente pas ou peu de problèmes de performance.

Pour modifier la mémoire virtuelle sous Windows XP, quittez toutes les applications, puis procédez comme suit :

  1. Sélectionnez Démarrer > Paramètres > Panneau de configuration, puis cliquez deux fois sur Système.
  2. Cliquez sur l’onglet Avancé, puis sélectionnez Paramètres dans la section Performances.
  3. Cliquez sur l’onglet Avancé, puis, dans la section Mémoire virtuelle, sur Modifier.
  4. Dans la liste des lecteurs, sélectionnez un disque dur comportant au moins une fois et demie la quantité de mémoire RAM installée sur l’ordinateur. Par exemple, si l’ordinateur comporte 2 Go de RAM, sélectionnez un disque dur possédant au moins 4 Go d’espace libre.
  5. Dans la section Taille du fichier d’échange pour le lecteur sélectionné, sélectionnez Taille personnalisée et, dans la zone Taille initiale, saisissez une valeur égale à deux fois la quantité de RAM installée sur l’ordinateur.
  6. Dans la zone Taille maximale, saisissez une valeur correspondant à quatre fois la quantité de mémoire RAM installée sur l’ordinateur.
  7. Cliquez sur Définir, puis sur OK.  
  8. Cliquez pour fermer l’Application Système du Panneau de configuration.
  9. Cliquez sur Oui dans la boîte de dialogue de modification des paramètres système pour redémarrer Windows.

Pour modifier la mémoire virtuelle sous Windows 7 et Vista, quittez toutes les applications, puis procédez comme suit :

  1. Sélectionnez Démarrer > Panneau de configuration, puis cliquez deux fois sur Système.
  2. Sélectionnez Paramètres système avancés dans la liste Tâches.
  3. Cliquez sur l’onglet Avancé, puis sélectionnez Paramètres dans la section Performances.
  4. Cliquez sur l’onglet Avancé, puis sur Modifier.
  5. Désélectionnez l’option Gérer automatiquement le fichier d’échange pour tous les lecteurs.
  6. Cliquez sur chaque lettre de disque dur pour afficher l’espace disponible. Sélectionnez un disque dur disposant de trois fois la quantité de RAM installée sur l’ordinateur et ne contenant pas un disque de travail.
  7. Sélectionnez Taille personnalisée et saisissez la quantité de votre RAM physique plus 300 Mo dans la zone Taille initiale. Saisissez trois fois la quantité de RAM installée sur l’ordinateur dans la zone Taille maximale. 
  8. Cliquez sur Définir, puis sur OK. Continuez à cliquez sur OK pour fermer toutes les boîtes de dialogue.
  9. Redémarrez l’ordinateur. Si des applications sont ouvertes, sélectionnez Redémarrer ultérieurement, fermez les applications, puis redémarrez Windows. Dans le cas contraire, cliquez sur Redémarrer maintenant.

Pour modifier la mémoire virtuelle sous Windows 8, quittez toutes les applications, puis procédez comme suit :

  1. Cliquez sur Démarrer > Panneau de configuration. S'il n'existe aucun bouton Démarrer, sélectionnez l'icône de dossiers et recherchez votre ordinateur dans le panneau de configuration.
  2. Sélectionnez Système puis Sécurité > Système.
  3. Suivez les étapes de Windows 7 et Vista ci-dessus, en commençant par l'étape 3.

Pour plus d’informations, voir les rubriques d’aide Microsoft suivantes :

  • (Windows XP) « Modifier la taille du fichier d’échange de la mémoire virtuelle »
  • (Windows Vista, Windows 7 et Windows 8) « Modifier la taille de la mémoire virtuelle »

Pour plus d’informations, reportez-vous également à la section Mémoire virtuelleet à Real World Photoshop CS5 for Photographers Conrad Chavez (Peachpit Press).

Ce produit est distribué sous licence Creative Commons Attribution - Pas d’utilisation commerciale - Partage à l’identique 3.0 non transposé  Les publications Twitter™ et Facebook ne sont pas couvertes par les dispositions Creative Commons.

Mentions légales   |   Politique de confidentialité en ligne