Mac 패키지 인증서 만료됨

Acrobat 및 Reader Mac 설치 관리자와 업데이트 패키지에 서명하는 데 사용된 인증서가 2017년 2월 21일에 만료되었습니다. 인증서가 만료되었으므로 macOS는 Acrobat 또는 Reader 설치 관리자의 대부분을 서명되지 않음 또는 만료됨으로 플래그 지정하기 시작했습니다.

다음과 같은 설치 관리자와 패치가 영향을 받습니다.

  • 15.016.20041 이전 버전의 Acrobat DC Continuous 패키지
  • 15.016.20039 이전 버전의 Acrobat Reader DC Continuous 패키지
  • 15.006.30173 이전 버전의 Acrobat DC 2015 패키지
  • 15.006.30172 이전 버전의 Acrobat Reader DC 2015 패키지
  • 11.0.17 이전 버전의 Acrobat 및 Reader XI 패키지

영향을 받은 패키지를 설치하는 경우 다음과 같은 경고 메시지가 표시됩니다.

설치 관리자 패키지의 인증서가 만료됨

명령줄을 사용하여 이러한 패키지를 설치하려는 경우 Mac OS에서 설치를 차단하여 실패합니다.

해결 방법: 최신 버전 또는 패치 다운로드

전체 설치 관리자

최신 설치 관리자는 이 문제의 영향을 받지 않습니다. Acrobat/Reader 전체 설치 관리자 패키지에 경고가 표시되는 경우 최신 버전을 다운로드하십시오.

이 위치의 설치 관리자 패키지가 새로 고쳐졌으므로 최신 패키지를 설치하는 데 문제가 없어야 합니다. 

패치

모든 트랙의 최신 패치에는 이 문제가 없습니다. 다음과 같은 최신 업데이트를 설치하는 것이 좋습니다.

이러한 모든 패키지는 경고가 표시되지 않으며 문제없이 설치할 수 있습니다. 하지만 '잠금' 아이콘을 클릭하여 패키지에 서명하는 데 사용된 인증서 체인을 명시적으로 가져오는 경우 여기에 표시된 대로 인증서가 만료되었음을 나타냅니다.

인증서 만료 오류 메시지

하지만 패키지 서명이 유효하고 OS에서 설치를 차단하지 않으므로 다음과 같은 pkgutil 명령을 사용하여 확인할 수 있습니다. 

pkgutil --check-signature <pkg 파일에 대한 경로>

11.0.19 Acrobat 패키지의 샘플 터미널 출력은 다음과 같이 표시됩니다. 이것은 패키지가 OS에서 신뢰할 수 있는 인증서로 서명되었음을 나타냅니다. 

pkgutil 명령

이 작업에는 Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License의 라이센스가 부여되었습니다.  Twitter™ 및 Facebook 게시물은 Creative Commons 약관을 적용받지 않습니다.

법적 고지 사항   |   온라인 개인 정보 보호 정책