Nota:

En la versión de junio de 2014 y las versiones posteriores de After Effects CC no se pueden exportar archivos a los formatos FLV y F4V. Use After Effects CC (junio de 2013) o inferior para exportar archivos a los formatos FLV y F4V.

Puede procesar y exportar películas de After Effects como películas que puede reproducir en Adobe Flash Player. Los archivos SWF se reproducen de forma nativa en Flash Player, mientras que un archivo FLV o F4V debe contenerse en un archivo SWF (o estar vinculado a él) para poder reproducirse en Flash Player. También puede exportar composiciones a Flash Professional como archivos XFL.

Este vídeo de la serie After Effects CS5: Learn by Video (After Effects CS5: aprendizaje por vídeo) ofrece una descripción general de la exportación a varios formatos de Flash Professional y Flash Player, y muestra el uso y los problemas comunes de cada uno.

XFL

Los archivos XFL son representaciones de composiciones que pueden abrirse en Flash CS4 Professional o posterior. Los archivos XFL son el equivalente XML de los archivos FLA.

SWF

Los archivos SWF son archivos pequeños que se reproducen en Flash Player. Suelen utilizarse para distribuir gráficos vectoriales animados (como dibujos animados), sonido y otros tipos de datos a través de Internet. Los archivos SWF también permiten que el espectador interactúe, por ejemplo haciendo clic para seguir un enlace Web, controlar animación o agregar elementos a una aplicación de Internet rica (RIA). Los archivos SWF se crean a partir de archivos FLA.

FLV y F4V

Los archivos FLV y F4V solo contienen vídeos basados en píxeles (rasterizados), no admiten gráficos vectoriales y no son interactivos. Los archivos FLA pueden contener archivos FLV y F4V y referirse a ellos. A continuación, dichos archivos se incrustan o vinculan en archivos SWF que se reproducen en Flash Player.

Exportación de una composición como archivo XFL a Flash Professional

Puede exportar una composición desde After Effects al formato XFL para utilizarla y editarla en Flash CS4 Professional o posterior. Por ejemplo, ActionScript se puede utilizar en Flash Professional para añadir una animación interactiva a cada una de las capas desde una composición de After Effects.

Cuando exporte una composición como archivo XFL, After Effects intentará exportar capas y fotogramas clave individuales y conservar el máximo de información que pueda para utilizarla directamente en Flash Professional. Si After Effects no puede exportar un elemento de una composición como datos sin procesar en un archivo XML, el elemento se ignora o se procesa en un elemento PNG o FLV, según si ha elegido ignorar las características incompatibles.

Acerca de los archivos XFL

Los archivos XFL son el equivalente XML de los archivos FLA. Un archivo XFL es una carpeta de archivos comprimida que contiene una carpeta de biblioteca y un documento XML (DOMDocument.xml) que describe el archivo FLA. La carpeta de biblioteca contiene los recursos a los que se hace referencia en el archivo XML. Cuando se abre un archivo XFL en Flash Professional, extrae esos elementos del archivo XFL y los utiliza para crear un documento FLA. El documento se guarda desde Flash Professional como un nuevo archivo FLA, sin cambiar el archivo XFL con Flash Professional.

Nota:

Si desea examinar o editar manualmente el contenido de un archivo XFL, puede abrir el archivo comprimido de igual forma que se hace con cualquier otro archivo .zip. No es necesario cambiar la extensión del nombre del archivo a .zip, pero hacerlo así puede simplificar la extracción de los archivos para este examen manual.

Este vídeo de la serie After Effects CS5: Learn by Video (After Effects CS5: aprendizaje por vídeo) muestra la exportación a XFL.

Exportación de una composición al formato XFL

  1. Para exportar la composición seleccionada como un archivo XFL, elija Archivo > Exportar > Adobe Flash Professional (XFL).

  2. En el cuadro de diálogo Ajustes de Adobe Flash Professional (XFL), elija lo que debe hacer After Effects con las capas que incluyen funciones no compatibles:

    Ignorar

    Las capas que tienen funciones no compatibles no se incluyen en la salida XLF.

    Rasterización

    Las capas que tienen funciones no compatibles se rasterizan. Esto significa que las capas se procesan a un formato de mapa de bits (un archivo FLV o una secuencia de imágenes PNG). Los vectores no se conservan. De esta forma se conserva el aspecto de la capa cuando se utiliza el archivo XFL en Flash Professional. Al rasterizar a una secuencia PNG, los fotogramas idénticos adyacentes solo se rasterizan una vez, a un archivo PNG único al que se hace referencia varias veces.

  3. (Opcional) Haga clic en el botón Opciones de formato y modifique los ajustes usados para la creación de secuencias de PNG o archivos FLV.

    Si hace clic en Opciones de formato tras elegir FLV en el menú Formato, se abre el cuadro de diálogo de ajustes de exportación. Aunque se pueden modificar elementos como la velocidad de transferencia de bits, por lo general no es necesario cambiar muchos ajustes en este cuadro de diálogo. Los cambios que realice en este cuadro de diálogo se mantienen y se utilizan para posteriores operaciones de exportación, por lo que debe tener cuidado con los cambios que realice.

    Si desea deshacer algún cambio efectuado en las opciones de formato, haga clic en el botón Restablecer ajustes preestablecidos del cuadro de diálogo Ajustes de Adobe Flash Professional (XFL).

  4. En el cuadro de diálogo Exportar como Adobe Flash Professional (XLF), elija una ubicación para los archivos de salida.

Mientras se procesa la composición, un cuadro de diálogo muestra el progreso de la operación de exportación.

Cuando After Effects crea un archivo XLF, también guarda un informe ( [nombre_de_archivoXLF] report.html) en la misma carpeta del archivo XLF. El informe contiene los siguientes datos:

  • si se han rasterizado o se han ignorado las capas que tienen funciones no compatibles

  • si se ha rasterizado ("procesado") cada uno de los elementos de origen o se ha pasado por ellos ("vinculado")

  • si se ha rasterizado ("procesado") cada una de las capas o se han convertido a un objeto Flash nativo

Uso de Flash Professional con documentos FLA creados a partir de archivos XFL

El panel Biblioteca de Flash Professional es parecido al panel Proyecto de After Effects. Cuando Flash Professional crea un documento FLA a partir de un archivo XFL, crea símbolos, carpetas y clips de vídeo, y los organiza en el panel Biblioteca. Todos los elementos del panel Biblioteca tienen un nombre exclusivo, incluso aunque estén basados en elementos de After Effects que tienen el mismo nombre, para que estos elementos se puedan manipular con ActionScript. Este requisito de que los nombres sean exclusivos obliga a que After Effects añada caracteres de subrayado y números a muchos nombres cuando crea los archivos XFL.

Cuando Flash Professional crea un documento FLA a partir de un archivo XFL que incluye archivos FLV, estos archivos FLV se incrustan en la línea de tiempo de Flash. Con frecuencia, una forma más eficiente de crear documento FLA consiste en mover los archivos de vídeo a una ubicación externa a la que haga referencia el archivo SWF para el flujo de vídeo. Puede incrustar archivos FLV como desee dentro de Flash Professional si borra el vídeo y lo vuelve a importar con el componente FLVPlayback.

Nota:

En After Effects, la línea de tiempo de la composición empieza en el fotograma 0. En Flash Professional, la línea de tiempo comienza en el fotograma 1. Esta diferencia hace que la línea de tiempo de la composición de After Effects y la línea de tiempo correspondiente de Flash parezcan estar desplazadas un fotograma entre sí.

En After Effects, las composiciones pueden tener proporciones de aspecto de píxeles distintas de 1,0 (píxeles cuadrados). Flash Professional solo admite la proporción de aspecto de píxeles de 1,0. Cuando se exporta una composición al formato XFL, el documento FLA será un documento de píxeles cuadrados con un número distinto de píxeles, de forma que el aspecto del documento en Flash Professional sea igual al de la composición en After Effects. Los valores de escala del archivo XFL conservan el aspecto de las capas.

Conservación de las funciones y datos al exportar una composición al formato XFL

Cuando una composición se exporta como archivo XFL, After Effects pasa por varias etapas en las que intenta exportar la máxima cantidad de información de las capas y sus archivos de origen.

Si la composición utiliza archivos PNG, JPEG y FLV como origen de las capas, estos archivos de origen se incluyen en la salida XFL (se pasa por ellos) a menos que las capas utilicen funciones que obliguen a After Effects a transcodificar los archivos de origen o a rasterizar las capas para exportarlas a XFL.

Nota:

La transcodificación es la conversión de un archivo de origen de un formato a otro, por ejemplo de GIF a PNG. La rasterización es la conversión de una capa a una imagen de mapa de bits, incorporando toda la información del modelo, como vectores y fotogramas clave, en una imagen acoplada basada en píxeles para cada fotograma.  

Etapa 1: los archivos de origen se transfieren sin modificarse si es posible.

Para que se pase por un archivo de origen de una capa hacia el archivo XFL, la capa debe cumplir estos requisitos:

  • La capa tiene un elemento de material de archivo de origen que utiliza una secuencia PNG o JPEG o un archivo FLV como origen. (La capa no debe ser una capa de texto, de cámara, de luz, ni de formas.)

  • La velocidad de fotogramas del elemento de material de archivo de origen coincide con la velocidad de fotogramas de la composición.

  • El origen de la capa no está recortado.

  • La capa no está ampliada por delante del primer fotograma ni después del último fotograma del área de trabajo de la composición.

  • La capa no tiene otras propiedades distintas de Posición, Punto de anclaje, Opacidad, Escala y Rotación. Puesto que los efectos agregan propiedades a las capas, este requisito también significa que la capa no debe tener aplicado ningún efecto.

  • La capa no tiene aplicados desenfoque de movimiento, fusión de fotogramas ni remapeo de tiempo.

  • La capa no tiene un mate de seguimiento.

  • No hay ninguna capa de ajuste encima de la capa.

  • Las capas situadas encima no usan modos de fusión distintos de Normal.

  • La capa no tiene configurada la opción Conservar transparencia ni tiene ninguna otra capa encima de ella.

  • La capa no es una capa 3D.

Etapa 2: los archivos de origen restantes se convierten en secuencias PNG o archivos FLV si es posible.

Si la única razón por la que un archivo de origen de capa no se pueda pasar al archivo XFL es que no utilice como origen una secuencia de PNG o JPEG o un archivo FLV, el origen de la capa se transcodifica o se rasteriza a una secuencia de PNG o a un archivo FLV que se incluye en el archivo XFL. En este caso, los fotogramas clave Posición, Opacidad, Escala y Rotación se conservan y se convierten a fotogramas clave en la salida XLF. Si varias capas usan el mismo origen en After Effects y cumplen todos los demás requisitos de paso indicados antes, también compartirán un origen común en el documento creado en Flash Professional. Las precomposiciones se pueden rasterizar como elementos de origen.

El archivo XFL creado a partir de una composición conserva la información de animación de las capas de la composición. Los fotogramas clave de las propiedades Posición, Opacidad, Escala y Rotación se convierten a fotogramas clave en Flash Professional, con un fotograma clave por fotograma de cada propiedad animada. Solo se convierten los fotogramas clave de Posición 2D (x e y) y de Rotación 2D (z).

En After Effects, la propiedad Punto de anclaje se puede animar, pero no el punto de transformación en Flash Professional. En Flash Professional, el punto de transformación se encuentra situado en la esquina superior izquierda del símbolo. Las animaciones de fotograma clave de propiedades de transformación (incluido el punto de anclaje) en After Effects se convierten en animaciones basadas en el centro de transformación del archivo XFL exportado.

Etapa 3: las capas restantes se rasterizan como capas individuales si es posible.

Si una capa no cumple los requisitos para que su archivo de origen se pase, se transcodifique o se rasterice como elemento de origen, la propia capa se debe rasterizar como una capa. Al rasterizar una capa se pierde toda su información de fotogramas clave: toda la información se incluye en los propios fotogramas de imagen rasterizada.

Para que se rasterice como capa individual, una capa debe cumplir estos requisitos:

  • La capa está basada en un elemento de material de archivo de vídeo (que incluya un sólido), es una capa de formas o una capa de texto. (La capa no es una capa de cámara, una capa de luz ni una capa de solo audio.)

  • No hay ninguna capa de ajuste encima de la capa.

  • Las capas situadas encima no usan modos de fusión distintos de Normal.

  • La capa no tiene un mate de seguimiento.

  • La capa no tiene configurada la opción Conservar transparencia ni tiene ninguna otra capa encima de ella.

  • La capa no es una capa 3D.

Etapa 4: las capas restantes se procesan y rasterizan juntas en bandejas.

Si la capa no cumple los requisitos para la rasterización a una capa individual, se procesa y rasteriza junto con las demás capas en un grupo (bandeja). Las bandejas de capas rasterizadas juntas son normalmente capas 3D, capas que están compuestas con los modos de fusión, los mates de seguimiento y las capas afectadas por una capa de ajuste.

Limitaciones de la exportación de composiciones al formato XFL

Cuando Flash Professional abre un archivo XFL, tiene que cargar todos los recursos en memoria. After Effects presenta un aviso si se exporta una composición para la que los recursos consumirán más de 580 MB. De manera similar, After Effects le avisará si un archivo XFL tardará mucho tiempo en abrirse en Flash Professional porque el número de fotogramas de una secuencia de PNG sea de más de 1.050. La composición se puede exportar al formato XFL incluso aunque se superen estos límites, pero es posible que no se pueda abrir el archivo XFL con Flash Professional.

Nota:

Para evitar largos tiempos de carga relacionados con las secuencias de una gran cantidad de archivos de PNG, considere la posibilidad de preprocesar las capas basadas en secuencias de PNG al formato FLV.

After Effects se basa en la versión incorporada de Adobe Media Encoder para crear los archivos FLV. Adobe Media Encoder no puede crear archivos FLV con dimensiones en píxeles superiores a 1920x1080.

Cuando exporta una composición al formato XFL desde un proyecto de 32 bpc, el procesamiento de colores con valores inferiores a 0 y superiores a 1 no produce resultados que conserven el aspecto de la composición en After Effects. Solo debería trabajar en proyectos de 8 bpc o 16 bpc al crear composiciones que desee exportar a Flash Professional en el formato XFL.

El audio no se exporta al archivo XFL.

Procesamiento y exportación de una composición como archivo SWF

Los archivos SWF son archivos pequeños que se reproducen en Flash Player. Suelen utilizarse para distribuir gráficos vectoriales animados (como dibujos animados), sonido y otros tipos de datos a través de Internet. Los archivos SWF también permiten que el espectador interactúe, por ejemplo haciendo clic para seguir un enlace Web, controlar animación o agregar elementos a una aplicación de Internet rica (RIA). Los archivos SWF se crean a partir de archivos FLA.

Al procesar y exportar una película a un archivo SWF, After Effects mantiene los gráficos vectoriales como objetos vectoriales siempre que sea posible. Sin embargo, las imágenes rasterizadas, los modos de fusión, los desenfoques de movimiento, algunos efectos y el contenido de las composiciones anidadas no se pueden representar como vectores en el archivo SWF y se rasterizan.

Puede omitir estos elementos no compatibles de manera que el archivo SWF solo incluya aquellas funciones de After Effects que se puedan convertir en elementos nativos de SWF, o puede rasterizar fotogramas que contengan funciones no compatibles y agregarlos al archivo SWF como imágenes de mapa de bits comprimidas JPEG, lo que puede reducir la eficacia del archivo SWF.

El audio se codifica en formato MP3 y se agrega al archivo SWF como flujo de audio.

Cuando After Effects crea un archivo SWF, también guarda un informe ([nombre_de_archivoSWF] R.htm) en la misma carpeta del archivo SWF. El informe contiene también un enlace al archivo SWF para que se pueda previsualizar la salida utilizando el plugin Flash Player. Abra el informe en un explorador para visualizar el archivo SWF y ver qué elementos de la composición no se admiten.

El archivo SWF exportado incluye en la composición una instancia de cada elemento, sin modificar, y después hace una referencia por cada uso. Si una capa se usa en varios fotogramas, todos los usos hacen referencia al mismo objeto, incluso si las propiedades de transformación de la capa (como la Posición) son animadas. No obstante, si el contenido de la campa cambia, por ejemplo, si una máscara de la capa es animada o si el elemento de material de archivo de origen de la capa es un vídeo, se crea un objeto nuevo para cada fotograma en el que la capa sea visible. Si varias capas de la composición comparten el mismo elemento de material de archivo de origen, se agrega el origen una vez y, posteriormente, se incluye una referencia para cada capa adicional que comparta el origen. Si el origen es un archivo de Illustrator, se crea y se hace referencia a un clip de película SWF. Los caracteres de texto se agregan como vectores una vez y, a continuación, se hace referencia en todos los fotogramas posteriores, a menos que haya seleccionado Relleno sobre trazo en el menú de opciones Relleno y trazo; en este caso, los caracteres se agregan como vectores en cada fotograma.

Nota:

Si está habilitada la gestión del color para el proyecto, los colores se convierten desde el espacio de color de trabajo del proyecto en el espacio de color sRGB IEC61966-2.1 para la salida. Este espacio de color de salida es el adecuado para las películas que se muestran en un navegador web. (Consulte) Administración de color.

  1. Seleccione la composición que desea exportar y, a continuación, elija Archivo > Exportar > Adobe Flash Player (SWF).
  2. Escriba un nombre de archivo (asegurándose de incluir la extensión .swf) y una ubicación y, a continuación, haga clic en Guardar.
  3. Especifique las opciones según sea necesario y haga clic en Aceptar.

Chris Jackson ofrece sugerencias para el procesamiento y exportación de archivos SWF desde After Effects en un pasaje de su libro Flash + After Effects, en el sitio web Sitio web de Focal Press.

Ajustes de exportación de SWF

Calidad JPEG

Especifica la calidad de las imágenes rasterizadas. Cuando mayor sea la calidad, más grande será el archivo. (Si se selecciona Rasterizar para Funciones no compatibles, el ajustes Calidad JPEG se utiliza para todas las imágenes de mapa de bits comprimidas JPEG exportadas al archivo SWF, incluidas las imágenes de mapa de bits generadas a partir de fotogramas de composición o archivos de Adobe Illustrator).

Funciones no compatibles

Especifica si se rasterizan las funciones no compatibles con el formato SWF. Seleccione Ignorar para excluir funciones no compatibles o Rasterizar para procesar todos los fotogramas que contengan funciones no compatibles, como las imágenes de mapa de bits comprimidas, e incluirlas en el archivo SWF. Si selecciona Rasterizar, el exportador de SWF rasteriza archivos de origen para cada capa de la composición (excepto las capas de utilizan archivos o sólidos de Illustrator como material de archivo de origen) y composiciones anidadas con Contraer transformaciones habilitado.

Velocidad de transferencia de bits de audio

Especifica la velocidad de bits de audio exportado. Seleccione Auto para obtener la velocidad de bits más baja para los ajustes especificados de Velocidad de muestreo y canales. Las velocidades de bits más altas incrementan el tamaño del archivo. El audio en un archivo SWF está en formato MP3.

Bucle continuo

Especifica que el archivo SWF exportado se repite continuamente durante la reproducción. Si desea especificar un bucle mediante la escritura de un código HTML para controlar el reproductor de Flash, anule la selección de Repetir continuamente.

Impedir edición

Crea un archivo SWF que no se puede modificar mediante aplicaciones como Flash Professional.

Incluir nombres de objetos

Incluye el nombre de las capas, máscaras y efectos del archivo para utilizarlos como entradas para programas ActionScript. Al seleccionar esta opción, aumenta el tamaño del archivo. A los objetos rasterizados no se les asigna nombre.

Cada máscara se exporta como un objeto SWF independiente, cuyo nombre es el nombre de la capa seguido del nombre de la máscara. Si todas las máscaras utilizan el modo Diferencia, se exportarán como un objeto SWF y el nombre será el nombre de la capa. Cada carácter se exporta como un objeto SWF independiente.

Acoplar material gráfico de Illustrator

Divide todos los objetos superpuestos en fragmentos no superpuestos. Cuando se selecciona esta opción, no es necesario convertir texto de Illustrator en contornos antes de la exportación. (Esta opción admite archivos de origen de Illustrator 9.0 o superior).

El acoplamiento del material gráfico de Illustrator tiene ventajas e inconvenientes. Cuando se acopla material gráfico de Illustrator, el texto se exporta correctamente al formato SWF y no es necesario convertir el texto en contornos. Los objetos superpuestos se eliminan de manera que las capas parezcan iguales en After Effects y en el archivo SWF. Los extremos finales, las uniones y los grupos de transparencia se exportan correctamente y no se incluye el material gráfico que se encuentra fuera de las marcas de recorte, que no son visibles en el archivo SWF. Sin embargo, el tamaño de los archivos SWF no se reduce necesariamente. Además, el proceso de acoplamiento puede introducir objetos no compatibles que se ignoran o se rasterizan, y pueden aparecer rebordes blancos alrededor de algunos objetos. El proceso puede ser lento, con un gran consumo de memoria, y posiblemente ineficaz para material gráfico complejo de Illustrator.

Incluir enlaces Web en los marcadores de capa (MS Windows) Incluir enlaces Web en los marcadores de capa (Mac OS)

Hace que los marcadores de capa se comporten como enlaces Web. La opción Incluir enlaces Web en los marcadores de capa agrega enlaces Web y una acción Obtener URL al archivo SWF mediante el uso de información de los marcadores de capa. Esta opción también agrega una etiqueta de fotograma a cada fotograma SWF que tenga un marcador de capa. Puede especificar cómo abre el explorador el enlace Web con comandos de destino estándar (por ejemplo, _blank). (Consulte Vínculos, enlaces de capítulo, puntos de señal y marcadores).

_blank

Carga el enlace Web en una nueva ventana del explorador.

_parent

Carga el enlace Web en el fotograma primario del fotograma en el que se esté reproduciendo el archivo actual.

_self

Carga el enlace Web en el fotograma actual.

_top

Carga el enlace Web en el fotograma superior de la ventana actual.

_level0

Carga otro archivo SWF en el nivel 0. Normalmente, el archivo actual se reproduce en el nivel 0; otro archivo cargado en el nivel 0 suele reemplazar al archivo actual. La URL debe hacer referencia a otro archivo SWF.

_level1

Carga otro archivo SWF en el nivel 1 si la URL hace referencia a otro archivo SWF.

Funciones no compatibles para exportación de formato SWF

Capas

Las capas de texto de After Effects se exportan al formato SWF en forma de gráficos vectoriales. Los siguientes tipos de capas y definidores de capas no son compatibles: Mates de seguimiento, Capas 3D, Cámaras 3D, Luces 3D, Capas de ajuste, Capas de forma, Conservar transparencia, Contraer transformaciones y Desenfoque del movimiento. La opción de caracteres Trazo sobre relleno y la propiedad de animación Desenfoque no son compatibles, y solo es compatible el modo de fusión normal. Las composiciones anidadas no son compatibles y se rasterizan.

Máscaras

Solo son compatibles las máscaras con el modo de máscara Agregar o Diferencia; las máscaras múltiples de una capa deben utilizar el mismo modo de máscara. Si se especifica el modo Agregar, también se admiten la opacidad parcial y la opción de máscara Invertida. No se admite el calado de máscara. El resultado de la superposición de máscaras con el modo Agregar y la opacidad parcial puede visualizarse de forma diferente en el archivo SWF y en After Effects. (Consulte Modos de máscara).

Efectos

El texto de trazado, la forma de onda de audio y el espectro de audio son compatibles con la salida en formato SWF.

Todas las opciones de texto de trazado son compatibles, con la excepción de las siguientes: Compuesto sobre original, Relleno sobre trazo y el modo Diferencia.

Las líneas que trazan los efectos espectro de audio y forma de onda de audio se convierten en vectores. Se omiten las siguientes características no compatibles: Color exterior (solo se emplea el Color interior), Suavidad y Compuesto sobre original. Además, solo se incluyen líneas gruesas uniformes en el archivo SWF. Por ejemplo, si selecciona la opción Usar trazado polar en Espectro de audio, las líneas se hacen más gruesas cuando se alejan del centro en After Effects, pero en el archivo SWF las líneas conservan el mismo grosor.

Las formas de onda pueden incrementar el tamaño del archivo SWF, de forma que debe reducir el valor de Muestreo de visualización en el efecto Forma de onda de audio, o el valor Bandas de frecuencia del efecto Espectro de audio, o reducir la velocidad de los fotogramas para que se reduzca el tamaño del archivo SWF.

Resolución

Los archivos SWF siempre se crean con máxima resolución (tamaño de la composición); las imágenes de mapa de bits JPEG comprimidas se procesan con máxima resolución.

Archivos de Adobe Illustrator

Solo son compatibles los trazados contorneados y los trazados rellenos en los espacios de color CMYK o RGB.

Las capas que contienen archivos de origen de Illustrator se convierten en los elementos SWF correspondientes si la capa no contiene máscaras o no tiene activada la opción Contraer transformaciones. Las capas de Illustrator que contienen máscaras o tienen activada la opción Contraer transformaciones se rasterizan. El archivo SWF mantiene las marcas de recorte de Illustrator El material gráfico que se encuentra fuera de las marcas se incluye en el archivo SWF aunque no sea visible, y se incrementa el tamaño del archivo.

El informe de exportación de SWF muestra información de funciones no compatibles en los archivos de Illustrator, en el primer fotograma en que es visible el archivo de Illustrator. Las funciones no compatibles se ignoran o se rasterizan (dependiendo de si ha seleccionado Ignorar o Rasterizar funciones no compatibles) en todos los fotogramas en los que el material de archivo es visible.

Procesamiento y exportación de una composición como archivo FLF o F4V

Los archivos FLV y F4V solo contienen vídeos basados en píxeles (rasterizados), no admiten gráficos vectoriales y no son interactivos.

Los formatos FLV y F4V son formatos contenedores, cada uno de ellos asociado a un conjunto de formatos de audio y vídeo. Los archivos FLV suelen incluir datos de vídeo codificados con el códec de vídeo On2 VP6 y datos de audio codificados con un códec de audio MP3. Los archivos F4V normalmente contienen datos de vídeo codificados mediante un códec de vídeo H.264 y el códec de audio AAC.

Nota:

After Effects CS4 y versiones anteriores también ofrecían la opción de codificar datos de vídeo en archivos FLV utilizando el códec de vídeo Sorenson Spark.

Puede reproducir una película en un archivo contenedor FLV o F4V en muchas formas diferentes, entre las que se incluyen:

  • Importar el archivo en la aplicación de creación Flash Professional y publicar el vídeo en un archivo SWF.

  • Reproducir la película en Adobe Media Player (AMP).

  • Previsualizar la película mediante Adobe Bridge.

Nota:

Los marcadores de After Effects se pueden incluir como puntos de señal en un archivo FLV o F4V de salida. Para transferir fotogramas clave o valores de propiedades globales desde After Effects a la aplicación de creación Flash Professional, ejecute la secuencia de comandos Convert Selected Properties To Markers.jsx antes de procesar y exportar un archivo FLV o F4V.

Una película se procesa y se exporta al formato contenedor FLV o F4V utilizando la cola de procesamiento exactamente igual que con otros formatos. (Consulte Procesar y exportar una película utilizando la cola de procesamiento).

Para incluir el canal alfa en la salida FLV, utilice el códec On2 VP6 y seleccione Codificar canal alfa en la ficha Vídeo del cuadro de diálogo de ajustes de exportación. After Effects premultiplica los canales con negro cuando codifica la transparencia en los archivos FLV. (Consulte Interpretación de canal alfa: premultiplicado o recto).

Cuando procesa y exporta una composición al formato F4V o FLV desde un proyecto de 32 bpc, el procesamiento de colores con valores inferiores a 0 y superiores a 1 no produce resultados que conserven el aspecto de la composición en After Effects. Para evitar resultados inesperados, puede trabajar con un proyecto de 8 bpc o 16 bpc al crear una composición que desee procesar y exportar al formato F4V o FLV. Si lo prefiere, puede trabajar en un proyecto de 32 bpc, procesar y exportar la composición a otro formato y convertir el archivo de salida en F4V o FLV.

Recursos en línea sobre los formatos FLV y F4V

Este vídeo de la serie After Effects CS5: Learn by Video (After Effects CS5: aprendizaje por vídeo) muestra la exportación a los formatos FLV y F4V.

Jan Ozer ofrece sugerencias e información técnica en “Encoding options for H.264 video” (Opciones de codificación para vídeo H.264), en el sitio web Adobe Developer Connection (en inglés) para codificar vídeo utilizando el códec H.264.

Kush Amerasinghe incluye una descripción general de H.264 y F4V en “H.264 for the rest of us“, en el sitio web Adobe Developer Connection (en inglés).

Robert Reinhardt proporciona información sobre vídeo para Flash Player en algunos capítulos de ejemplo en su libro Video with Adobe Flash CS4 Professional Studio Techniques en el sitio web Peachpit (en inglés). En el capítulo "Compression primer", se explican detalladamente las ventajas y desventajas de los códecs de vídeo On2 VP6 y H.264.

Para obtener más información sobre los formatos FLV y F4V, incluyendo la especificación F4V, consulte el sitio web del centro de desarrollo de Adobe.

Fabio Sonnati ofrece recomendaciones para los ajustes de películas H.264 (F4V) para dispositivos móviles en el sitio web del centro de desarrollo de Adobe.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea