Masking in Premiere Pro

You can leverage the powerful masking and tracking workflows from After Effects directly within Premiere Pro.

Masks let you define a specific area in a clip that you want to blur, cover, highlight, apply effects, or color-correct.

You can create and modify different shaped masks, like an Ellipse or a Rectangle. Or, you can draw free-form Bezier shapes using the Pen tool.

Masking in Premiere Pro

A. Ellipse shape tool B. Rectangle shape tool C. Pen tool  

You can apply effects either inside or outside the masked area. One of the common uses of masking is to blur a person's face to protect their identity. For example, you can mask a person's face by applying a Blur effect or a Mosaic effect.

You can also use masking in more creative ways like applying a mask to correct a specific color. You can use an inverse mask selection to exclude the masked area from color corrections applied to the rest of the clip. In addition, you can add multiple shape masks with different effects to different areas of a clip.

Create a mask using shape tools

Premiere Pro provides you two shape tools: An Ellipse shape tool to create a circular or ellipse-shaped mask, and a Rectangle shape tool to create a four-sided polygon.

 

  1. In the Timeline, select the clip containing the area that you want to mask.

  2. From the Effects panel, select the effect that you want to apply to the masked area.

    For example, if you want to apply the Mosaic effect, select Video Effects > Stylize > Mosaic.

  3. Apply the selected effect to a clip by dragging the effect icon from the Effects panel to the clip in the Timeline panel. Alternatively, select the clip and double-click an effect in the Effects panel to apply it.

    Note:

    You can apply the same effect multiple times by using different settings each time.

    For more information on applying an effect, see Apply effects to clips.

  4. Click the Ellipse shape tool to create an Ellipse-shaped mask or click the Rectangle shape tool to create a rectangle-shaped mask.

    The shape mask appears in the clip displayed in the Program Monitor, and the effect is constrained within the masked area.

Important notes

  • Premiere Pro does not save masks as effects presets.
  • Masking is disabled for the Warp Stabilizer effect. The mask shape controls do not appear for the Warp Stabilizer effect in the Effect Controls Panel.

Create a free-form shape using the Pen tool

The Pen Tool lets you freely draw complex mask shapes around objects.

Click the Pen tool to begin drawing the mask. You can create different shapes by drawing straight lines and curved segments. To draw smooth curves, you can draw Bezier path segments that provide you greater control over the shape of the mask.  

Draw straight path segments with the Pen tool

The simplest path that you can draw with the Pen tool is a straight line with two vertex points. By continuing to click, you create a path made of straight-line segments connected by vertex points.

Using the Pen tool
Click with the Pen tool to create straight segments

  1. Select the Pen tool.

  2. Position the Pen tool where you want the straight segment to begin, and click to define the first vertex point (do not drag).

    Note:

    The first segment you draw is not visible until you click a second vertex point.

  3. Click again where you want the segment to end (Shift-click to constrain the angle of the segment to a multiple of 45°).

  4. Continue clicking to set vertex points for additional straight segments.

  5. To close the path, position the Pen tool over the first vertex point. A small circle appears next to the Pen tool pointer when it is positioned correctly. Click or drag to close the path.

Draw curved Bezier path segments with the Pen tool

You create a curved path segment by dragging direction lines using the Pen tool. The length and direction of the direction lines determine the shape of the curve.

To create Bezier shapes, you convert a vertex point on a mask to a Bezier point by pressing the Alt key while placing the cursor over the vertex point. The cursor becomes an inverted "V" shape . Then, click and release the pointer.

Bezier handles provide two-directional controls that allow you to change the curve of the line segment between the handle and the next point on either side.

Bezier handles
A. Two-directional Bezier handles to control the shape of the curve B. Bezier mask points  
  1. Place the Pen tool where you want the curve to begin, and hold the mouse button down. A vertex appears, and the Pen tool pointer changes to an arrowhead.

  2. Drag to modify the length and direction of both direction lines for a vertex, and then release the mouse button.

    Drawing the first vertex in a curved path
    Drawing the first vertex in a curved path

    A. Placing the Pen tool  B. Starting to drag (mouse button pressed) C. Dragging to extend direction lines  
  3. Place the Pen tool where you want the curved segment to end, and do one of the following:

    • To create a C-shaped curve, drag in the direction opposite from the direction that you dragged the previous direction line, and then release the mouse button.
    Drawing the second vertex in a curved path
    Drawing the second vertex in a curved path

    A. Starting to drag B. Dragging away from previous direction line, creating a C curve  C. Result after releasing mouse button  
    • To create an S-shaped curve, drag in the same direction as the previous direction line, and then release the mouse button.
    Drawing an S curve
    Drawing an S curve

    A. Starting to drag B. Dragging in same direction as previous direction line, creating an S curve C. Result after releasing mouse button  
  4. Continue dragging the Pen tool from different locations to create a series of smooth curves.

Modifying and moving masks

The vertex points on a mask let you easily manage the shape, size, and rotation of a mask.

Adjust mask shapes
A, B, C, D: Vertex points to adjust the shape, size, and rotation of a mask

 Modify the shape, size, and rotation of a mask

  • To change the shape of a mask, drag a mask handle.
  • To change the shape of an ellipse mask to a polygon, press Alt and click any of the vertices of the ellipse.
  • To resize a mask, place your cursor just outside a vertex and press Shift (cursor becomes a double-sided arrow ), then drag the cursor while pressing the Shift key.
  • To rotate the mask, place your cursor just outside a vertex (cursor becomes a curved double-sided arrow ), and then drag. Press the Shift key while dragging the cursor to constrain the rotation in 22.5 degree increments.

Move, add, or remove a vertex

  • To move a vertex, drag the vertex with the Selection tool. Note that while dragging an ellipse-shaped mask, the ellipse shape is not maintained.
  • To add a vertex, place your cursor over a mask edge while pressing the Ctrl Key (Win) or Cmd key (Mac). The cursor changes to a pen shape with a "+" sign . Click to add the vertex to the mask shape.
  • To remove a vertex, place your cursor over the point to remove while pressing the Ctrl Key (Win) or Cmd key (Mac). The cursor changes to a pen shape with a minus sign . Click to remove the selected vertex from the mask shape.

Other important commands and keyboard shortcuts

  • Use the arrow keys on your keyboard to nudge a selected control point by a distance of one unit.
  • Press Shift and use the arrow keys to nudge a selected control point by a distance of five units.
  • To deselect all the selected control points, click outside a currently active mask.
  • To disable direct manipulation of a mask, click outside the mask. Or deselect the clip in the sequence.
  • To delete a mask, select the mask in the Effects Control Panel and press Delete on your keyboard.

Feather a mask edge or adjust mask expansion

Premiere Pro provides controls that let you adjust mask feathering and expansion directly on the Program Monitor.

The mask position handle lets you move the feather and expansion handles in unison along the mask outline. Using the mask position handle, you can place the feather and expansion controls at a convenient position on the mask.

Feather mask
A. Feather handle to control feathering B. Expansion handle to expand and contract the mask C. Mask position handle to move controls D. Expansion guide E. Feathering guide 

Apply mask feathering

Feather mask edges
A. Without feathering B. With feathering applied 

Smooth the edges of a mask shape by applying feathering. Feathering softens the mask selection border so that it blends into the area outside the selection, and provides an aesthetically pleasing result.

The mask feather handle lets you control the amount of feathering directly on the mask outline in the Program Monitor. Premiere Pro displays a feathering guide around the mask outline. The feathering guide is displayed as a dashed line.

You can also specify a Mask Feather value in the Effects Control panel.

Drag the handle away from the feathering guide to increase the feathering, or toward the feathering guide to decrease the feathering.

Adjust mask expansion

Mask expansion lets you expand or contract the area of the mask. The mask expansion guide, displayed as a solid blue line on the Program Monitor, helps you expand or contract the mask area precisely.

Drag the handle away from the expansion guide to expand the mask area, or toward the expansion guide to contract the mask area.   

You can also specify a Mask Expansion value in the Effects Controls panel to move the borders of the mask inwards or outwards. Positive values move the borders outward, and negative values move it inward.

Adjust mask settings using Effect Controls panel

You can specify values to adjust a mask using the Effects Controls panel. You can track the mask, change the opacity, expand the mask, invert the mask, or feather the mask edges.

Adjust mask settings
A. Track the mask B. Invert masked and unmasked areas C. Change mask expansion D. Adjust mask opacity E. Feather mask edges 

Adjust mask opacity

To adjust the opacity of a mask, specify a Mask Opacity value. The slider controls the mask opacity. At  a value of 100, the mask is opaque and blocks out any underlying area of the layer. As you lower the opacity, more of the area under the mask becomes visible.

Invert mask selection

Select the Inverted check box to reverse the masked and unmasked areas. You can protect areas that you want to leave as-is by masking it, and select the Inverted check box to apply effects to the unmasked areas.

Lumetri Look applied to unmasked area using the Invert mask selection
Lumetri Look applied to unmasked area using the Invert mask selection

Copy and paste masks

You can easily copy and paste masks between clips or between effects.

Copy and paste effects with masks between clips

When you copy and paste an effect containing masks, the pasted effect has the same masks applied.

  1. In the Timeline panel, select the clip containing the effect with masks.
  2. In the Effect Controls panel, select the effect to copy.
  3. Select Edit > Copy. Or use the keyboard shortcut Ctrl+C (Windows) or Cmd+C (Mac OS).
  4. Select another clip in the Timeline to which you want to paste the mask.
  5. Select Edit > Paste. Or use the keyboard shortcut Ctrl+V (Windows) or Cmd+V (Mac OS).

 

Copy and paste masks between effects

  1. In the Effect Controls panel, click the triangle to expand the effect to reveal the applied masks.
  2. Select the mask to copy.
  3. Select Edit > Copy. Or use the keyboard shortcut Ctrl+C (Windows) or Cmd+C (Mac OS).
  4. Select another effect in the Effects Control panel to which you want to paste the mask.
  5. Choose Edit > Paste. Or use the keyboard shortcut Ctrl+V (Windows) or Cmd+V (Mac OS).

Note:

You can copy and paste only one mask at a time.

Mask tracking in Premiere Pro

When you apply a mask to an object, Premiere Pro can let the mask automatically follow the object as it moves from one frame to another. For example, after blurring a face using a shape mask, Premiere Pro can automatically track the movements of the masked face from frame to frame as the person moves.

When a mask is selected, the Effect Controls panel displays controls for tracking the mask forward or backward. You can choose to track the mask either one frame at a time or until the end of the sequence.

Click the wrench icon  to modify how masks are tracked. You can select from a few choices to provide the most effective tracking:

Position

Tracks just the mask position from frame to frame

Position And Rotation

Tracks the mask position while changing the rotation as required per frame

Position, Scale, And Rotation

Tracks the mask position while automatically scaling and rotating as the frame moves

Note:

You can find the option that works best for your clip by trial. Select one of these options, and if it doesn't work well, undo, and try another one.

To use the more advanced tracking features available in After Effects, send your sequence to After Effects using the Dynamic Link feature. For more information, see Mask Tracking in After Effects.

Video tutorial

How to blur a moving face with masking and tracking

In this 5-min video tutorial, learn how to apply a feathered mask to protect a person's identity and then track that mask as it moves across the frame in a scene.

The tutorial provides you sample files to try out the feature for yourself.  


This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy