Примечание.

Экспорт в форматы FLV и F4V поддерживается, начиная с версии After Effects CC, выпущенной в июне 2014 года, и более поздних версий. Для экспорта файлов в форматы FLV и F4V используйте After Effect CC (июньский выпуск 2013) или более ранних версий.

Можно выполнять рендеринг фильмов и экспортировать их из программы After Effects для воспроизведения в Adobe Flash Player. Файлы SWF автоматически воспроизводятся в Flash Player, однако для воспроизведения файлов формата FLV или F4V требуется упаковать их в контейнер файла SWF или привязать их к нему. Можно также экспортировать композиции в Flash Professional в виде файлов XFL.

Это видео из серии After Effects CS5: изучаем по видео содержит общие сведения об экспорте файлов в различные форматы для Flash Professional и Flash Player и демонстрирует использование и общие возможности каждого из них.

XFL

Файлы XFL являются представлениями композиций, которые можно открыть в Flash CS4 Professional или более поздних версиях. По сути, файлы XFL представляют собой XML-эквивалент файлов FLA.

SWF

Файлы SWF — это небольшие файлы, которые воспроизводятся в Flash Player. Они часто используются для представления анимированных векторных изображений (например, мультфильмов), аудио и других типов данных в Интернете. Формат SWF также обеспечивает интерактивное взаимодействие пользователя с файлом: щелчок мыши для перехода по ссылке, управление анимацией, предоставление входной информации для сетевых приложений стандарта RIA. Файлы SWF — это выходные файлы, создаваемые из файлов FLA.

FLV и F4V

Файлы FLV и F4V содержат только видео на пиксельной основе (растрированное) и не предусматривают векторных изображений, они не являются интерактивными. Файлы FLA могут содержать в себе файлы FLV и F4V и обращаться к ним, при этом файлы таких форматов встраиваются или связываются с файлами SWF, воспроизводимыми в проигрывателе Flash Player.

Экспорт композиции как файла XFL в Flash Professional

Можно экспортировать композиции из программы After Effects в формате XFL для дальнейшего редактирования и использования в Flash CS4 Professional или более поздних версиях. Например, можно использовать ActionScript в Flash Professional для добавления интерактивной анимации к каждому из слоев в композициях After Effects.

При экспорте композиции в виде файла XFL After Effects пытается экспортировать отдельные слои и ключевые кадры, сохраняя максимальный объем информации для прямого использования в Flash Professional. Если After Effects не может экспортировать элемент композиции в файл XFL в виде данных без рендеринга, элемент пропускается или выполняется его рендеринг в элемент PNG или FLV, в зависимости от того, выбран ли параметр пропускания неподдерживаемых возможностей.

Сведения о файлах XFL

По сути, файлы XFL представляют собой XML-эквивалент файлов FLA. Файл XFL — это сжатая архивная папка, которая содержит подпапку библиотеки и документ XML (DOMDocument.xml), описывающий файл FLA. Подпапка библиотеки содержит ресурсы, на которые ссылается файл XML. При открытии в программе Flash Professional эти элементы извлекаются из файла XFL и используется для создания документа FLA. Документ из Flash Professional сохраняется как новый файл FLA; файл XFL при работе с Flash Professional не изменяется.

Примечание.

Если требуется просмотреть или вручную отредактировать содержимое файла XFL, можно открыть сжатый архивный файл так же, как любой другой файл ZIP. Изменение расширения имени файла на ZIP не требуется, но такое вспомогательное действие может сделать процедуру извлечения файлов более удобной для пользователя.

Это видео из серии After Effects CS5: изучаем по видео посвящено экспорту файла в формат XFL.

Экспорт композиции в формат XFL

  1. Для экспорта выделенной композиции как файла XFL выберите «Файл» > «Экспорт» > «Adobe Flash Professional (XFL)».

  2. В диалоговом окне «Настройки Adobe Flash Professional (XFL)» выберите действие, которое After Effects будет применять к слоям с неподдерживаемыми возможностями.

    Пропустить

    Слои с неподдерживаемыми возможностями не включаются в конечную композицию XFL.

    Растрировать в

    Слои с неподдерживаемыми возможностями растрируются. Это подразумевает рендеринг слоев в растровый формат (файл FLV или набор изображений PNG). Векторная информация при этом не сохраняется. Этот параметр сохраняет внешний вид слоя при использовании файла XFL в Flash Professional. При растеризации в набор изображений PNG идентичные смежные кадры растририруются только один раз в один файл PNG, к которому можно обращаться несколько раз.

  3. (Необязательно) Нажав кнопку «Параметры формата», можно изменить настройки, используемые для создания наборов PNG или файлов FLV.

    При выборе из меню «Формат» формата FLV и нажатии кнопки «Параметры формата» появляется диалоговое окно настроек экспорта. Можно изменить такие элементы, как скорость потока, но, как правило, изменение многих параметров в этом диалоговом окне не требуется. Изменения, выполненные в этом диалоговом окне, сохраняются и используются для последующих операций экспорта, поэтому будьте внимательны при внесении изменений.

    Если требуется отменить изменения, внесенные в параметры формата, в диалоговом окне «Настройки Adobe Flash Professional (XFL)» выберите «Сбросить к значениям по умолчанию».

  4. В диалоговом окне «Экспортировать как проект Adobe Flash Professional (XFL)» выберите местоположение для сохранения выходных файлов.

По мере продвижения процесса обработки композиции в диалоговом окне показывается ход операции экспорта.

При создании файла XFL, After Effects также сохраняет отчет ([XFLfile_name] report.html) в той же папке, что и файл XFL. Отчет содержит следующие сведения:

  • были ли слои с неподдерживаемыми возможностями растрированы или пропущены;

  • был ли каждый исходный элемент растрирован (выполнялся рендеринг) или пропущен (привязан);

  • был ли каждый слой растрирован (выполнялся рендеринг) или же преобразован во внутренний объект Flash.

Работа в Flash Professional с документами FLA, созданными из файлов XFL

Панель «Библиотека» в программе Flash Professional похожа на панель «Проект» в программе After Effects. При создании документа FLA из файла XFL, Flash Professional создает символы, папки и видеоклипы и упорядочивает их на панели «Библиотека». Каждый элемент на панели «Библиотека» имеет уникальное имя, даже если несколько элементов созданы на основе элементов с одинаковыми именами в After Effects, так что этими элементами можно управлять и получать к ним доступ с помощью ActionScript. Для соблюдения требований в отношении уникальности имен при создании файлов XFL After Effects присоединяет ко многим именам файлов символы подчеркивания и цифры.

Когда Flash Professional создает документ FLA из файла XFL, включающий файлы FLV, они встраиваются в таймлайн в формате Flash. Часто более эффективным способом создания документа FLA является перемещение видеофайлов на какое-либо внешнее место, на которое затем ссылается файл SWF при потоковой передачи видео. В случае необходимости можно удалить встроенные в Flash Professional файлы FLV путем удаления и повторного импорта видео с использованием компонента FLVPlayback.

Примечание.

В After Effects таймлайн композиции начинается с кадра 0. В Flash Professional таймлайн начинается с кадра 1. Из-за этого различия таймлайн композиции After Effects и соответствующий таймлайн Flash оказываются сдвинуты друг относительно друга на один кадр.

В After Effects композиция может иметь пропорции пикселя, отличные от 1,0 (квадратные пиксели). Flash Professional поддерживает только пропорции пикселя 1,0. Если композиция экспортируется в формат XFL, документ FLA формируется из другого числа квадратных пикселей, чтобы внешний вид документа в среде Flash Professional соответствовал виду композиции After Effects. Значения масштаба в файле XFL сохраняют внешний вид слоев.

Сохранение возможностей и данных при экспорте композиции в формат XFL

При импорте композиции в формате XFL After Effects выполняет обработку в несколько этапов, пытаясь на каждом этапе экспортировать максимальное количество информации из слоев и их исходных файлов.

Если в качестве источников для слоев композиции используются файлы PNG, JPEG и FLV, эти исходные файлы включаются в вывод XFL (передаются), если только слои не используют возможности, которые требуют от After Effects перекодирования файлов источника или растеризации слоев для экспорта в XFL.

Примечание.

Перекодировка — это преобразование исходного файла из одного формата в другой формат (например, GIF в PNG). Растеризация — это преобразование слоя в растровое изображение, т. е. вся информация о модели (включая векторные объекты и ключевые кадры) объединяется в сглаженное попиксельное изображение для каждого кадра.  

Этап 1. Исходные файлы остаются по возможности без изменений.

Для передачи исходного файла слоя в файл XFL слой должен соответствовать следующим требованиям.

  • Слой должен содержать элемент исходного видеоряда, и этот элемент видеоряда должен использовать набор PNG или JPEG или файл FLV в качестве источника. (Слой не является текстовым слоем, слоем камеры, слоем света или слоем-фигурой.)

  • Частота кадров элемента исходного видеоряда должна соответствовать частоте кадров композиции.

  • Источник слоя не должен быть усечен.

  • Слой не должен растягиваться за пределы перед первым кадром или за последним кадром рабочей области композиции.

  • Слой не должен иметь никаких свойств, кроме свойств «Положение», «Опорная точка», «Непрозрачность», «Масштаб» и «Поворот». Поскольку эффекты добавляют свойства в слои, это требование также означает, что слой не должен иметь примененных эффектов.

  • Слой не должен содержать размытия в движении, совмещения кадров, или преобразований времени.

  • Слой не должен содержать подложки отслеживания.

  • Над слоем не должно располагаться корректирующего слоя.

  • Слои над данным слоем могут использовать только нормальный режим наложения.

  • Слой и все слои над ним не должны содержать набор параметров «Сохранить прозрачность».

  • Слой не должен быть 3D-слоем.

Этап 2. Оставшиеся исходные файлы преобразуются в наборы PNG или файлы FLV, если это возможно.

Если единственная причина невозможности преобразования источника слоя в файл XFL состоит в том, что он не использует набор PNG, набор JPEG или файл FLV в качестве источника, то источник слоя перекодируется или растрируется в набор PNG или файл FLV, включаемые в файл XFL. В этом случае ключевые кадры «Положение», «Опорная точка», «Непрозрачность», «Масштаб» и «Поворот» сохраняются и преобразуются в ключевые кадры формата XFL. Если несколько слоев используют один и тот же источник в After Effects и удовлетворяют всем перечисленным требованиям для преобразования, они будут также использовать общий источник в документе, созданном в Flash Professional. Предварительные композиции могут быть растрированы как элементы источника.

Файл XFL, созданный из композиции, сохраняет данные анимации для слоев композиции. Ключевые кадры для свойств «Положение», «Опорная точка», «Непрозрачность», «Масштаб» и «Поворот» преобразуются в ключевые кадры в Flash Professional, но с одним ключевым кадром на кадр для каждого анимированного свойства. Преобразуются только двухмерные ключевые кадры «Положение» (X и Y) и «Поворот» (Z).

В After Effects свойство «Опорная точка» может быть анимировано, но точка преобразования в Flash Professional анимирована быть не может. В Flash Professional точка преобразования расположена в левом верхнем углу символа. Анимации ключевых кадров свойств преобразования (включая опорную точку) в After Effects преобразуются в анимации вокруг центра преобразования в экспортированном файле XFL.

Этап 3. Оставшиеся слои растрируются как отдельные слои, если это возможно.

Если слой не соответствует требованиям передачи, перекодировки или растеризации исходного файла как элемента источника, то сам слой необходимо растрировать как слой. Растеризация слоя подразумевает потерю всей информации о его ключевых кадрах, информация будет содержаться непосредственно в кадрах растрированного изображения.

Для растеризации в качестве отдельного слоя слой должен соответствовать следующим требованиям.

  • Слой должен быть основан на элементе видеоряда (включая сплошной элемент) или являться слоем-фигурой или текстовым слоем. (Слой не является слоем камеры, слоем света или слоем только с аудио.)

  • Над слоем не должно располагаться корректирующего слоя.

  • Слои над данным слоем могут использовать только нормальный режим наложения.

  • Слой не должен содержать подложки отслеживания.

  • Слой и все слои над ним не должны содержать набор параметров «Сохранить прозрачность».

  • Слой не должен быть 3D-слоем.

Этап 4. Оставшиеся слои визуализируются и растрируются вместе в подборках.

Если слой не соответствует требованиям для растеризации в отдельный слой, его рендеринг и растеризация осуществляются вместе с другими слоями в группе (подборке). Подборка слоев, растрируемых вместе, обычно является подборкой 3D-слоев, слоев, размещаемых вместе с режимами наложения, подложек отслеживания и слоев с влиянием корректирующих слоев.

Ограничения на экспорт композиции в формат XFL

Когда Flash Professional открывает файл XFL, он должен загрузить все ресурсы в память. After Effects выводит предупреждение при экспорте композиции, ресурсы которой потребуют более 580 МБ памяти. Если количество кадров в наборе PNG превышает 1050, After Effects предупреждает об увеличении времени, необходимого для открытия файла XFL в Flash Professional. Композицию можно экспортировать в формат XFL, даже если он превышает эти ограничения, но файл XFL может не открыться в программе Flash Professional.

Примечание.

Чтобы избежать долгого времени загрузки наборов с большим количеством файлов PNG, можно осуществить предварительный рендеринг слоев на основе наборов PNG в формат FLV.

Для создания файлов FLV After Effects использует встроенную версию Adobe Media Encoder. Adobe Media Encoder не может создать файлы FLV, чьи размеры в пикселях превышают 1920 x 1080.

При экспорте композиции в формат XFL из проекта с глубиной 32 бита на канал рендеринг цветов со значениями ниже 0 и более 1 не сохраняет внешний вид композиции After Effects. При создании композиции, которая будет экспортироваться в Flash Professional в формате XFL, необходимо работать только с проектами с глубиной цвета 8 или 16 бит на канал.

Аудио не экспортируется в файл XFL.

Рендеринг и экспорт композиции в виде файла SWF

Файлы SWF — это небольшие файлы, которые воспроизводятся в Flash Player. Они часто используются для представления анимированных векторных изображений (например, мультфильмов), аудио и других типов данных в Интернете. Формат SWF также обеспечивает интерактивное взаимодействие пользователя с файлом: щелчок мыши для перехода по ссылке, управление анимацией, предоставление входной информации для сетевых приложений стандарта RIA. Файлы SWF — это выходные файлы, создаваемые из файлов FLA.

При выполнении рендеринга и экспорта фильма в файл SWF After Effects по мере возможности сохраняет векторную графику в виде векторных объектов. Однако растровые изображения, режимы наложения, размытие в движении, некоторые другие эффекты и содержимое вложенных композиций растрируются и не могут быть представлены как векторы в файле SWF.

Можно пропускать неподдерживаемые элементы, и файл SWF будет включать только функции After Effects, которые могут быть преобразованы в собственные элементы SWF; можно растрировать кадры, содержащие неподдерживаемые возможности и добавить их в файл SWF как сжатые битовые изображения формата JPEG, что может уменьшить эффективность использования файла SWF.

Аудио кодируется в формате MP3 и добавляется в файл SWF как аудиопоток.

При создании файла SWF, After Effects также сохраняет отчет ([SWFfile_name]R.htm) в той же папке, что и файл SWF. Отчет также включает ссылку на файл SWF, чтобы можно было предварительно просмотреть конечный результат, используя подключаемый модуль проигрывателя Flash Player. Отчет можно открыть в браузере, чтобы просмотреть файл SWF и увидеть, какие элементы в композиции не поддерживаются.

Экспортированный файл SWF содержит один экземпляр каждого неизмененного элемента композиции After Effects и ссылается на них при каждом использовании. Если слой используется в нескольких кадрах, каждый случай использования ссылается на тот же самый объект, даже если свойства преобразования слоя (например, «Положение») анимируются. Если содержимое слоя изменяется, например, если маска слоя анимируется или если элемент исходного видеоряда для слоя является элементом видео, то для каждого кадра, в котором появляется слой, создается новый объект. Если несколько слоев в композиции используют тот же элемент исходного видеоряда, источник добавляется только один раз, а затем на него ссылается каждый дополнительный слой, использующий источник. Если исходный файл является файлом Illustrator, создается клип SWF, который используется в качестве ссылки. Текстовые символы добавляются один раз как векторы, и затем на них ссылаются все последующие кадры, если только в меню настроек «Заливка и обводка» не выбран параметр «Заливка поверх обводки» — в этом случае символы добавляются в виде векторов к каждому кадру.

Примечание.

Если в проекте включено управление цветом, цвета преобразуются из рабочего цветового пространства проекта в цветовое пространство sRGB IEC61966-2.1 для вывода. Это цветовое пространство вывода подходит для фильмов, отображаемых в браузере. (См. раздел Управление цветом.)

  1. Выберите композицию для экспорта и выберите «Файл» > «Экспорт» > «Adobe Flash Player (SWF)».
  2. Введите имя файла (с расширением .SWF) и путь к нему и нажмите кнопку «Сохранить».
  3. Укажите необходимые параметры и затем нажмите кнопку «ОК».

Chris Jackson предлагает полезные советы по рендерингу и экспорту файлов SWF из After Effects в отрывке из книги Flash + After Effects на веб-сайте Focal Press.

Настройки экспорта SWF

Качество JPEG

Определяет качество растровых изображений. Чем выше качество, тем больше размер файла. (При выборе растеризации для неподдерживаемых возможностей параметр «Качество JPEG» используется для всех растровых изображений, сжатых по алгоритму JPEG для экспорта в файл SWF, включая растровые изображения, созданные из кадров композиции или файлов Adobe Illustrator.)

Неподдерживаемые возможности

Определяет, следует ли растрировать возможности, которые не поддерживает формат SWF. Выберите «Пропустить» для исключения неподдерживаемых возможностей или «Растрировать» для рендеринга всех кадров, содержащих неподдерживаемые возможности, в формат растровых изображений, сжатых по алгоритму JPEG, и включения их в файл SWF. При выборе параметра «Растрировать» средство экспорта SWF растрирует исходные файлы для каждого слоя в композиции (за исключением слоев, которые используют файлы Illustrator и заливку как исходный видеоряд) и вложенные композиции с выбранным параметром «Свернуть трансформации».

Битрейт аудио

Определяет скорость потока (битрейт) экспортированного аудио. Выберите «Автоматически» для установки наименьшего доступного битрейта для заданных параметров «Частота дискретизации» и настроек каналов. Увеличение битрейта приводит к увеличению размера файла. Звук в файле SWF представляется в формате MP3.

Повторять бесконечно

Указывает, что экспортированный файл SWF должен воспроизводиться с неограниченным повторением. Если предусматривается задание циклического воспроизведения с помощью кода HTML для управления Flash Player, снимите флажок «Повторять бесконечно».

Запретить редактирование

Создает файл SWF, который не может быть изменен приложениями, такими как Flash Professional.

Включить имена объектов

Включает слой, маски и имена эффектов в файл для использования в качестве ввода в приложениях ActionScript. При выборе этого параметра размер файла увеличивается. Растрированные объекты имеют имен.

Каждая маска экспортируется как отдельный объект SWF, имя которого складывается из имени слоя и имени маски. Если для всех масок используется режим «Разница», все маски экспортируются как один объект SWF, имя которого совпадает с именем слоя. Каждый текстовый символ экспортируется как отдельный объект SWF.

Выполнить сведение графического объекта Illustrator

Разделяет все объекты с наложением на ненакладывающиеся части. При выборе этого параметра перед экспортом не требуется преобразовывать текст Illustrator в кривые. (Этот параметр поддерживает исходные файлы приложения Illustrator 9.0 или более поздних версий.)

Функция сведения графического объекта Illustrator имеет свои преимущества и недостатки. При сведении объектов Illustrator текст корректно экспортируется в формат SWF, исключая необходимость преобразования текста в кривые. Накладывающиеся объекты удаляются, так что составленные слои отображаются одинаково как в After Effects, так и в файле SWF. Оконечные элементы, соединения и группы прозрачности экспортируются корректно, и изображение за пределами меток обрезки (которое не видно в файле SWF) не включается. Однако размер файла SWF не обязательно уменьшается. Кроме того, процесс выравнивания может привести к появлению неподдерживаемых объектов, которые затем пропускаются или растрируется, а вокруг некоторых объектов могут потом появиться светлые края. Процесс может протекать медленно, требовать большого количества памяти и может оказаться неэффективным для сложных объектов Illustrator.

Включить веб-ссылки на маркеры слоя

Маркеры слоя ведут себя как веб-ссылки. Параметр «Включить веб-ссылки на маркеры слоя» добавляет ссылки и действия Get URL к файлу SWF, используя информацию из маркеров слоя. Этот параметр также добавляет метку кадра к каждому кадру SWF, который содержит маркер слоя. Указать поведение браузера при открытии ссылки можно с помощью стандартных целевых команд (например, _blank). (См. раздел Веб-ссылки, ссылки на главы, точки разметки и маркеры.)

_blank

Загружает ссылки в новое окно браузера.

_parent

Загружает ссылки в родительском фрейме страницы, в которой воспроизводится текущий файл.

_self

Загружает ссылки в текущий фрейм.

_top

Загружает ссылки в верхний фрейм в текущем окне.

_level0

Загружает другой файл SWF на уровень 0. Текущий файл обычно воспроизводится на уровне 0; другой файл, загруженный на уровень 0, как правило, заменяет текущий файл. URL-адрес должен ссылаться на другой файл SWF.

_level1

Загружает другой файл SWF на уровень 1, если URL-адрес относится к другому файлу SWF.

Поддерживаемые функции для экспорта в формат SWF

Слои

Текстовые слои After Effects экспортируются в формат SWF в виде векторной графики. Не поддерживаются следующие типы и переключатели слоев: подложки отслеживания, 3D-слои, 3D-камеры, 3D-свет, корректирующие слои, слои-фигуры, «Сохранить прозрачность», «Свернуть трансформации» и размытие в движении. Не поддерживаются параметр для символов «Заполнение поверх обводки» и свойства аниматора размытия, поддерживается только наложение в нормальном режиме. Не поддерживаются и не растрируются вложенные композиции.

Маски

Поддерживаются маски только в режимах добавления масок и разницы масок; несколько масок на одном слое должны использовать один и тот же режим маски. В режиме добавления масок поддерживаются также функции частичной непрозрачности и инвертирования. Растушевка маски не поддерживается. Результат наложения масок в режиме добавления и частичной непрозрачности может отображаться по-разному в файле SWF и в After Effects. (См. раздел Режимы маски.)

Эффекты

Эффекты «Текст пути», «Форма звуковой волны» и «Спектр аудио» поддерживаются для вывода в формат SWF.

Поддерживаются все параметры текста пути, за исключением следующих: «Разместить на оригинале», «Заливка поверх обводки» и «Разница».

Линии, нарисованные с помощью эффектов «Спектр аудио» и «Форма звуковой волны», преобразуются в векторную графику. Следующие неподдерживаемые возможности игнорируются: «Внешний цвет» (используется только «Внутренний цвет»), «Мягкость» и «Разместить на оригинале». Кроме того, в файл SWF включаются только линии постоянной толщины. Например, при выборе для эффекта «Спектр аудио» параметра «Использовать путь в полярных координатах», линии в After Effects утолщаются при удалении от центра, но в файле SWF они остаются той же толщины.

Значение формы звуковой волны может увеличиться в файле SWF; для уменьшения этого значения уменьшите значение параметра «Отображаемые выборки» в эффекте «Форма звуковой волны», значение «Полосы частот» в эффекте «Спектр аудио» или скорость смены кадров.

Разрешение

Файл SWF всегда создается в полном разрешении (размер композиции); рендеринг растровых изображений, сжатых по алгоритму JPEG, выполняется с полным разрешением.

Файлы Adobe Illustrator

В цветовом пространстве CMYK или RGB поддерживаются только обведенные контуры и контуры с заливкой.

Слои с исходными файлами Illustrator преобразуются в соответствующие элементы SWF, если слой не содержит масок или выбран параметр «Свернуть трансформации». Слои Illustrator, содержащие маски или активный параметр «Свернуть трансформации», растрируются. Файл SWF поддерживает метки обрезки Illustrator. Объект за пределами меток обрезки включается в файл SWF, даже если его не видно, соответственно размер файла увеличивается.

Отчет экспорта в SWF содержит информацию о неподдерживаемых возможностях в файлах Illustrator для первого кадра, в котором файл Illustrator является видимым. Неподдерживаемые возможности пропускаются или растрируются (в зависимости от состояния параметров «Пропустить» или «Растрировать») на всех кадрах с видимым видеорядом.

Визуализация и экспорт композиции в виде файла FLV или F4V

Файлы FLV и F4V содержат только видео на пиксельной основе (растрированное) и не предусматривают векторных изображений, они не являются интерактивными.

Форматы FLV и F4V являются контейнер-форматами, каждый из которых связан с набором видео- и аудиоформатов. Файлы FLV обычно содержат видеоданные, которые кодируются с использованием видеокодека On2 VP6, и аудиоданные, которые кодируются с использованием аудиокодека MP3. Файлы F4V обычно содержат видеоданные, которые кодируются с использованием видеокодека H.264 и аудиокодека AAC.

Примечание.

After Effects CS4 и более ранние версии также предоставляют возможность кодирования видеоданных в файлы FLV с использованием видеокодека Sorenson Spark.

Можно воспроизвести фильм в контейнер-файле FLV или F4V разными способами, включая предложенные ниже.

  • Импорт файла в исходное приложение Flash Professional и публикация видео в файле SWF.

  • Воспроизведение фильма в Adobe Media Player (AMP).

  • Предпросмотр фильма с использованием Adobe Bridge.

Примечание.

Маркеры After Effects можно включить в виде точек разметки в выходном файле FLV или F4V. Для передачи ключевых кадры или значений глобальных свойств в исходное приложение Flash Professional из After Effects перед рендерингом и экспортом файла FLV или F4V запустите сценарий «Преобразование выбранных свойств в маркеры.jsx».

Рендеринг и экспорт фильма в контейнер-формат FLV или F4V выполняется с помощью очереди рендеринга, как и в случае с другими форматами. (См. раздел Рендеринг и экспорт фильма с использованием очереди рендеринга.)

Для включения альфа-канала в формат FLV используйте кодек On2 VP6, на вкладке «Видео» диалогового окна настроек экспорта выберите параметр «Кодировать альфа-канал». При кодировании прозрачности в файлах FLV After Effects выполняет перемножение каналов в обратном порядке. (См. раздел Интерпретация альфа-канала: в прямом или обратном порядке.)

При рендеринге и экспорте композиции в формат F4V или FLV из проекта с глубиной 32 бита на канал рендеринг цветов со значениями ниже 0 и более 1 не сохраняет внешний вид композиции After Effects. Во избежание неожиданных результатов при создании композиции, для которой предполагается рендеринг и экспорт в формат FLV или F4V, можно работать в проекте с глубиной 8 или 16 бит на канал. Кроме того, можно работать в проекте с глубиной 32 бита на канал, после чего выполнить рендеринг и экспорт композиции в другой формат, а затем преобразовать выходной файл в F4V и FLV.

Ресурсы в Интернете, посвященные форматам FLV и F4V

Это видео из серии After Effects CS5: изучаем по видеопосвящено экспорту файла в форматы FLV и F4V.

Ян Озер (Jan Ozer) описывает технические детали и представляет полезные советы в статье «Параметры кодирования для видео H.264» на веб-сайте Adobe Developer Connection для кодирования видео с использованием видеокодека H.264c.

Каш Амеразинг (Kush Amerasinghe) предлагает обзор H.264 и F4V в статье «H.264 простым языком» на веб-сайте Adobe Developer Connection.

Роберт Рейнардт (Robert Reinhardt) представляет сведения о видео для Flash Player в некоторых главах своей книги Video with Adobe Flash CS4 Professional Studio Techniques на веб-сайте Peachpit. В главе Основы сжатия он в деталях рассматривает преимущества и недостатки видеокодеков On2 VP6 и H.264.

Дополнительные сведения о форматах FLV и F4V, включая спецификации F4V, можно найти на веб-сайте Adobe Developer Connection.

Рекомендации Фабио Соннати (Fabio Sonnati) по настройке видеофильмов в формате H.264 (F4V) для мобильных устройств можно найти на веб-сайте Adobe Developer Connection.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет