Работа с программами Adobe Bridge и After Effects

Используйте Adobe Bridge для применения шаблонов настроек анимации; выполнения сценариев автоматизации процесса взаимодействия программ; просмотра и управления файлами и папками; организации файлы путем добавления ключевых слов, подписей и рейтингов; поиска файлов и папок; и для просмотра, редактирования и добавления метаданных.

  • Для открытия Adobe Bridge из After Effects выберите «Файл» > «Обзор в Bridge».
  • Для открытия файла в Adobe Bridge выберите файл на панели «Проект» и нажмите «Файл» > «Открыть в Bridge».
  • Для использования Adobe Bridge для просмотра шаблонов настроек анимации, выберите «Анимация» > «Обзор шаблонов настроек».

Программа Adobe Bridge входит в комплект программ Creative Cloud, она загружается и устанавливается с помощью Creative Cloud. См. справочную документацию и страницу программы Adobe Bridge CC для получения дополнительных сведений.

См. видео с обзором Adobe Bridge CC.

Работа с Photoshop и After Effects

При использовании Photoshop для создания неподвижных изображений можно использовать After Effects, чтобы собрать вместе эти неподвижные изображения и заставить их двигаться и меняться. В After Effects можно анимировать все изображение Photoshop или любой из его слоев. Можно даже анимировать отдельные свойства изображений Photoshop, например свойства стиля слоя. При использовании After Effects для создания фильмов можно использовать Photoshop для обработки отдельных кадров.

Сравнительные преимущества для определенных задач

Достоинства After Effects заключаются в ее функциях анимации и автоматизации. Это означает, что в After Effects лучше всего выполнять задачи, которые могут быть автоматизированы от кадра к кадру. Например, можно использовать функции трассировки движения After Effects для отслеживания движения микрофонной стойки, а затем автоматически применить это же движение к обводке, выполненной с помощью инструмента «Штамп». Таким образом можно удалить микрофон из каждого кадра съемки, и вам не придется обрисовывать микрофон вручную в каждом кадре.

С другой стороны, в Photoshop имеются великолепные инструменты для заливки и рисования.

Выбор приложения зависит от задачи. Обводки заливки в Photoshop непосредственно влияют на пиксели слоя. Обводки заливки в After Effects являются элементами эффекта, каждый из которых можно включать и отключать или изменять в любой момент. Если хотите полностью контролировать каждую обводку заливки после ее создания, или если хотите анимировать сами обводки заливки, используйте инструменты заливки After Effects. Если целью применения обводки заливки является окончательное изменение неподвижного изображения, используйте инструменты заливки Photoshop. При создании вручную нескольких обводок для устранения пыли рекомендуется использовать инструменты рисования Photoshop.

Функции анимации и видео в Photoshop включают простую анимацию на основе ключевых кадров. After Effects использует похожий интерфейс, но имеет гораздо больше разнообразных функций анимации.

After Effects может также автоматически создавать трехмерные слои для имитации плоскостей, созданных функцией «Перспектива» Photoshop.

Обмен неподвижными изображениями

After Effects может импортировать и экспортировать неподвижные изображения во многих форматах, но обычно рекомендуется использовать собственный формат Photoshop PSD при передаче отдельных кадров или наборов неподвижных изображений между After Effects и Photoshop.

При импорте или экспорте файла PSD After Effects может сохранять отдельные слои, маски, стили слоев, и большинство других атрибутов. При импорте файла PSD в After Effects можно указать, будет ли он импортирован как сведенное изображение или как композиция с отдельными слоями без изменений.

Часто имеет смысл подготовить неподвижное изображение в Photoshop перед импортом в After Effects. Такая подготовка может включать коррекцию цвета, масштабирование и кадрирование. Часто лучше изменить исходное изображение в Photoshop, чем выполнять одну и ту же операцию много раз в секунду в рамках рендеринга каждого кадра для предпросмотра или окончательного вывода в приложении After Effects.

Создав свой новый документ PSD в диалоговом окне Новый файл Photoshop с шаблоном настроек Фильм и видео, вы можете начать работу с документом, правильно настроенным для определенного типа вывода видео. Если вы уже работаете в After Effects, можете создать новый документ PSD, соответствующий вашим настройкам композиции и проекта, выбрав «Файл» > Создать» > «Файл Adobe Photoshop».

Обмен фильмами

Также можно перемещать видеофайлы, например ролики QuickTime, между Photoshop и After Effects. При открытии фильма в Photoshop создается слой видео, который ссылается на файл исходного видеоряда. Слои видео позволяют рисовать на кадрах видеоряда не затрагивая оригинал аналогично тому, как After Effects работает со слоями, используя фильмы как их источники. При сохранении файла Photoshop со слоем видео сохраняются изменения, внесенные в слой видео, но не изменения в самом видеоряде.

Вы также можете делать рендеринг фильма непосредственно в Photoshop. Например, можно создать фильм QuickTime в Photoshop, а затем импортировать его в After Effects.

Цвет

На внутреннем уровне After Effects работает с цветами в цветовом пространстве RGB (красный, зеленый, синий). Хотя After Effects может преобразовывать изображения CMYK в RGB, работу с видео и анимацией в Photoshop следует делать в RGB.

Если это важно для вашего конечного результата, лучше проверить, что цвета в вашем изображении нормально отображаются в Photoshop перед импортом изображения в After Effects. Это можно сделать, присвоив соответствующее конечное цветовое пространство, например, SDTV (Rec. 601) в документе Photoshop. After Effects выполняет управление цветом в соответствии с цветовыми профилями, встроенными в документы, включая импортированные файлы PSD.

Работа с Animate CC и After Effects

Если для создания видео или анимации используется Adobe Animate (прежнее название Flash Professional), то After Effects можно использовать для их редактирования и улучшения. Например, из Adobe Animate можно экспортировать анимации и приложения как фильмы QuickTime, .mp4 и в других стандартных видеоформатах. После этого можно воспользоваться приложением After Effects для редактирования видео и улучшения его качества.

При использовании After Effects для редактирования и монтажа видео можно затем опубликовать это видео с помощью приложения Animate.

В программах Animate и After Effects используются разные термины для одних и тех же понятий. В следующей таблице приведен список различий в терминах двух программ.

After Effects Анимировать
Композиция Фрагмент ролика
Рамка композиции (панель «Композиция») Монт. стол
Панель «Проект» Панель «Библиотека»
Файлы проекта Файлы FLA
Рендеринг и экспорт фильма Публикация файла SWF

Дополнительные ресурсы

В следующих статьях можно найти дополнительную информацию о совместном использовании Animate и After Effects:

  • Ричард Харрингтон (Richard Harrington) и Маркус Гедульд (Marcus Geduld) представляют «Основы Flash для пользователей After Effects» — выдержку из своей книги After Effects for Flash | Flash for After Effects на веб-сайте Peachpit. В этой главе Ричард и Маркус объясняют Animate в терминах, которые будут понятны пользователю After Effects. http://www.peachpit.com/articles/article.aspx?p=1350895

  • Ричард Харрингтон (Richard Harrington) и Маркус Гедульд (Marcus Geduld) представляют «Основы After Effects для пользователей Flash» — выдержку из своей книги After Effects for Flash | Flash for After Effects. В этой главе Ричард и Маркус объясняют After Effects в терминах, которые будут понятны пользователю Animate. http://www.peachpit.com/articles/article.aspx?p=1350894

  • На веб-сайте Slippery Rock NYC Роберт Пауэрс (Robert Powers) дает видеоинструкцию об основах использования программы After Effects для тех, кто знаком с работой в программе Animate.

Экспорт видео в формате QuickTime из приложения Animate

При создании анимации и приложений в приложении Animate можно экспортировать их в виде фильмов QuickTime с помощью команды «Файл» > Экспорт > «Экспортировать фильм». Для анимации Animate можно выбрать оптимальный формат видеовывода. В приложении Animate видео формируется в процессе работы приложения, позволяя пользователю управлять им. Это дает возможность зафиксировать ветви или состояния приложения, которые необходимо включить в видеофайл.

Импорт и публикация видео в приложении Animate

При импорте файла видеофильма в приложение Animate для управления визуальным интерфейсом, сопровождающим видео, можно использовать различные методы, например сценарии и компоненты Animate. Например, к видео можно приложить элементы управления воспроизведением и другие графические элементы. Также для создания композиции можно добавить графические слои поверх фильма.

Композитинг графики, анимации и видео

Как Animate, так и After Effects включают множество возможностей, позволяющих производить сложный композитинг видео и графики. Выбор приложения зависит от личных предпочтений и типа вывода, который должен быть создан в результате.

Приложение Animate в большей степени ориентировано на создание веб-содержимого, поскольку создает файлы небольшого размера. Кроме того, Animate позволяет управлять анимацией в реальном времени. Приложение After Effects ориентировано на производство видео и фильмов, предлагает широкий спектр визуальных эффектов и обычно используется для создания видеофайлов.

Оба приложения могут применяться для создания оригинальных изображений и анимации. Оба используют таймлайн и поддерживают создание сценариев для программного управления анимацией. After Effects содержит больше эффектов.

Оба приложения позволяют размещать графику и эффекты в разных слоях для последующего композитинга. Эти слои можно включать и выключать по необходимости. Оба приложения позволяют применять эффекты к содержанию отдельных слоев.

В приложении Animate композитинг не воздействует на видеосодержимое непосредственно; оно оказывает влияние на видео лишь во время воспроизведения в приложении Flash Player. Напротив, при композитинге импортированного видео в приложении After Effects экспортируемый видеофайл действительно включает все объединенные графические объекты и эффекты.

Поскольку все операции рисования в After Effects выполняются на слоях, отдельных от слоя импортированного видео, все изменения являются обратимыми. Animate поддерживает режимы рисования с обратимыми и необратимыми изменениями.

 

Импорт файлов SWF в приложение After Effects

Приложение Animate обладает уникальным набором инструментов векторной графики, позволяющим создавать разнообразные объекты, которые невозможно создать с помощью After Effects или Adobe® Illustrator®. Файлы SWF можно импортировать в приложение After Effects для композитинга с другим видео или создания видео с дополнительными творческими эффектами посредством рендеринга. Интерактивное содержимое и анимация со сценариями не сохраняются. Сохраняется анимация, определенная ключевыми кадрами.

Все файлы SWF, импортируемые в After Effects, сводятся в единый слой с постоянным растрированием и сохранением альфа-канала. Постоянное растрирование позволяет сохранить четкость графического объекта после его увеличения. Этот метод импорта позволяет использовать корневой слой или объект файлов SWF в качестве элемента с гладким рендерингом в приложении After Effects, что позволяет наилучшим образом использовать возможности обеих программ.

Импорт FLA-файлов в After Effects

FLA-файлы Animate можно импортировать в After Effects как композицию многоуровневых файлов .swf. Их можно комбинировать с видео или визуализировать как видео с дополнительными творческими эффектами.

Для использования этой функциональной возможности на том же компьютере должна быть установлена версия Animate 19.0.

При импорте документа Animate в After Effects отдельные слои экспортируются приложением Animate как файлы .swf, которые добавляются в композицию. Во время импорта укажите в диалоговом окне Импорт установок расположение импортированных файлов.

Если установлен флажок «Импортировать аудио», слои аудио экспортируются приложением Animate как файлы .wav.

Примечание.

Поддерживаются только документы ActionScript 3.0. Чтобы преобразовать документ HTML5 Canvas или WebGL в ActionScript 3.0, откройте его в Animate и выберите Файл > Преобразовать в > ActionScript 3.0.

Работа с Adobe XD и After Effects

Слои и монтажные области можно экспортировать из Adobe XD в проект After Effects. Эта функциональная улучшает передачу ресурсов между XD и After Effects со встроенным сопоставлением слоев, монтажных областей, векторов, текста и графических объектов. Проектировщикам Adobe XD может отправлять в After Effects группы слоев и определять расширенные микровзаимодействия или монтажные области для создания сложных и уточненных переходов и взаимодействий. Если на вашем компьютере не установлена программа After Effects, то вариант After Effects в меню XD будет неактивен.

Чтобы экспортировать ресурсы для проектирования из XD в After Effects, выполните указанные ниже действия.

  1. В XD выделите слой или монтажную область, которые требуется анимировать в After Effects.

  2. Выберите Файл> Экспорт > After Effects. Приложение After Effects запускается (если было закрыто) или переходит на передний план (если было открыто в фоновом режиме).

  3. В новой композиции слои и монтажные области добавляются в проект After Effects как собственные фигуры, тексты, ресурсы и вложенные композиции.

Список поддерживаемых элементов XD

After Effects поддерживает следующие элементы XD:

  • Векторные фигуры
  • Контуры
  • Текстовые слои
  • Растровые изображения
  • Маски
  • Группы
  • Монтажные области
  • Символы
  • Логические операции
  • Обводки
  • Заливка
  • Тени
  • Непрозрачность
  • Размытие объекта
  • Размытие и яркость фона
  • Градиенты как изображения
  • Повторные масштабные сетки

Работа с программами Adobe Premiere Pro и After Effects

Adobe Premiere Pro предназначен для захвата, импорта и редактирования фильмов. After Effects предназначен для создания графики движения, применения визуальных эффектов, составления визуальных элементов, выполнения цветокоррекции и других задач обработки фильмов.

Вы легко можете перемещать проекты, композиции, эпизоды, дорожки и слои между After Effects и Adobe Premiere Pro:

Если у вас есть Adobe Premiere Pro, вы можете делать следующее.

  • С помощью Adobe Dynamic Link можно работать с композициями After Effects в Adobe Premiere Pro. Динамически подключенная композиция отображается в Adobe Premiere Pro как клип.
  • С помощью Adobe Dynamic Link можно работать с эпизодами Adobe Premiere Pro в After Effects. Динамически связанный эпизод отображается в After Effects как элемент видеоряда.
  • Запустите After Effects из Premiere Pro и создайте новую композицию с настройками, соответствующими настройкам проекта Premiere Pro.
  • Выберите набор клипов в Adobe Premiere Pro и преобразуйте их в композицию After Effects.

Дополнительные сведения об использовании Dynamic Link совместно с After Effects и Premiere Pro см. в разделе Dynamic Link и After Effects и в разделах Dynamic Link справки Adobe Premiere Pro.

Работа с программами Adobe Media Encoder и After Effects

Adobe Media Encoder можно использовать для экспорта видео из After Effects. Adobe Media Encoder используется для таких форматов, как H.264, MPEG-2 и WMV. Другие форматы доступны в Adobe Media Encoder, но недоступны в After Effects. Например, формат DNxHD доступен в Adobe Media Encoder, но недоступен в After Effects.

При добавлении файлов проекта After Effects в папку отслеживания Adobe Media Encoder композиция автоматически будет добавляться в очередь кодирования Adobe Media Encoder. Подробные сведения см. в разделе Импорт файлов с помощью папок отслеживания справки Adobe Media Encoder.

Сведения об использовании Adobe Media Encoder с After Effects см. в разделе Adobe Media Encoder.

См. этот урок урокчтобы научиться экспортировать композиции After Effects с помощью Adobe Media Encoder.

Редактировать в Adobe Audition

При работе в After Effects, можно воспользоваться широкими возможностями редактора аудио Adobe Audition для редактирования звука. Можно использовать команду «Редактировать в Adobe Audition», чтобы запустить Adobe Audition из After Effects.

При редактировании аудиофайла (например, файла в формате WAV) в Adobe Audition можно изменить исходный файл. При редактировании слоя, который содержит и аудио, и видео (например, файл AVI), редактируется копия исходного аудиофайла.

  1. Выберите слой, содержащий аудио для редактирования. Тип элемента должен быть таким, чтобы его можно было редактировать в Adobe Audition.

  2. Выберите «Правка» > «Редактировать в Adobe Audition», чтобы открыть клип в режиме редактирования в Adobe Audition.

  3. Отредактируйте файл и выполните одно из предложенных ниже действий.

    • При редактировании только слоя аудио, выберите «Файл» > «Сохранить», чтобы применить изменения к исходному аудиофайлу. Можно также выбрать «Файл» > «Сохранить как», чтобы применить изменения к копии аудиофайла. При выборе «Файл» > «Сохранить как» импортируйте копию файла в After Effects.

    • При редактировании слоя, который содержит аудио и видео, выберите «Файл» > «Сохранить как». После сохранения файла, импортируйте его в After Effects. Затем добавьте его к композиции и отключите исходное аудио в клипе, убрав флажок с параметра аудио на панели Таймлайн.

    Примечание.

    Никакие эффекты, примененные к аудио в After Effects, не включаются в копию, передаваемую в Adobe Audition.

Информацию по использованию Adobe Audition для работы с аудио из After Effects см. в публикации блога After Effects Region of Interest.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет