Сведения об импортированных файлах и элементах видеоряда

На основе импортированных в проект исходных файлов создаются элементы видеоряда, которые используются в качестве источников слоев. Один и тот же файл может служить источником для нескольких элементов видеоряда, каждый из которых имеет собственные настройки интерпретации. Каждый элемент видеоряда можно использовать в качестве источника для одного или нескольких слоев. Работа связана с наборами слоев в композиции.

В основном работа с элементами видеоряда ведется на панели «Проект». Для анализа видеоряда и выполнения несложных операций редактирования, таких как усечение продолжительности элемента видеоряда, можно использовать панель «Видеоряд».

В качестве источников отдельных элементов видеоряда можно импортировать множество различных типов файлов, наборы файлов или компонентов файлов, включая файлы видеоизображений, файлы неподвижных изображений, наборы неподвижных изображений и файлы аудио. Используя средства After Effects можно даже создавать собственные элементы видеоряда, такие как сплошные заливки и предварительные композиции. Элементы видеоряда можно импортировать в проект в любое время.

При импорте файлов After Effects не копирует данные изображений в проект, но создает ссылку на источник элемента видеоряда. Это обеспечивает сравнительно небольшой размер файлов проекта.

При удалении, переименовании или перемещении импортируемого исходного файла, ссылка теряет связь с файлом. Если ссылка недействительна, имя исходного файла отображается на панели «Проект» курсивом, а в столбце «Путь к файлу» сообщается об ее отсутствии. Если элемент видеоряда доступен, ссылку можно восстановить. Обычно для этого достаточно два раза щелкнуть по элементу и заново выбрать файл.

Примечание.

Можно найти элементы видеоряда с отсутствующими источниками, введя слово «отсутствует» в поле поиска на панели «Проект». См. раздел Поиск и фильтрация на панелях «Таймлайн», «Проект» и «Эффекты и шаблоны».

Чтобы уменьшить время рендеринга и увеличить производительность, рекомендуется подготовить видеоряд перед импортом в After Effects. Например, очень часто неподвижное изображение проще масштабировать и обрезать в Photoshop, а затем импортировать в After Effects. Предпочтительней один раз выполнить операцию в Photoshop, чем заставлять After Effects выполнять ее для каждого кадра с изображением со скоростью несколько раз в секунду.

Для экономии времени и уменьшения размера и сложности проекта следует импортировать источник в виде отдельного элемента видеоряда, а затем использовать его в композиции необходимое число раз. В редких случаях целесообразно продублировать элемент видеоряда и обработать их независимо друг от друга. Например, можно использовать один и тот же видеоряд, задав два разных значения частоты смены кадров.

Если при изменении элемента видеоряда используется другое приложение, изменения вступят в силу при следующем открытии проекта в After Effects. Можете также выделить элемент видеоряда и выбрать команду «Файл» > «Перезагрузить видеоряд».

Примечание.

Чтобы заменить исходный элемент видеоряда другим элементом, при этом не повлияв на изменения свойств слоя, выделите слой, а затем, удерживая клавишу ALT (Windows) или OPTION (Mac OS), перетащите новый элемент видеоряда в данный слой на панели «Таймлайн».

Примечание.

Чтобы заменить все варианты выделенных элементов видеоряда другим элементом видеоряда, выделите эти элементы на панели «Проект», а затем, удерживая клавишу ALT (Windows) или OPTION (Mac OS), перетащите новый элемент видеоряда на один из выделенных элементов на панели «Проект».

Когда приложение After Effects импортирует видео- и аудиофайлы в некоторых форматах, оно обрабатывает и кэширует версии этих элементов для быстрого доступа к ним при создании предпросмотров. Кэширование значительно повышает производительность для предпросмотров, так как позволяет не выполнять повторную обработку элементов видео и аудио для каждого предпросмотра. 

Дополнительные сведения об импортировании ресурсов см. в видеопособии Эндрю Дэвиса (Andrew Devis) на веб-сайте Creative COW.

Встроенные средства кодирования и декодирования файлов QuickTime

After Effects имеет встроенные средства для кодирования и декодирования файлов QuickTime (.mov) с использованием кодеков GoPro CineForm в Mac OS и Windows. Это означает, что у пользователя нет необходимости устанавливать дополнительные кодеки для создания и использования таких файлов.

В After Effects имеется встроенная поддержка импорта в MOV для следующих форматов без сжатия:

  • DV, IMX, MPEG2, XDCAM, h264, JPEG, Avid DNxHD, Avid DNxHR, Apple ProRes, AVCI и GoPro CineForm

Встроенная поддержка экспорта доступна для следующих форматов без сжатия:

  • Avid DNxHD, Avid DNxHR, DV и GoPro CineForm

Примечание.

Поскольку After Effects имеет встроенные средства импорта и экспорта с поддержкой большого количества кодеков (перечисленных выше), установка QuickTime в ОС Windows не требуется. Дополнительные сведения о совместимости см. в публикации блога QuickTime в ОС Windows

Поддерживаемые форматы импорта

Некоторые расширения файлов, такие как MOV, AVI, MXF, FLV и F4V, обозначают контейнер-форматы, а не отдельные форматы аудио, видео или изображений. Контейнер-файлы могут содержать данные, закодированные при помощи различных схем сжатия и кодирования. After Effects может импортировать такие контейнер-файлы, но возможность импорта данных, которые в них содержатся, зависит от установленных кодеков (а конкретно, декодеров).

Устанавливая дополнительные кодеки, можно расширить возможности After Effects по импорту дополнительных типов файлов. Многие кодеки установлены в составе операционной системы (Windows или Mac OS) и функционируют в качестве компонентов форматов QuickTime или Video for Windows. Для получения дополнительных сведений о кодеках, поддерживающих файлы, созданные на конкретных устройствах или в конкретных приложениях, обращайтесь к производителю оборудования или ПО.

Для импорта и использования некоторых файлов требуется установка дополнительных подключаемых модулей. (См. раздел Подключаемые модули.)

Приложение Adobe Premiere Pro способно захватывать и импортировать множество форматов, которые After Effects не может импортировать своими средствами. Данные из Adobe Premiere Pro можно переносить в After Effects различными способами. (См. раздел Работа с приложениями Adobe Premiere Pro и After Effects.)

Форматы аудио

  • Adobe Sound Document (ASND; многодорожечные файлы, импортированные как одна объединенная дорожка)

  • Advanced Audio Coding (AAC, M4A)

  • Audio Interchange File Format (AIF, AIFF)

  • MP3 (MP3, MPEG, MPG, MPA, MPE)

  • Video for Windows (AVI; в Mac OS требуется QuickTime)

  • Waveform (WAV)

Форматы неподвижных изображений

  • Adobe Illustrator (AI, AI4, AI5, EPS, PS; непрерывная растеризация)
  • Adobe PDF (PDF; только первая страница; непрерывная растеризация)
  • Adobe Photoshop (PSD)
  • Растровое (BMP, RLE, DIB)
  • Camera Raw (TIF, CRW, NEF, RAF, ORF, MRW, DCR, MOS, RAW, PEF, SRF, DNG, X3F, CR2, ERF)
  • Cineon/DPX (CIN, DPX с 8-, 10-, 12- и 16 битами на канал, включая файлы с альфа-каналом и тайм-кода)
  • Discreet RLA/RPF (RLA, RPF; 16бит на канал; импортирует данные камеры)
  • EPS
  • GIF
  • JPEG (JPG, JPE)
  • Данные камеры Maya (MA)
  • Maya IFF (IFF, TDI; 16бит на канал)
  • OpenEXR (EXR, SXR, MXR; 32бит на канал)
  • PICT (PCT)
  • Portable Network Graphics (PNG; 16 бит на канал)
  • Radiance (HDR, RGBE, XYZE; 32 бит на канал)
  • SGI (SGI, BW, RGB; 16 бит на канал)
  • Softimage (PIC)

Примечание.

В After Effects входят подключаемые модули эффекта «Канал 3D» из программного обеспечения fnord, обеспечивающие доступ к нескольким слоям и каналам файлов OpenEXR. (См. раздел Использование каналов в файлах OpenEXR.)

Примечание.

After Effects может читать файлы ZPIC, относящиеся к импортированным файлам PIC. См. раздел Импорт и использование файлов с данными в формате 3D из других приложений.)

  • Targa (TGA, VDA, ICB, VST)

  • TIFF (TIF)

Примечание.

Импортировать файлы неподвижных изображений любого формата также можно в виде набора. См. раздел Подготовка и импорт неподвижных изображений.

Форматы видео и анимации

  • Анимированный GIF (GIF)
  • Avid DNxHR
  • HEVC (H.265) MPEG-4
  • Поддержка файлов ARRIRAW, полученных с камер ARRI ALEXA или ARRIFLEX D-21
    Дополнительные сведения о файлах ARRIRAW см. в разделе часто задаваемых вопросов о ARRIRAW на веб-сайте группы ARRI.
  • CinemaDNG

Примечание. CinemaDNG входит в подмножество Camera Raw. Доступ к подклассу Camera Raw возможен через меню «Дополнительные параметры» диалогового окна «Интерпретировать видеоряд». Система управления цветом для CinemaDNG включает те же цветовые пространства, что и Camera Raw в After Effects: Adobe RGB, sRGB IEC619662.1, ColorMatch RGB и ProPhoto RGB.

  • DV (в контейнер-формате MOV или AVI или в качестве «бесконтейнерного» DV-потока)
  • Electric Image (IMG, EI)
  • FLV, F4V
  • QuickTime (MOV; 16бит на канал, только для кодеков, для которых нет встроенных декодеров)
  • Video for Windows (AVI, WAV; в Mac OS требуется QuickTime)

  • Файл Windows Media (WMV, WMA, ASF; только в ОС Windows)

  • XDCAM HD и XDCAM EX

  • RED (R3D)
  • Media eXchange Format (MXF)

MXF представляет собой контейнер-формат. В After Effects имеется возможность импорта только некоторых видов данных, содержащихся в файлах MXF. After Effects может импортировать файлы MXF Op-Atom, используемые видеокамерами Panasonic для записи на носители Panasonic P2. After Effects может импортировать видео из таких MXF-файлов, используя HD-кодеки AVC-Intra 50, AVC-Intra 100, DV, DVCPRO, DVCPRO50 и DVCPRO. After Effects может также импортировать файлы XDCAM HD в формате MXF, формате MXF OP1, который содержит видео MPEG-2, совместимое с форматом XDCAM HD.

  • Форматы MPEG-1, MPEG-2 и MPEG-4: MPEG, MPE, MPG, M2V, MPA, MP2, M2A, MPV, M2P, M2T, M2TS (AVCHD), MP4, M4V, M4A
  • SWF (непрерывная растеризация)

Форматы проектов

  • Adobe Premiere Pro 1.0, 1.5, 2.0, CS3, CS4, CS5, CS6 и CC (PRPROJ; 1.0, 1.5 и 2.0 только для Windows) и проекты более поздних версий

  • Adobe After Effects 6.0 и более поздние двоичные проекты в After Effects CS5 (AEP, AET)

  • After Effects 7 может открывать проекты After Effects версий 3.0–7.

  • Adobe After Effects CS4 и XML-проекты более поздних версий (AEPX)

Подключаемый модуль Automatic Duck Pro Import AE теперь входит в пакет приложения и называется Pro Import After Effects. С его помощью можно импортировать файлы AAF и OMF из системы Avid, файлы XML из Final Cut Pro 7 или более ранних версий и файлы проектов Motion 4 или более ранних версий. Подробные сведения об использовании Pro Import After Effects см. в руководстве пользователя. Для этого выберите «Файл» > «Импорт» > «Pro Import After Effects» и нажмите кнопку «Справка».

Можно также импортировать проекты Final Cut Pro в Premiere Pro, а затем оттуда переносить в After Effects.


Примечание.

 

  • After Effects может читать файлы EIZ, относящиеся к импортированным файлам EI. См. раздел Импорт и использование файлов с данными в формате 3D из других приложений.)
  • Некоторые форматы данных MPEG хранятся в контейнер-форматах с расширениями файлов, которые не распознаются After Effects, например .vob и .mod. В некоторых случаях можно импортировать эти файлы в After Effects после изменения расширения файла на расширение, которое распознается программой. Из-за разницы в исполнении данных контейнер-форматов совместимость не гарантирована.
  • Дополнительные сведения о форматах MPEG можно найти на на веб-сайте MPEG и в статье, посвященной MPEG, на веб-сайте Википедии.
  • Перед началом работы с QuickTime прочитайте предупреждение, изданное Группой быстрого реагирования на компьютерные инциденты США в апреле 2016 года, которое рекомендует пользователям Windows удалить Apple QuickTime со своих компьютеров.
  • Файлы R3D воспринимаются как файлы, содержащие цвета глубиной 32 бита на канал в цветовом пространстве HDTV (Rec. 709). Параметры цветокоррекций в исходных настройках RED R3D не сохраняют значения сверхъяркости. Цветокоррекция, применяемая в After Effects, позволяет сохранять сверхъяркие цвета при работе в режиме 32 бита на канал. Во избежание обтравки рекомендуется настраивать экспозицию в After Effects, а не во время интерпретации видеоряда в диалоговом окне «Исходные настройки RED R3D».
  • After Effects может импортировать ресурсы Sony XDCAM HD, если они были записаны в файлы MXF. After Effects не может импортировать ресурсы XDCAM HD IMX в формат IMX. After Effects может импортировать ресурсы Sony XDCAM EX, хранящиеся в виде базовых файлов с расширением .mp4 в каталоге BPAV. Дополнительные сведения о формате XDCAM можно найти в документе PDF на веб-сайте компании Sony.
  • Файлы SWF импортируется с альфа-каналом. Аудио не сохраняется. Интерактивное содержимое и анимация со сценариями не сохраняются. Сохраняется анимация, определяемая ключевыми кадрами в основном фрагменте верхнего уровня.

Импорт элементов видеоряда

Можно импортировать в проект файлы мультимедиа с помощью диалогового окна «Импорт» или перетаскивания объектов. Импортированные элементы видеоряда отображаются на панели «Проект».

Если диалоговое окно «Интерпретировать видеоряд» появляется после импорта элемента видеоряда, значит там содержится непомеченный альфа-канал и необходимо выбрать метод интерпретации альфа-канала или щелкнуть кнопку «Предположение», позволяющую After Effects самостоятельно определять способ интерпретации альфа-канала. (См. раздел Интерпретация альфа-канала: в прямом или обратном порядке.)

Импорт элементов видеоряда с помощью диалогового окна «Импорт»

  1. Выберите «Файл» > «Импорт» > «Файл», выберите «Файл» > «Импорт» > «Несколько файлов» или два раза щелкните пустую область панели «Проект».

    При выборе импорта нескольких файлов можно выполнять следующий шаг несколько раз, не прибегая к повторениям команды «Импорт».

    Примечание.

    Чтобы отобразить только поддерживаемые файлы видеоряда (кроме файлов проекта), выберите «Все файлы видеоряда» в меню «Файлы типа» (Windows) или «Включить» (Mac OS).

  2. Выполните одно из следующих действий.
    • Выберите файл и нажмите кнопку «Открыть».

    • Для выделения нескольких файлов щелкните их, удерживая нажатой клавишу CTRL (Windows) или COMMAND (Mac OS), а затем нажмите «Открыть».

    • Для выделения нескольких файлов подряд щелкните один из файлов, а затем, удерживая нажатой клавишу «SHIFT», щелкните последний файл, после чего нажмите «Открыть».

    • (Только в ОС Windows) Выберите всю папку, затем нажмите «Импорт папки».

    Примечание.

    При выборе параметра «Набор» выполняется импорт нескольких файлов из папки в виде набора неподвижных изображений.  

Импорт элементов видеоряда перетаскиванием

Примечание.

При необходимости импортировать многослойные файлы неподвижных изображений, перетаскиваемых в After Effects, в виде композиции, выберите «Правка» > «Установки» > «Импорт» (Windows) или «After Effects» > «Установки» >«Импорт» (Mac OS), а затем в меню «Перетащить несколько элементов импорта как» выберите пункт «Композиция» или «Композиция — сохранить размеры слоев». (См. раздел Импорт набора изображений в виде композиции.)

  • Чтобы импортировать один файл, перетащите его на панель «Проект» из Проводника (Windows) или Finder (Mac OS).
  • Чтобы импортировать содержимое папки в виде набора неподвижных изображений, представленных на панели «Проект» как один элемент видеоряда, перетащите в панель «Проект» папку из проводника (Windows) или Finder (Mac OS).
  • Чтобы импортировать содержимое папки в виде отдельных элементов видеоряда, отображаемых на панели «Проект» внутри папки, перетащите папку на панель «Проект» из проводника (Windows), удерживая нажатой клавишу ALT, или из Finder (Mac OS), удерживая нажатой клавишу OPTION.
  • Чтобы импортировать полученный в результате рендеринга файл из панели «Очередь рендеринга», перетащите соответствующий модуль вывода с этой панели на панель «Проект».

Примечание.

При перетаскивании модуля вывода с панели «Очередь рендеринга» на панель «Проект» до процедуры рендеринга After Effects создает элемент видеоряда, выполняющий функцию заполнителя. Ссылки на заполнитель видеоряда автоматически заменяются после рендеринга модуля вывода, при этом замены самого заполнителя не происходит.

Интерпретация элементов видеоряда

Для интерпретации импортируемых элементов видеоряда на основе расчетов пропорций пиксела, частоты кадров, цветового профиля и типа альфа-канала в After Effects используется набор внутренних правил. Если расчеты After Effects оказываются неверными или видеоряд будет использоваться в иных целях, эти правила можно изменить применительно ко всем элементам видеоряда определенного типа, отредактировав файл правил интерпретации (interpretation rules.txt). Можно изменить интерпретацию отдельного элемента видеоряда с помощью диалогового окна «Интерпретировать видеоряд».

Параметры интерпретации сообщают After Effects определенные сведения о каждом элементе видеоряда.

Примечание.

Вся эта информация используется для принятия решения о том, как интерпретировать данные, содержащиеся в импортируемом элементе видеоряда, и для ввода в After Effects данных о видеоряде. Параметры интерпретации в диалоговом окне «Интерпретировать видеоряд» должны соответствовать параметрам, использованным при создании исходного файла видеоряда. Не используйте параметры интерпретации, чтобы задать параметры для конечного продукта рендеринга.

Как правило, настройки интерпретации не требуют изменений. Однако для интерпретации нестандартного элемента видеоряда программе After Effects может потребоваться дополнительная информация.

Чтобы передать After Effects данные о том, как интерпретировать информацию о цвете элемента видеоряда, можно использовать элементы управления в разделе «Управление цветом». Этот шаг обычно требуется только тогда, когда в элементе видеоряда отсутствует встроенный цветовой профиль.

При использовании функции предпросмотра на панели «Видеоряд» можно просматривать результаты операций по интерпретации видеоряда.

На своем веб-сайте redefinery Джефф Алмасол (Jeff Almasol) предлагает сценарий расчета преобразований 3:2 или 24Pa, или интерпретации альфа-канала.

Примечание.

В диалоговом окне «Интерпретировать видеоряд» выберите «Предпросмотр», что позволит перед принятием изменений отобразить параметры, заданные в диалоговом окне.

Интерпретация отдельного элемента видеоряда с помощью диалогового окна «Интерпретировать видеоряд»

  1. На панели «Проект» выберите элемент видеоряда и выполните одно из следующих действий.
    • В нижней части панели «Проект» нажмите кнопку «Интерпретировать видеоряд» .

    • Перетащите элемент видеоряда на кнопку «Интерпретировать видеоряд».

    • Выберите «Файл» > «Интерпретировать видеоряд» > «Основной».

    • Нажмите CTRL+ALT+G (Windows) или COMMAND+OPTION+G (Mac OS).

Интерпретация прокси с помощью диалогового окна «Интерпретировать видеоряд»

  1. На панели «Проект» выберите исходный элемент видеоряда и выполните одно из следующих действий.
    • Удерживая нажатой клавишу ALT (Windows) или OPTION (Mac OS), нажмите кнопку «Интерпретировать видеоряд» в нижней части панели «Проект».

    • Удерживая нажатой клавишу ALT (Windows) или OPTION (Mac OS), перетащите элемент видеоряда на кнопку «Интерпретировать видеоряд».

    • Выберите «Файл» > «Интерпретировать видеоряд» > «Прокси».

Применение параметров интерпретации видеоряда к нескольким элементам

Чтобы различные элементы видеоряда использовали одинаковые настройки, скопируйте настройки одного элемента и примените их к другим.

  1. На панели «Проект» выберите элемент с необходимыми настройками интерпретации.
  2. Выберите «Файл» > «Интерпретировать видеоряд» > «Запомнить интерпретацию».
  3. Выберите один или несколько элементов видеоряда на панели «Проект».
  4. Выберите «Файл» > «Интерпретировать видеоряд» > «Применить интерпретацию».

Изменение правил интерпретации для всех элементов указанного типа

Файл правил интерпретации содержит правила, определяющие, каким образом After Effects будет интерпретировать элементы видеоряда. В большинстве случаев файл правил интерпретации не требует внесения изменений пользователем. При импорте элемента видеоряда After Effects ищет в файле соответствующие правила, после чего определяет настройки интерпретации для элемента видеоряда. С помощью диалогового окна «Интерпретировать видеоряд» эти настройки можно изменить после импорта.

Обычно файл правил интерпретации носит имя interpretation rules.txt, однако в некоторых обновлениях After Effects устанавливается новый файл интерпретации, в имени которого содержится номер обновленной версии. Обновленное приложение использует именно этот файл. Если в старый файл правил интерпретации были внесены изменения, может потребоваться применить их также к новому файлу.

Местоположения файла правил интерпретации After Effects CC:

  • (Windows) <диск>\Users\<имя_пользователя>\AppData\Roaming\Adobe\After Effects\15.1>
  • (Mac OS) <диск>/Users/<имя_пользователя>/Library/Preferences/Adobe/After Effects/15.1>

Местоположения файла правил интерпретации After Effects CC предыдущих версий:

  • (Windows) <диск>\Users\<имя_пользователя>\AppData\Roaming\Adobe\After Effects\14.x>
  • (Mac OS) <диск>/Users/<имя_пользователя>/Library/Preferences/Adobe/After Effects/14.x>
  1. Закройте приложение After Effects.
  2. В целях предосторожности создайте резервную копию файла правил интерпретации. По умолчанию этот файл размещается в том же местоположении, что и приложение After Effects.
  3. Откройте файл правил интерпретации в любом текстовом редакторе.
  4. Измените настройки в соответствии с инструкциями файла.

    Примечание.

    Для каждого типа видеоряда или кодека необходимо задать код типа файла из четырех символов. Если вы не знаете код для файла или кодека в проекте, во время выбора файла на панели «Проект» нажмите клавишу ALT (Windows) или OPTION (Mac OS). Код типа файла или код кодека (если файл сжат) отображаются в последней строке описания файла в верхней части панели «Проект».

  5. Сохраните файл interpretation rules.txt.

Интерпретация альфа-канала: умноженная в обратном порядке или прямая

Файлы изображений с альфа-каналами хранят информацию о прозрачности, используя один из двух способов: прямая интерпретация и интерпретация, умноженная в обратном порядке. Хотя альфа-каналы одинаковы, цветовые каналы отличаются.

Для прямых (или без подложки) каналов информация о прозрачности хранится только в альфа-канале, и ни в одном из видимых цветовых каналов. В случае прямых каналов результаты прозрачности не показываются, пока изображение не будет выведено на экран в приложении, поддерживающем прямые каналы.

Для предварительно умноженных (или с подложкой) каналов информация о прозрачности хранится не только в альфа-канале, но и в видимых каналах RGB, которые умножаются на цвет фона. Умноженные в обратном порядке каналы иногда называют каналами с цветовой подложкой. Цвета полупрозрачных областей, таких как растушеванные края, смещены к цвету фона пропорционально их степени прозрачности.

Некоторые программы позволяет указать цвет фона, на который будут предварительно умножены каналы. В противном случае цвет фона обычно является черным или белым.

Прямые каналы хранят более точную информацию о цвете, чем предварительно умноженные каналы. Предварительно умноженные каналы совместимы с большим количеством программ, например, с проигрывателем Apple QuickTime Player. Часто выбор, использовать ли изображения с прямыми или предварительно умноженными каналами, уже сделан до предоставления ресурсов для редактирования и совмещения. Adobe Premiere Pro и After Effects распознают и прямые, и предварительно умноженные каналы, но только первый найденный альфа-канал, если обрабатываемый файл содержит несколько альфа-каналов.

Правильная настройка интерпретации альфа-канала может избавить от проблем при импорте файла, например появления нежелательных цветов по краям изображения или снижения качества изображения по краям альфа-канала. Например, если каналы интерпретируются как обычные, хотя в действительности являются умноженными в обратном порядке, в полупрозрачных областях частично сохраняется цвет фона. При неточной передаче цвета, например возникновении эффекта свечения, и одновременном наличии полупрозрачных краев в композиции попробуйте изменить метод интерпретации.

Предварительно умноженные каналы
В режиме «Обычный режим — без подложки» (внизу слева) элемент с умноженными в обратном порядке каналом (вверху) отображается в виде черного свечения. Если элемент видеоряда интерпретируется как элемент с умножением в обратном порядке и цветовой подложкой, при том, что цвет фона установлен черным, свечения не возникает (внизу справа).

Можно использовать эффект «Удалить обработку краев цветом», позволяющий удалять окантовку полупрозрачных областей слоя путем его отмены умножения.

Настройка интерпретации альфа-канала для элемента видеоряда

  1. На панели «Проект» выберите элемент видеоряда.
  2. Выберите «Файл» > «Интерпретировать видеоряд» > «Основной».
  3. Если требуется поменять непрозрачные и прозрачные области изображения, выберите команду «Обратить альфа-канал».
  4. В разделе «Альфа-канал» выберите метод интерпретации.

    Предположение

    Пытается определить тип каналов, используемых в изображении. Если After Effects не уверен в расчетах, звучит сигнал.

    Пропустить

    Пренебрегает информацией о прозрачности, содержащейся в альфа-канале.

    Обычный режим — без подложки

    Интерпретирует каналы как прямые.

    Умноженный в обратном порядке — с подложкой цвета

    Интерпретирует каналы как умноженные в обратном порядке. Чтобы задать цвет фона, с помощью которого будет осуществляться обратное умножение каналов, используйте инструменты «Пипетка» или «Палитра цветов».

Установка параметров альфа-канала по умолчанию

  1. Выберите «Правка» > «Установки» > «Импорт» (Windows) или «After Effects» > «Установки» > «Импорт» (Mac OS).
  2. Выберите варианты, представленные в меню «Интерпретировать альфа-канал без метки как». Параметры данного меню похожи на параметры диалогового окна «Интерпретировать видеоряд». Параметр «Спрашивать пользователя» означает, что диалоговое окно «Интерпретировать видеоряд» будет открываться при каждом импорте элемента видеоряда с непомеченным альфа-каналом.

Частота кадров

Параметр частоты кадров композиции задает количество кадров, отображаемых в секунду, и принцип распределения времени по кадрам на линейке времени и на табло времени. Другими словами, частота кадров композиции указывает, сколько раз в секунду происходит дискретизация изображений из элементов видеоряда, а также временные границы, на которых можно устанавливать ключевые кадры.

Примечание.

After Effects имеет меню тайм-кода с пропуском кадров или без пропуска кадров, доступное в диалоговом окне «Настройки композиции». В предыдущих выпусках этот параметр входил в общие настройки проекта.

Частота кадров композиции обычно определяется типом конечного продукта. Видео в формате NTSC имеет частоту кадров 29,97 кадр/с, видео в формате PAL — 25 кадр/с, а кинолента — обычно 24 кадр/с. В зависимости от системы вещания, DVD-видео может иметь одинаковую частоту кадров с NTSC- или PAL-видео или частоту кадров 23,976. Мультфильмы и видео, предназначенные для записи на компакт-диск или размещения в сети, обычно имеют частоту кадров от 10 до 15 кадр/с.

Примечание.

При установке частоты кадров композиции, в два раза превышающей этот показатель в конечном продукте, After Effects отображает каждое поле видеоряда с чересстрочной разверткой в виде отдельного кадра на панели композиции. Это позволяет размещать ключевые кадры в конкретных полях и увеличивать точность при анимировании масок.

При окончательном рендеринге фильма у вас есть выбор между частотой кадров композиции или ее другими вариантами. Возможность задать частоту кадров для каждого модуля вывода полезна в случаях, когда одна и та же композиция используется для создания конечного продукта, ориентированного на различные носители.

Поддержка видеоряда с высокой частотой кадров

В выпуске After Effects CC (апрель 2017 года) для поля частоты кадров можно установить любое значение максимум до 999 кадров/с. Обновление позволяет использовать более высокую частоту кадров для рендеринга в отличие от более ранних версий, где максимальная частота кадров, которую можно было установить для композиции, составляла 99 кадров/с.

Каждый элемент движущегося видеоряда в композиции также может иметь собственную частоту кадров. Связь между частотой кадров элемента видеоряда и частотой кадров композиции определяет, насколько ровным будет воспроизведение слоя. Например, если частота кадров элемента видеоряда составляет 30 кадр/с, а частота кадров композиции — 30 кадр/с, то при переходе композиции на один кадр вперед будет отображаться следующий кадр элемента видеоряда. Если частота кадров элемента видеоряда составляет 15 кадр/с, в то время как частота кадров композиции — 30 кадр/с, каждый кадр видеоряда будет отображаться в двух последующих кадрах композиции. (Речь идет о простых случаях, в которых к слою не были применены эффекты растягивания или наложения.)

В идеале, рекомендуется использовать исходный видеоряд, соответствующий частоте кадров конечного продукта. В этом случае After Effects осуществляет рендеринг каждого кадра, в конечном же продукте кадры не будут опускаться, дублироваться или интерполироваться. Однако если исходный материал имеет частоту кадров, которая незначительно отличается от конечной (например, видеоряд с частотой 30 кадр/с при конечной частоте 29,97 кадр/с), можно совместить частоту кадров видеоряда и композиции с помощью операции согласования.

При согласовании частоты кадров элемента видеоряда исходный файл не меняется, а меняется только ссылка, используемая программой After Effects. При согласовании After Effects изменяет внутреннюю продолжительность кадров, в то время как содержимое кадров остается нетронутым. После этого видеоряд воспроизводится с другой скоростью. Например, при согласовании частоты кадров с 15 до 30 кадр/с, скорость воспроизведения видеоряда удвоится. В большинстве случаев согласование используется только тогда, когда разница между частотой кадров видеоряда и конечного продукта незначительна.

Примечание.

В результате согласования может измениться синхронизация видеоряда с аудиодорожкой, так как изменение частоты кадров не влияет на параметры аудио. При растягивании и аудио и видео используйте команду «Растягивание по времени». (См. раздел Растягивание слоя по времени.) Ключевые кадры, примененные к исходному видеоряду, не меняют своего первоначального местоположения (что обеспечивает синхронизацию внутри композиции, но не визуального содержимого слоя). После согласования элемента видеоряда может потребоваться скорректировать размещение ключевых кадров.

Можно изменить частоту кадров в любых фильмах и наборах неподвижных изображений. Например, можно импортировать набор из 10 неподвижных изображений и указать частоту кадров для этого элемента видеоряда 5 кадр/с; в этом случае продолжительность набора в композиции будет составлять две секунды.

Примечание.

При импорте набора неподвижных изображений ему присваивается частота кадров, указанная в установках «Видеоряд набора» в категории «Импорт». Частота кадров по умолчанию составляет 30 кадров в секунду. Можно изменить частоту кадров после импорта или повторного импорта элемента видеоряда. (См. раздел Интерпретация элементов видеоряда.)

Низкая частота кадров создает ощущение нереальности, поэтому при выполнении творческих задач многие пользователи предпочитают работать с более низкой частотой кадров, например 24 кадра в секунду, вместо 29,97 кадра в секунду, принятых в стандартном формате NTSC.

Примечание.

При удалении из видео с чересстрочной разверткой преобразования 3:2, After Effects автоматически устанавливает частоту кадров конечного элемента видеоряда равной 4/5 первоначальной. При удалении из видео в формате NTSC преобразования 3:2, итоговая частота кадров составит 24 кадр/с.

Частота кадров композиции должна соответствовать частоте кадров конечного формата. В большинстве случаев можно просто выбрать шаблон настроек композиции. И наоборот — частоту кадров каждого элемента видеоряда следует устанавливать равной частоте кадров исходного видеоряда.

Советы по согласованию элементов видеоряда с определенной частотой кадров можно найти в статье (PDF) Триш и Криса Мейер (Trish и Chris Meyer) на веб-сайте Artbeats.

Элементы видеоряда: изменение частоты кадров

  1. Выделите элемент видеоряда на панели «Проект».
  2. Выберите «Файл» > «Интерпретировать видеоряд» > «Основной».
  3. Выберите команду «Согласовать с частотой кадров», введите новую частоту кадров для параметра «кадров в секунду» и нажмите «ОК».

Примечание.

Для изменения частоты кадров видеоряда вместо использования команды «Интерпретировать видеоряд» можно растянуть слой во времени с основой в виде элемента видеоряда. Например, для преобразования частоты 30 кадр/с в 29,97 кадр/с следует растянуть слой во времени на 100,1 %. При растягивании во времени меняется скорость воспроизведения как видео, так и аудио. (См. раздел Растягивание слоя по времени.)

Композиция: изменение частоты кадров

  1. Выберите «Композиция» > «Настройки композиции».
  2. Выполните одно из следующих действий.
    • В меню «Шаблон настроек» выберите шаблон настроек композиции.

    • Задайте значение «Частота кадров».

Примечание.

Джефф Алмасол (Jeff Almasol) предлагает на своем веб-сайте redefinery сценарий, который устанавливает частоту кадров и длительность текущей композиции и каждой вложенной в нее.

Пропорции пиксела и пропорции кадра

Пропорции пиксела (PAR) — это соотношение ширины и высоты одного пиксела изображения. кадровая пропорция (пропорция изображения или IAR) — это соотношение ширины кадра изображения и его высоты.

Пропорции кадра
Пропорции кадра 4:3 (слева) и более широкие пропорции кадра 16:9 (справа)

В большинстве компьютерных мониторов используются квадратные пикселы, но во многих форматах видео, включая ITU-R 601 (D1) и DV используются прямоугольные пикселы.

Некоторые форматы видео передают изображение с той же кадровой пропорцией, но в них используются другие пропорции пиксела. Например, конечная выходная кадровая пропорция некоторых цифровых преобразователей NTSC составляет 4:3 с квадратными пикселами (пропорции пиксела 1,0) и размером кадра 640 x 480 пикселов. NTSC D1 на выходе имеет ту же кадровую пропорцию — 4:3 — и неквадратные пикселы (пропорции пиксела 0,91) при размерах кадра 720 x 486 пикселов. Пикселы D1 всегда прямоугольные, ориентированы вертикально в системах, создающих видео NTSC, и горизонтально в системах, создающих видео PAL.

Если без изменений отобразить прямоугольные пикселы на мониторе с квадратными пикселами, изображения и движение будут выглядеть искаженными, например, круги превратятся в овалы. Однако при отображении на видеомониторе изображения будут без искажений. При импорте видеоряда NTSC D1 или DV в After Effects изображение выглядит немного шире, чем в системах D1 или DV. (Видеоряд PAL D1 выглядит слегка уже, чем должно быть.) При импорте анаморфного видеоряда с использованием широкоэкранных видеоформатов D1/DV NTSC или D1/DV PAL происходит обратное. Широкоэкранные видеоформаты имеют кадровые пропорции 16:9.

Примечание.

Чтобы активировать просмотр неквадратных пикселов на мониторе компьютера, нажмите кнопку «Вкл./выкл. коррекцию пропорции пиксела» в нижней части панели композиции. На качество коррекции пропорций пиксела, используемых в функциях предпросмотра, влияют установки «Качество масштабирования» в категории «Предпросмотр». (См. раздел Параметры качества просмотра.)

Квадратные и неквадратные пикселы
Квадратные и неквадратные пикселы

A. Квадратные пикселы и кадровая пропорция 4:3 B. Неквадратные пикселы и кадровая пропорция 4:3 C. Неквадратные пикселы, отображаемые на мониторе с квадратными пикселами 

Если в элементе видеоряда используются неквадратные пикселы, After Effects отображает значение пропорций пиксела рядом с миниатюрой этого элемента на панели «Проект». Вы можете изменить интерпретацию пропорций пиксела для отдельных элементов видеоряда в диалоговом окне «Интерпретировать видеоряд». Убедившись, что все элементы видеоряда интерпретируются правильно, в одной композиции вы можете создавать сочетания элементов видеоряда с различными пропорциями пиксела.

After Effects считывает и записывает пропорции пиксела из видеороликов QuickTime напрямую. Например, если импортировать фильм, захваченный в широкоэкранном формате (16:9 DV), After Effects автоматически проставляет необходимые теги. В файлах AVI и PSD содержатся прямые указания на пропорции пиксела изображений.

Если элемент видеоряда не содержит информацию, которая прямо указывает на пропорции пиксела изображения, в качестве собственного варианта After Effects использует размеры кадра в пикселах. При импорте элемента видеоряда с размерами 720 x 486 пикселов для формата D1 или размерами 720 x 480 пикселов для формата DV, After Effects автоматически интерпретирует этот элемент материала как D1/DV NTSC. При импорте элемента видеоряда с размерами 720 x 576 пикселов для форматов D1 или DV After Effects автоматически интерпретирует этот элемент видеоряда как D1/DV PAL. Убедиться, что все файлы распознаны верно, можно, взглянув на панель «Проект» или диалоговое окно «Интерпретировать видеоряд».

Примечание.

При импорте файла с квадратными пикселами, где изображения имеют размеры в пикселах D1 или DV — например, изображение не в DV-формате, размеры которого окажутся равными 720 x 480 пикселов — следует сменить настройку пропорций пиксела на «Квадратные пикселы».

Параметр пропорций пиксела композиции должен соответствовать пропорциям пиксела в формате конечного продукта. В большинстве случаев можно просто выбрать шаблон настроек композиции. И наоборот, пропорции пиксела каждого элемента видеоряда должны быть заданы такими же, как пропорции пиксела оригинального видеоряда.

Ниже приведены документы в формате PDF на веб-сайте Artbeats с советами Триш и Криса Мейер (Trish и Chris Meyer) относительно пропорций пиксела.

На своем веб-сайте Lurker's Guide to Video Крис Пирацци (Chris Pirazzi) рассматривает технические вопросы пропорций.

Обновление пропорций пиксела для корректировки значений

After Effects CS3 и более ранние версии использовали пропорции пиксела для видеоформатов стандарта SD, которые игнорируют понятие чистой диафрагмы. Без учета отличие чистой диафрагмы от производственной диафрагмы в SD-видео пропорции пиксела, использовавшиеся в Premiere Pro CS3 и более ранних версиях, были немного неточны. Неправильные пропорции пиксела приводили к едва заметным искажениям некоторых изображений.

Примечание.

Чистая диафрагма — часть изображения, свободная от артефактов и искажений, появляющихся на краях изображения. Производственная диафрагма представляет собой все изображение.

В записи блога на веб-сайте Adobe Тодд Коприва (Todd Kopriva) обобщает сведения о коррекции пропорций пиксела.

В следующей таблице приведены сведения о значениях пропорций пиксела в After Effects:

Формат

Значение в After Effects CS4 и более поздних версиях

Старое значение

D1/DV NTSC

0.91

0.9

D1/DV NTSC, широкоэкранный

1.21

1.2

D1/DV PAL

1.09

1.07

D1/DV PAL, широкоэкранный

1.46

1.42

Это несоответствие характерно для подобных устаревших форматов со стандартным разрешением, в которых чистая диафрагма отличается от производственной. Оно отсутствует в более новых форматах.

В новых проектах и композициях, созданных в After Effects CS4 и более поздних версиях, по умолчанию используются правильные значения пропорций пиксела.

При открытии в программе After Effects CS4 и более поздних версиях проекты и композиции, созданные в After Effects CS3 или более ранних версиях, обновляются с целью использования в них правильных пропорций пиксела.

Примечание.

При наличии файла правил интерпретации с пользовательскими настройками необходимо обновить его, используя правильные значения пропорций пиксела.

При использовании элементов видеоряда с квадратными пикселами, предназначенными для заполнения кадра композиции с прямоугольными пикселами, может оказаться, что изменение в пропорциях пиксела вызывают изменения свойств изображения. Например, если ранее были созданы элемента видеоряда размером 768 x 576 квадратных пикселов для использования в композиции формата PAL D1/DV, необходимо создать данные элементы с размерами 788 x 576 квадратных пикселов.

Шаблоны настроек композиций, используемые с квадратно-пиксельными аналогами форматов со стандартным разрешением, изменились следующим образом.

Формат

Размеры в пикселах в After Effects CS4 и более поздних версиях

Предыдущие размеры в пикселах

Аналог NTSC D1 с квадратными пикселами

720x534

720x540

Аналог NTSC D1, широкоэкранный, с квадратными пикселами

872x486

864x486

Аналог D1/DV PAL с квадратными пикселами

788x576

768 x 576

Аналог D1/DV PAL, широкоэкранный, с квадратными пикселами

1050x576

1024x576

Изменение интерпретации пропорций пиксела в элементе видеоряда

  1. На панели «Проект» выберите элемент видеоряда.
  2. Выберите «Файл» > «Интерпретировать видеоряд» > «Основной».
  3. В меню «Пропорции пиксела» выберите пропорцию и нажмите кнопку «ОК».

Изменение пропорций пиксела для композиции

  1. Выберите «Композиция» > «Настройки композиции».
  2. Выполните одно из следующих действий.
    • В меню «Шаблон настроек» выберите шаблон настроек композиции.

    • В меню «Пропорции пиксела» выберите значение.

Общие пропорции пиксела

Пропорции пиксела

Применение

Квадратные пикселы

1.0

Видеоряд имеет размер кадра 640x480 или 648x486, 1920x1080 HD (не HDV или DVCPRO HD), 1280x720 HD или HDV или был экспортирован из приложения, не поддерживающего неквадратные пикселы. Этот параметр также подходит для видеоматериала, который был перенесен из фильма, или для настраиваемых проектов.

D1/DV NTSC

0.91

Видеоряд имеет размер кадра 720x486 или 720x480, желаемый результат — кадровая пропорция 4:3. Этот параметр также подходит для видеоматериала, который был экспортирован из приложения, работающего с неквадратными пикселами, например приложения для создания 3D анимации.

D1/DV NTSC, широкоэкранный

1.21

Видеоряд имеет размер кадра 720x486 или 720x480, желаемый результат — кадровая пропорция 16:9.

D1/DV PAL

1.09

Видеоряд имеет размер кадра 720x576, желаемый результат — кадровая пропорция 4:3.

D1/DV PAL, широкоэкранный

1.46

Видеоряд имеет размер кадра 720x576, желаемый результат — кадровая пропорция 16:9.

Анаморфный 2:1

2.0

Видеоряд был снят с использованием анаморфного объектива или анаморфически перенесен из кадра пленки с пропорциями 2:1.

HDV 1080/DVCPRO HD 720, анаморфный HD 1080

1.33

Видеоряд имеет размер кадра 1440x1080 или 960x720, желаемый результат — кадровая пропорция 16:9.

DVCPRO HD 1080

1.5

Видеоряд имеет размер кадра 1280x1080, желаемый результат — кадровая пропорция 16:9.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет