Общие сведения о рендеринге и экспорте

Что такое рендеринг?

Рендеринг — это создание кадров фильма из композиции. Рендеринг кадра подразумевает создание совмещенного двухмерного изображения с использованием всех слоев, установок и другой информации, содержащейся в композиции и задающей модель изображения. Рендеринг фильма подразумевает покадровый рендеринг всех кадров, составляющих фильм. Дополнительные сведения о том, как выполняется рендеринг каждого кадра, см. в разделе Порядок рендеринга и сворачивание трансформаций.

Как правило, термин рендеринг применяется только к конечному результату. Однако процессы создания предпросмотров для панелей «Видеоряд», «Слой» и «Композиция» также являются разновидностями рендеринга. Предпросмотр можно при необходимости сохранить в формате фильма и использовать в качестве конечного результата монтажа. (См. раздел Предпросмотр видео и аудио.)

После завершения рендеринга композиции для окончательного вывода она обрабатывается одним или несколькими модулями вывода, которые кодируют кадры в один или несколько выходных файлов. Процесс кодирования визуализированных кадров в выходной файл представляет собой разновидность экспорта.

Примечание:

  • Дополнительные сведения о настройках проекта, определяющих формат отображения времени, способ обработки цветовых данных и частоту дискретизации аудиосинала см. в разделе Настройки проекта.
  • Сведения о том, как задать настройки композиции, включая разрешение, размер кадра и пропорции пикселя для конечного результата рендеринга, см. в разделе Настройки композиции.

После завершения работы над композицией ее можно экспортировать в виде видеофайла. Существуют два различных метода экспорта в видеофайл. Пользователь может выбрать метод в соответствии со своими потребностями.

Экспорт в видеофайл может потребоваться по следующим причинам.

  • Требуется фильм высокого качества (с использованием или без использования альфа-каналов) или набор изображений, который будет помещен в набор Premiere Pro или использован в другом приложении для редактирования видео, компоновки или обработки 3D-графики.

    Чтобы создать файл фильма в высоком качестве, выполните рендеринг с использованием очереди рендеринга. См. раздел Рендеринг и экспорт с помощью панели «Очередь рендеринга».

  • Необходим сжатый файл фильма для размещения в интернете или для записи на диск DVD или Blu-ray.

    Для создания фильма высокого качества, сжатого для размещения в Интернете или для записи на диск DVD или Blu-ray, сжатие видеоряда можно осуществить с помощью Adobe Media Encoder. См. раздел Adobe Media Encoder.

Примечание.

Некоторые виды экспорта не предусматривают рендеринг и предназначены для промежуточных стадий рабочего процесса, а не для окончательного вывода. Например, можно экспортировать проект как проект Adobe Premiere Pro, выбрав «Файл» >«Экспорт» > «Проект Adobe Premiere Pro». Данные проекта сохраняются без применения рендеринга. Как правило, рендеринг данных, переданных с помощью Dynamic Link, не осуществляется.

Фильм можно записать в одном выходном файле, содержащем все визуализированные кадры, или же его можно сформировать как набор неподвижных изображений (как это было бы при создании вывода для записи на пленку).

Для формирования вывода можно преобразовать композиции с использованием очереди рендеринга After Effects или добавить композиции в очередь Adobe Media Encoder с настройками рендеринга, выбранными на панели «Очередь рендеринга».

Для способа, включающего использование панели «Очередь рендеринга», After Effects использует встроенную версию Adobe Media Encoder для кодирования большинства форматов фильмов в панели «Очередь рендеринга». При выполнении рендеринга и экспорта с помощью панели «Очередь рендеринга» встроенная версия Adobe Media Encoder вызывается автоматически. Adobe Media Encoder в этом случае отображается только в форме диалоговых окон настройки экспорта, в которых можно задавать некоторые параметры кодирования и вывода. (См. раздел Параметры кодирования и сжатия фильмов.)

Примечание.

Встроенная версия Adobe Media Encoder, используемая для управления параметрами экспорта в модулях вывода After Effects, не поддерживает всех возможностей полного автономного приложения Adobe Media Encoder.

From an expert: Using the Render Queue to export files

From an expert: Using the Render Queue to export files
Ian Robinson

Рендеринг и экспорт с помощью панели «Очередь рендеринга»

Рендеринг и экспорт фильмов из программы After Effects осуществляется главным образом через панель «Очередь рендеринга».

При помещении композиции на панель «Очередь рендеринга» она становится элементом рендеринга . В очередь рендеринга можно добавлять множество элементов рендеринга и After Effects может проводить рендеринг нескольких элементов в пакетном режиме без вмешательства оператора. При нажатии кнопки «Рендеринг» в правом верхнем углу панели «Очередь рендеринга» начинается процесс рендеринга всех элементов с состоянием «В очереди» и вывод видеоряда в том порядке, в котором расположены элементы очереди на панели «Очередь рендеринга».

Примечание.

Для экспорта фильма в несколько форматов нет необходимости проводить рендеринг несколько раз с теми же самыми настройками. Можно экспортировать несколько версий одного и того же визуализированного фильма с добавлением модулей вывода к элементу рендеринга на панели «Очередь рендеринга».

При работе с несколькими элементами рендеринга бывает полезным добавлять комментарии в столбец «Комментарий» на панели «Очередь рендеринга». Если столбец комментариев не отображается, щелкните заголовок столбца правой кнопкой мыши (Windows) или левой кнопкой мыши, удерживая нажатой клавишу CONTROL (Mac OS), и выберите «Столбцы» > «Комментарий».

Управление элементами рендеринга

На панели «Очередь рендеринга» можно одновременно управлять несколькими элементами рендеринга, каждый из которых имеет свои настройки и модули вывода.

Настройки рендеринга определяют следующие характеристики:

  • Выходная частота кадров
  • Длительность
  • Разрешение
  • Качество слоя

Параметры модуля вывода, применяемые после настроек рендеринга, определяют характеристики обработки после рендеринга, такие как:

  • Выходной формат
  • Параметры сжатия
  • Кадрирование
  • Будет ли встроена ссылка в проект в выходном файле

Можно создавать шаблоны, которые содержат обычно используемые настройки рендеринга и модулей вывода.

С помощью панели «Очередь рендеринга» можно выполнять рендеринг одной и той же композиции в различные форматы с различными настройками, причем эти действия инициируются однократным нажатием кнопки «Рендеринг».

  • Можно осуществлять вывод в набор неподвижных изображений, например, набор Cineon, которую затем можно преобразовать в фильм для показа в кинотеатре.

  • Можно создавать выходные файлы с помощью алгоритмов сжатия без потерь (или в формате без сжатия) в контейнер QuickTime с передачей в нелинейную систему редактирования (NLE) для редактирования видео.

Можно выбирать, дублировать и изменять порядок рендеринга элементов с помощью множества комбинаций клавиш, которые используются для работы со слоями и другими элементами. См. раздел Общие сочетания клавиш.

Примечание.

Для переноса визуализированного выходного видеоряда из After Effects в формат пленки или видео необходимо иметь оборудование для переноса пленки или видео или же доступ к службе, которая предлагает такие услуги.

Рендеринг и экспорт фильма с использованием очереди рендеринга

  1. Выберите композицию на панели «Проект», из которой требуется создать фильм, а затем выполните одно из следующих действий для добавления композиции в очередь рендеринга.
    • Выберите «Композиция» > «Добавить в очередь рендеринга».

    • Перетащите композицию в очередь рендеринга.

    Примечание.

    Чтобы создать композицию из элемента видеоряда и сразу добавить ее в очередь рендеринга, перетащите элемент видеоряда из панели «Проект» на панель «Очередь рендеринга». Это удобный способ преобразования элемента видеоряда из одного формата в другой.

  2. Щелкните треугольник рядом с заголовком «Вывод в» на панели «Очередь рендеринга» для выбора нового имени выходного файла в соответствии с соглашением о присвоении имен, затем выберите местоположение; или щелкните текст рядом с заголовком «Вывод в» для ввода любого имени. (См. раздел Указание имен и местоположений выходных файлов рендеринга.)
  3. Щелкните треугольник справа от заголовка «Настройки рендеринга» для выбора шаблона настроек рендеринга или щелкните подчеркнутый текст справа от заголовка «Настройки рендеринга» для управления настройками. (См. раздел Настройки рендеринга.)
  4. Выберите тип журнала из меню «Журнал».

    Если файл журнала записан, путь к нему отображается под заголовком «Настройки рендеринга» и в «Журнал».

  5. Щелкните треугольник справа от заголовка «Модуль вывода» для выбора шаблона настроек модуля вывода или щелкните подчеркнутый текст справа от заголовка модуля вывода для настройки параметров. Настройки модуля вывода используются для задания формата файла фильма на выходе. В некоторых случаях после выбора формата открывается диалоговое окно, в котором можно задать параметры, связанные с этим форматом. (См. разделы Модули вывода и их параметры и Параметры кодирования и сжатия фильмов.)

    После выбора имени и положения для файла выхода и настройки всех параметров рендеринга и модулей вывода запись в столбце «Рендеринг» автоматически помечается как выбранная (устанавливается флажок) и ее состояние изменяется на «В очереди». Состояние «В очереди» означает, что элемент рендеринга помещен в очередь рендеринга.

    Примечание.

    Нажмите клавишу CAPS LOCK перед началом рендеринга, чтобы на панели «Композиция» не показывались визуализированные кадры. При отключении обновления панели «Композиция» After Effects требуется меньше времени для обработки простых элементов рендеринга с большим количеством кадров.

  6. Нажмите кнопку «Рендеринг» в правом верхнем углу панели «Очередь рендеринга».

Рендеринг композиции в фильм может занять несколько секунд или несколько часов, в зависимости от размера кадра композиции, качества, сложности изображения и метода сжатия. При выполнении рендеринга элемента, работать в After Effects нельзя. Об окончании рендеринга предупреждает аудиосигнал.

См. этот урок, чтобы научиться использовать очередь рендеринга для экспорта файлов.

При завершении рендеринга элемент остается на панели «Очередь рендеринга», а его состояние меняется на «Завершен» до удаления из очереди рендеринга. Нельзя провести повторный рендеринг элемента после завершения обработки, но можно скопировать элемент, разместив копию в очереди рендеринга с такими же или другими настройками.

Примечание.

По завершении рендеринга элемента можно импортировать законченный видеофрагмент как элемент видеоряда, перетаскивая его модуль вывода из очереди рендеринга на панель «Проект». (См. раздел Импорт элементов видеоряда.)

Состояние элемента рендеринга

Каждому элементу рендеринга присваивается состояние, которое отображается в столбце «Состояние» на панели «Очередь рендеринга».

Не в очереди

Элемент рендеринга находится на панели «Очередь рендеринга», но еще не подготовлен к операции рендеринга. Подтвердите выбор требуемых настроек рендеринга и модуля вывода и выберите команду «Рендеринг» для включения элемента в очередь.

В очереди

Элемент рендеринга готов к рендерингу.

Требуется вывод

Не указано имя файла вывода. Выберите значение из меню «Вывод в» или щелкните подчеркнутый текст «Пока не определено» рядом с заголовком «Вывод в», чтобы задать имя файла и пути.

Ошибка

After Effects не удалось выполнить операцию рендеринга элемента. Используйте текстовый редактор для просмотра файла журнала для получения подробной информации о причинах сбоя операции рендеринга. Если файл журнала записан, путь к нему отображается под заголовком «Настройки рендеринга» и в «Журнал».

Остановлено пользователем

Процесс рендеринга был остановлен.

Готово

Процесс рендеринга элемента завершен.

Управление элементами и изменение состояний рендеринга

  • Выбор исходной композиции для элемента рендеринга в панели «Проект»: щелкните элемент рендеринга правой кнопкой мыши (Windows) или левой кнопкой, удерживая нажатой клавишу CONTROL (Mac OS) и выберите пункт Показать композицию в окне «Проект» в контекстном меню.
  • Удаление элемента рендеринга из очереди рендеринга (изменение его состояния с «В очереди» на «Не в очереди»): снимите с элемента выделение в столбце «Рендеринг». Элемент останется на панели Очередь рендеринга.
  • Изменение состояния элемента рендеринга с «Не в очереди» на «В очереди»: выделите элемент в столбце «Рендеринг».
  • Удаление элемента рендеринга с панели «Очередь рендеринга»: выберите элемент и нажмите клавишу Delete или выберите Правка > Очистить.
  • Изменение порядка элементов в панели «Очередь рендеринга»: перетащите элемент вверх или вниз в очереди. Между элементами рендеринга появляется жирная черная линия, указывающая на место размещения элемента. Изменить порядок выделенных элементов рендеринга можно также, выбрав Слой > Упорядочить, а затем одну из следующих команд: Переместить элемент рендеринга вперед, Отправить элемент рендеринга назад, Переместить элемент рендеринга в начало или Отправить элемент рендеринга в конец
  • Перемещение выделенных элементов рендеринга вверх (вперед) в очереди: нажмите клавиши CTRL+ALT+СТРЕЛКА ВВЕРХ (Windows) или COMMAND+OPTION+СТРЕЛКА ВВЕРХ (Mac OS).
  • Перемещение выделенных элементов рендеринга вниз (назад): нажмите CTRL+ALT+СТРЕЛКА ВНИЗ (Windows) или COMMAND+OPTION+СТРЕЛКА ВНИЗ (Mac OS).
  • Перемещение выделенных элементов рендеринга в начало очереди: нажмите CTRL+ALT+SHIFT+СТРЕЛКА ВВЕРХ (Windows) или COMMAND+OPTION+SHIFT+СТРЕЛКА ВВЕРХ (Mac OS).
  • Перемещение выделенных элементов рендеринга в конец очереди: нажмите CTRL+ALT+SHIFT+СТРЕЛКА ВНИЗ (Windows) или COMMAND+OPTION+SHIFT+СТРЕЛКА ВНИЗ (Mac OS).
  • Создание копии элемента рендеринга: щелкните элемент рендеринга правой кнопкой мыши (Windows) или левой кнопкой мыши, удерживая нажатой клавишу CONTROL (Mac OS), и выберите команду из контекстного меню.
    • Рендеринг с тем же именем файла: выберите команду Дублировать с именем файла.
    • Рендеринг с новым именем файла: выберите Дублировать, щелкните подчеркнутое имя файла рядом с пунктом Вывод в, введите имя файла и нажмите кнопку Сохранить.

Приостановка или прерывание рендеринга

Если на диске, на который выполняется запись модулем вывода, заканчивается свободное место, After Effects приостанавливает операцию рендеринга. Освободив место на диске, можно вернуться к прерванным операциям рендеринга и экспорта.

  • Чтобы приостановить рендеринг, нажмите кнопку «Пауза». Чтобы возобновить рендеринг, нажмите кнопку «Продолжить».

    Если операция рендеринга приостановлена, изменить настройки или использовать After Effects каким-либо другим способом нельзя.

  • Чтобы остановить рендеринг с целью повторного запуска операции, нажмите кнопку «Остановить», удерживая нажатой клавишу ALT (Windows) или OPTION (Mac OS).

    Элементу рендеринга при этом присваивается состояние «Остановлено пользователем», и на панель «Очередь рендеринга» добавляется новый элемент с состоянием «В очереди». Новый элемент использует то же имя выходного файла и имеет ту же длительность, что и исходный элемент рендеринга.

  • Чтобы остановить рендеринг для последующего возобновления того же процесса, нажмите «Остановить».

    Элементу рендеринга при этом присваивается состояние «Остановлено пользователем», и на панель «Очередь рендеринга» добавляется новый элемент с состоянием «Не в очереди». Новый элемент использует инкрементное имя выходного файла и возобновляет рендеринг с кадра, находящегося непосредственно перед кадром, на котором произошла остановка; таким образом, первый кадр нового элемента является последним успешно визуализированным кадром элемента, рендеринг которого был остановлен.

Информация, отображаемая для текущих операций рендеринга

Основные сведения о текущих операциях рендеринга отображаются внизу панели «Очередь рендеринга».

Сообщение

Сообщение о состоянии. Например: «Рендеринг 1 из 4».

ОЗУ

Память, доступная для процесса рендеринга.

Запуск рендеринга

Дата и время запуска текущего пакета операций рендеринга.

Всего времени прошло

Истекшее время рендеринга (без пауз) от начала запуска текущего пакета операций рендеринга.

Последняя ошибка

Путь к месту хранения файлов журнала.

Примечание.

Для получения дополнительной информации о текущей операции рендеринга щелкните треугольник слева от заголовка «Текущий модуль рендеринга». Через некоторое время окно «Текущий модуль рендеринга» сворачивается автоматически. Чтобы предотвратить сворачивание по истечении интервала ожидания, удерживая нажатой клавишу Alt (ОС Windows) или клавишу Option (ОС Mac OS), щелкните треугольник рядом с заголовком «Текущий модуль рендеринга». Для информации о завершенной операции рендеринга просмотрите файл журнала. Если файл журнала записан, путь к нему отображается под заголовком «Настройки рендеринга» и в «Журнал».

Изменение звукового сигнала окончания рендеринга

При успешном окончании операции рендеринга и экспорта всех элементов очереди раздается звуковой сигнал; сбой операции обозначается другим сигналом. Можно изменить звуковые сигналы об окончании рендеринга, заменив файлы с именами rnd_okay.wav и rnd_fail.wav в папке звуковых сигналов. Папка звуковых сигналов имеет следующий путь:

  • Program Files\Adobe\Adobe After Effects CC 2015\Support Files (Windows)

  • Программы/Adobe After Effects CC/Contents/Resources (Mac OS)

Ресурсы в Интернете, посвященные рендерингу и экспорту с использованием очереди рендеринга

Ллойд Альварес (Lloyd Alvarez) предлагает на своем веб-сайте After Effects Scripts сценарий, который отправляет готовые к операции элементы на рендеринг в фоновом режиме с помощью aerender.

Джефф Альмасол (Jeff Almasol) предлагает на своем веб-сайте redefinery сценарий, который визуализирует и экспортирует каждый из выделенных слоев по отдельности. Этот сценарий можно использовать, если к слоям применены различные версии эффекта, или при необходимости визуализировать различные части эффекта отдельно для обеспечения гибкости их композиции.

Кристофер Грин (Christopher Green) предлагает на своем веб-сайте сценарий (Queue_Comp_Sections.jsx), который позволяет использовать несколько направляющих слоев для задания нескольких временных интервалов, которые визуализируются и экспортируются по отдельности с помощью очереди рендеринга.

Рендеринг и экспорт с помощью Adobe Media Encoder

From an expert: Export a composition from After Effects to Adobe Media Encoder

From an expert: Export a composition from After Effects to Adobe Media Encoder
Jeff Sengstack

Можно также экспортировать композиции After Effects непосредственно в Adobe Media Encoder, что обеспечивает дополнительную гибкость благодаря возможности продолжения работы с After Effects в процессе обработки файлов. При использовании Adobe Media Encoder можно также использовать дополнительные шаблоны настроек и параметры, которые недоступны в очереди рендеринга After Effects. 

Для добавления композиции в очередь Adobe Media Encoder можно использовать один из следующих способов:

  • Добавление в очередь Adobe Media Encoder (Композиция > Добавление в очередь Adobe Media Encoder или Файл > Экспорт > Добавление в очередь Adobe Media Encoder) — для окончательного рендеринга с использованием шаблонов настроек и параметров, заданных в Adobe Media Encoder.
  • кнопка Добавить в очередь AME в очереди рендеринга («Окно» > «Очередь рендеринга») — для чернового рендеринга композиции с использованием параметров, заданных в очереди рендеринга, при параллельной работе над композицией. 

Дополнительные сведения об использовании Adobe Media Encoder для рендеринга см. в разделе Кодирование видео или аудио в Adobe Media Encoder.

Примечание:

Настройки модуля вывода, такие как параметры формата или выбор цветового канала, не передаются в Adobe Media Encoder при выборе варианта «Добавить в очередь AME». Имя и местоположение выходного файла передаются, однако Adobe Media Encoder не использует шаблоны имени и местоположения файла, вследствие чего могут возникнуть несоответствия в нумерации набора кадров.

Добавить композицию непосредственно в Adobe Media Encoder

Чтобы добавить композицию в Adobe Media Encoder, выполните следующие действия.

  1. Перетащите проект After Effects, содержащий требуемую композицию, в очередь кодирования в Adobe Media Encoder.

    Можно добавить в Adobe Media Encoder композицию из After Effects. Выполните одно из предложенных ниже действий.

    • Выберите «Композиция» > «Добавить в очередь Adobe Media Encoder»

    • Выберите «Файл» > «Экспорт» > «Добавить в очередь Adobe Media Encoder»

    • Нажмите клавиши Ctrl+Alt+M (Windows) или Command+Option+M (Mac OS)

  2. Откроется диалоговое окно импорта композиций After Effects. Выберите композицию, которую необходимо закодировать.

  3. Выполните кодирование файла как обычно, выбрав шаблоны настроек и расположение файла экспорта в Adobe Media Encoder.

Добавить композицию из очереди рендеринга в Adobe Media Encoder

Чтобы добавить композицию в Adobe Media Encoder с черновыми настройками рендеринга:

  1. Выберите «Композиция» > «Добавить в очередь рендеринга» или нажмите сочетание клавиш Control + M (Windows) или Command + M (Mac).

  2. На панели «Очередь рендеринга» щелкните кнопку «Добавить в очередь AME». 

Выбор формата и параметров вывода

After Effects предоставляет различные форматы и параметры сжатия для вывода видео. Выбор формата и параметров сжатия определяются тем, как предполагается использовать выходное видео. Например, если рендеринг фильма из программы After Effects выполняется для конечного вывода и создания продукта, предназначенного для демонстрации, то необходимо учитывать характеристики устройства, с которого предполагается показывать фильм, и ограничения на размер файла и скорость данных. И наоборот, если фильм, созданный в программе After Effects, является промежуточным продуктом, который будет использоваться в качестве входных данных для системы редактирования видео, то следует выбрать формат вывода без сжатия, совместимый с данной системой редактирования. (См. раздел Планирование процесса.)

Аарон Рабинович (Aharon Rabinowitz) опубликовал на веб-сайте Creative COW статью, посвященную планированию проекта и выбору форматов и параметров для использования в подготовке выходного видеофайла.

Следует учитывать, что можно использовать разные схемы сжатия и кодирования на разных фазах рабочего процесса. Например, несколько кадров можно экспортировать как неподвижные изображения с высоким разрешением (например, файлы TIFF), если требуется получить одобрение заказчика по поводу использования цветовой палитры; сам фильм можно экспортировать в формате кодирования со сжатием (например, H.264), если требуется утвердить временную развертку для анимации.

Поддерживаемые выходные форматы

Можно добавить возможность экспортирования других типов данных путем установки подключаемых модулей и сценариев, предоставленных другими разработчиками. Например, на форуме AE Enhancers Пол Терслей (Paul Tuersley) предлагает сценарий экспорта данных из композиции After Effects в качестве данных проекта Cinema 4D. В статье Марка Кристиансена на веб-сайте ProVideo Coalition приводятся ссылки на сценарии и внешние модули для экспорта содержимого из After Effects для использования в Cinema 4D, Maya, Lightwave и других 3D-приложениях. (См. раздел Подключаемые модули.)

Если не указано иначе, все форматы файлов изображений экспортируются с кодированием в 8 бит на канал.

Форматы видео и анимации

  • QuickTime (MOV)

  • Video for Windows (AVI; только в Windows)

Примечание.

Чтобы создать анимированный фильм GIF, выполните рендеринг и экспортируйте фильм QuickTime из After Effects. Затем импортируйте фильм QuickTime в Photoshop и экспортируйте его в формат анимированного файла GIF.

Форматы проекта видео

  • Проект Adobe Premiere Pro (PRPROJ)

Форматы неподвижных изображений

  • Adobe Photoshop (PSD)

  • Cineon (CIN, DPX)

  • Maya IFF (IFF)

  • JPEG (JPG, JPE)

  • OpenEXR (EXR)

  • PNG (PNG)

  • Radiance (HDR, RGBE, XYZE)

  • SGI (SGI, BW, RGB)

  • Targa (TGA, VBA, ICB, VST)

  • TIFF (TIF)

Форматы аудио

  • Audio Interchange File Format (AIFF)

  • MP3

  • WAV

Сбор файлов в одном местоположении

Команда «Сбор файлов» собирает копии всех файлов проекта или композиции в одном месте. Используйте эту команду перед началом рендеринга, для архивирования или перемещения проекта в другую компьютерную систему или учетную запись пользователя.

При использовании команды «Сбор файлов» After Effects создает новую папку, в которой сохраняются следующие данные:

  • Новая копия проекта
  • Копии файлов видеоряда
  • Файлы прокси в соответствии с заданными настройками
  • Отчет с описанием файлов, эффектов и шрифтов, необходимых для повторного создания проекта и рендеринга композиций.

После завершения сбора файлов можно внести в проект новые изменения, однако важно помнить, что внесенные изменения сохраняются в оригинальных файлах проекта, а не в собранной версии.

  1. Выберите «Файл» > «Зависимости» > «Сбор файлов».

  2. В диалоговом окне «Сбор файлов» выберите необходимые параметры команды «Сбор исходных файлов».

    Все

    Собирает все файлы видеоряда, включая неиспользуемые файлы видеоряда и настройки прокси.

    Для всех композиций

    Собирает все файлы видеоряда и настройки прокси, используемые в любой композиции проекта.

    Для выбранных композиций

    Собирает все файлы видеоряда и настройки прокси, используемые в композициях, которые выделены на панели «Проект».

    Для композиций в очереди

    Собирает все файлы видеоряда и настройки прокси, используемые прямо или косвенно в любой композиции с состоянием «В очереди» на панели «Очередь рендеринга».

    Нет (только проект)

    Копирует проект в новое место без сбора исходного видеоряда.

  3. При необходимости укажите другие параметры.

    Создать только отчет

    При выборе этого параметра не копируются файлы и настройки прокси.

    Учитывать настройки прокси

    Используйте этот параметр с композициями, содержащими настройки прокси, при выборе копирования с включением настроек прокси. Если выбран этот параметр, копируются только файлы, используемые в композиции. Если этот параметр не выбран, то копия содержит и настройки прокси, и исходные файлы, что позволяет позже изменить настройки прокси в собранной версии.

    Примечание.

    Если в диалоговом окне «Сбор исходных файлов» выбран параметр «Для композиций в очереди», After Effects использует параметры прокси из настроек рендеринга, а не композиции.

    Уменьшить проект

    Удаляет все неиспользуемые элементы и композиции видеоряда из собранных файлов при установке следующих параметров в меню «Сбор исходных файлов»: «Для всех композиций», «Для выделенных композиций» и «Для композиций в очереди».

    Изменить вывод рендеринга на

    Этот параметр позволяет модулям вывода перенаправить рендеринг в указанную подпапку в папке собранных файлов. С его помощью можно контролировать доступ к визуализированным файлам при рендеринге проекта с другого компьютера. Для выполнения рендеринга файлов в эту папку состояние рендеринга для модулей выхода должен иметь одно из действительных значений («В очереди», «Не в очереди» или «Будет продолжено»).

    Включить рендеринг «Отслеживать папку»

    Команда «Сбор файлов» может использоваться для сохранения проектов в специальную папку отслеживания для запуска процедуры отслеживания рендеринга по сети. After Effects включает файл контроля рендеринга с именем [имя_проекта]_RCF.txt, с помощью которого сигнализирует подключенным компьютерам, что проект доступен для рендеринга. After Effects и любые другие установленные приложения для рендеринга могут таким образом осуществлять рендеринг проекта совместно по сети. (См. раздел Настройка рендеринга «Отслеживать папку».)

    Максимальное количество компьютеров

    Используется для указания количества ядер рендеринга или лицензированных копий After Effects, которые нужно выделить для рендеринга собранного проекта. Под этим параметром After Effects сообщает, какое количество элементов проекта будет обработано с использованием более одного компьютера.

    Примечание.

    Слишком долгое выполнение рендеринга может означать, что для параметра «Максимальное количество компьютеров» задано слишком большое значение, и количество сетевой служебной информации, необходимое для отслеживания рендеринга на всех компьютерах, является непропорционально большим по сравнению со временем самого процесса рендеринга. Оптимальное число компьютеров зависит от многих других переменных, относящихся к конфигурации сети и параметрам компьютеров; экспериментальный подбор значений позволит выявить оптимальное значение параметра для конкретной сети.

  4. Для добавления собственной информации к создаваемому программой отчету щелкните «Комментарии», добавьте необходимый текст и щелкните «ОК». Комментарии отображаются в конце отчета.
  5. Щелкните «Сбор». Задайте имя папки и путь для собранных файлов.

    После запуска процесса сбора файлов After Effects создает папку и копирует в нее указанные файлы. Иерархия папок совпадает с иерархией папок и элементов видеоряда в проекте. Новая папка содержит папку видеоряда и может также содержать папку для вывода (если выбрано «Изменить вывод рендеринга на»).

Имена этих папок появляются в скобках для того, чтобы ожидающие ядра рендеринга не выполняли поиск проектов в данных папках.

Карл Ларсен (Carl Larsen) демонстрирует использование команд «Сбор файлов» и «Сбор видеоряда» в видеоруководстве на веб-сайте Creative COW, посвященном организации, сбору и архивированию файлов и видеоряда проекта.

Дэвид Торно (David Torno) представляет на веб-сайте After Effects Scripts сценарий экспорта информации о проекте.

Указание имен и местоположений выходных файлов рендеринга

Примечание.

Найти ранее обработанный элемент или просмотреть путь для вывода элемента рендеринга в очереди можно, развернув группу «Модули вывода» на панели «Очередь рендеринга» и щелкнув подчеркнутое имя файла на заголовке «Модули вывода» правой кнопкой мыши (Windows) или левой кнопкой мыши, удерживая нажатой клавишу CONTROL (Mac OS).

Указание имени файла и пути к нему для одного элемента рендеринга

  • Чтобы вручную ввести имя файла и целевую папку, щелкните подчеркнутый текст рядом с заголовком «Вывод в».
  • Для задания имени файла с использованием шаблона щелкните треугольник рядом с заголовком «Вывод в» и выберите шаблон из меню.

Создание и использование пользовательского шаблона для имени файла

Присвоения имен выходным файлам можно использовать пользовательские шаблоны, настроенные в соответствии со свойствами композиции и проекта.

Примечание.

Чтобы сделать шаблон присвоения имен файлам шаблоном по умолчанию, нажмите и удерживайте клавишу CTRL (Windows) или COMMAND (Mac OS) при выборе шаблона из меню «Вывод в».

  1. В панели «Очередь рендеринга» выберите из меню «Вывод в» параметр «Пользовательский».
  2. Если требуется создать новый шаблон присвоения имен файлам на основе существующего шаблона, выберите существующий шаблон из меню «Шаблон настроек».

  3. В окне «Шаблон» щелкните область, в которую требуется вставить правило присвоения имен и выполните любое из предложенных ниже действий.

    • Чтобы добавить свойство шаблона настроек к имени файла, выберите свойство в меню «Добавить свойство».

    • Введите текст в поле «Шаблон».

    Примечание.

    Убедитесь, что курсор вставки находится за пределами квадратных скобок ([]) в свойствах шаблона настроек.

  4. Выполните любое из предложенных ниже действий.
    • Чтобы сохранить шаблон присвоения имен файлам как шаблон настроек для будущего использования в меню «Вывод в», нажмите кнопку «Сохранить» . В диалоговом окне «Выбор имени» введите имя для шаблона и щелкните «ОК».

    • Для постоянного использования выделенного шаблона присвоения имен файлам установите флажок «По умолчанию».

    • Для применения выбранного шаблона присвоения имен файлам к текущему модулю вывода нажмите кнопку «ОК».

Автоматическое присвоение имен выходным файлам

Установка «Использовать имя файла и папку по умолчанию» автоматически присваивает уникальные имена выходным файлам всех композиций в очереди рендеринга (за исключением файлов, созданных путем сохранения результатов предпросмотра из оперативной памяти, которым присваивается имя композиции). При выборе этого параметра каждому элементу рендеринга присваивается то же имя папки, что и предыдущим элементам до следующей смены пути к файлу. Если рендеринг композиции выполняется более одного раза, After Effects добавляет число к имени файла (например, имя_композиции_1).

Примечание.

Старайтесь не использовать в именах файлов символы из расширенной таблицы ASCII или других нестандартных символов, если проект будет использоваться на другой вычислительной платформе или рендеринг проекта будет выполняться с использованием папки отслеживания.

  1. Выберите «Правка» > «Установки» > «Вывод» (Windows) или «After Effects» > «Установки» > «Вывод» (Mac OS).
  2. Выберите «Использовать имя файла и папку по умолчанию».

Поддержка путей в шаблонах

В шаблоны можно добавлять пути, В шаблоне можно задать абсолютные пути. Например, пользователь может задать и сохранить шаблон, который всегда будет помещать преобразованные файлы в папку E:\Output\[Имя компьютера].[расширение]. Информацию о новых шаблонах в выпуске After Effects CC 12.2 см. в главе «Обновление шаблонов имени и расположения файла» раздела Новые возможности After Effects CC 12.2.

Настройки рендеринга

Настройки рендеринга применяются к каждому элементу рендеринга и определяют особенности процесса рендеринга композиции для конкретного элемента. По умолчанию параметры рендеринга для элемента рендеринга основаны на параметрах текущего проекта, настройках композиции и параметрах переключения для композиции, на основе которой создан элемент рендеринга. Однако можно изменить настройки рендеринга для каждого элемента для переопределения некоторых из этих настроек.

Настройки рендеринга применяются к корневой композиции элемента рендеринга и ко всем вложенным композициям.

Примечание.

Настройки рендеринга влияют только на вывод элемента рендеринга, с которым они связаны; композиция при этом не затрагивается.

Настройки рендеринга
Настройки рендеринга

Изменение настроек рендеринга

  • Чтобы изменить настройки рендеринга для элемента рендеринга, щелкните имя шаблона настроек рендеринга рядом с заголовком «Настройки рендеринга» на панели «Очередь рендеринга» и выберите настройки в диалоговом окне «Настройки рендеринга».
  • Чтобы применить шаблон настроек рендеринга к выбранным элементам рендеринга, щелкните треугольник рядом с заголовком «Настройки рендеринга» на панели «Очередь рендеринга» и выберите шаблон из меню. Можно выбрать пользовательский шаблон настроек рендеринга или один из предустановленных шаблонов настроек рендеринга.

    Оптимальные настройки: этот параметр часто используется при рендеринге для конечного вывода.

    Настройки черновика: подходит для просмотра или тестирования движения.

    Настройки DV: этот параметр похож на параметр «Оптимальные настройки», но включает активированный параметр «Рендеринг поля» со значением «Сначала нижнее поле».

    Настройки системы с несколькими компьютерами: этот параметр похож на параметр «Оптимальные настройки», но включает выбор параметра «Пропустить существующие файлы» для возможности рендеринга на нескольких компьютерах.

Примечание.

Шаблон настроек рендеринга по умолчанию присваивается элементу рендеринга в момент его создания. Для изменения шаблона настроек рендеринга по умолчанию удерживайте нажатой клавишу CTRL (Windows) или COMMAND (Mac OS) при выборе шаблона настроек рендеринга из меню.

Создание, редактирование и управление шаблонами параметров рендеринга

В диалоговом окне «Шаблоны настроек рендеринга» выполняются следующие задачи. Для открытия диалогового окна «Шаблоны настроек рендеринга» выберите команду «Правка» > «Шаблоны» > «Настройки рендеринга» или щелкните треугольник рядом с заголовком «Настройки рендеринга» на панели «Очередь рендеринга» и выберите команду «Создать шаблон».

  • Для создания нового шаблона настроек рендеринга нажмите «Создать», задайте настройки рендеринга и щелкните «ОК». Введите имя нового шаблона.
  • Для редактирования существующего шаблона настроек рендеринга, выберите шаблон из меню «Имя настроек», щелкните «Правка» и задайте настройки рендеринга.

Примечание.

Изменения существующего шаблона не влияют на элементы рендеринга, уже находящиеся в очереди.

  • Чтобы указать, какой из шаблонов настроек рендеринга будет использоваться при рендеринге фильмов, отдельных кадров, предварительно визуализированных фильмов и прокси по умолчанию, выберите шаблон из меню в области «Настройки по умолчанию» в диалоговом окне «Шаблоны настроек рендеринга».
  • Для сохранения всех загруженных шаблонов настроек рендеринга в файл щелкните «Сохранить все».
  • Для загрузки сохраненного файла шаблонов настроек рендеринга нажмите «Загрузить», выберите файл шаблонов настроек рендеринга и затем нажмите «Открыть».

Действие настроек рендеринга

Каждый из этих параметров переопределяет настройки композиции, настройки проекта или параметры переключения слоев.

Журнал

Можно задать объем информации, который After Effects записывает в файл журнала рендеринга. При выборе параметра «Только ошибки» After Effects создает файл, только если в процессе рендеринга встретились ошибки. При выборе параметра «С настройками» создается файл журнала, в который записываются текущие настройки рендеринга. При выборе параметра «Данные прибавления по отдельным кадрам» создается файл журнала, в котором записываются текущие настройки рендеринга и сведения о рендеринге каждого кадра. Если файл журнала записан, путь к нему отображается под заголовком «Настройки рендеринга» и в «Журнал».

Качество

Параметр качества, применяемый для всех слоев. (См. раздел Качество изображения слоя и субпиксельное позиционирование.)

Разрешение

Разрешение визуализированной композиции по отношению к исходному размеру композиции. (См. раздел Разрешение.)

Примечание.

Если рендеринг выполняется с пониженным разрешением, установите параметр «Качество» в значение «Черновик». При уменьшении разрешения рендеринг с параметром «Наилучшее качество» создает мутноватое изображение и выполняется дольше, чем рендеринг в черновом качестве.

Кэш диска

Определяет использование во время рендеринга установок кэша диска. Параметр «Только чтение» не записывает новые кадры в кэш диска во время рендеринга After Effects. В текущих настройках (по умолчанию) используются параметры кэша диска, определенные в установках «Носитель и кэш диска». (См. раздел Кэш диска.)

Использование прокси

Указывает, следует ли использовать прокси во время рендеринга. В текущих настройках используются параметры каждого элемента видеоряда. (См. раздел Заполнители и прокси.)

Эффекты

В текущих настройках (по умолчанию) используются текущие настройки для переключателей «Эффекты» . «Все вкл.» — рендеринг всех примененных эффектов. «Все выкл.» — рендеринг эффектов не выполняется.

Переключатели режима «Соло»

В текущих настройках (по умолчанию) используются текущие настройки для переключателей режима «Соло» для каждого слоя. При выборе значения «Все выкл.» рендеринг выполняется так, как если бы все переключатели режима «Соло» были отключены. (См. раздел Включение режима «Соло» для слоя.)

Слои направляющих

При выборе параметра «Текущие настройки» выполняется рендеринг слоев направляющих в композиции верхнего уровня. При выборе параметра «Все выкл.» (по умолчанию) рендеринг слоев направляющих не выполняется. Рендеринг слоев направляющих во вложенных композициях не выполняется. (См. раздел Слои направляющих.)

Разрядность цвета

При выборе параметра «Текущие настройки» (по умолчанию) используется разрядность проекта. (См. раздел Разрядность цвета и расширенный динамический диапазон цветов.)

Наложение кадров

Выбор параметра «Вкл. для проверенных слоев» приводит к рендерингу наложения кадров только для слоев с установленным переключателем «Наложение кадров» независимо от состояния параметра «Наложение кадров» для композиции. (См. раздел Наложение кадров.)

Рендеринг поля

Определяет метод рендеринга полей, используемый в рендеринге композиции. Установите этот параметр на значение «Выкл.» при рендеринге для фильма или для показа на экране компьютера. (См. раздел Чересстрочное видео и разделительные поля.)

Преобразование 3:2

Определяет фазу преобразования сторон 3:2. (См. раздел Преобразование 3:2.)

Размытие в движении

«Текущие настройки» используют текущие настройки для переключателя слоя «Размытие в движении» и для переключателя композиции «Включить размытие в движении». Выбор параметра «Вкл. для проверенных слоев» запускает рендеринг размытия в движении только для слоев с установленным переключателем слоя «Размытие в движении» независимо от параметра «Включить размытие в движении» для композиции. Выбор параметра «Выкл. для всех слоев» выполняет рендеринг всех слоев без размытия движения независимо от положения переключателей слоев и настроек переключателя композиции. (См. раздел Размытие в движении.)

Временной диапазон

Определяет, какая часть композиции будет обработана при рендеринге. Для выполнения рендеринга всей композиции выберите значение «Длина композиции». Для рендеринга только части компоновки, указанной с помощью маркеров рабочей области, выберите значение «Только рабочая область». Для указания временного диапазона вручную выберите «Вручную». (См. раздел Рабочая область.)

Частота кадров

Частота кадров, используемая при рендеринге фильмов. Выберите значение «Частота кадров композиции» для использования частоты кадров, заданной в диалоговом окне «Настройки композиции», или выберите «Использовать другое значение частоты» для выбора другой частоты. Фактическая частота кадров композиции не меняется. Частота кадров окончательного кодированного видеофрагмента определяется настройками модуля вывода. (См. раздел Частота кадров.)

Пропустить существующие файлы

Позволяет выполнить повторный рендеринг части набора файлов, не теряя времени на обработку уже визуализированных кадров. При выполнении рендеринга набора файлов After Effects находит файлы, являющиеся частью данного набора, идентифицирует недостающие кадры и выполняет рендеринг только этих кадров, вставляя их в соответствующие места набора. Можно также использовать этот параметр для рендеринга набора изображений на нескольких компьютерах. (См. раздел Рендеринг набора неподвижных изображений на нескольких компьютерах.)

Примечание.

Текущий набор изображений должен иметь те же имя, номер стартового кадра, частоту кадров и временной промежуток, что и существующий набор изображений. Рендеринг необходимо проводить в папку с уже обработанными кадрами.

Модули вывода и их параметры

Настройки модуля вывода применяются к каждому элементу рендеринга и определяют процедуру окончательной обработки фильма. Используйте настройки модуля вывода для указания формата файла, профиля цвета вывода, параметров сжатия и других параметров экспорта.

Также можно использовать настройки модуля вывода для обрезки, растяжения или сжатия изображения в фильме; часто бывает полезно выполнять такие действия после процедуры рендеринга, если требуется сгенерировать несколько версий выходного файла из одной композиции.

Настройки модуля вывода применяются к визуализируемому выходному видеофрагменту, который создается в соответствии с параметрами рендеринга.

Для некоторых форматов после выбора формата в диалоговом окне «Настройки модуля вывода» открывается дополнительное диалоговое окно. Эти настройки можно изменять, а также применять готовые наборы настроек для установки параметров, связанных с конкретным форматом, например, параметров сжатия.

К одному элементу рендеринга можно применять несколько модулей вывода, что позволяет создать несколько версий фильма из одного файла рендеринга. Например, можно автоматизировать создание фильма и подложки альфа-канала для него, а также создать версии фильма с высоким и низким разрешением.

Примечание.

Перед началом рендеринга проверьте настройки выходного аудио в диалоговом окне «Настройки модуля вывода». Для рендеринга аудио нужно выбрать параметр «Вывод аудио». Если композиция не содержит аудио, не выбирайте параметр «Вывод аудио», чтобы без необходимости не увеличивать размер выходных файлов.

Настройки рендеринга

Вы можете одновременно задавать модуль вывода для нескольких элементов очереди рендеринга. Выберите элементы очереди рендеринга, а затем выберите шаблон модуля вывода из меню «Настройки модуля вывода» для одного из элементов.

Можно перетащить модуль вывода на панель «Проект» для импорта готового фильма или местозаполнитель в проект для использования в качестве элемента видеоряда. (См. раздел Импорт элементов видеоряда.)

На веб-сайте Video Copilot представлено видеоруководство Эндрю Крамера (Andrew Kramer) с полезными советами по работе с прокси, модулями вывода и шаблонами модуля вывода.

Изменение настроек модуля вывода

  • Чтобы изменить настройки модуля вывода для элемента рендеринга, щелкните подчеркнутое имя шаблона настроек модуля вывода рядом с заголовком «Модуль вывода» на панели «Очередь рендеринга» и выберите настройки в диалоговом окне «Настройки модуля вывода».
  • Чтобы применить шаблон настроек модуля вывода к выбранным элементам рендеринга, щелкните треугольник рядом с заголовком «Модуль вывода» на панели «Очередь рендеринга» и выберите шаблон из меню.

    Можно выбрать пользовательский шаблон настроек модуля вывода или один из предустановленных шаблонов настроек модуля вывода. Предусмотрено несколько шаблонов, включая шаблон «Без потерь» для создания фильмов с последующим переносом в видео, на пленку или в систему NLE.

Примечание.

Шаблон настроек модуля вывода по умолчанию присваивается элементу рендеринга в момент его создания. Для изменения шаблона настроек модуля вывода по умолчанию удерживайте нажатой клавишу CTRL (Windows) или COMMAND (Mac OS) при выборе шаблона настроек модуля вывода из меню.

Примечание.

Для изменения настроек для нескольких модулей вывода одновременно выделите модули вывода и затем выберите шаблон модуля вывода. Шаблон применяется ко всем выделенным модулям вывода.

Создание, изменение и редактирование шаблонов модуля вывода

В диалоговом окне «Шаблоны модуля вывода» выполняются следующие задачи. Для открытия диалогового окна «Шаблоны модуля вывода» выберите команду «Правка» > «Шаблоны» > «Модуль вывода» или щелкните треугольник рядом с заголовком «Модуль вывода» на панели «Очередь рендеринга» и выберите команду «Создать шаблон».

  • Для создания нового шаблона настроек модуля вывода нажмите «Создать», задайте настройки модуля вывода и щелкните «ОК». Введите имя нового шаблона.
  • Для редактирования существующего шаблона настроек модуля вывода, выберите шаблон из меню «Имя настроек», щелкните «Правка» и задайте настройки модуля вывода.

Примечание.

Изменения существующего шаблона не влияют на элементы рендеринга, уже находящиеся в очереди.

  • Чтобы указать, какой из шаблонов настроек модуля вывода будет использоваться при обработке фильмов, отдельных кадров, предпросмотра, предварительно визуализированных фильмов и прокси по умолчанию, выберите шаблон из меню в области «Настройки по умолчанию» в диалоговом окне «Шаблоны модуля вывода».
  • Для сохранения всех загруженных шаблонов модуля вывода в файл щелкните «Сохранить все».
  • Для загрузки сохраненного файла шаблонов модуля вывода нажмите «Загрузить», выберите файл шаблонов модуля вывода и затем нажмите «Открыть».

Добавление и удаление модулей вывода к элементам рендеринга

  • Для добавления нового модуля вывода с настройками по умолчанию к одному элементу рендеринга щелкните знак плюса (+) слева от заголовка «Вывод в» последнего модуля вывода для элемента рендеринга.
  • Для удаления модуля вывода из элемента рендеринга нажмите знак минуса (-) слева от заголовка «Вывод в» последнего модуля вывода для элемента рендеринга.
  • Для добавления нового модуля вывода с настройками по умолчанию к выделенным элементам рендеринга выберите «Композиция» > «Добавить модуль вывода».
  • Для создания копии выделенных модулей вывода нажмите CTRL+D (Windows) или COMMAND + D (Mac OS).

Настройки модуля вывода

Информацию об использовании элементов управления в области «Управление цветом» диалогового окна «Настройки модуля вывода» см. в разделе Назначение профиля цвета вывода.

Формат

Определяет формат выходного файла или набора файлов.

Включить ссылку на проект

Указывает, следует ли включать в выходной файл информацию со ссылкой на исходный проект After Effects. При открытии выходного файла в другом приложении, например Adobe Premiere Pro, можно использовать команду «Редактировать оригинал» для редактирования исходного проекта в After Effects.

Включить исходные метаданные XMP

Указывает, следует ли включать метаданные XMP в выходной файл из файлов, используемых в качестве источников для визуализируемой композиции. Метаданные XMP могут передаваться по всей цепочке последовательных файлов в After Effects от исходных файлов к элементам видеоряда и композициям, в файлы рендеринга и экспортируемые файлы. Во всех шаблонах модулей вывода параметр «Включить исходные метаданные XMP» по умолчанию отключен. (См. раздел Экспорт метаданных XMP из After Effects.)

Действие по завершении рендеринга

Определяет действия After Effects после окончания рендеринга композиции. (См. раздел Действие по завершении рендеринга.)

Параметры формата

Открывает диалоговое окно, в котором задаются параметры, связанные с конкретным форматом.

Каналы

Выходные каналы, содержащиеся в выходном фильме. При выборе параметра «Цветовое пространство RGB + альфа-канал» с разрядностью, указанной в параметре «Миллионы цветов+» After Effects создает фильм с альфа-каналом. Не все кодеки поддерживают альфа-каналы.

Примечание.

Все файлы, созданные с разрядностью цвета «Миллионы цветов+», «Триллионы цветов+» или «Плавающая точка+», имеют маркированные альфа-каналы; информация об альфа-канале сохраняется в файле. Поэтому нет необходимости задавать интерпретацию альфа-канала каждый раз при импорте элемента, созданного в After Effects.

Разрядность

Задает разрядность цвета для выходного фильма. Некоторые форматы могут ограничивать разрядность и настройки цвета.

Цвет

Определяет способ передачи цветов с альфа-каналом. Выберите «Предварительно умноженный (с подложкой)» или «Обычный режим (без подложки)». (См. раздел Интерпретация альфа-канала: в прямом или обратном порядке.)

Начальный номер

Определяет номер начального кадра набора. Например, если данный параметр имеет значение 38, After Effects присваивает первому кадру имя [имя_файла]_00038. Параметр «Использовать номер кадра композиции» добавляет номер начального кадра в рабочей области к начальному кадру набора.

Изменить размер

Определяет размер выходного файла фильма. Выберите «Зафиксировать пропорции», если требуется сохранить существующие пропорции кадра при изменении размера. Выберите «Низкое качество при изменении размеров» при обработке тестовых фрагментов или «Высокое качество при изменении размеров» при создании конечного варианта фильма. (См. раздел Уменьшение масштаба фильма и Увеличение масштаба фильма.)

Обрезка

Используется для удаления или добавления строк или столбцов пикселей к краям выходных фильмов. Можно указать число строк или столбцов пикселей, которые будут добавлены или удалены сверху, слева, снизу или справа в кадре фильма. Положительные значения параметров приводят к обрезке, а отрицательные — к добавлению строк или столбцов пикселей. Выберите «Видимая область» для экспорта только необходимой области, выделенной на панели «Композиция» или «Слой». (См. раздел Видимая область.)

Примечание.

Добавляя одну строку пикселей сверху и убирая одну строку в нижней части кадра, можно изменить порядок полей.

Вывод аудио

Определяет частоту дискретизации, разрядность (8 бит или 16 бит) и формат воспроизведения (стерео или моно). Выберите частоту дискретизации, которая соответствует свойствам выходного формата. Разрядность дискретизации 8 бит рекомендуется выбирать для воспроизведения на компьютере, разрядность 16 бит — при воспроизведении CD и цифрового аудио или для устройств, которые поддерживают 16-разрядное воспроизведение.

Примечание.

Спецификации некоторых форматов создают ограничения для параметров аудио. В таких случаях соответствующие параметры аудио могут быть недоступны для изменения в диалоговом окне модуля вывода. Кроме того, параметры аудио для некоторых форматов задаются в диалоговом окне настроек экспорта для этих форматов. Например, чтобы задать параметры вывода аудио для Windows Media, щелкните «Параметры формата» в диалоговом окне «Настройки модуля вывода».

Предупреждение о несоответствии частоты кадров или размеров

В некоторых форматах применяются ограничения на размеры кадра или частоту кадров.

При выборе такого выходного формата с ограничениями и несоответствии настроек композиции, рендеринга или модуля вывода этим ограничениям в нижней части диалогового окна настроек модуля вывода After Effects отображается желтый значок предупреждения и сообщение «Несоответствие параметров».

Щелкните значок предупреждения для просмотра подробного сообщения, в котором описывается, какие изменения будут внесены в выходной файл для обеспечения его соответствия ограничениям формата. Можно вернуться назад и изменить параметры композиции, рендеринга и модуля вывода, чтобы After Effects не вносил изменения в модуль вывода автоматически.

Дополнительные сведения об ограничениях в модуле экспорта и предупреждениях о несоответствии частоты кадров, размеров и пропорций пикселя можно найти на на веб-сайте Adobe.

Параметры кодирования и сжатия фильмов

Сжатие необходимо для уменьшения размера фильмов с целью повышения эффективности хранения, передачи и воспроизведения. Сжатие выполняется кодировщиком; распаковка данных выполняется декодером. Для кодировщиков и декодеров используется общий термин «кодек». Ни один кодек или набор параметров не является идеальным для всех случаев. Например, кодек, наиболее подходящий для сжатия мультипликационных фильмов, обычно не подходит для сжатия видео с натуральным движением. Аналогично, оптимальный кодек для воспроизведения по медленному сетевому каналу, как правило, не подходит для промежуточной стадии процесса подготовки фильма. Дополнительные сведения о стратегии и планировании процесса работы с фильмом с учетом требований для конечного вывода можно найти в разделе Планирование работы.

After Effects использует встроенную версию Adobe Media Encoder для кодирования большинства форматов фильмов в панели «Очередь рендеринга». При выполнении рендеринга и экспорта с помощью панели «Очередь рендеринга» встроенная версия Adobe Media Encoder вызывается автоматически. Adobe Media Encoder в этом случае отображается только в форме диалоговых окон настройки экспорта, в которых можно задавать некоторые параметры кодирования и вывода.

Примечание.

Встроенная версия Adobe Media Encoder, используемая для управления параметрами экспорта в модулях вывода After Effects, не поддерживает всех возможностей полного, автономного приложения Adobe Media Encoder. Сведения о полном автономном приложении Adobe Media Encoder см. в справке Adobe Media Encoder.

Для большинства выходных форматов можно указать специфические для них параметры кодирования и сжатия. Во многих случаях открывается диалоговое окно и отображаются эти параметры при выборе соответствующего формата экспорта или нажатии кнопки «Параметры формата» в диалоговом окне «Модуль вывода». (См. раздел Модули вывода и их параметры.)

Настройки кодирования и сжатия QuickTime (MOV)

  1. На панели «Очередь рендеринга» щелкните подчеркнутое имя модуля вывода.
  2. В меню «Формат» выберите QuickTime.
  3. Нажмите «Параметры формата» в разделе «Вывод видео».
  4. В диалоговом окне «Параметры QuickTime» выберите кодек и настройте параметры в соответствии с особенностями конкретного кодека и требованиями к файлу видео:

    Качество

    Более высокое значение параметра качества обеспечивает более высокое качество, но ведет к увеличению размера файла фильма.

    Частота ключевых кадров

    В терминологии QuickTime термин «Ключевые кадры» применяется в ином значении, чем аналогичный термин, используемый для обозначения определенных сменяемых во времени кадров на панели «Таймлайн» After Effects. В QuickTime ключевые кадры — это кадры, которые появляются в фильме через одинаковые интервалы времени. Во время сжатия они сохраняются как полноценные кадры. Каждый кадр между ключевыми сравнивается с предыдущим кадром и хранит только изменения картинки. Использование ключевых кадров приводит к чувствительному снижению размера фильма и значительному увеличению объема памяти, необходимой для редактирования и рендеринга ролика. Сокращение интервалов между ключевыми кадрами позволит быстрее производить поиск и воспроизведение в обратную сторону, но может значительно увеличить размер файла.

    Переупорядочивание кадров

    Некоторые кодеки поддерживают возможность кодирования и декодирования кадров не по порядку для обеспечения их более экономного хранения.

    Примечание. Дополнительную информацию о приложении QuickTime см. на веб-сайте компании Apple.

     

  5. Нажмите кнопку «ОК».
  6. Укажите другие параметры в диалоговом окне «Настройки модуля вывода».

Действия по завершении рендеринга

Для автоматизации некоторых простых задач, необходимых после завершения рендеринга, можно указать действия, выполнение которых будет происходить по завершении рендеринга.

Распространенным примером использования этой функции является предварительный рендеринг. Выбор команды «Композиция» > «Предварительный рендеринг» добавляет выделенную композицию в очередь рендеринга и устанавливает для параметра «Действия по завершении рендеринга» значение «Импорт и замена».

Примечание.

При выборе параметра «Действия по завершении рендеринга» в группе «Модуль вывода» следует иметь в виду, что изменение шаблона модуля вывода может привести также к изменению параметра «Действия по завершении рендеринга». (См. раздел Модули вывода и их параметры.)

  1. Разверните группу «Модуль вывода» на панели «Очередь рендеринга», щелкнув стрелку слева от заголовка «Модуль вывода».
  2. Выберите в меню «Действия по завершении рендеринга» один из следующих пунктов.

    Нет

    Не выполняет каких-либо операций после окончания рендеринга. Этот вариант выбран по умолчанию.

    Импорт

    По завершении рендеринга импортирует обработанный файл в проект как элемент видеоряда.

    Импорт и замена использования

    Импортирует обработанный файл в проект и заменяет его для указанного элемента. Перетащите инструмент «Лассо» к элементу, который требуется заменить на панели «Проект».

    Примечание.

    Используйте параметр «Импорт и замена использования» для создания цепочки зависимых элементов рендеринга. Например, можно настроить один элемент рендеринга для использования папки отслеживания и обработки с помощью нескольких компьютеров для создания набора неподвижных изображений, затем с помощью следующего элемента рендеринга можно монтировать из этого набора изображений один видеофайл. (См. раздел Рендеринг по сети с использованием папки отслеживания и нескольких ядер рендеринга.)

    Задать прокси

    Задает обработанный файл в качестве прокси для указанного элемента. Перетащите инструмент «Лассо» к элементу на панели «Проект», чтобы выбрать его.

Эта работа лицензируется в соответствии с лицензией Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported  На посты, размещаемые в Twitter™ и Facebook, условия Creative Commons не распространяются.

Правовые уведомления   |   Политика конфиденциальности в сети Интернет