Grafik veya belge en iyi hale getirildikten sonra, belgeyi dışa aktarabilirsiniz (ya da orijinal dosya türüne bağlı olarak kaydedebilirsiniz).

Bir belgeyi, GIF, JPEG veya başka bir grafik dosyası formatı içinde tek bir görüntü olarak dışa aktarabilirsiniz (ya da bazı durumlarda, kaydedebilirsiniz). Ayrıca, tüm belgeyi bir HTML dosyası ve ilişkili görüntü dosyaları, yalnızca seçili dilimler veya belirtilen alan olarak da dışa aktarabilirsiniz. Ek olarak, Fireworks durumları ve katmanlarını ayrı görüntü dosyaları olarak da dışa aktarabilirsiniz.

Fireworks uygulamasının dosyaları dışa aktardığı varsayılan konum, aşağıdakilere göre şu sırayla belirlenir:

  1. Belgenin geçerli dışa aktarma tercihi; belgeyi daha önce dışa aktarıp ardından PNG'yi kaydettiyseniz tanımlanır

  2. Kaydet, Farklı Kaydet veya Dışa Aktar iletişim kutusunda, varsayılan konumdan her gözattığınızda tanımlanan, geçerli dışa aktar/kaydet konumu

  3. Geçerli dosyanın konumu

  4. İşletim sisteminizde yeni belgelerin veya görüntülerin kaydedildiği varsayılan konum

    Dışa aktarmanın aksine, Fireworks uygulamasının bir belgeyi kaydettiği varsayılan konum başka ölçütlerle belirlenir. Daha fazla bilgi için bkz. Fireworks dosyalarını kaydetme.

Sayfaları görüntü dosyaları olarak dışa aktarma

  1. Dosya > Dışa Aktar'ı seçin.

  2. Dışa aktarılacak dosyalar için konum seçin.

  3. Aşağıdakilerden birini yapın:

    • Dışa Aktar açılır menüsünden Sadece Görüntüler'i seçin ve Sadece Geçerli Sayfa onay kutusunu seçin veya seçimini kaldırın. Sayfalar, En iyileştir panelinde ayarlanan görüntü formatlarına dışa aktarılır.

    • Dışa Aktar açılır menüsünde Sayfalar Dosyaya'yı seçin ve Dışa Farklı Aktar açılır menüsünde Görüntüler'i seçin. Sayfalar, En iyileştir panelinde ayarlanan görüntü formatlarına dışa aktarılır

    • Dışa Aktar açılır menüsünde Sayfalar Dosyaya'yı seçin ve Dışa Farklı Aktar açılır menüsünde Fireworks PNG'yi seçin. Her sayfa, Fireworks 8 ile geriye doğru uyumlu ayrı bir PNG dosyası olarak dışa aktarılır.

    Not:

    Seçilen formattaki tüm sayfaları dışa aktarmak istiyorsanız, sayfaların tümünü seçin ve ardından ayarları en iyileştirin.

Tek bir görüntüyü dışa aktarma

Fireworks uygulamasında açtığınız mevcut bir görüntüyle çalışıyorsanız, bu görüntüyü dışa aktarma yerine kaydedebilirsiniz. Daha fazla bilgi için, bkz. Belgeleri diğer formatlarda kaydetme.

Not:

Bir belgedeki yalnızca belirli görüntüleri dışa aktarmak için, öncelikle belgenizi dilimlemeli ve ardından yalnızca istediğiniz dilimi dışa aktarmalısınız.

  1. En İyileştir panelinde, bir dosya formatı seçin ve formata özel seçenekleri ayarlayın.

  2. Dosya > Dışa Aktar'ı seçin.

  3. Görüntü dosyasını dışa aktaracağınız bir konum seçin.

    Web grafikleri için, en iyi konum genel olarak yerel web siteniz içindeki bir klasördür.

  4. Uzantısız bir dosya adı girin. Dışa aktarma sırasında dosya türüne dayanan bir uzantı eklenir.

  5. Dışa Aktar açılır menüsünden Sadece Görüntüler'i seçin.

  6. Kaydet'i tıklatın.

Dilimli bir belgeyi dışa aktarma

Varsayılan değer olarak, dilimli bir Fireworks belgesini dışa aktardığınızda, bir HTML dosyası ve ilişkilendirilmiş görüntüler dışa aktarılır. Dışa aktarılan HTML dosyası, bir web tarayıcıda görüntülenebilir ya da daha ileri düzenleme için diğer uygulamalara içe aktarılabilir.

Dışa aktarmadan önce, HTML Ayarı iletişim kutusunda uygun HTML stilinin seçili olduğundan emin olun. Bkz. HTML dışa aktarma seçeneklerini ayarlama.

Tüm dilimleri dışa aktarma

  1. Dosya > Dışa Aktar'ı seçin.

  2. Dışa aktarma yapılacak sabit diskinizin bir klasörüne gelin.

  3. Dışa Aktar açılır menüsünden HTML ve Görüntüler'i seçin.

  4. Dosya Adı (Windows) veya Farklı Kaydet (Mac OS) kutusuna bir dosya adı girin.

  5. HTML açılır menüsünden HTML Dosyasını Dışa Aktar'ı seçin.

  6. Dilimler açılır menüsünden Dilimleri Dışa Aktar'ı seçin.

  7. (İsteğe bağlı) Görüntüleri Alt Klasöre Koy'u seçin.

  8. Kaydet'i tıklatın.

Seçili dilimleri dışa aktarma

  1. Birden çok dilim seçmek için Shift tuşuna basılı tutup tıklatın.

  2. Dosya > Dışa Aktar'ı seçin.

  3. Dışa aktarılan dosyaların saklanacağı, yerel web siteniz içindeki bir klasör gibi bir konum seçin.

  4. Dışa Aktar açılır menüsünden HTML ve Görüntüler'i seçin.

  5. Uzantısız bir dosya adı girin. Dışa aktarma sırasında dosya türüne dayanan bir uzantı eklenir.

    Birden çok dilimi dışa aktarıyorsanız, Fireworks, kök adı olarak girdiğiniz adı, Katmanlar paneli veya Özellik denetçisini kullanarak özel adlandırdıklarınız hariç, dışa aktarılan tüm grafikler için kullanır.

  6. Dilimler açılır menüsünden Dilimleri Dışa Aktar'ı seçin.

  7. Yalnızca dışa aktarmadan önce seçtiğiniz dilimleri dışa aktarmak için, Sadece Seçilen Dilimler'i seçin ve Dilimleri Olmayan Alanları Dahil Et seçeneğinin seçili olmadığından emin olun.

  8. Kaydet'i tıklatın.

Bir dilimi güncelleme

Dilimli bir belgeyi henüz dışa aktardıysanız ve Fireworks uygulamasında orijinal belgede sonradan değişiklikler yaptıysanız, yalnızca görüntüyü veya değişen dilimi güncelleyebilirsiniz. Değiştirme dilimini konumlandırmayı kolaylaştırmak için ad dilimlerini özelleştirin.

  1. Dilimi gizleyin ve altındaki alanı düzenleyin.

  2. Dilimi tekrar gösterin.

  3. Dilimi sağ tıklatın (Windows) veya Control (Mac OS) tuşunu basılı tutup tıklatın ve Seçili Dilimleri Dışa Aktar'ı seçin.

  4. Aynı taban adını kullanan orijinal dilimle aynı klasörü seçin ve Kaydet'i tıklatın.

  5. Mevcut dosyayı değiştirmek mi istediğiniz sorulduğunda Tamam'ı tıklatın.

    Not:

    Dilimi, Fireworks uygulamasındaki orijinal dışa aktarma boyutunun ötesinde yeniden boyutlandırmayı engelleyin, aksi halde, dilim güncellendikten sonra, HTML belgesinde beklenmeyen sonuçlar oluşturabilirsiniz.

Bir animasyonu dışa aktarma

Oluşturulma ve en iyileştirmeden sonra, animasyon dışa aktarmaya hazırdır. Bir animasyonu aşağıdaki dosya türlerinden herhangi birisi olarak dışa aktarabilirsiniz:

Animasyonlu GIF'ler

Bunlar küçük resim ve karikatür benzeri grafikler için en iyi sonuçları verir.

Flash SWF veya Fireworks PNG (dışa aktarma gerekmez)

Bir animasyonu Flash uygulamasına içe aktarmak için SWF dosyası olarak dışa aktarın. Ayrıca, bir Fireworks PNG kaynak dosyasını doğrudan Flash uygulamasına içe aktararak dışa aktarma adımını atlayabilirsiniz. Bu doğrudan yöntemi kullanarak tüm katmanları ve animasyonunuzun durumlarını içe aktarabilir ve ardından, onları daha sonra Flash içinde düzenleyebilirsiniz. Bkz. Flash ile çalışma.

Çoklu dosyalar

Aynı nesne için farklı katmanlar üzerinde birçok sembolünüz olduğunuzda, animasyon durumlarını veya katmanlarını çoklu dosyalar olarak dışa aktarmak faydalıdır. Örneğin, şirket adının her harfi bir grafik içinde canlandırılmışsa bir bant reklamını çoklu dosyalar olarak dışa aktarabilirsiniz. Bkz. Durumları veya katmanları çoklu dosyalar olarak dışa aktarma.

Belgeniz birden fazla animasyon içeriyorsa bir animasyonu dışa aktarmak için döngü ve durum gecikmesi gibi farklı animasyon ayarları kullanarak her animasyona dilimler ekleyebilirsiniz.

Bir animasyonlu GIF dosyasını dışa aktarma

  1. Tüm dilim ve nesnelerin seçimini kaldırmak için Seç > Seçimi Kaldır'ı seçin ve En İyileştir panelinde dosya formatı olarak Animasyonlu GIF'i seçin.

  2. Dosya > Dışa Aktar'ı seçin.

  3. Dosya için bir ad yazın ve hedefi seçin.

  4. Kaydet'i tıklatın.

Birden çok animasyonlu GIF'i farklı animasyon ayarlarıyla dışa aktarma

  1. Tümünü seçmek için Shift tuşunu basılı tutup animasyonları tıklatın.

  2. Düzenle > Ekle > Dikdörtgen Dilim'i veya Çokgen Dilim'i seçin.

  3. İleti kutusunda, Çoklu'yu tıklatın.

  4. Her dilimi tek tek seçin ve her birine farklı animasyon ayarları belirlemek için Durumlar panelini kullanın.

  5. Canlandırmak istediğiniz tüm dilimleri seçin ve En İyileştir panelinde dosya formatı olarak Animasyonlu GIF'i seçin.

  6. Her dilimi sağ tıklatın (Windows) veya Control (Mac OS) tuşunu basılı tutup tıklatın ve her dilimi tek tek dışa aktarmak için Seçili Dilimleri Dışa Aktar'ı seçin. Dışa Aktar iletişim kutusunda, her dosya için bir ad girin, hedefi seçin ve Kaydet'i tıklatın.

Durumları veya katmanları birden fazla dosya halinde dışa aktarma

Fireworks, bir belgedeki her bir katman veya durumu ayrı bir görüntü dosyası olarak dışa aktarabilir ve En İyileştir panelinde belirlenen en iyileştirme ayarlarını kullanabilir. Katman veya durumun adı, dışa aktarılan her dosyanın dosya adını belirler. Bu dışa aktarma yöntemi bazen animasyonları dışa aktarmak için kullanılır.

  1. Dosya > Dışa Aktar'ı seçin.

  2. Bir dosya adı girin ve bir hedef klasör seçin.

  3. Dışa Aktar açılır menüsünde bir seçenek belirleyin:

    Durumlar Dosyaya

    Durumları birden çok dosya halinde dışa aktarır.

    Katmanlar Dosyaya

    Katmanları birden çok dosya halinde dışa aktarır.

    Not: Bu eylem, geçerli durumdaki tüm katmanları dışa aktarır.

  4. Yalnızca her durum üzerindeki nesnelere dahil etmek üzere dışa aktarılan her görüntüyü otomatik olarak kırpmak için Görüntüleri Kes'i seçin. Tüm tuvali dahil etmek için ise (nesnelerin dışındaki boş alanlar dahil), bu seçeneğin seçimini kaldırın.

  5. Kaydet'i tıklatın.

Bir belgeden bir alanı dışa aktarma

  1. Araçlar panelinden Alanı Dışa Aktarma aracını seçin.

  2. Belgenin dışa aktarılacak bölümünü tanımlayacak bir seçim çerçevesi sürükleyin.

    Not:

    Seçim çerçevesinin konumunu sürüklerken ayarlayabilirsiniz. Fare düğmesini basılı tutarken, boşluk çubuğunu basılı tutun, ve ardından seçim çerçevesini tuval üzerinde başka bir konuma sürükleyin. Seçim çerçevesini çizmeye devam etmek için Boşluk Çubuğu'nu bırakın.

    Fare düğmesini bıraktığınızda, dışa aktarma alanı seçili kalır.

  3. Gerekliyse dışa aktarma alanını yeniden boyutlandırın:

    • Dışa aktarma alanı seçim çerçevesini orantılı olarak yeniden şekillendirmek için Shift tuşuna basılı tutup tutamaçlardan birini sürükleyin.

    • Seçim çerçevesini merkez noktadan başlayarak yeniden boyutlandırmak için, tutamaçlardan birini Alt (Windows) veya Option (Mac OS) tuşunu basılı tutarak sürükleyin.

    • Oranları sınırlamak ve merkez noktadan başlayarak yeniden boyutlandırmak için, tutamaçlardan birini Alt (Windows) veya Option (Mac OS) tuşunu basılı tutarak sürükleyin.

  4. Görüntü Önizleme'ye gitmek için dışa aktarma alanı seçim çerçevesinin içini çift tıklatın.

  5. Görüntü Önizleme'de ayarları düzenleyin ve Dışa Aktar'ı tıklatın.

  6. Bir dosya adı girin ve bir hedef klasör seçin.

  7. Dışa Aktar açılır menüsünde Sadece Görüntüler'i seçin.

  8. Kaydet'i tıklatın.

    Not:

    Dışa aktarmadan iptal etmek için dışa aktarma alanı seçim çerçevesinin dışını çift tıklatın, Escape tuşuna basın ya da başka bir araç seçin.

HTML'yi dışa aktarma

Başka türlü belirlemezseniz, dilimli bir Fireworks belgesini dışa aktardığınızda, dışa aktardığınız bir HTML dosyası ve onun görüntüleridir. Fireworks uygulamasının HTML'yi nasıl dışa aktaracağını tanımlamak için HTML Ayarı iletişim kutusunu kullanırsınız.

Fireworks, çoğu web tarayıcı ve HTML düzenleyici tarafından okunabilen saf HTML oluşturur. Varsayılan olarak, dışa aktarma UTF-8 kodlamalı belirler.

Fireworks HTML dosyasını dışa aktarmanın çeşitli yolları vardır:

  • Bir HTML düzenleyicide düzenlemek için daha sonra açabileceğiniz bir HTML dosyasını dışa aktarın.

  • Bir Fireworks dosyasındaki her sayfayı ayrı bir HTML dosyasına dışa aktarın.

  • HTML kodunu Fireworks uygulamasındaki Pano'ya kopyalayın ve ardından bu kodu doğrudan mevcut bir HTML belgesine yapıştırın.

  • Bir HTML dosyasını dışa aktarın, bunu bir HTML düzenleyicide açın, dosyadan kod bölümlerini elle kopyalayın ve bu kodu başka bir HTML belgesine yapıştırın.

  • HTML'yi Geçişli Stil Sayfası (CSS) katmanları veya XHTML olarak da dışa aktarın.

  • Daha önceden oluşturduğunuz bir HTML dosyasına değişiklikler yapmak için HTML'yi Güncelle komutunu kullanın.

    Fireworks, HTML'yi Generic, Dreamweaver, Microsoft® FrontPage® ve Adobe GoLive® formatlarında dışa aktarmanıza olanak sağlar.

    Not:  Adobe Dreamweaver ile Fireworks arasında sıkı bir entegrasyon kurulmuştur. Fireworks, HTML'nin Dreamweaver uygulamasına dışa aktarılmasını diğer HTML düzenleyicilere dışa aktarılmasından farklı biçimde ele alır. Fireworks HTML'yi Dreamweaver uygulamasına dışa aktarıyorsanız, bkz. Dreamweaver uygulamasıyla çalışma.

    Bir ekip ortamında çalışıyorsanız, Fireworks HTML'yi diğer uygulamalara aktarmak için ideal yöntem dışa aktarmadır. Bu yöntem, iş akışını parçalara böler, böylece bir kişi bir görevi bir uygulamada gerçekleştirebilir ve daha sonra başka biri başka bir uygulama kullanarak bu görevi üzerine alabilir.

Dışa aktarılan HTML'ye açıklamalar dahil etme

Fireworks HTML açıklamaları <!--ile başlar ve --> ile sonlanır. Bu iki işaret arasındaki hiçbir şey HTML veya JavaScript kodu olarak yorumlanmaz.

  1. Dışa aktarmadan önce, HTML Ayarı iletişim kutusunun Genel sekmesinde HTML Yorumlarını Dahil Et'i seçin.

Dışa aktarmanın sonuçları

Fireworks uygulamasında HTML dışa aktarıyor veya kopyalıyorsanız, aşağıdakiler oluşturulur:

  • Belge etkileşimli öğeler içeriyorsa dilimli görüntüleri ve herhangi bir JavaScript kodunu yeniden birleştirmek için HTML kodu zorunludur. Fireworks HTML, dışa aktarılan görüntülere bağlar içerir ve web sayfasının arka plan rengini tuval rengine ayarlar.

  • Belgenizde kaç dilim bulunduğuna ve düğmelere kaç durum dahil ettiğinize bağlı olarak, bir veya daha fazla görüntü dosyası.

  • Gerekliyse spacer.gif olarak adlandırılan bir dosya. Spacer.gif, dilimli görüntüler bir HTML tablosunda yeniden birleştirilirken Fireworks uygulamasının aralık sorunlarını düzeltmek için kullandığı saydam, 1-piksele 1–piksel bir GIF dosyasıdır. Fireworks uygulamasının bir boşluk ekleyiciyi dışa aktarmasını veya aktarmamasını seçebilirsiniz.

  • Herhangi bir açılır menüyü dışa aktarıyorsanız; aşağıdaki dosyalar dışa aktarılır: mm_css_menu.js ve CSS açılır menü kodu içeren bir .css dosyası. Açılır menüleriniz alt menüler içeriyorsa bir arrows.gif dosyası da dışa aktarılır.

  • HTML'yi Dreamweaver uygulamasına dışa aktarır veya kopyalarsanız, Fireworks ile Dreamweaver arasında tümleştirmeyi kolaylaştıran notlar dosyaları oluşturulur. Bu dosyalar .mno uzantısına sahip olur.

Fireworks HTML'yi dışa aktarma

  1. Dosya > Dışa Aktar'ı seçin.

  2. Dışa aktarma yapılacak sabit diskinizin bir klasörüne gelin.

  3. Dışa Aktar açılır menüsünden HTML ve Görüntüler'i seçin.

  4. Seçenekler düğmesini tıklatın ve HTML Ayarı iletişim kutusunun Genel sekmesindeki HTML Stili açılır menüsünden HTML düzenleyiciyi seçin. HTML düzenleyiciniz listelenmemişse Genel'i seçin.

    Not:

    HTML stili olarak HTML düzenleyicinizi seçmeniz önemlidir; böylece, düğme ve rollover'lar gibi etkileşimli öğeler HTML düzenleyicinize içe aktarıldığında düzgün çalışır.

  5. Tamam'ı tıklatın.

  6. HTML açılır menüsünden HTML Dosyasını Dışa Aktar'ı seçin.

  7. Belgeniz dilimler içeriyorsa Dilimler açılır menüsünden Dilimleri Dışa Aktar'ı seçin.

  8. Görüntüleri ayrı klasörlerde saklamak için Görüntüleri Alt Klasöre Koy'u seçin. Belirli bir klasör seçebilir veya Fireworks varsayılan Görüntüler klasörünü kullanabilirsiniz.

  9. Birden çok sayfalı bir Fireworks belgesini dışa aktarıyorsanız, tüm belgeleri ayrı HTML belgelerine dışa aktarmak için Sadece geçerli sayfa onay kutusunun seçimini kaldırın.

  10. Kaydet'i tıklatın.

    Dışa aktarımdan sonra, Fireworks uygulamasının dışa aktardığı dosyaları sabit diskinizde göreceksiniz. Görüntüler ve bir HTML dosyası, Dışa Aktar iletişim kutusunda belirlediğiniz konumda oluşturulur.

Pano'ya HTML kodu kopyalama

Fireworks uygulamasında HTML kodunu Pano'ya iki yoldan kopyalayabilirsiniz. HTML Kodunu Kopyala komutunu kullanın ya da alternatif olarak, Dışa Aktar iletişim kutusunda Pano'ya Kopyala'yı seçin. Daha sonra bu HTML'yi tercih ettiğiniz HTML düzenleyicinizde bir belgeye yapıştıracaksınız.

Fireworks HTML'nin diğer uygulamalar içine nasıl koyulacağını belirlerken, HTML kodunu Pano'ya kopyalamanın aşağıdaki şu dezavantajlarını unutmayın:

  • Görüntüleri bir alt klasöre kopyalama seçeneğiniz yoktur. Görüntülerin, kopyalanan HTML'yi yapıştırdığınız HTML dosyasıyla aynı klasörde bulunması gerekir. Dreamweaver uygulamasına kopyalanan HTML bir istisnadır.

  • Fireworks açılır menülerinde kullanılan bağlar veya yollar sabit diskinize eşlenecektir. Dreamweaver uygulamasına kopyalanan HTML bir istisnadır.

  • Dreamweaver veya Microsoft FrontPage dışında bir HTML düzenleyici kullanırsanız, düğmeler, davranışlar ve rollover görüntüleriyle ilişkilendirilen JavaScript kodu kopyalanır, fakat düzgün çalışmayabilir.

    Bu meseleler sizin için bir sorun oluşturuyorsa HTML'yi Pano'ya kopyalama yerine HTML'yi Dışa Aktar seçeneğini kullanın.

    Not: HTML kodunu kopyalamadan önce, uygun HTML stilini seçtiğinizden ve HTML Ayarları iletişim kutusunun Genel sekmesinden HTML Yorumlarını Dahil Et seçeneğini belirlediğinizden emin olun.

HTML Kodunu Kopyala seçeneğini kullanarak Fireworks HTML'yi kopyalama

  1. Düzenle > HTML Kodunu Kopyala'yı seçin.

  2. Sihirbazı izleyin. Dışa aktarılan görüntüler için hedef olarak istediğiniz bir klasörü belirleyin. Bu, HTML dosyanızın bulunacağı konum olmalı.

    Not:

    HTML kodunu Dreamweaver uygulamasına yapıştırmayı planlıyorsanız, görüntüler kodunuzu yapıştıracağınız HTML dosyası olarak aynı Dreamweaver sitesi içinde yer aldığı sürece, görüntüleri nereye dışa aktardığınız fark etmez.

Dışa Aktar iletişim kutusunu kullanarak Fireworks HTML'yi dışa aktarma

  1. Dosya > Dışa Aktar'ı seçin.

  2. Dışa Aktar iletişim kutusunda, dışa aktarılan görüntüler için hedef olarak bir klasör belirleyin. Bu, HTML dosyanızın bulunacağı konumla aynı olmalı.

    Not:

    HTML kodunu Dreamweaver uygulamasına yapıştırmayı planlıyorsanız, görüntüler, kodunuzu yapıştıracağınız HTML dosyası olarak aynı Dreamweaver sitesi içinde yer aldığı sürece, görüntüleri nereye dışa aktardığınız fark etmez.

  3. Dışa Aktar açılır menüsünden HTML ve Görüntüler'i seçin.

  4. HTML açılır menüsünden Pano'ya Kopyala'yı seçin.

  5. Belgeniz dilimler içeriyorsa Dilimler açılır menüsünden Dilimleri Dışa Aktar'ı seçin.

  6. Seçenekler düğmesini tıklatın, HTML Ayarı iletişim kutusundan HTML düzenleyicinizi seçin ve ardından Tamam'ı tıklatın.

  7. Kaydet'i tıklatın.

Fireworks uygulamasından kopyalanan HTML'yi bir HTML belgesine yapıştırma

  1. HTML düzenleyicinizde, mevcut bir HTML belgesini açın veya yeni bir belge oluşturun. Belgeyi, görüntülerinizi dışa aktardığınız konuma kaydedin.

    Not:

    Dreamweaver kullanıyorsanız, HTML dosyasını dışa aktarılan görüntülerle aynı konuma kaydetmek zorunlu değildir. Görüntüleri Fireworks uygulamasından bir Dreamweaver sitesine dışa aktardığınız ve HTML dosyasını bu site içinde bir konuma kaydettiğiniz sürece, Dreamweaver, yolları ilgili görüntülere dönüştürür.

  2. HTML kodunu görüntüleyin ve ekleme noktasını <BODY> etiketleri arasına yerleştirin.

    Not:

    Fireworks uygulamasından kopyalanan HTML kodu, açılış veya kapanış <HTML> ve <BODY> etiketlerini içermez.

  3. HTML kodunu yapıştırın.

    Mümkünse Pano'ya kopyaladığınızda, görüntüleri web sitesinde yer alacakları konuma dışa aktarın. Fireworks belgeye bağlı URL'ler kullanır, bu yüzden HTML veya görüntüler taşınırsa URL bağları koparılır.

Kodu, dışa aktarılan bir Fireworks dosyasından kopyalama ve bunu başka bir HTML belgesine yapıştırma

  1. Bir HTML düzenleyiciye dışa aktardığınız Fireworks HTML dosyasını açın.

  2. Gerekli kodu vurgulayın ve bunu Pano'ya kopyalayın.

  3. Mevcut bir HTML belgesi açın ya da yeni bir belge oluşturun.

  4. Kodu yeni HTML dosyası içine yapıştırın. <HTML> ve <BODY> etiketlerini kopyalamak zorunda değilsiniz, çünkü bunlar hedef HTML belgesinde zaten dahil edilmiş olmalıdır.

    Fireworks uygulamasında HTML Ayarı iletişim kutusunda HTML Yorumlarını Dahil Et'i seçtiyseniz, kodu uygun konuma kopyalayıp yapıştırmak için yorumlardaki talimatları izleyin.

  5. Fireworks belgeniz etkileşimli öğeler içeriyorsa JavaScript kodunu kopyalayın.

    JavaScript kodu <SCRIPT> etiketleriyle çevrelenmiştir ve belgenin <HEAD> bölümüne konumlanmıştır. Hedef belgenizde halihazırda bir <SCRIPT> bölümü yoksa tüm <SCRIPT> bölümünü kopyalayıp yapıştırın. Bu durumda, mevcut <SCRIPT> bölümüne,<SCRIPT> bölümünün yalnızca içeriklerini kopyalayıp yapıştırmalısınız, bunu yaparken mevcut bölümün içeriklerini üst üste yazmamaya dikkat edin. Ayrıca, kodu yapıştırdıktan sonra <SCRIPT> bölümünde çoğaltılmış JavaScript işlevleri olmadığından da emin olun.

Dışa aktarılan HTML'yi güncelleme

Güncelleme size daha önceden dışa aktardığınız bir Fireworks HTML dosyasında değişiklikler yapma olanağı sağlar ve belgenin yalnızca tek bir bölümünü güncellemenize yardımcı olur.

Not:

HTML'yi Güncelle, Dreamweaver belgeleriyle, diğer HTML belgeleriyle çalıştığından farklı bir biçimde çalışır. Daha fazla bilgi için, bkz. Dreamweaver uygulamasıyla çalışma.

Güncellerken, yalnızca değiştirilen görüntüleri değiştirmeyi seçebilirsiniz ya da tüm kod ve görüntülerin üstüne yazabilirsiniz. Yalnızca değiştirilen görüntüleri değiştirmeyi seçerseniz, Fireworks uygulamasının dışındaki HTML dosyasına yaptığınız tüm değişiklikler korunur.

Not:

Belge katmanına yapılacak önemli değişiklikler için, değişikliklerinizi Fireworks uygulamasında yapın ve HTML dosyasını yeniden dışa aktarın.

  1. Dosya > HTML'yi Güncelle'yi seçin.

  2. Güncellenecek dosyayı seçin.

  3. Aç'ı tıklatın.

  4. Aşağıdakilerden birini yapın:

    • Fireworks uygulamasında oluşturulan bir HTML bulunmazsa belgenin sonuna yeni HTML eklemek için Tamam'ı tıklatın.

    • Fireworks uygulamasında oluşturulmuş HTML bulunursa, aşağıdakilerden birini seçin ve Tamam'ı tıklatın.

      Görüntüleri ve Görüntülerin HTML'sini Değiştir

      Önceki Fireworks HTML'sini değiştirir

      Sadece Görüntüleri Güncelle

      Yalnızca görüntülerin üstüne yazar

  5. Görüntüler Klasörünü Seç iletişim kutusu görüntülenirse bir klasör seçin ve Aç'ı tıklatın.

CSS katmanlarını dışa aktarma

CSS katmanları üst üste binebilir ve bir katman bir diğerinin üstüne yığınlanabilir. Fireworks uygulamasında normal HTML çıktısı üst üste binmez.

  1. Dosya > Dışa Aktar'ı seçin.

  2. Bir dosya adı girin ve bir hedef klasör seçin.

  3. Dışa Aktar açılır menüsünden CSS Ve Görüntüler'i seçin.

    • Yalnızca geçerli durumu dışa aktarmak için Yalnızca Geçerli Durum'u seçin.

    • Yalnızca geçerli sayfayı dışa aktarmak için Yalnızca Geçerli Sayfa'yı seçin.

    • Görüntüler için bir klasör seçmek üzere Görüntüleri Alt Klasöre Koy'u seçin.

  4. HTML sayfası özelliklerini ayarlamak için Seçenekler'i tıklatın.

  5. Bir arka plan görüntüsü belirlemek için Gözat'ı tıklatın ve arka plan görüntüsü döşemeyi ayarlayın.

    • Görüntüyü yalnızca bir kere görüntülemek için Tekrar Yok'u seçin.

    • Görüntüyü yatay ve dikey yinelemek veya döşemek için Tekrarla seçeneğini belirleyin.

    • Görüntüyü yatay olarak döşemek için Tekrarla-x seçeneğini belirleyin.

    • Görüntüyü dikey olarak döşemek için Tekrarla-y seçeneğini belirleyin.

  6. Tarayıcı üzerindeki sayfa hizalamasını sol, orta veya sağ olarak seçin.

  7. Tamam'ı tıklatın ve ardından Kaydet'i tıklatın.

XHTML'yi dışa aktarma

XHTML HTML (web sayfalarını biçimlendirme ve görüntülemenin şu anki standardı) ve XML'nin (Genişletilebilir İşaretleme Dili) kombinasyonudur. XHTML geriye doğru uyumludur—yani şu anki web tarayıcılarının çoğu bunu görüntüleyebilir—ve XML içeriğini görüntüleyen, PDA'lar, cep telefonları ve diğer elle kullanılan cihazlar gibi tüm cihazlar tarafından okunabilir.

Fireworks XHTML'yi de içe aktarabilir. Bkz. HTML dosyalarından Fireworks PNG dosyaları oluşturma.

XHTML hakkında daha fazla bilgi için www.w3.org adresindeki World Wide Web Consortium (W3C) XHTML belirtimini ziyaret edin.

  1. Dosya > HTML Ayarı'nı seçin, Genel sekmesindeki HTML Stili açılır menüsünden bir XHTML stili seçin ve ardından Tamam'ı tıklatın.

  2. HTML'yi dışa aktarma veya kopyalama için kullanılabilir olan yöntemlerden herhangi birini kullanarak belgenizi dışa aktarın. Bkz. HTML'yi dışa aktarma.

    Not:

    Fireworks, XHTML'ye dışa aktarırken UTF-8 kodlaması kullanır.

Dosyaları UTF-8 kodlamalı ve kodlamasız dışa aktarma

UTF-8, Evrensel Karakter Kümesi Dönüştürme Formatı-8, web tarayıcıların farklı karakter kümelerini (örneğin, Çince metin ve İngilizce metin) aynı HTML sayfasında görüntülemesine olanak sağlayan bir metin kodlaması yöntemidir. UTF-8 kodlaması varsayılan olarak açıktır.

Fireworks UTF-8 kodlaması kullanan belgeleri de içe aktarabilir. Bkz. HTML dosyalarından Fireworks PNG dosyaları oluşturma.

Belgeleri UTF-8 kodlamasız dışa aktarma

  1. Dosya > HTML Ayarı'nı seçin.

  2. Belgeye Özgü sekmesinde, UTF-8 kodlaması kutusunu temizleyin ve Tamam'ı tıklatın.

  3. HTML'yi dışa aktarma veya kopyalama için kullanılabilir olan yöntemlerden herhangi birini kullanarak belgeyi dışa aktarın.

HTML dışa aktarma seçeneklerini ayarlama

HTML Ayarı iletişim kutusu, Fireworks uygulamasının HTML'yi nasıl dışa aktaracağını tanımlamanıza olanak sağlar. Belgeye özgü sekmesinde yapılan değişiklikler yalnızca geçerli dosyayı etkiler. Genel ve Tablo ayarları global tercihlerdir ve tüm yeni belgeleri etkiler.

  1. Aşağıdakilerden birini yapın:

    • Dosya > HTML Ayarı'nı seçin.

    • Dışa Aktar iletişim kutusunda Seçenekler düğmesini tıklatın.

  2. Genel sekmesinde, tercih ettiğiniz seçenekleri belirleyin.

    HTML Stili

    Dışa aktarılan HTML için stili seçin.

    Generic HTML tüm HTML düzenleyicilerde çalışır. Fakat, belgenizde davranışlar veya diğer etkileşimli içerik bulunuyorsa, listede görüntülenmesi durumunda özel düzenleyicinizi seçin.

    XHTML standardını kullanarak belgenizi dışa aktarmak için, açılır menüden uygun XHTML stilini seçin.

    Uzantı

    Açılır menüden bir dosya uzantısı seçin veya yeni bir uzantı girin.

    HTML Yorumlarını Dahil Et

    HTML içinde nereye kopyalanıp yapıştırılacağıyla ilgili yorumları dahil etmek için seçin. Belgeniz düğmeler, davranışlar veya rollover görüntüleri gibi etkileşimli öğeler içeriyorsa önerilir.

    Küçük Harfli Dosya Adı

    HTML dosyası ve ilgili görüntü dosyalarının adlarını dışa aktarırken küçük harfli yapmak için seçin.

    Not: Uzantılar açılır menüsünde bir büyük harf uzantısı seçilmişse bu seçenek HTML dosyası uzantılarını küçük harfle değiştirmez.

    Açılır Menüler için CSS Kullanma

    Açılır menü kodlarınız için JavaScript yerine CSS kullanmayı seçin. Bağları kod içinde güncelledikçe, menüleri dizine almak için Dreamweaver kullanabilirsiniz.

    Harici Bir Dosyaya CSS Yazma

    HTML dosyasıyla aynı konuma dışa aktarılan harici bir .css dosyasına yazılı CSS kodunu seçin. HTML dosyasının adıyla, .css dosyasının adı eşleşir (dosya uzantısı hariç). Bu seçeneği belirlemek ayrıca, mm_css_menu.js olarak adlandırılan bir dosyayı HTML dosyasıyla aynı konuma dışa aktarır.

    Not: Bu seçenek yalnızca Açılır Menüler İçin CSS Kullan seçeneğini belirlediğinizde kullanılabilir.

    Dosya Oluşturucu (Mac OS)

    Açılır menüden ilgili bir uygulama seçin. Dışa aktarılan HTML dosyasını sabit diskinizde çift tıklattığınızda, dosya seçili uygulamada otomatik olarak açılır.

  3. Tablo sekmesinde, HTML tablolarınız için ayarları seçin. Bilgi için, bkz. HTML tablolarının nasıl dışa aktarılacağını tanımlama.

  4. Belgeye Özgü sekmesinde, aşağıdaki seçeneklerden birini seçin:

    Dilim Dosyası Adları

    Dilimleri otomatik adlandırmak için açılır menüde bir formül seçin. Varsayılan ayarları seçebilir ya da kendi seçeneklerinizi belirleyebilirsiniz.

    Not: İlk üç menüden herhangi biri için Yok seçeneği belirlenmişse Fireworks uygulamasının dışa aktardığı dilim dosyaları birbirinin üzerine yazılır; bu da, tek bir grafiğin dışa aktarılmasına ve her hücrede bu grafiği görüntüleyen bir tablo oluşturulmasına neden olur.

    Varsayılan Alt Etiket

    Görüntüler web'den indirilirken, tüm görüntülerin ve indirilemeyen tüm görüntülerin yerine görüntülenecek metni girin. Bazı tarayıcılarda bu metin ayrıca, işaretçi görüntünün üzerinden geçtiğinde bir araç ipucu olarak görüntülenebilir. Bu ayrıca, görme engelli web kullanıcıları için bir yardımdır.

    Birden Çok Gezinme Çubuğu HTML Sayfasını Dışa Aktar (Çerçeve Kümeleri Olmadan Kullanmak İçin)

    Birçok sayfayı birbirine bağlayan bir gezinme çubuğunu dışa aktarırken seçin. Fireworks, gezinme çubuğundaki her düğme için ilave sayfaları dışa aktarır.

    Dilim Nesneleri Olmayan Alanları Dahil Et

    Tuvalin dilimlerle kaplı olmayan alanlarını dahil etmek için seçin.

    UTF-8 Kodlaması

    Varsayılan olarak açıktır. Dışa aktarılan belgenizin karakterlerinin çoklu karakter kümelerinden görüntülenmesine olanak sağlar. Bu seçeneği kapatmak için onay kutusunun seçimini kaldırın.

  5. Bu ayarları global varsayılan ayarlarınız olarak kaydetmek için Varsayılanları Ayarla'yı tıklatın..

Adobe PDF dosyalarını dışa aktarma

Bir Fireworks tasarımını yazdırmanız veya gözden geçirmek için dağıtmak istediğinizde, Adobe PDF'ye dışa aktarın. Gözden geçirenler yorum ekleyebilir ve Adobe Reader® veya Acrobat® uygulamasında başkalarının yaptığı yorumları yanıtlayabilir. PDF gözden geçirmelerini oluşturma hakkında bilgi için, Acrobat Yardım'a bakın.

Dışa aktarılan PDF dosyaları tüm sayfaları ve köprüleri korur, gözden geçirenlere web'deymiş gibi gezinme olanağı verir. Ancak, HTML prototiplerinin tersine, Adobe PDF gözden geçirenlerin sizin tasarımlarınızı düzenlemesini veya kopyalamasını engelleyen güvenlik ayarları sağlar.

  1. Dosya > Dışa Aktar'ı seçin.

  2. Dışa Aktar açılır menüsünden Adobe PDF'yi seçin.

  3. Dışa aktarılacak sayfaları seçin ve PDF'yi Adobe Reader veya Acrobat'da otomatik olarak açmak için Dışa Aktarma sonrası PDF'yi görüntüle'yi seçin.

  4. PDF'yi özelleştirmek için Seçenekler'i tıklatın ve ardından aşağıdaki ayarları belirleyin:

    Uyumluluk

    Dışa aktarılan dosyaları hangi Adobe PDF uygulamalarının açabileceğini belirler.

    Sıkıştırma

    Dosya boyutunu küçülterek görüntü sıkıştırma türünü belirler. Genelde, JPEG ve JPEG2000 sıkıştırma, renkten renge aşamalı geçişlere sahip olan, fotoğraf gibi görüntülerde daha iyi sonuçlar verir. Düz renklerin geniş alanlarıyla oluşturulan resimler için ZIP daha iyi bir seçimdir.

    Kalite

    JPEG veya JPEG2000 sıkıştırmaları için görüntü kalite ayarlarını sunar. Yüksek kaliteyi seçmek, görüntü kalitesi iyi geniş bir dosya boyutu üretir.

    Gri Tonlamaya Dönüştür

    Dosya boyutunu küçülterek tüm görüntüleri gri tonlamaya dönüştürür.

    Metin Seçimini Etkinleştir

    Gözden geçirenlerin dışa aktarılan dosyadaki metinleri kopyalamasına izin verir. Dosya boyutunu önemli miktarda küçültmek için bu seçeneğin seçimini kaldırın.

    Taşma Payı Değeri

    Her sayfa üzerindeki görüntüyü çevreleyen boş kenarlığın piksel genişliğini belirler. Örneğin 20 değeri, her görüntüyü 20 piksel kenarlığıyla çevreler.

    Belgeyi Açmak için Parola Kullan

    Dışa aktarılan dosyayı açmak için açma parolasının girilmesini gerektirir.

    Görevleri Sınırlamak için Parola Kullan

    Aşağıdaki seçilen işlevlerin yapılabilmesi için güvenli parolanın girilmesini gerektirir. Yazdırma, Düzenleme, Kopyalama ve Yorum Ekleme.

  5. Seçenekler iletişim kutusunu kapatmak için Tamam'ı tıklatın.

  6. Bir dosya adı ve ardından konum belirleyip Kaydet'i tıklatın.

    Not:

    Fireworks belgenizdeki sayfaların tuvali saydamsa, herhangi bir saydamlık uygulanmış nesneleri PDF'ye dışa aktardığınızda saydam özelliklerini kaybeder. Bunu önlemek için, PDF'ye dışa aktarmadan önce tuvali saydam olmayan bir arka plana ayarlayın.

Video

Fireworks'ü kullanarak PDF veya HTML dosyaları gibi müşteri provaları oluşturma (00:05:32)

Müşteri onayı veya ekip incelemesi için bir PDF veya HTML belgesi oluşturmak üzere Fireworks Dışa Aktarma menüsünü kullanmayı öğrenin.

Tom Green

Dışa aktarılan PDF dosyalarını Adobe Acrobat veya Adobe Reader'da görüntülediğinizde, aşağıdaki ayarları kullanın:

  1. Adobe Acrobat veya Adobe Reader'da Düzenle > Tercihler'i seçin.

  2. Soldaki panelden Sayfa Görüntüleme'yi seçin.

  3. Özel Çözünürlük ayarını inç başına 72 piksel olarak ayarlayın.

  4. Yakınlaştırma değerini %100 olarak ayarlayın.

FXG dosyalarını dışa aktarma

FXG formatı Flash Catalyst, Fireworks, Illustrator ve Photoshop tarafından desteklenen bir dosya formatıdır. FXG dışa aktarma kullanarak vektör ve bit eşlem görüntüsü dışa aktardığınızda, <filename.assets> adlı ayrı bir klasör oluşturulur. Klasörde dosyayla ilişkili bit eşlem görüntüleri bulunur.

İlişkili dosyalardan herhangi birisi bu klasörden silinirse içe aktarma işlemi başarısız olur.

Not:

Öğeler, filtreler, Karışım Modları, degradeler ve maskeler için FXG'de karşılık gelen bir eşlem etiketi olmadığından bitmap grafikleri olarak dışa aktarılırlar.

  1. Dosya > Dışa Aktar'ı seçin ve dosyaları kaydetmek istediğiniz konuma gidin.

  2. FXG dosyası için bir ad girin.

  3. Dışa Aktar iletişim kutusunda, Dışa Aktar menüsünden FXG ve Görüntüler'i seçin.

  4. Kaydet'i tıklatın.

Not:

Fireworks'te tuvalin ötesine uzanan nesneler, dışa aktarılan FXG dosyası Flash Catalyst uygulamasında açıldığında tümüyle görüntülenir.

Bu çalışma Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License kapsamında lisanslanmıştır  Creative Commons şartları, Twitter™ ve Facebook sitelerinde paylaşılanları kapsamaz.

Yasal Uyarılar   |   Çevrimiçi Gizlilik İlkesi