Aprenda a depurar archivos HTML, CSS y JS en Adobe Dreamweaver. Vea los errores y advertencias en el panel Salida y diríjase a las líneas erróneas de código con un solo clic.

Tanto si es un programador principiante como si ya es un experto, siempre cabe la posibilidad de que los errores se infiltren en el código que está escribiendo sin que se dé cuenta o debido a la falta de conocimiento. Cuando la página web o una parte de la misma no tiene la apariencia que usted tenía en mente, se ve obligado a depurar el código para encontrar los posibles errores de sintaxis o lógica. Sin embargo, la depuración estrictamente hablando puede ser un proceso lento y extenuante, especialmente en situaciones donde hay implementaciones complejas.

Dreamweaver simplifica la depuración de código para los errores más comunes con la ayuda de linting. Linting es el proceso de análisis de código que se hace para indicar rápidamente los posibles errores o un uso extraño del código. En Dreamweaver, linting puede detectar y marcar errores en la sintaxis de HTML, errores de análisis de CSS o advertencias en los archivos de JavaScript.

Los errores y advertencias que se encuentren, se mostrarán en un panel independiente (panel Salida) acoplado en la parte inferior del espacio de trabajo. Cada línea del panel le permite ir directamente a la porción de código donde se ha producido el error, facilitando así la búsqueda y solución de errores en el código. Además, los números de línea en los que haya código erróneo se resaltan en rojo si hay errores y en amarillo si son advertencias. De este modo, al pasar el ratón sobre el número de línea resaltado, se muestra una vista previa del error o la advertencia.

Dreamweaver le permite depurar archivos HTML (.htm and .html), CSS y JavaScript. Realice los siguientes pasos para depurar el código en estos archivos:

  1. Especifique las reglas de linting editando los archivos de configuración de HTML, CSS y JS. Para obtener más información, consulte Especificar normas de linting.

  2. Activación o desactivación de linting. Puede depurar los archivos al cargarlos o guardarlos. Puede activar o desactivar linting con la opción Preferencias > Linting. Para obtener más información, consulte Habilitar linting y configurar las preferencias.

Los errores y advertencias que se encuentren en los archivos se mostrarán en el panel Salida. Para obtener más información, consulte Resultados de linting y el panel Salida.

Habilitar linting y especificar las reglas de linting

Haga clic en Edición > Preferencias (Windows) o Dreamweaver > Preferencias (Mac). Seleccione Linting en la lista Categoría y, a continuación, elija Activar linting.

Especificar reglas de linting

Puede depurar archivos HTML, CSS y JS editando las reglas de linting en los archivos de configuración correspondientes:

  • HTML: DW.htmlhintrc
  • CSS: DW.csslintrc
  • JS: .eslintrc

Para acceder a estos archivos y editarlos, siga los pasos siguientes:

  1. Haga clic en Edición > Preferencias (Windows) o Dreamweaver > Preferencias (Mac).

  2. Seleccione Linting en la lista Categoría.

  3. En la sección Editar conjunto de reglas, haga clic en el tipo de archivo en cuestión y luego haga clic en Editar y aplicar cambios.

    El archivo de configuración correspondiente se abrirá en Dreamweaver.

  4. Edite o añada las reglas de linting a los archivos de configuración. Si desea obtener más información sobre las reglas de linting, consulte la siguiente documentación:

    En estos archivos de configuración, también puede establecer el tipo de errores o advertencias que mostrarán. 

Nota:

El archivo de configuración de reglas de linting para las versiones anteriores de Dreamweaver CC 19.0 es JS: DW.jshintrc. Puede dirigirse a http://jshint.com/docs/options/

Depuración de ECMAScript 6

Dreamweaver es compatible con la sintaxis ECMAScript 6. Dreamweaver también es compatible con la depuración de código ECMAScript, con ESLint como depurador predeterminado de JavaScript.

  1. Seleccione Sitio > Administrar sitios.

    Diálogo Administrar sitios
    Elija el sitio web en el cuadro de diálogo Administrar sitios
  2. Seleccione Configuración avanzada en el panel izquierdo del cuadro de diálogo de configuración de sitios. 

  3. Seleccione JS Lint en Configuración avanzada en el panel izquierdo. 

    Puede hacer clic en la lista desplegable que se encuentra junto a la opción Versión de ECMAScript y elegir 3, 5 o 6. Dreamweaver utiliza el conjunto de reglas predeterminadas para la versión que seleccione.

    Selección de la versión de ECMAScript
    Selección de la versión de ECMAScript
  4. Si desea personalizar el conjunto de reglas, puede seleccionar Archivo de configuración en la lista desplegable y hacer clic en Editar archivo de configuración.  

    Edición del archivo de configuración de JS Lint
    Edición del archivo de configuración de JS Lint

    Los cambios que realice en la configuración del sitio se guardarán y se creará un nuevo archivo .eslintrc.js en la raíz del sitio si no está presente.

    El archivo .eslintrc.js se abrirá en la carpeta raíz del sitio para su edición. Si desea obtener más información, consulte la sección Reglas ESLint

    Archivo de configuración .eslintrc.js
    Archivo de configuración .eslintrc.js

    Nota:

    • La configuración de la versión de ECMAScript definida en el cuadro de diálogo Configuración del sitio tiene prioridad sobre el archivo .eslintrc.js utilizado en la carpeta raíz del sitio.
    • Si no utiliza el archivo .eslintrc.js en la configuración del sitio, Dreamweaver busca el archivo .eslintrc.js en todas las ubicaciones que llevan al directorio raíz.

    Puede obtener más información sobre la secuencia y la jerarquía de los archivos de configuración en el sitio de ESLint.

Resultados de linting y el panel Salida

Los resultados de linting, tanto los errores como las advertencias, se muestran en el panel Salida. El panel Salida está disponible en modo acoplado en la parte inferior de todos los espacios de trabajo predeterminados. Si el panel Salida está cerrado, puede abrirlo de las siguientes formas:

  • Haciendo clic en el icono de estado de linting situado en la barra de estado de la ventana de documento
  • Utilizando el método abreviado del teclado Mayús + F6
  • Seleccionando Ventana > Resultados > Salida
Panel Salida e icono de linting
Panel Salida e icono de linting

El icono de linting que aparece en la barra de estado indica los resultados obtenidos:

  • Rojo: el documento actual contiene errores y advertencias
  • Amarillo: el documento actual solo contiene advertencias
  • Verde: el documento actual no contiene errores

Nota:

Si el icono se muestra rojo o amarillo (aunque no verde), puede utilizar el icono de linting de la barra de estado para abrir o cerrar el panel Salida.

Las líneas que contengan errores o advertencias se resaltarán en rojo y amarillo, respectivamente. Puede hacer doble clic en los mensajes del panel Salida para desplazarse directamente a las líneas donde se ha producido el error. En la Vista de código, también puede colocar el ratón sobre los números de línea que contengan errores para obtener una vista previa del error o advertencia que se haya producido en esa línea.

El panel Salida puede mostrar 50 mensajes a la vez, con los errores enumerados antes que las advertencias. A medida que vaya corrigiendo los errores, la lista del panel se desplaza para mostrar el siguiente error.

Esta obra está autorizada con arreglo a la licencia de Reconocimiento-NoComercial-CompartirIgual 3.0 Unported de Creative Commons.  Los términos de Creative Commons no cubren las publicaciones en Twitter™ y Facebook.

Avisos legales   |   Política de privacidad en línea