What's covered

Welcome to Adobe Fireworks CS3. This document contains late-breaking product information, updates, and troubleshooting tips not

covered in the Fireworks CS3 documentation.

Minimum system requirements

Fireworks CS3 system requirements are located here.

Install your software

  1. Before you install, close all applications currently running on your system;including other Adobe applications, Microsoft Office

    applications, and browser windows.
  2. Do one of the following:
    • Windows:
      • Insert the DVD in your drive, and follow the on-screen instructions. If the installer does not launch automatically, navigate to the Adobe CS3 folder found at the root level on your disk and double-click Setup.exe to start the installation process.
      • If you downloaded the software from the web, open the folder, navigate to the Adobe CS3 folder, double-click Setup.exe, and then follow the on-screen instructions.
    • Mac:
      • Insert the DVD in your drive, and follow the on-screen instructions. If the installer does not launch automatically, navigate to the application folder found at the root level on your disk and double-click Setup Mac OS to start the installation process.
      • If you downloaded the software from the web, open the folder, navigate to the application folder, double-click Setup, and then follow the on-screen instructions.

Note: In order to install additional components or reinstall your software after your original installation, you will need

access to the original installer (DVD or the download from the web). Before you begin additional installations or

reinstallations, please make sure the installer is in the same drive or location it was during the original installation.

Uninstall your software

  1. Before you uninstall, close all applications currently running on your systemincluding other Adobe applications, Microsoft Office applications, and browser windows.
  2. Do one of the following:
    • In Windows, open the Windows Control Panel and double-click Add or Remove Programs. Select the product that you want to uninstall, click Change/Remove, and then follow the on-screen instructions.
    • IMPORTANT: Mac OS has new uninstall functionality. DO NOT drag applications to the trash to uninstall them. To

      safely uninstall on Mac OS X, double-click the product installer in Applications/Utilities/Adobe Installers. Authenticate as

      an administrator, then select Remove Components and follow the on-screen instructions.

Purchase from a trial

Choose Activate from the Help menu and follow the on-screen instructions.



Note: If you decide to purchase a different product than you installed for the trial, you may need to uninstall and reinstall the software. For example, if you download and install a trial of Adobe Creative Suite 3 Design Premium, but you decide to purchase only Adobe Illustrator, you will need to uninstall the trial version of the Suite before installing the standalone version of Illustrator that you purchased. For more detailed information, visit www.adobe.com/go/tbinfo



Volume licensing customers cannot purchase from a trial directly. After evaluating a Creative Suite 3 product, you must uninstall the trial and install the product using the volume licensing media and serial number. Refer to the Uninstall your software section of this document for instructions. Please contact your reseller or authorized Adobe licensing center to place an order for a volume license. To find a reseller in your area, go to http://partners.adobe.com/resellerfinder/na/reseller.jsp.

Electronic licensing

Adobe software may include electronic license (e-license) management technology to ensure compliance with the Product License Agreement. When present, this technology prompts you to verify the license of your product within 30 days after you start it for the first time. If prompted, verification is mandatory.



The on-screen prompt may ask you to activate the software. This verification process does not collect, transmit, or use any personally identifiable information. To learn more, visit the Adobe web site at http://www.adobe.com/activation.



Activate software:

  1. If the Activation dialog box is not already open, choose Help > Activate.
  2. Follow the on-screen instructions.

    Note: If you want to install the product on a different computer, you must first deactivate the software on your computer. To deactivate, choose Help > Deactivate.

Registration information

When you install your software, be sure to register to get up-to-date product information, training, newsletters, and invitations to Adobe events and seminars.

Font installation

The installation disk contains miniml fonts in the Goodies/Fonts folder. To use the fonts, copy them to your system. For installation information, see http://www.adobe.com/go/learn_fontinstall_en miniml fonts are vector-based pixel font emulations that are designed to remain aliased in Fireworks and Flash. Aliased fonts improve legibility because of their high contrast. You must use the fonts according to specific guidelines to maintain their crispness. See the miniml Read Me.html in the Goodies/Fonts folder for more information about using these fonts.

Known issues

Installation

  • If the special character % is used in the installation path, Fireworks can be installed but will not launch on Windows [Bug

    #225604].

Limitations When Running on Microsoft Vista

  • Running Fireworks as Compatible with Win XP SP2 on Vista may cause the user interface to behave unexpectedly. For

    example, the options button and the drop down menu box in the Export dialog may get overlapped on each other, while resizing

    the dialog box.
  • If the Windows Appearance setting in Vista is set to Windows Aero for the color scheme, there may be performance issues when

    using the Fireworks Brush tool. To solve this problem, change the setting to Windows Vista Basic". [Bug #211789].
  • It is recommended that you log in as Administrator in order to modify or view exported .MXML files in Adobe Flex on Vista.
  • Its been noticed that some times Fireworks may not run in Trial Mode on Vista, currently we dont know of any good

    workarounds for this issue.

Differences from Fireworks 8

  • Alien skin plug-ins do not ship with Fireworks CS3. If an existing Fireworks 8 file that makes use of an Alien Skin plug-in is

    opened in Fireworks CS3, a missing filter message is displayed. To resolve this issue, the Fireworks 8 filter can be copied into

    Fireworks CS3 Plugins folder.
  • In Fireworks CS3, linear gradients are applied in the vertical direction, whereas in Fireworks 8 they were applied in a horizontal

    direction.

Illustrator Import Limitations

  • Radial gradients and patterns in Illustrator files are shifted during import [Bug #226061].
  • When importing an Illustrator file with a linked Fireworks PNG file the objects in the source PNG are imported rather than the

    raster image objects [Bug #216084].
  • Strokes applied for text content are lost when an Illustrator file is opened [Bug #222065].
  • When importing a linked Illustrator file, an error is displayed if the linked file is missing [Bug #222735].
  • The Illustrator Opacity mask is not translating properly when importing into Fireworks [Bug #224555].
  • Fireworks CS3 files do not correctly maintain gradients when copied or exported to Illustrator [Bug #225334].
  • Any text that is created using Illustrator 8 or previous versions does not appear as text when imported or opened in Fireworks CS3. Instead, it displays as a path and a grouped object.
  • Copy and Paste behavior is the same as in Fireworks 8, but Import AI has enhanced capabilities.

Multiple Pages Limitations

  • Linking Pages Pages with different canvas sizes are resized to match the master page when they are linked to a master page. In

    the process, objects may be incorrectly stretched. This problem can be avoided by resizing the page to the size of the master page

    before linking [Bug #225875].
  • This issue is fixed in the 9.0.1 patch available through the Adobe Updater application.

  • Import Functionality When importing a document that contains a master page and has missing fonts, a missing font dialog is

    displayed. If you choose a replacement font, master page layers from the imported document appear permanently locked. To unlock them, switch to a different frame or page and then switch back. (If there is no additional page in the file then the user will

    have to create and delete to get the expected results of importing).



MXML Export Script Limitations

  • During MXML export, images can be overwritten if they use the default Fireworks image names. If separate images are desired,

    you must name the objects differently in the Layers panel. Once they are named, the images are exported using those user defined

    names and hence none of the images are overwritten [Bug #221109].
  • On Macintosh systems, the images that are created and saved while exporting MXML are always saved into the last remembered

    path only. Even if we try to save them in a new location, only the output mxml file gets created in the new specified path but all

    the images are still exported into the old path only [Bug #224743].
  • If the Current page only, check box is unchecked while exporting pages, using the MXML and Images option, the exported

    output file will be named as CurrentPageName.mxml [Bug #214866].
  • An extra image of the entire document is created by Fireworks automatically during MXML export. When you export a document

    with slices from Fireworks, the HTML style code determines whether the slice images are exporting by using a return value of

    "ok". If "ok" is not used, images are not exported. The problem with this in terms of the MXML export is that when you export

    MXML, Fireworks automatically exports the entire page as an image - an extra image that doesn't relate to the export at all. This is

    just an extra image file created by the script which is not used anywhere [Bug #211758].

XMP Limitations

  • XMP data embedded within a Fireworks .PNG file is sometimes not read by other applications such as Adobe Photoshop, Bridge

    or Illustrator. Editing the data within these applications in such cases could lead to the loss of metadata [Bug #223430].

Hierarchical Layers Limitations

  • If a Fireworks .PNG file with more than five sub layers is exported as a .PSD file, all objects placed beyond the fifth level will be

    placed in the fifth sub layer. This is due to the fact that Photoshop supports only five levels of hierarchy.
  • The <SHIFT> + method of selecting objects spanning multiple layers does not always work as expected. Some objects may remain

    unselected. Use the <CTRL> + method to select and deselect individual objects [Bug #214080].

Photoshop Layer Effects Limitations

  • Fireworks preserves all Photoshop Layer Effects on import, but does not allow you to edit Gradients, Patterns, Blend Modes and

    Contours. In addition, the order of Photoshop Live Effects cannot be changed in Fireworks; unlike other Fireworks Live Effects.

Rich Symbols Limitations

  • A multi-level folder hierarchy is not supported for saving rich symbols under the <user_preferences>/Configuration/Common

    Library/ folder. For instance, if you have a folder hierarchy such as <user_preferences>/Configuration/Common Library/Custom

    Symbols/MyFolder, only those symbols directly under the Custom Symbols folder are listed in the Common Library panel; the

    symbols under MyFolder are not listed.

9-Slice Scaling Limitations

  • When a bitmap symbol with 9-slice scaling is edited and the symbol is modified in edited state then bitmap scaling done before

    this modification is not preserved [Bug #225233].
  • Nested symbols do not work with 9-slice scaling [Bug #212697].
  • If a symbol with text is scaled using 9-slice scaling and then rotated, the text loses its relative position [Bug #225801].

Bridge Integration Limitations

  • The Bridge commands Convert grayscale", Convert to Sepia and Invert selection color in the Tools menu do not work on

    Macintosh systems [Bug #226501].
  • If Fireworks is installed in a non default location then the Tools -> Fireworks submenu items in Bridge will not work In order for Bridge -> Tools -> Fireworks submenus to function, user needs to edit the following values in /Library/Application Support/

    Startup Scripts CS3/ Adobe Fireworks/fireworks.jsx:
    • Mac OS:
      • Set fireworks.baseVolumeName to the current volume name -

        default is Macintosh%20HD_1
      • Set fireworks.InstallPathURIPrefix to current install location in URI format - default is file:///Macintosh%

        20HD_1/Applications
    • Windows:
      • Set fireworks.InstallPathURIPrefix to current install location in URI format - default is file:///c|/Program%

        20Files/Abobe
  • When you open a file in Fireworks on a Macintosh system and click Browse from the File menu, the Bridge application does not

    correctly highlight the selected file [Bug #226502].

Customer care

Customer Service

Adobe Customer Service provides assistance with product information, sales, registration, and other non-technical issues. To find out how to contact Adobe Customer Service, please visit Adobe.coms main page for your region or country and click on Contact.

Support Plan Options and Technical Resources

If you require technical assistance for your product, including information on free and paid support options and troubleshooting resources, more information is available at http://www.adobe.com/go/support/. For outside of North America http://www.adobe.com/go/intlsupport/. Free troubleshooting resources include Adobes support knowledgebase, Adobe user-to-user forums, and more.

Online Support Resources

Other resources

Documentation

Online Resources

Legal notices

Mobile device images are provided with this software for simulation purposes only and may not implement Adobe technology when made commercially available by the applicable device manufacturer.



Updated Information/Additional Third Party Code Information available at www.adobe.com/go/thirdparty.

This work is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License  Twitter™ and Facebook posts are not covered under the terms of Creative Commons.

Legal Notices   |   Online Privacy Policy