Adobe Flash Player에 대한 보안 업데이트

릴리스 날짜: 2014년 13월 5일

취약점 식별자: APSB14-14

우선순위: 아래 표 참조

CVE 번호: CVE-2014-0510, CVE-2014-0516, CVE-2014-0517, CVE-2014-0518, CVE-2014-0519, CVE-2014-0520

플랫폼: 모든 플랫폼

요약

Adobe는 Windows 및 Macintosh용 Adobe Flash Player 13.0.0.206 및 이전 버전과 Linux용 Adobe Flash Player 11.2.202.356 및 이전 버전을 위한 보안 업데이트를 발표했습니다. 이러한 업데이트는 잠재적으로 침입자가 해당 시스템을 제어할 수 있는 취약점을 해결합니다. 따라서 제품을 아래와 같이 최신 버전으로 업데이트하는 것이 좋습니다.

  • Windows 및 Macintosh용의 Adobe Flash Player 13.0.0.206 및 이전 버전을 사용하는 사용자는 Adobe Flash Player 13.0.0.214으로 업데이트해야 합니다.
  • Linux용 Adobe Flash Player 11.2.202.356 및 이전 버전을 사용하는 사용자는 Adobe Flash Player 11.2.202.359으로 업데이트해야 합니다.
  • Google Chrome에 설치된 Adobe Flash Player 13.0.0.206는 최신 Google Chrome 버전으로 자동 업데이트되며, 여기에는 Windows, Macintosh 및 Linux용 Adobe Flash Player 13.0.0.214 버전이 포함됩니다.
  • Internet Explorer 10과 함께 설치되는 Adobe Flash Player 13.0.0.206는 Windows 8.0용 Adobe Flash Player 13.0.0.214이 포함되어 있는 최신 Internet Explorer 10 버전으로 자동 업데이트됩니다.
  • Internet Explorer 11과 함께 설치되는 Adobe Flash Player 13.0.0.206는 Windows 8.1용 Adobe Flash Player 13.0.0.214이 포함되어 있는 최신 Internet Explorer 11 버전으로 자동 업데이트됩니다.
  • Adobe AIR 13.0.0.83 SDK 및 이전 버전 사용자는 Adobe AIR 13.0.0.111 SDK로 업데이트해야 합니다.
  • Adobe AIR 13.0.0.83 SDK & Compiler 및 이전 버전 사용자는 Adobe AIR 13.0.0.111 SDK & Compiler로 업데이트해야 합니다.

해당되는 소프트웨어 버전

  • Windows 및 Macintosh용 Adobe Flash Player 13.0.0.206 이상 버전
  • Linux용 Adobe Flash Player 11.2.202.356 이상 버전
  • Adobe AIR 13.0.0.83 SDK 및 이전 버전
  • Adobe AIR 13.0.0.83 SDK & Compiler 및 이전 버전

시스템에 설치되어 있는 Adobe Flash Player 버전을 확인하려면 Flash Player 정보 페이지에 액세스하거나 Flash Player에서 실행되는 컨텐츠를 마우스 오른쪽 단추로 클릭한 다음 메뉴에서 "Adobe(또는 Macromedia) Flash Player 정보"를 선택하십시오. 여러 개의 브라우저를 사용하고 있는 경우 각 브라우저별로 Flash Player 버전 번호를 확인한 후 설치하십시오.

시스템에 설치되어 있는 Adobe AIR 버전을 확인하려면 Adobe AIR 기술 문서에 있는 지침을 따르십시오.

해결 방법

아래 지침에 따라 소프트웨어를 업데이트하는 것이 좋습니다.

  • Windows 및 Macintosh용 Adobe Flash Player 13.0.0.206 이하 버전 사용자는 Adobe Flash Player 다운로드 센터에서 최신 버전을 다운로드하거나 제품 내에서 업데이트 여부를 묻는 메시지가 나타날 때 업데이트 메커니즘을 통해 최신 버전인 13.0.0.214 버전으로 업데이트하는 것이 좋습니다.
  • Linux용 Adobe Flash Player 11.2.202.356 및 이전 버전 사용자는 Adobe Flash Player 다운로드 센터에서 Adobe Flash Player 11.2.202.359를 다운로드하여 업데이트하는 것이 좋습니다.
  • Google Chrome에 설치된 Adobe Flash Player 13.0.0.206는 최신 Google Chrome 버전으로 자동 업데이트되며, 여기에는 Windows, Macintosh 및 Linux용 Adobe Flash Player 13.0.0.214 버전이 포함됩니다.
  • Internet Explorer 10과 함께 설치되는 Adobe Flash Player 13.0.0.206는 Windows 8.0용 Adobe Flash Player 13.0.0.214이 포함되어 있는 최신 Internet Explorer 10 버전으로 자동 업데이트됩니다.
  • Internet Explorer 11과 함께 설치되는 Adobe Flash Player 13.0.0.206는 Windows 8.1용 Adobe Flash Player 13.0.0.214이 포함되어 있는 최신 Internet Explorer 11 버전으로 자동 업데이트됩니다.
  • Adobe AIR 13.0.0.83 SDK를 사용하는 사용자는 Adobe AIR 13.0.0.111 SDK로 업데이트해야 합니다.
  • Adobe AIR 13.0.0.83 SDK & Compiler 및 이전 버전 사용자는 Adobe AIR 13.0.0.111 SDK & Compiler로 업데이트해야 합니다.

* 2014년 5월 13일부터 연장 지원 버전으로 Mac 및 Windows용 Adobe Flash Player 13이 11.7 버전을 대체합니다. 보안 업데이트를 계속 받으려면 13. 버전으로 업그레이드하는 것이 좋습니다.  자세한 내용은 이 블로그 게시물을 참조하십시오. http://blogs.adobe.com/flashplayer/2014/03/upcoming-changes-to-flash-players-extended-support-release.html

우선 순위 및 심각도 등급

Adobe는 이러한 업데이트를 다음과 같은 우선 순위 등급으로 분류하고 사용자가 최신 버전으로 업데이트할 것을 권장합니다.

제품 업데이트된 버전 플랫폼 우선 순위 등급
Linux용 13.0.0.214
Windows 및 Macintosh
1
  13.0.0.214 Windows 8.0용 Internet Explorer 10 1
  13.0.0.214
Windows 8.1용 Internet Explorer 11 1
  13.0.0.214
Windows, Macintosh 및 Linux용 Chrome 1
  11.2.202.359 Linux 3
Adobe AIR SDK 및 Compiler 13.0.0.111 Windows 및 Macintosh 3
Adobe AIR SDK 13.0.0.111 Windows 및 Macintosh 3

이 업데이트는 소프트웨어에 있는 치명적인 취약점을 해결합니다.

자세한 내용

Adobe는 Windows 및 Macintosh용 Adobe Flash Player 13.0.0.206 및 이전 버전과 Linux용 Adobe Flash Player 11.2.202.356 및 이전 버전을 위한 보안 업데이트를 발표했습니다. 이러한 업데이트는 잠재적으로 침입자가 해당 시스템을 제어할 수 있는 취약점을 해결합니다. 따라서 제품을 아래와 같이 최신 버전으로 업데이트하는 것이 좋습니다.

  • Windows 및 Macintosh용의 Adobe Flash Player 13.0.0.206 및 이전 버전을 사용하는 사용자는 Adobe Flash Player 13.0.0.214으로 업데이트해야 합니다
  • Linux용 Adobe Flash Player 11.2.202.356 및 이전 버전을 사용하는 사용자는 Adobe Flash Player 11.2.202.359으로 업데이트해야 합니다.
  • Google Chrome에 설치된 Adobe Flash Player 13.0.0.206는 최신 Google Chrome 버전으로 자동 업데이트되며, 여기에는 Windows, Macintosh 및 Linux용 Adobe Flash Player 13.0.0.214 버전이 포함됩니다.
  • Internet Explorer 10과 함께 설치되는 Adobe Flash Player 13.0.0.206는 Windows 8.0용 Adobe Flash Player 13.0.0.214이 포함되어 있는 최신 Internet Explorer 10 버전으로 자동 업데이트됩니다.
  • Internet Explorer 11과 함께 설치되는 Adobe Flash Player 13.0.0.206는 Windows 8.1용 Adobe Flash Player 13.0.0.214이 포함되어 있는 최신 Internet Explorer 11 버전으로 자동 업데이트됩니다.
  • Adobe AIR 13.0.0.83 SDK 및 이전 버전 사용자는 Adobe AIR 13.0.0.111 SDK로 업데이트해야 합니다.
  • Adobe AIR 13.0.0.83 SDK & Compiler 및 이전 버전 사용자는 Adobe AIR 13.0.0.111 SDK & Compiler로 업데이트해야 합니다.

이 업데이트는 임의의 코드를 실행할 수 있는 use-after-free 취약점을 해결합니다(CVE-2014-0510).

이러한 업데이트는 동일출처정책을 우회하는 데 사용될 수 있는 취약점을 해결합니다(CVE-2014-0516).

이 업데이트는 보안 우회 취약성(CVE-2014-0517, CVE-2014-0518, CVE-2014-0519, CVE-2014-0520)을 해결합니다.

해당되는 소프트웨어     권장 플레이어 업데이트 사용 가능성
Windows 및 Macintosh용 Flash Player 13.0.0.206 이상 버전   13.0.0.214 Flash Player 다운로드 센터
Flash Player 13.0.0.206 및 이전 버전(네트워크 배포)   13.0.0.214
Flash Player 라이선스
Linux용 Flash Player 11.2.202.356 및 이전 버전   11.2.202.359 Flash Player 다운로드 센터
Chrome용 Flash Player 13.0.0.206 및 이전 버전(Windows, Macintosh 및 Linux)   13.0.0.214
Google Chrome 릴리스
Windows 8.0용 Internet Explorer 10의 Flash Player 13.0.0.206 및 이전 버전   13.0.0.214
Microsoft Security Advisory
Windows 8.1용 Internet Explorer 11의 Flash Player 13.0.0.206 및 이전 버전   13.0.0.214
Microsoft Security Advisory
AIR 13.0.0.83 SDK & Compiler   13.0.0.111 AIR SDK 다운로드
AIR 13.0.0.83 SDK   13.0.0.111 AIR SDK 다운로드

감사의 말

Adobe는 관련 문제를 보고하여 Adobe 고객의 보안 유지에 도움을 주신 다음 분들께 감사의 말씀을 전합니다.

  • HP의 Zero Day Initiative를 담당하는 Keen Team 및 Team 509(CVE-2014-0510)
  • Masato Kinugawa님(CVE-2014-0516)
  • Contextis의 James Forshaw(CVE-2014-0517, CVE-2014-0518, CVE-2014-0519, CVE-2014-0520)