Adobe Flash Player에 대한 보안 업데이트

릴리스 날짜: 2016년 12월 13일

최종 업데이트일: 2016년 12월 14일

취약점 식별자: APSB16-39

우선순위: 아래 표 참조

CVE 번호: CVE-2016-7867, CVE-2016-7868, CVE-2016-7869, CVE-2016-7870, CVE-2016-7871, CVE-2016-7872, CVE-2016-7873, CVE-2016-7874, CVE-2016-7875, CVE-2016-7876, CVE-2016-7877, CVE-2016-7878, CVE-2016-7879, CVE-2016-7880, CVE-2016-7881, CVE-2016-7890, CVE-2016-7892

플랫폼: Windows, Macintosh, Linux 및 Chrome OS

요약

Adobe는 Windows, Macintosh, Linux 및 Chrome OS용 Adobe Flash Player에 대한 보안 업데이트를 발표했습니다.  이러한 업데이트는 공격자가 해당 시스템을 제어하도록 허용할 가능성이 있는 치명적인 취약점을 해결합니다.  

Adobe에서는 CVE-2016-7892가 Windows에서 Internet Explorer(32비트)를 실행하는 사용자에 대한 제한적, 선별적인 공격에 악용되고 있다는 보고를 인지하고 있습니다.

해당하는 버전

제품 해당하는 버전 플랫폼
Adobe Flash Player 데스크탑 런타임 23.0.0.207 및 이전 버전
Windows 및 Macintosh
Google Chrome용 Adobe Flash Player 23.0.0.207 및 이전 버전 Windows, Macintosh, Linux 및 Chrome OS
Microsoft Edge 및 Internet Explorer 11용 Adobe Flash Player 23.0.0.207 및 이전 버전 Windows 10 및 8.1
Linux용 Adobe Flash Player 11.2.202.644 및 이전 버전 Linux
  • 시스템에 설치되어 있는 Adobe Flash Player 버전을 확인하려면 Flash Player 정보 페이지에 액세스하거나 Flash Player에서 실행되는 컨텐츠를 마우스 오른쪽 단추로 클릭한 다음 메뉴에서 "Adobe(또는 Macromedia) Flash Player 정보"를 선택하십시오. 여러 개의 브라우저를 사용하고 있는 경우 각 브라우저별로 Flash Player 버전 번호를 확인한 후 설치하십시오.

해결 방법

Adobe는 이러한 업데이트를 다음과 같은 우선 순위 등급으로 분류하고 사용자가 최신 버전으로 업데이트할 것을 권장합니다.
제품 업데이트된 버전 플랫폼 우선 순위 등급 사용 가능성
Adobe Flash Player 데스크탑 런타임
24.0.0.186 Windows 및 Macintosh
1 Flash Player 다운로드 센터
Flash Player 배포
Google Chrome용 Adobe Flash Player 24.0.0.186 Windows, Macintosh, Linux 및 Chrome OS 1 Google Chrome 릴리스
Microsoft Edge 및 Internet Explorer 11용 Adobe Flash Player 24.0.0.186 Windows 10 및 8.1 1 Microsoft Security Advisory
Linux용 Adobe Flash Player 24.0.0.186 Linux 3 Flash Player 다운로드 센터
  • Windows 및 Macintosh용 Adobe Flash Player 데스크탑 런타임 사용자는 제품 [1] 안의 업데이트 메커니즘을 사용하거나 Adobe Flash Player 다운로드 센터를 방문하여 Adobe Flash Player 24.0.0.186로 업데이트하는 것이 좋습니다.
  • Linux용 Adobe Flash Player 사용자는 Adobe Flash Player 다운로드 센터를 방문하여 Adobe Flash Player 24.0.0.186 버전으로 업데이트하는 것이 좋습니다.
  • Google Chrome과 함께 설치되는 Adobe Flash Player는 Windows, Macintosh, Linux 및 Chrome OS용 Adobe 24.0.0.186가 포함되는 최신 Google Chrome 버전으로 자동 업데이트됩니다.
  • Windows 10 및 Windows 8.1용 Microsoft Edge 및 Internet Explorer 11과 함께 설치되는 Adobe Flash Player는 Adobe Flash Player 24.0.0.186가 포함되는 최신 버전으로 자동 업데이트됩니다. 
  • Flash Player 설치에 대한 도움이 필요하면 Flash Player 도움말 페이지를 방문하시기 바랍니다.

[1] 'Adobe가 업데이트를 설치하도록 허용' 옵션을 선택한 Windows용 Flash Player 11.2.x 이상 사용자와 Macintosh용 Flash Player 11.3.x 이상 사용자는 업데이트를 자동으로 수신하게 됩니다. 'Adobe가 업데이트를 설치하도록 허용' 옵션을 사용하지 않는 사용자는 제품 내에서 업데이트할지 여부를 묻는 메시지가 나타날 때 이 업데이트 메커니즘을 통해 업데이트를 설치할 수 있습니다.

취약성 세부 정보

  • 이 업데이트는 코드를 실행할 수 있는 무료 기간 종료 후 사용 취약점을 해결합니다(CVE-2016-7872, CVE-2016-7877, CVE-2016-7878, CVE-2016-7879, CVE-2016-7880, CVE-2016-7881, CVE-2016-7892). 
  • 이 업데이트는 코드를 실행할 수 있는 버퍼 오버플로우 취약점을 해결합니다(CVE-2016-7867, CVE-2016-7868, CVE-2016-7869, CVE-2016-7870). 
  • 이 업데이트는 코드를 실행할 수 있는 메모리 손상 취약점을 해결합니다(CVE-2016-7871, CVE-2016-7873, CVE-2016-7874, CVE-2016-7875, CVE-2016-7876). 
  • 이 업데이트는 보안 우회 취약점을 해결합니다(CVE-2016-7890).

감사의 말

Adobe는 관련 문제를 보고하여 Adobe 고객의 보안 유지에 도움을 주신 다음 분들께 감사의 말씀을 전합니다.
  • Microsoft Vulnerability Research의 Nicolas Joly(CVE-2016-7877)
  • Trend Micro의 Zero Day Initiative와 협력하는 Pangu LAB의 Wen Guanxing(CVE-2016-7867, CVE-2016-7868)
  • Tencent PC Manager의 willJ(CVE-2016-7876)
  • Trend Micro의 Zero Day Initiative와 협력하는 Saber(CVE-2016-7872)
  • Chromium 취약성 보상 프로그램에서 작동하는 Tencent Zhanlu Lab의 JieZeng(CVE-2016-7881)
  • Trend Micro의 Zero Day Initiative와 협력하는 kurusu nono(CVE-2016-7879)
  • Palo Alto Networks의 Tao Yan(@Ga1ois)(CVE-2016-7873, CVE-2016-7874)
  • Trend Micro의 Zero Day Initiative와 협력하는 CloverSec Labs의 bo13oy(-7875, CVE-2016-, CVE-2016-7878)
  • Trend Micro의 Zero Day Initiative와 협력하는 CloverSec Labs의 bo13oy 및 Palo Alto Networks의 Tao Yan(@Ga1ois)(CVE-2016-7871)
  • 360 Vulcan 팀의 Yuki Chen(CVE-2016-7880)
  • Trend Micro의 Zero Day Initiative와 협력하는 WanderingGlitch - Trend Micro Zero Day Initiative(CVE-2016-7869, CVE-2016-7870)
  • Paulos Yibelo(CVE-2016-7890)
  • JPCERT/CC(CVE-2016-7892)에서 일하는 익명 연구원

수정

2016년 12월 14일: CVE-2016-7892의 크레딧을 수정했습니다.